Vous êtes sur la page 1sur 26

Chapitre 1 :

Planification pour
des rseaux complexes

Chapitre 2 :
Mettre en uvre une
solution base sur EIGRP

CCNP ROUTE 642-902


2. Introduction au EIGRP & le Neighbor Relationship
ESSALIFI Mohamed Faial
mf.essalifi@gmail.com
http://www.mcug.ma

Chapitre 3 :
Mettre en uvre une
solution base sur OSPF
Chapitre 4 :
Optimisation du routage
Chapitre 5 :
Mettre en uvre le
contrle de chemin
Chapitre 6 :
Mettre en uvre une
solution base sur BGP
Chapitre 7 :
Connexion distance
Chapitre 8 :
Introduction au IPv6

dition 1.0
Dcembre 2010

1. Introduction
La configuration du protocole Enhanced Interior Gateway Routing
Protocol (EIGRP) ncessite quelque commande
router eigrp 1
network net-id

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

EIGRP propose plusieurs option et fonctionnalit cls,


surtout dans une moyenne ou grande entreprise !!!!!

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

2. Rvision sur le cours CCNA - EIGRP


Les commandes de base:
router eigrp asn
network net-id wildcard-mask subcommands

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

Les rgles:
Les routeurs voisin doivent avoir le mme ASN (router eigrp asn).
Si il n y a aucun wildcard-mask, le masque par dfaut sera classful
Si il n y a aucun wildcard-mask, le EIGRP sera activ sur tout les sous rseau
attach a cette interface
Si lEIGRP est configur avec un wildcard-mask, la comparaison se fera avec la
mme logique quune ACL

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

3. Atelier CCNA EIGRP sur GNS3


GNS3 - IOS - VPCs

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

c2691-adventerprisek9-mz.124-25c
ESSALIFI Mohamed Faial
dition 1.0 / Dcembre 2010

4. Atelier CCNA EIGRP sur GNS3

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

Casa
router eigrp 1
network 10.0.0.0
network 172.16.0.0

Rabat
router eigrp 1
network 10.10.0.0 0.0.31.255
network 10.10.12.1 0.0.0.0

!!!!!! Discussion !!!!!!

Settat
router eigrp 1
network 10.10.0.0 0.0.255.255

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

7. Le Workflow du protocole EIGRP


Etape 1. Neighbor discovery
Etape 2. Topology Exchange
Etape 3. Choosing Routes

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

8. Etape 1 : Neighbor discovery

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

5. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 1 : EIGRP est activ dans quelles interfaces ?


Router#show ip eigrp interfaces

Router#show ip protocols

Etape 2 : Est-ce que la relation voisin Neighbor relationship est conforme


au design?

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

Router#show ip eigrp neighbors

Etape 3 : La topologie dEIGRP inclus au moins un chemin pour chaque rseau?


Router#show ip eigrp topology

Etape 4 : Les IP ROUTE?


Router#show ip route

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 1 : EIGRP est activ dans quelles interfaces ?


Router#show ip eigrp interfaces

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 1 : EIGRP est activ dans quelles interfaces ?


Router#show ip protocols

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 1 : EIGRP est activ dans quelles interfaces ?


Router#show ip protocols

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 1 : EIGRP est activ dans quelles interfaces ?


Router#show ip protocols

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification


Etape 2 : Est-ce que la relation voisin Neighbor relationship est conforme
au design?
Router#show ip eigrp neighbors

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 3 : La topologie dEIGRP inclus au moins un chemin pour chaque rseau?


Router#show ip eigrp topology

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 3 : La topologie dEIGRP inclus au moins un chemin pour chaque rseau?


Router#show ip eigrp topology

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 3 : La topologie dEIGRP inclus au moins un chemin pour chaque rseau?


Router#show ip eigrp topology

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 4 : Les IP ROUTE?


Router#show ip route

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 4 : Les IP ROUTE?


Router#show ip route

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

6. Atelier CCNA EIGRP sur GNS3 : Vrification

CCNP ROUTE
642-902

Etape 4 : Les IP ROUTE?


Router#show ip route

Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

8. Etape 1 & 2. Neighbor discovery & Topology Exchange

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

Les messages de mise jour sont envoy sur ladresse multicast 224.0.0.10

Les messages de mise jour sont envoys via le protocole Reliable Transport
Protocol (RTP).

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

10. Etape 3. Choosing Routes

EIGRP associe cinq diffrentes mtriques chaque route :


Dlai
Bande passante
Fiabilit
Charge
MTU (non utilis dans le calcul de l'algorithme)

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

Par dfaut, K1 et K3 sont 1, et le reste zro, rduisant la formule :

http://fr.wikipedia.org/wiki/Enhanced_Interior_Gateway_Routing_Protocol
ESSALIFI Mohamed Faial
dition 1.0 / Dcembre 2010

11. Manipulation des HELLO et TIMERS

CCNP ROUTE
642-902

Dans une configuration par dfaut le Hello est 5, et le Hold est 10


Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

ESSALIFI Mohamed Faial


dition 1.0 / Dcembre 2010

11. Manipulation des HELLO et TIMERS

CCNP ROUTE
642-902

Exemple de configuration pour le routeur WAN1


Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

WAN1
interface FastEthernet0/0
ip address 10.10.10.10 255.255.255.0
duplex auto
speed auto
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000

router eigrp 1
network 10.10.10.0 0.0.0.255
network 193.10.24.0 0.0.0.3
network 193.10.25.0

interface Serial0/0.1 multipoint


ip address 193.10.25.1 255.255.255.0
frame-relay interface-dlci 101
frame-relay interface-dlci 102

interface Fastethernet0/0
ip hello-interval eigrp 1 2
ip hold-time eigrp 1 6

interface Serial0/0.2 point-to-point


ip address 193.10.24.1 255.255.255.252
frame-relay interface-dlci 103

R1#show ip eigrp interfaces detail fa0/1


R2#show ip eigrp neighbors
ESSALIFI Mohamed Faial
dition 1.0 / Dcembre 2010

12. Utilisation du Passif interface

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

R2#show ip eigrp interfaces


R2#show ip protocols
ESSALIFI Mohamed Faial
dition 1.0 / Dcembre 2010

13. Contrle des associations par authentification

CCNP ROUTE
642-902
Chapitre 2 :
Mettre en uvre
une solution base
sur EIGRP

key chain carkeys


key 1
key-string fstsettat1
key 2
key-string fstsettat2

interface FastEthernet0/0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 carkeys

R1#show key chain


R1#debug eigrp packet
ESSALIFI Mohamed Faial
dition 1.0 / Dcembre 2010

Chapitre 1 :
La planification pour des rseaux complexes
Chapitre 2 :
Mettre en uvre une solution base sur EIGRP
Chapitre 3 :
Mettre en uvre une solution base sur OSPF

CCNP ROUTE 642-902

Chapitre 4 :
Optimisation du routage

Merci

Chapitre 5 :
Mettre en uvre le contrle de chemin
Chapitre 6 :
Mettre en uvre une solution base sur BGP
Chapitre 7 :
Connexion distance

Chapitre 8 :
Introduction au IPv6

ESSALIFI Mohamed Faial


mf.essalifi@gmail.com
http://www.mcug.ma

dition 1.0

Dcembre 2010

Vous aimerez peut-être aussi