Vous êtes sur la page 1sur 6

Nome: Hudson Alencar Saldanha de Oliveira

RA: 8492237379

SUMRIO
1- Introduo:
2- Relatrio 1 Soluo para o Problema 1:
2.1 Desenvolvimento:
2.2 Identificao dasvariveis:
2.3 Tabelas verdades:
2.4 Representao do problema:
2.4.1 Representao por Pseudo-Linguagem(VisualG):

1 - INTRODUO:

No contexto abaixo, sero apresentadas as sugestes para resoluo dos


problemas sugeridos na atividade de ATPS (Atividades Prticas
Supervisionadas), da disciplina Cosntruo de Algoritmos.
Sendo que o primeiro trata-se do calculo dos nmeros impares existentes entre
um determinado range de nmero, o segundo sobre a mdia de distancia, o
terceiro sobre quantidade de leds necessrios para a construo de um
nmero e o quarto sobre a distribuio e retirada das pessoas em um
determinado jogo (Problema de Josephus).
Estas propostas apresentadas no so a nica possibilidade de soluo, porem
foi a que o grupo concluiu como a mais adequada para a soluo dos
problemas.

2 Relatrio 1 Soluo para o Problema 1:

Foi apresentado um problema que consiste em efetuar a soma dos nmeros


inteiros impares existentes entre o range de dois outros nmeros informados.
Tambm ser informado dinamicamente um valor decasos de testes a serem
executados.

2.1 Desenvolvimento:
Foi criada uma entrada de dados para que o usurio informe a quantidade de
ocorrncias (casos) que ele pretende checar. Aps obter esta informao,
solicitado ao usurio que informa o valor do primeiro nmero inteiro do range, e
logo aps ser solicitado que informe o segundo nmero inteiro do range.
Neste momento e feita a conferencia de se o segundo nmero informado
maior que o primeiro nmero informado, caso no seja, ser solicitado ao
usurio que informe novamente o segundo nmero inteiro.
O processo para identificao dos nmeros impares, consista em efetuar a
diviso do numero por 2, e verificar se o resto igual a 1, caso seja este
numero impar. Conforme feita a identificao dos nmeros impares, os
mesmos so acumulados e apresentado o total no final do processamento.

2.2 Identificao das variveis:


Para esta soluo do problema apresentado sero utilizadas as variveis
abaixo apresentadas:
- ContOcor Controle de ocorrncias atendidas, recebera dados do tipo inteiro;
- Ocorrencia Quantidade ocorrncias solicitadas, recebera dados do tipo
inteiro;
- ContNumeros Controle de incremente dos nmeros, recebera dados do tipo
inteiro;
- PrimNumero Primeiro nmero do range a ser testado, recebera dados do
tipo inteiro;
- SegNumero Segundo nmero do range a ser testado, recebera dados do
tipo inteiro;

- SomaImpares Acumulador da soma dos nmeros impares existentes no


range solicitado, recebera dados do tipo inteiro.

2.3 Tabelas verdades:


Esto descritas as tabelas verdade dos pontos de questionamento.
Tabela verdade para solicitao de 2 (duas) ocorrncias:
ContOcor
Ocorrencia
ContOcor < Ocorrencia
Resultado
1
2
V
Continua processamento
2
2
V
Continua processamento
3
2
F
Encerra processamento
4
2
F
Encerra processamento
Tabela verdade para comparao do range solicitado:
SegNumero
PrimNumero
SegNumero

2.4 - Representao do problema


Problema 1
Definir um nmero inteiro N que ser o nmero de casos de teste. Cada caso
de teste uma linha que contm dois nmeros inteiros X e Y. O problema se
resume em imprimir a soma de todos os valores mpares entre os dois nmeros
inteiros, excetuando-os.
Entrada
A primeira linha de entrada um nmero inteiro N que o nmero de casos de
teste a serem solucionados. Cada caso de teste uma linha contendo dois
inteiros X e Y.
Sada
Imprimir a soma de todos os nmeros mpares entre X e Y.
Identificao das variveis
N, X, Y, A, B, soma: inteiro
N: nmero a ser inserido de casos teste
X e Y: dados de entrada a serem digitados pelo usurio
A: varivel auxiliar que conta o nmero de casos teste contento a funo
PARA
B: varivel auxiliar que recebe valor da conta e auxilia na expresso
matemtica utilizada para identificar os nmeros impares dentro de um
intervalo
Soma: varivel do tipo inteiro que auxilia na expresso matemtica utilizada
para a resoluo do problema.

2.4.1 - Estrutura do programa no visualg


// Funo: calcular a soma de nmeros impares de duas variveis distintas.
// Seo de Declaraes
var
N, X, Y, A, B, soma: inteiro
inicio
escreva ("Informe o nmero de casos de teste: ")
leia (N) // condio de numero de casos a serem testados.
para C de 1 ate N faca // contador de numero de casos
escreval ("informe o primeiro nmero: ")
leia (X)
escreval ("Informe o segundo nmero: ")
leia (Y)
soma <- 0
B <- X + 1
enquanto (B < Y) faca
se (B%2 <> 0) entao
soma <- soma + B
fimse
B <- B + 1
fimenquanto
escreval ("Caso de teste: ", A)

escreval ("Intervalo: ", X, " A ", Y, " soma dos mpares: ", soma)
fimpara
fimalgoritmo