Vous êtes sur la page 1sur 3

Universit Cadi Ayyad

Ecole Nationale des Sciences Appliques- Marrakech


Filire Rseaux et Tlcommunications

Travaux pratiques : MPLS

1/3

1- MAQUETTE DE TRAVAIL
Pour mettre en uvre les fonctionnalits de MPLS, nous avons cr un rseau de 6 routeurs de type C3725 tel qu'illustr sur la figure, afin davoir
des routeurs dextrmits limitant le nuage MPLS, des routeurs internes, ainsi que des routeurs nappartenant pas au nuage.

Schma 1 : Maquette du TP
- Raliser la maquette comme en dessus avec OSPF comme protocole de routage.
- Listez les tables de routage de chaque routeur.
- Vrifiez la connectivit IP entre les deux CPEs.

2- ROUTAGE IMPLICITE
Il n'y a pas de fonction d'tablissement de route avec MPLS dans le mode implicite. Le protocole utilis est LDP qui n'a qu'un rle d'information et
non pas de calcul. Pour cela, il s'appuie sur un protocole de routage de niveau 3 de type "link-state" comme IS-IS ou OSPF par exemple, afin de
dfinir le chemin saut par saut.

2.1- Configuration de CEF


La premire opration effectuer pour utiliser MPLS est dactiver le CEF (Cisco Express Forwarding) au niveau de chaque routeur du backbone
MPLS. En effet, CEF est une technique de commutation, qui doit tre active globalement, et cela par les commandes suivantes (x=2, 3, 4 et 5) :
Rx>en
Rx#conf t
Rx(config)#ip cef

Vrifiez lactivation CEF via la commande

Rx#sh ip cef

Cette commande affiche la table CEF du routeur contenant la correspondance entre les prfixes IP connus, leur interface de sortie ainsi que
ladresse du next-hop.

2.2- Configuration de LDP


La commande mpls ip en mode de configuration global permet dactiver la transmission hop-by-hop . Et pour permettre un routeur
d'tablir une adjacence LDP avec un voisin sur une interface donne, cette interface doit tre configure avec la mme commande comme exemple:
R2>en
R2#conf t
R2(config)#mpls ip
R2(config)#int f0/1
R2(config-if)#mpls ip

NB : On peut configurer LDP sur lensemble des interfaces -associes OSPF- dun routeur par une seule commande mpls ldp autoconfig area 0
. Cette commande est valable pour les LSR (R4/R3) par exemple :
R4(config)#router ospf 1
R4(config-router)#mpls ldp autoconfig area 0

Le fait quelle inclut toutes les interfaces, cette fonctionnalit nous garantit facilit et rapidit dactivation.

2/3

2.3- Vrification de la configuration MPLS


On peut vrifier la configuration avec les commandes suivantes :
Rx#sh
Rx#sh
Rx#sh
Rx#sh

mpls
mpls
mpls
mpls

interfaces
forwarding-table
ldp bindings
ldp neighbor

affiche les informations sur les interfaces configures pour MPLS


affiche le contenu de la table LFIB
affiche les labels affects un subnet par chaque LSR voisin
affiche tous les voisins LDP du routeur

prsent, le protocole MPLS est activ. La commutation de label fonctionne sur les routeurs internes MPLS, et la diffusion de paquets LDP peut
tre observe sur le lien entre R4 et R5 en utilisant Wireshark.

3- ROUTAGE EXPLICITE
Un des avantages trs important du protocole MPLS est de pouvoir conjuguer du routage automatique (implicite) recherchant les meilleures routes
et de le complter avec des paramtres manuels en imposant par exemple certaines liaisons (explicites). En effet, les routes optimales proposes
par les protocoles de routage sont des chemins idaux sans considrer les autres flux. Dit autrement, ce sont des configurations statiques ne tenant
pas compte de la ralit du trafic en cours.
Cette notion de dynamique peut tre introduite dans les tables de commutation de label par la cration de tunnels ddis. En effet, il est possible de
modifier certains acheminements provoquant des goulots d'tranglement dans le rseau pour soulager les liaisons les plus utilises. Pour cela, on
peut expliciter une liste d'intermdiaires constituant un tunnel. Cest ce quon appelle l'ingnierie de trafic (traffic engineering).

3.1- Activation globale de Traffic Engineering


Pour qu'un LSR puisse grer le TE, la commande mpls traffic-eng tunnels doit tre saisie en mode de configuration globale.
Rx(config)#mpls traffic-eng tunnels

3.2- Configuration de lIGP


Avec OSPF, la configuration du traffic engineering est la suivante :
Rx(config)#router ospf 1
Rx(config-router)# mpls traffic-eng router-id loopback0
Rx(config-router)# mpls traffic-eng area 0

3.3- Configuration des interfaces


Chaque interface MPLS devant permettre le Traffic Engineering doit tre configure de la manire comme dans lexemple suivant :
R2(config)#int f0/0
R2(config-if)#mpls traffic-eng tunnels

3.4- Cration dun tunnel explicite


On va choisir l'tablissement d'un tunnel entre R2 et R5. La configuration de R2 est la suivante :
R2(config)#int tunnel 1
R2(config-if)# ip unnumbered loopback0
R2(config-if)# tunnel destination 20.20.5.5
R2(config-if)# tunnel mode mpls traffic-eng
R2(config-if)# tunnel mode mpls traffic-eng autoroute announce
R2(config-if)# tunnel mode mpls traffic-eng path-option 1 exlplicit name way
R2(config-if)# exit
R2(config)# ip explicit-path name way1 enable
R2(cfg-ip-expl-path)# next-address 10.10.1.2
R2(cfg-ip-expl-path)# next-address 10.10.3.2

3.5- Vrification de la configuration de TE :


On peut vrifier la configuration avec les commandes suivantes :
R2# Show mpls traffic-engineering autoroute
R2# Show mpls traffic- engineering tunnels
Visualiser les paquets RSVP avec Wireshark

3/3