Vous êtes sur la page 1sur 273

Introduction

Prsentation de la
formation

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Prsentation du formateur

Cisco Systems

Certifications Cisco

CCNET

Pr-requis

Le plan de formation

Outils ncessaires

Cisco ICND1/CCENT (100-101)

alphorm.com

Prsentation du formateur

Nol Mac

alphorm@noelmace.com

Formateur consultant expert Unix et FOSS

Mes rfrences :
Mon profil Viadeo : http://fr.viadeo.com/fr/profile/noel.mace
Mon parcours : http://vizualize.me/noelmace
Mon site : http://noelmace.com

Contacts

Blogs

Base de connaissance

CV

Etc

Cisco ICND1/CCENT (100-101)

alphorm.com

Cisco Systems

Entreprise cre en 1984

premier routeur multi-protocoles

Entreprise leader de nombreux domaines

permettant dinterconnecter des rseaux utilisant des protocoles de


communication diffrents

rseaux et tlphonie principalement

Parts de march au 3me trimestre 2012 (selon le groupe Dell'Oro)

routeurs d'entreprise

77 %, soit 855 millions de dollars

routeurs d'accs

84 % soit 671 millions de dollars

Cisco ICND1/CCENT (100-101)

alphorm.com

Certifications Cisco

7 parcours de certifications

Routing & Switching

Design

Network Security

Service Provider

Storage Networking

Voice

Wireless

3 niveaux

Associate (CCNA)

Professionnal (CCNP, CCDP, CCSP, CCIP et CCVP)

Expert (CCIE / CCDE) + Design Architect (CCAr)

plus un niveau d'entre, commun tout les parcours : CCENT

Cisco ICND1/CCENT (100-101)

alphorm.com

CCENT

Cisco Certified Entry Networking Technician

connaissances basiques des rseaux informatique

ne couvre que trs peu les aspects techniques spcifiques Cisco

est donc conu par Cisco comme une tape intermdiaire vers les CCNA
et CCDA

Trs bonne certification pour les administrateurs rseaux dbutants

tout en offrant une premire approche des produits Cisco

ncessite cependant un approfondissement rapide (cf CCNA) pour tre


convenablement reconnu au niveau professionnel

Cisco ICND1/CCENT (100-101)

alphorm.com

Pr-requis

quasi nuls

il est cependant recommand d'avoir une bonne connaissance et


pratique de l'informatique

Cisco ICND1/CCENT (100-101)

alphorm.com

Le plan de formation

Fondamentaux

Switching

classes, sous-rseaux, VLSR

Routage IP

concepts, design, configuration, VLANs

Adressage IP

concepts fondamentaux, modles (TCP/IP et OSI), mdias et composants,


protocoles

concepts et protocoles, configuration, OSPF

Services IP

DHCP, ACLs, NAT

Cisco ICND1/CCENT (100-101)

alphorm.com

Outils ncessaires

Plusieurs solutions

crer son propre lab

location d'un rack distant

http://labswitch.blogspot.sg/

GNS3 : simulateur de rseaux trs complet, libre et gratuit

au minimum 3 routeurs et 3 switchs

ncessite IOS : payant et non libre

Cisco Packet Tracer

restreint aux seuls tudiants des acadmies officielles Cisco

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Introduction au cours CCENT

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Introduction

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Qu'est ce qu'un rseau

Dcoupage horizontal

chelle

Cisco ICND1/CCENT (100-101)

alphorm.com

Qu'est ce qu'un rseau

ensemble d'quipements (nuds)

relis entre eux

grce divers moyens matriels et logiciels

pour changer des donnes

Cisco ICND1/CCENT (100-101)

alphorm.com

Dcoupage horizontal

3 couches

infrastructures (supports)

cbles, ondes radios, fibre optique, etc ...

fonctions de contrle et de commande

protocoles dfinissant comment sont changes les donnes

voir modles TCP/IP et OSI

services

rendus l'utilisateur

Cisco ICND1/CCENT (100-101)

alphorm.com

chelle

Intranet

Extranet

rseau interne d'une entit organisationnelle

rseau externe d'une entit organisationnelle

Internet

rseau des rseaux

interconnects l'chelle de la plante

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Introduction aux rseaux

dfinition et prsentation

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Types de rseaux

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Taxinomie des rseaux

Classification par tendue

Personal Area Network

Local Area Network

Metropolitan Area Network

Wide Area Network

Exemple de rseau WAN :


RENATER

Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

Il y a plusieurs moyen de classification des rseaux

tendue (PAN, LAN, MAN, WAN)

relation fonctionnelle entre les composants

client/serveur

p2p

topologie

Cisco ICND1/CCENT (100-101)

alphorm.com

Classification par tendue

PAN : Personal Area Network

LAN : Local Area Network

MAN : Metropolitan Area Network

WAN : Wide Area Network

Cisco ICND1/CCENT (100-101)

alphorm.com

Personal Area Network

rseaux de trs petite dimension

gnralement sur 10m ou moins

pour une seule personne, ou un trs petit nombre de personne

et un trs petit nombre d'lments

ex : un laptop + un smartphone + un appareil photo connect

le plus souvent via des technologies sans-fil (Wireless PAN)

IrDA

Wireless USB

Bluetooth

Z-Wave

ZigBee

etc ..

peut tre ralis proximit directe du corps humain (Body Area Network)
Cisco ICND1/CCENT (100-101)

alphorm.com

Local Area Network

rseau de petite dimension

l'chelle d'un btiment ou d'une entreprise

sur une distance comprise environs entre 10m et 1km

gnralement quelques centaines d'utilisateur

de 10Mb/s (Ethernet) 1Gb/s (Gigabit Ethenet), voir 10Gb/s

Cisco ICND1/CCENT (100-101)

alphorm.com

Metropolitan Area Network

lchelle d'un campus ou d'une ville

priv ou public

entre 5 et 50 kms

gnralement par fibre optique

mais aussi

par des mdias identiques aux LAN

la paire tlphonique (ex : RNIS)

WiFi tendu

Wimax

etc ...

Cisco ICND1/CCENT (100-101)

alphorm.com

Wide Area Network

trs grande zone gographique

pays, continent, voir plante

Le plus grand et connu tant bien sr Internet

assure linterconnexion entre LANs ou MANs

type de connexions htrogne

en fonction du prix et de la distance

jusqu' 2Tb/s sur fibres optiques

diverses topologies

Cisco ICND1/CCENT (100-101)

alphorm.com

Exemple de rseau WAN : RENATER

rseaux des universits franaises


Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Les diffrents types de rseaux

en fonction de leur tendue

PAN

LAN

MAN

WAN

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Topologies

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Introduction

Rseaux en bus

Rseaux en anneaux (Token Ring, FDDI)

Rseaux en toile

Rseaux hirarchiques

Rseau maill

Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

Dfinie l'architecture d'un rseau

relation entre composants

via un ou plusieurs mdias

connections

hirarchie

Cisco ICND1/CCENT (100-101)

alphorm.com

Rseaux en bus

cblage unique

liaison passive par


drivation (lectrique ou
optique)

uni ou bi-directionnel

termin chaque
extrmit par des
"bouchons"

avantages :

simple

conomique

inconvnients

panne totale en cas de


dysfonctionnement du support

bande passante partage

taux de collision lev

limine les rflexions

quasi obsolte

Cisco ICND1/CCENT (100-101)

alphorm.com

Rseaux en anneaux (Token Ring, FDDI)

Chaque station joue le rle de station


intermdiaire

sur un connexion unique


"circulaire"

le plus souvent grce un


rpartiteur sur lequel sont
connects tout les lments

Sens unique

souvent compos de deux anneaux


sens oposs

Avantages

isolation de chaque nud

Inconvnients

cot

une dfaillance d'un


lment entrane une
panne de tout le systme

bande passante ddi

Cisco ICND1/CCENT (100-101)

alphorm.com

Rseaux en toile

nuds connects grce un


quipement dinterconnexion

concentrateur (hub) ou
commutateur (switch)

chaque nud tant connect


un quipement

topologie la plus courante

Inconvnients

Avantages

pas de dfaillance gnrale


en cas de
dysfonctionnement d'une
liaison

meilleur dbit

cot d'volution lev

Cisco ICND1/CCENT (100-101)

alphorm.com

Rseaux hirarchiques

ou rseaux en arbre

maximum 4 niveaux

souvent utilis pour les LAN

Avantages

trs faible cot

flexibilit

inconvnient

Cisco ICND1/CCENT (100-101)

rle centrale de llment


et des liaisons de niveau 1

alphorm.com

Rseau maill

rseau pair pair

avantages

sans aucune hirarchie centrale

chaque nud doit recevoir, envoyer et relayer


l'information

tolrance aux pannes et


aux interfrences

grand rseaux de distribution

dploiement rapide et
simplifi

grande volutivit de la
couverture

ex : Internet

optimis pour le sans-fil

voir Open-Mesh.org (B.A.T.M.A.N.),


Serval, ou encore commotion

Cisco ICND1/CCENT (100-101)

issue de la recherche
militaire

Inconvnient

nombre de liaisons

N (N -1) / 2

croissance rapide

alphorm.com

Ce qu'on a couvert

Les diffrentes topologies rseaux

bus

anneau

toile

arbre

maille

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Modle OSI

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Prsentation

Couches hautes

Couches basses

Mnmotechnique

Couches et protocoles

Types de donnes

Protocoles

Relations

Exemple : requte / rponse HTTPS

Cisco ICND1/CCENT (100-101)

alphorm.com

Prsentation

standard de communication en rseau de tout les systmes


informatiques

OSI : Open Systems Interconnection

Modle basique de rfrence pour l'interconnexion des systmes


ouverts (OSI) : ISO 7498

ncessaire face la diversit des solution sa cration (1984)

dfinie un modle universel pour les dveloppeurs et les fabricants

dtermine clairement le rle de chaque lment et protocole

par une dcomposition en couches

chaque couche servant de support la couche suprieure

Cisco ICND1/CCENT (100-101)

alphorm.com

Couches hautes
Dsignation

Description

7 Application

Point d'accs aux services rseau

6 Prsentation

codage et conversion des donnes applicatives

5 Session

4 Transport

Cisco ICND1/CCENT (100-101)

synchronisation des changes et des


transactions
ouverture / fermeture
connexion bout bout
connectivit et contrle de flux
notion de ports

alphorm.com

Couches basses
Dsignation

Description

3 Rseau

communication de proche en proche


travers des rseaux physiques diffrents
parcours des donnes
adressage logique

2 Liaison

communication entre deux htes relis


directement
adressage physique

1 Physique

transmission de signaux sur le support


physique
binaire

Cisco ICND1/CCENT (100-101)

alphorm.com

Mnmotechnique

Physique Liaison Rseau Transport Session Prsentation Application

PLSTSPA

Partout Le Roi Trouve Sa Place Assise

Pour Le Rseau Tout Se Passe Automatiquement

Et dans l'ordre inverse

APSTSLP

Aprs Plusieurs Semaines, Tout Respire La Paix

Mme si des phrases plus grossires sont plus simple retenir,


restons courtois

sinon, cf wikipedia

Cisco ICND1/CCENT (100-101)

alphorm.com

Couches et protocoles

Chaque couche fournie un ou plusieurs services

implment(s) par des protocoles

Chacun dfinissant une unit de donne

PDU (Protocol Data Unit)

compos de :

une entte

un champ de donnes

et enfin d'une en-queue pour la couche liaison

constituant l'lment transmettre

Cisco ICND1/CCENT (100-101)

alphorm.com

Types de donnes
Dsignation

Types de donnes

Application

Prsentation

Session

Transport

Rseau

paquets / datagrammes

Liaison

trames

Physique

Bits

Cisco ICND1/CCENT (100-101)

donnes

segments

alphorm.com

Protocoles
Dsignation

Protocoles

Application

FTP, SMTP, Telnet, HTTP, DNS, DHCP

Prsentation

Session

Transport

Rseau

ICMP, IP, ARP, service DHCP

Liaison

Ethernet, PPP, Wi-Fi

Physique

HTML, MIME, ASCII, SMB, AFP

Cisco ICND1/CCENT (100-101)

SSH, L2TP, PPTP, AppleTalk, NetBIOS


TCP / UDP

alphorm.com

Relations

chaque couche repose sur sa couche infrieure

afin de pouvoir, finalement, transmettre les informations sur le support physique


(couche 1)

Cela se fait grce l'encapsulation des PDUs

chaque N-PDU contenant les donnes du (N+1)-PDU,

l'metteur envoi donc des donnes applicatives

plus une entte et ventuellement une en-queue

auxquelles sont ajoutes les en-tte des protocoles de chaque couche

le receveur rutilisant ces enttes pour analyser les donnes et les lments du
protocole

afin de ds-encapsuler l'information et l'utiliser

Cisco ICND1/CCENT (100-101)

alphorm.com

Exemple : requte / rponse HTTPS

Aprs avoir tabli :

la session SSL (Handshake)

et la connexion TCP (3-way handshake)

Dsignation

Protocoles

Requte

Rponse

7 Application

HTTP

GET

OK

6 Prsentation

MIME

text/html

5 Session

SSL

session ok

session ok

4 Transport

TCP

established
dport : 443

established
sport : 443

3 Rseau

IPv4

s : 82.226.40.107
d : 82.165.81.167

s : 82.165.81.167
d : 82.226.40.107

2 Liaison

Ethernet

s : 8C-89-A5-08-D9-C2
d : 7D-82-4B-DD-32-42

s : 7D-82-4B-DD-32-42
d : 8C-89-A5-08-D9-C2

1 Physique

01000111101111...

001111000111...

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Prsentation du modle OSI

7 couches

Application

Prsentation

Session

Transport

Rseau

Liaison

Physique

leur rle

leurs relations

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Modle TCP/IP

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Prsentation

Comparaison avec le modle OSI

Types de donnes

Ce qu'on a couvert

Cisco ICND1/CCENT (100-101)

alphorm.com

Prsentation

suite de protocoles : TCP + IP

adopt le 1er Janvier 1983 par Arpanet

fusionne avec le rseau de la National Science Foundation en 1984,


donnant naissance Internet

le web, lui, n'tant apparu qu'en 1990

norme officielle d'internet depuis 1989 (RFC 1122)

Cisco ICND1/CCENT (100-101)

alphorm.com

Comparaison avec le modle OSI

Plus pragmatique

seulement 4 couches

les protocoles internet ne se soucient pas de la liaison ni de la


connexion physique
ni de la sparation de protocoles applicatifs

certains pouvant couvrir plusieurs couches

Applications + TCP/UDP + IP + Rseaux

Adopt sur la grande majorit des LAN, MAN et WAN aujourd'hui

du fait du rle central d'Internet

Cisco ICND1/CCENT (100-101)

alphorm.com

Types de donnes
Modle OSI
7

Modle TCP/IP

Application
Donnes

Prsentation

Session

Transport

Rseau

Message
TCP / UDP
Paquet

Application

Transport

Internet

Accs au rseau

IPv4 / IPv6

2
1

Liaison

Trame

Physique

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Prsentation du modle TCP/IP

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Composants

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Rpteur

Concentrateur (Hub)

Pont (Bridge)

Commutateur (Switch)

Routeur

Cisco ICND1/CCENT (100-101)

alphorm.com

Rpteur

combinaison de rcepteur et d'metteur

permettant de retransmettre les signaux reus

permet d'augmenter la distance entre deux nuds

ex : porte WiFi (distance maximum AP - client)

Fonctionnement binaire

aucune interprtation du signal reu

couche 1 (physique) du modle OSI

Cisco ICND1/CCENT (100-101)

alphorm.com

Concentrateur (Hub)

amplifie et multiplie le signal


vers plusieurs PCs

petit concentrateur 10BaseT

forme de rpteur / multiprise

Traitement binaire

redistribution du signal sur


tout les ports

couche 1 du modle OSI

concentrateur 100BaseT

physique

Cisco ICND1/CCENT (100-101)

alphorm.com

Pont (Bridge)

assure la connexion entre


rseaux distincts

de technologie semblables
ou diffrentes

plan d'adressage identique

Filtre les collisions et vite de les retransmettre

Couche 2 (Liaison) du modle OSI

Cisco ICND1/CCENT (100-101)

alphorm.com

Commutateur (Switch)

"hub intelligent" et "pont multi-port"

aiguille les trames reus vers le port / segment adquat

relativement l'adresse du destinataire

forte diminution (voir totale suppression) des collisions


niveau 2 (Liaison) du
modle OSI

Cisco ICND1/CCENT (100-101)

alphorm.com

Routeur

niveau 3 (rseau) du modle OSI


fait transiter des paquets d'une interface
une autre

selon un ensemble de rgles

permet d'interconnecter plusieurs


rseaux

le plus souvent via le protocole IP


(adresse)

routeur

logiciel de routage sur serveur


applicatif

plans d'adressage diffrents

dtermine le chemin emprunt par un


paquet

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Tour d'horizon des diffrents composants d'un rseau

rpteur

concentrateur ou hub

pont

commutateur ou switch

routeur

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Mdias

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Cbles lectriques

Blindage

Perturbations

Coaxiaux

Protections contre les perturbations

Fibre optique

Paires torsades

Catgories obsoltes

Sans fil
CPL

Catgories en voie de
remplacement
Catgories actuelles

Cisco ICND1/CCENT (100-101)

alphorm.com

Cbles lectriques

ligne de transmission

lments conducteurs mtalliques (cuivre le plus souvent)

permettant d'acheminer un signal

d'un metteur vers un rcepteur

Cisco ICND1/CCENT (100-101)

alphorm.com

Perturbations

Sur une ligne de transmission

les perturbations sont d'origine lectromagntiques

d'origine intrieure ou extrieure

ajoute une tension au signal transmettre

le transforme

Ex : signal audio : "friture"

Dans le cadre d'un signal numrique

changement d'tat de certains bits

fausse totalement le message

Cisco ICND1/CCENT (100-101)

alphorm.com

Protections contre les perturbations

antiparasitage des sources de parasites

loigner la ligne de transmission de toute source potentielle

obligation lgale pour les constructeurs

micro-onde, moteurs lectriques, etc

chemins de cbles mtalliques

cage de Faraday

blindage des cbles

transmission diffrentielle

Cisco ICND1/CCENT (100-101)

alphorm.com

Paires torsades

enroulement en hlice de chaque paire de fils conducteur

diminue la diaphonie

en maintenant constante la distance entre les fils

Chaque paire tant caractris par un nombre moyen de torsade par mettre

perturbation du signal d'un fil par le chant magntique du second

augmenter le nombre de torsades permettant de diminuer les risques de


diaphonie

Un cble rseau pouvant tre compos de plusieurs paires torsades, il est important
de varier leurs nombre moyen de torsades par mettre

pour viter toute diaphonie entre les paires

Cisco ICND1/CCENT (100-101)

alphorm.com

Catgories obsoltes

Catgorie 1

tlphonie

abandonn au profit de la catgorie 5

Catgorie 2

anciennement utilis principalement pour du Token Ring

de faible dbit : 4Mbits/s

bande passante : 2Mhz

Cisco ICND1/CCENT (100-101)

alphorm.com

Catgories en voie de remplacement

Catgorie 3

4 paires torsades

bande passante : 16Mhz

utilis principalement en tlphonie

progressivement remplac par la catgorie 5

Catgorie 4

non dcrit dans la norme actuelle

4 paires de cuivre

bande passante : 20MHz

rseaux Token Ring (16Mbps) / 10BASE-T

Cisco ICND1/CCENT (100-101)

alphorm.com

Catgories actuelles

Catgorie 5

bande passante : 100Mhz

tlphonie ou rseaux

remplac par la cat5e /


classe D

Fast Ethernet (100Mbits/s)

e pour enhanced : 125Mhz

Catgorie 6 / Classe E

250Mhz et plus

Catgorie 7 / Classe F

600Mhz

rseaux et tlvision

Cat6a : 500Mhz

10GBASE-T sur 90m

cat7a : 1Ghz

Cisco ICND1/CCENT (100-101)

VHF ou UHF
jusqu' 10Gbits/s

alphorm.com

Blindage

limite les interfrences

pour chaque paire (autour de chacune)

et/ou l'ensemble du cble

en jouant le rle de cage de Faraday

plac alors entre la gaine et les paires

acheminement des parasites lectriques vers la masse

types de blindage

F = foil shielding : blindage par feuillard

feuille d'aluminium

cot modr

S = braided shielding : blindage par tresse

en cuivre tam

protection maximale pour un cot lev

Cisco ICND1/CCENT (100-101)

alphorm.com

Blindage
Dnomination
courante

Dnomination
officielle

Blindage du
cble

Blindage des
paires

Usage

UTP

U/UTP

cot minimal

STP

U/FTP

feuillard

FTP

F/UTP

feuillard

le plus courant

FFTP

F/FTP

feuillard

feuillard

satellite, etc
...

SFTP

SF/UTP

feuillard et
tresse

max pour cat5e

SSTP

S/FTP

tresse

feuillard

uniquement
partir de cat6

TP = twisted pair : paire torsade

U = unshielded : non blind

Cisco ICND1/CCENT (100-101)

alphorm.com

Coaxiaux

un seul conducteur

simple ou multi-brin

cuivre

dit "me" du cable

isol de son blindage

par un matriaux dilectrique

PV ou TEFLON

dbit important sur de longues distances

faible cot

ex : rseau cbl urbain

fragile, instable et vulnrable aux


interfrences et aux coutes

Cisco ICND1/CCENT (100-101)

A : gaine extrieure

isolant plastique ou PVC

B : blindage de cuivre tress

C : dilectrique (isolant)

D : conducteur

alphorm.com

Fibre optique

trs haut dbit

grce des rayons optiques conduits par le "cur" du cable

entour d'une gaine et d'une protection

uni-directionnel

insensible aux champs lectromagntiques

2 types

monomode : 1Gb/s / km

multimode : 100Gb/s / km

Cisco ICND1/CCENT (100-101)

alphorm.com

Fibre Optique

Avantages

Inconvnients

Lgret

installation complexe

Immunit au bruit

cot lev

Faible attnuation

Trs haut dbit

Quasi impossibilit d'coute

des connections entre rpartiteurs

des connections trs haut dbit

principalement utilis pour

ne convient pas aux LAN

Cisco ICND1/CCENT (100-101)

alphorm.com

Sans fil (ondes lectromagntiques)

Ondes radios (entre 9kHz et 300GHz)

rglementes suivant les rgions du monde

communication rseaux limite un espace de UHF

ultra haute frquence - 300MHz 3GHz

PAN : Bluetooth, ZigBee, Wireless USB

LAN : WiFi, HiperLan 1 et 2

MAN : WiMax, HiperMan, HiperACCESS

WAN : 3G, 4G, GSM, UMTS, etc ...

Infra-rouge (300GHz 100THz)

voir IrDA (Infrared Data Association) pour le transfert de fichiers

progressivement remplac par les technologies ondes radios

Champs lumineux visible (spectre optique - 384THz 789THz)

anecdotique

Cisco ICND1/CCENT (100-101)

alphorm.com

CPL

Courant Porteur en Ligne

transmission par rseau lectrique

signal de plus haute frquence et de faible nergie

ne ncessite aucun cblage supplmentaire

superpos au courant lectrique alternatif (50 ou 60Hz)

Deux catgories

haut dbit : modulations multi-porteuses (type OFDM)

bande de frquence : de 1,6 30Mhz

entre 14 et 500Mbits/s

bas dbit : une seule porteuse la fois en modulation de frquence

bande de frquence : entre 9 et 150kHz en Europe

entre 150 et 450kHz aux tats-Unis

principalement pour la domotique de 2,4 20 kbits/s

Cisco ICND1/CCENT (100-101)

alphorm.com

CPL

Extrmement sujet au bruit et aux attnuations

contrs par un mcanisme de redondance

dpendant de la qualit du cblage lectrique, n'tant par dfinition pas destin transmettre
des informations

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Les diffrents mdias de communication rseaux

Filaire

cbles paires torsads et cbles coaxiaux

Fibre optique

Sans-fil (ondes lectromatiques)

CPL

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Ethernet

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Prsentation

Adressage des pairs

Structure d'une adresse MAC

Accs au mdia

Trames

Cisco ICND1/CCENT (100-101)

alphorm.com

Prsentation

protocole rseau LAN

implmente la couche 1 (physique) du modle OSI

sur rseau cbl (paires torsades, coaxial et fibre optique)

bande de base (par opposition aux larges bandes types ADSL)

ne s'applique pas au CPL, qui a ses propres normes

et la couche 2 (liaison) du modle OSI

adresse MAC, etc

est gnralement class ce niveau

norme IEEE 802.3

a inspir la norme WiFi (802.11), dans la mme famille de normes rseau 802

quasi identique concernant la couche liaison

avec ajout des caractristiques spcifiques au sans-fil

identifiant rseau, dcouverte, association, etc ...

Cisco ICND1/CCENT (100-101)

alphorm.com

Adressage des pairs

adresse MAC (Media Access Point)

identifiant dit "physique"

stock sur la carte ou l'interface rseau

sous-couche (dite couche MAC) de la couche liaison

insertion et traitement de l'adresse MAC dans les trames

utilise par de nombreux protocoles de niveau 2

Ethernet, bien sr

mais aussi WiFi, Bluetooth, ATM, Token Ring, ZigBee

48bits (6 octets)

gnralement reprsents sous forme hexadcimale

en sparant les octets par un double point (parfois un tiret)

exemple : 5E:FF:56:A2:AF:15

Cisco ICND1/CCENT (100-101)

alphorm.com

Structure d'une adresse MAC

premier octet

bit 1 : bit I/G

0 = unicast

1 = multicast ou broadcast

0 = adresse universelle

illustration

wikimedia commons CC-By-SA

Cisco ICND1/CCENT (100-101)

conforme au format de l'IEEE

1 = locale

22 bits rservs : adresse du constructeur

impaire (galement B,D,F)

bit 2 : bit U/L

paire (galement A, C et E)

tout les bits 0 pour une adresse locale

24 bits : adresse unique

permet de diffrencier les diffrentes


cartes rseaux d'un mme constructeur)

alphorm.com

Accs au mdia

CSMA/CD

Carrier Sense Multiple Access

Accs multiple avec coute de la porteuse

coute le mdia

pour vrifier qu'aucune autre station ne


transmet de donnes

mais une latence peu amener malgr tout


des collisions

with Collision Detection

Dtection de Collisions

n'met que dans ce cas

rmission aprs un dlais alatoire

Partage du mme mdia entre deux pairs

aucun jeton ni priorit d'mission

Cisco ICND1/CCENT (100-101)

alphorm.com

Trames

PDU de la couche liaison

EtherType : dfinition du protocole de couche suprieur utilis

ex : 0x0800 = Internet Protocol version 4 (IPv4)

liste assez complte ici

6 11

0 ... 5
Adresse MAC
Destination

Adresse MAC
source
En-tte

Cisco ICND1/CCENT (100-101)

12 et 13

14 1513

1514 1517

EtherType

Donnes

FCS/CRC

Corps

En-pied
alphorm.com

Ce qu'on a couvert

Le protocole liaison (couche 2) le plus courant : Ethernet

adressage physique (MAC)

accs au mdia

structure de trame

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Introduction l'Internet
Protocol

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Rle

Versions

Adresse IPv4

Adresse IPv6

En tte IPv4

En-tte IPv6

Cisco ICND1/CCENT (100-101)

alphorm.com

Rle

Couche internet (2) du modle TCP/IP

Couche rseau (3) du modle OSI

laboration et transport des paquets

reprsentation, routage et expdition

Cisco ICND1/CCENT (100-101)

alphorm.com

Versions

deux version

IPv4

RFC 791 (septembre 1981)

limit : seulement 232 (soit 4 294 967 296) d'adresses en thorie

en pratique, seul un certains nombre en est utilisable

limite en voie d'tre atteinte sur internet

encore le plus utilis, aussi bien sur internet que les rseaux privs

IPv6

RFC 2460 (dcembre 1998)

2128 (soit environs 3.4e+38) adresses possibles

Ces versions sont incompatibles

un hte ne disposant que d'une adresse ipv4 ne peu communiquer avec un hte ne disposant
que d'une adresse ipv6

transition toujours en cours, car complexe .cf RFC 4966

Cisco ICND1/CCENT (100-101)

alphorm.com

Adresse IPv4

code sur 32 bits

soit 4 octets

reprsents sous forme dcimale (base 10)

nombre entre 0 et 255

spars par des points

notation dite "dcimale pointe"

ex : 192.168.10.3

Spars en classes, en sous-rseaux, etc

cf chapitre "adressage IP"

Cisco ICND1/CCENT (100-101)

alphorm.com

Adresse IPv6

code sur 128 bits

soit 16 octets

8 groupes de 2 octets

reprsents en hexadcimale (base 16)

soit 39 caractres en notation complte

spars par des signes doubles points

ex : 2001:0db8:0000:85a3:0000:0000:ac1f:8001

reprsentation abrge :

omission de 1 3 chiffres zro non significatifs

et des groupes de valeur zro

ex : 2001:db8:0:85a3::ac1f:8001

Cisco ICND1/CCENT (100-101)

alphorm.com

En tte IPv4

source : wikimedia commons - cc-by-sa


Cisco ICND1/CCENT (100-101)

alphorm.com

En-tte IPv6

source : wikimedia commons - cc-by-sa


Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Rapide introduction au protocole IP

rle

versions (v4 et v6)

formats d'adresses

en-ttes

Sera largement approfondie dans les deux chapitres suivants (adressage et


routage)

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

Transmission Control
Protocol

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Introduction

lments

Segment TCP

Port TCP

Fiabilit

tablissement de connexion

Autre drapeaux

Autres lments

Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

Deux protocoles de couche transport dans le modle TCP/IP

TCP : pour les communications ncessitant une fiabilit des donnes

Protocole de contrle de transmission

UDP : pour les communications privilgiant le dbit

Permettent le dialogue entre applications

OSI niveau 2 (Liaison) : communication sur rseau local

OSI niveau 3 (Rseau) : communication entre rseaux

entre machines distantes

OSI niveau 4 (Transport) : communication entre applications distantes

Cisco ICND1/CCENT (100-101)

alphorm.com

lments

contrle des donnes

mode connect

ne pas confondre avec la couche session du modle OSI (auth)

rgulation du dbit

tablissement d'une session de communication entre deux htes


(applications)

par mission de messages (segments) de taille variable

multiplexage

cohabitation sur une mme ligne d'informations destines diverses applications

en les identifiant grce un numro (de port)

Cisco ICND1/CCENT (100-101)

alphorm.com

Segment TCP

Cisco ICND1/CCENT (100-101)

alphorm.com

Port TCP

stocks sur 2 octets

dfini l'application mettrice et l'application destinataire de l'information

permettent le multiplexage

3 catgories :

*ports "bien connus" (Well-known ports)

de 0 1023

assigns par l'IANA

*ports enregistrs (Registered ports)

de 1024 49151

services

enregistrs par l'IANA (officiels)

Internet Assigned Numbers


Authority

protocoles largements utiliss

ou non officiels

exemples : FTP (21), SSH


(22), HTTP (80)
voir liste officielle

Cisco ICND1/CCENT (100-101)

exemples : OpenVPN (1194),


IPSec (1293), Cisco X.25
over TCP (XOT) service
(1998)
exemple : Windows Live
Messenger (1503)

*ports dynamiques / privs

de 49152 65535

plus rarement utiliss

alphorm.com

Fiabilit

numro de squence

associ un paquet lors de son mission

aprs rception, un "accus de rception" est envoy

paquet avec drapeaux ACK activ ( 1)

avec un numro d'acquittement gal au numro de squence du paquet reu + quantit de


donnes (en octets) reues

et un numro de squence gal au numro d'acquittement du paquet reu

en labsence de rception de cet "accus de rception" durant un temps imparti, le paquet est
retransmis

en cas de rception de deux paquets identiques (mme numro de squence), la machine


rceptrice ne considrera que le dernier paquet reu

Cisco ICND1/CCENT (100-101)

alphorm.com
wikimedia commons - cc-by-sa

source :

tablissement de connexion

"synchronisation" des numros


de squence

Three-way handshake

Deux drapeaux :

SYN : demande de connexion

ACK : acquittement

positionn ensuite pour


tout les segments
changs sur une
connexion tablie

Cisco ICND1/CCENT (100-101)

3 tapes :

demande de connexion

acquittement + demande
de connexion

acquittement
alphorm.com

Autre drapeaux

ECN : signale la prsence de congestion

RFC 3168

URG : donnes urgentes

PSH : donnes envoyer tout de suite (push)

RST : rupture anormale de la connexion (reset)

FIN : demande la FIN de la connexion

Un espace de 5 bits est conserv avant ces drapeaux

afin de prvoir des ventuels ajouts futurs

Cisco ICND1/CCENT (100-101)

alphorm.com

Autres lments

Taille de l'en-tte

Fentre

somme des champs de donnes de l'en-tte

afin de permettre de vrifier l'intgrit de l'en-tte

cf OSI : rptition avec l'Ethernet, car cloisonnement des couches

Pointeur de donnes urgentes


numro de squence partir duquel l'information devient urgente

Options

nombre d'octets que le rcepteur souhaite recevoir sans accus de rception

Somme de contrle (Checksum ou CRC)

essentiel, car la taille de champs Options est variable

diverses options

Remplissage

par des zros

afin d'obtenir une taille d'en-tte multiple de 32 bits

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Prsentation du protocole TCP

son rle

en-tte de segments

drapeaux

lments permettant la fiabilit et le contrle des donnes

connexion

Cisco ICND1/CCENT (100-101)

alphorm.com

Fondamentaux

User Datagram
Protocol
Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Prsentation

Segment UDP

Annexe : nommage des PDU

Cisco ICND1/CCENT (100-101)

alphorm.com

Prsentation

Protocole de transport

permet de rpondre certaines problmatiques non couvertes par le TCP

services ne ncessitant pas de contrle de la fiabilit des donnes

permet un meilleur dbit (transport immdiat des informations)

streaming, VOIP, etc ...

un paquet peut tre perdu

mais l'essentiel est d'envoyer les informations en temps rel, le plus


rapidement possible

Bien plus simple que le TCP

aucune procdure de contrle et donc de mode connect

Cisco ICND1/CCENT (100-101)

alphorm.com

Segment UDP

Le plus simple possible

aucun mcanisme complexe

ports (source + destination)

idem que pour TCP

cf https://fr.wikipedia.org/wiki/Liste_des_ports

longueur du segment

somme de contrle (pour l'intgrit)

Cisco ICND1/CCENT (100-101)

alphorm.com

Annexe : nommage des PDU

Nombreux termes nombreuses confusions

paquet, segment, datagramme, trame

Datagramme

pour les lments envoys


sans contrle de rception
IP mais aussi UDP

Paquet

couche rseau uniquement ! (IP,


ICMP)

souvent mal utilis

Segment

division d'un message en


plusieurs lments de taille
variable

Trame

pour optimiser le transfert


couche Transport : TCP / UDP

Cisco ICND1/CCENT (100-101)

ne s'applique pas aux couche


suprieures (TCP/UDP) ni
infrieurs (Ethernet)

dernire encapsulation avant


transport sur le rseau

header + donnes + trailer

couche liaison uniquement !


(Ethernet, WiFi, PPP)

alphorm.com

Ce qu'on a couvert

Prsentation du protocole UDP

segment

principes

avantages et inconvnients

Cisco ICND1/CCENT (100-101)

alphorm.com

Switching

Fondamentaux

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Rappel : qu'est ce qu'un commutateur?

Commutation

Apprentissage

Domaine de collision

Cisco ICND1/CCENT (100-101)

alphorm.com

Rappel : qu'est ce qu'un commutateur?

lment de niveau 2 du modle OSI

agit donc au niveau de la liaison

adresse MAC, CSMA/CD, etc ...

nombreuses fonctionnalits supplmentaires

par rapports aux hubs (composants de niveau 1)

commutation (ie. aiguillage)

et aux bridges (composants de niveau 2)

multiport

Cisco ICND1/CCENT (100-101)

alphorm.com

Commutation

Un commutateur est un composant multi-ports

une ou plusieurs machines pourront donc tre relies chacun

ce qui va permettre de dterminer de manire intelligente o envoyer


chaque trame

en fonction de son adresse MAC de destination

c'est ce qu'on appellera la commutation

un port tant associ chaque adresse MAC

ne pas confondre avec le routage

Le commutateur va tablir ces correspondances port/adresse MAC

grce une table CAM (Content Addressable Memory)

Cisco ICND1/CCENT (100-101)

alphorm.com

Apprentissage

Au dpart, la table CAM du commutateur est vide

aucune correspondance MAC / port

Celle-ci va donc tre remplie de manire dynamique et intelligente

A la rception d'une trame, le commutateur va :

associer l'adresse MAC source au port par lequel est parvenue cette
trame

puis envoyer le paquet tout le monde (ie sur tout les ports)

quand la machine de destination rpondra cette trame, il pourra alors


associer son adresse MAC au port par lequel est parvenu cette rponse

Cisco ICND1/CCENT (100-101)

alphorm.com

Domaine de collision

Zone logique du rseau dans laquelle les collisions sont possibles

toute portion constitue uniquement de composants de


niveau 1

Un commutateur stocke les trames avant envoi

afin de ne les envoyer que si le mdia est libre

vite donc les collisions

permet de ne plus utiliser le CSMA/CD

c'est ce qu'on appel le full duplex


oppos au half duplex, utilis avec les hub et les cbles
coaxiaux
utilisation dtermine automatiquement par la carte
rseau

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Introduction au switching

rappel des principes du commutateur

intrts et principes de la commutation

design

domaine de collision

Cisco ICND1/CCENT (100-101)

alphorm.com

Switching

Premire approche
de la CLI Cisco IOS
Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Introduction

Modes
modes "utilisateur" et "privilgi"

Accder la CLI

Port console

Configuration

Paramtres

Telnet et SSH

Abrviations

Se connecter via le rseau

Putty

Aide

Raccourcis
Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

CLI : Command Line Interface

interface de configuration en ligne de commande

l'administrateur rentre une commande

appuyer sur Entre envoi cette commande au switch, qui agi en consquent

IOS : Internetwork Operating System

Systme d'exploitation pour la connexion des rseaux

systme d'exploitation de la plupart des quipements Cisco

beaucoup de commandes vues dans ce chapitre seront donc applicable aux


routeurs

utilise Tcl (Tool Command Language) pour la CLI et le scripting

Cisco ICND1/CCENT (100-101)

alphorm.com

Accder la CLI

3 mthodes

console

port physique

par le rseau IP

telnet

SSH

Il est galement possible d'utiliser un outil graphique

Cisco Security Device Manager (SDM)

ou son successeur Cisco Configuration Program (CCP)

Cisco ICND1/CCENT (100-101)

alphorm.com

Port console

port RJ-45

clairement indiqu ("console")

connect au PC via un cble UTP rollover

via la port srie (RS232 - DB25)

il est possible d'utiliser un adaptateur srie-usb pour les PCs


rcents
ou un cable RJ-45 to DE-9

souvent dsign tord comme port DB9

connecteur mle
DE-9

ncessite un mulateur de terminal

minicom : libre, pour les systmes Unix

teraterm : libre, pour Windows

bonne alternative Hyper-Terminal, supprim de Windows


partir de Vista

connecteur
DB25

Putty : libre, trs complet, compatible Window et Unix

Cisco ICND1/CCENT (100-101)

alphorm.com

Paramtres

paramtres respecter :

9600 bits/second

aucun contrle de flux matriel

8-bit ASCII

pas de bit de parit

1 bit stop

Voir plus loin pour tablir la


connexion avec Putty

Cisco ICND1/CCENT (100-101)

alphorm.com

Telnet et SSH

deux protocoles client-serveur

telnet

non scuris

toute communication transmise en clair, mot de passe compris

port TCP/UDP 23

SSH (Secure Shell)

scuris

toute communication est authentifie et chiffre

port TCP/UDP 22

Cisco ICND1/CCENT (100-101)

alphorm.com

Se connecter via le rseau

ncessite un client telnet ou SSH

clients basiques

commande ssh (openssh-client) ou telnet des systmes unix

disponibles via Cygwin sous Windows

Putty

client graphique complet


SSH, Telnet, mais aussi Rlogin, TCP brut et connexion directe

Cisco ICND1/CCENT (100-101)

alphorm.com

Putty

Cisco ICND1/CCENT (100-101)

alphorm.com

Modes

Dans le terminal, les commandes seront interprtes suivant le


"mode" actuel

le prompt indiquera systmatiquement le mode actuel

exemple : en mode "configuration d'une ligne"

switch(config-line)#

nous verrons au fur et mesure les commandes permettant de passer


dans chaque "mode"

Cisco ICND1/CCENT (100-101)

alphorm.com

modes "utilisateur" et "privilgi"

Par dfaut, suite de votre connexion, le mode "user EXEC" est utilis

ce qui implique qu'il est impossible d'effectuer des commandes ncessitant


certains privilges

ex : redmarrer le switch grce la commande reload

ceci est indiqu par le prompt ">"

Pour excuter ces commandes, il vous faudra passer en mode "privilgi"

"Enable mode", "privileged mode" ou encore "privileged EXEC mode"

grce la commande enable

ncessite un mot de passe

indiqu par le prompt "#"

Cisco ICND1/CCENT (100-101)

alphorm.com

Configuration

pour modifier le mot de passe du mode enable :


# enable secret password

en labsence de ce mot de passe, il est impossible de passer en mode


"privilgi" via une connexion telnet ou SSH

Cisco ICND1/CCENT (100-101)

alphorm.com

Abrviations

il est possible d'abrger chaque commande

afin de gagner du temps

cependant, il sera bien entendu impossible de les abrger au dela d'une certaine
limite

Exemple :

pour viter toute ambigut

la commande enable pourra tre abrge en "en" mais pas en "e"

la plupart du temps, les commandes seront crites compltement dans ce cours

mais, une fois celles-ci prsentes, elles pourront tre utilise sous leur forme
abrges

Cisco ICND1/CCENT (100-101)

alphorm.com

Aide
Commande

Description

com?

liste et rapide description des commandes


disponibles dans le mode actuel
rapide prsentation des manires d'obtenir de
l'aide
liste des premiers paramtres disponibles pour
la commande avec leur description
liste des commandes commenant par "com"

command parm?

liste des paramtres commenant par "parm"

command parm<tab>

complte la commande si il n'existe qu'un


possibilit

command parm1 ?

liste les paramtres suivants disponibles

help

command ?

Cisco ICND1/CCENT (100-101)

alphorm.com

Raccourcis
Raccourci

Action

ou Ctrl-p

remonte d'une commande dans l'historique

ou Ctrl-n

redescend d'une commande dans l'historique

ou Ctrl-b

dplacer le curseur vers la gauche

ou Ctrl-f

dplacer le curseur vers la droite

Backspace

supprimer le caractre gauche du curseur

Ctrl-a

dplacer le curseur en dbut de ligne

Ctrl-e

dplacer le curseur en fin de ligne

Ctrl-r

r-afficher le ligne de commande et tout ses caractres


(trs utile quand un message encombre l'affichage)

Ctrl-d

supprimer le caractre sous le curseur

Esc-b

se dplacer d'un mot vers la gauche

Esc-f

se dplacer d'un mot vers la droite

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Effectuer une premire approche de la CLI Cisco IOS

savoir comment s'y connecter

via la console

ou via le rseau

comprendre cette interface

prompt et modes

abrviations

Cisco ICND1/CCENT (100-101)

alphorm.com

Switching

Configuration

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Running-config et
startup-config

Nom d'hte

Configuration des interface

Configuration IP

Passerelle par dfaut

Configuration des interfaces de


commutation

Cisco ICND1/CCENT (100-101)

Scurit
Mot de passe
SSH
Scurisation des ports
Scurisation des ports :
configuration
Scurisation des ports : adresses

alphorm.com

Running config et startup config

deux espaces distincts pour stocker la configuration

mmoire vive (RAM)

running-config

configuration actuellement utilise

perdues aprs redmarrage

mmoire non volatile (NVRAM)

startup-config

configuration charge au dmarrage

pour afficher la configuration


# show running-config

# show startup-config

pour enregistrer la configuration actuelle (running-config)


# write

ou
# copy running-config startup-config

Cisco ICND1/CCENT (100-101)

alphorm.com

Configuration des interface

mode Interface

(config)# interface type number


(config-if)#

Exemple

(config)# interface FastEthernet 0/1

Il est possible de configurer en une seule fois un ensemble


d'interfaces

Exemple

(config)# interface range FastEthernet 0/10 - 20


(config-if-range)#
Cisco ICND1/CCENT (100-101)

alphorm.com

Configuration IP

ncessaire pour accder au commutateur via le rseau

telnet, ssh, interface web

hors, un commutateur n'est pas fait pour, normalement, agir sur la couche 3

on va donc utiliser une interface virtuelle VLAN1 (cf cours suivants)

dans le VLAN par dfaut

(config)#interface vlan 1

nous configurons ensuite l'adresse ip

Statique

(config-if)#ip address dhcp

ou dynamique

(config-if)#ip address 192.168.1.200 255.255.255.0


Cisco ICND1/CCENT (100-101)

alphorm.com

Configuration IP

puis on active l'interface


(config-if)#no shutdown

Cisco ICND1/CCENT (100-101)

alphorm.com

Passerelle par dfaut

Configurer une passerelle par dfaut se fera dans la configuration


globale
(config)#ip default-gateway 192.168.1.1

Cisco ICND1/CCENT (100-101)

alphorm.com

Configuration des interfaces de commutation

Par dfaut, la vitesse et le mode duplex d'une interface sont ngocis


automatiquement avec le priphrique connect

il est cependant possible de forcer ces valeurs

(config)#interface fastEthernet 0/1


(config-if)#speed 10
(config-if)#duplex half
(config-if)#end

Pour plus de clart, il est galement possible de renseigner une


description pour chaque interface
(config-if)#description votre description ici

Cisco ICND1/CCENT (100-101)

alphorm.com

Scurit

Par dfaut, votre commutateur est "convenablement" scuris

du moment qu'il reste inaccessible physiquement

enferm dans un salle approprie

seul un accs console est autoris par dfaut

aucune authentification requise

accs complet toutes les commandes

pas de mot de passe pour le mode Enable

Il peu cependant tre ncessaire de mettre en place un mot de passe


pour la connexion

et d'activer le telnet et le SSH

Cisco ICND1/CCENT (100-101)

alphorm.com

Mot de passe

deux types

console

Virtual Terminal - vty (pour le telnet)

de 0 15 (ou de 0 4 pour les modles les plus anciens)

aucun nom d'utilisateur

Exemples de configuration :

ncessite de passer en mode configuration partir du terminal

> enable
# configure terminal

Port console 0

(config)# line console 0


(config-line)# password faith
(config-line)# login
Cisco ICND1/CCENT (100-101)

Tout les vty

(config)# line vty 0 15


(config-line)# password love
(config-line)# login

alphorm.com

SSH

ncessite l'usage de noms d'utilisateurs locaux


(config)#line vty 0 15
(config-line)#login local

activer le ssh en plus du telnet

seul le telnet est activ par dfaut

(config-line)#transport input telnet ssh

ajout d'une ou plusieurs paire(s) utilisateur / mot de passe


(config)#username name password pwd

configurer un nom de domaine


(config)#ip domain-name example.com

gnrer une paire cl publique / prive ainsi qu'une cl de chiffrement partage


(config)#crypto key generate rsa

Cisco ICND1/CCENT (100-101)

alphorm.com

Scurisation des ports

vite l'intrusion d'un attaquant sur le rseau

en explicitant la machine prvue pour se connecter au port

pas pas

passer en mode de configuration de l'interface

(config)#interface FastEthernet 0/1

passer l'interface en mode "access"

(config-if)#switchport mode access

activer la scurisation de port sur cette interface

(config-if)#switchport port-security
Cisco ICND1/CCENT (100-101)

alphorm.com

Scurisation des ports : configuration

indiquer le nombre maximum d'adresses MACs scurises sur cette interface

Optionnel - 1 par dfaut

(config-if)#switchport port-security maximum nombre

indiquer l'action raliser la rception d'une trame non conforme

Optionnel - shutdown par dfaut

(config-if)#switchport port-security violation {protect | restrict | shutdown}

protect : blocage des trames sans message d'avertissement.

restrict : blocage des trames avec avertissement

message syslog, trap snmp et incrmentation du compteur d'erreur

shutdown : dsactivation de l'interface

avec blocage des trames et avertissement

Cisco ICND1/CCENT (100-101)

alphorm.com

Scurisation des ports : adresses

3 possibilites :

configuration manuelle (explicite)

apprentissage dynamique

ne peuvent tre enregistres

sticky : adresses apprises dynamiquement et enregistres dans la running-config

peuvent alors tre enregistres dans la startup-config

mode dsactiv par dfaut

lors de l'activation de ce mode, toute adresse apprise dynamiquement est convertie en adresse "sticky"

spcifier explicitement une nouvelle adresse MAC autorise

si il reste un certain nombre dadresses MAC autorises possible non dfinies, celles-ci seront apprises
dynamiquement

(config-if)#switchport port-security mac-address addresse-mac

activer le mode "sticky"

(config-if)# switchport port-security mac-address sticky


Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

L'essentiel de la configuration d'un switch Cisco IOS.

comprendre le systme de configuration

paramtres globaux

nom d'hte

adresse IP

passerelle par dfaut

configuration des interfaces

scurit

protection par mot de passe

SSH

scurisation des ports

Cisco ICND1/CCENT (100-101)

alphorm.com

Switching

Introduction aux
VLANs
Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Prsentation

Intrts

Fonctionnement

Cisco ICND1/CCENT (100-101)

alphorm.com

Prsentation

Virtual LAN

rseau local virtuel

rseau logique indpendant

permet de sparer les ports d'un switch dans des rseaux diffrents

les machines d'un VLAN ne pouvant communiquer avec celles d'un autre
VLAN

Cisco ICND1/CCENT (100-101)

alphorm.com

Intrts

du concept de VLAN lui mme

segmentation

scurit

optimisation de la bande passante

scurit

ncessite l'utilisation d'un routeur pour communiquer entre VLANs

de l'usage de VLAN plutt que de nombreux switchs spars

diminution des cots

un "gros" switch de 256 ports revient moins cher que 5 switchs de 48

centralisation de la configuration

modifications simplifies

le passage d'une machine d'une VLAN une autre peu se faire par simple configuration

Cisco ICND1/CCENT (100-101)

alphorm.com

Fonctionnement

norme IEEE 802.1Q

successeur de Cisco ISL (Cisco Inter-Switch Link)

Adresse MAC

ajout
Destination

MAC
TAG
d'unAdresse
tag
aux
trames
ethernet
source
(4 octets)

EtherType

Donnes

FCS/CRC
(modifi)

Corps

En-pied

En-tte

Tag Control Information


(TCI)

Tag protocol
identifier (TPID)
Identifie le protocole de
la balise insre
(0x8100 pour le
801.1Q)
16 bits
Cisco ICND1/CCENT (100-101)

Priority Code Point


(PCP)

Canonical Format
Identifier (CFI)

VLAN ID
(VID)

Priorit du VLAN
De 0 7

Compatibilit Eth /
Token Ring

De 1 4094

3 bits

1 bit

12 bits

alphorm.com

Ce qu'on a couvert

Introduction au concept de VLANs

prsentation

avantages

fonctionnement

protocole 802.1Q

Cisco ICND1/CCENT (100-101)

alphorm.com

Switching

Configuration des
VLANs
Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Administration des VLANs

Configuration des ports

Affectation d'un port access un VLAN

Filtrage des VLANs sur port trunk

Cisco ICND1/CCENT (100-101)

alphorm.com

Administration des VLANs

pour passer en mode de configuration d'un VLAN

(config)# vlan 2
(config-vlan)#

il est galement possible de configurer plusieurs VLANs la fois

(config)# vlan 2,3,4


(config-vlan)#

si la VLAN n'existe pas encore, elle est automatiquement cre

pour la supprimer, utiliser la commande no

(config)# no vlan 2
Cisco ICND1/CCENT (100-101)

alphorm.com

Configuration des ports

2 modes

access (par dfaut)

connexion terminale d'un priphrique

n'appartient qu' un seul VLAN

trunk

connexion faisant transiter les trames de plusieurs VLAN

particulirement utile pour les connexions entre switchs

Mise en uvre

mode access

(config-if)#switchport mode access

mode trunk

(config-if)#switchport mode trunk


Cisco ICND1/CCENT (100-101)

alphorm.com

Configuration des ports

si plusieurs protocoles d'encapsulation sont disponibles (isl ou dot1q), il peut-tre ncessaire de


spcifier celui utiliser au pralable
(config-if)#switchport trunk encapsulation dot1q

Cisco ICND1/CCENT (100-101)

alphorm.com

Affectation d'un port access un VLAN

en mode de configuration de l'interface

fonctionne aussi avec un groupe d'interface (if-range)

(config-if)#switchport access vlan 2

Cisco ICND1/CCENT (100-101)

alphorm.com

Filtrage des VLANs sur port trunk

Autoriser des VLANs

(config-if)#switchport trunk allowed vlan add 2,3,10

Interdire un VLAN

(config-if)#switchport trunk allowed vlan remove 3

Annuler le filtrage

(config-if)#no switchport trunk allowed vlan

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Configuration des VLANs de niveau 1 sur un switch cisco

Cisco ICND1/CCENT (100-101)

alphorm.com

Adressage IP

Classes

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Introduction

Concept

Classes

Classe A

Classe B

Classe C

Classe D et E

Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

au dpart, seul le premier octet servait dsigner le rseau

les 3 autres octets dsignant les machines

soit seulement 256 rseaux de 16 million d'adresses !

ncessit de permettre plus de rseaux

premire proposition : IEN 46 - Juin 1978

agrgation des rseaux en rgions

RFC 790 - Septembre 1981

solution prsente dans ce cours

obsolte depuis Septembre 1993 !

et l'apparition du CIDR (Classless Inter-Domain Routing)

RFC 1518

Cisco ICND1/CCENT (100-101)

alphorm.com

Concept

Sparation des adresses en deux parties

net id : adresse rseau

host id : adresse de l'hte

5 classes d'adresses

identifies par une lettre de A E

diffrentes tailles de rseaux

les adresses rseaux sont gres au niveau mondial (pour Internet)

par l'IANA

par d'autres organisations (Apple, MIT, etc ...)

ou par des registres internet rgionaux

cf https://www.iana.org/assignments/ipv4-address-space/ipv4-address-space.xml

Cisco ICND1/CCENT (100-101)

alphorm.com

Classes
Classe

Dbut

Fin

Net id sur :

0.0.0.0

127.255.255.255

le premier octet

128.0.0.0

191.255.255.255

les deux premiers octets

192.0.0.0

223.255.255.255

les trois premiers octets

224.0.0.0

239.255.255.255

NA (multicast)

240.0.0.0

255.255.255.255

NA (rserve)

Cisco ICND1/CCENT (100-101)

alphorm.com

Classe A

Rseaux de trs grande dimension

nombreuses adresses rserves des organisations

ex : 018.rrr.rrr.rrr pour le MIT

cas particulier : boucle locale (rseau 127.0.0.0)

nombre de rseaux possibles : 128

nombre de postes maximum par rseau : plus de 16 millions

premier octet : de 0 127

masque par dfaut : 255.0.0.0 - /8

Cisco ICND1/CCENT (100-101)

alphorm.com

Classe B

Rseaux de "moyenne" dimension

nombre de rseaux possibles : 16 384

nombre de postes maximum par rseau : 65 534

premier octet : de 128 191

masque par dfaut : 255.255.0.0 - /16

Cisco ICND1/CCENT (100-101)

alphorm.com

Classe C

Rseaux de petite dimension

nombre de rseaux possibles : 2 097 152

nombre de postes maximum par rseau : 254

premier octet : de 192 223

masque par dfaut : 255.255.255.0 - /24

Cisco ICND1/CCENT (100-101)

alphorm.com

Classe D et E

adresses uniques (pas de net id)

Classe D

destines au multicast

bits de dpart : 1110

premier octet : 224 239

Classe E

rserves par l'IANA pour un usage futur

bits de dpart : 1111

premier octet : 240 255

Cisco ICND1/CCENT (100-101)

alphorm.com

Et l'ipv6 ?

IPv6 a t prsent en 1998

soit bien aprs le CIDR (1993) et l'abandon du concept de classe

Il n'y a donc aucun concept de classe

IPv6 tant pleinement orient CIDR

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Prsentation de l'adressage ip sur rseaux classfull

obsolescence

concepts

introduction au concept d'adresse rseau

Cisco ICND1/CCENT (100-101)

alphorm.com

Adressage IP

Sous-rseaux IPv4
classful
Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Introduction

Fonctionnement

Exemple

Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

Le concept de classe est trs limit

ne permet que peu de rseaux

pour pallier cela, un nouveau concept est introduction en 1984

RFC 917 (Internet Subnets)

sous-rseaux

Permet la subdivision logique des rseaux de taille plus importante

relativement aux classes d'adresses

Cisco ICND1/CCENT (100-101)

alphorm.com

Fonctionnement

Ajout d'un troisime champs

entre le net id et le host id

permettant de dsigner un sous-rseau

La taille de ce champ tant variable, la division entre adresse de sous-rseau et d'hte est faite grce un masque

adresse IPv4 dont tout les bits correspondant une adresse de rseau ont une valeur de 1

ex : 18 premiers bits = 255.255.192.0

donne le sous-rseau d'un hte par un ET logique sur son adresse

Le nombre de sous-rseaux possible est dtermin par la formule suivante :

S = 2n - 1

car l'adresse de broadcast (tout 1) n'est pas utilisable

o n est le nombre de bits masqus en plus de ceux du net id

Le nombre d'htes possibles est dtermini par la formule suivante :

S= 2n - 2

car ni l'adresse de broadcast ni l'adresse de rseau ne sont utilisables

o n est le nombre de bits restant pour le host id

Cisco ICND1/CCENT (100-101)

alphorm.com

Exemple

Un administrateur souhaite diviser le rseau 192.52.61.0 dont il a la


charge en 4 sous-rseaux

rseau de classe C : 8 bits disponibles

3 = 22 -1

<

23 - 1 = 7

il aura donc besoin de 3 bits pour le sous-rseaux

soit un masque de 27 bits

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Subnetting sur les rseaux IPv4 classful

concept

fonctionnement

masque de sous-rseau

exemple concret

Cisco ICND1/CCENT (100-101)

alphorm.com

Adressage IP

Adressage IPv6

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Introduction

Rappels

Scope

Types d'adresses unicast

Sous-rseaux

Adresses locales de lien

Adresses locales uniques

Adresses globales unicast

Multicast

Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

Mme si la migration de l'IPv4 l'IPv6 n'a, clairement, toujours pas rellement eu lieu

elle devient de plus en plus ncessaire

face la pnurie d'adresse IPv4

Mme si la notation hexadcimale peu paratre complexe

comprendre l'IPv6 n'est pas bien plus difficile que pour l'IPv4

Donc, mme si nous n'en rencontrons encore que peu

nous allons en rencontrer de plus en plus

et il est plus que ncessaire de s'y prparer

d'autant plus que cela ne reprsente que peu de temps d'apprentissage

Cisco ICND1/CCENT (100-101)

alphorm.com

Rappels

Une adresse IPv6 est code sur 128 bits

soit en thorie 3.4x1038 = 340 sextillions d'adresses

soit 340 milliards de milliards de milliards de milliards !

soit 48 quadrillards (1027) d'adresses par personnes dans le monde !

Tout cela ne reste que de la thorie

soit de quoi changer 17 billiards (1015) de fois d'IP par seconde en 85 ans
pour une personne possdant 1 milliard de machines

car bien entendu, de "trs" nombreuses adresses ne sont pas utilisables

Mais on pourrait donc tout de mme tablir des adresses uniques mondialement pour
chaque machine !

rsolution du problme de pnurie du nombre d'adresses IPv4

Cisco ICND1/CCENT (100-101)

alphorm.com

Scope

unicast

adresses dsignant une seul interface d'un hte

anycast

nouveau concept

"le plus proche" / "le plus efficace"

adresse d'un nud parmi un groupe de nuds

dsigne "n'importe quel" membre ce nud

multicast

abandon des adresses de broadcast

dsigne un groupe d'interfaces

chaque interface tant libre de s'abonner un groupe et de le quitter, tout moment

moins pnalisant que le broadcasting IPv4

Cisco ICND1/CCENT (100-101)

alphorm.com

Types d'adresses unicast

adresses de boucle locale (loopback)

::1/128

limite une utilisation interne pour un hte

adresses de liaison locale (link-local)

uniques sur un lien donne

purement locales (adresses locales de lien)

ou uniques (mondialement)

non routables

RFC 4193

adresses globales

uniques dans le monde

Cisco ICND1/CCENT (100-101)

alphorm.com

Sous-rseaux

Mme systme que pour l'IPv4 classless

notation CIDR du masque

Exemple :

2001:db8:1:1a0::/59

de 2001:db8:1:1a0:0:0:0:0 2001:db8:1:1bf:ffff:ffff:ffff:ffff

cf https://en.wikipedia.org/wiki/IPv6_subnetting_reference

Cisco ICND1/CCENT (100-101)

alphorm.com

Adresses locales de lien

adresses fe80 ::/10

purement locales

non routables

uniquement utilisables sur les rseau de niveau 2 (segment rseau : lien ou domaine de
broadcast)

alloue automatiquement (le plus souvent partir de l'adresse MAC) ou manuellement

requis sur toute interface s lesquelles IPv6 est activ

pour d'autres protocoles lis IPv6 (NDP, DHCPv6, etc ...)

uniques sur un lien uniquement

masque en /64

ce qui permet un hte d'utiliser ventuellement la mme adresse pour plusieurs interfaces

aucun sous-rseau

toutes les machines appartiennent au rseau fe80::/64

Cisco ICND1/CCENT (100-101)

alphorm.com

Adresses locales uniques

fc00::/7 (pour Internet)

ne sont routables que sur les sites qui le souhaitent

pas sur Internet

quivalent des plages d'adresses prives (RFC 1918) IPv4

ID Globale : identifiant unique de l'organisation

et fd00::/8+ (pour L=1, pour les rseaux locaux)

choisi pseudo-alatoirement

L : 1 si l'ID Globale est assign localement

Cisco ICND1/CCENT (100-101)

alphorm.com

Adresses globales unicast

2000 ::/3

soit 1000 0000 0000 0000 ::/3

1/8me de l'espace total d'adressage IPv6 utilis seulement (la plupart en 2001::/16)

afin de limiter la taille des tables de routage

assignes par blocs de /23 /12 par les Registres Internet Rgionaux (cf IANA)

exemple : SFR dtient le bloc 2001:4c18::/32

routables sur Internet

moins d'un autre 1/8me est rserv

ex : 2002::/16 : adresses 6to4

permettent d'acheminer le trafic IPv6 via un ou plusieurs rseaux IPv4

Toutes les autres adresses routables (plus des trois quarts) sont actuellement rserves pour usage
ultrieur

Cisco ICND1/CCENT (100-101)

alphorm.com

Multicast

ff00::/8

propres l'application

exemple : ff02::1:ff00:0/104

pour dcouvrir l'adresse MAC d'un hte dont l'adresse IPv6 est connue

avec NDP (Neighbor Discovery Protocol)

Drapeau : 3 bits dfinis par la RFC 4291

le bit le plus significatif tant rserv un usage ultrieur

Scope : domaine de validit de l'adresse

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Adressage IPv6

types d'adresses

lments

subnetting

Cisco ICND1/CCENT (100-101)

alphorm.com

Routage IP

Mthodes et protocoles de
routage

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Qu'est ce que le routage ?

Exemple avec traceroute

Tables de routage

Systmes Autonomes

Protocoles de routage

Exemples de protocoles de routage


interne
Exemples de protocoles de routage
externe

Cisco ICND1/CCENT (100-101)

alphorm.com

Qu'est ce que le routage ?

Permet d'interconnecter plusieurs rseaux

via des routeurs

composants de couche rseau (3)


toute machine compatible IP peu agir en tant que routeur, grce un logiciel
de routage

en relayant les paquets qui ne sont "pas pour lui"

en ds-encapsulant le paquet IP de la trame Ethernet

et en le r-encapsulant avec une nouvelle adresse MAC de destination

grce un ensemble de rgles

dterminant qui peu communiquer avec qui et comment

c'est dire "en empruntant quel chemin" / "en passant par qui"

enregistres dans
Cisco ICND1/CCENT (100-101)

des "tables de routage"

alphorm.com

QU'EST CE QUE LE ROUTAGE ?

Remarque : un routeur permet galement de connecter des VLANs

par exemple pour communiquer avec des ressources partages (comme le


DHCP)

le subnetting se fera entre des rseaux physiques diffrents (spars par des
routeurs) alors que les VLANs seront sur un mme rseau physique (via des
switchs)

en pratique, on cumulera souvent les deux

Cisco ICND1/CCENT (100-101)

alphorm.com

Exemple avec traceroute

ici un traceroute en ligne

affiche la route emprunte

Cisco ICND1/CCENT (100-101)

entre le serveur de sdv.fr

et celui de alphorm.com

ou voit ici qu'il a t ncessaire


de passer par 6 routeurs
diffrents
alphorm.com

Tables de routage

Le routage est un processus dcentralis

chaque routeur possde les informations sur son voisinage

dtermine qui doivent tre envoys les paquets destins un rseau particulier

routeur voisin ou rseau directement connect

associe une adresse rseau une passerelle (un routeur)

Trois types de routes

statique : configuration manuelle par l'administrateur

dynamique : apprentissage par le routeur lui mme

grce des protocoles de routage spcifique

connecte : rseaux directement connects au routeur

chaque entre est donne explicitement

appel un protocole de niveau 2 (Ethernet)

A cela s'ajoute une route par dfaut, qui peut-tre statique ou dynamique

Cisco ICND1/CCENT (100-101)

alphorm.com

Systmes Autonomes

AS pour Autonomous System

zone particulire (sous ensemble) d'un trs grand rseau

compos de nombreux rseaux IP, LAN, WAN, etc

administrs par une mme entit

ex : rseaux "grand compte" d'envergure mondiale, backbones internet (rseau d'oprateur de large
envergure)

deux types de routeurs en son sain

de bordure : permettent d'entrer et sortir de l'AS

par exemple, pour rejoindre Internet (d'un rseau d'oprateur vers les autres)

internes : assurent la communication entre rseaux de l'AS

chaque AS est identifis par un numro (ASN) unique au sain d'un mme rseau

sur Internet, ceux-ci sont dlivrs par les registres internet rgionaux

ex : 16276 pour OVH via RIPE-NCC

plus de 45000 AS composent Internet en 2013

Cisco ICND1/CCENT (100-101)

alphorm.com

Protocoles de routage

Pour employer des algorithmes de routage efficaces, un routeur besoin de connatre au moins
une partie de la typologie du rseau

il est donc ncessaire de diffuser les tables de routage

ie. changer les informations entre routeurs

On utilise pour cela un protocole de routage

de deux types :

internes : Interior Gateway Protocols (IGP)

entre routeurs internes d'un mme AS

ex : RIP ou OSPF

les seules concerns par la CCENT

ou externes : Exterior Gateway Protocols (EGP)

entre routeurs de bordure d'AS diffrents

ex : BGP

Cisco ICND1/CCENT (100-101)

alphorm.com

Exemples de protocoles de routage interne

RIP et RIP-2 : Routing Information Protocol

trs limit

OSPF : Open Shortest Past First

crit pour remplacer RIP en palliant ses limites

complet et performant

habituellement rserv aux grands rseaux

recommand comme IGP pour Internet (RFC 1371)

IGRP : Interior Gateway Routing Protocol

le plus ancien et le plus simple

propritaire Cisco

IS-IS : Interior System to Interior System

norme ISO/IEC 10589:2002 de l'OSI

extrmement stable

Cisco ICND1/CCENT (100-101)

alphorm.com

Exemples de protocoles de routage externe

EGP : Exterior Gateway Protocol

le premier

trs peu performant

quasi abandonn

BGP : Border Gateway Protocol

le plus efficace et donc le plus utilis

utilis pour Internet

ES-IS : Exterior System to Interior System

unique EGP normalis OSI

trs peu utilis

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Concepts essentiels du routage rseau

objectifs et fonctionnement

types de routes

statiques

dynamiques

connectes

par dfaut

protocoles de routage

IGP

EGP

Cisco ICND1/CCENT (100-101)

alphorm.com

Routage IP

Configuration basique des


routeurs

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Introduction

Commandes d'information

Rappel : Adresse IP d'une interface

Routes statiques

Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

La grande majorit des commandes vues pour les switchs reste applicable

modes (user et enable) et mots de passe

modes de configuration

configuration console, telnet et ssh

nom d'hte et description d'interface

configuration des interfaces (speed, duplex)

activation et dsactivation des interfaces (shutdown)

aide et raccourcis

startup et running config (copy et setup)

seules diffrent

la configuration IP

les questions poses en mode setup

la prsence du port AUX, absent des switchs

accs la CLI par ligne tlphonique

Cisco ICND1/CCENT (100-101)

alphorm.com

Commandes d'information

afficher les protocoles configurs


# show protocols

afficher la table de routage


# show ip route

affichage des statistiques IP


# show ip traffic

afficher l'tat des protocoles de routage actifs

# show ip protocols

Cisco ICND1/CCENT (100-101)

alphorm.com

Rappel : Adresse IP d'une interface

configuration statique
(config-if)#ip address 10.1.1.1 255.255.255.0

configuration par dhcp


(config-if)#ip address dhcp

synthse rapide de la configuration des interfaces


#show ip interface brief

Cisco ICND1/CCENT (100-101)

alphorm.com

Routes statiques

syntaxe gnrale

(config)#ip route adresse-rseau masque passerelle


(config)#ip route adresse-rseau masque interface

route par dfaut

(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.1

exemples de routes statiques

(config)#ip route 192.168.1.0 255.255.255.0 FastEthernet 1/0

(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.1


Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Configuration de base d'un routeur

points communs avec les switchs

commandes d'information

adressage IP

configuration des routes statiques

Cisco ICND1/CCENT (100-101)

alphorm.com

Routage IP

OSPF

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Problme du plus court chemin

Limitations de RIP

Open Shortest Path First

Fonctionnement

Area

Activation

Dfinition du Router-ID

Activation de l'OSPF sur une interface

Interface passive

Commandes d'information

Cisco ICND1/CCENT (100-101)

alphorm.com

Problme du plus court chemin

problme classique de thorie des graphes

trouver le chemin optimal entre les sommets


d'un graphe

particulirement utile dans le cadre des


rseaux

de nombreux algorithmes existent pour


rsoudre ce problme

plus ou moins efficaces suivant les contextes

algorithme de Dijkstra

Algorithme de Bellman-Ford

Cisco ICND1/CCENT (100-101)

alphorm.com

Limitations de RIP

protocole vecteur de distances

aucune vision globale du rseau

diffusion des routes de proche en proche

grande consommation de la bande passante

particulirement pour les grands rseaux

du fait de l'envoi priodique de toutes les tables de routage en broadcast

sensible aux boucles de routage

limite de 15 sauts

tout rseau au del de 15 routeurs est considr comme inaccessible

ne se base que sur le nombre de "sauts" permettant d'atteindre le routeur voisin

aucune prise en compte de la bande passante des liaisons pour choisir le meilleur chemin
possible, ou d'autre information (fiabilit, charge, dlai, etc ...)

Cisco ICND1/CCENT (100-101)

alphorm.com

Open Shortest Path First

protocole tat de lien

connaissance de l'intgralit de la topologie du rseau

limine les boucles de routage

collecte de l'ensemble des cots de liens

en terme de temps

en continue

plus grande consommation de ressources processeur

ncessite des routeurs performants

Cisco ICND1/CCENT (100-101)

alphorm.com

Fonctionnement
1.

analyse en continue des connexions vers les lments proches

message hello envoy intervalles rguliers

2.

calcul du plus court chemin vers les routeurs voisins

3.

diffusion de la liste des routes connectes et des tats de liens

propag de proche en proche

toutes les 30 minutes (intgralit des LSAs)

LSA (Link-State Advertisement)

4.

et chaque changement (LSA modifis uniquement)

l'ensemble des LSAs d'une aire formant la LSDB (Link-State Data Base)

dtermine enfin la route la plus courte pour chaque rseau de la LSDB

Cisco ICND1/CCENT (100-101)

alphorm.com

Area

sous-ensemble de routeurs

en bordure duquel un rsum de la LSDB peut-tre fait

chaque sous-rseau appartenant une seule aire

permet d'viter de propager l'intgralit de la LSDB

identifies par des nombres entiers de 32bits

souvent nots en notation dcimale pointe

la manire des adresses IPv4

la configuration d'OSPF devient complexe quand plusieurs aires sont mises en place

heureusement, il ne vous est demand que de savoir le configurer dans une aire
unique dans le cadre de la CCENT

Cisco ICND1/CCENT (100-101)

alphorm.com

Activation
# router ospf process-id
(config-router)#

lancement d'un processus de routage OSPF

permet d'activer l'OSPF sur le routeur (aucun par dfaut)

ou de passer en mode de configuration de ce processus de routage si


dj actif

proccess-id : identifiant interne du processus de routage

n'importe quel entier suprieur ou gal 1

Cisco ICND1/CCENT (100-101)

alphorm.com

Dfinition du Router-ID

Optionnel

gnralement gnr automatiquement partir des adresses IP du


routeur au lancement d'OSPF

Valeur explicite
(config-router)# router router-id

ou par configuration de la plus haute adresse IP de l'interface de


loopback
(config)#interface loopback 0
(config-if)#ip address 172.16.0.1 255.255.255.0

Cisco ICND1/CCENT (100-101)

alphorm.com

Activation de l'OSPF sur une interface

De manire implicite

relativement une adresse rseau

(config-router)# network ip-address wildcard-mask area area-id

Exemple

(config)#router ospf 100


(config-router)#network 10.0.3.0 0.0.0.255 area 0
(config-router)#network 10.0.0.0 0.0.0.255 area 0

Cisco ICND1/CCENT (100-101)

alphorm.com

Interface passive

Par dfaut, un routeur sur lequel OSPF est activ continuera de


chercher rgulirement ses "voisins" sur ses interfaces

par envoi de messages hello intervalles rguliers

Hors cela peut-tre un gchis de ressources quand il n'y a aucun


voisin sur celle-ci

il est donc possible de mettre une interface en mode passif

afin qu'elle nenvoie plus de message hello

en mode de configuration du processus de routage


(config-router)# passive-interface type number

ou en mode de configuration de l'interface

(config-if)# ip ospf passive-interface


Cisco ICND1/CCENT (100-101)

alphorm.com

Commandes d'information
# show ip ospf

afficher les informations sur les voisins

# show ip ospf neighbor

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Gestion de l'OSPF en single-area

bnfices par rapport au protocole RIP

fonctionnement

activation

router-id

configuration

interfaces passive

Cisco ICND1/CCENT (100-101)

alphorm.com

Routage IP

Routage interVLAN

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

3 solutions

Rappel : trunking

Sous interfaces

Configuration des sous-interfaces

Cisco ICND1/CCENT (100-101)

alphorm.com

3 solutions

via un routeur

avec une interface connecte chaque VLAN

trs rarement employ

avec une interface trunk vers un switch

Router on a stick (ROAS)

routage inter-vlan laide dun router ddi

solution la plus courante

prsente dans ce cours

via un switch de couche 3

Cisco ICND1/CCENT (100-101)

alphorm.com

Rappel : trunking

permet de faire transiter les trames de plusieurs VLANs sur une


interface
Switch(config)# interface FastEthernet 0/0
Switch(config-if)# switchport mode trunk

activer avant toute chose sur l'interface connecte du switch

Cisco ICND1/CCENT (100-101)

alphorm.com

Sous interfaces

Pour effectuer le routage interVLAN, il est ncessaire de disposer


d'une adresse IP sur chaque VLAN

hors, avec un ROAS, seule une interface relle est connecte en mode
trunk

les sous-interfaces vont donc permettre, sur une mme interface trunk,
de crer virtuellement une interface par VLANs

Autant d'interface logique qu'il existe de VLAN router

Exemple
(config)# interface FastEthernet 0/0.1
(config-subif)#

Cisco ICND1/CCENT (100-101)

alphorm.com

Configuration des sous-interfaces

sur chaque sous-interface

activation du 802.1Q

association un VLAN

configuration IP (adresse et masque)

Exemple

association de la sous-interface FastEthernet 0/0.1 au VLAN 1

(config)# interface FastEthernet 0/0.1


(config-subif)# encapsulation dot1Q 1
(config-subif)# ip address 192.168.1.254 255.255.255.0
Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Routage interVLAN

solutions possibles

configuration sur un ROAS

sous-interfaces

Cisco ICND1/CCENT (100-101)

alphorm.com

Services IP

DHCP

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Dynamic Host Configuration Protocol

Fonctionnement

Agent relais DHCP

Rappel : interface cliente DHCP

IOS DHCP Server : mise en place

IOS DHCP Server : baux

IOS DHCP Server : paramtres

Commandes d'information

Cisco ICND1/CCENT (100-101)

alphorm.com

Dynamic Host Configuration Protocol

Octobre 1993 : premire dfinition (RFC 1531)

comme extension de BOOTP (Bootstrap Protocol)

adresse IP, masque, passerelle par dfaut

adresses des serveurs de noms (DNS et NBNS (WINS))

modifi et complt par la RFC 2131 (Mars 1997)

couvre l'ensemble des configurations IP

rfrence ipv4 actuelle

adapt l'ipv6 depuis Juillet 2003 (RFC 3315)

Cisco ICND1/CCENT (100-101)

alphorm.com

Fonctionnement

DHCP DISCOVER

broadcast (255.255.255.255)

port 67

DHCP OFFER

rponse du serveur ayant reu la requte

proposant une adresse IP et un masque

et indiquant l'adresse IP du serveur

port 68

DHCP REQUEST

demande d'assignation de l'adresse propose

et l'envoi des valeurs des paramtres

DHCP ACK

accus de rception

assigne l'adresse IP pour une dure dfinie

ainsi que d'autres paramtres ventuels (passerelle par


dfaut, DNS, WINS)
Cisco ICND1/CCENT (100-101)

alphorm.com

Agent relais DHCP

les datagrammes DHCP sont limits un domaine de broadcast

ncessite donc des serveurs DHCP ou des serveurs relais sur chaque
segment

transforme les requtes multicast en de l'unicast

dfini par la RFC 1542

Cisco ICND1/CCENT (100-101)

alphorm.com

Rappel : interface cliente DHCP

(config-if)# ip address dhcp

Cisco ICND1/CCENT (100-101)

alphorm.com

IOS DHCP Server : mise en place

cration d'un pool d'adresses


(config)# ip dhcp pool pool-ID
(dhcp-config)#

pool-ID : chane de caractres identifiant le pool d'adresses

dfinition du sous-rseau support


(dhcp-config)# network 192.168.2.0 255.255.255.0

Cisco ICND1/CCENT (100-101)

alphorm.com

IOS DHCP Server : baux

dfinition de la dure de bail


(dhcp-config)# lease days hours minutes

Cisco ICND1/CCENT (100-101)

alphorm.com

IOS DHCP Server : paramtres

dfinition du/des routeur(s) par dfaut


(dhcp-config)# default-router adresse1 adresse2 ...

adresses du/des serveur(s) DNS


(dhcp-config)# dns-server adresse1 adresse2 ...

nom de domaine DNS


(dhcp-config)# domain-name name

Cisco ICND1/CCENT (100-101)

alphorm.com

Commandes d'information

informations d'tat de chacun des baux allous


# show ip dhcp binding

statistiques et intervales d'adresse d'un pool d'adresses


# show ip dhcp pool [poolname]

statistiques du serveur DHCP


# show ip dhcp server statistics

afficher les conflits


# show ip dhcp conflict

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

DHCP

fonctionnement

configuration du client

configuration du serveur

pool d'adresses

paramtres

dure de bail

Cisco ICND1/CCENT (100-101)

alphorm.com

Services IP

ACLs

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Introduction

ACLs standards

ACLs tendues

ACLs tendues : exemples

Description d'une ACL

ACLs nommes

Appliquer une ACL une interface

Commandes d'information

Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

Filtrer les accs

aux rseaux

au routeur lui mme

relativement :

adresse IP

source

destination

protocole

numro de port

Cisco ICND1/CCENT (100-101)

sur un trafic entrant ou sortant

analyses de manire squentielle


l'ordre des ACLs est donc
important
du plus prcis au plus gnrique

tout trafic est interdit par dfaut

alphorm.com

ACLs standards

uniquement sur les adresses IP source

(config)# access-list number {permit|deny} {host|source source-wildcard|any}

number : entre 1 et 99 ou 1300 et 1999

Exemple

interdire l'accs seulement tout les membres du rseau 192.168.1.0/24


ainsi qu' l'hte 192.168.2.10

(config)# access-list 1 deny 192.168.1.0 0.0.0.255


(config)# access-list 1 deny host 192.168.2.10

(config)# access-list 1 permit any


Cisco ICND1/CCENT (100-101)

alphorm.com

ACLs tendues

sur les adresses IP source, de destination, le protocole ou le numro


de port

(config)# access-list number {deny|permit} protocole source masque-source


[operateur [port]] destination masque-destination
[operateur [port [established][log]

oprateurs :

eq : gal

neq : diffrent de

gt : plus grand que

lt : plus petit que

number : entre 100 et 199 ou 2000 et 2699

Cisco ICND1/CCENT (100-101)

alphorm.com

ACLs tendues : exemples

interdire tout paquet IP destination de l'hte 192.168.2.10

(config)# access-list 101 deny ip any host 192.168.2.10

interdire tout segment TCP de port source supprieur 1023 et


destination du port 23 de l'hte 192.168.2.10

(config)# access-list 101 deny tcp any gt 1023 host 192.168.2.10 eq 23

interdire tout segment TCP destination du port 80 et en provenance


du rseau 192.168.10.0/24

(config)# access-list 101 deny tcp 192.168.10.0 0.0.0.255 any eq http

Cisco ICND1/CCENT (100-101)

alphorm.com

Description d'une ACL

Il est possible de dfinir une description d'ACL pour plus de clart

(config)# access-list 101 remark Description de l'ACL

Cisco ICND1/CCENT (100-101)

alphorm.com

ACLs nommes

Les ACLs numrotes sont complexe administrer ds que leur


nombre devient important et qu'elles deviennent complexes

il est impossible de les modifier

la seule solution tant de la supprimer et de la rcrire

Une ACL nomme est en revanche modifiable

(config)# ip access-list extended nom


(config-ext-nacl)# {deny|permit} protocole source masque-source ...

pour ajouter une rgle, il suffit d'utiliser la syntaxe des ACLs tendues
numrotes, sans "access-list number"

et d'utiliser la commande "no" pour la supprimer

Cisco ICND1/CCENT (100-101)

alphorm.com

Appliquer une ACL une interface


(config-if)# ip access-group {number|name} {in|out}

utiliser la commande "no" pour dsactiver l'ACL sur l'interface

Cisco ICND1/CCENT (100-101)

alphorm.com

Commandes d'information

afficher une ACL

# show access-lists [number|name]

afficher la configuration d'une interface

# show run interface FastEthernet 0/0

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Contrle des accs rseaux et routeur grce aux ACLs

diffrents types d'ACLs

cration

gestion

application une interface

interrogation

Cisco ICND1/CCENT (100-101)

alphorm.com

Services IP

NAT

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Introduction

Types de NATing

Rseau priv / publique

NAT statique

NAT Dynamique

NAT dynamique PAT

NAT dynamique PAT pour adresse publique unique

Commandes d'information

Cisco ICND1/CCENT (100-101)

alphorm.com

Introduction

Traduction d'adresse IP (Network Address Translation)

faire correspondre une adresse publique unique pour un rseau priv

le nombre d'adresses publiques tant limit

ex : dmarche de demande de bloc d'IP au RIPE NCC via OVH

RFC 1631 - Mai 1994

Cisco ICND1/CCENT (100-101)

alphorm.com

Types de NATing

statique

dynamique

faire correspondre une adresse publique une adresse prive

cr dynamiquement les translations dans un pool d'adresses publiques

PAT

translation base sur les ports TCP/UDP

Cisco ICND1/CCENT (100-101)

alphorm.com

Rseau priv / publique

Premire tape de tout type de nating

le NAT ne prenant effet que quand un paquet est rout de "l'intrieur"


vers "l'extrieur", ou inversement

il est donc ncessaire de dfinir cet "intrieur" et cet "extrieur"

Par interface

(config-if)# ip nat {inside|outside}

Cisco ICND1/CCENT (100-101)

alphorm.com

NAT statique

Faire correspondre une adresse publique une adresse prive

(config)# ip nat inside source static 192.168.1.10 201.55.4.8

Cisco ICND1/CCENT (100-101)

alphorm.com

NAT Dynamique

Les adresses publiques sont automatiquement choisies dans un pool


d'adresse

cration du pool d'adresses

(config)# ip nat pool POOL-NAT-LAN1 201.55.4.1 201.49.10.10 netmask 255.255.255.240

cration de l'ACL

(config)# access-list 1 deny 192.168.1.10


(config)# access-list 1 permit 192.168.1.0 0.0.0.255

activation du NAT

(config)# ip nat inside source list 1 pool POOL-NAT-LAN1


Cisco ICND1/CCENT (100-101)

alphorm.com

NAT dynamique PAT

ncessaire si le nombre d'adresses publique est plus faible que celui


d'adresses prives

translation du port source, afin d'identifier le client

ajouter simplement "overload" la configuration prcdente

(config)# ip nat inside source list 1 pool POOL-NAT-LAN1 overload

Cisco ICND1/CCENT (100-101)

alphorm.com

NAT dynamique PAT pour adresse publique unique

Configuration la plus courante sur les rseaux de petite dimension

une seule adresse IP fixe sur Internet par exemple

Dfinir un pool d'adresse n'est donc plus adapt

il suffira alors de se baser sur l'adresse de l'interface "outside"

(config)#ip nat inside source list 1 interface serial 0/0 overload

Cisco ICND1/CCENT (100-101)

alphorm.com

Commandes d'information

Afficher la table de translations

translations effectues en accord avec les rgles tablies

# show ip nat translations

Vrifier l'adresse des paquets reu sur un routeur

# debug ip paquet

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Configuration du NAT sur les routeurs Cisco

concept

fonctionnement

types de NAT

mise en place

NAT statique

NAT dynamique

PAT

Cisco ICND1/CCENT (100-101)

alphorm.com

Services IP

NTP

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Plan

Network Time Protocol

Activation du client NTP

Vrification

Cisco ICND1/CCENT (100-101)

alphorm.com

Network Time Protocol

synchronisation des horloges sur le rseau

prsent pour la premire fois en septembre 1985

dernire version : NTPv4

RFC 958

RFC 5905 - Juin 2010

indispensable pour une bonne lecture des logs

et donc un troubleshooting simple

Cisco ICND1/CCENT (100-101)

alphorm.com

Activation du client NTP

ncessite de spcifier un serveur NTP

ainsi qu'une version du protocole

(config)# ntp server 172.16.2.2 version 4

Cisco ICND1/CCENT (100-101)

alphorm.com

Vrification

Vrifier si l'horloge est synchronise

# show ntp status

Vrifier l'association un serveur de temps

# show ntp associations

Cisco ICND1/CCENT (100-101)

alphorm.com

Ce qu'on a couvert

Configuration d'un routeur IOS en tant que client NTP

et vrification

de l'tat de la synchronisation

de la configuration actuelle

Cisco ICND1/CCENT (100-101)

alphorm.com

Conclusion

Conclusion

Site : http://www.alphorm.com
Blog : http://www.alphorm.com/blog
Forum : http://www.alphorm.com/forum
Cisco ICND1/CCENT (100-101)

Nol Mac
Formateur et Consultant indpendant
Expert Unix et FOSS

Contact : alphorm@noelmace.com

alphorm.com

Ce qu'on a couvert

Merci tous et bientt.

Cisco ICND1/CCENT (100-101)

alphorm.com