Vous êtes sur la page 1sur 28

Taller # 4

Securing Layer 2 Switching

Integrantes:
Katiuska Criollo, Johnny Segarra, Byron Asencio, Luis Pilay, Boris De la Torre

Taller 4
Securing Layer 2 Switching

Parte 1: Configuracin Bsica de Switch

1. Configuracin del cableado entre los dispositivos como se


muestra en la topologa

2. Configuracin de nombres de los dispositivos, asignacin de


password al usuario enable y asignar password a las conexiones
de consola y vty, configuracin de direcciones ip segn plan de
direccionamiento ( en R1, S1 y S2)
R1
R1#show run
Building configuration...
Current configuration : 703 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
enable secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
!
!
!
!
!

!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
description Enlace al S1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
exec-timeout 5 0
password ciscoconpass
logging synchronous
login
!
line aux 0
!
line vty 0 4
exec-timeout 5 0
password ciscovtypass
login
!
!

!
end
S1
S1#show run
Building configuration...
Current configuration : 1207 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
enable secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
!
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14

!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
description VLan 1 S1
ip address 192.168.1.2 255.255.255.0
!
!
line con 0
password ciscoconpass
logging synchronous
login
exec-timeout 5 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
S2
S2#show run
Building configuration...
Current configuration : 1207 bytes
!
version 12.2

no service timestamps log datetime msec


no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
enable secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
!
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!

interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
description VLan 1 S2
ip address 192.168.1.3 255.255.255.0
!
!
line con 0
password ciscoconpass
logging synchronous
login
exec-timeout 5 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

3. Verificar conectividad bsica de la red


a. Realizar Ping desde la PC-A y PC-B a la interfaz Fa0/1 del R1
(192.168.1.1)

4. Realizar Ping desde la PC-A (192.168.1.10) a la PC-B (192.168.1.11)

Parte 2 : Configurando conexiones SSH

1. Generando llave RSA en S1 y S2

2. Verificando conectividad por medio de SSH al S1 desde la PC-A y mostrar


los usuarios conectados (show users)

3. Mostrar configuracin de equipos


S1
S1#show run

Building configuration...
Current configuration : 1434 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
enable secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
!
!
ip ssh authentication-retries 2
ip ssh time-out 90
no ip domain-lookup
ip domain-name ccnasecurity.com
!
username admin secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!

interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
description VLan 1 S1
ip address 192.168.1.2 255.255.255.0
!
!
line con 0
password ciscoconpass
logging synchronous
login
exec-timeout 5 0
!
line vty 0 4
exec-timeout 5 0
login local
transport input ssh
privilege level 15
line vty 5 15
login
transport input none
!
!
end
S2

S2#show run
Building configuration...
Current configuration : 1434 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
enable secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
!
!
ip ssh authentication-retries 2
ip ssh time-out 90
no ip domain-lookup
ip domain-name ccnasecurity.com
!
username admin secret 5 $1$mERr$.82qvoGUQIH4qvaicridz0
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13

!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
description VLan 1 S2
ip address 192.168.1.3 255.255.255.0
!
!
line con 0
password ciscoconpass
logging synchronous
login
exec-timeout 5 0
!
line vty 0 4
exec-timeout 5 0
login local
transport input ssh
privilege level 15
line vty 5 15
login
transport input none
!
!
end

Parte 3: Configurando Troncales Seguras y acceso a puertos


seguros
1. Configurando el switch S1 como el switch raiz

2. Configurar puertos troncales en S1 y S2

3. Cambiar la VLAN nativa para los puertos troncales en S1 y S2

4. Prevenir el uso de DTP en S1 y S2

5. Habilitar el control de tormenta de Broadcast

6. Habilitando PortFast en acceso a puertos para S1 y S2

Tarea 4: Configurar seguridad en puertos y desahabilitar los puertos no usados.


1. Grabar la Mac Address del Fa0/0 del R1

2. Configurar seguridad basica de puertos

3. Cambiar la mac del router y probar el ping a la 192.168.1.10

4. Configuracin de los dispositivos


R1

R1#show run
Building configuration...
Current configuration : 703 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
enable secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
description Enlace al S1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless

!
!
!
!
!
!
!
line con 0
exec-timeout 5 0
password ciscoconpass
logging synchronous
login
!
line aux 0
!
line vty 0 4
exec-timeout 5 0
password ciscovtypass
login
!
!
!
end
S1
S1#show run
Building configuration...
Current configuration : 1729 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S1
!
enable secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
!
!
ip ssh authentication-retries 2
ip ssh time-out 90
no ip domain-lookup
ip domain-name ccnasecurity.com
!
username admin secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
spanning-tree mode pvst
spanning-tree vlan 1 priority 0
!

interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 50
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
switchport mode access
switchport port-security mac-address 0000.F320.E502
spanning-tree portfast
!
interface FastEthernet0/6
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21

!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
description VLan 1 S1
ip address 192.168.1.2 255.255.255.0
!
!
line con 0
password ciscoconpass
logging synchronous
login
exec-timeout 5 0
!
line vty 0 4
exec-timeout 5 0
login local
transport input ssh
privilege level 15
line vty 5 15
login
transport input none
!
!
end
S2
S2#show run
Building configuration...
Current configuration : 1628 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
enable secret 5 $1$mERr$WvpW0n5HghRrqnrwXCUUl.
!
!
!

ip ssh authentication-retries 2
ip ssh time-out 90
no ip domain-lookup
ip domain-name ccnasecurity.com
!
username admin secret 5 $1$mERr$.82qvoGUQIH4qvaicridz0
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 50
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
switchport mode access
spanning-tree portfast

spanning-tree bpduguard enable


!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface Vlan1
description VLan 1 S2
ip address 192.168.1.3 255.255.255.0
!
!
line con 0
password ciscoconpass
logging synchronous
login
exec-timeout 5 0
!
line vty 0 4
exec-timeout 5 0
login local
transport input ssh
privilege level 15
line vty 5 15
login
transport input none
!
!
end

Vous aimerez peut-être aussi