Vous êtes sur la page 1sur 5

AVALIACAO UNIDADES 1

1. Analise a Figura 1 a seguir e assinale a alternativa correta:

a. O principal item o processamento, pois gera o resultado.


b. Os dados de entrada tm que ser obrigatoriamente fornecidos pelos usurios.
c. Os dados de sada no so correspondentes, via de regra, s informaes solicitadas.
d. Algoritmos no se relacionam com o processo apresentado na figura.
e. A figura representa os princpios de organizao dos dados em algoritmos.
2. Quando se trata de Gesto de Projetos, h uma frmula conhecida como PERT (Program Evaluation and
Review Technique), que auxilia as equipes no clculo do tempo estimado para concluso de uma
atividade. Ela considera os cenrios: otimista (O), pessimista (P) e o mais provvel (MP). A frmula a
seguinte:

Ao elaborar o algoritmo, algumas variveis tero de ser declaradas. Assinale a alternativa que traz as
variveis e o seu respectivo tipo de dado, corretamente:
a. pert, O, P, MP: real
b. pert, O, P, MP: inteiro
c. O, P, 4, 6, PERT: inteiro
d. num4, num6, mdia: real
e. media, pert, O, P: caractere
3. Para o problema do clculo do tempo com a frmula PERT, correto afirmar que:
a. as variveis podem ser trocadas pelo tipo de dado inteiro sem prejuzos ao programa.
b. o comando leia (atividade) pode ser suprimido, sem prejuzos ao propsito do programa.
c. os parnteses utilizados na frmula para os clculos do algoritmo podem ser suprimidos sem intervir
no resultado da operao.
d. o tipo de dado real o mais indicado para a declarao das variveis especificadas no algoritmo, em
funo de permitir, sem prejuzos, os clculos necessrios apresentao do resultado.
e. a sequncia apresentada para a execuo do algoritmo no est coerente com a operao realizada e o
seu respectivo resultado.

5. Com base no algoritmo a seguir, identifique os tipos de dados das variveis declaradas e assinale a
alternativa correspondente:

a. inteiro, caractere, lgico e real.


b. caractere, inteiro, real e lgico.
c. string, caractere, char e lgico.
d. real, inteiro, caractere e lgico.
e. lgico, real, inteiro e caractere.

AVALIACAO UNIDADES 2
1.

a.

Suponha que em uma cidade a empresa que faz o controle e tratamento de gua e esgoto precisa
controlar o nvel de gua das caixas dagua dos bairros, para que os controladores possam identificar
se a caixa dagua est cheia, vazia, transbordando ou sem vazo. Para tal, foi proposta a seguinte
regra para verificao.
Regra: Verificar se o valor exibido na tela igual a 1. Se sim, exibe a mensagem Caixa dagua cheia..
Seno, executar a condio que vem expressamente na sequncia.
Sobre o enunciado anterior, responda: a regra para verificao pode ser representada pela estrutura
imediatamente expressa na alternativa:
se (N =1) ento

b. se (N =1) entao
escreval (Caixa dagua cheia.)
fimse
c. se (condio 1) entao
comandos 1 para condio verdadeira
senao
comandos 2 para condio falsa
fimse

d. se (tipo = 4) entao
escreval("Telefone:")
leia (telefone)
fimse
e. se (condio 1) entao
comandos 1 para condio verdadeira
senao
2. Assinale V ou F:
a. V, V, V.
b. V, V, F.
c. F, F, F.
d. F, V, F.
e. V, F, F.
3.Analise a figura a seguir e assinale:

Refere-se a:
a. Estrutura condicional simples sequencial.
b. Estrutura de seleo.
c. Estrutura condicional encadeada.
d. Estrutura condicional sequencial.
e. Estrutura condicional composta sequencial.
4. Analise a figura a seguir e assinale:

Refere-se a:

a. Estrutura condicional composta sequencial.


b. Estrutura de seleo.
c. Estrutura condicional sequencial.
d. Estrutura condicional encadeada.
e. Estrutura condicional simples sequencial.
5. O texto a seguir apresenta a anlise de qual estrutura?
a. Estrutura condicional encadeada.
b. Estrutura condicional composta sequencial e encadeada.
c. Estrutura condicional sequencial.
d. Estrutura de seleo.
e. Estrutura condicional simples sequencial.

UNIDADE 3 AVALIACAO
1.

Analise a figura e assinale a alternativa que apresenta o tipo de estrutura de repetio a que se refere:

a. Repetio com teste no final.


b. Repetio controlada por varivel.
c. Estrutura de Seleo.
d. Repetio com teste no incio.
e. Estrutura de Deciso.
2. Analise as afirmaes e assinale a alternativa que representa a sequncia correta quanto sua veracidade:
I. A varivel de controle assume a funo de contador da estrutura.
II. possvel otimizar cdigos utilizando esta estrutura sem ter de fazer testes no final.
III. Quanto ao comando passo, obrigatrio.
Escolha uma:
a. V, V, F.
b. V, V, V.
c. V, F, V.
d. F, V, F.
e. F, F, F.
3

Quando analisamos a estrutura de repetio controlada por varivel observamos que a varivel de
controle pode ser declarada ou no. O que podemos concluir da definio dada pelos autores
Manzano e Oliveira (2012, p. 103)?

Ser executado o conjunto de instrues entre os comandos para e fim_para, sendo a varivel i (varivel de
controle) inicializada com o valor 1 e incrementada de mais 1 pelo comando passo at o valor 5. Esse tipo de
repetio pode ser utilizado todas as vezes que se tiver a necessidade de repetir trechos finitos, quando se
conhece o valor inicial e o valor final.
a. O comando passo obrigatrio.
b. O valor padro para incremento sem o comando passo 2.
c. No obrigatria a atribuio de valores para a varivel de controle.
d. O comando passo mais utilizado para decrementos.
e. O comando passo no obrigatrio.

4. Analise as afirmaes e assinale a alternativa que representa a sequncia correta quanto sua veracidade:
I. A varivel de controle, no caso, chamamos de i no exemplo, iniciada com o valor mnimo pretendido
antes da linha de comando para (i = 1).
II. Na linha de comando para, h a comparao do valor da varivel de controle com o limite estabelecido
(at).
III. Se o valor comparado for menor ou igual ao valor do limite, ento as instrues que esto dentro do bloco
de comandos para sero executadas repetidamente at que se atinja o valor limite.
a. F, V, V.
b. F, F, F.
c. V, V, V.
d. F, V, F.
e. F, F, V.
5. O conjunto de comandos para...de...at...passo..faca..fimpara um(a):
a. Decremento.
b. Estrutura de deciso.
c. Estrutura de seleo.
d. Repetio.
e. Funo.