Vous êtes sur la page 1sur 13

Herramientas para la productividad

EXCEL 2007

SEMANA 5

TABLA DE CONTENIDO EXCEL 2007

TABLA DE CONTENIDO ...............................................................................................................2


4. NCLEO TEMTICO 4. ..............................................................................................................3
Funciones lgicas aplicadas a la evaluacin y anlisis de una base de datos. ..........3
4.1. Objetivo especfico ...............................................................................................................3
4.2. Competencia ...........................................................................................................................3
4.3. Desarrollo temtico .............................................................................................................3
4.3.1 introduccin ........................................................................................................................3
4.3.2 Definicin y aplicacin de funciones lgicas ............................................................4

La funcin SI..................................................................................................................................... 4
Prctica 1................................................................................................................................................... 4
La funcin NO .................................................................................................................................. 6
La funcin Y ...................................................................................................................................... 6
La funcin O ..................................................................................................................................... 7

3.3 Funciones anidadas ..............................................................................................................8

[ POLITCNICO GANCOLOMBIANO EN ALIANZA CON WHITNEY INTERNATIONAL SYSTEM ]

4. NCLEO TEMTICO 4.
Funciones lgicas aplicadas a la evaluacin y anlisis de
una base de datos.
Es posible lograr que Microsoft Excel se convierta en un excelente colaborador a la hora de
tomar decisiones, cuando se manejan grandes volmenes de datos.

4.1. Objetivo especfico


Impartir el conocimiento necesario para el uso de funciones lgicas y explicar diversas
aplicaciones en bases de datos.

4.2. Competencia
Reconocer y aplicar las funciones lgicas de la hoja de clculo que permiten analizar una base de
datos y presentar de forma dinmica los datos ante el usuario final de la informacin, haciendo
fcil y entendible su gestin.

4.3. Desarrollo temtico


4.3.1 introduccin
Son muchos los casos en que se deben tomar decisiones que dependen del valor del dato
que se est manejando. Cuando se est comprando un regalo, la eleccin se hace teniendo
en cuenta decisiones tomadas con base en caractersticas como el gnero (mujer u hombre)
y la edad (beb, nio, adolescente, adulto). La informacin generada del ejercicio profesional
o laboral tiene implcita la toma de decisiones de este estilo.

[ HERRAMIENTAS PARA LA PRODUCTIVIDAD ]

4.3.2 Definicin y aplicacin de funciones lgicas


Las funciones son procedimientos preestablecidos que tienen como caractersticas las de
tener un nombre especfico y exigir una forma de uso estandarizado (sintaxis). Microsoft
Excel cuenta con una lista de funciones bastante extensa entre las cuales estn las llamadas
funciones lgicas. Las funciones lgicas del Excel permiten tomar decisiones de tipo lgico,
dependiendo de los datos que evalen.

La funcin SI
=SI(condicin; accin 1; accin 2)
La funcin SI evala la condicin dada, si es verdadera ejecuta la accin 1, si la condicin es
falsa ejecuta la accin 2.
Condicin es cualquier expresin que pueda evaluarse como Verdadero o Falso.
Accin1 es el valor que se devolver si la prueba lgica es Verdadero. Si se omite devolver
VERDADERO.
Accin2 es el valor que se devolver si la prueba lgica es Falso. Si se omite devolver
FALSO

Prctica 1.
A los vendedores de una empresa les dan una bonificacin que depende del volumen de
ventas: si un empleado vendi ms de 100 artculos, se bonifica con $500, pero si no logr esa
meta, se bonifica con $250.
Ingrese esta informacin:

[ POLITCNICO GANCOLOMBIANO EN ALIANZA CON WHITNEY INTERNATIONAL SYSTEM ]

Para saber cunto se dar de bonificacin a cada empleado, se puede llevar la decisin a
estos trminos:
=SI(la cantidad vendida es mayor que 100 ; pague 500 ; pague 250)
En trminos de Excel, para el empleado Carlos P., se debe escribir en la celda C2 la funcin
as:

En la celda C2 aparece el valor de bonificacin de $500, pues vendi ms de 100 artculos.


Copie la frmula para los dems empleados usando el control de relleno:

[ HERRAMIENTAS PARA LA PRODUCTIVIDAD ]

Recuerde,
>
<
>=
<=
<>

Mayor que
Menor que
Mayor o igual que
Menor o igual que
Diferente de

Algunos ejemplos con los mismos datos:

Ejemplo

Resultado

=SI( A2 = A3 ; mismo nombre; diferente nombre)

diferente nombre

=SI(C5 = C6; igual bonificacin;diferente bonificacin)

igual bonificacin

=SI(B2 < B3; B2; B3)

Jos M.

=SI(B4*10 > 1000; vendi mucho;vendi poco)

vendi mucho

=SI(B4 > 120 ; C4 + 100 ; C4 -100)

600

La funcin NO
=NO(condicin)
Esta funcin invierte el resultado (verdadero o falso) de la condicin.
Por ejemplo =NO(2+2=4) dar como resultado FALSO pues la condicin es verdadera.
Es una funcin de poco uso.

La funcin Y
=Y(condicin 1, condicin 2, .)
La funcin Y devuelve VERDADERO si todas las condiciones son verdaderas, o FALSO si una o
ms condiciones son falsas.

[ POLITCNICO GANCOLOMBIANO EN ALIANZA CON WHITNEY INTERNATIONAL SYSTEM ]

Para evaluar si Carlos P. y Mara J. vendieron ms de 100 artculos:

Efectivamente, ambos vendieron ms de 100 artculos.


Para determinar si todos lograron vender ms de 80 artculos:

Es FALSO pues Lus Z. vendi solo 78 artculos.

La funcin O
=O(condicin 1, condicin 2, .)
La funcin O devuelve VERDADERO si cualquiera de las condiciones son verdaderas, o FALSO
si todas las condiciones son falsas.
Para evaluar si Carlos P o Jos M vendieron menos de 100 artculos:

[ HERRAMIENTAS PARA LA PRODUCTIVIDAD ]

Efectivamente uno de los dos vendi menos de 100 artculos (Verdadero).

3.3 Funciones anidadas


Algunas situaciones exigen que una funcin se deba utilizar como uno de los argumentos de
otra funcin. Esto es lo que se conoce como anidamiento.
Considere la siguiente situacin: la bonificacin para los empleados del ejemplo ahora tiene
las siguientes condiciones:
Si vendi menos de 80 artculos, no hay bonificacin, $0.
Si menos de 100 artculos se bonifica con $250.
Si vendi 100 artculos o ms se bonifica con $500
La funcin SI es de la forma =SI(condicin; accin 1; accin 2)
Lo que debe hacer es usar la funcin SI con anidamiento, reemplazando la accin 2 (cuando
la condicin es falsa) por otra funcin SI:
=SI( B2 < 80 ; 0 ; SI( B2 <100; 250; 500))
Si el valor de B2 no es menor que 80, se evala el SI interno (anidado).

[ POLITCNICO GANCOLOMBIANO EN ALIANZA CON WHITNEY INTERNATIONAL SYSTEM ]

Copie la funcin en las dems celdas:

Luis Z., no recibe bonificacin por vender menos de 80, la primera condicin
Jos M y Pedro R reciben $250, pues cumplen la segunda condicin
Carlos P y Mara J reciben $500, pues cumplen la tercera condicin.
Se decide una condicin ms para la bonificacin:
Si vendi menos de 80 artculos, no hay bonificacin.
Si menos de 100 artculos se bonifica con $250.
Si vendi entre 100 y 120 artculos se bonifica con $500
Si vendi ms de 120 artculos se bonifica con $700.
Esta situacin requiere anidar una funcin SI dentro de la funcin SI anidada:

=SI(B2<80 ; 0 ; SI(B2< 100 ; 250 ; SI( B2 < 120 ; 500 ; 700)))


Analice la forma como se dise esta funcin anidada.
El resultado, aplicando la funcin a todos los empleados:

[ HERRAMIENTAS PARA LA PRODUCTIVIDAD ]

No solo es posible anidar funciones lgicas, se pueden anidar todo tipo de funciones siempre
y cuando se haga de manera coherente.
Antes de terminar esta unidad, ordene los datos de la tabla segn el nombre del empleado
para que se haga ms sencillo localizar un vendedor:
1. Seleccione los datos que se quieren ordenar:

Tenga en cuenta que, aunque se quiere ordenar por la columna de empleado, es importante
que los datos asociados a cada empleado (cantidad vendida y bonificacin) se reubiquen
tambin al ordenar. Es por eso, que no solo se seleccion la columna empleado sino tambin
todos los dems datos relacionados.
2. Seleccione la opcin Orden Personalizado del comando Ordenar y Filtrar en el men
INICIO, para tener acceso al cuadro de dilogo Ordenar

10

[ POLITCNICO GANCOLOMBIANO EN ALIANZA CON WHITNEY INTERNATIONAL SYSTEM ]

Aparece el cuadro de dialogo Ordenar:

Esta opcin permite varios niveles de ordenacin, que se explicarn ms adelante.


Por ahora observe que la seccin Ordenar por muestra un listado con los nombres de
columna dados a la tabla y sugiere que el orden sea ascendente (Criterio de ordenacin de la
A a la Z):

Como se quiere ordenar por empleado, slo bastar con hacer clic en el botn aceptar:

[ HERRAMIENTAS PARA LA PRODUCTIVIDAD ]

11

Si se quiere ordenar por Cantidad vendida:


1. Seleccione los datos a ordenar:

2. Seleccione la opcin Orden Personalizado del comando Ordenar y Filtrar en el men


INICIO, para tener acceso al cuadro de dilogo Ordenar.
3. Seleccione la columna CANTIDAD VENDIDA en la seccin Ordenar por:

12

[ POLITCNICO GANCOLOMBIANO EN ALIANZA CON WHITNEY INTERNATIONAL SYSTEM ]

4. Haga clic en el botn Aceptar:

Ahora el empleado Lus Z aparece de primero, pues el que menos vendi, mientras que Mara
J pas al final por la razn contraria.

[ HERRAMIENTAS PARA LA PRODUCTIVIDAD ]

13