Vous êtes sur la page 1sur 20

Universidade Federal Rural do Semi-rido

Departamento de Cincias Exatas e Naturais


Programao de Computadores| BCT Eng Produo

Aula 02
Reviso de Algoritmos

Prof. Dnis Freire

Algoritmo
Histrico

Algoritmo de Euclides (300 a.c.)


Calcular o MDC de um nmero atravs de uma sequncia de
passos que poderia ser executado com lpis e papel

Abu Abdullah Muhammad bin Musa al-Khwarizmi (Sc. 9


d.c.)
Astrlogo rabe
De numero Indorum (Arte Indu de Calcular)
Traduo:
al-Khwarizmi = Algoritmo

Algoritmo
Definio

Conjunto predeterminado e bem definido


de regras e processos destinados
soluo de um problema, com um
nmero finito de etapas

Algoritmo

Entrada

Processamento

Sada

Incio
Verifica se o interruptor est desligado;
Procura uma lmpada nova;
Pega uma escada;
Leva a escada at o local;
Posiciona a escada;
Sobe os degraus;
Para na altura apropriada;
Retira a lmpada queimada;
Coloca a lmpada nova;
Desce da escada;
Aciona o interruptor;
Se a lmpada no acender, ento:
Retira a lmpada queimada;
Coloca outra lmpada nova
Joga a lmpada queimada no lixo;
Seno
Tarefa terminada;
Fim Se
Guarda a escada;
Fim

Controle de Fluxo

Controle de fluxo de execuo a maneira


de organizar a sequncia em que as
instrues so executadas em um
algoritmo. Ou seja, consiste em definir em
que ordem as instrues sero executadas
sobre os dados

Estrutura Sequencial

Comando
01

Comando
02

Comando
...

Comando
N

Comando
03

Estrutura Sequencial

A estrutura sequencial aquela em que os


comandos do algoritmo so executados em
uma sequncia pr-estabelecida. Cada
comando, nessa estrutura, s executa aps
o trmino do anterior.

Exemplo
Incio
Receba a nota da prova1;
Receba a nota de prova2;
Some todas as notas;
Divida o resultado por 2;
Mostre o resultado da diviso;
Fim

Estruturas de Deciso

Verdadeiro

Se

Falso

Estruturas de Deciso

Condio!

Incio
...
Desce da escada;
Aciona o interruptor;
Se a lmpada no acender, ento:
Retira a lmpada queimada;
Coloca outra lmpada nova
Joga a lmpada queimada no lixo;
Seno
Tarefa terminada;
Bloco
falso
...
Fim

Bloco
verdadeiro

Estruturas de Deciso Simples


Incio
Se Condio, ento:
Comando 01;
Fim Se;
Comando 02;
...
Fim

Verdadeiro

Condio

Comando 01

Comando 02

Estruturas de Deciso Composta


Incio
Se Condio, ento:
Comando 01;
Seno:
Comando 02;
Fim Se;
Comando 03;
...

Verdadeiro

Condio

Falso

Comando 02

Comando 01

Comando 03

Estruturas de Deciso Encadeadas


Incio
Se Condio 01, ento
Se Condio 02 ento
Comando 01;

Comando N;
Fim Se
Seno
Se Condio 03, ento
Comando 01;

Comando N;
Seno
Se Condio 04, ento
Comando 01;

Comando N;
Seno
Comando 01;
Fim Se
Comando 01;
Fim Se
Fim Se
Fim

Exemplo
inicio
escreva ("Digite o valor da primeira nota:")
leia (nota1)
escreva("Digite o valor da segunda nota:")
leia (nota2)
media (nota1 + nota2)/2
escreva ("A mdia =", media)
se media >= 7 ento
escreva ("Aluno aprovado!")
fim se
Fim algoritmo

Estruturas de Repetio

Condio

Comando N

Comando X

Estruturas de Repetio
Incio
...
Enquanto Condio 01 Faa
Comando 01;
Comando 02;

Comando N;
Fim Enquanto
Comando S;
...
Fim

Condio

Comando 01

Comando 02

Comando N

Comando S

Estruturas de Repetio
Incio
...
Repita
Comando
Comando

Comando
At que
Fim Repita
Comando S;
...
Fim

01;
02;
N;
Condio 01

Comando 01

Comando 02

Comando N

Condio

Comando S

Exemplo
inicio
num 1
enquanto num > 0 faca
leia(num)
escreva(num^2)
fim enquanto
escreva("Voc digitou um valor negativo")
Fim algoritmo