Vous êtes sur la page 1sur 2

MAT 146 Introduo Lgica de Programao

Algoritmos Exerccios de Fixao

Estrutura de Controle Seqencial


1. Faa um algoritmo que receba o salrio-base de um funcionrio, calcule e mostre o salrio a receber,
sabendo-se que esse funcionrio tem gratificao de 5% sobre o salrio-base e paga imposto de 7% sobre
o total.
2. Faa um algoritmo que receba o ano de nascimento de uma pessoa e o ano atual, calcule e mostre:
a) a idade dessa pessoa
b) quantos anos ela ter em 2005.

Estrutura de Controle Condicional (ou de Seleo)


3. Faa um algoritmo em pseudocdigo que calcule a mdia ponderada de um aluno, a partir de suas 3
notas obtidas no curso, sabendo-se que a primeira avaliao tem peso 2, a segunda tem peso 4 e a terceira
tem peso 4. Mostre, ao final, a mensagem : A MEDIA FINAL DE ... FOI ... . Informar tambm se o aluno foi
aprovado, mostrando a mensagem APROVADO caso a nota final seja maior ou superior a 7,0.
4. Elabore um algoritmo usando notao de fluxogramas que verifique se um dado nmero inteiro positivo
PAR ou MPAR.
5. Modifique o algoritmo da mdia do aluno para informar:
APROVADO ............ caso a nota final esteja no intervalo [10, 7]
RECUPERAO...... caso a nota final esteja no intervalo [5, 7)
REPROVADO .......... caso a nota final esteja no intervalo [0, 5)
6. Faa um algoritmo que leia 2 valores numricos e um smbolo. Caso o smbolo seja um dos relacionados
abaixo efetue a operao correspondente com os valores. Ateno para a diviso por 0!
+
-
*
/

operao de soma
operao de subtrao
operao de multiplicao
operao de diviso

7. Dados 3 valores A, B, C, verifique se podem ser valores de lados um tringulo e, se for, determine se o
tringulo equiltero, issceles ou escaleno.
8. Sejam 3 nmeros distintos A, B, C. Coloque-os em ordem crescente, utilizando seleo encadeada (ou
aninhada).

MAT 146 Introduo Lgica de Programao

Solues
1.
Soluo 1:

Soluo 2:

salBase, salReceber, grat, imp: real

salBase, salReceber, Imp: real

Inicio
Leia(salBase)
Grat salBase * 5/100
SalReceber salBase +grat imp
Imp SalReceber * 7/100
SalReceber SalReceber imp
Escreva (salReceber)
Fim
m

Inicio
Leia(salBase)
SalReceber (salBase * 5/100 )
Imp SalReceber * 7/100
SalReceber SalReceber imp
Escreva (salReceber)
Fi

2.
ano_atual, ano_nascimento, idade_atual, idade_2005: inteiro
Inicio
Leia (ano_nascimento, ano_atual)
Idade_atual ano_atual - ano_nascimento
Idade_2005 2005 - ano_nascimento
Escreva (idade_atual)
Escreva (idade_2005)
Fim
3.
aluno: caracter;
nota1, nota2, nota3, media: real;
p1, p2, p3: inteiro;
Inicio
p1 2;
p2 4;
p3 4;
Leia (aluno);
Leia (nota1, nota2, nota3);
media (nota1 *p1 + nota2 * p2 + nota3 * p3)/10
Escreva (a media de , aluno, foi , media);
Se (media >= 7,0) ento
Escreva (aprovado);
Fim se
Fim

5.
aluno: caracter;
nota1, nota2, nota3, media: real;
Inicio
Leia (aluno);
Leia (nota1, nota2, nota3);
media (nota1 *0.2 + nota2 * 0.4 + nota3 * 0.4
Escreva (a media de , aluno, foi , media);
Se (media >= 7,0) ento
Escreva (aprovado);
seno
Se (media < 7,0 e media >= 5,0) ento
Escreva (recuperao);
seno
Escreva (reprovado);
Fim se;
Fim se;
Fim

inicio

4.
Num

Num mod 2 = 0

V
Num, eh par

Num,
eh impar

Fim
6.
num1, num2 : real;
operador: caracter;
Inicio
Leia (num1, num2);
Leia (operador);
Escolha operador
caso +: escreva (num1 + num2);
caso -: escreva (num1 num2);
caso *: escreva (num1 * num2);
caso /: Se num2 <>0 ento
escreva (num1/num2);
seno
escreva(diviso indefinida)
fim se
fim escolha;