Vous êtes sur la page 1sur 12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

ACCEUIL

RSEAUX

DVELOPPEMENT APPS

c#

SCURIT

SYSTMES

BASE DE DONNES

DVELOPPEMENT WEB

CONCEPTION

ASTUCES

New
1-CrationdeslogicielsWindows:Prsentation

Linux

Configurerleficherdeconfiguration

COURS : LE RELAIS DE TRAMES (FRAME RELAY)


EN DTAILS

Eng. Reda

10:25

Bonjour et bienvenue sur coursnet,aujourdhuion va vous prsenter un cours qui


parle du frame relay en dtails ...
Catgorie de cours : Rseau informatique , ccna
Sujet de cours : FRAME RELAY en dtails

FRAME RELAY (RELAIS DE TRAMES)

http://www.coursnet.com/2014/11/cours-frame-relay.html

1/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

Frame Relay est un protocole de rseau tendu qui agit au niveau des couches
physique et liaison de donnes du modle OSI. Ce protocole est utilis par les
fournisseurs daccs pour transmettre des signaux-vocaux et numriques entre
rseaux locaux par lintermdiaire dun rseau tendu.
Frame Relay est un protocole de rseau tendu trs rpandu car il est de faible cot
par rapport aux lignes ddies et dune grande exibilit.
A la n des annes 70, des sites distants taient gnralement relis en utilisant le
protocole X.25. Ce protocole permettait dobtenir une connexion rseau trs able
sur des infrastructures cbles non ables grce un contrle de ux et derreurs.
Frame Relay, le remplaant de X.25, demande moins de temps de traitement que X.25
car il ne fournit pas de corrections derreurs.
La propagation des donnes informatiquesest donc trs rapide.Lorsque Frame Relay
est utilis pour connecter des rseaux locaux, le DTE sur chacun des rseaux est un
routeur, le commutateur Frame Relay est un DCE .

CIRCUITS VIRTUELS

En Informatique , un circuit virtuel dsigne une connexion logique entre deux DTE
par un rseau Frame Relay . On distingue deux types de circuits virtuels :
Le circuit virtuel commu (SCV)
Le circuit virtuel permanent (PVC)
http://www.coursnet.com/2014/11/cours-frame-relay.html

2/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

Un circuit virtuel peut passer par un nombre quelconque de commutateurs du rseau


Frame Relay.Un circuit virtuel est identi par un indicateur de connexion de liaison de
donnes appel DLCI . Il est gnralement attribu par le fournisseur de service
Frame Relay et a uniquement une signication locale.
Le DLCI est stock dans le champ dadresse de chaque trame indiquant ainsi o la
trame doit tre achemine. La valeur dun DLCI varie entre 16 et 1007.
Le rseau Frame Relay est statistiquement multiplex. Cela signie quil ne
transmet quune trame la fois, mais que plusieurs connexions logiques peuvent
coexister sur la mme ligne physique. Ainsi, chaque point dextrmit ne ncessite
quune ligne daccs et une interface.

FRAME RELAY ET L'ENCAPSULATION


Frame Relay reoit un paquet de la couche rseau . Il lui adjoint un champ dadresse
et une somme de contrle. Finalement, des champs dindicateur de dbut et de n de
trame sont ajouts. La trame est alors passe la couche physique.
Le champ dadresse contient le DLCI (les FECN , BECN et DE ). La somme de
contrle est calcule puis insre dans la trame par la source. Le destinataire
recalcule le FCS . Si les rsultats sont identiques, il traite la trame rseau , sinon il
labandonne.

TOPOLOGIES FRAME RELAY


On distingue trois types de topologie rseau :
En toile
A maillage global
A maillage partiel

FRAME RELAY ET LA MAPPAGE DES ADRESSES


An denvoyer des donnes informatiques laide du protocole Frame-Relay, le
routeur doit connaitre la relation entre le DLCI local et ladresse de couche 3 de la
destination.
Il existe deux types de mappage :
Mappage dynamique
http://www.coursnet.com/2014/11/cours-frame-relay.html

3/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

Mappage statique
Le mappage dynamique utilise linverse ARP pour rsoudre ladresse IP du saut
suivant en une valeur DLCI locale. Il stocke ces informations dans sa table de
mappage.
Pour voir le contenu de cette table :show frame-relay map.
Sur les routeurs Cisco lARP inverse est activ par dfaut.Le mappage statique est
utilis lorsquun routeur ne prend pas en charge linverse ARP ou quun rseau
Frame-Relay est constitu dune topologie en toile.

INTERFACE DE SUPERVISION LOCALE (LMI)


LMI (Local Management Interface) est un mcanisme de test dactivit qui fournit
des informations sur les connexions Frame Relay entre le routeur DTE et le switch
Frame Relay (DCE). Si le rseau ne fournit pas les informations demandes, le routeur
peut considrer la connexion comme coupe.
Le commutateur et le routeur doivent utiliser le mme LMI. Il existe dirents types
dinterfaces LMI, incompatibles entre elles :
Cisco

Ansi

q933a

115days

Depuis lIOS Cisco 11.2, le routeur dtecte automatiquement la LMI utilise par le
commutateur et congure son interface en fonction.On congure le LMI avec la
commande :
http://www.coursnet.com/2014/11/cours-frame-relay.html

4/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

frame-relay lmi-type [cisco | ansi |q933]

UTILISATION DU LMI DE lARP INVERSE POUR LE MAPPAGE DES


ADRESSES
Le routeur (DTE) se connecte au rseau Frame-Relay et envoie une LMI. Le rseau
rpond par un message dtat LMI donnant des informations sur les circuits virtuels
congurs sur la liaison.
Le routeur doit alors mapper ces circuits virtuels des adresses de couche 3. Pour ce
faire, il envoie un message ARP inverse sur chaque circuit virtuel. Il peut alors
eectuer le mappage. Il prote aussi lors de lenvoi de son message pour envoyer son
adresse rseau an que le routeur distant puisse aussi eectuer son propre
mappage.

CONFIGURATION DE BASE FRAME RELAY (MAPPAGE


DYNAMIQUE)
Pour congurer une interface srie avec le protocole Frame Relay :
R1(cong)#interface serial 0/0
R1(cong-if)#ip address ad IP masque reseau
On congure lencapsulation :
R1(cong-if)#encapsulation frame-relay [ietf | cisco]
Rappelons que le type dencapsulation Frame Relay par dfaut est cisco . Le type
dencapsulation ietf sutilise lorsque le routeur distant nest pas cisco. Les routeurs
dextrmit doivent utiliser la mme encapsulation frame relay. Finalement la
conguration du lmi est automatique, donc facultative.
Pour vrier la conguration :
R1(cong)# show interfaces serial 0/0

CONFIGURATION D'UN MAPPAGE STATIQUE FRAME RELAY


Dans ce cas on tablit manuellement le mappage entre ladresse rseau du routeur
distant et le numro DLCI local.
Dsactiver linverse-map :
R1(cong-if)# no frame-relay inverse-arp
R1(cong-if)# frame-relay map ad IP numero DLCI [broadcast|cisco|ietf ]
Remarques :
Il faut utiliser ietf si le routeur auquel on se connecte nest pas de type
http://www.coursnet.com/2014/11/cours-frame-relay.html

5/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

cisco.
Le rseau Frame Relay est un rseau informatique NBMA (nonbroadcast multiaccess). Cela signie quil ne prend pas en charge par
dfaut la diusion et la multidiusion. Lors de lutilisation de protocoles de
routage, le mot-cl broadcast permet cette diusion ou multidiusion sur le
circuit virtuel permanent.

DCOUPAGED'HORIZON
Un rseau FrameRelay est de type NBMA et possde gnralement une topologie
en toile. Un protocole de routage vecteur de distance utilise la technique du
dcoupage dhorizon pour viter les boucles de routage.
Rappel :
le dcoupage dhorizon empche quune mise jour de routage reue sur une
interface physique ne soit retransmise par la mme interface. Dans le cas dun rseau
toile cela signie que les mises jour ne peuvent pas tre achemines sur tout le
rseau informatique .
Plusieurs solutions se prsentent :
Dsactivation du dcoupage dhorizon

Topologie maillage global

Utilisation de sous-interfaces

FRAME RELAY ET LES SOUS-INTERFACES


Frame Relay peut partitionner une interface physique en plusieurs interfaces virtuelles
ou sous-interfaces, chacune est associe un circuit virtuel permanent. Une sous
interface peut tre congure en mode point point ou multipoint.
Point point :
Une sous-interface point point tablit une connexion par circuit virtuel permanent
une interface physique ou une sous-interface dun routeur distant.
Chaque paire de routeurs point point rside sur son propre rseau informatique et
chaque sous-interface point point ne dispose que dun DLCI . Dans ce cas, le
dcoupage dhorizon nintervient pas.
http://www.coursnet.com/2014/11/cours-frame-relay.html

6/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

Multipoint :
Une seule sous-interface tablit plusieurs connexions de circuit virtuel permanent
plusieurs interfaces physiques ou sous-interfaces sur des routeurs distants. Tous les
circuits virtuels multipoint appartiennent au mme sous rseau. Dans ce cas, le
dcoupage dhorizon intervient.
La commandeencapsulation frame-relaysapplique linterface physique, les autres
lments de conguration sappliquent (ad IP, DLCI) aux sous-interfaces.

CONFIGURATION DE SOUS-INTERFACES FRAME RELAY POINT A


POINT point
Prenons lexemple cidessous et congurons linterface srie S0 du routeur R1.
Sur linterface physique,
On indique le type dencapsulation :
R1(cong-if)# encapsulation frame-relay
On congure alors les sous-interfaces logiques en indiquant le numro de DLCI pour
des raisons dorganisation.
Premire sous interface logique :
R1(cong-if)# int S0.102 point-to-point
On indique alors son adresse IP ainsi que son DLCI :
R1(cong-if)# ip address 10.1.1.2 255.255.255.252
R1(cong-if)# frame-relay interface-dlci 102
Seconde sous interface logique :
R1(cong-if)# int S0.103 point-to-point
On indique alors son adresse IP ainsi que son DLCI :
R1(cong-if)# ip address 10.1.1.5 255.255.255.252
R1(cong-if)# frame-relay interface-dlci 103 Finalement, on eectue lactivation des
sous-interfaces depuis linterface physique
avec la commandeno shutdown.

CONFIGURATION DU SWITCH FRAME-RELAY


On commence par activer la commande Frame-Relay sur le routeur lui
permettant de transfrer des trames sur la base des DLCI entrant :
SFR(cong)#frame-relay switching
Sur linterface choisie on modie le type dencapsulation :
http://www.coursnet.com/2014/11/cours-frame-relay.html

7/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

SFR(cong)#interface S0/0
SFR(cong-if)#encapsulation frame-relay
On indique alors que linterface est de type DCE :
SFR(cong-if)#frame-relay intf-type dce
SFR(cong-if)#clock-rate vitesse
On congure alors le Switch Frame-Relay pour quil transfre le trac entrant ici
sur linterface S0/0 ayant le DLCI x vers par exemple linterface S0/1 ayant le
DLCI y.
On cre ainsi le premier PVC :
SFR(cong-if)#frame-relay route x interface serial 0/1 y
SFR(cong-if)#no shutdown
On cre alors le second PVC pour le retour :
SFR(cong)#interface S0/1
SFR(cong-if)#encapsulation frame-relay
SFR(cong-if)#frame-relay intf-type dce
SFR(cong-if)#clock-rate vitesse
SFR(cong-if)#frame-relay routey interface serial 0/0 x
SFR(cong-if)#no shutdown
On vrie la conguration avec la commande :show frame-relay pvc.

Paiement de Frame Relay


Un client achte un service Frame Relay un fournisseur de services. Pour
comprendre le paiement dun tel service, il est ncessaire de connaitre les
notionssuivantes :
Dbit
daccs ou vitesse du port :
dbit auquel le circuit accde au rseau Frame Relay. La vitesse du port
est cadence par le switch Frame Relay.
Dbit de donnes garanti (CIR) :
correspond la quantit de donns informatiques que lerseau Frame
Relayreoit du circuit daccs. Ce dbit est garanti par le fournisseur de
services.
Frame Relay met la disposition des clients tout capacit inutilise du rseau appele
http://www.coursnet.com/2014/11/cours-frame-relay.html

8/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

rafales suprieures leur CIR, en gnral gratuitement.


Un client paie donc pour une connexion Frame Relay :
Frais d'quipement dabonn

Dbit daccs

Circuit virtuel permanent

CIR
Les fournisseurs font parfois de la surrservation en vendant plus de bande passante
que disponible, en supposant que tous les clients nutilisent pas en permanence toute
la bande passante quils ont loues. Il peut en rsulter des problmes de trac
rseau .

Rafales ( Informatique )
Les circuits physique du rseau Frame Relay sont partags entre les abonns. Il arrive
quun surplus de bande passante soit disponible. Un client peut envoyer alors
gratuitement en rafales des donnes informatiques excdant son CIR. la dure des
rafales doittrede quelques secondes.
Les termes suivants permettent dedcrirelesdbitsde rafale :
Dbit garanti en rafale ou CIBR
http://www.coursnet.com/2014/11/cours-frame-relay.html

9/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

Dbit garanti en excs ou BE


Le CIBR est un dbit ngoci par le client en plus du CIR. La dure dune rafale
doittrecourte,sinon le client doit acheter plus de CIR.
Le BE correspond la bande passante disponible au dessus du CBIR jusquau dbit
daccs de la liaison. Ce surplus de dbit nest pas ngoci. Les trames transmises
ce dbit sont trs sujettes a labandon.

CONTROLE DE FLUX FRAME RELAY


Frame Relay utilise des mcanismes dencombrement simples comme :
Notication explicite dencombrement au destinataire ou FECN.
Notication explicite dencombrement la source ou BECN.
Les notications explicitesdencombrement sont indiques par un bit dans lentte de
la trame. le routeur dtecte lencombrement etarrtela transmissionjusquce que
lasituationnormale soit rtablie.
Les trames rseau qui arrivent au switch Frame Relay sont mises en le dattente.
Lors dune accumulation excessive de trames, le switch signale le problme aux
routeurs laide des bits de notication explicite dencombrement :
Les quipements en aval sont informs de la le dattente en congurant
le bit FECN.
Les quipements en amont sont informs de la le dattente en
congurant le bit BECN.
Lentte de trame contient galement un bit d'ligibilit la suppression (DE). Les
trames dont le bit est 1 sont considres comme moins importantes et peuvent tre
abandonnes pendant une priode dencombrement.
Les rgles logiques sont appliques :
Si la trame entrante ne dpasse pas le CIBR, la trame passe.
Si

http://www.coursnet.com/2014/11/cours-frame-relay.html

10/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

la trame entrante dpasse le CIBR, son bit DE est x 1.

Si
la trame entrante dpasse le CIBR augment du BE, elle est
abandonne.

Fin de cours
Les meilleurs cours d'informatique vous les trouvez sur coursnet.com

Twitter

Facebo
ok

Google

Tumblr

Pintere
st

RELATED POSTS:

LE RLE DUN ROUTEUR AU


SEIN DUN RSEAU WAN

http://www.coursnet.com/2014/11/cours-frame-relay.html

COURS COMPLET SUR LA


TECHNOLOGIE IPV6

COMMENT
LES
CBLES
SOUS-MARIN RELIENT LES
PAYS?

11/12

4/29/2016

Cours : Le relais de trames (Frame Relay) en dtails | Cours et Formations Informatiques en ligne !

http://www.coursnet.com/2014/11/cours-frame-relay.html

12/12