Vous êtes sur la page 1sur 26

But de cette prsentation

Configuration de base
d'un
routeur
CISCO

Le matriel Cisco est trs utilis dans le monde des


rseaux
Sa prise en main nest pas vidente et ncessite un
apprentissage des concepts rseaux et des commandes
de configuration propres lIOS Cisco
On peut apprendre manipuler les routeurs et switchs
Cisco dans le cursus CCNA
Sont prsents ici les commandes permettant de
raliser la configuration de base dun routeur
Elles ont t testes sur un Cisco 28xx et ne sont
prsentes
comme valides que pour cette famille de routeurs

Hainaut Patrick 2014

Hainaut P. 2014 - www.coursonline.be

Le routeur Cisco 2801

Outils ncessaires pour se


connecter

Routeur services intgrs

Pour se connecter au routeur:


Putty (choisir serial) :
Bits par second : 9600 ->
confreg est mal

Data bits : 8
Parity : None
Stop bits : 1
Flow control : None

attention, si le

configur, la console sera


illisible, dans ce cas,
essayez avec une autre
vitesse (19200 par ex.)

+ cble pour se connecter au routeur via le port


console

Hainaut P. 2014 - www.coursonline.be

Ou telnet, via l'interface rseau (si le routeur est


configur pour, donc si il sort du carton, pas le
choix -> port console (ou

aux via modem))

Hainaut P. 2014 - www.coursonline.be

Hainaut P. 2014 - www.coursonline.be

Mmoires du routeur
Mmoire
RAM
(DRAM)

ROM
(EPROM)

Flash
(EPROM, SIMM
ou
PCMCIA)
NVRAM

Contenu

Squence de dmarrage
Commande

show runningFichier de configuration courante (run) config


Tables de routage
show ip route
Cache ARP
show arp
Mmoire de travail
show memory
POST
Bootstrap
Mode ROM Monitor ou RXBoot
Trouve et charge l'IOS
Emplacement de l'image IOS
Fichiers de configuration
supplmentaires
Images supplmentaires de l'IOS

---

show flash

Fichier de configuration de dmarrage show startup(start)


config
Registre de configuration
show version
Hainaut P. 2014 - www.coursonline.be

Hainaut P. 2014 - www.coursonline.be

Interfaces et ports
Fichiers de configuration
Dans un routeur cisco (en gnral), il existe
diffrents fichiers de configuration
Il y a un fichier de configuration dans la nvram
(startup-config), qui est lu au dmarrage du
routeur

Les
interfaces
permettent
au
routeur
d'interconnecter les rseaux pour le routage et la
commutation.
On trouve gnralement une interface WAN de
technologie srie et une interface LAN de technologie
Ethernet

Ce fichier de configuration est copi dans la


mmoire vive (et devient la running-config)
La startup-config est conserve dans la nvram sous
forme ASCII. Tandis que la running-config est dans la
ram sous forme binaire
Hainaut P. 2014 - www.coursonline.be

Hainaut P. 2014 - www.coursonline.be

Hainaut P. 2014 - www.coursonline.be

Interfaces et ports
Les routeurs sont quips dun port console qui
autorise une communication physique srielle (via
un cble ddi) et un port auxiliaire qui permet
une communication distance via modem

On peut alors grer le routeur via Telnet, grce


des terminaux virtuels VTY (une fois la
configuration initiale effectue au moyen du
port console)
Hainaut P. 2014 - www.coursonline.be

Command Line Interface:


Hirarchie
III. Mode configuration globale (Global
Configuration mode)
Router(config)#

Invite

Router#configure
terminal

Accs
Description

Configuration gnrale et
globale
du routeur

Le mode configuration global possde des niveaux


spcifiques

dont,
entre-autres: Invite

III. 1. Configuration des


interfaces
Router(config-if)#

Router(config)#interface
FastEthernet 0/0, par exemple ou

Accs

Router(config)#interface serial
0/3/0

Description

Configuration spcifique des interfaces


11

Hainaut P. 2014 - www.coursonline.be

Command Line Interface:


Hirarchie
Command Line Interface:
Hirarchie

I. Mode utilisateur (User EXEC mode)


Invite

Router>

Accs

Mode par dfaut au dmarrage

Description

Informations trs limites sur le


routeur

III. 2. Configuration des lignes (ports)


Invite
Accs

II. Mode privilge (Privileged EXEC


mode)
Invite

Router#

Accs

Router>enable

Description

Router(config)#line console ,
par
exemple ou
Router(config)#line
aux

Descriptio
n
Configuration spcifique des
lignes (ports)

Informations dtailles et
toutes
commandes qui ne
configurent
pas le routeur

Hainaut P. 2014 - www.coursonline.be

Router(config-line)#

III. 3. Configuration du
routage
10

exit permet de sortir


d'un mode et de
revenir
au prcdent
ctrl+z ramne au mode

privil
ge
Hainaut P. 2014 - www.coursonline.be

Hainaut P. 2014 - www.coursonline.be

Invite
Accs

Router(config-router)#
Router(config)#router rip ,
par
exemple ou
Router(config)#router igrp
100

Descriptio
n
Configuration spcifique du
routage
12

Command Line Interface:


systme d'aide

Command Line Interface:


systme d'aide

La commande ? vous donne la liste des


commandes disponibles dans un mode, par
exemple :
Router>?
NB : la barre d'espacement permet de passer la
liste suivante

Une commande entire suivie de ? vous


donne la liste des paramtres suivants
immdiats :
Router#configure ?
memory Configure from NV memory
network Configure from a TFTP
network host

overwrite-network Overwrite NV memory from TFTP


network host terminal Configure from the terminal

Une commande incomplte suivie de ? vous


donnera les disponibilits :
Router#co?
configure connect copy

Une

commande
renseigne
:
rnning-config

errone
est
Router#show

^
% Invalid input detected at '^' marker.
Hainaut P. 2014 - www.coursonline.be

13
Hainaut P. 2014 - www.coursonline.be

Command Line Interface:


systme d'aide
Aussi, il y a interprtation d'une commande
abrge si elle n'est pas errone ou ambigu :
Router(config)#int f0/1 correspond :
Router(config)#interface FastEthernet
0/1 ou encore
Router#conf t correspond Router#configure
terminal
Mais si la commande est ambige, le
CLI le signale: Router#show access
% Ambiguous command : "show access"

14

Passage du mode utilisateur


au mode privilge
Comme indiqu plus
haut:
Router>enable
Si il n'y a pas de mot de passe,
l'invite devient: Router#
Par contre s'il y a un mot de passe de dfini, il faut
le rentrer pour accder au mode privilge

Un dbut de commande peut tre complt par


la touche de tabulation :
Router(config)#int suivi de la touche TAB donne
Router(config)#interface

Hainaut P. 2014 - www.coursonline.be

15
Hainaut P. 2014 - www.coursonline.be

16

Hainaut P. 2014 - www.coursonline.be

Password recovery

Password recovery

Si on rcupre un routeur dj configur, il se


peut que l'on ne connaisse pas le ou les mots de
passe

1.Dmarrez le routeur, tapez show version et


regardez quelle est la valeur du registre (dernire
ligne)
Habituellement c'est 0x2102 ou 0x102
Si vous n'arrivez pas voir ce paramtre,
prenez 0x2102 par dfaut

Il faut donc passer outre de ces mots de passe


Pour cela, il faut premirement, se connecter via
le port console sur le routeur

Hainaut P. 2014 - www.coursonline.be

17

2.

Arrtez et redmarrez le routeur


Dans les 60 secondes, appuyez sur
ctrl+pause(break) pour rentrer dans le mode ROM
Monitor (rommon)

Hainaut P. 2014 - www.coursonline.be

18

Password recovery

Password recovery

3. Modification de la valeur du registre de dmarrage

5. Visualisation de la startup-config
C1600, C1700, C2600,
C2800, c827

C1600, C1700, C2600,


c2800,
C2500
C800
c827
rommon 1>confreg
boot#set ios-conf =
0x2142
>o/r 0x2142 0x2142
rommon 2>reset

>i

Router>enable

Router>enable

Router#more nvram:startupconfig

Router#show configuration

boot#boot

La startup -config s'affiche, ainsi que les


mots de passe prcdemment dfinis

4.Aprs redmarrage, rpondez no chaque


question de la procdure de setup initiale
(assistant) ou ctrl+c pour l'viter

Hainaut P. 2014 - www.coursonline.be


Hainaut P. 2014 - www.coursonline.be

C2500

19

20

Hainaut P. 2014 - www.coursonline.be

Password recovery

Password recovery

6.Les mots de passe en clair peuvent tre


rutiliss, les mots de passes crypts doivent
tre remplacs
Pour cela, tapez configure terminal

7. Rtablissement de la valeur du registre de


dmarrage et redmarrage ( ne pas
oublier !)

L'invite <hostname>(config)# apparat


Tapez enable secret <password> pour redfinir ce
mot de passe

Tapez ctrl+z pour revenir l'invite Router#

Router#configure terminal
Router(config)#config-register
0x2102
Router(config)#
exit
Router#reload

Tapez copy running-config


startup-config pour valider les
changements

Hainaut P. 2014 - www.coursonline.be

21
Hainaut P. 2014 - www.coursonline.be

Password recovery:
effacement du fichier de
configuration initiale

22

Sauvegarde de la
configuration active

Lorsque l'on accde des routeurs dont on ne connat pas


l'histoire, il peut sembler utile d'effacer toute pollution
d'une configuration antrieure par la commande erase et
de redmarrer le routeur
Pour cela on effectue les tapes 1 4 dcrites
prcdemment

Afin de ne pas perdre sa configuration


courante, il est recommand de la
sauvegarder en NVRAM :
Router#copy running-config startup-config
(copy run start) ou Router#write (wr)

Router>enable
Router#erase startup-config
Router#configure terminal
Router(config)#config-register 0x2102
Router(config)#exit
Router#reload

ce qui copie la configuration courante en NVRAM

Notez que la commande erase startup-config peut


tre remplace par #write erase ou #erase nvram:
Hainaut P. 2014 - www.coursonline.be

23
Hainaut P. 2014 - www.coursonline.be

24

Hainaut P. 2014 - www.coursonline.be

Diffrences entre les


commandes enable secret
et enable password

Mot de passe sur le port


console
On peut restreindre l'accs
Console par mot de passe:

Le 'enable secret' est utilis pour protger l'accs


au mode Privilge et Configuration. Ce mot de
passe, aprs avoir t introduit, devient encrypt
dans la configuration (MD5)

au(x)

port(s)

Router(config)#line con 0

Le 'enable password' est utilis quand vous ne


spcifiez pas de mot de passe 'enable secret',
avec certaines anciennes versions software (IOS)
et certaines images de boot

Router(config-line)#password
mot-de-passe Router(configline)#login Router(configline)#exit

Le 'enable password' n'est pas utilis lorsque un


'enable secret' est configur (prioritaire si les
deux sont configurs)

Hainaut P. 2014 - www.coursonline.be


Hainaut P. 2014 - www.coursonline.be

Attribution d'un nom d'hte

Accs via Telnet


Le service Application Telnet sera activ ds qu'un mot de
passe aura t dfini
Evidemment pour que ce service soit accessible distance
faut-il encore que tous les protocoles infrieurs (couches 2 et
3) aient t correctement configurs (adresse IP sur une des
interfaces )
Les routeurs Cisco disposent de plusieurs terminaux virtuels
(VTY). Il est possible de configurer les terminaux sparment.
Nous nous tiendrons une configuration gnrale:
Router(config)#line vty 0 4
Router(config-line)# password
mot-de-passe Router(configline)#login Router(config-line)#exit
Le mode privilge n'est accessible qu'aprs configuration d'un
mot de passe
(par enable secret )
Hainaut P. 2014 - www.coursonline.be

26

25

27

Pour donner un nom un routeur visible dans


l'invite, il suffit d'appliquer la commande :
Router(config)#hostname name
Par exemple :
Router(config)#hostn
ame R1 ATC1(config)#
L'invite par dfaut "Router" a t change en
"R1"

Hainaut P. 2014 - www.coursonline.be

28

Hainaut P. 2014 - www.coursonline.be

Configuration d'une bannire


d'accueil

Configuration d'une bannire


d'accueil

On peut configurer une bannire d'accueil qui


s'affiche ds que l'on accde au routeur. On
l'appelle la Message Of The Day (MOTD) Banner:

Plus intressant, on peut galement configurer une


bannire de login qui s'affiche aussi ds que l'on
accde au routeur.

Router(config)#banner login #
Enter TEXT message End with the character '#'.

Router(config)#banner motd #
Enter TEXT message End with the character '#'.
Attention, ce routeur sera redmarr le 30/04
23h55 !
#

Attention, accs non autoris toute


personne trangre au service !

#
Router(config)#
Remarque: ne souhaitez jamais la bienvenue

Router(config)#
Le message doit ici se terminer par dise mais on
peut utiliser n'importe quel autre caractre que le #
(viter d'utiliser une lettre au risque d'avoir un
message incomplet ;-) )
Hainaut P. 2014 - www.coursonline.be

Et enfin, on peut afficher une bannire d'excution


qui s'affiche quand on est "logu"

Router(config)#banner exec #
Hainaut P. 2014 - www.coursonline.be

30

29

Dsactiver le timeout

Messages du Syslog
intempestifs

Pour des raisons de scurit videntes, le


systme vous dconnecte de la cli aprs un
certain temps d'inactivit (10 min par dfaut)

Pas

vident de taper une commande


quand le systme l'interrompt pour afficher
des donnes.

En environnement de test, on peut se permettre de


dsactiver ce paramtre, par la commande:
Router(config-line)#exec-timeout 0

Pour viter cela tapez, pour la


console: Router(config-

A rpter pour chaque ligne d'accs au routeur


utilise

line)#logging synchronous
Dans ce cas, le systme vous rend la main en

ayant recopi votre dbut de commande sur la


ligne active

Hainaut P. 2014 - www.coursonline.be

31

Hainaut P. 2014 - www.coursonline.be

32

Hainaut P. 2014 - www.coursonline.be

Dsactiver la rsolution de
noms

Visualisation des interfaces du


routeur

La rsolution de noms est active par dfaut, ce qui


peut parfois occasionner quelques dsagrments lors
d'une faute de frappe

Pour voir les interfaces prsentes sur un routeur

Quand le routeur est connect via une interface

wan, le systme effectue une requte DNS pour


trouver le nom tap, ce qui ne donnera rien mais
vous privera de console pendant un temps
toujours trop long

(et leurs noms): Routeur#show ip interface brief


(sh ip int br)

Pour dsactiver la rsolution DNS,


tapez:

Router(config)#no

ip

domain lookup

Hainaut P. 2014 - www.coursonline.be

33
Hainaut P. 2014 - www.coursonline.be

Configuration des interfaces du


routeur

34

Configuration d'une
interface LAN
(FastEthernet)

Pour se mettre en mode de

On va pouvoir ici attribuer une adresse IP et un masque


une interface en notation dcimale pointe, l'activer et
ventuellement lui donner une description. Voici les
commandes

configuration de base:

Router(config)#interface type
number Router(config-if)#ip
address ip-address mask
Router(config-if)#no shutdown
Router(config-if)#description
description

Routeur#configure terminal (conf t)


Routeur(config)#

Par exemple,
Router(config)#interface fast-ethernet 0/1
(int f0/1) Router(config-if)#ip address
192.168.1.1 255.255.255.0
Router(config-if)#no shutdown (no
shut) Router(config-if)#description
liaison rseau local 1
Hainaut P. 2014 - www.coursonline.be

35
Hainaut P. 2014 - www.coursonline.be

36

Hainaut P. 2014 - www.coursonline.be

Configuration d'une interface WAN


(srie)

Configuration d'une interface WAN


(srie)

En production, les routeurs sont relis un


boitier qui fait l'interface entre le routeur et la
ligne longue distance

Au niveau des commandes de configuration, elles sont


identiques celles concernant le LAN
Par exemple,

Ce boitier produit un signal d'horloge qui


cadence la communication

Router(config)#interface serial 0/0/0


Router(config-if)#ip address 192.168.1.1
255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#description
liaison WAN

En environnement de test, on simule le dispositif


de communication WAN par deux cbles, un
cble ETTD (mle) et un cble ECD (femelle),
connects ensemble
Les commandes:
Router#show controllers
controllers s0/3/1

On trouvera en plus, du cot ECD uniquement,

s0/3/0

ou

show

Exemple:

permet de voir si le routeur est connect


l'extrmit ECD ou

Router(config-if)#clock rate 64000


Hainaut P. 2014 - www.coursonline.be

ETTD

Hainaut P. 2014 - www.coursonline.be

l'instruction Router(config-if)#clock rate valeur

38

37

Vrification de la config

Table de routage

Pour vrifier la configuration du


routeur:
Routeur#show
running config

Pour vrifier la configuration les adresses IP des


interfaces du routeur et leurs status:
Routeur#show ip interface brief

Pour voir la table de


routage: Routeur#show
ip route

Exemple:

C indique une route vers une interface directement


Hainaut P. 2014 - www.coursonline.be

39

connecte

Hainaut P. 2014 - www.coursonline.be

40

Hainaut P. 2014 - www.coursonline.be

10

Table de routage

Exercice pratique

Pour ajouter une route statique:

Router(config)#ip route network-address mask


interface
Cest dans ce cadre l quon utilise ladresse
de rseau ( ne pas confondre avec ladresse
de passerelle)
Par exemple,
Router(config)#ip
255.255.255.0 f0/0

route

192.168.0.0

Pour ajouter la passerelle par dfaut:


Router(config)#ip route 0.0.0.0
0.0.0.0 s0/3/0
Hainaut P. 2014 - www.coursonline.be

Hainaut P. 2014 - www.coursonline.be

42

41

Exercice pratique
La liaison entre les routeurs se fera avec un
cble DCE

Exercice pratique

La liaison entre le routeur et le PC se fera au moyen


dun cble

Cet exemple peut tre cbl avec du matriel


rel ou ralis en virtuel sous Packet Tracer (si
vous suivez un cursus CCNA Cisco)

UTP crois

Configurez les PC avec des paramtres IP


statiques
Configurez les routeurs au moyen de la ligne de
commande (CLI) pour dfinir les paramtres IP
des interfaces employes, et les routes
ventuellement ncessaires
Sous Packet Tracer, les routeurs choisis seront
des 2811 et le switch, un 2960
Hainaut P. 2014 - www.coursonline.be

43

Le switch na pas besoin de configuration


Ne regardez les dias suivantes que quand vous
aurez essay
de faire cet exercice
Hainaut P. 2014 - www.coursonline.be

44

Hainaut P. 2014 - www.coursonline.be

11

Rsolution de lexercice

Configuration de R1

Conventions de dpart:

Router>en
Router#conf t
Router(config)#hostname R1

PC1 est connect linterface fa0/1 du switch


fa0/0 de R1 est connect linterface fa0/24
du switch

Router(config)#int f0/0
Router(config-if)#ip address 10.0.0.254
255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int s0/3/0
Router(config-if)#ip address 172.16.0.1
255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 s0/3/0

s0/3/0 de R1 est connect s0/3/0 de R2


R1 est la terminaison DCE ( vrifier )
PC2 est connect linterface fa0/0 de R2

Hainaut P. 2014 - www.coursonline.be

45

Hainaut P. 2014 - www.coursonline.be

Configuration de R2

Vrification de la config

Router>en
Router#con
ft

Router(config)#sh ip int br permet de


voir les cartes configures et si elles sont
actives

46

Router(config)#hostna
me
R2
Router(config)#int f0/0
Router(config-if)#ip address 192.168.0.254
255.255.255.0 Router(config-if)#no shutdown
Router(config-if)#int s0/3/0
Router(config-if)#ip
address
172.16.0.2
255.255.255.252
Router(config-if)#no
shutdown
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 s0/3/0
Hainaut P. 2014 - www.coursonline.be
Hainaut P. 2014 - www.coursonline.be

47

48

Hainaut P. 2014 - www.coursonline.be

12

Vrification de la config

Vrification de la config

Router(config)#sh ip route permet de voir


les lignes de la table de routage et la
passerelle par dfaut

Sur le schma Packet Tracer, les lignes sont


maintenant actives (voir la dia 43)

Le ping entre PC1 et PC2 doit maintenant fonctionner

Hainaut P. 2014 - www.coursonline.be

49

Hainaut P. 2014 - www.coursonline.be

Variante

Conclusion

Ralisez le mme exercice mais sans utiliser


de route par dfaut

Vous tes maintenant capable de configurer des


petits rseaux quips de routeurs Cisco
configurs avec du routage statique

Hainaut P. 2014 - www.coursonline.be

51

Hainaut P. 2014 - www.coursonline.be

50

52

Hainaut P. 2014 - www.coursonline.be

13

Vous aimerez peut-être aussi