Vous êtes sur la page 1sur 13

BTS SIO

Services
Informatiques
aux
Option
SIS
R
Session
20
15
Jean Hugo BENGI

Nature de
lactivit
Objectifs

Activit
professionnelle N

1
4

SPANNING-TREE
Mise en place du Spanning-Tree sur les Switchs des ligues de la
M2L

COMPETENCES MISES EN OEUVRE POUR CETTE ACTIVITE PROFESSIONNELLE


A1.1.1

Analyse du cahier des charges d'un service produire

A1.1.2

tude de l'impact de l'intgration d'un service sur le systme informatique

A1.1.3

tude des exigences lies la qualit attendue d'un service

A1.2.2

Rdaction des spcifications techniques de la solution retenue

A1.2.3

valuation des risques lis l'utilisation d'un service

A1.2.4

Dtermination des tests ncessaires la validation d'un service

A1.3.4

Dploiement dun service

A2.2.1

Suivi et rsolution d'incidents

A2.3.2

Proposition damlioration dun service

A3.1.1

Proposition d'une solution d'infrastructure

A3.1.2

Maquettage et prototypage d'une solution d'infrastructure

A3.2.1

Installation et configuration d'lments d'infrastructure

A3.3.1

Administration sur site ou distance des lments d'un rseau, de serveurs,

A3.3.3

Gestion des identits et des habilitations

A3.3.4

Automatisation des tches d'administration

A4.1.8

Ralisation des tests ncessaires la validation d'lments adapts ou dvelopps

A4.1.9

Rdaction d'une documentation technique

A5.1.2

Recueil dinformation sur une configuration & ses lments

A5.2.3

Reprage des complments de formation ou d'auto-formation ...

A5.2.4

tude dune technologie, d'un composant, d'un outil ou d'une mthode

DEROULEMENT DE L'ACTIVITE
Introduction au rseau M2L :
Dans cette activit, nous nous intresserons la partie verte. On y voit le
routeur (Cisco 2611XM : RLIGUES), ainsi que le switch 1 (Cisco 2940 :
SW1LIG) et deux switchs 2 et 3 (Cisco 2950 : SW2LIG et SW3LIG)

MAQUETTE VIA PACKET TRACER :

Nb : Entre matriel de mme nature lutilisation de cble droit est


ncessaire mis part les matriel disposant dAUTO-MDIX ou de AUTO
UPLINK, ce qui nest pas le cas ici.

Dans le rseau M2L, le spanning tree est assur par 3 switchs,


respectivement : SW1LIG, SW2LIG et finalement SW3LIG.
Nous allons prendre comme exemple le SW1LIG pour cette activit :

hostname SW1LIGUE
nom attribu au Switch
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
Mot de pass Crypt
(SSH)
!
!
!
no ip domain-lookup
Dsactive la recherche DNS du Switch
!
vtp mode transparent
Ceci est le protocole qui permet de
configurer et
administrer les Vlans sur les priphriques
Cisco
!
!
spanning-tree mode pvst
Affectation du spanning-tree par
Vlan dans le Trunk
(802.1Q)
spanning-tree vlan 12 priority 20480
spanning-tree vlan 1,10-11,99 priority 24576 La priorit est affect au Vlan,
passant par le mme trunk
!

vlan 10
name TENNIS
!
vlan 11
name ATHLE
Vlans
!
vlan 12
name BASKET
!
vlan 99
name GESTION
!
interface FastEthernet0/1
switchport mode trunk
switchport nonegotiate

Cration & Dnomination des

Mise en place dun Trunk sur le port


Dsactivation du Dynamic
Trunking Protocol, donc le
lien Trunk
ne sera pas mont
automatiquement

!
interface FastEthernet0/2
channel-group 1 mode active
Pour lagrgation de lien nous
mettrons 2
switchport mode trunk
ports Trunk dans un groupe afin daccroitre
le
dbit
.

!
interface FastEthernet0/3
channel-group 1 mode
active switchport mode
trunk
!
interface FastEthernet0/4
channel-group 2 mode active Le deuxime groupe de port trunk sera sur
le port
switchport mode trunk
Fa0/4 & Fa0/5
!
interface FastEthernet0/5
channel-group 2 mode
active switchport mode
trunk
!
interface FastEthernet0/6
switchport access vlan 10
Le port Fa0/6 est Untagged sur le
Vlan 10
!
Il appartient donc ce dernier.
interface FastEthernet0/7
!
interface FastEthernet0/8
Le port Fa0/8 est Untagged sur le
Vlan 10
switchport access vlan 10
Il appartient donc ce dernier.
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21

!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
TRUNK

Le port FA0/24 est en mode

switchport mode trunk


RLigues
!
Vlans.
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Portchannel 1
switchport mode
trunk switchport
nonegotiate
!

Cest le port qui connecte les ligues au


Ceci permettra datteindre tous les

Les port channel 1 & 2 sont configur


en Mode Trunk, donc inter Vlan, avec le DTC
dsactiv.

interface Portchannel 2
switchport mode
trunk switchport
nonegotiate
!
interface Vlan1
est
no ip address
shutdown
!
interface Vlan99
ip address 172.16.99.1 255.255.255.240
avec

Le Vlan 1 na pas dip mais


activ

Le vlan 99 aura lIP 172.16.99.1


la passerelle
172.16.99.14

!
ip default-gateway 172.16.99.14
!
no cdp run
!
!
!
!
line con 0
!
line vty 0 4
password 7
0822455D0A16 login
local
transport input
telnet line vty 5 15
login
!

Le Spannin Tree sorganise comme ceci :

Sur le schma ci-dessus, on voit bien que si le switch tombe (panne lectrique,
bug), plus aucune communication entre les ordinateurs A et B nest possible

Avec une redondance cela donne ceci :

Ce problme est nomm Tempte de Broadcast :

Les trames tournes sans arret entre les deux switchs, ce qui fait que lutilisation du CPU de

Ils reoivent tous deux une message Broadcast dans avec comme Destination FFFF, FFFF,

Ce problme ce nomme DUPLICATION DE TRAME :

Si lon envoie une trame avec comme Source A et destinataire B, les Deux switchs vont en
Le rseau nest pas optimis

Ce problme ce nomme INSTABILIT DE LA TABLE


CAM : Cam = Content Addressable Memory

Cest ici que sincrmente la Table Cam, a chaque rception par le switchs de
trame, il en extrait l@ Mac de la source.
la trame arrive sur le port 1 du switch du haut. Le switch extrait ladresse
MAC source et linsre dans sa table CAM [port 1 = adresse MAC A]
la trame arrive aussi sur le port 3 du switch du bas. Le switch extrait ladresse
MAC source et linsre dans sa table CAM [port 3 = adresse MAC A]
Maintenant que chaque switch a extrait ladresse MAC source pour linsrer
dans sa table, chacun extrait ladresse MAC de destination (B) et la compare
sa table.
Comme aucune entre nest trouve, chaque switch va dupliquer la trame
sur tous ses ports:
le switch du haut envoi la trame sur son
port 2 le switch du bas envoi la trame
sur son port 4

ET DONC FATALEMENT :
Le switch du haut reoit sur son port 2 la trame du switch du bas.
Le switch extrait ladresse MAC source et linsre dans sa table CAM [port 2 =
adresse MAC A].

Pour cela, il supprime lentre prcdente qui tait [port 1 =


adresse MAC A] Le switch du bas reoit sur son port 4 la trame du
switch du haut.
Le switch extrait ladresse MAC source et linsre dans sa table CAM [port 4 =
adresse MAC
A].
Pour cela, il supprime lentre prcdente qui tait [port 3 = adresse MAC A]

MAIS LA RSOLUTION DE CE PROBLME EST SIMPLE :

Cest dailleurs pour cela que le Spanning tree a t cr. Comme ces problmes provienn

Ici cest le Port 4 du Switch du bas qui est dsactiv, pour que les paquets passent par le s
La boucle nest plus boucle.

CONCLUSION
Linstallation de ce spanning tree permet une redondance avec les switchs
des ligues, et donc une scurit supplmentaire sur le rseau de la M2L, ce
qui donne aux ligues une haute disponibilit.

EVOLUTION
Une redondance de lien entrePOSSIBLE
le SW1LIG & le Routeur LIGUES, avec
davoir une scurit supplmentaire, car si ce lien casse, le spanning
Tree ne servira pas grand- chose.

La mise en place de MSTP, et contrairement a PVST, il n'est pas


ncessaire de disposer d'une instance par VLAN, ceux-ci pouvant
tre trs nombreux, les VLAN tant groups.