Vous êtes sur la page 1sur 13

CCNA Voice Telefonia IP Bsica e

CME com Packet Tracer


MARCELO B DO NASCIMENTO 18 DE ABRIL DE 2012 16
COMENTRIOS CISCO

TEMPO DE LEITURA: 5 MINUTOS

Ol caros Leitores, Alunos e Internautas! Nesse artigo vamos passar


alguns comandos sobre a configurao do voice over ip (VoIP)
disponveis no Packet Tracer 5.3. Esses comandos sero teis para
que est se preparando para o CCNA Voice (ICOMM verso 8.0).
Neste artigo vamos ver os seguites tpicos
Como configurar o Call Manager ExpressTM (CME) bsico em
um roteador 2811 com base no CCNA Voice,
Como utilizar os dispositivos de telefonia do packet tracer 5.3

Topologia de Rede

CCNA Voice
topologia
Vamos montar uma topologia bem bsica com apenas dois telefones
IP para ficar mais simples, porm voc pode expandir e colocar
quantos telefones e roteadores desejar.
Uma dica sobre os telefones IP que eles no iro ligar sozinhos, pois
os switches no tem PoE, portanto voc vai ter que mover o cabo da
fonte para o conector do telefone IP. Veja a figura 1 abaixo com a dica
de ligao da energia do telefone IP. Veja a figura abaixo.

CCNA Voice Telefone IP

Configurando a interface FastEthernet 0/0 e o DHCP


no RouterA (2811)
Vamos iniciar as configuraes, porm note que vamos mostrar o
necessrio para fazer a parte de telefonia funcionar e omitiremos
comandos bsicos do CCNA Voice.
RouterA>enable
RouterA#configure terminal
RouterA(config)#interface FastEthernet0/0
RouterA(config-if)#ip address 192.168.10.1
255.255.255.0
RouterA(config-if)#no shutdown
O prprio roteador servir nesse caso como servidor DHCP e para
o CME preciso que voc fornea o IP do servidor TFTP para que os

telefones possam buscar seu firmware e arquivos de configurao.


Isso feito com a opo 150 do DHCP. Veja a configurao abaixo:
RouterA(config)#ip dhcp pool VOICE
RouterA(dhcp-config)#network 192.168.10.0
255.255.255.0
RouterA(dhcp-config)#default-router 192.168.10.1
RouterA(dhcp-config)#option 150 ip 192.168.10.1

Configurando o Call Manager Express (telephony


service no RouterA)
Agora vamos ativar o Call Manager Express (telephony service) no
RouterA para habilitar o VoIP em nossa rede.
RouterA(config)#telephony-service
RouterA(config-telephony)#max-dn 5
RouterA(config-telephony)#max-ephones 5
RouterA(config-telephony)#ip source-address
192.168.10.1 port 2000
RouterA(config-telephony)#auto assign 1 to 5
Os comandos bsicos e obrigatrios para configurar o CME esto
dentro do modo de configurao do telephony-service. O Max-dn
define o nmero mximo de linhas que voc vai ter, j o max-ephones
define o mximo de telefones fsicos que voc vai ter. Cada modelo de
roteador permite um nmero mximo de telefones IP para o CME.
O comando ip source-address 192.168.10.1 port 2000 define que o
roteador 192.168.10.1 ser o responsvel pelo registro dos telefones
atravs da porta 2000.
Por ltimo temos o auto-assign, comando que faz o registro
automtico dos telefones e vincula os DNs (directory numbers ou

linhas) aos telefones fsicos, economizando comandos para criao


dos telefones fsicos (ephones). Na prtica quase no utilizamos essa
tcnica e configuramos os telefones IP inserindo os ephones
manualmente, vinculando o MAC de cada telefone a um ramal (DN).

Configurando a voice vlan no SwitchA


Como vamos utilizar apenas telefones no vamos ter duas VLANs
separadas para voz e dados, por isso vamos utilizar a VLAN 1 mesmo
como VLAN de Voz. Esse comando utilizado para separar o trfego
de voz e dados, por isso se voc for utilizar computadores nas portas
de switch do telefone IP voc precisar criar 2 VLANs, onde o trfego
de voz passado pela voice vlan e o de dados pela vlan de acesso
normal. Vamos configurar as portas de 1 a 5 para conectar telefones
IP, veja abaixo:
SwitchA(config)#interface range fa0/1 5
SwitchA(config-if-range)#switchport mode access
SwitchA(config-if-range)#switchport voice vlan 1

Configurando o ramal do telefone (directory number


do IP Phone 1)
O ramal (extenso/extension/linha) chamado de nmero de diretrio
(directory number ou DN). Apesr dp IP Phone 1 estar conectado ao
SwitchA e j estar com a VLAN de voz ele no vai subir sozinho, pois
precisamos configurar os ramais que esses telefones iro utilizar para
serem capazes de se comunicar entre si. Para isso precisamos ir no
RouterA para definir os nmeros de telefon ou DNs que iremos utilizar
nos telefones IP. Isso feito com o comando ephone-dn 1 (nesse
caso devido ao max-dn e max-ephone estarem em 5 podemos ter de 1
a 5), conforme abaixo:

RouterA(config)#ephone-dn 1
RouterA(config-ephone-dn)#number 54001
Portanto o primeiro telefone que conectarmos ao switch ter o ramal
54001 configurado nele. Faa o seguinte, ao montar a topologia lique
apenas o telefone 1 e o 2 deixe desconectado, assim voc garante
que esse ramal estar no telefone 1. Depois que o telefone 1 estiver
configurado voc pode conectar o 2. Para verificar a configurao
basta parar com o cursor do mouse encima do telefone. O registro
(processo do telefone pegar as configuraes e se registrar no
roteador CME) pode demorar um pouco.

Verificando a configurao
Agora vamos verificar a config fo IP Phone A e ver se ele recebe o IP e
o nmero 54001 do RouterA corretamente (lembre que pode demorar
um pouco!).

CCNA Voice config telefone

Clicando na aba GUI voc tem uma viso grfica do telefone e poder
fazer os testes, porm tudo imaginrio, ou seja, no vai tocar nada
apenas aparecer mensagens do tipo ringing, etc.

ccna voice telefone frontal

Configurando o DN para o IP Phone 2


Agora vamos inserir o ramal do IP Phone 2 e conect-lo ao SwitchA .
O telefone IP 2 ter o ramal 54002, veja os comandos abaixo.

RouterA(config)#ephone-dn 2
RouterA(config-ephone-dn)#number 54002

Verificando e testando a configurao


Agora basta abrir a aba GUI de cada telefone, clicar encima do
monofone (handset) e discar o ramal do outro telefone. Para atender
basta clicar sobre o monofone.
V at o telefone IP 2, disque 54001 e verifique se o IP phone 1
recebe a chamada.
Por enquanto isso a, em um prximo artigo vou mostrar como
configurar os dial-peers.
Fonte: http://www.packettracernetwork.com/voipconfiguration.html

Packet Tracer 6.1 tutorial configurao bsica de


telefonia IP
4,121951219512211111

Rating 4.12 (41 Votos)

ltima Atualizao: segunda-feira, fevereiro 23, 2015 08:19


Hits: 62965

A inscrio tutorial
Este tutorial foi concebido para ajud-lo a configurar a nova voz sobre IP (VoIP)
recursos disponveis no Packet Tracer 6.0.Ele ir mostrar-lhe os passos
necessrios para:

Configurar Chamada Manager Express TM em um roteador 2811,


Use os vrios dispositivos de telefonia
pares de marcao Setup
Ligue Cisco TM telefones IP, bem como de telefone analgico na rede.

Diagrama de rede

Nota: Conecte somente IP Phone 1 no incio do laboratrio. Telefone IP 2 deve


ser desligada.

Tarefas 1: Configurar interface


FastEthernet 0/0 e servidor DHCP na
RouterA (2811 router)
#configure A FA 0/0 de interface #
RouterA> enable
RouterA # configure terminal
RouterA (config) #interface FastEthernet0 / 0
RouterA (config-if) # ip endereo 192.168.10.1 255.255.255.0
RouterA (config-if) desligamento #no

O servidor DHCP necessrio para fornecer um endereo IP e a localizao do


servidor TFTP para cada telefone IP conectado rede.
piscina RouterA (config) # ip dhcp piscina VOICE #Criar DHCP chamado VOICE
RouterA (dhcp-config) #network 192.168.10.0 255.255.255.0 rede rede #DHCP
192.168.10 com / 24 mscara #

RouterA (dhcp-config) # default-router 192.168.10.1 #O roteador padro


endereo IP #
RouterA (dhcp-config) #option 150 ip 192.168.10.1 #Mandatory para
configurao voip.

Aps a configurao, aguarde um momento e verifique se 'IP Phone 1' recebeu


um endereo IP, colocando o cursor sobre o telefone at que seja exibido um
resumo de configurao.

Tarefas 2: Configurar o servio de


telefonia Call Manager Express no
RouterA
Agora voc deve configurar o servio de telefonia Call Manager Express no
RouterA para permitir VoIP em sua rede.
RouterA (config) # telefonia servio #Configuring o roteador de servios de
telefonia #
RouterA (config-telefonia) # max-dn 5 #Define o nmero mximo de nmeros
de diretrio #
RouterA (config-telefonia) # max-ephones 5 # define o nmero mximo de
telefones #
RouterA (config-telefonia) #ip fonte endereo 192.168.10.1 port 2000 # ip fonte
Endereo #
RouterA (config-telefonia) #auto atribuir 4-6 atribuindo #Automatically nmeros
ext aos botes #
RouterA (config-telefonia) #auto atribuir 1-5 atribuindo #Automatically nmeros
ext aos botes #

Tarefa 4: Configurar uma VLAN de voz


sobre SwitchA
Aplicar a seguinte configurao em interfaces SwitchA. Esta configurao ir
separar trfego de voz e dados em diferentes VLANs em SwitchA. pacotes de
dados ser realizada na VLAN de acesso.
SwitchA (config) gama #interface fa0 / 1 - range 5 Interface #configure #
SwitchA (config-if-gama) o acesso modo #switchport
SwitchA (config-if-gama) #switchport vlan voz 1 #Define a VLAN em que os
pacotes de voz ser tratado #

Tarefa 5: Configurar o diretrio de


telefone para telefone IP 1
Embora 'Telefone IP 1' j est conectado a SwitchA, ele precisa de configurao
additionnal antes beeing capaz de se comunicar. necessrio configurar
RouterA CME para atribuir um nmero de telefone para este telefone IP.
RouterA (config) # ephone-dn 1 #Defining o primeiro diretrio de entrada #
RouterA (config-ephone-dn) #number 54001 #assign o nmero de telefone a
esta entrada #

Tarefa 5: Verificar a configurao


Certifique-se de que o telefone IP recebe um endereo IP e um nmero de
telefone 54001 a partir RouterA (isso pode demorar um pouco).

Tarefa 6: Configurar o diretrio de


telefone para telefone IP 2

Ligue IP Phone 2 a SwitchA e poder o telefone usando o adaptador de energia


(guia Fsica).
RouterA (config) # ephone-dn 2 #Defining o primeiro diretrio de entrada #
RouterA (config-ephone-dn) #number 54002 #assign o nmero de telefone a
esta entrada #

Tarefa 7: Verificar a configurao


Certifique-se de que o Telefone IP 2 recebe um endereo IP e um nmero de
telefone 54002 a partir RouterA (isso pode demorar um pouco). Mesmo
procedimento tarefa n 5.
Dial 54001 e verificar se o telefone IP 1 recebe correctamente a chamada.