Vous êtes sur la page 1sur 8

Techniques des Rseaux Informatiques

Configuration de VPN
Comment configurer votre ordinateur en tant que serveur VPN sous Windows:
Votre systme dexploitation Windows XP vous permet de crer en toute scurit, via Internet, votre
propre rseau priv virtuel. Voici une suite de manipulations pour configurer correctement votre
ordinateur comme serveur pour une connexion VPN...
Il est ncessaire de rgler le pare-feu (Comment dsactiver le pare-feu ?) ; de mettre l'adresse IP
locale du serveur VPN dans la DMZ ; de s'assurer que votre ordinateur faisant office de serveur dispose
d'un pare-feu correctement configur. Pour une utilisation frquente de votre serveur VPN, nous vous
conseillons de le configurer avec une adresse IP fixe (Comment configurer un ordinateur avec une adresse
IP fixe ?). Comment configurer votre ordinateur en tant que serveur VPN sous Windows ?
1- Cliquez sur le bouton "Dmarrer", choisissez "Paramtres" et "Panneau de configuration", puis
slectionnez "Connexions rseau".
2- La fentre "Connexions rseau" saffiche. Cliquez sur "Crer une nouvelle connexion".

3- La fentre "Bienvenue dans lAssistant Nouvelle connexion" saffiche. Cliquez sur le bouton "Suivant >".

KATKOUT KHALID

Page 1

Techniques des Rseaux Informatiques


4- La fentre "Type de connexion rseau" saffiche. Slectionnez la proposition "Configurer une connexion
avance", puis cliquez sur le bouton "Suivant >".

5- La fentre "Options de connexion avances" saffiche. Slectionnez la proposition "Accepter les


connexions entrantes", puis cliquez sur le bouton "Suivant >".

6- La fentre "Priphriques pour connexions entrantes" saffiche. Ne cochez rien, puis cliquez sur le
bouton "Suivant >".

KATKOUT KHALID

Page 2

Techniques des Rseaux Informatiques


7- La fentre "Connexion rseau prive virtuelle (VPN) entrante" saffiche. Slectionnez le choix
"Autorisez les connexions prives virtuelles", puis cliquez sur le bouton "Suivant >".

8- La fentre "Autorisations des utilisateurs" saffiche. Slectionnez le(s) utilisateur(s) autoris(s) se


connecter, puis cliquez sur le bouton "Suivant >".

Si lutilisateur napparat pas dans la liste, cliquez sur le bouton "Ajouter", renseignez les diffrents
champs, puis cliquez sur le bouton "OK".

KATKOUT KHALID

Page 3

Techniques des Rseaux Informatiques


9- La fentre "logiciel de rseau" saffiche. Slectionnez les services, protocoles et clients que vous
dsirez activer. Par dfaut, nous vous conseillons de ne rien modifier. Cliquez ensuite sur le bouton
"Suivant >".

10- La fentre "Fin de lAssistant Nouvelle connexion" saffiche. Cliquez sur le bouton "Terminer".

11- Suite cette dernire srie de manipulations, pour configurer les proprits de la connexion VPN
cre, il vaut prsent retourner dans la fentre "Connexion rseau". Effectuez un clic droit sur la
connexion VPN ainsi cre, puis slectionnez dans le menu contextuel "Proprits".

KATKOUT KHALID

Page 4

Techniques des Rseaux Informatiques


12- La fentre "Proprits de Connexions entrantes" saffiche. Cliquez sur longlet "Gestion de rseau".
Slectionnez Protocole Internet (TCP/IP), puis cliquez sur "Proprits".

13- La fentre "Proprits TCP/IP entrantes" saffiche... Une srie d'options apparaissent:
L'option "Autoriser les correspondants appelant accder mon rseau local" permet de configurer votre
ordinateur comme routeur (si l'option est dcoche, l'appelant n'aura accs qu' votre ordinateur ; si
l'option est coche, l'appelant pourra accder aux autres ordinateurs de votre rseau).
Loption "Attribuer les adresses TCP/IP automatiquement avec DCHP" permet dassigner automatiquement les
adresses TCP/IP.
Loption Spcifier des adresses TCP/IP permet d'indiquer une plage d'adresse utiliser pour les
appelants.Elle est utile lorsqu'il n'y a pas sur le rseau de serveur DHCP.
REMARQUE : le nombre d'adresses alloues, calcul en fonction des adresses tapes dans les zones "De"
et "", s'affiche dans la zone "Total".
Loption "Autoriser l'ordinateur appelant spcifier sa propre adresse IP" inverse le processus d'attribution
de l'adresse. Ce n'est plus votre ordinateur qui attribue une adresse mais lordinateur de lappelant.
ATTENTION : cette option risque de provoquer des conflits dadresses IP sur votre rseau.
Cliquez sur le bouton "OK".

Votre ordinateur est maintenant configur correctement en tant que serveur pour un rseau virtuel via
une connexion VPN

KATKOUT KHALID

Page 5

Techniques des Rseaux Informatiques

Test de la connexion VPN :


Ouvrez votre navigateur Web, puis saisissez dans la barre dadresses lIP du serveur VPN.
Si vous affichez les dossiers partags du serveur VPN, cest que la connexion VPN fonctionne
correctement.

Configuration :
Configuration du rseau sans cryptage :
SITE 1 :
router(config)# hostname site1
site1(config)# interface ethernet0/0
site1(config-if)# ip address 172.16.0.1 255.255.255.0
site1(config-if)# no shudown
site1(config-if)# exit
site1(config) # interface serial 0/0
site1(config-if) # ip address 10.1.1.2 255.255.255.252
site1(config-if) # no shutdown
site1(config-if) # exit
site1(config) # ip route 192.168.0.0 255.255.255.0 10.1.1.1
SITE 2 :
router(config)# hostname site2
site2(config)# interface ethernet0/0
site2(config-if)# ip address 192.168.0.1 255.255.255.0
site2(config-if)# no shudown
site2(config-if)# exit
site2(config) # interface serial 1/0
site2(config-if) # ip address 10.1.1.1 255.255.255.252
site2(config-if) # clock rate 64000
site2(config-if) # no shudown
site2(config-if) # exit
site2(config) # ip route 172.16.0.0 255.255.255.0 10.1.1.2
Configuration CA
SITE 1 :
site1# clock set 10:14:59 22 jul 2014
site1(config) # ip domain-name tri.ma
site1(config) # ip host vpnca 192.168.0.254
site1(config) # crypto key generate rsa usage-keys
site1(config) # crypto ca trustpoint vpnca
Site2(ca-trustpoint)# enrollment url http://vpnca/certsrv/mscep/mscep.dll
site1(ca-truspoint) # exit
site1(config) # crypto ca authenticate vpnca
SITE 2 :
site2# clock set 11:03:14 11 jul 2014
site2(config) # ip domain-name tri.ma
site2(config) # ip host vpnca 192.168.0.254
site2(config) # crypto key generate rsa usage-keys
site2(config) # crypto ca trustpoint vpnca
Site2(ca-trustpoint)# enrollment url http://vpnca/certsrv/mscep/mscep.dll
site2(ca-truspoint) # exit
site2(config) # crypto ca authenticate vpnca
KATKOUT KHALID

Page 6

Techniques des Rseaux Informatiques


Configuration IKE
SITE 1 :
site1(config) # crypto isakmp policy 1
site1(config-isakmp) # encryption des
site1(config-isakmp) # hash sha
site1(config-isakmp) # authentication rsa-sig
site1(config-isakmp) # lifetime 86400
site1(config-isakmp) # end
site1(config) # crypto isakmp key key1700 address 10.1.1.2
SITE 2 :
site2(config) # crypto isakmp policy 1
site2(config-isakmp) # encryption des
site2(config-isakmp) # hash sha
site2(config-isakmp) # authentication rsa-sig
site2(config-isakmp) # lifetime 86400
site2(config-isakmp) # end
site2(config) # crypto isakmp key key1700 address 10.1.1.1
Configuration IPsec
SITE 1 :
site1(config)# crypto ipsec transform-set trs1 ah-sha-hmac esp-des
site1(config-crypto-trans)# mode tunnel
site1(cfg-crypto-trans)# exit
site1(config) # access-list 110 permit ip 172.16.0.0 0.0.0.255 192.168.0.0 0.0.0.255
site1(config) # access-list 110 permit tcp 172.16.0.0 0.0.0.255 192.168.0.0 0.0.0.255
site1(config)# crypto map map1 10 ipsec-isakmp
site1(cfg-crypto-map)# match address 110
site1(cfg-crypto-map)# set peer 10.1.1.2
site1(cfg-crypto-map) # exit
site1(config) # interface serial 0/0
site1(config-if) # crypto map map1
site1(config-if) # exit
SITE 2 :
site2(config)# crypto ipsec transform-set trs2 ah-sha-hmac esp-des
site2(config-crypto-trans)# mode tunnel
site2(cfg-crypto-trans)# exit
site2(config) # access-list 101 permit ip 192.168.0.0 0.0.0.255 172.16.0.0 0.0.0.255
site2(config) # access-list 101 permit tcp 192.168.0.0 0.0.0.255 172.16.0.0 0.0.0.255
site2(config)# crypto map map1 10 ipsec-isakmp
site2(cfg-crypto-map)# match address 101
site2(cfg-crypto-map)# set peer 10.1.1.1
site2(cfg-crypto-map) # exit
site2(config) # interface serial 1/0
site2(config-if) # crypto map map1
site2(config-if) # exit

KATKOUT KHALID

Page 7

Techniques des Rseaux Informatiques


Test et Vrification
Test et Vrification ( site1 ) :

ping 192.168.0.10 t l 1500

Test et Vrification ( site2 ) :

ping 172.16.0.10 t l 1500

KATKOUT KHALID

Page 8