Vous êtes sur la page 1sur 15

INTRODUCTION

But de cet article


Le pourquoi et le comment de la cration de cet article est qu la base, je
mtais amus faire communiquer diffrentes machines virtuelles (Workstation,
VBOX) via GNS3 qui taient configures lorigine pour tre isoles de toutes
communicationsbut de cet article est dexpliquer comment isoler deux VM
partir dun hyperviseur et les faire communiquer via GNS3 pour ensuite les
connecter au rseau Internet grce un routeur virtuel Cisco.
. En effet, GNS3 permet dimporter et dintgrer des VM une architecture
rseau qui, elle aussi est virtualise.
Lide est de reproduire un petit LAN avec un routeur virtuel qui fera office
de Box Internet. Chaque VM atteindra le rseau internet via ce routeur. Un peu
comme vos PC connects la Box de votre FAI, jenlve la Box et plus dinternet
pour tout le monde et aucunes communications entre les PC.

1 GESTION RESEAU DES VM


Commenons par le commencement. Dans VMware Workstation, il existe
diffrents types de connexions rseaux : Le Bridge, le Nat, le Host Only, le Lan
Segment.
VMware Workstation permet de crer diffrentes cartes rseaux virtuelles
(VMnet) configures dans un des diffrents modes dcrits ci-dessus.
Je vous invite lire cet article trs intressant et complet sur la gestion
rseau des VM.
http://chrtophe.developpez.com/tutoriels/gestion-reseau-machine-virtuelle/

Les VMnet sont des cartes rseaux virtuelles de VMware Workstation.(sous Windows)

Mes machines virtuelles taient configures de sorte ne pouvoir


communiquer quavec la machine hte. Cest ce quon appelle le Mode Host Only.
Les VM taient connectes chacune une carte rseau virtuelle diffrentes donc
aucunes communications entres les VM.
Il est logique que si 2 machines virtuelles se trouvent sur 2 rseaux
diffrents et configures en mode Host Only alors chacune des machines
virtuelles sera capable de communiquer avec la machine hte mais ne pourront
pas communiquer ensemble ni aller sur Internet ou tout autre rseau. Aprs tout
le mode Host Only est fait pour a.

Un petit schma pour expliquer le mode Host Only de chez VMware :

Le mode Host Only permet disoler la VM du rseau extrieur et du rseau local via la carte rseau
physique de lhte.

Donc comment faire, sans modifier le mode de connexion, communiquer


les VM travers GNS3 ? Le but de la manipulation tant bien sr de manipuler
des priphriques rseaux.
Cela fait, il tait possible certes de faire communiquer diffrentes VM entre
elles, mais il ntait pas possible de joindre le rseau extrieur, cest--dire
INTERNET.
Par manque de connaissances, la premire ide mtre venue en tte
tait dajouter une deuxime carte rseau mes VM et de les configurer en NAT
pour avoir accs Internet via ma machine hte, mais faut avouer que ce nest
pas trs propre.
Alors mes recherches ont commenc, pour savoir sil tait possible de
connecter un routeur virtuel Internet via GNS3 et ensuite connecter tout mon
rseau virtualis ce routeur pour avoir un accs au WEB. Bref en quelques
sortes, le but tait de simuler une Box tel que celle dun FAI et rendre dpendant
la totalit de mon SI de ce routeurAyant une petite approche de GNS3, je savais
quil tait possible dimporter des VM de VirtualBOX sur le plan. VMware
Workstation tant un produit propritaire, il est au contraire de VirtualBOX non
intgr GNS3. Mais il est possible dy importer les cartes rseaux virtuelles l
o sont connectes les VM.
Les cartes rseaux virtuelles VMnet fonctionnent un peu comme un
commutateur avec un serveur DHCP intgr qui peut bien sr tre dsactiv..

2 GNS3
2.1INTRODUCTION A LA VIRTUALISATION
La virtualisation consiste faire fonctionner une ou plusieurs machines sur un
hte physique. Il est donc possible de virtualiser plusieurs systmes
dexploitation et les faire fonctionner simultanment sur un seul PC. Je citerai
Oracle VM VirtualBox et VMware Workstation qui sont tous les 2 des hyperviseurs
de type 2 et qui permettent donc de virtualiser des machines pour y installer des
OS invits.
Pour rappel un hyperviseur type 2 est un logiciel install sur votre OS qui
permet de crer et de virtualiser des machines. Un hyperviseur de type 2 nest
pas li la couche matrielle contrairement un hyperviseur de type 1 qui lui est
install directement tel un OS au-dessus de la couche matrielle. Ce qui permet
de meilleures performances. Je ne mattarderai pas aller plus loin mais pour
plus dinformations sur la virtualisation et les hyperviseurs :
http://fr.wikipedia.org/wiki/Hyperviseur

En dehors de la virtualisation de stations de travail ou de serveurs, il est


galement possible de virtualiser des priphriques rseaux tel que des routeurs
par exemple.

STOP POUR
AUJOURDHUI
Je vous invite jeter un il cet article qui aborde la gestion rseau des
machines virtuelles :
http://chrtophe.developpez.com/tutoriels/gestion-reseau-machine-virtuelle/

2.2PRESENTATION DE GNS3
GNS3 (Graphical Network Simulation) est une solution libre disponible sous
Windows, GNU/Linux et MacOS permettant lmulation ou la simulation de
rseaux informatiques via une interface graphique.
Pour fonctionner GNS3 sappuie sur 2 outils qui sont Dynamips et Dynagen.

Ce logiciel peut servir travailler diffrents protocoles ou mme reproduire


une architecture complte (SI) en y ajoutant des VM. Idal galement pour crer
de petits LAB et prparer des certifications telles que CCNA, CCNP de chez CISCO
par exemple.

2.3DYNAMIPS

Dynamips est un logiciel crit en langage C qui offre une solution


dmulation hardware de routeurs CISCO via des images IOS non modifies.
MIPS est une architecture de processeur quon retrouve dans les routeurs
CISCO, des NAS ou encore mme certaines anciennes consoles de jeux vido
etc
Les gammes de routeurs CISCO muls sont :

Cisco
Cisco
Cisco
Cisco
Cisco

7200
3600
3700
2600
1700

(NPE-100 jusqu' NPE-400, NPE-G2)


(3620, 3640, 3660)
(3725, 3745)
(2610 2651XM, 2691)
(1710 1760)

Lmulation de Switch nest pas support du fait que le processeur de ces


priphriques est trs compliqu muler. Il est possible malgr tout dintgrer
un module switch Ethernet un routeur tel que le module NM-16ESW.
Attention les images de systme dexploitation Cisco ne sont pas libres. Il faut
possder un routeur avec un systme dexploitation ou disposer dun compte
utilisateur sur le site Cisco avec les droits daccs au tlchargement pour
obtenir une image dIOS.
http://www.cisco.com/c/en/us/support/index.html

2.4DYNAGEN

Dynagen est un produit complmentaire crit en PYTHON sinterfaant avec


Dynamips grce un mode hyperviseur. Dynagen permet de facilit la cration
de maquettes ainsi que leurs gestions via un fichier de configuration qui contient
la topologie du rseau.

2.5INSTALLATION DE GNS3 (WINDOWS)


Il faut au pralable ouvrir un compte pour avoir accs au tlchargement.
https://community.gns3.com/login.jspa

Il en manque ici ? Tu ne parleras que de linstallation sous Windows ou bien tu


parleras aussi de Linux et MAC ?

3 CARTE DE BOUCLAGE MICROSOFT


Il est indispensable dinstaller une carte rseau virtuelle notamment
lorsque lon souhaite utiliser des VM isoles, tout en autorisant les
communications entre ces VM et la machine hte. En loccurrence dans cet
article, ce sera le partage de connexion internet.
Quest ce quelle a de particulier cette carte de bouclage, pourquoi est elle
obligatoire ?
3.1Installation de la carte de bouclage
Je me rends dans le gestionnaire de priphriques pour y ajouter un
matriel dancienne gnration.
Il suffit tout simplement de faire un CLIC DROIT sur le nom de votre PC puis
de cliquer sur Ajouter un matriel dancienne gnration pour lancer
lassistant.

Une fois lassistant lanc, je choisi dinstaller le matriel manuellement et je CLIC


sur SUIVANT.

Je slectionne Cartes rseau puis SUIVANT.


Je slectionne Microsoft puis droite je slectionne Carte de bouclage
Microsoft KM-TEST puis je clic sur SUIVANT pour lancer linstallation.

3.2 Partage de connexion Internet vers la carte de bouclage.


La carte rseau virtuelle install, je massure dans un premier temps
quelle est bien prsente et active dans mon gestionnaire de connexions rseaux.
(Je lai renomm L0, je vous conseille galement de renommer vos interfaces
rseaux pour mieux vous retrouver)
Ma connexion Internet se fait via ma carte rseau nomme
Smartphone , il vous faudra partager internet via votre interface (Wifi,
Ethernet ).

Pour partager la connexion internet vers la carte de bouclage, il suffit tout


simplement de slectionner linterface rseau connecte au WEB puis de se
rendre dans les proprits de la carte et de cliquer sur longlet Partage.

Il faut dans un premier temps autoriser le partage et slectionner la carte


rseau puis de cliquer sur OK pour valider.

Une fois le partage tabli, en se rendant dans les proprites de la carte de


bouclage, je peux constater que ladresse IPv4 adresse est 192.168.137.1 /24.

Jouvre un CMD et je PING ma carte de bouclage pour massurer de la


connectivit.

3 CONFIGURATION GNS

Le but de cette procdure est de pouvoir faire en sorte que lensemble de


mon LAN VIRTUEL puisse avoir accs internet.
Dans la topologie ci-dessous, nous avons un nuage reprsentant INTERNET
qui est configure pour tre associ la carte de bouclage Microsoft
prcdemment installe. Un routeur Cisco 3745 sera connect directement
cette carte de bouclage (CLOUD) et un VPC pour tester la connectivit.
La configuration du routeur ne demande pas spcialement dtre un crack
en rseau mais requiert un minimum de connaissances et spcialement lIOS
de Cisco et le NAT.

3.1 Confi guration du nuage


CLIC DROIT sur le nuage puis CONFIGURE, je slectionne la carte L0, je lajouter,
japplique puis OK

3.2 CONFIGURATION DU ROUTEUR CISCO


Aprs avoir connect le CLOUD linterface F0/0 du routeur, puis le VPC
linterface F0/1 du routeur, je le dmarre et je patiente jusqu linvite de
commande.

La configuration est trs basique, je configurerai et activerai les interfaces


rseaux jen profiterai galement pour mettre en place un serveur DHCP pour
adresser le rseau 192.168.100.0 /24. Je massurerai que le service DNS est ctiv
et je le configurerai de sorte pour DNS la carte L0 soit 192.168.137.1.
Le NAT sera configur de sorte translater lensemble du rseau en une
seule et unique adresse publique (192.168.137.2), jutiliserai donc loverloading.
Une petite ACL sera mettre en place pour faire en sorte que le rseau
192.168.100.0 puisse accder au NET.

conf t
ip domain-lookup
ip name-server 192.168.137.1
int f0/0
ip address 192.168.137.2 255.255.255.0
ip nat outside
no sh
int f0/1

ip address 192.168.100.254 255.255.255.0


ip nat inside
no sh
exit
ip dhcp pool LAN
network 192.168.100.0 255.255.255.0
default-router 192.168.100.254
dns-server 192.168.137.1
exit
service dhcp
ip route 0.0.0.0 0.0.0.0 192.168.137.1
access-list 10 permit 192.168.100.0 0.0.0.255
ip nat inside source list 10 interface F0/0 overload
exit
wr
cop r s

4 TEST DE CONNECTIVITE

4.1 TEST DU ROUTEUR VERS INTERNET

4.2 TEST DU VPC VERS INTERNET

Jouvre une console et je commence par lancer un DHCP REQUEST pour


avoir une adresse IP fournie par le serveur DHCP configur sur le routeur R1.

Puis je ping le serveur www.google.fr pour massurer de la connectivit

2 QDQ
SQDQ