Vous êtes sur la page 1sur 33

Rapport du stage Perfectionnement

Introduction

Etudiant en deuxime anne en Rseaux et Services Informatique javais effectu un stage de


perfectionnement chez lentreprise SOTETEL dans le dpartement Direction Centrale des
Rseaux.
Dans le cadre de ce stage jai eu lopportunit de raliser des diffrentes taches et de
dcouvrir des nouvelles notions.
Lenjeu de ce stage tait de raliser 3 maquettes rseaux sur le logiciel gns3.
En effet, ces maquettes recourent aux diffrents objectifs et des diffrents outils.
Les principaux objectifs taient en premier lieux dassurer une communication distance
scurise en second lieux lobjectif tait daugmenter la passerelle par dfaut des htes dun
mme rseau et enfin crer un domaine de routage dont la configuration de routage nest pas
centralis dans les mains dun individu mais en se basant sur un protocole de routage.
Cest quoi ce logiciel gns3 ? Quels sont ces nouvelles notions ? Quels sont ces tches qui
rpondent ces objectifs ?
Ce rapport aprs une prsentation de lentreprise en premire partie, explicitera en dtail les
diffrents tches, les diffrentes protocoles et notions sur lesquels jai travaill puis dmontra
leur utilit.

Page 1

Rapport du stage Perfectionnement

Chapitre 1 : Prsentation du cadre de Stage


I. Prsentation de la Socit
1. Introduction
La SOTETEL est un acteur de rfrence dans le domaine des tlcommunications
oprant depuis 1981 sur le march Tunisien et l'tranger.
C'est une entreprise pionnire dans la mise en uvre et la maintenance des rseaux privs et
des rseaux publics de tlcommunications.
Elle a constamment jou un rle prpondrant dans le dploiement de l'infrastructure de
Tlcommunications en Tunisie en prenant part presque tous les grands projets raliss pour
Le compte de l'oprateur national Tunisie Tlcom .Elle est galement le partenaire
privilgi des principaux quipementiers internationaux Oprant en Tunisie.

Sa prsence tout au long de la chaine des Tlcommunications, depuis l'installation


d'appareils tlphoniques jusqu' la mise en uvre des rseaux les plus volus, lui confre un
potentiel de dveloppement et de croissance important, tant sur le plan national que sur le plan
international, notamment dans les pays du Maghreb, du Moyen Orient et dans certains pays
d'Afrique .

Figure1.Identit de la SOTETEL

Page 2

Rapport du stage Perfectionnement

Figure2.Tableau de prosprit de la SOTETEL

Figure3.Organigramme de la SOTETEL

2. Activits
Ses activits couvrent principalement cinq domaines:
1. Rseaux privs :

Etude, conception, intgration et maintenance des rseaux informatiques et de


tlcommunication d'entreprises,

Fourniture, installation et maintenance d'quipements actifs : routeur, switch, modem


xDSL,

Page 3

Rapport du stage Perfectionnement

Installation des systmes de scurit informatiques et lectroniques,

Dveloppement des logiciels spcifiques aux besoins des entreprises.


2. Rseaux publics :

la construction des rseaux de Lignes Abonns et des rseaux mobiles,

Construction de liaisons de transmission par cbles fibres optiques et par faisceaux


hertziens,

Installation et intgration des systmes de commutation tlphonique,

Montage et mise en service des systmes de commutation de donnes,

Rseaux Mobiles,

Dploiement de stations de base pour rseaux publics mobiles GSM et autres,

Recherche et acquisition des sites pour stations de base.

3. Les infrastructures rseaux :

La ralisation des travaux de gnie civil aussi bien pour les rseaux de transmissions
que pour les rseaux d'accs,

fourniture, installation, raccordement des cbles fibre optique,

Mise en place des pylnes et de leurs systmes associs.

4. Les rseaux Wireless :

La construction, la mise en exploitation et la maintenance des rseaux de


tlcommunication sans fil font partie des spcialits les plus importantes de la
SOTETEL.

5. Le cblage et la Connectivites
Dans le cadre de sa stratgie de dveloppement base sur une intgration plus pousse, la
SOTETEL assure l'ensemble des travaux de cblage et de connectivit, des pralables
ncessaires au dploiement de ses solutions l'intrieur des immeubles, A ce sujet, les
prestations assures dans ce domaine renferment notamment :

L'tude, la configuration et le dploiement des solutions WIFI, ,

L'tude et le dploiement des rseaux LAN ,


Page 4

Rapport du stage Perfectionnement

La fourniture et la maintenance des accs ADSL ,

II. Eude de lexistant :


Ressources Humaines

530 dont 411 ingnieurs et techniciens spcialiss,

Moyens Logistiques,

225 Vhicules,

20 Gros engins,

1 Trancheuse RIV500,

6 Micro et Mini trancheuses,

3 machines de soufflage,

22 Laboratoires F.O quips.

Page 5

Rapport du stage Perfectionnement

Chapitre 2 : Spcification des besoins


I. Besoins Fonctionnels :
Ils sagissent des besoins fondamentaux, ce sont les besoins spcifient chaque topologie.
1. Topologie 1 : Cette topologie est une topologie trs simple qui fait le recours au
protocole SSH en offrent une communication scurise et crypte.
2. Topologie 2 : Cette topologie est une topologie assez complexe qui fait le recours
au protocole VRRP en permettant de redonder la Gateway dun rseau.
3. Topologie 3 : Cette topologie est une topologie simple partir de laquelle il ya une
dfinition dun domaine de routage bas sur le protocole RIP.
II. Besoins non Fonctionnels :
A part les besoins fondamentaux, Chaque maquette doit rpondre aux critres suivants :
1. Topologie 1 : Le protocole Telnet configur sur cette topologie a permis linterfaage
des quipements de la topologie travers le rseau.
2. Topologie 2 : Le routage statique utilis au niveau de cette topologie a permis
lacheminement des donnes entre les diffrents rseaux et a permis de dfinir les
routes emprunter.

Page 6

Rapport du stage Perfectionnement

Chapitre 3 : Le Routage
Avant dentamer le chapitre suivant, Il faut tout dabord bien dfinir et Comprendre
quelques notions.
I. Dfinition du Routage
1. Dfinition :
Le routage est un processus par lequel un lment (courrier, appels tlphoniques, trains,
paquets IP, ) va tre achemin dun endroit un autre.
Un lment faisant du routage doit connatre :

La destination, de quelle source il peut apprendre les chemins daccs la destination


voulue,

Les itinraires possibles pour atteindre la destination,

Le(s) meilleur(s) itinraire(s) pour atteindre la destination.


2. Lutilit de routage :

Un quipement sur un rseau local peut atteindre directement les machines sur le mme
segment sans routage (ARP).
3. Principes du Routage IP :
Routage IP bas uniquement sur ladresse du destinataire .Chaque quipement du rseau sait
atteindre un quipement dun autre rseau, sil existe au moins un quipement de routage pour
acheminer les paquets lextrieur du rseau local. Les informations de routage sont
mmorises dans la table de routage des quipements (routeurs).
Le routage seffectue sur deux oprations:
1. La slection de la meilleure voie,
2. La commutation du paquet sur linterface approprie.

Page 7

Rapport du stage Perfectionnement

4. Types de Routage :
Il existe deux types de routage :
1. Routage Statique,
2. Routage Dynamique.
II .Le Routage Statique
1. Dfinition :
Le routage statique est le routage le plus simple mettre en uvre.
Dans ce type de routage ladministrateur va configurer les routeurs un un au sein dun
rseau afin dy saisir les routes emprunter pour aller dun rseau un autre.
2. Avantage :
Dautant plus encore, le routage statique offre des avantages en terme de :

Economie de bande passante : tant donn quune information ne transite entre les
routeurs pour quils se tiennent jour, la bande passante nest pas encombre avec des
messages dinformation et de routage,

Scurit : Contrairement aux protocoles de routage dynamique le routage statique ne


diffuse pas dinformation sur le rseau puisque les informations de routage sont
directement saisies de manire dfinitive dans la configuration par ladministrateur,

Connaissance du chemin lavance : ladministrateur ayant configur lensemble de la


topologie saura exactement par o passant les paquets pour aller dun rseau un
autre, cela peut donc faciliter la comprhension dun incident sur le rseau lors des
transmissions de paquets.

3. Inconvnients :
Malgr ces avantages nets, il prsente quand mme un inconvnient souligner : sa
maintenance devient plus lourde une fois le nombre de nuds (routeurs) augmentent dans le
rseau.

Page 8

Rapport du stage Perfectionnement

III. Le Routage Dynamique


1. Dfinition :
Le routage dynamique permet quant lui de se mettre jour de faon automatique. La
dfinition dun protocole de routage va permettre au routeur de se comprendre et dchanger
des informations de faon priodique ou vnementielle afin que chaque routeur soit au
courant des volutions du rseau sans intervention manuelle de ladministrateur du rseau.
Concrtement, le protocole de routage fixe la faon dont les routeurs vont communiquer mais
galement la faon dont ils vont calculer les meilleurs routes emprunter.
Il est important de savoir que certains protocoles de routage calculent les routes en fonction de
la vitesse des liens les liants, dautres en fonction du nombre de routeurs passer avant
datteindre la destination.
2. Avantage :
Le routage dynamique prsente les avantages suivants:

Une maintenance rduite par lautomatisation des changes et des dcisions de


routage,

Une modularit et une flexibilit accrue, il est plus facile de faire voluer le rseau
avec un rseau qui se met jour automatiquement,

Sa performance et sa mise en place ne dpendent pas de la taille du rseau.

3. Inconvnient :

Il peut tre plus compliqu mettre en place lors de son initialisation,

Il consomme de la bande passante de par les messages que les routeurs senvoient
priodiquement sur le rseau,

La diffusion automatique de message sur le rseau peut constituer un problme de


scurit car un attaquant peut obtenir des informations sur la topologie du rseau
simplement en coutant et en lisant ces messages dinformation du protocole de
routage et mme en crer afin de se faire passer pour un membre du rseau.

Page 9

Rapport du stage Perfectionnement

Chapitre 4 : Conception

Dans ce chapitre, on va analyser modliser les diffrents topologies ralises ainsi de


dfinir les protocoles utilises dans chacune.
Pour modliser les topologies ci-dessous on va dfinir en premier lieu les quipements
utilises ensuite le plan dadressage et enfin les protocoles utiliss.
I. Topologie 1
But : Le but de cette topologie est :

Dcouvrir le logiciel gns3,

Assure la configuration des quipements,

Raliser une simple PING,

La Configuration du Protocole SSH.

Figure4.Topologie1

1. Equipements utilises :

1 Routeur c7200,

2 Ethernet Switch,

2 VPCS.

Page 10

Rapport du stage Perfectionnement

2. Plan dadressage :
Le plan dadressage de cette topologie est comme suit :
Tableau1.Tableau dadressage des routeurs du Topologie1
Equipement

Interface

Adresse

Masque

R1

Interface

192.168.1.2

255.255.255.0

42.30.220.2

255.0.0.0

FastEthernet0/0
R2

Interface
FastEthernet0/0

Tableau2.Tableau dadressage du PC du Topologie1


Equipement

Adresse

Passerelle par dfaut

PC1

192.168.1.2

192.168.1.1

PC2

42.20.220.2

42.30.220.1

3. Protocole utilise :
Le Protocole SSH
SSH est un protocole qui permet de se connecte une machine distante avec une liaison
scurise. Les donnes sont cryptes entre machines. Il permet dexcuter des commandes sur
un serveur distant.
Le protocole SSH existe en deux versions majeures :

la version 1.0,

la version 2.0.

La premire version permet de se connecter distance un ordinateur afin d'obtenir


un shell ou ligne de commande. Cette version souffrait nanmoins de problmes de scurit
dans la vrification de l'intgrit des donnes envoyes ou reues.La deuxime version est
beaucoup plus sre au niveau cryptographique, et possde en plus un protocole de transfert de
fichiers complet.

Page 11

Rapport du stage Perfectionnement

SSH peut galement tre utilis pour transfrer des ports TCP d'une machine vers une autre.
Cette mthode est couramment utilise afin de scuriser une connexion qui ne l'est pas en la
faisant transfrer par le biais du tunnel chiffr SSH.
Protocole Telnet :
Telnet (Telecommunication Network) est un protocole utilis sur tout rseau TCP/IP,
permettant de communiquer avec un serveur distant en changeant des lignes de textes et en
recevant des rponses galement sous forme de texte.
Cr en 1969, Telnet est un moyen de communication trs gnraliste et bidirectionnel. Il
appartient la couche application du modle OSI et du modle ARPA. Il est normalis par
l'IETF .
Une des utilisations majeures de la commande Telnet tait de se connecter des serveurs
Telnet, qui demandaient un identifiant, puis un mot de passe, et donnaient une ligne de
commande sur la machine distante en change. Cette utilisation est progressivement devenue
marginale car le protocole Telnet n'est pas scuris.
La commande Telnet reste une commande trs pratique pour tester des serveurs. Vu la
flexibilit du programme, il est possible d'utiliser la commande Telnet pour tablir une
connexion TCP interactive avec d'autres services tels que SMTP, HTTP, POP, IMAP. en
utilisant alors le port du protocole au lieu du port Telnet standard.
Telnet est indispensable pour paramtrer certains matriels rseau n'ayant pas d'interface de
gestion web, et reste utile en complment d'une telle interface. On peut ainsi configurer
des commutateurs, des routeurs, des serveurs d'impression, des tlphones IP.
II. Topologie 2 :
But : Le But de cette Topologie est :

Utiliser le routage Statique,

Raliser le PING entre les diffrents quipements,

Configuration du protocole VRRP.

Page 12

Rapport du stage Perfectionnement

Figure5.Topologie2

1. Equipements utilises :

3 Routeur c7200,

2 Ethernet Switch,

4 VPCS.
2. Plan dadressage :

Le plan dadressage de cette topologie est comme suit :


Tableau3.Tableau dadressage des routeurs du Topologie2
Equipement

Interface

Adresse

Masque

Routeur WAN

Interface Serial 2/0

80.1.0.1

255.255.255.252

Interface Serial 2/2

80.2.0.1

255.255.255.252

Interface Serial 2/2

80.1.0.2

255.255.255.252

Interface FastEthernet0/0

192.168.0.1

255.255.255.0

Interface FastEthernet1/1

10.10.0.2

255.255.252.0

Interface Serial 2/2

80.2.0.2

255.255.255.252

Interface FastEthernet0/0

172.16.0.1

255.255.255.0

Interface FastEthernet1/1

10.10.0.3

255.255.252.0

Routeur R1

Routeur R2

Page 13

Rapport du stage Perfectionnement

Tableau4.Tableau dadressage du PC du Topologie2


Equipement

Adresse

Passerelle par dfaut

PC1

192.168.0.2

192.168.0.1

PC2

192.168.0.3

192.168.0.1

PC3

172.16.0.2

172.16.0.1

PC4

172.16.0.3

172.16.0.1

3. Protocole utilise :
1. Dfinition :
VRRP, protocole de redondance de routeur virtuel, est un protocole standard dont le but est
d'augmenter la disponibilit de la passerelle par dfaut des htes d'un mme rseau. Le
principe est de dfinir la passerelle par dfaut pour les htes du rseau comme tant une
adresse IP virtuelle rfrenant un groupe de routeurs.
2. Fonctionnement :
VRRP utilise la notion de routeur virtuel, auquel est associe une adresse IP virtuelle ainsi
qu'une adresse MAC virtuelle. Les rles de routeur master et routeur backup sont galement
utiliss et associs aux routeurs d'un groupe VRRP.
Le routeur master est associ l'adresse IP virtuelle du groupe. Un ou plusieurs
routeurs backup qui pourront reprendre le rle de master en cas de dfaillance de celui-ci.
VRRP peut tre utilis sur Ethernet, et les rseaux Token Ring.
3. Implmentation :
Chaque routeur qui participe au groupe VRRP se voit dfinir une priorit allant de 1 255.
Les messages VRRP sont changs intervalle rgulier, gal une seconde par dfaut. Les
messages sont envoys avec comme adresse MAC source l'adresse MAC virtuelle du groupe
VRRP.
Les routeurs backup sont attentifs ces messages : ils vrifient que la priorit du matre est
toujours suprieure la leur, ainsi que l'arrive rgulire des messages. dfaut de message
Page 14

Rapport du stage Perfectionnement

d'un autre routeur matre dans le sous-rseau (aprs 3,6 s par dfaut), un routeur backup se
proclamera matre.
III .Topologie3 :
But : Le But de cette Topologie est :

Utiliser le routage Dynamique,

Utiliser le protocole RIP,

Faire une PING entre les diffrents quipements.

Figure6.Topologie3

1. Equipements utilises :

4 Routeur c7200.
2. Plan dadressage :

Le plan dadressage de cette topologie est comme suit :

Page 15

Rapport du stage Perfectionnement

Tableau5.Tableau dadressage des routeurs du Topologie3


Equipement

Interface

Adresse

Masque

Routeur R1

Interface Serial 2/0

192.168.2.254

255.255.255.0

Interface Serial 2/2

192.168.5.1

255.255.255.0

Interface Serial 2/0

192.168.2.1

255.255.255.0

Interface Serial 2/2

192.168.3.254

255.255.255.0

Interface Serial 2/0

192.168.4.254

255.255.255.0

Interface Serial 2/2

192.168.3.1

255.255.255.0

Interface Serial 2/0

192.168.4.1

255.255.255.0

Interface Serial 2/2

192.168.5.254

255.255.255.0

Routeur R2

Routeur R3

Routeur R4

3. Protocole utilise :
1. Dfinition :
RIP, protocole d'information de routage est un protocole de routage IP de type vecteur de
distances. Il permet chaque routeur de communiquer aux routeurs voisins la mtrique, cest-dire la distance qui les spare d'un rseau IP dtermin quant au nombre de sauts.
Pour chaque rseau IP connu, chaque routeur conserve l'adresse du routeur voisin dont la
mtrique est la plus petite. Ces meilleurs routes sont diffuses toutes les 30 secondes.
2. Versions :

RIP version1 :

Cette version ne prend pas en charge les masques de sous-rseau de longueur variable ni
l'authentification des routeurs. Les routes sont envoyes en broadcast.

RIP version2 :

Cette version, dveloppe en 1993, a t conue pour permettre au protocole de rpondre aux
contraintes des rseaux actuels (dcoupages des rseaux IP en sous-rseaux, authentification
par mot de passe, ).
3. Fonctionnement :
Le protocole RIP sappuie sur lchange dinformation entre les routeurs adjacents. Chaque
routeur connait le cot de ses propres liaisons, et diffuse ses informations aux autres routeurs
Page 16

Rapport du stage Perfectionnement

quil connait. Ensuite les routeurs recalculent les meilleures routes, grce aux informations
reues.
4. RIP et la mtrique :
La mtrique de RIP est simple comparer dautre protocole de routage. La mtrique est
calcule en fonction du nombre de saut pour atteindre la destination. Un saut reprsente le
nombre de routeur que doit traverser la donne avant darriver destination.
Pour viter des boucles de routage la mtrique maximum est 16, on lappelle aussi mtrique
infini. Un domaine de routage RIP ne peut donc pas excder 15 sauts de routage. Cest lune
des raisons qui limite RIP de petits rseaux.
5. Limitation du RIP :

Pour viter les boucles de routage, le nombre de sauts est limit 15. Au-del, les
paquets sont supprims,

RIP ne prend en compte que la distance entre deux machines en ce qui concerne le
saut, mais il ne considre pas l'tat de la liaison afin de choisir la meilleure bande
passante possible.

Page 17

Rapport du stage Perfectionnement

Chapitre 5 : Ralisation

Ce chapitre comporte deux parties la premire prsente lenvironnement de


dveloppement quant la deuxime cette partie prsente les interfaces graphiques de chaque
topologie.
I. Environnement de dveloppement
1. Environnement Matriel :
Les caractristiques de lordinateur sur lequel les topologies sont ralises sont :

Processeur : Intel Core i3-2348M CPU @ 2.30 GHZ,

Mmoire RAM : 4.00 Go,

Type de Systme : Systme dexploitation 32 bits,

2.

Environnement Logiciel

1. Dfinition :
GNS3 est un simulateur graphique de rseaux qui permet de crer des topologies de rseaux
complexes et den tablir des simulations. Ce logiciel en lien avec Dynamips (simulateur
IOS), Dynagen (interface textuelle avec Dynamips), est un excellent outil pour
ladministration des rseaux Cisco. De plus Il est possible de sen servir pour tester les
fonctionnalits des IOS Cisco ou de tester les configurations devant tre dployes dans le
futur sur des routeurs rels.
2. Avantage :
Cest de lmulation, donc tous les protocoles disponibles en fonction de lIOS ajout
contrairement au logiciel Packet Tracer ou certains protocoles ne sont pas implments
(HSRP,VRF ).
3. Inconvnients :
Le logiciel est un peu faiblard, cest quil ne propose aucun switch au niveau 2 digne de ce
nom, aucun Switch de la gamme Catalyst type 2950 et a manque.
Page 18

Rapport du stage Perfectionnement

II. Principales Interface Graphique


1. Topologie 1 :
Rappelons que dans cette topologie le but consiste raliser le Ping entre les 2 pc et la
configuration de protocole SSH et configuration Telnet.

Configuration Pc :

On prend comme exemple PC1 (la configuration du PC2 est mise en annexe).
La commande : ip 192.168.1.2 192.168.1.1

Figure7.Configuration PC1(Topologie1)

Configuration des interfaces de routeurs :

Commande :
R1# Configure terminal
R1(config)# Interface FastEthernet0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)#exit
R1(config)# Interface FastEthernet1/1
R1(config-if)#ip address 42.30.220.2 255.0.0.0
R1(config-if)# no shutdown
Page 19

Rapport du stage Perfectionnement

R1(config-if)#end

Figure8.Configuration Interfaces R1(Topologie1)

Configuration du Protocole SSH :

Commande :
R1# Configure terminal
R1(config)# ip domain-name cisco.com
R1(config)# crypto key generate rsa
R1(config)# username gns password cisco.com
R1(config)# line vty 0 4
R1(config-line)# transport input ssh
R1(config-line)# login local
R1(config-line)# privilege level 15
R1(config-line)# exit
R1(config)# ip ssh version 2
R1(config)# ip ssh authentication-retries 2
R1(config)# do sh ip ssh
R1(config)# end

Page 20

Rapport du stage Perfectionnement

Figure9.Configuration Protocole SSH

Ping :

PC1 vers PC2 :

Figure10.Ping PC1(Topologie1)

PC2 vers PC1 :

Figure11.Ping PC2(Topologie1)

2. Topologie 2 :
Rappelons que dans cette topologie le but consiste utiliser le routage statique et le protocole
VRRP.
Dans cette topologie on prend comme exemple pour la configuration des interfaces le routeur
R1 les configurations des interfaces des autres routeurs sont mis en annexe.

Configuration des Interfaces du Routeur R1 :


Page 21

Rapport du stage Perfectionnement

Commande :
R1# Configure terminal
R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 192.168.0.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface FastEthernet1/1
R1(config-if)# ip address 10.10.0.2 255.255.252.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface serial2/2
R1(config-if)# ip address 80.1.0.2 255.255.255.252
R1(config-if)# no shutdown

Figure12.Configuration Interfaces R1 (Topologie2)

Configuration de la route statique du routeur R1:

Commande :
R1# configure terminal

Page 22

Rapport du stage Perfectionnement

R1(config)# ip route 0.0.0.0 0.0.0.0 80.1.0.1


R1(config)# ip route 80.2.0.0 255.255.255.252 80.1.0.1

Figure13.Configuration de la Route du routeur R1 (Topologie2)

Pour visualiser la route on utilise la commande :

R1# show ip route.

Figure14.Visualisation de la route du routeur R1 (Topologie2)

Configuration de la route statique du routeur R3 :

Commande :
R3# configure terminal
R1(config)# ip route 0.0.0.0 0.0.0.0 80.2.0.1
R1(config)# ip route 80.1.0.0 255.255.255.252 80.2.0.1

Figure15.Configuration de la route du routeur R3 (Topologie2)

Page 23

Rapport du stage Perfectionnement

Pour visualiser la route on utilise la commande :

R3# show ip route.

Figure16.Visualisation de la route du routeur R3 (Topologie2)

Configuration de la route statique du routeur WAN:

Commande :
WAN# configure terminal
WAN(config)# ip route 10.10.0.0 255.255.252.0 80.1.0.2
WAN(config)# ip route 172.16.0.0 255.255.255.0 80.2.0.2
WAN(config)# ip route 192.168.0.0 255.255.255.252 80.1.0.2

Figure17.Configuration de la route du routeur WAN (Topologie2)

Pour visualiser la route on utilise la commande :

R3# show ip route.

Page 24

Rapport du stage Perfectionnement

Figure18.Visualisation de la route du routeur WAN (Topologie2)

Configuration du protocole VRRP pour Routeur R1 :

Commande :
R1#configure terminal
R1(config)# interface FastEthernet1/1
R1(config-if)# vrrp 10 priority 160
R1(config-if)# vrrp 10 timers advertise 3
R1(config-if)# vrrp 10 timers learn
R1(config-if)# vrrp 10 ip 10.10.0.1
R1(config-if)# vrrp 10 preempt
R1(config-if)# end

Figure19.Configuration VRRP R1 (Topologie2)

Pour visualiser la configuration VRRP on utilise la commande :

R1# show vrrp.


Page 25

Rapport du stage Perfectionnement

Figure20.Visualisation Configuration VRRP R1 (Topologie2)

Configuration VRRP pour Routeur R3 :

Commande :
R3#configure terminal
R3(config)# interface FastEthernet1/1
R3(config-if)# vrrp 10 priority 100
R3(config-if)# vrrp 10 timers advertise 3
R3(config-if)# vrrp 10 timers learn
R3(config-if)# vrrp 10 ip 10.10.0.1
R3(config-if)# vrrp 10 preempt
R3(config-if)# end

Figure21. Configuration VRRP R3 (Topologie2)

Pour visualiser la configuration VRRP on utilise la commande :

R3# show vrrp.

Page 26

Rapport du stage Perfectionnement

Figure22.Visualisation Configuration VRRP R3 (Topologie2)

Explication :

Ligne 1: Entrer en mode configuration dinterface,

Ligne2 : Attributions une priorit linterface, cest--dire au routeur. De plus, on cre


par la mme occasion le groupe 10 ,

Ligne3/Ligne4 : Rglage des dlais davertissement (envoie de paquet aux autres


routeurs du groupe VRRP pour vrifier ltat du VRID) et de frquence
dapprentissage des infos VRRP,

Ligne5 : Attribution de ladresse IP virtuelle du VRID, cest--dire lIP reprsentant le


groupe qui sera utilise par R1 ou R3 selon le cas,

Ligne6 : Cette option autorise un routeur devenir maitre si sa priorit est suprieure
celle du maitre actuel, mme si ce maitre fonctionne correctement. Sans cette option, il
y aura rlection si et seulement si le routeur maitre tombe,

Les deux routeurs sont configurs pour appartenir un seul et mme VRID, cest--dire un
groupe VRRP . En fait, cest un routeur virtuel, un faux routeur qui nexiste pas
physiquement mais seulement virtuellement . Ces deux routeurs, R1 et R2 donc, ont des IPs
diffrentes sur leurs interfaces. Le VRID, lui, possde une IP virtuelle : 10.10.0.1.
La priorit de R1 tant suprieure R3 (160 > 100), cest R1 qui sera lu maitre. Cest donc
R1 qui va possder ladresse virtuelle 10.10.0.1, et rpondre aux diffrentes requtes
adresses cette adresse : Telnet, SSh, Ping.
Si, par le plus grand des hasards, R1 steint ou nest plus joignable, il y a rlection dans le
groupe, celui avec la plus haute priorit serait devenu maitre.
Une fois R2 devenu maitre, cest lui qui va rpondre ladresse virtuelle (10.10.0.1). Le
temps de transition est faible et paramtrable, soit 2 minutes, afin dviter un changement de
routeur chaque petite coupure de connexion.
Page 27

Rapport du stage Perfectionnement

Ping :

PC1 vers les autres PC :

Figure23. Ping PC1 (Topologie2)

3. Topologie 3 :
Rappelons que dans cette topologie le but consiste utiliser le protocole de routage
dynamique le RIP.
Dans cette topologie on prend comme exemple pour la configuration des interfaces le routeur
R1 les configurations des interfaces des autres routeurs sont mis en annexe.

Configuration des interfaces du routeur :

Commande :
R1# configure terminal
R1(config)# interface serial2/0
R1(config-if)# ip address 192.168.2.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface serial2/2
R1(config-if)# ip address 192.168.5.1 255.255.255.0
R1(config-if)# no shutdown
Page 28

Rapport du stage Perfectionnement

Figure24.Configuration Interfaces R1 (Topologie3)

Configuration du protocole RIP pour routeur R1 :

Commande :
R1#Configure terminal
R1(config)#router rip
R1(config)# network 192.168.2.0
R1(config)# network 192.168.5.0

Figure25.Configuration Protocole RIP R1 (Topologie3)

Pour visualiser la route on utilise la commande :

R1# show ip route.

Page 29

Rapport du stage Perfectionnement

Figure26.Visualisation de la Configuration RIP R1 (Topologie 3)

Configuration du protocole RIP pour routeur R2 :

Commande :
R2#Configure terminal
R2(config)#router rip
R2(config)# network 192.168.2.0
R2(config)# network 192.168.3.0

Figure27. Configuration RIP R2 (Topologie 3)

Pour visualiser la route on utilise la commande :

R2# show ip route.

Figure28.Visualisation de la configuration RIP R2 (Topologie 3)

Page 30

Rapport du stage Perfectionnement

Configuration du protocole RIP pour routeur R3 :

Commande :
R3#Configure terminal
R3(config)#router rip
R3(config)# network 192.168.3.0
R3(config)# network 192.168.4.0

Figure29. Configuration RIP R3 (Topologie 3)

Pour visualiser la route on utilise la commande :

R3# show ip route.

Figure30. Visualisation de la configuration RIP R3 (Topologie 3)

Configuration du protocole RIP pour routeur R4 :

Commande :
R4#Configure terminal
R4(config)#router rip
R4(config)# network 192.168.4.0
Page 31

Rapport du stage Perfectionnement

R4(config)# network 192.168.5.0

Figure31. Configuration RIP R4 (Topologie 3)

Pour visualiser la route on utilise la commande :

R4# show ip route.

Figure32.Visualisation de la configuration RIP R4 (Topologie 3)

Page 32

Rapport du stage Perfectionnement

Conclusion
Mon stage de perfectionnement pass au sein de lentreprise SOTETEL est une trs
bonne chance qui a permis de mettre en pratique des nouvelles connaissances, de plus, je me
suis confront aux difficults relles du monde de travail.
Au cours de ces 4 semaines jai t intress par la notion de routage et par divers autres
protocoles tels que : SSH, VRRP, RIP, Telnet.
Dun cot, je fais face des difficults nouvelles. Il faut en effet comprendre le
fonctionnement de la logiciel gns3 qui est un logiciel un peu dlicat, comprendre la bon
configuration des quipements et des protocoles.
Mais dun autre ct, quand la barrire de la comprhension a t franchie, jai pu aller trs
loin avec des maquettes fonctionnelles et par suite jai pu rpondre lobjectif de chaque une
et la mise en place des topologies dont ses quipements se communiquent en toute scurit
aussi en augmentant la redondance de la passerelle par dfaut dun rseau et en crant un
domaine de routage bas sur le protocole RIP.
Je vois bien sur quil reste des amliorations apporter et des fonctionnalits ajouter tels
que le protocole DHCP qui permet dassurer une configuration automatiques des quipements
IP cest au lieu des les configurer manuellement, de configurer les routes empruntes en
utilisant le rsum des routes afin de rduire le nombre des entres dans le table de routage.
Enfin, je tiens exprimer ma satisfaction davoir pu travaill dans de bonnes conditions
matrielles et un environnement agrable.

Page 33