Vous êtes sur la page 1sur 43

Understanding X2 Call flow in Reliance IP/MPLS

network

Author:
Mitali Bhojwani

Date: 27th Nov2015

Introduction:
X2 Signalling is used for communication between eNodeB to eNodeB in LTE environment. It is used
to perform X2 handover when a UE is moving from one cell to another. In case, X2 handover doesnt
happen, S1-MME Handover is required.

Source eNodeB is connected to Cell Site Router which should carry traffic in the IP/MPLS network to
move to the second CSS connected to destination eNodeB.
In IP/MPLS setup, there can be two X2 scenarios:
1. eNodeBs connected to CSRs under same AG2 pair
2. eNodeBs connected to CSRs under different AG2 pair
Same AG2 pair CSR have same 64740 RT values. They learn each others CSS lo0 and BDI101 IPv6
address.
Different AG2 pair CSR have same 64730 values as they are in same State. They learn a default route
by the states SAR and reach each other via this route.

In this document we will see both X2 scenarios for understanding how routes and labels are installed
and how traffic flows hop-by-hop.

Same and Different AG2 X2 flow


I-KO-KLKT-ENB-1745
I-KO-KLKT-ENB-1745

I-KO-KLKT-ENB-0616
I-KO-KLKT-ENB-B016

172.23.251.228
172.23.251.228

172.23.250.161
172.23.251.9

Case Study 1: Same CSS ring X2 scenario


ENB-1745 is trying to form X2 neighborship with ENB-0616. These eNodeBs are connected to CSS
which are under the same AG2 pair. As they are under same AG2 pair, they will have same 64740 RT
value for vrf RJIL-BEARER-ENB. Hence, they will learn each others lo0 address and BDI101 ipv6
address.
CSS1
172.23.251.228

CSS2
172.23.250.161

KLKTSURKESR002#traceroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1- Ping CSS2(250.161) BDI101 from

CSS1(251.228)
1 ::FFFF:172.21.92.214 [MPLS: Labels 273/250 Exp 0] 0 msec 0 msec 4 msec- CSS1 to adjoining CSS(249.85)
2 ::FFFF:172.20.246.53 [MPLS: Labels 96/250 Exp 0] 4 msec 4 msec 4 msec- CSS(249.85) to AG1(.76.55)
3 ::FFFF:172.16.229.234 [MPLS: Labels 0/1448/250 Exp 0] 4 msec 4 msec 0 msec- CSS(249.85) to AG1(.76.55)
4 ::FFFF:172.20.250.226 [MPLS: Labels 170/250 Exp 0] 0 msec 0 msec 4 msec- AG1(.76.55) to CSS(.248.15)
5 2405:200:103:C00:3:2:101:F1 4 msec 4 msec 4 msec CSS2(250.161) BDI101
KLKTSURKESR002#traceroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1- Ping CSS2(250.161) BDI101 from
CSS1(251.228). vpnv6 label assigned by CSS2 for BDI101: 250
1 ::FFFF:172.21.92.214 [MPLS: Labels 273/250 Exp 0] 0 msec 0 msec 4 msec 273-label assigned by CSS(249.85) for CSS2
2 ::FFFF:172.20.246.53 [MPLS: Labels 96/250 Exp 0] 4 msec 4 msec 4 msec- 96- label assigned by AG1(.76.55) for CSS2
3 ::FFFF:172.16.229.234 [MPLS: Labels 0/1448/250 Exp 0] 4 msec 4 msec 0 msec- 1448- Ipv4 LU label assigned by
AG1(.77.100) to AG1(.76.55) for BDI101. 0 is implicit-null from AG1(.77.100) to AG1(.76.55)
4 ::FFFF:172.20.250.226 [MPLS: Labels 170/250 Exp 0] 0 msec 0 msec 4 msec 170- label assigned by AG1(.77.100) for
CSS2
5 2405:200:103:C00:3:2:101:F1 4 msec 4 msec 4 msec

########################################CSS1#######################################
Xshell:\> TELNET 172.23.251.228
------------------------------------------------------------------------NE-ID INKOKLKTSURKNB0001ENBESR001
SAP-ID I-KO-KLKT-ENB-1745
FAC-ID INKOKLKTSURKNB0001
HostName KLKTSURKESR002
------------------------------------------------------------------------KLKTSURKESR002#sh run int bdi101- Source for X2 ping. It must have ip mtu 9216.
interface BDI101
description # To eNode-B - R4G_Bearer #
vrf forwarding RJIL-BEARER-ENB
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 9216
load-interval 30
ipv6 address 2405:200:103:C00:3:2:101:105/126
ipv6 enable
ipv6 mtu 9216
no ipv6 redirects
no ipv6 unreachables
end

KLKTSURKESR002#sh run vrf- Bearer vrf has2 RT values. 64740 is associated to AG2 pair and 64730 is mapped to SAP-ID.
vrf definition RJIL-BEARER-ENB
description *** FOR BEARER LTE SERVICES ***
rd 172.23.251.228:2
route-target export 64730:127
route-target export 64740:27021
route-target import 64730:12701
route-target import 64740:27021
!

KLKTSURKESR002#SH IP ROUte 172.23.250.161 CSS1 (.251.228) is learning CSS2(.250.161) lo0 via ISIS and redistributing
further via ISIS RAN. CSS2 lo0 is tagged 50 by AG1. CSS1 (.251.228) needs to traverse BDI353 to reach CSS2(.250.161)
Routing entry for 172.23.250.161/32
Known via "isis", distance 115, metric 16777244
Tag 50, type level-2
Redistributing via isis RAN
Last update from 172.21.92.214 on BDI353, 4d22h ago
Routing Descriptor Blocks:
* 172.21.92.214, from 172.23.240.99, 4d22h ago, via BDI353
Route metric is 16777244, traffic share count is 1
Route tag 50

KLKTSURKESR002#SH BGp VPnv6 UNicast VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126 CSS1 (.251.228) is


importing CSS2(.250.161) BDI101. The originator is verified as CSS2(.250.161). In case of duplicate BDIs mis-configuration
two originators are observed.
BGP routing table entry for [172.23.251.228:2]2405:200:103:C00:3:2:101:F0/126, version 229354
Paths: (1 available, best #1, table RJIL-BEARER-ENB)
Not advertised to any peer
Refresh Epoch 2
Local, imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 16777244) (via default) from 172.23.240.99 (172.16.76.55) learned via AG1(.76.55)
Origin incomplete, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64730:127 RT:64740:27021 CSS2 (.250.161) RT values
Originator: 172.23.250.161, Cluster list: 172.16.76.55, 49.44.0.193, 172.16.76.139 , recursive-via-host
mpls labels in/out nolabel/250 vpnv6 label originated by CSS2 (.250.161) for its BDI101
rx pathid: 0, tx pathid: 0x0

KLKTSURKESR002#SH MPLS FORwarding-table VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

or Tunnel Id

Switched

None

250

2405:200:103:C00:3:2:101:F0/126[V] \
0

BD353

interface

172.21.92.214

KLKTSURKESR002#SH IP CEF 172.23.250.161 CSS1 (.251.228) is assigned label for CSS2(.250.161) by its ISIS neighbor
172.23.250.161/32
nexthop 172.21.92.214 BDI353 label 273

KLKTSURKESR002#sh mpls forwarding-table 172.23.250.161


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

153

273

or Tunnel Id

interface

172.23.250.161/32 \
0

BD353

172.21.92.214

KLKTSURKESR002#traceroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1 Ping CSS2(250.161) BDI101 from


CSS1(251.228) for checking X2 communication
1 ::FFFF:172.21.92.214 [MPLS: Labels 273/250 Exp 0] 0 msec 0 msec 4 msec ISIS LDP label for CSS2(.250.161) lo0/BGP
vpnv6 label for CSS2(.250.161) BDI101
2 ::FFFF:172.20.246.53 [MPLS: Labels 96/250 Exp 0] 4 msec 4 msec 4 msec
3 ::FFFF:172.16.229.234 [MPLS: Labels 0/1448/250 Exp 0] 4 msec 4 msec 0 msec
4 ::FFFF:172.20.250.226 [MPLS: Labels 170/250 Exp 0] 0 msec 0 msec 4 msec
5 2405:200:103:C00:3:2:101:F1 4 msec 4 msec 4 msec

KLKTSURKESR002#PING MPLS IPV4 172.23.250.161/32 SOurce 172.23.251.228 Ping CSS2 (250.161) l0 from
CSS1(251.228) for MPLS
Sending 5, 72-byte MPLS Echos to Target FEC Stack TLV descriptor,
timeout is 2 seconds, send interval is 0 msec:

Codes: '!' - success, 'Q' - request not sent, '.' - timeout,


'L' - labeled output interface, 'B' - unlabeled output interface,
'D' - DS Map mismatch, 'F' - no FEC mapping, 'f' - FEC mismatch,
'M' - malformed request, 'm' - unsupported tlvs, 'N' - no label entry,
'P' - no rx intf label prot, 'p' - premature termination of LSP,
'R' - transit router, 'I' - unknown upstream index,
'l' - Label switched with FEC change, 'd' - see DDMAP for return code,
'X' - unknown return code, 'x' - return code 0

Type escape sequence to abort.


!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/4 ms
Total Time Elapsed 24 ms

KLKTSURKESR002#SH ISIS NEIghbors Find Outgoing-interface

Tag RAN:
System Id

Type Interface IP Address

KLKTSKBTESR001 L2 BD353

State Holdtime Circuit Id

172.21.92.214 UP 26

00

KLKTSURKESR002#SH MPLS LDP NEIghbor BDI353 Find neighbour lo0 IP address for telnet
Peer LDP Ident: 172.23.249.85:0; Local LDP Ident 172.23.251.228:0
TCP connection: 172.23.249.85.646 - 172.23.251.228.51580
State: Oper; Msgs sent/rcvd: 119480/119516; Downstream
Up time: 10w1d
LDP discovery sources:
BDI353, Src IP addr: 172.21.92.214
Targeted Hello 172.23.251.228 -> 172.23.249.85, active, passive
Addresses bound to peer LDP Ident:
172.23.249.85 172.21.193.5 172.21.193.128 172.20.246.52
172.21.92.214 172.21.107.100

#####################Second hop##############################
Xshell:\> telnet 172.23.249.85
------------------------------------------------------------------------NE-ID INKOKLKTSKBTNB6001ENBESR001
SAP-ID I-KO-KLKT-ENB-6314
FAC-ID INKOKLKTSKBTNB6001
HostName KLKTSKBTESR001
------------------------------------------------------------------------KLKTSKBTESR001#SH IP ROUte 172.23.250.161 CSS (.249.85) is learning CSS2(.250.161) lo0 via ISIS and redistributing
further via ISIS RAN. CSS2 lo0 is tagged 50 by AG1. CSS (.249.85) needs to traverse BDI354 to reach CSS2(.250.161)

Routing entry for 172.23.250.161/32


Known via "isis", distance 115, metric 16777234
Tag 50, type level-2
Redistributing via isis RAN
Last update from 172.20.246.53 on BDI354, 5d22h ago
Routing Descriptor Blocks:
* 172.20.246.53, from 172.23.240.99, 5d22h ago, via BDI354
Route metric is 16777234, traffic share count is 1

Route tag 50

KLKTSKBTESR001#SH BGp VPnv6 UNicast VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126 CSS2(.250.161)


BDI101
BGP routing table entry for [172.23.249.85:2]2405:200:103:C00:3:2:101:F0/126, version 396492
Paths: (2 available, best #1, table RJIL-BEARER-ENB)
Not advertised to any peer
Refresh Epoch 2
Local, imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 16777234) (via default) from 172.23.240.99 (172.16.76.55)
Origin incomplete, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64730:127 RT:64740:27021
Originator: 172.23.250.161, Cluster list: 172.16.76.55, 49.44.0.193, 172.16.76.139 , recursive-via-host
mpls labels in/out nolabel/250 vpnv6 label originated by CSS2 (.250.161) for its BDI101
rx pathid: 0, tx pathid: 0x0
Refresh Epoch 2
Local, imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 16777234) (via default) from 172.23.240.129 (172.16.76.140)
Origin incomplete, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:127 RT:64740:27021
Originator: 172.23.250.161, Cluster list: 172.16.76.140, 49.44.0.193, 172.16.76.139 , recursive-via-host
mpls labels in/out nolabel/250
rx pathid: 0, tx pathid: 0

KLKTSKBTESR001#SH MPLS FORwarding-table VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

or Tunnel Id

Switched

None

250

2405:200:103:C00:3:2:101:F0/126[V] \
0

BD354

interface

172.20.246.53

KLKTSKBTESR001#sh ip cef 172.23.250.161 CSS (.249.85) is assigned label for CSS2(.250.161) by its ISIS neighbour AG1
172.23.250.161/32
nexthop 172.20.246.53 BDI354 label 96

KLKTSKBTESR001#sh mpls forwarding-table 172.23.250.161 Local label 273 was used by CSS1(.251.228) to forward
traffic.

Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

273

96

or Tunnel Id

interface

172.23.250.161/32 \
54169770

BD354

172.20.246.53

KLKTSURKESR002#traceroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1


1 ::FFFF:172.21.92.214 [MPLS: Labels 273/250 Exp 0] 0 msec 0 msec 4 msec Local label for CSS2(.250.161) lo0
2 ::FFFF:172.20.246.53 [MPLS: Labels 96/250 Exp 0] 4 msec 4 msec 4 msec ISIS LDP label for CSS2(.250.161) lo0/BGP
vpnv6 label for CSS2(.250.161) BDI101
3 ::FFFF:172.16.229.234 [MPLS: Labels 0/1448/250 Exp 0] 4 msec 4 msec 0 msec
4 ::FFFF:172.20.250.226 [MPLS: Labels 170/250 Exp 0] 0 msec 0 msec 4 msec
5 2405:200:103:C00:3:2:101:F1 4 msec 4 msec 4 msec

KLKTSKBTESR001#sh isis neighbors


Tag RAN:
System Id

Type Interface IP Address

State Holdtime Circuit Id

KLKTSKTLPAR001 L2 BD354

172.20.246.53 UP 29

00

KLKTSURKESR002 L2 BD352

172.21.92.215 UP 24

01

KLKTKSLPESR001 L2 BD355

172.21.107.101 UP 25

01

KLKTSKBTESR001#sh mpls ldp neighbor bdi354


Peer LDP Ident: 172.16.76.55:0; Local LDP Ident 172.23.249.85:0
TCP connection: 172.16.76.55.646 - 172.23.249.85.18537
State: Oper; Msgs sent/rcvd: 167772/177318; Downstream
Up time: 13w3d
LDP discovery sources:
Targeted Hello 172.23.249.85 -> 172.16.76.55, active, passive
BDI354, Src IP addr: 172.20.246.53
Addresses bound to peer LDP Ident:
172.16.76.55 172.23.240.99 172.16.229.235 172.20.231.246
172.20.246.53 172.20.229.27 172.21.92.214 172.20.234.71
172.20.236.241 172.21.51.1

172.16.228.240

##############################Third hop#################################
Xshell:\> telnet 172.16.76.55

-------------------------------------------------------------------------

KLKTSKTLPAR001#SH BGp VPnv6 UNicast VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126


BGP routing table entry for [172.16.76.55:2]2405:200:103:C00:3:2:101:F0/126, version 5403833
Paths: (2 available, best #2, table RJIL-BEARER-ENB)
Not advertised to any peer
Refresh Epoch 1
Local, imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 10) (via default) from 49.44.0.194 (49.44.0.194)
Origin incomplete, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:127 RT:64740:27021
Originator: 172.23.250.161, Cluster list: 49.44.0.194, 172.16.76.139 , recursive-via-host
mpls labels in/out nolabel/250
rx pathid: 0, tx pathid: 0
Refresh Epoch 1
Local, imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 10) (via default) from 49.44.0.193 (49.44.0.193)
Origin incomplete, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64730:127 RT:64740:27021
Originator: 172.23.250.161, Cluster list: 49.44.0.193, 172.16.76.139 , recursive-via-host
mpls labels in/out nolabel/250
rx pathid: 0, tx pathid: 0x0

KLKTSKTLPAR001#SH MPLS FORwarding-table VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

or Tunnel Id

Switched

None

250

2405:200:103:C00:3:2:101:F0/126[V] \
0

interface

Te0/0/0 172.16.229.234

KLKTSKTLPAR001#SH IP ROUte 172.23.250.161 AG1(.76.55) is learning CSS2(.250.161) lo0 via BGP and redistributing
further via ISIS RAN. CSS2 lo0 is tagged 50 by AG1. AG1(.76.55) needs to traverse tengig0/0/0 to reach CSS2(.250.161)

Routing entry for 172.23.250.161/32


Known via "bgp 55836", distance 200, metric 20, type internal
Redistributing via isis RAN

Advertised by isis RAN metric-type internal level-2 route-map RJIL-BGP2ISIS-IPv4


Last update from 172.16.77.100 1w6d ago
Routing Descriptor Blocks:
* 172.16.77.100, from 49.44.0.193, 1w6d ago, recursive-via-host
Route metric is 20, traffic share count is 1
AS Hops 0
MPLS label: 1448---BGP IPv4 LU for CSS2(.250.161)
MPLS Flags: NSF

KLKTSKTLPAR001#sh mpls forwarding-table 172.23.250.161


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

96

1448

or Tunnel Id

interface

172.23.250.161/32 \
125786408

Te0/0/0 172.16.229.234

KLKTSKTLPAR001#sh ip cef 172.23.250.161


172.23.250.161/32
nexthop 172.16.229.234 TenGigabitEthernet0/0/0 label explicit-null 1448
KLKTSKTLPAR001#SH ip bgp 172.23.250.161
BGP routing table entry for 172.23.250.161/32, version 8202467
Paths: (2 available, best #1, table default)
Additional-path-install
Not advertised to any peer
Refresh Epoch 1
Local
172.16.77.100 (metric 10) from 49.44.0.193 (49.44.0.193)
Origin incomplete, metric 20, localpref 100, valid, internal, best
Community: 64600:127 64601:27021
Originator: 172.16.77.100, Cluster list: 49.44.0.193 , recursive-via-host
mpls labels in/out nolabel/1448
rx pathid: 0, tx pathid: 0x0
Refresh Epoch 1
Local
172.16.77.100 (metric 10) from 49.44.0.194 (49.44.0.194)
Origin incomplete, metric 20, localpref 100, valid, internal

Community: 64600:127 64601:27021


Originator: 172.16.77.100, Cluster list: 49.44.0.194 , recursive-via-host
mpls labels in/out nolabel/1448
rx pathid: 0, tx pathid: 0

KLKTSKTLPAR001#sh ip bgp 172.16.77.100


BGP routing table entry for 172.16.77.100/32, version 2652136
Paths: (2 available, best #1, table default, RIB-failure(17))
Additional-path-install
Not advertised to any peer
Refresh Epoch 1
Local
172.16.77.100 (metric 10) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal, best
Community: 64600:127 64601:27021
Originator: 172.16.77.100, Cluster list: 49.44.0.193 , recursive-via-host
mpls labels in/out nolabel/imp-null
rx pathid: 0, tx pathid: 0x0
Refresh Epoch 1
Local
172.16.77.100 (metric 10) from 49.44.0.194 (49.44.0.194)
Origin IGP, metric 0, localpref 100, valid, internal
Community: 64600:127 64601:27021
Originator: 172.16.77.100, Cluster list: 49.44.0.194 , recursive-via-host
mpls labels in/out nolabel/imp-null
rx pathid: 0, tx pathid: 0
KLKTSKTLPAR001#sh ip cef 172.16.77.100
172.16.77.100/32
nexthop 172.16.229.234 TenGigabitEthernet0/0/0 label explicit-null

KLKTSURKESR002#traceroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1 Ping CSS2(250.161) BDI101 from


CSS1(251.228) for checking X2 communication
1 ::FFFF:172.21.92.214 [MPLS: Labels 273/250 Exp 0] 0 msec 0 msec 4 msec
2 ::FFFF:172.20.246.53 [MPLS: Labels 96/250 Exp 0] 4 msec 4 msec 4 msec Local label for CSS2(.250.161) lo0
3 ::FFFF:172.16.229.234 [MPLS: Labels 0/1448/250 Exp 0] 4 msec 4 msec 0 msec Explicit null/BGP IPv4 LU/Vpnv6 label

4 ::FFFF:172.20.250.226 [MPLS: Labels 170/250 Exp 0] 0 msec 0 msec 4 msec


5 2405:200:103:C00:3:2:101:F1 4 msec 4 msec 4 msec

KLKTSKTLPAR001#sh isis neighbors


Tag CORE:
System Id

Type Interface IP Address

State Holdtime Circuit Id

KLKTCHTRPAR001 L1 Te0/0/0

172.16.229.234 UP 27

00

KLKTTMHTPAR001 L1 BD370

172.16.228.241 UP 28

01

Tag RAN:
System Id

Type Interface IP Address

KLKTTMHTPAR001 L2 BD371

State Holdtime Circuit Id

172.20.231.247 UP 26

04

KLKTTLIRESR001 L2 BD353

172.20.236.240 UP 20

03

KLKTSKTLESR003 L2 BD361

172.20.234.70 UP 23

00

KLKTSKTLESR001 L2 BD352

172.20.229.26 UP 26

00

KLKTTMHTESR002 L2 BD354
KLKTSKBTESR001 L2 BD351

172.21.51.0

UP 20

00

172.20.246.52 UP 23

01

KLKTSKTLPAR001#sh mpls ldp neighbor Te0/0/0


Peer LDP Ident: 172.16.77.100:0; Local LDP Ident 172.16.76.55:0
TCP connection: 172.16.77.100.24786 - 172.16.76.55.646
State: Oper; Msgs sent/rcvd: 216968/217589; Downstream
Up time: 15w3d
LDP discovery sources:
Targeted Hello 172.16.76.55 -> 172.16.77.100, active, passive
TenGigabitEthernet0/0/0, Src IP addr: 172.16.229.234
Addresses bound to peer LDP Ident:
172.16.77.100 172.23.240.98 172.16.229.234 172.20.231.243
172.20.250.227 172.16.228.239

###########################Fourth hop##############################

Xshell:\> telnet 172.16.77.100

-------------------------------------------------------------------------

KLKTCHTRPAR001#SH BGp VPnv6 UNicast VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126


BGP routing table entry for [172.16.77.100:2]2405:200:103:C00:3:2:101:F0/126, version 513971
Paths: (3 available, best #3, table RJIL-BEARER-ENB)
Not advertised to any peer
Refresh Epoch 1
Local, imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 20) (via default) from 49.44.0.194 (49.44.0.194)
Origin incomplete, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:127 RT:64740:27021
Originator: 172.23.250.161, Cluster list: 49.44.0.194, 172.16.76.139 , recursive-via-host
mpls labels in/out nolabel/250
rx pathid: 0, tx pathid: 0
Refresh Epoch 1
Local, imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 20) (via default) from 49.44.0.193 (49.44.0.193)
Origin incomplete, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:127 RT:64740:27021
Originator: 172.23.250.161, Cluster list: 49.44.0.193, 172.16.76.139 , recursive-via-host
mpls labels in/out nolabel/250
rx pathid: 0, tx pathid: 0
Refresh Epoch 2
Local, (Received from a RR-client), imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 20) (via default) from 172.23.250.161 (172.23.250.161)
Origin incomplete, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64730:127 RT:64740:27021 , recursive-via-host
mpls labels in/out nolabel/250
rx pathid: 0, tx pathid: 0x0

KLKTCHTRPAR001#SH MPLS FORwarding-table VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

or Tunnel Id

Switched

None

250

2405:200:103:C00:3:2:101:F0/126[V] \
0

BD352

interface

172.20.250.226

KLKTCHTRPAR001#SH IP ROUte 172.23.250.161 CSS2(.250.161) lo0 via ISIS and redistributing further via ISIS RAN and
BGP
Routing entry for 172.23.250.161/32
Known via "isis", distance 115, metric 20
Tag 10, type level-2
Redistributing via isis RAN, bgp 55836
Advertised by bgp 55836 level-2 route-map RJIL-RAN-ISIS2BGP-IPv4
Last update from 172.20.250.226 on BDI352, 1w6d ago
Routing Descriptor Blocks:
* 172.20.250.226, from 172.23.250.161, 1w6d ago, via BDI352
Route metric is 20, traffic share count is 1
Route tag 10

KLKTCHTRPAR001#sh mpls forwarding-table 172.23.250.161 1448 is Local label for CSS2(.250.161) lo0 and 170 is
outgoing label assigned by adjoin CSS(.248.15)
Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

or Tunnel Id

Switched

1448

170

172.23.250.161/32 \

interface

2587669453 BD352

172.20.250.226

KLKTCHTRPAR001#sh ip cef 172.23.250.161


172.23.250.161/32
nexthop 172.20.250.226 BDI352 label 170
KLKTSURKESR002#traceroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1 Ping CSS2(250.161) BDI101 from
CSS1(251.228) for checking X2 communication
1 ::FFFF:172.21.92.214 [MPLS: Labels 273/250 Exp 0] 0 msec 0 msec 4 msec
2 ::FFFF:172.20.246.53 [MPLS: Labels 96/250 Exp 0] 4 msec 4 msec 4 msec
3 ::FFFF:172.16.229.234 [MPLS: Labels 0/1448/250 Exp 0] 4 msec 4 msec 0 msec Explicit null/Local label
4 ::FFFF:172.20.250.226 [MPLS: Labels 170/250 Exp 0] 0 msec 0 msec 4 msec Outgoing label for CSS2(.250.161) lo0/BGP
vpnv6 label for CSS2(.250.161) BDI101
5 2405:200:103:C00:3:2:101:F1 4 msec 4 msec 4 msec

KLKTCHTRPAR001#sh isis nei

Tag CORE:
System Id

Type Interface IP Address

KLKTTLDGPAR001 L1 BD370

State Holdtime Circuit Id

172.16.228.238 UP 22

01

KLKTSKTLPAR001 L1 Te0/0/0

172.16.229.235 UP 29

00

Tag RAN:
System Id

Type Interface IP Address

State Holdtime Circuit Id

KLKTTLDGPAR001 L2 BD371

172.20.231.242 UP 22

02

KLKTSURKESR001 L2 BD352

172.20.250.226 UP 29

01

KLKTCHTRPAR001#sh mpls ldp neighbor bdi352


Peer LDP Ident: 172.23.248.15:0; Local LDP Ident 172.16.77.100:0
TCP connection: 172.23.248.15.59654 - 172.16.77.100.646
State: Oper; Msgs sent/rcvd: 31677/30209; Downstream
Up time: 2w3d
LDP discovery sources:
BDI352, Src IP addr: 172.20.250.226
Targeted Hello 172.16.77.100 -> 172.23.248.15, active, passive
Addresses bound to peer LDP Ident:
172.23.248.15 172.21.193.2 172.21.193.128 172.20.250.226
172.21.252.148

##############################Fifth hop##################################
Xshell:\> telnet 172.23.248.15

------------------------------------------------------------------------NE-ID INKOKLKTSURKTW6001ENBESR001
SAP-ID I-KO-KLKT-ENB-6317
FAC-ID INKOKLKTSURKTW6001
HostName KLKTSURKESR001
------------------------------------------------------------------------KLKTSURKESR001#SH BGp VPnv6 UNicast VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126
BGP routing table entry for [172.23.248.15:2]2405:200:103:C00:3:2:101:F0/126, version 7756
Paths: (2 available, best #1, table RJIL-BEARER-ENB)
Not advertised to any peer
Refresh Epoch 2
Local, imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 10) (via default) from 172.23.240.98 (172.16.77.100)

Origin incomplete, metric 0, localpref 100, valid, internal, best


Extended Community: RT:64730:127 RT:64740:27021
Originator: 172.23.250.161, Cluster list: 172.16.77.100 , recursive-via-host
mpls labels in/out nolabel/250
rx pathid: 0, tx pathid: 0x0
Refresh Epoch 2
Local, imported path from [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126 (global)
::FFFF:172.23.250.161 (metric 10) (via default) from 172.23.240.128 (172.16.76.139)
Origin incomplete, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:127 RT:64740:27021
Originator: 172.23.250.161, Cluster list: 172.16.76.139 , recursive-via-host
mpls labels in/out nolabel/250
rx pathid: 0, tx pathid: 0

KLKTSURKESR001#SH MPLS FORwarding-table VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

or Tunnel Id

Switched

None

250

2405:200:103:C00:3:2:101:F0/126[V] \
0

BD353

interface

172.21.252.149

KLKTSURKESR001#SH IP ROUte 172.23.250.161Adjoining CSS2(.250.161)


Routing entry for 172.23.250.161/32
Known via "isis", distance 115, metric 10
Tag 10, type level-2
Redistributing via isis RAN
Last update from 172.21.252.149 on BDI353, 1w6d ago
Routing Descriptor Blocks:
* 172.21.252.149, from 172.23.250.161, 1w6d ago, via BDI353
Route metric is 10, traffic share count is 1
Route tag 10

KLKTSURKESR001#sh mpls forwarding-table 172.23.250.161


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

170

explicit-n 172.23.250.161/32 \

or Tunnel Id

interface

2667906197 BD353

172.21.252.149

KLKTSURKESR001#sh ip cef 172.23.250.161


172.23.250.161/32
nexthop 172.21.252.149 BDI353 label explicit-null

KLKTSURKESR002#traceroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1 Ping CSS2(250.161) BDI101 from


CSS1(251.228) for checking X2 communication
1 ::FFFF:172.21.92.214 [MPLS: Labels 273/250 Exp 0] 0 msec 0 msec 4 msec
2 ::FFFF:172.20.246.53 [MPLS: Labels 96/250 Exp 0] 4 msec 4 msec 4 msec
3 ::FFFF:172.16.229.234 [MPLS: Labels 0/1448/250 Exp 0] 4 msec 4 msec 0 msec
4 ::FFFF:172.20.250.226 [MPLS: Labels 170/250 Exp 0] 0 msec 0 msec 4 msec Incoming label for CSS2(.250.161) lo0.
Explicit null. Hence, last hop from CSS(.248.15) to CSS2 via BDI353 is not seen.
5 2405:200:103:C00:3:2:101:F1 4 msec 4 msec 4 msec

KLKTSURKESR001#sh isis nei

Tag RAN:
System Id

Type Interface IP Address

State Holdtime Circuit Id

KLKTCHTRPAR001 L2 BD355

172.20.250.227 UP 22

00

KLKTSMLLESR001 L2 BD353

172.21.252.149 UP 25

01

KLKTSURKESR001#sh mpls ldp neighbor bdi353


Peer LDP Ident: 172.23.250.161:0; Local LDP Ident 172.23.248.15:0
TCP connection: 172.23.250.161.28639 - 172.23.248.15.646
State: Oper; Msgs sent/rcvd: 23234/23198; Downstream
Up time: 1w6d
LDP discovery sources:
BDI353, Src IP addr: 172.21.252.149
Targeted Hello 172.23.248.15 -> 172.23.250.161, active, passive
Addresses bound to peer LDP Ident:
172.23.250.161 172.21.193.128 172.21.252.149 172.21.193.12

##################################Last hop################################
Xshell:\> telnet 172.23.250.161
-------------------------------------------------------------------------

NE-ID INKOKLKTSMLLTW0001ENBESR001
SAP-ID I-KO-KLKT-ENB-0616
FAC-ID INKOKLKTSMLLTW0001
HostName KLKTSMLLESR001
------------------------------------------------------------------------KLKTSMLLESR001#sh run vrf
vrf definition RJIL-BEARER-ENB
description *** FOR BEARER LTE SERVICES ***
rd 172.23.250.161:2
route-target export 64730:127
route-target export 64740:27021
route-target import 64730:12701
route-target import 64740:27021

interface BDI101
description # To eNode-B - R4G_Bearer #
vrf forwarding RJIL-BEARER-ENB
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 9216
load-interval 30
ipv6 address 2405:200:103:C00:3:2:101:F1/126
ipv6 enable
ipv6 mtu 9216
no ipv6 redirects
no ipv6 unreachables

KLKTSMLLESR001#SH BGp VPnv6 UNicast VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126 BDI101 route


BGP routing table entry for [172.23.250.161:2]2405:200:103:C00:3:2:101:F0/126, version 24456
Paths: (1 available, best #1, table RJIL-BEARER-ENB)
Advertised to update-groups:
2
Refresh Epoch 1

Local
:: (via vrf RJIL-BEARER-ENB) from 0.0.0.0 (172.23.250.161)
Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best
Extended Community: RT:64730:127 RT:64740:27021
mpls labels in/out 250/nolabel(RJIL-BEARER-ENB) Local label
rx pathid: 0, tx pathid: 0x0

KLKTSMLLESR001#SH MPLS FORwarding-table VRf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:F1/126


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

250

No Label 2405:200:103:C00:3:2:101:F0/126[V] \

or Tunnel Id

interface

1078352264 aggregate/RJIL-BEARER-ENB
###############################################################################

Case Study 2: Same CSS ring X2 scenario


ENB-1745 is trying to form X2 neighborship with ENB-B016. These eNodeBs are connected to CSS
which are under different pair. As they are in the same state, they will have same 64730 RT value for
vrf RJIL-BEARER-ENB. They will not learn each others lo0 address and BDI101 ipv6 address. Kolkata
SARs will send a default route which will be used by CSS1 to reach SAR to CSS2.

CSS1
172.23.251.228

CSS2
172.23.251.9

KLKTSURKESR002#TRACeroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:C9 Ping CSS2(251.9) BDI101 from

CSS1(251.228)
1 ::FFFF:172.21.92.214 [MPLS: Labels 200/81351 Exp 0] 4 msec 4 msec 4 msec CSS1 to adjoining CSS
2 ::FFFF:172.20.246.53 [MPLS: Labels 916/81351 Exp 0] 4 msec 8 msec 4 msec CSS to adjoining AG1
3 ::FFFF:172.16.228.241 [MPLS: Labels 29/16450/81351 Exp 0] 4 msec 8 msec 4 msec AG1 to adjoining AG1
4 2405:200:103:0:172:16:228:243 [MPLS: Labels 16007/16450/81351 Exp 0] 4 msec 4 msec 4 msec AG1 to AG2
5 2405:200:103::1:0:31 [MPLS: Labels 16450/81351 Exp 0] 4 msec 4 msec 4 msec AG2 to AG3
6 2405:200:103:C00:3:2:101:C9 8 msec 8 msec 8 msec CSS2 BDI101

KLKTSURKESR002#TRACeroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:C9- Ping CSS2(251.9) BDI101 from

CSS1(251.228). vpnv6 label assigned by selected SAR for default route 81351
1 ::FFFF:172.21.92.214 [MPLS: Labels 200/81351 Exp 0] 4 msec 4 msec 4 msec200: Label assigned by adjoining CSS for
SAR
2 ::FFFF:172.20.246.53 [MPLS: Labels 916/81351 Exp 0] 4 msec 8 msec 4 msec916: Label assigned by adjoining AG1 for
SAR
3 ::FFFF:172.16.228.241 [MPLS: Labels 29/16450/81351 Exp 0] 4 msec 8 msec 4 msec29: Label assigned by adjoining
AG1 for AG3. 16450 is BGP IPv4 LU for SAR.
4 2405:200:103:0:172:16:228:243 [MPLS: Labels 16007/16450/81351 Exp 0] 4 msec 4 msec 4 msec16007: Label
assigned by adjoining AG2 for AG3. 16450 is BGP IPv4 LU for SAR.
5 2405:200:103::1:0:31 [MPLS: Labels 16450/81351 Exp 0] 4 msec 4 msec 4 msec 16450 is BGP IPv4 LU for SAR.
6 2405:200:103:C00:3:2:101:C9 8 msec 8 msec 8 msec

############################################CSS1################################

Xshell:\> TELNET 172.23.251.228


------------------------------------------------------------------------NE-ID INKOKLKTSURKNB0001ENBESR001
SAP-ID I-KO-KLKT-ENB-1745
FAC-ID INKOKLKTSURKNB0001
HostName KLKTSURKESR002
------------------------------------------------------------------------KLKTSURKESR002#SH RUN VRF
vrf definition RJIL-BEARER-ENB
description *** FOR BEARER LTE SERVICES ***
rd 172.23.251.228:2
route-target export 64730:127 KLKT SAP-ID 6730 value
route-target export 64740:27021
route-target import 64730:12701
route-target import 64740:27021

interface BDI101
description # To eNode-B - R4G_Bearer #

vrf forwarding RJIL-BEARER-ENB


no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 9216
load-interval 30
ipv6 address 2405:200:103:C00:3:2:101:105/126
ipv6 enable
ipv6 mtu 9216
no ipv6 redirects
no ipv6 unreachables

KLKTSURKESR002# sh ip route 172.23.251.9 CSS2 lo0 not learned


% Subnet not in table
KLKTSURKESR002#show bgp vpnv6 uni vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:C9/126 CSS2 BDI101 not learned
% Network not in table

KLKTSURKESR002#SHOW BGP VPNV6 UNI VRF RJIL-BEARER-ENB ::/0 Default route generated by Kolkata SARs is
imported. Lowest Router-ID SAR is selected based on BGP Best Path Selection Algorithm.
BGP routing table entry for [172.23.251.228:2]::/0, version 230450
Paths: (4 available, best #3, table RJIL-BEARER-ENB)
Not advertised to any peer
Refresh Epoch 2
Local, imported path from [49.44.5.72:2]::/0 (global)
::FFFF:49.44.5.72 (metric 20) (via default) from 172.23.240.99 (172.16.76.55)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.72, Cluster list: 172.16.76.55, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/24234
rx pathid: 0, tx pathid: 0
Refresh Epoch 2
Local, imported path from [49.44.5.71:2]::/0 (global)
::FFFF:49.44.5.71 (metric 20) (via default) from 172.23.240.99 (172.16.76.55)
Origin IGP, metric 0, localpref 100, valid, internal

Extended Community: RT:64730:12701


Originator: 49.44.5.71, Cluster list: 172.16.76.55, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16000
rx pathid: 0, tx pathid: 0
Refresh Epoch 2
Local, imported path from [49.44.5.69:2]::/0 (global)
::FFFF:49.44.5.69 (metric 20) (via default) from 172.23.240.99 (172.16.76.55)
Origin IGP, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64730:12701
Originator: 49.44.5.69, Cluster list: 172.16.76.55, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/81351 BGP VPNv6 Label used
rx pathid: 0, tx pathid: 0x0
Refresh Epoch 2
Local, imported path from [49.44.5.70:2]::/0 (global)
::FFFF:49.44.5.70 (metric 20) (via default) from 172.23.240.99 (172.16.76.55)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.70, Cluster list: 172.16.76.55, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16253
rx pathid: 0, tx pathid: 0

KLKTSURKESR002#SHOW mpls forwarding-table VRF RJIL-BEARER-ENB ::/0


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

None

81351

or Tunnel Id
::/0[V]

interface

BD353

172.21.92.214

KLKTSURKESR002#sh ip route 49.44.5.69 SAR IP is learned via ISIS


Routing entry for 49.44.5.69/32
Known via "isis", distance 115, metric 20
Tag 5000, type level-2
Redistributing via isis RAN
Last update from 172.21.92.214 on BDI353, 6d02h ago
Routing Descriptor Blocks:
* 172.21.92.214, from 172.23.240.99, 6d02h ago, via BDI353
Route metric is 20, traffic share count is 1

Route tag 5000

KLKTSURKESR002#sh mpls forwarding-table 49.44.5.69 ISIS LDP Label used to reach SAR
Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

26

200

or Tunnel Id

49.44.5.69/32 0

interface

BD353

172.21.92.214

KLKTSURKESR002#sh ip cef 49.44.5.69


49.44.5.69/32
nexthop 172.21.92.214 BDI353 label 200

KLKTSURKESR002#PING vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:C9


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2405:200:103:C00:3:2:101:C9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms

KLKTSURKESR002#TRACeroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:C9


1 ::FFFF:172.21.92.214 [MPLS: Labels 200/81351 Exp 0] 4 msec 4 msec 4 msecIGP Label/VPnv6 label for default route
2 ::FFFF:172.20.246.53 [MPLS: Labels 916/81351 Exp 0] 4 msec 8 msec 4 msec
3 ::FFFF:172.16.228.241 [MPLS: Labels 29/16450/81351 Exp 0] 4 msec 8 msec 4 msec
4 2405:200:103:0:172:16:228:243 [MPLS: Labels 16007/16450/81351 Exp 0] 4 msec 4 msec 4 msec
5 2405:200:103::1:0:31 [MPLS: Labels 16450/81351 Exp 0] 4 msec 4 msec 4 msec
6 2405:200:103:C00:3:2:101:C9 8 msec 8 msec 8 msec

KLKTSURKESR002#sh isis neighbors

Tag RAN:
System Id

Type Interface IP Address

KLKTSKBTESR001 L2 BD353

State Holdtime Circuit Id

172.21.92.214 UP 26

00

KLKTSURKESR002#sh mpls ldp neighbor bdi353


Peer LDP Ident: 172.23.249.85:0; Local LDP Ident 172.23.251.228:0
TCP connection: 172.23.249.85.646 - 172.23.251.228.51580
State: Oper; Msgs sent/rcvd: 121299/121334; Downstream

Up time: 10w2d
LDP discovery sources:
BDI353, Src IP addr: 172.21.92.214
Targeted Hello 172.23.251.228 -> 172.23.249.85, active, passive
Addresses bound to peer LDP Ident:
172.23.249.85 172.21.193.5 172.21.193.128 172.20.246.52
172.21.92.214 172.21.107.100

########################Second hop#####################

Xshell:\> telnet 172.23.249.85

------------------------------------------------------------------------NE-ID INKOKLKTSKBTNB6001ENBESR001
SAP-ID I-KO-KLKT-ENB-6314
FAC-ID INKOKLKTSKBTNB6001
HostName KLKTSKBTESR001
------------------------------------------------------------------------KLKTSKBTESR001#SHOW BGP VPNV6 UNI VRF RJIL-BEARER-ENB ::/0
BGP routing table entry for [172.23.249.85:2]::/0, version 396438
Paths: (4 available, best #3, table RJIL-BEARER-ENB)
Not advertised to any peer
Refresh Epoch 2
Local, imported path from [49.44.5.72:2]::/0 (global)
::FFFF:49.44.5.72 (metric 10) (via default) from 172.23.240.99 (172.16.76.55)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.72, Cluster list: 172.16.76.55, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/24234
rx pathid: 0, tx pathid: 0
Refresh Epoch 2
Local, imported path from [49.44.5.71:2]::/0 (global)
::FFFF:49.44.5.71 (metric 10) (via default) from 172.23.240.99 (172.16.76.55)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701

Originator: 49.44.5.71, Cluster list: 172.16.76.55, 49.44.0.193, 0.0.7.208 , recursive-via-host


mpls labels in/out nolabel/16000
rx pathid: 0, tx pathid: 0
Refresh Epoch 2
Local, imported path from [49.44.5.69:2]::/0 (global)
::FFFF:49.44.5.69 (metric 10) (via default) from 172.23.240.99 (172.16.76.55)
Origin IGP, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64730:12701
Originator: 49.44.5.69, Cluster list: 172.16.76.55, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/81351 BGP VPNv6 Label used
rx pathid: 0, tx pathid: 0x0
Refresh Epoch 2
Local, imported path from [49.44.5.70:2]::/0 (global)
::FFFF:49.44.5.70 (metric 10) (via default) from 172.23.240.99 (172.16.76.55)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.70, Cluster list: 172.16.76.55, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16253
rx pathid: 0, tx pathid: 0

KLKTSKBTESR001#sh ip route 49.44.5.69 SAR IP learned via ISIS


Routing entry for 49.44.5.69/32
Known via "isis", distance 115, metric 10
Tag 5000, type level-2
Redistributing via isis RAN
Last update from 172.20.246.53 on BDI354, 6d01h ago
Routing Descriptor Blocks:
* 172.20.246.53, from 172.23.240.99, 6d01h ago, via BDI354
Route metric is 10, traffic share count is 1
Route tag 5000

KLKTSKBTESR001#sh mpls forwarding-table 49.44.5.69


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

200

916

or Tunnel Id

interface

49.44.5.69/32 7923496583 BD354

172.20.246.53

KLKTSKBTESR001#sh ip cef 49.44.5.69


49.44.5.69/32
nexthop 172.20.246.53 BDI354 label 916

KLKTSKBTESR001#SHOW mpls forwarding-table VRF RJIL-BEARER-ENB ::/0


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

None

81351

or Tunnel Id
::/0[V]

interface

BD354

172.20.246.53

KLKTSURKESR002#TRACeroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:C9


1 ::FFFF:172.21.92.214 [MPLS: Labels 200/81351 Exp 0] 4 msec 4 msec 4 msec Local label for SAR
2 ::FFFF:172.20.246.53 [MPLS: Labels 916/81351 Exp 0] 4 msec 8 msec 4 msecIGP Label/VPnv6 label for default route
3 ::FFFF:172.16.228.241 [MPLS: Labels 29/16450/81351 Exp 0] 4 msec 8 msec 4 msec
4 2405:200:103:0:172:16:228:243 [MPLS: Labels 16007/16450/81351 Exp 0] 4 msec 4 msec 4 msec
5 2405:200:103::1:0:31 [MPLS: Labels 16450/81351 Exp 0] 4 msec 4 msec 4 msec
6 2405:200:103:C00:3:2:101:C9 8 msec 8 msec 8 msec

KLKTSKBTESR001#sh isis neighbors

Tag RAN:
System Id

Type Interface IP Address

State Holdtime Circuit Id

KLKTSKTLPAR001 L2 BD354

172.20.246.53 UP 26

00

KLKTSURKESR002 L2 BD352

172.21.92.215 UP 25

01

KLKTKSLPESR001 L2 BD355

172.21.107.101 UP 23

01

KLKTSKBTESR001#sh mpls ldp neighbor bdi354


Peer LDP Ident: 172.16.76.55:0; Local LDP Ident 172.23.249.85:0
TCP connection: 172.16.76.55.646 - 172.23.249.85.18537
State: Oper; Msgs sent/rcvd: 168050/177612; Downstream
Up time: 13w3d
LDP discovery sources:
Targeted Hello 172.23.249.85 -> 172.16.76.55, active, passive
BDI354, Src IP addr: 172.20.246.53
Addresses bound to peer LDP Ident:

172.16.76.55 172.23.240.99 172.16.229.235 172.20.231.246


172.20.246.53 172.20.229.27 172.21.92.214 172.20.234.71
172.20.236.241 172.21.51.1

172.16.228.240

######################Third hop########################
Xshell:\> telnet 172.16.76.55
------------------------------------------------------------------------KLKTSKTLPAR001#SHOW BGP VPNV6 UNI VRF RJIL-BEARER-ENB ::/0
BGP routing table entry for [172.16.76.55:2]::/0, version 5518344
Paths: (4 available, best #3, table RJIL-BEARER-ENB)
Not advertised to any peer
Refresh Epoch 1
Local, imported path from [49.44.5.72:2]::/0 (global)
::FFFF:49.44.5.72 (metric 30) (via default) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.72, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/24234
rx pathid: 0, tx pathid: 0
Refresh Epoch 1
Local, imported path from [49.44.5.71:2]::/0 (global)
::FFFF:49.44.5.71 (metric 30) (via default) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.71, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16000
rx pathid: 0, tx pathid: 0
Refresh Epoch 1
Local, imported path from [49.44.5.69:2]::/0 (global)
::FFFF:49.44.5.69 (metric 30) (via default) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64730:12701
Originator: 49.44.5.69, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/81351
rx pathid: 0, tx pathid: 0x0

Refresh Epoch 1
Local, imported path from [49.44.5.70:2]::/0 (global)
::FFFF:49.44.5.70 (metric 30) (via default) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.70, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16253
rx pathid: 0, tx pathid: 0

KLKTSKTLPAR001#SHOW mpls forwarding-table VRF RJIL-BEARER-ENB ::/0


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

None

81351

or Tunnel Id
::/0[V]

interface

KLKTSKTLPAR001#sh ip route 49.44.5.69BGP IPv4 LU for SAR


Routing entry for 49.44.5.69/32
Known via "bgp 55836", distance 200, metric 0, type internal
Redistributing via isis RAN
Advertised by isis RAN metric-type internal level-2 route-map RJIL-BGP2ISIS-IPv4
Last update from 49.44.0.193 3d23h ago
Routing Descriptor Blocks:
* 49.44.0.193, from 49.44.0.193, 3d23h ago, recursive-via-host
Route metric is 0, traffic share count is 1
AS Hops 0
MPLS label: 16450
MPLS Flags: NSF

KLKTSKTLPAR001#sh mpls forwarding-table 49.44.5.69


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

or Tunnel Id

Switched

916

16450

49.44.5.69/32 89622691870 BD370

interface

KLKTSKTLPAR001#sh ip cef 49.44.5.69


49.44.5.69/32
nexthop 172.16.228.241 BDI370 label [29|1516] 16450

172.16.228.241

repair: attached-nexthop 172.16.229.234 TenGigabitEthernet0/0/0

KLKTSKTLPAR001#sh ip bgp 49.44.5.69


BGP routing table entry for 49.44.5.69/32, version 8812057
Paths: (2 available, best #1, table default)
Additional-path-install
Not advertised to any peer
Refresh Epoch 1
Local
49.44.0.193 (metric 30) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal, best
Community: 64603:127
Originator: 49.44.5.69, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16450
rx pathid: 0, tx pathid: 0x0
Refresh Epoch 1
Local
49.44.0.194 (metric 30) from 49.44.0.194 (49.44.0.194)
Origin IGP, metric 0, localpref 100, valid, internal, backup/repair
Community: 64603:127
Originator: 49.44.5.69, Cluster list: 49.44.0.194, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16442
rx pathid: 0, tx pathid: 0

KLKTSKTLPAR001#show ip route 49.44.0.193ISIS label for AG3


Routing entry for 49.44.0.193/32
Known via "isis", distance 115, metric 30
Tag 5000, type level-1
Redistributing via isis CORE, isis RAN
Last update from 172.16.228.241 on BDI370, 3d23h ago
Routing Descriptor Blocks:
* 172.16.228.241, from 49.44.0.193, 3d23h ago, via BDI370
Route metric is 30, traffic share count is 1
Route tag 5000
Repair Path: 172.16.229.234, via TenGigabitEthernet0/0/0

KLKTSKTLPAR001#sh ip cef 49.44.0.193


49.44.0.193/32
nexthop 172.16.228.241 BDI370 label [29|1516]
repair: attached-nexthop 172.16.229.234 TenGigabitEthernet0/0/0

KLKTSKTLPAR001#sh mpls for 49.44.0.193


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

977

29

or Tunnel Id

interface

49.44.0.193/32 5596248

BD370

172.16.228.241

KLKTSURKESR002#TRACeroute vrf RJIL-BEARER-ENB 2405:200:103:C00:3:2:101:C9


1 ::FFFF:172.21.92.214 [MPLS: Labels 200/81351 Exp 0] 4 msec 4 msec 4 msec
2 ::FFFF:172.20.246.53 [MPLS: Labels 916/81351 Exp 0] 4 msec 8 msec 4 msec Local label for SAR
3 ::FFFF:172.16.228.241 [MPLS: Labels 29/16450/81351 Exp 0] 4 msec 8 msec 4 msecIGP Label/BGP IPv4 LU/VPnv6 label
for default route
4 2405:200:103:0:172:16:228:243 [MPLS: Labels 16007/16450/81351 Exp 0] 4 msec 4 msec 4 msec
5 2405:200:103::1:0:31 [MPLS: Labels 16450/81351 Exp 0] 4 msec 4 msec 4 msec
6 2405:200:103:C00:3:2:101:C9 8 msec 8 msec 8 msec

KLKTSKTLPAR001#sh isis neighbors

Tag CORE:
System Id

Type Interface IP Address

State Holdtime Circuit Id

KLKTCHTRPAR001 L1 Te0/0/0

172.16.229.234 UP 29

00

KLKTTMHTPAR001 L1 BD370

172.16.228.241 UP 23

01

Tag RAN:
System Id

Type Interface IP Address

KLKTTMHTPAR001 L2 BD371

State Holdtime Circuit Id

172.20.231.247 UP 29

04

KLKTTLIRESR001 L2 BD353

172.20.236.240 UP 26

03

KLKTSKTLESR003 L2 BD361

172.20.234.70 UP 21

00

KLKTSKTLESR001 L2 BD352

172.20.229.26 UP 28

00

KLKTTMHTESR002 L2 BD354
KLKTSKBTESR001 L2 BD351

172.21.51.0

UP 21

00

172.20.246.52 UP 24

01

KLKTSKTLPAR001#sh mpls ldp neighbor bdi370


Peer LDP Ident: 172.16.76.140:0; Local LDP Ident 172.16.76.55:0
TCP connection: 172.16.76.140.41548 - 172.16.76.55.646
State: Oper; Msgs sent/rcvd: 210052/210402; Downstream
Up time: 15w1d
LDP discovery sources:
BDI371, Src IP addr: 172.20.231.247
Targeted Hello 172.16.76.55 -> 172.16.76.140, active, passive
BDI370, Src IP addr: 172.16.228.241
Addresses bound to peer LDP Ident:
172.16.76.140 172.23.240.129 172.16.228.241 172.20.231.247
172.16.228.242 172.21.51.3

172.20.236.243 172.20.234.73

172.21.70.143

#######################################################
Xshell:\> telnet 172.16.76.140
------------------------------------------------------------------------KLKTTMHTPAR001#SHOW BGP VPNV6 UNI VRF RJIL-BEARER-ENB ::/0
BGP routing table entry for [172.16.76.140:2]::/0, version 474051
Paths: (4 available, best #3, table RJIL-BEARER-ENB)
Not advertised to any peer
Refresh Epoch 1
Local, imported path from [49.44.5.72:2]::/0 (global)
::FFFF:49.44.5.72 (metric 20) (via default) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.72, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/24234
rx pathid: 0, tx pathid: 0
Refresh Epoch 1
Local, imported path from [49.44.5.71:2]::/0 (global)
::FFFF:49.44.5.71 (metric 20) (via default) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701

Originator: 49.44.5.71, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host


mpls labels in/out nolabel/16000
rx pathid: 0, tx pathid: 0
Refresh Epoch 1
Local, imported path from [49.44.5.69:2]::/0 (global)
::FFFF:49.44.5.69 (metric 20) (via default) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64730:12701
Originator: 49.44.5.69, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/81351
rx pathid: 0, tx pathid: 0x0
Refresh Epoch 1
Local, imported path from [49.44.5.70:2]::/0 (global)
::FFFF:49.44.5.70 (metric 20) (via default) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.70, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16253
rx pathid: 0, tx pathid: 0

KLKTTMHTPAR001#SHOW mpls forwarding-table VRF RJIL-BEARER-ENB ::/0


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

None

81351

or Tunnel Id
::/0[V]

interface

KLKTTMHTPAR001#sh ip route 49.44.5.69


Routing entry for 49.44.5.69/32
Known via "bgp 55836", distance 200, metric 0, type internal
Redistributing via isis RAN
Advertised by isis RAN metric-type internal level-2 route-map RJIL-BGP2ISIS-IPv4
Last update from 49.44.0.193 3d23h ago
Routing Descriptor Blocks:
* 49.44.0.193, from 49.44.0.193, 3d23h ago, recursive-via-host
Route metric is 0, traffic share count is 1
AS Hops 0

MPLS label: 16450


MPLS Flags: NSF

KLKTTMHTPAR001#sh mpls forwarding-table 49.44.5.69


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

or Tunnel Id

Switched

138

16450

49.44.5.69/32 924437165084 Te0/0/0 172.16.228.243

interface

KLKTTMHTPAR001#sh ip cef 49.44.5.69


49.44.5.69/32
nexthop 172.16.228.243 TenGigabitEthernet0/0/0 label [16007|64] 16450
repair: attached-nexthop 172.16.76.50 MPLS-Remote-Lfa10211

KLKTTMHTPAR001#sh ip bgp 49.44.5.69


BGP routing table entry for 49.44.5.69/32, version 8656923
Paths: (2 available, best #1, table default)
Additional-path-install
Not advertised to any peer
Refresh Epoch 1
Local
49.44.0.193 (metric 20) from 49.44.0.193 (49.44.0.193)
Origin IGP, metric 0, localpref 100, valid, internal, best
Community: 64603:127
Originator: 49.44.5.69, Cluster list: 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16450
rx pathid: 0, tx pathid: 0x0
Refresh Epoch 1
Local
49.44.0.194 (metric 20) from 49.44.0.194 (49.44.0.194)
Origin IGP, metric 0, localpref 100, valid, internal, backup/repair
Community: 64603:127
Originator: 49.44.5.69, Cluster list: 49.44.0.194, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16442
rx pathid: 0, tx pathid: 0

KLKTTMHTPAR001#sh ip cef 49.44.0.193


49.44.0.193/32
nexthop 172.16.228.243 TenGigabitEthernet0/0/0 label [16007|64]
repair: attached-nexthop 172.16.76.50 MPLS-Remote-Lfa10211

KLKTTMHTPAR001#sh mpls forwarding-table 49.44.0.193ISIS label for AG3


Local

Outgoing Prefix

Bytes Label Outgoing Next Hop

Label

Label

Switched

29

16007

or Tunnel Id

interface

49.44.0.193/32 328766536828 Te0/0/0 172.16.228.243

KLKTTMHTPAR001#sh isis neighbors


Tag CORE:
System Id

Type Interface IP Address

KLKTBKSMAAR001 L1 Te0/0/0
KLKTSKTLPAR001 L1 BD370

State Holdtime Circuit Id

172.16.228.243 UP 22
172.16.228.240 UP 23

00
01

Tag RAN:
System Id

Type Interface IP Address

KLKTTLIRESR001 L2 BD353

State Holdtime Circuit Id

172.20.236.242 UP 22

KLKTSKTLPAR001 L2 BD371

172.20.231.246 UP 28

KLKTSKTLESR003 L2 BD355

172.20.234.72 UP 28

KLKTMHDGESR001 L2 BD352

172.21.70.142 UP 26

KLKTTMHTESR001 L2 BD354

172.21.51.2

UP 28

04
07
01
04
02

KLKTTMHTPAR001#sh run interface tenGigabitEthernet 0/0/0PAR to AAR Connection


interface TenGigabitEthernet0/0/0
description # TO-AG2/AG1-KLKTBKSMAAR001-TenGigE0/0/0/5-ETH #
mtu 9216
ip address 172.16.228.242 255.255.255.254
no ip redirects
no ip unreachables
no ip proxy-arp
ip router isis CORE
ip pim sparse-mode

load-interval 30
carrier-delay msec 0
ipv6 address 2405:200:103:0:172:16:228:242/127
ipv6 enable
ipv6 mtu 9216
no ipv6 redirects
no ipv6 unreachables
ipv6 router isis CORE
mpls ip
mpls ldp igp sync delay 25
synchronous mode
cdp enable
clns mtu 9200
isis circuit-type level-1
isis network point-to-point
service-policy input RJIL-QOS-NTWK-NNI-IN-PARENT
service-policy output RJIL-QOS-NTWK-NNI-OUT-PARENT
end

KLKTTMHTPAR001#sh mpls ldp neighbor tenGigabitEthernet 0/0/0


Peer LDP Ident: 49.44.0.208:0; Local LDP Ident 172.16.76.140:0
TCP connection: 49.44.0.208.646 - 172.16.76.140.33200
State: Oper; Msgs sent/rcvd: 203484/206738; Downstream
Up time: 15w0d
LDP discovery sources:
Targeted Hello 172.16.76.140 -> 49.44.0.208, active, passive
TenGigabitEthernet0/0/0, Src IP addr: 172.16.228.243
Addresses bound to peer LDP Ident:
49.44.0.208

172.16.228.243 172.16.125.145 172.16.231.154

172.16.228.60 172.16.117.213 172.16.125.3 172.16.228.58


172.17.32.25 172.16.117.81

#######################################################
Xshell:\> telnet 49.44.0.208
-------------------------------------------------------------------------

RP/0/RSP0/CPU0:KLKTBKSMAAR001#SH MPLs LDP BIndings 49.44.5.69/32


Fri Nov 27 15:54:01.471 IST
49.44.5.69/32, rev 0
No local binding
Remote bindings: (12 peers)
Peer

Label

----------------- -------172.16.76.57:0

1202

172.16.77.71:0

69

172.16.76.83:0

888

172.16.76.84:0

113

172.16.76.140:0

138

172.16.77.141:0

928

172.16.77.156:0

1034

172.16.77.183:0

441

49.44.0.193:0

16450

49.44.0.194:0

16442

172.16.77.210:0

975

172.16.76.242:0

216

RP/0/RSP0/CPU0:KLKTBKSMAAR001#SH MPLs LDP BIndings 49.44.0.193/32


Fri Nov 27 15:56:31.518 IST
49.44.0.193/32, rev 21872
Local binding: label: 16007
Remote bindings: (14 peers)
Peer

Label

----------------- -------172.16.76.57:0

649

172.16.77.71:0

810

172.16.76.83:0

766

172.16.76.84:0

883

172.16.76.140:0

29

172.16.77.141:0

972

172.16.77.156:0

1658

172.16.77.183:0

1019

49.44.0.193:0

IMP-NULL

49.44.0.194:0

16003

172.16.77.210:0

54

49.44.0.212:0

16010

49.44.0.218:0

16007

172.16.76.242:0

254

RP/0/RSP0/CPU0:KLKTBKSMAAR001#SH RUN INTerface BUndle-Ether 2AG2 to AG3 Bundle


Fri Nov 27 15:57:03.369 IST
interface Bundle-Ether2
description # TO-Remote-KLKTKTBACCR001-BE-713-ETH #
bfd address-family ipv4 timers start 180
bfd address-family ipv4 multiplier 3
bfd address-family ipv4 destination 172.16.228.61
bfd address-family ipv4 fast-detect
bfd address-family ipv4 minimum-interval 50
mtu 9216
service-policy output RJIL-QOS-NTWK-NNI-OUT-PARENT
ipv4 address 172.16.228.60 255.255.255.254
ipv4 unreachables disable
ipv6 address 2405:200:103::1:0:32/127
ipv6 unreachables disable
bundle minimum-active links 1
load-interval 30
dampening
!

#######################################################
Xshell:\> TELNET 49.44.0.193
------------------------------------------------------------------------RP/0/RP0/CPU0:KLKTSLEPCCR001#SH MPLs LDP BIndings 49.44.5.69/32
Fri Nov 27 15:57:43.369 IST
49.44.5.69/32, rev 766186
Local binding: label: 16450

Remote bindings: (38 peers)


Peer

Label

----------------- -------49.44.2.1:0
172.16.76.1:0
49.44.1.2:0

24016
794
17077

172.16.76.2:0

3004

172.16.76.13:0

1473

172.16.76.18:0

643

49.44.3.19:0

16285

49.44.3.20:0

16277

49.44.3.24:0

16280

49.44.3.27:0

16012

49.44.3.28:0

16140

172.16.77.40:0

802

49.44.2.65:0

16353

49.44.1.66:0

16080

49.44.2.66:0

17703

49.44.5.69:0

IMP-NULL

172.16.76.69:0

1474

49.44.5.70:0

52443

49.44.5.71:0

26958

49.44.5.72:0

24088

172.16.77.72:0

974

172.16.77.102:0

344

172.16.77.121:0

1280

172.16.77.181:0

630

49.44.0.194:0

16442

49.44.0.197:0

16128

49.44.0.198:0

16146

172.16.77.213:0

680

49.44.2.216:0

16291

49.44.2.217:0

16034

49.44.2.219:0

17450

49.44.2.220:0

17348

49.44.2.232:0

16351

49.44.2.237:0

16061

49.44.2.238:0

16091

172.16.76.242:0

216

49.44.2.246:0

16020

49.44.2.247:0

16327

RP/0/RP0/CPU0:KLKTSLEPCCR001#SH ISIS NEighbors | I KLKTBKSMAAR001


Fri Nov 27 15:58:31.102 IST
KLKTBKSMAAR001 BE713

*PtoP*

Up 25

L1 Capable

RP/0/RP0/CPU0:KLKTSLEPCCR001#SH RUN INTerface BUndle-Ether 713


Fri Nov 27 15:58:39.852 IST
interface Bundle-Ether713
description # TO-KLKTBKSMAAR001-BE-1-ETH #
bfd address-family ipv4 timers start 180
bfd address-family ipv4 multiplier 3
bfd address-family ipv4 destination 172.16.228.58
bfd address-family ipv4 fast-detect
bfd address-family ipv4 minimum-interval 50
mtu 9216
service-policy output RJIL-QOS-NTWK-NNI-OUT-PARENT
ipv4 address 172.16.228.59 255.255.255.254
ipv4 unreachables disable
ipv6 address 2405:200:103::1:0:31/127
ipv6 unreachables disable
bundle minimum-active links 1
load-interval 30
dampening
!

#########################CSS2##########################

Xshell:\> TELNET 172.23.251.9

------------------------------------------------------------------------NE-ID INKOKLKTMHDGTW6002ENBESR001
SAP-ID I-KO-KLKT-ENB-B016
FAC-ID INKOKLKTMHDGTW6002
HostName KLKTMHDGESR002
-------------------------------------------------------------------------

KLKTMHDGESR002#SH RUN VRF


vrf definition RJIL-BEARER-ENB
description *** FOR BEARER LTE SERVICES ***
rd 172.23.251.9:2
route-target export 64730:127
route-target export 64740:27007
route-target import 64730:12701
route-target import 64740:27007

interface BDI101
description # To eNode-B - R4G_Bearer #
vrf forwarding RJIL-BEARER-ENB
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 9216
load-interval 30
ipv6 address 2405:200:103:C00:3:2:101:C9/126
ipv6 enable
ipv6 mtu 9216
no ipv6 redirects
no ipv6 unreachables

KLKTMHDGESR002#SHOW BGP VPNV6 UNI VRF RJIL-BEARER-ENB ::/0


BGP routing table entry for [172.23.251.9:2]::/0, version 452578
Paths: (4 available, best #4, table RJIL-BEARER-ENB)
Not advertised to any peer

Refresh Epoch 1
Local, imported path from [49.44.5.72:2]::/0 (global)
::FFFF:49.44.5.72 (metric 30) (via default) from 172.23.240.127 (172.16.76.138)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.72, Cluster list: 172.16.76.138, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/24234
rx pathid: 0, tx pathid: 0
Refresh Epoch 1
Local, imported path from [49.44.5.71:2]::/0 (global)
::FFFF:49.44.5.71 (metric 30) (via default) from 172.23.240.127 (172.16.76.138)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.71, Cluster list: 172.16.76.138, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16000
rx pathid: 0, tx pathid: 0
Refresh Epoch 1
Local, imported path from [49.44.5.70:2]::/0 (global)
::FFFF:49.44.5.70 (metric 30) (via default) from 172.23.240.127 (172.16.76.138)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64730:12701
Originator: 49.44.5.70, Cluster list: 172.16.76.138, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/16253
rx pathid: 0, tx pathid: 0
Refresh Epoch 1
Local, imported path from [49.44.5.69:2]::/0 (global)
::FFFF:49.44.5.69 (metric 30) (via default) from 172.23.240.127 (172.16.76.138)
Origin IGP, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64730:12701
Originator: 49.44.5.69, Cluster list: 172.16.76.138, 49.44.0.193, 0.0.7.208 , recursive-via-host
mpls labels in/out nolabel/81351
rx pathid: 0, tx pathid: 0x0

####################################################################################################