Vous êtes sur la page 1sur 15

Routeurs Cisco

Mise en service dun routeur cisco


Table des matires
Mise en service dun routeur cisco.............................................................................1
I. Connexion du PC au routeur pour en faire la configuration......................................2
II. Configuration du routeur...............................................................................2
III. Voir et sauvegarder la configuration du routeur...................................................3
Show.........................................................................................................3
Sauvegarde et restauration..............................................................................3
IV. Configuration des interfaces rseau dun routeur CISCO.........................................4
A. Interfaces FastEthernet...............................................................................4
B. Interfaces series avec encapsulation PPP..........................................................4
C. Authentification PPP..................................................................................5
V. Activer et configurer le routage.......................................................................6
A. Forcer lactivation du routage.......................................................................6
B. Ajouter une route statique...........................................................................6
C. Ajouter une route par dfaut........................................................................6
D. Routage dynamique vecteurs de distance : RIP.................................................7
E. Routage dynamique tat de liens : OSPF........................................................8
F. Routage inter-VLAN ...................................................................................8
G. Afficher la table de routage.........................................................................8
VI. Connexion distance par telnet......................................................................9
VII. Activation de NAT......................................................................................9
A. Dfinitions :.............................................................................................9
NAT statique :............................................................................................10
Redirection de ports :...................................................................................10
Masquage d'adresse (surcharge) :.....................................................................10
Vrifications :.............................................................................................10
VIII. DHCP...................................................................................................11
IX. ACL :.......................................................................................................12
ACL standard (1 99) :..................................................................................12
ACL tendues (100 199) :.............................................................................12
X. IPv6 :......................................................................................................13
Routage statique en IPv6 :..............................................................................13
Routage RIPng :...........................................................................................13
Routage OSPFv3 :........................................................................................13
Routage EIGRPv6 :.......................................................................................13
Vrifications :.............................................................................................13
XI. R-initialisation de la configuration Routeur......................................................14
XII. Rinitialisation du Routeur aprs perte du mot de passe........................................14
XII. Rcupration dun dsastre (perte de lIOS).....................................................14

Dernires modifications le 30/03/11


- Page 1 -

Routeurs Cisco

I.

Connexion du PC au routeur pour en faire la configuration

1 - Brancher le port console sur le port srie dun micro-ordinateur,


2 - Sur le micro-ordinateur lancer Putty en choisissant la case serial
Si besoin, prciser le dbit (par dfaut 9600 bps).
3 - Valider la configuration
4 - Ensuite mettre le routeur sous tension,

II. Configuration du routeur


Une fois le routeur dmarr, la console de commande en ligne vous propose une invite ">"
signifiant que vous tes dans le mode utilisateur.

enable (en) : pour entrer dans le mode commande privilgi permettant la gestion (statistique,
debugage,) du fonctionnement du routeur. La validation de cette commande entrane souvent
la demande dun mot de passe. Par la suite pour revenir ce niveau du mode commande, il
suffira de taper CTRL+Z .
configure terminal (conf t) : pour entrer dans le mode de configuration globale. Ce mode est
utilis sur un routeur pour appliquer des instructions de configuration qui affectent lensemble
du systme.
A partir du mode ci-dessus, vous pouvez passer dans les modes spcifiques, linvite du routeur se
transforme et toute modification de la configuration sappliquera alors uniquement aux
interfaces ou aux processus couverts par le mode particulier.

Dernires modifications le 30/03/11


- Page 2 -

Routeurs Cisco

III. Voir et sauvegarder la configuration du routeur


Show
show ? (sh ?) : pour lister toutes les options possibles de la commande show. On peut noter que
quelle que soit la commande, et quel que soit le niveau de configuration, il est possible de
connatre les options en tapant un ?
show running-config (ou sh run) pour lister la configuration en cours dutilisation du routeur.
show startup-config (ou sh start) pour lister la configuration au dmarrage du routeur.
show ip route (ou sh ip route) pour lister la table de routage du routeur
show interface (ou sh int) pour lister les caractristiques des interfaces
show interface s0 (ou sh int s0) pour lister les caractristiques de linterface Serial 0

Sauvegarde et restauration
On peut aussi utiliser la commande copy pour copier une configuration en mmoire non volatile
ou pour rcuprer une configuration partir de la mmoire non volatile ou dailleurs

copy run start


pour copier la configuration en train de fonctionner vers la mmoire non volatile.
copy start run
pour copier de la mmoire non volatile la configuration qui va fonctionner
copy tftp start
pour copier un fichier dun serveur tftp vers la mmoire non volatile
copy start tftp
pour copier de la mmoire non volatile le fichier de configuration vers un serveur tftp

Dernires modifications le 30/03/11


- Page 3 -

Routeurs Cisco

IV. Configuration des interfaces rseau dun routeur CISCO


A. Interfaces FastEthernet
enable
Pour entrer dans le mode commande privilgi. (Si ce nest dj fait)
configure terminal
Pour modifier la configuration globale (Si vous nest pas dj dans ce mode)
interface fastethernet 0/0
Pour rentrer dans le mode de commande spcifique concernant linterface ethernet 0
ip address 10.0.0.1 255.0.0.0
Pour affecter une adresse IP et son masque de sous-rseau linterface dfini par la commande
interface Fast Ethernet 0/0
no shutdown
Pour indiquer que cette interface ne doit pas tre inactive.
<crtl z>
Pour revenir en mode commande
show interface fastethernet 0/0
Pour vrifier la configuration de linterface dfini par la commande interface ethernet 0

B. Interfaces series avec encapsulation PPP


Ex : Configuration IP de linterface serie serial 0/0
enable
configure terminal
interface serial 0/0
ip address 10.0.0.1 255.0.0.0
encapsulation ppp

Permet pour une interface srie dutiliser le protocole point to point sur la liaison srie.
Seul le routeur faisant office de DCE doit fournir lhorloge :
clock rate XXXXXX
Par exemple : clockrate 64000 pour un dbit de 64 kbit/s.
no shutdown
<crtl z>
show interface serial 0/0
show controllers serial 0/0

Dernires modifications le 30/03/11


- Page 4 -

Routeurs Cisco

C. Authentification PPP
Les deux types principaux d'authentification avec PPP sont :
Le protocole PAP : A dconseiller car il transmet les mots de passe en clair sur le rseau.
Le protocole CHAP : Il est beaucoup plus scuris car il utilise les mots de passe par
challenge (voir le principe ici).
Configuration de CHAP entre R1 et R2 :
Sur R1 :
hostname r1
username r2 secret motdepassecommun
interfaces s0/0
ppp authentication chap
Sur R2 :
hostname r2
username r1 secret motdepassecommun
interfaces s0/0
ppp authentication chap

Dernires modifications le 30/03/11


- Page 5 -

Routeurs Cisco

V. Activer et configurer le routage


A. Forcer lactivation du routage
enable
configure terminal
ip routing

B. Ajouter une route statique


enable
configure terminal
ip route @IP_rseau_dest
Pour indiquer une route statique.

Exemples :
ip route
ip route

masque

prochain saut

192.168.10.0 255.255.255.0 s0
192.168.5.0 255.255.255.0 192.168.10.1

C. Ajouter une route par dfaut


enable
configure terminal
ip route 0.0.0.0 0.0.0.0 prochain saut
Dfinit le prochain saut comme chemin de destination pour les paquets qui ne comportent pas
d'entres dans la table de routage.

Dernires modifications le 30/03/11


- Page 6 -

Routeurs Cisco

D. Routage dynamique vecteurs de distance : RIP


enable
configure terminal
router rip

Indiquer les rseaux directement connects au routeur qui


participent et seront diffuss dans les paquets RIP.
network adresse du rseau

Par exemple :
network 192.168.1.0
network 192.168.2.0
version 1 ou version 2
Envoyer et recevoir uniquement pour la version 1 ou 2 de RIP.
Il est possible de spcifier la version de RIP utilise pour les mises jour envoyes et
reues.
ip rip send version 1 ou 2
ip rip receive version 1 ou 2

ip default-network reseau
Permet de faire propager un rseau de passage pour sortir sur une destination inconnue.
show ip protocol
Affiche les valeurs des compteurs de routage et les informations de rseau associes
l'ensemble du routeur.
debug ip rip
Permet de voir l'cran tous les changes RIP. S'arrte avec no debug ip rip.

Dernires modifications le 30/03/11


- Page 7 -

Routeurs Cisco

E. Routage dynamique tat de liens : OSPF


enable
configure terminal
router ospf id-processus
LID de processus est un numro qui permet didentifier un processus de routage OSPF sur le
routeur. Plusieurs processus OSPF peuvent tre dmarrs sur un mme routeur. Ce numro peut
tre nimporte quelle valeur comprise entre 1 et 65535.
network adresse rseau masque-gnrique area n zone
Ladresse rseau peut tre celle dun rseau entier ou dun sous-rseau.
Le masque gnrique est un masque de sous rseau invers : Pour un masque de sousrseau de 255.255.255.0, le masque gnrique est 0.0.0.255
Chaque rseau doit pouvoir tre identifi par la zone auquel il appartient.
default-information originate
Propagation de la route par dfaut tous les routeurs situs dans la zone OSPF.

Pour que lOSPF fonctionne de manire approprie, il est essentiel de dfinir la bande passante
des interfaces sries.
interface serial 0/0
bandwidth bp en kbit/s
Par exemple pour une liaison 64 kbit/s : bandwidth 64

F. Routage inter-VLAN
Dans lexemple, le routeur a trois sousinterfaces configures sur linterface
Fast Ethernet 0/0.
Ces
trois
sous-interfaces
sont
identifies par 0/0.1, 0/0.2 et 0/0.3.
Toutes les interfaces sont encapsules
pour 802.1Q.

G. Afficher la table de routage


enable
show ip route

Affiche la table de routage IP qui contient toutes les entres des rseaux et des sous-rseaux
connus, avec un code indiquant la faon dont les informations ont t acquises. Ex : S pour route
statique ; R pour route dcouverte par RIP.

Dernires modifications le 30/03/11


- Page 8 -

Routeurs Cisco

VI. Connexion distance par telnet


Pour que le routeur accepte une connexion telnet, vous devez mettre un mot de passe pour au
mode privilgi
Passer en mode privilgi puis en mode de configuration :
enable secret mot_de_passe
Vous devez autoriser les connexions telnet
line vty 0 4
password mot_de_passe
Pour tester, vous pouvez taper avec un ordinateur sous Windows ou Linux :
telnet adresse IP du routeur

VII. Activation de NAT


A. Dfinitions :

Inside addresses Lensemble des rseaux internes l'entreprise.


Outside addresses Adresses publiques sur Internet.
Inside local address Ladresse IP dun hte interne.
Inside global address Ladresse IP dun hte interne telle quelle apparat l'extrieur.
Ladresse translate l'aller.
Outside global address Ladresse IP d'un hte externe.
NAT peut tre utilis pour effectuer plusieurs fonctions:
Nat statique mapping entre adresses inside local et global.
Nat dynamique Permet de rsoudre les problmes dadressage quand il y a recouvrement
entre les adresses internes et externes.
Redirection de ports On peut dfinir un port sur le routeur qui sera toujours redirig vers un
serveur local n'ayant pas d'adresse publique.

Dernires modifications le 30/03/11


- Page 9 -

Routeurs Cisco
Ici on considre que fa0/0 reprsente le rseau interne de l'entreprise
et s0/0 reprsente l'interface connecte vers l'extrieur.

NAT statique :
interface f 0/0
ip nat inside
interface s 0/0
ip nat outside
CTRL + Z
ip nat inside source static <adresse-interne> <adresse-externe>

Redirection de ports :
interface f 0/0
ip nat inside
interface s 0/0
ip nat outside
ip nat inside source static tcp <adr-interne> <port> <adr-externe>
<port> extendable
ip nat inside source static udp <adr-interne> <port> <adr-externe>
<port> extendable

Masquage d'adresse (surcharge) :


ip nat pool <nom-du-pool> <ip-publique-dbut> <ip-publique-fin>
netmask 255.255.255.0

Liste des adresses ligibles au masquage d'adresses :


access-list <n> permit <adresse-rseau> <masque-gnrique>
Association de la liste dadresses globale avec les adresses internes autorises (par ACL)
ip nat inside source list <n> pool <nom-du-pool> overload
Dfinition des interfaces du routeur Intranet/Internet
interface fa 0/0
ip nat inside
interface serial 0/0
ip nat outside

Vrifications :
show ip nat translations

Supprimer les translations statiques


clear ip nat translation *

Dernires modifications le 30/03/11


- Page 10 -

Routeurs Cisco

VIII. DHCP
Dans la configuration de linterface qui est connect au serveur :
Quand un serveur DHCP et un client ne se trouvent pas sur le mme segment et sont spars par
un routeur, la commande ip helper-address permet de relayer les requtes de broadcast.
ip helper-address adresse DHCP
pour relayer les requtes de broadcast pour ces services UDP cls.
Il peut y avoir plusieurs helper-address si plusieurs serveurs.
ip dhcp pool nom
network adresse rseau masque
default-router adresse de la passerelle
dns-server adresse serveur DNS
domain-name nom de domaine
netbios-name-server adresse serveur DNS
lease jours heures minutes
exit
ip dhcp excluded-address adresse exclue 1 adresse exclue 2

Vrification du fonctionnement du DHCP :


show ip dhcp binding
permet de vrifier le fonctionnement du protocole DHCP.
debug ip dhcp server events
permet de dpanner le protocole DHCP.
show ip dhcp server statistics
permet de sassurer que des broadcasts sont reus, ou envoys, par le routeur. Celle-ci permet
dafficher le nombre de messages DHCP envoys et reus.

Dernires modifications le 30/03/11


- Page 11 -

Routeurs Cisco

IX. Recommandations Cisco pour les ACL


Les rgles de base suivantes doivent tre respectes lors de la cration et de lapplication des
listes daccs :

Une liste daccs par direction et par protocole.


Les listes daccs standard doivent tre appliques le plus prs possible de la
destination.
Les listes daccs tendues doivent tre appliques le plus prs possible de la source.
Pour faire rfrence une interface dentre ou de sortie, placez-vous lintrieur du
routeur en regardant l'interface en question.
Les instructions sont traites dans lordre depuis le dbut de la liste jusqu la fin jusqu
ce quune correspondance soit trouve. Si aucune correspondance nest dtecte, le
paquet est refus.
Il existe un refus implicite deny any la fin de toutes les listes de contrle daccs. Cela
napparat pas dans la liste de configuration.
Les entres de la liste daccs doivent filtrer les paquets dans lordre, du plus spcifique
au plus gnral. Les htes spcifiques doivent tre rejets en premier, tandis que les
groupes ou les filtres gnraux viennent en dernier.
La condition de correspondance est examine en premier. Lacceptation ou le refus est
examin UNIQUEMENT si la condition est vraie.
Ne travaillez jamais avec une liste daccs qui est applique de manire active.
Utilisez un diteur de texte pour crer des commentaires indiquant la logique, puis
ajoutez les instructions correspondantes.
Les nouvelles lignes sont toujours ajoutes la fin de la liste de contrle daccs. La
commande no access-listx supprime toute la liste. Il nest pas possible dajouter et de
supprimer des lignes spcifiques dans des listes daccs numrotes.
Une liste daccs IP envoie un message ICMP dhte inaccessible lmetteur du paquet
rejet et limine le paquet dans la corbeille prvue cet effet.
Soyez particulirement attentif lorsque vous supprimez une liste daccs. Si la liste
daccs est applique une interface de production et que vous la supprimez, selon la
version de lIOS, une instruction deny any peut tre applique par dfaut linterface et
tout le trafic peut tre arrt.
Les filtres de sortie ne concernent pas le trafic gnr par le routeur local.

Dernires modifications le 30/03/11


- Page 12 -

Routeurs Cisco

Exemples d'ACL simples :


Access-list

<n>

<permit ou deny>

host <adr-hte>
ou <adresse-rseau> <masque-gnrique>

L'ACL suivante interdit les requtes provenant de l'hte 192.168.0.1


Access-list 10 deny host 192.168.0.1
L'ACL suivante interdit les requtes provenant du rseau 192.168.0.0
Access-list 10 permit 192.168.0.0 0.0.0.255
On applique l'ACL 10 la sortie de l'interface FastEthernet 0/0
interface f0/0
ip access-group 10 out

Exemples d'ACL tendues :


access-list

<n>

permit ou deny
<ip, icmp, tcp, udp>
<ip-source>
<gt ou lt ou eq (plus grand, plus petit ou gal )> <nport>
<ip-destination>
<gt ou lt ou eq (plus grand, plus petit ou gal )> <nport>

L'ACL suivante permet au clients du rseau 192.168.0.0/24 d'aller visiter le serveur Web :
access-list 101 permit tcp 192.168.0.0 0.0.0.255 gt 1023
host 192.168.1.1 eq 80
Permettre les requtes ICMP du rseau 172.16.0.0 au 172.17.0.0
access-list 101 permit icmp 172.16.0.0 0.0.0.255 172.17.0.0 0.0.0.255
On applique l'ACL 101 l'entr de l'interface FastEthernet 0/0
interface f0/0
ip access-group 101 in

Exemples d'ACL nommes :


ip

access-list
extended
<nom>
permit <ip, icmp, tcp, udp> <ip-source> <gt,lt,eq> <nport> <ip-dest> <gt,lt,eq> <nport>

L'ACL suivante permet au clients du rseau 192.168.0.0/24 d'aller visiter le serveur Web et DNS :
ip access-list extended monacl
permit tcp 192.168.0.0 0.0.0.255 gt 1023 host 192.168.1.1 eq 80
permit udp 192.168.0.0 0.0.0.255 gt 1023 host 192.168.2.1 eq 53
On applique l'ACL monacl l'entr de l'interface FastEthernet 0/0
interface f0/0
ip access-group monacl in
Dernires modifications le 30/03/11
- Page 13 -

Routeurs Cisco

X. IPv6 :
Activer le routage IPv6 sur le routeur :
(config)# ipv6 unicast-routing
Donner une adresse IPv6 statique ou en auto-configuration une interface :
(config-if)# ipv6 address <adresse>/<masque>
Donner une adresse IPv6 en mode autoconfiguration (norme eui-64) :
(config-if)# ipv6 address <prfixe>/<masque> eui-64

Routage statique en IPv6 :


(config)# ipv6
(config)# ipv6

route
route

<adresse-rseau>/<masque>
<adresse-rseau>/<masque>

<passerelle>
<interface de sortie>

Routage RIPng :
Avec RIPng, vous n'avez plus dfinir les adresses rseaux avec la commande network.
Il faut activer RIP sur les interfaces sur lesquelles les adresse rseaux sont transmettre.
(config)# ipv6 router rip <nom du processus>
(config-router)# exit
(config)# int s0/0
(config-if)# ipv6 rip <nom du processus> enable

Routage OSPFv3 :
Avec OSPFv3, de mme que pour RIPng, plus de commande network mais l'activation du
processus de routage sur l'interface que l'on souhaite.
(config)# ipv6 router ospf <n processus>
(config-router)# exit
(config)# int s0/0
(config-if)# ipv6 ospf <n processus> area <n zone>

Routage EIGRPv6 :
Avec EIGRPv6, de mme que pour RIPng et OSPFv3, plus de commande network mais l'activation
du processus de routage sur l'interface que l'on souhaite.
(config)# ipv6 router eigrp <n processus>
(config-router)# exit
(config)# int s0/0
(config-if)# ipv6 eigrp <n processus>

Vrifications :
Les commandes show de ipv4 existent de la mme manire en IPv6 :
show ipv6 interfaces brief
show ipv6 route
show ipv6 protocols
...
Dernires modifications le 30/03/11
- Page 14 -

Routeurs Cisco

XI. R-initialisation de la configuration Routeur


1 - Brancher le port console sur le port srie dun micro-ordinateur,
2 - Effacer la mmoire de dmarrage
WR ERASE <Entre>
# pour effacer la configuration existante.
RELOAD <Entre> (pour rebouter le routeur).
3 - Au redmarrage du routeur, rpondre :
no la question d'autoconfiguration.
Puis le prompt

XII. Rinitialisation du Routeur aprs perte du mot de passe


1 - Brancher le port console sur le port srie dun ordinateur. Mettre le routeur sous tension.
2 - Ds que des informations apparaissent sur lcran appuyer sur les touches CRTL + PAUSE.
3 - Le prompt > apparat, taper alors les commandes suivantes
confreg 0x2142
reset
4 - Le redmarrage du routeur se fait, rpondre : no la question.
5 - le prompt Routeur(Boot) apparat. Pour changer la configuration de Boot taper
EN
<Entre>
# pour activer le mode administration du routeur.
Erase start
<Entre> # pour effacer la configuration existante d'un routeur 2600.
CONF T
<Entre>
# pour accder aux commandes de configuration du routeur.
CONFIG-REGISTER 0x2102 <Entre>
# pour redmarrer le routeur normalement).
CRTL+Z
<Entre>
# pour revenir en mode commande gnral .
RELOAD <Entre> (pour rebouter le routeur).
Aprs la question : voulez-vous sauvegarder la configuration ?, tapez Y

XII. Rcupration dun dsastre (perte de lIOS)


1 - Brancher le port console sur le port srie dun ordinateur. Mettre le routeur sous tension.
2 - Ds que des informations apparaissent sur lcran appuyer sur les touches CRTL + PAUSE.
3 - Le prompt > apparat, taper alors les commandes suivantes
IP_ADDRESS=171.68.171.0
IP_SUBNET_MASK=255.255.254.0
DEFAULT_GATEWAY=171.68.170.3
TFTP_SERVER=171.69.1.129
TFTP_FILE=c2600-is-mz.113-2.0.3.Q
tftpdnld

IP_ADDRESS: @ adresse

IP_SUBNET_MASK: masque

DEFAULT_GATEWAY: passerelle

TFTP_SERVER: @adresse du serveur tftp (vrifier la connection avant)

TFTP_FILE: Nom de limage

Do you wish to continue? y/n: [n]: y


Receiving c2600-is-mz.113-2.0.3.Q from 171.69.1.129 !!!!!!!!!!!!!!!!!!!!!

reload

Dernires modifications le 30/03/11


- Page 15 -

Vous aimerez peut-être aussi