Vous êtes sur la page 1sur 4

323 M de R

SEMANA 39

SEGUNDA PARCIAL 1/4

VERSION: 1

LAPSO 2016-1

323 M de R SEMANA 39 SEGUNDA PARCIAL 1/4 VERSION: 1 LAPSO 2016-1 UNIVERSIDAD NACIONAL ABIERTA

UNIVERSIDAD NACIONAL ABIERTA VICERRECTORADO ACADÉMICO ÁREA INGENIERÍA

MODELO

DE RESPUESTA

ASIGNATURA: COMPUTACIÓN I

MOMENTO:

SEGUNDA PARCIAL

CÓDIGO: 323 VERSIÓN: 01

FECHA DE APLICACIÓN: 24/09/2016

MOD.II, UND. 3, OBJ.3

1.- Solución:

CRITERIO DE DOMINIO 1/1

CI, TOTCI, INDICE: Entero

A: Arreglo [1 cedulas**

..

N]

de enteros

**vector o arreglo que almacena

INICIO TOTCI, CI=0 INDICE= 1 ESCRIBIR “registre cédula = cero (0) para salir” LEER:CI **si el usuario registra cero como cedula podrá salir** MIENTRAS CI # 0 HACER SI CI > 500000 y CI < 90000000 **rango de cédulas válidas** A[INDICE] =CI

TOTCI=TOTCI+1

INDICE=INDICE + 1 FIN_SI SINO ESCRIBIR: “Registre una cédula válida” FIN_SINO LEER: CI

Especialista: Mercedes Picón

Ingeniería de Sistemas

Evaluador: Sandra Sánchez

323 M de R

SEMANA 39

SEGUNDA PARCIAL 2/4

VERSION: 1

LAPSO 2016-1

FIN_MIENTRAS ESCRIBIR: “Total cédulas registradas: ”, TOTCI

FIN

Corrida del pseudocódigo:

  • 1. TOTCI= 0, CI=0, INDICE=1 **valores iniciales**

  • 2. TOTCI= 0, CI=1111111, INDICE=1

  • 3. TOTCI= 1, CI=1111111, INDICE=2, A[1]= 1111111

  • 4. TOTCI= 1, CI=2222222, INDICE=2, A[1]= 1111111

  • 5. TOTCI= 2, CI=2222222, INDICE=3, A[2]= 2222222

  • 6. TOTCI= 2, CI=3333333, INDICE=3, A[2]= 2222222

  • 7. TOTCI= 3, CI=3333333, INDICE=4, A[3]= 3333333

  • 8. TOTCI= 3, CI=0 **valores finales**

Criterio de Corrección:

El objetivo se considera logrado si el estudiante responde de una

manera equivalente al modelo, mostrando los valores que toman las variables y estructuras de datos del mismo.

MOD. II, UND. 4, OBJ. 4

2.- Solución:

Definición del problema

CRITERIO DE DOMINIO 1/1

Generar

un

listado

con

todos

los

estudiantes

de

la

nación,

clasificado

por

centro

local

y

carrera,

calculando

los

totales

respectivos.

 

Análisis del problema

Datos de entrada: CI, Nombre, Apellido, Estado, Centro Local, Carrera, Semestre

Especialista: Mercedes Picón

Ingeniería de Sistemas

Evaluador: Sandra Sánchez

323 M de R

SEMANA 39

SEGUNDA PARCIAL 3/4

VERSION: 1

LAPSO 2016-1

Datos de Salida: CI, Nombre, Apellido, Estado, Centro Local, Carrera, Semestre, Total estudiantes por carrera, Total estudiantes por centro local, Total estudiantes por nación

Proceso:

Leer un número indefinido de estudiantes registrados y ordenados por centro local y carrera, mediante una estructura de control que utilice ciclos a repetir para cada centro local, y dentro de cada centro local, para cada carrera. Para calcular los totales es necesario hacer un rompimiento de control de ejecución por carrera y por centro local. La lectura de una cédula igual a -1 indica el final del registro de estudiantes a procesar.

Definición de variables:

CI: CI NOM: Nombre APE: Apellido EST: Estado CTOLOC, CTOLOCPREVIO: Centro Local CAR, CARPREVIA: Carrera SEM: Semestre TOTCAR: Total Estudiantes por Carrera TOTCTOLOC: Total Estudiantes por Centro Local TOTNAC: Total Estudiantes de la Nación

Algoritmo INICIO TOTNAC, TOTCAR, TOTCTOLOC=0 **Inicializa totales ** LEER: CI, NOM, APE, EST, CTOLOC, CAR, SEM ESCRIBIR “LISTADO DE ESTUDIANTES”

MIENTRAS CI # -1 HACER CTOLOCPREVIO=CTOLOC **Control de cambio de centro local** MIENTRAS CTOLOC = CTOLOCPREVIO HACER CARPREVIA=CAR **Control de cambio de carrera**

Especialista: Mercedes Picón

Ingeniería de Sistemas

Evaluador: Sandra Sánchez

323 M de R

SEMANA 39

SEGUNDA PARCIAL 4/4

VERSION: 1

LAPSO 2016-1

MIENTRAS CAR = CARPREVIA Y CTOLOC = CTOLOCPREVIO HACER

ESCRIBIR: “CEDULA: ”,CI,“NOMBRE: ”,NOM, “APELLIDO:

”,APE,”ESTADO: ”,EST,”CENTRO LOCAL: ”,CTOLOC, “CARRERA: ”, CAR, “SEMESTRE: ”, SEM

TOTCAR=TOTCAR+1

TOTCTOLOC=TOTCTOLOC+1

TOTNAC=TOTNAC+1 ** se incrementan los 3 totales** LEER: CI, NOM, APE, EST, CTOLOC, CAR, SEM

FIN_MIENTRAS

ESCRIBIR “TOTAL DE LA CARRERA”, TOTCAR

TOTCAR=0

FIN_MIENTRAS

ESCRIBIR “TOTAL DEL CENTRO LOCAL”, TOTCTOLOC

TOTCTOLOC=0

TOTCAR=0

FIN_MIENTRAS **el usuario registró -1 y se imprime total nacional** ESCRIBIR “TOTAL DE LA NACION”, TOTNAC FIN

Criterio de Corrección:

Para lograr el objetivo la respuesta dada por el estudiante debe

ser equivalente al modelo con comentarios que faciliten el mantenimiento del algoritmo, además debe contener todas las secciones que describen la metodología descendente.

FIN DEL MODELO

Especialista: Mercedes Picón

Ingeniería de Sistemas

Evaluador: Sandra Sánchez