Vous êtes sur la page 1sur 30

Rapport de Projet de Fin

de Formation

Au terme de ce travail, nous tenons exprimer notre gratitude et nos


remerciements pour toutes les personnes qui ont contribu sa
ralisation.
Nous tenons tout dabord remercier Monsieur() pour son aide,
ses conseils, son encouragement et sa disponibilit dans ce projet.
Nous prsentons nos sincres remerciements tous nos enseignants
de lISTA.
Nos profonds remerciements pour les membres de jury qui ont
accept dvaluer ce travail.

2013/2014

A
Mes trs chers parents
En tmoignage de ma reconnaissance envers le soutien, les scarifies
et tous les efforts quils ont fait pour mon ducation ainsi que ma
formation
A
Mon frre et mes surs
Pour leur affection, comprhension et patience
Tous ceux qui ont une relation de proche ou de loin
Avec la ralisation du prsent rapport

2013/2014

A mer chers PARENTS pour leurs amours, leurs sacrifices et leurs


affections.

A ma chre SOUEUR pour son encouragement continu


Je ddie ce travail toutes les personnes chres mon cur
Quelles
trouvent ici lexpression de toute ma gratitude et mon amour

2013/2014

TABLE DES MATIERES


I. GNS3 5
Cest Quoi GNS3 ?................................................................................................................ 5

Etape1 : Tlchargement de GNS3.. 6


Etape 2 : Installation de GNS3. 6
Etape 3 : Dfinition des fichiers Cisco IOS.. 11

II. La Topologie.. 13
Cration de la topologie.. 13

Connecter GNS3 avec VMware.. 13


La configuration des quipements du rseau de la topologie. 17

III. Routage. 20
Configuration de routeur 20
La table de routage 20
IV. Serveur FTP. 21
V. Pare-feu ASA. 24
Dfinition de pare-feu ASA. 24
Accs par web linterface de lASA. 24
VI. Conclusion.. 28

2013/2014

Cest Quoi GNS3 ?


GNS3 (Graphical Network Simulator) est un simulateur de rseau graphique qui
permet l'mulation des rseaux complexes. Vous connaissez peut-tre avec
VMware ou Virtual Box qui sont utilises pour muler les diffrents systmes
d'exploitation dans un environnement virtuel. Ces programmes vous
permettent d'excuter plusieurs systmes d'exploitation tels que Windows ou
Linux dans un environnement virtuel. GNS3 permet le mme type d'mulation
l'aide de Cisco Internetwork Operating Systems. Il vous permet dexcuter un
IOS Cisco dans un environnement virtuel sur votre ordinateur. GNS3 est une
interface graphique pour un produit appel Dynagen. Dynamips est le
programme de base qui permet l'mulation d'IOS. Dynagen s'excute audessus de Dynamips pour crer un environnement plus convivial, bas sur le
texte environnement. Un utilisateur peut crer des topologies de rseau de
Windows en utilisant de simples fichiers de type ini.
Les laboratoires rseaux ou les personnes dsireuses de s'entraner avant de
passer les certifications CCNA, CCNP, CCIP ou CCIE. De plus, il est possible de
s'en servir pour tester les fonctionnalits des IOS Cisco ou de tester les
configurations devant tre dployes dans le futur sur des routeurs rels. Ce
projet est videmment Open Source et multi-plates-formes. Il est possible de le
trouver pour Mac OS X, Windows et videmment pour votre distribution Linux.

2013/2014

Installation et configuration de GNS3


Cette section vous guidera travers des tapes pour commencer avec GNS3
dans un environnement Windows. Toutes les critiques et les choses les plus
importantes savoir seront couvertes.
A. Etape1 : Tlchargement de GNS3
Utilis le lien http://www.gns3.net/download/ Pour accder au page de
tlchargement et cliquer sur GNS3 v0.8.6 all-in-one sous Windows.

B. Etape 2 : Installation de GNS3

Autoris GNS3 pour crer un


dossier Menu Dmarrer avec le
nom par dfaut GNS3 en cliquant
sur le bouton Suivant.

2013/2014

GNS3 dpend de plusieurs


autres programmes pour
fonctionner. Ceux
Dpendances comprennent
WinPCAP, Wireshark,
Dynamips, Qemu, Pemu,
SuperPutty . Ces Composants
ainsi que GNS3 sont tous
choisis par dfaut pour les
Linstallation, si juste cliquez
sur le bouton Suivant pour
continuer.

Un emplacement par dfaut


est choisi pour GNS3. Cliquez
sur le bouton Installer pour
accepter l'emplacement par
dfaut et pour commencer
l'installation proprement dite
des fichiers.

2013/2014

La premire dpendance
pour GNS3 est WinPcap.
Cliquez sur le bouton
Suivant pour lancer
l'assistant d'installation
WinPcap.

Cliquez sur J'accepte pour


accepter l'accord de licence
pour WinPcap.
L'installation de WinPcap va
commencer. Toutefois, si
vous avez un version
prcdente de WinPcap sur
votre ordinateur, l'assistant
vous demandera pour
supprimer l'ancienne
version et ensuite installer
la nouvelle version.

2013/2014

La deuxime dpendance pour GNS3 est Wireshark. Cliquez sur le bouton Next pour lancer
l'assistant d'installation Wireshark.

Cliquez sur I Agree pour


accepter l'accord de licence
pour Wireshark.
L'installation de Wireshark
va commencer. Toutefois, si
vous avez une version
prcdente de Wireshark
sur votre ordinateur,
l'assistant vous demandera
pour supprimer l'ancienne
version et ensuite installer la
nouvelle version.

2013/2014

Aprs WinPcap est install,


l'Assistant de configuration
GNS3 revient installer
GNS3.

Lorsque l'Assistant a
termin, vous pouvez
dcocher Afficher Lisez moi,
puis cliquer sur le bouton
Finish .

2013/2014

10

Vous avez maintenant termin l'installation de GNS3. Cliquez sur le bouton Dmarrer, Tous
les programmes, GNS3, puis choisissez GNS3 sur la liste des applications installes.
Vous verrez la fentre principale de GNS3.

C. Etape 3 : dfinition des fichiers Cisco IOS.


Comme mentionn prcdemment, vous devez fournir votre propre Cisco IOS
utiliser avec GNS3 en raison de problmes de licences. GNS3 est destin tre
utilis dans un environnement de laboratoire pour tester et apprendre. Une
fois que vous avez obtenu votre propre copie d'un logiciel IOS de Cisco pour
l'un des les plates- formes supportes, vous tes prt continuer. Platesformes actuelles pris en charge incluent:

2013/2014

11

Dans le menu Edition,


choisissez se IOS
images and hypervisors.

Sous l'onglet IOS


Images,
cliquez sur
puis
trouver votre logiciel
IOS de Cisco
dposer et cliquez sur
Ouvrir. Le
fichier apparat sous la
forme de votre fichier
image.

2013/2014

12

Cration de la topologie
A. Connecter GNS3 avec VMware
Configurer la
liaison entre
VMware et
GNS3 on
utilisant une
carte rseau
virtuel (NIC)

2013/2014

13

Configurer les
options TCP/IP de la
carte rseau virtuel
dans le mme
segment

2013/2014

14

Utiliser loption Virtual Network Editor pour ajouter une carte rseau virtuel (par exemple :
Vmnet 3)

On peut ajouter 9 cartes rseaux virtuels pour la VMware on utilisant la case Add Network.

2013/2014

15

Ajouter une carte


rseau loopack pour
connecter GNS3
internet on excutant
la commande hdwwiz
sous la console CMD.

2013/2014

16

B- La configuration des quipements du rseau de la topologie


ASA-CONFIG
: Saved
: Written by cisco at 00:06:59.198 UTC Tue Nov 30 1999
!
ASA Version 8.0(2)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Ethernet0/0
nameif management
security-level 0
ip address 192.168.20.1 255.255.255.0
!
interface Ethernet0/1
nameif EXTERNE
security-level 0
ip address 192.168.40.1 255.255.255.0
!
interface Ethernet0/2

2013/2014

17

nameif LAN
security-level 0
ip address 192.168.30.1 255.255.255.0
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/4
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/5
shutdown
no nameif
no security-level
no ip address
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot config disk0:/.private/startup-config
ftp mode passive
access-list LAN_access_in remark Autoriser l'acces par http seulement
et refuser tout autre trafic
access-list LAN_access_in extended permit tcp 192.168.30.0
255.255.255.0 any eq www
pager lines 24
logging enable
logging asdm informational
no logging message 402128
mtu management 1500
mtu EXTERNE 1500
mtu LAN 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-647.bin
no asdm history enable
arp timeout 14400
access-group LAN_access_in in interface LAN
!
router ospf 1
log-adj-changes
!
router eigrp 1
network 192.168.20.0 255.255.255.0
network 192.168.30.0 255.255.255.0
network 192.168.40.0 255.255.255.0
!
route EXTERNE 0.0.0.0 0.0.0.0 192.168.0.10 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat
0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect
0:02:00

2013/2014

18

timeout uauth 0:05:00 absolute


dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.20.10 255.255.255.255 management
http 192.168.20.1 255.255.255.255 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
!
service-policy global_policy global
username cisco password 3USUcOPFUiMCO4Jk encrypted privilege 15
prompt hostname context
Cryptochecksum:2b5cef16c5fcc25b2aeb280fa2746705
: end

2013/2014

19

Configuration de routeur

Table de routage de routeur R2

2013/2014

20

Linstallation du package ftp avec la commande rpm ivh

Ldition du fichier de configuration vsftpd.conf sous etc

Dans le fichier de la configuration

2013/2014

21

2013/2014

22

Lajout dun utilisateur

Dmarrage le service vsftpd avec la commande service vsftpd restart

2013/2014

23

Dfinition de pare-feu ASA


LASA relve ces dfis en faisant voluer la technologie pare-feu prouve du PIX, tout en
intgrant des fonctions de pare-feu inspection applicative avance (plus de 30 protocoles
supports), ainsi que des fonctions de scurisation des communications unifies uniques.
Flexibilit de dploiement, haute disponibilit, haute performance, support de la qualit de
service font galement partie des caractristiques communes la gamme ASA.
Exploitation et maintenance des ASA La protection des accs, les niveaux de privilge
Recouvrement de mot de passe Mise niveau de l'IOS Gestion des licences Atelier :
Sauvegarde de la configuration, mise niveau de l'IOS, mot de passe perdu

Accs par web linterface de lASA

Activation de
JAVA.

2013/2014

24

Lacceptation
des termes et
conditions
pour
lactivation de
JAVA.

LAuthentification avec un nom dutilisateur et mot de passe pour accder en mode


graphique a linterface du pare-feu ASA.
Username = cisco
Password = cisco

2013/2014

25

Le chargement de lauthentification et vrification des informations de lASA.

Linterface
graphique
finale du parefeu ASA.

2013/2014

26

La rgle daccs
qui permet
dautoriser le
protocole http
et de refuser
tout autre trafic.

2013/2014

27

En clturant ce prsent rapport on veut noter que la ralisation de


cette plate-forme droul dans de trs bonnes conditions en nous
permettant dacqurir de nouvelles connaissances et de goter
lesprit dquipe.
Ainsi que damliorer nos comptences et capacits dadaptations.

2013/2014

28