Vous êtes sur la page 1sur 6

INSTITUT PREPARATOIRE

AUX ETUDES DINGENIEUR Anne universitaire 2013/2014


DE MONASTIR
Devoir surveill N I
Matire
Nombre de pages Dure
Classes
Informatique
6
1 heures AP2 : MP, PC, Tech

Exercice 1 (6 points)
Donner les commandes MAPLE permettant de raliser les oprations suivantes :
(a) Initialiser la session de travail.

1 point

Solution:
> restart;
(b) Dfinir dans la variable P, lexpression suivante :

 
xy
exp
2z

2z
1/
2

point

1/
2

point

1/
2

point

1/
2

point

Solution:
> P := exp(-((x-y)/(sqrt(2)*z))^2)/sqrt(2*Pi*z);
(c) Calculer dans le Laplacien de P dfinit par :
=

2P
2P
2P
+
+
x2
y 2
z 2

Solution:
> Delta := diff(P,x$2) + diff(P,y$2) + diff(P,z$2);
(d) Dans la variable Q calculer la valeur de pour z = 1.
Solution:
> Q := eval(Delta,z=1);
(e) Donner lexpression de Q en coordonnes polaires et stocker le rsultat dans
la variable pol. Pour crire une expression en coordonnes cartsiennes dans le
systme de coordonnes polaires il faut effectuer les substitutions suivantes :

x = cos
et

y = sin

page 1 sur 6

Solution:
> pol := eval(Q,{x = rho *cos(theta) , y = rho * sin(theta)});
(f) valuer lexpression obtenue pour =
R.

et stocker le rsultat dans la variable


1/
2

point

1/
2

point

1/
2

point

Solution:
> R := eval(pol,theta = Pi/2);
(g) Transformer R en une fonction f .
Solution:
> f := unapply(R,rho);
(h) Rsoudre lquation suivante :
(E) f 0 (x) + x f 00 (x) = 0

Solution:
> solve(D(f)(x) +x * (D@@2)(f)(x) = 0,x);
(i) Donner une approximation numrique des racines avec une prcision de 30
1/ point
chiffres.
2
Solution:
> evalf(%,30);
(j) Trouver les points dintersection entre f et laxe des abscisses.

1/
2

point

Solution:
> solve(f(x)=0,x);
R
(k) Reprsenter sur le mme repre les courbes reprsentatives de f (x), f (x)dx et f 0 (x)
pour x [5, 5] en restreignant laxe des ordonnes sur lintervalle [2, 2]. 1/2 point
Solution:
> plot([int(f(x),x), f(x),D(f)(x)],x=-5..5,-2..2);
Exercice 2 (3 points)
On se propose dtudier sur R la loi de composition interne L dfinie par lexpression
suivante :
L : R R R
(x, y) 7 x + y + 3 x y
Donner les commandes MAPLE permettant de raliser les tches suivantes :
(a) Dfinir une fonction l qui associe tout (x, y) lexpression de L.

page 2 sur 6

1/
2

point

Solution:
>l := (x,y)-> x + y + 3 * x * y;
(b) Montrer que L est commutative cest dire :
(x, y) R2 :

l(x, y) = l(y, x)
1/
2

point

1/
2

point

1/
2

point

1/
2

point

1/
2

point

Solution:
>is(l(x,y) = l(y,x));
ou bien
> evalb(l(x,y) = l(y,x));
(c) Montrer que L est associative cest dire :
(x, y, z) R3 :

l(l(x, y), z) = l(x, l(y, z))

Solution:
>is(l(l(x,y),z) = l(x, l(y,z)));
ou bien
> evalb(simplify(l(l(x,y),z)) = simplify(l(x, l(y,z))));
(d) Trouver e llment neutre de L vrifiant la relation suivante :
xR :

l(x, e) = x

Solution:
> e := solve(l(x,e) = x,e);
(e) Trouver lexpression de y linverse de x par L. Si y est linverse de x alors il
vrifie la relation suivante :
l(x, y) = e

Solution:
> y := solve(l(x,y)=e,y);
(f) Tracer la courbe reprsentative de L pour (x, y) [3, 3] [2, 2].
Solution:
> plot3d(l(x,y),x=-3..3,y=-2..2);

page 3 sur 6

Exercice 3 (11 points)


Le systme de numration octal est le systme de numration base 8, et utilise les
chiffres {0 . . . 7}. Un nombre N scrit dans la base octale comme tant une succession
de chiffres N8 = an an1 . . . a1 a0 tels que ai {0 . . . 7} i. Lquivalent dcimal de N
est obtenu en appliquant la formule suivante :
N10 =

n
X

ai 8i

i=0

Exemple : Si N8 = 17543 alors N10 = 3 80 + 4 81 + 5 82 + 7 83 + 1 84 = 8035.


(a) crire une fonction boolenne Verif_octal qui permet de vrifier si un nombre
2 points
entier est exprime dans la base octale ou bien non.
Solution:
fonction Verif_octal(x : entier) : boolen
var n, u : entier
Dbut
nx
tantque n 6= 0 faire
u n mod 10
n n div 10
si u 8 alors
retourner faux
fin si
fin tantque
retourner vrai
Fin Verif_octal
(b) crire une fonction Saisie_octal qui permet de faire la saisie dun nombre
octal.
1 point
Solution:
fonction Saisie_octal() : entier
var n : entier
Dbut
rpter
crire("donner un nombre entier dans la base octale")
Lire(n)
jusqu Verif_octal(n)
retourner n
Fin Saisie_octal
(c) crire une fonction Convertir qui permet de convertir un nombre octal en un
nombre dcimal.
2 points
Solution:

page 4 sur 6

fonction Convertir(x : entier) : entier


var n, r, p : entier
Dbut
nx
r0
p1
tantque n 6= 0 faire
r r + (n mod 10) p
n n div 10
pp8
fin tantque
retourner r
Fin Convertir
(d) Une mthode pour vrifier un nombre dcimal est divisible par 11 consiste
faire le travail suivant :
soustraire de N amput de son chiffre des units le chiffre des units supprim
et recommencer ventuellement avec le nombre ainsi obtenu jusquau moment
o lon peut conclure la divisibilit.
Exemple :
N
1234567 4
123456 3
12345 3
1234 2
123 2
12 1
11

= 12345674
= 1234563
=
123453
=
12342
N est divisible par 11
=
1232
=
121
=
11
=
0

crire une fonction Diviseur qui permet de vrifier si un entier naturel N est
3 points
divisible par 11 en utilisant la mthode dcrite ci-dessus.
Solution:
fonction Verif_div11(x : entier) : entier
var n : entier
Dbut
nx
tantque n > 0 faire
n n div 10 n mod 10
fin tantque
retourner n = 0
Fin Verif_div11
(e) crire un algorithme qui permet de faire la saisie dun nombre octal, de lafficher
en dcimal puis de le vrifier si il est divisible par 11 en utilisant les fonctions
dcrites dans les questions prcdentes.
3 points

page 5 sur 6

Solution:
Algorithme Principal
var n8, n10 : entier
. ici on liste les dclarations des fonctions dfinies dans les questions
prcdentes
Dbut
n8 Saisie_octal()
n10 Convertir(n8)
crire(n8,"(octal) = ",n10,"(dcimal)")
si Verif_div11(n10) alors
crire(n10," divisible par 11")
sinon
crire(n10," non divisible par 11")
fin si
Fin Principal

page 6 sur 6

Bonne chance