Vous êtes sur la page 1sur 6

Comandos do Switch

Descrio
Ativar modo privilegiado
Acesso ao modo global de configurao
Nomear o Switch
Definir a senha do modo privilegiado sem criptografia
Definir a senha do modo privilegiado com criptografia
Criptografar as senhas que no so criptografadas por padro
Desativar a pesquisa do DNS
Selecionar a interface fastehernet 0/0
Selecionar um grupo de interfaces
Definir a porta como 100Mbps
Definir a porta como full-duplex
Criar um Banner
Criar uma descrio para interface fastehernet 0/0
Definir um endereo IP na interface fsica (Para Switches L3)
Definir um endereo IP na interface VLAN
Ativar uma interface para uso
Retornar ao modo de configurao anterior
Voltar ao modo privilegiado
Definir senha de console

Definir senha de telnet


Inserir rota esttica
Criar VLAN
Nomear a VLAN
Associar uma porta a uma VLAN
Configurar uma porta como Trunk
Permitir que apenas algumas VLAN sejam encaminhadas pelo Trunk
Alterar a VLAN nativa
Desativar o DTP
Visualizar as VLAN criadas e portas associadas
Visualizar as portas Trunk

Configurar acesso SSH

Prompt do Roteador
Switch>
Switch#
Switch(config)#
Switch(config)#
Switch(config)#
Switch(config)#
Switch(config)#
Switch(config)#
Switch(config)#
Switch(config-if)#
Switch(config-if)#
Switch(config)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch(config)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch(config)#
Switch(config-line)#
Switch(config-line)#
Switch(config)#
Switch(config-line)#
Switch(config-line)#
Switch(config)#
Switch(config)#
Switch(config-vlan)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch#
Switch#
Switch(config)#
Switch(config)#

Comando IOS
enable
configure terminal
hostname SW_A
enable password cisco
enable secret cisco
service password-encryption
no ip domain-lookup
interface fastethernet 0/0

Banner motd # mensagem #


description connected to Server DHCP
no switchport
ip address 192.168.5.1 255.255.255.0

no shutdown
exit
CTRL + Z
line console 0
password cisco
login
line vty 0 15
password cisco
login
ip route 192.168.5.0 255.255.255.0 10.10.10.1

Configurar acesso SSH

Visualizar tabela CAM do Switch


Ativar a Segurana em Porta
Definir o nmero mximo de MACs que podem ser associados a uma porta
Especificar qual endereo MAC ser permitido em uma porta
Associar o primeiro MAC recebido pela porta
Determinar o mtodo de violao de porta
Determine o tempo em que a porta ficar desativada, em caso de violao
Visualizar a segurana em porta
Configurar DHCP Snooping
Configurar porta como Trusted
Configurar o nmero de pacotes DHCP por segundo aceitveis na porta
Configurar DHCP Snooping para uma VLAN especfica
Para visualizar as configurao do DHCP Snooping
Determinar o Switch Raiz Primrio
Determinar o Switch Raiz Secundrio
Visualizar informaes do STP
Configurando o PortFast
Configurando o BPDU Guard
Configurando o Root Guard
Desativar o CDP no Switch
Desativar o CDP em uma porta
Visualizar o CDP
Configurar SPAN
Configurar Storm - Control
Salvar a configurao atual
Apagar o arquivo de configurao de backup
Apagar a base de dados de VLAN
Reinicializa o switch
Acessa o modo setup
Testar conectividade
Descobrir para onde os dados esto sendo enviados
Permite fazer conexo com um host
Comandos de encerramento de sistema e servios
Verifica o arquivo de conf. da RAM
Verifica o arquivo de conf. da NVRAM
Exibe a tabela de roteamento
Verificar o histrico dos ltimos comandos

Switch(config)#
Switch(config)#
Switch(config)#
Switch(config-line)#
Switch(config-line)#
Switch(config)#
Switch(config)#
Switch(config)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch#
Switch(config)#
Switch(config-if)#
Switch(config-if)#
Switch(config)#
Switch#
Switch(config)#
Switch(config)#
Switch#
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#
Switch(config)#
Switch(config-if)#
Switch#
Switch(config)#
Switch(config)#
Switch(config-if)#
Switch#
Switch#
Switch#
Switch#
Switch#
Switch# ou Switch>
Switch# ou Switch>
Switch# ou Switch>
Switch# ou Switch>
Switch#
Switch# ou Switch>
Switch# ou Switch>
Switch# ou Switch>

S
w
i
t
c
h
#

copy running-config startup-config


erase startup-config
reload
setup
ping
traceroute

show running-config
show startup-config
show ip route
show history

Exibe a configurao hardware do sistema e a verso de software


Exibe informaes sobre os processos ativos
Monitora as sesses abertas via telnet
Exibe a tabela DNS
Mostra informaes da Flash
Exibe as estatsticas das interfaces do switch

Switch# ou Switch>
Switch# ou Switch>
Switch# ou Switch>
Switch# ou Switch>
Switch# ou Switch>
Switch# ou Switch>

show version
show processes
show session
show hosts
show flash
show interfaces fast0/8

Comando IOS
enable
configure terminal
hostname SW_A
enable password cisco
enable secret cisco
service password-encryption
no ip domain-lookup
interface fastethernet 0/0
interface range fast0/1 - 10
speed 100
duplex full
Banner motd # mensagem #
description connected to Server DHCP
no switchport
ip address 192.168.5.1 255.255.255.0
interface vlan 1
ip address 160.20.55.98 255.255.255.0
no shutdown
exit
CTRL + Z
line console 0
password cisco
login
line vty 0 15
password cisco
login
ip route 192.168.5.0 255.255.255.0 10.10.10.1
vlan 5
name Suporte
switchport mode access
switchport access vlan 5
switchport mode trunk
switchport trunk allowed vlan 5, 6,8
switchport trunk native vlan 10
switchport nonegotiate
show vlan
show interfaces trunk
hostname SW_A
username bob password 123

ip domain-name example.com
crypto key generate rsa
line vty 0 15
login local
transport input ssh
show mac-address-table
switchport mode access
switchport port-security
switchport port-security maximum 2
switchport port-security mac-address 0A0B.1234.5678
switchport port-security mac-address sticky
switchport port-security violation {shutdown/restrict/protect]
switchport port-security aging time 200
show port-security ou show port-security inteface fast0/10
ip dhcp snooping
ip dhcp snooping trust
ip dhcp snooping limit rate 3
ip dhcp snooping vlan 5
show ip dhcp snooping
spanning-tree vlan 3,4 root primary
spanning-tree vlan 3,4 root secondary
show spanning-tree
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree guard root
no cdp run
no cdp enable
show cdp neighbors
monitor session 1 source interface fast0/1
monitor session 1 destination interface fast0/20
storm-control broadcast level 70
copy running-config startup-config
erase startup-config
delete flash:vlan.dat
reload
setup
ping
traceroute
telnet
exit; logout; disconnect
show running-config
show startup-config
show ip route
show history

show version
show processes
show session
show hosts
show flash
show interfaces fast0/8