Vous êtes sur la page 1sur 22

UNIVERSIDAD NACIONAL DE

HUANCAVELICA
FACULTAD DE INGENIERA ELECTRNICA
- SISTEMAS

IMPLEMENTACIN DE UN SISTEMA DE
COMUNICACIONES INTEGRADOS

ASIGNATURA Taller de Sistemas Distribuidos

DOCENTE Ing. Lus E. Pacheco Moscoso

ALUMNOS

1
PAMPAS TAYACAJA - 2014
A Dios por sus grandes bendiciones padres
por su apoyo Incondicional a nuestro
incondicional y a nuestro docente por
ensearnos con esmero

2
INDICE
INTRODUCCION............................................................................................... 4
IMPLEMENTACIN DE UN SISTEMA DE COMUNICACIONES INTEGRADOS...........5
PASOS PARA LA IMPLEMENTACIN DEL SISTEMA DE COMUNICACIONES
INTEGRADOS................................................................................................... 7
CREACIN DE VLANS....................................................................................... 7
CONFIGURACIN DE ENLACES TRONCALES....................................................12
CONFIGURACION DE TELFONOS IPS:.............................................................17
ASIGNACIN DE NMEROS TELEFNICOS:.....................................................20
REALIZACIN DE LLAMADAS TELEFONICAS:..................................................21
CONCLUSIONES............................................................................................. 22

3
INTRODUCCION

Este trabajo describe la forma que se dio solucin a un sistema de comunicaciones


integradas lo cual permita seguridad, escalabilidad, calidad de servicio y restriccin a ciertos
servicios mediante el programa Packet Tracer.

4
IMPLEMENTACIN DE UN SISTEMA DE COMUNICACIONES
INTEGRADOS
ENUNCIADO:

Como implementaramos el sistema de comunicaciones integradas que me permita seguridad,


escalabilidad calidad de servicio y restriccin a ciertos servicios, adems el sistema muestra que
cada rea cuenta con el servicio de telefona. Se le deja a criterio del estudiante la eleccin de la
direccin ip clase b o clase c y el nmero de dispositivos intermediarios o de comunicacin
segn sea el caso.

NOMBRE ASIGNADO TERMINALES


A LA RED POR RED
Default
INFORMATICA 3
DIRECCION 10
ORGA_POYO 12
INFRAESTRUCTURA 5
REG_CIVIL 2
SERV_SOCIALES 4
TELEFONOS 19
VIDEOCONFERENCIA 3
IMPRESION 4
SERVIDORES 3
INALAMBRICO 16
TOTAL DE PUNTOS 81

5
ELECCION DEL SOLUCIONADOR: Se eligi trabajar en el programa cisco packet Tracer
donde mediante el diseo, la codificacin en dicho programa se dar solucin al enunciado.
Antes de ello conceptualizaremos temas muy importantes

VLAN:

Una VLAN (acrnimo de Virtual LAN, red de rea local virtual) es una red de
computadoras lgicamente independiente. Varias VLANs pueden coexistir en un
nico switch fsico.

Una 'VLAN' consiste en una red de computadores que se comportan como si


estuviesen conectados al mismo cable, aunque pueden estar en realidad
conectados fsicamente a diferentes segmentos de una red de rea local. Los
administradores de red configuran las VLANs mediante software en lugar de
hardware, lo que las hace extremadamente flexibles. Una de las mayores
ventajas de las VLANs surge cuando se traslada fsicamente una computadora a
otra ubicacin: puede permanecer en la misma VLAN sin necesidad de ninguna
reconfiguracin hardware.

TIPOS DE VLAN:

VLAN de datos: Est configurada solo para enviar trfico de datos


generado por el usuario.
VLAN de predeterminada: VLAN a la cual se asignan todos los puertos
del switch al iniciarlo.
VLAN nativa: Esta asignada a un puerto troncal 802.1Q, que admite el
trfico que va desde y hacia una VLAN. Sirve como un identificador
comn en extremos opuestos de un enlace troncal.
VLAN de administracin: Es cualquier VLAN que el administrador
configura para acceder a la administracin de un switch.

CISCO PACKET TRACER: Es un programa simulador de redes de


computadoras y sistemas distribuidas.

6
PASOS PARA LA IMPLEMENTACIN DEL SISTEMA DE
COMUNICACIONES INTEGRADOS

Primer paso: Revisar el estado actual de las redes virtuales, usar el siguiente comando
en cada switch:

Switch#show vlan

Note que inicialmente ya hay creadas varias vlan. Pero todos los puertos del switch
estn asociados a la vlan default.

Segundo paso: Realice pruebas de conectividad entre PCs.

CREACIN DE VLANS

Tercer paso: Ahora proceda a configurar en cada Switch las VLANs: INFORMATICA,
DIRECCION, ORGA_POYO, INFRAESTRUCTURA, REG_CIVIL,
SERV_SOCIALES, TELEFONOS, VIDEOCONFERENCIA, IMPRESIN,
SERVIDORES, INALAMBRICO.

Switch>enable
Switch#configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#name INFORMATICA
Switch(config-vlan)#exit

Switch(config)#vlan 20
Switch(config-vlan)#name DIRECCION
Switch(config-vlan)#exit

Switch(config)#vlan 30
Switch(config-vlan)#name ORGA_POYO
Switch(config-vlan)#exit

Switch(config)#vlan 40
Switch(config-vlan)#name INFRAESTRUCTURA

7
Switch(config-vlan)#exit

Switch(config)#vlan 50
Switch(config-vlan)#name REG_CIVIL
Switch(config-vlan)#exit

Switch(config)#vlan 60
Switch(config-vlan)#name SERV_SOCIALES
Switch(config-vlan)#exit

Switch(config)#vlan 70
Switch(config-vlan)#name TELEFONOS
Switch(config-vlan)#exit

Switch(config)#vlan 80
Switch(config-vlan)#name VIDEOCONFERENCIA
Switch(config-vlan)#exit

Switch(config)#vlan 90
Switch(config-vlan)#name IMPRESIN
Switch(config-vlan)#exit

Switch(config)#vlan 100
Switch(config-vlan)#name SERVIDORES
Switch(config-vlan)#exit

Switch(config)#vlan 110
Switch(config-vlan)#name INALAMBRICO
Switch(config-vlan)#exit

8
Cuarto paso: Revisar nuevamente el estado de las redes virtuales y luego copy run
start para guardar.

Switch#show vlan

Quinto paso: Asignacin de puertos a las vlan creadas en el paso anterior. Las
asignaciones se realizarn segn indica la siguiente tabla.

Switch Puerto Nueva VLAN


Switch2 Fa 0/9 10
Switch2 Fa 0/10 10
Switch2 Fa 0/1 20
Switch2 Fa 0/2 20
Switch2 Fa 0/3 30
Switch2 Fa 0/4 30
Switch2 Fa 0/5 40
Switch2 Fa 0/6 40
Switch2 Fa 0/7 50
Switch2 Fa 0/8 50
Switch3 Fa 0/1 60
Switch3 Fa 0/2 60
Switch3 Fa 0/9 70
Switch3 Fa 0/3 70
Switch3 Fa 0/5 80
Switch3 Fa 0/6 80

Sexto paso: Asignacin de puertos a las VLANs (Asignacin de puertos para


el Switch2)
Switch2#configure terminal
Switch2(config)#interface FastEthernet 0/9
Switch2(config-if)#switchport access vlan 10
Switch2(config-if)#exit

Switch2#configure terminal

9
Switch2(config)#interface FastEthernet 0/10
Switch2(config-if)#switchport access vlan 10
Switch2(config-if)#exit

Switch2#configure terminal
Switch2(config)#interface FastEthernet 0/1
Switch2(config-if)#switchport access vlan 20
Switch2(config-if)#exit

Switch2#configure terminal
Switch2(config)#interface FastEthernet 0/2
Switch2(config-if)#switchport access vlan 20
Switch2(config-if)#exit

Switch2#configure terminal
Switch2(config)#interface FastEthernet 0/3
Switch2(config-if)#switchport access vlan 30
Switch2(config-if)#exit

Switch2#configure terminal
Switch2(config)#interface FastEthernet 0/4
Switch2(config-if)#switchport access vlan 30
Switch2(config-if)#exit

Switch2#configure terminal
Switch2(config)#interface FastEthernet 0/5
Switch2(config-if)#switchport access vlan 40
Switch2(config-if)#exit

Switch2#configure terminal
Switch2(config)#interface FastEthernet 0/6
Switch2(config-if)#switchport access vlan 40
Switch2(config-if)#exit

10
Switch2#configure terminal
Switch2(config)#interface FastEthernet 0/7
Switch2(config-if)#switchport access vlan 50
Switch2(config-if)#exit

Switch2#configure terminal
Switch2(config)#interface FastEthernet 0/8
Switch2(config-if)#switchport access vlan 50
Switch2(config-if)#exit

Switch3#configure terminal
Switch3(config)#interface FastEthernet 0/1
Switch3(config-if)#switchport access vlan 60
Switch3(config-if)#exit

Switch3#configure terminal
Switch3(config)#interface FastEthernet 0/2
Switch3(config-if)#switchport access vlan 60
Switch3(config-if)#exit

Switch3#configure terminal
Switch3(config)#interface FastEthernet 0/9
Switch3(config-if)#switchport access vlan 70
Switch3(config-if)#exit

Switch3#configure terminal
Switch3(config)#interface FastEthernet 0/3
Switch3(config-if)#switchport access vlan 70
Switch3(config-if)#exit

Switch3#configure terminal
Switch3(config)#interface FastEthernet 0/5
Switch3(config-if)#switchport access vlan 80
Switch3(config-if)#exit

11
Switch3#configure terminal
Switch3(config)#interface FastEthernet 0/6
Switch3(config-if)#switchport access vlan 80
Switch3(config-if)#exit

Sptimo paso: Usar nuevamente el comando show vlan.


Octavo paso: Para guardar copy run start.

CONFIGURACIN DE ENLACES TRONCALES.

Lo que obtenemos entonces es que las PCs no estn conectadas puede comprobar
haciendo ping entre ellas debido a que pertenecen a diferentes switches. Por lo
tanto se debe de configura un enlace de troncal entre los switches.
Noveno paso: Configuracin en Switch2:
Switch0#configure terminal
Switch0(config)#interface fastethernet 0/11
Switch0(config-if)#switchport mode trunk
Switch0(config-if)#CTRL+Z
Note que se ha configurado la interface 0/11, ya que esta es la utilizada para la
comunicacin hacia el Switch1

Decimo paso: Configuracin en Switch1:


Switch1#configure terminal
Switch1(config)#interface fastethernet 0/5
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#CTRL+Z

Switch1#configure terminal
Switch1(config)#interface fastethernet 0/4

12
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#CTRL+Z

Para comprobar la comunicacin a travs del enlace troncal, se pueden realizar


ping entre las PCs.
Todas las pruebas deberan ser realizadas con xito, ya que las estaciones de
trabajo pertenecen a la misma vlan y por tanto al mismo dominio de broadcast.
CONFIGURACIN DE ENRUTAMIENTO INTER_VLAN

Aadir un enrutador 2620 al esquema de conexin


11vo paso: En esta parte de la prctica, colocaremos las VLANs creadas en la
parte anterior en diferentes redes, y estas sern intercomunicadas por medio de
enrutador.
Colocar las estaciones de trabajo en redes diferentes:

Laptop1: Direccin IP: 192.168.10.2, Mscara de subred: 255.255.255.0,


Gateway: 192.168.10.1
Laptop0: Direccin IP: 192.168.20.18, Mscara de subred: 255.255.255.0,
Gateway: 192.168.10.1
PC0: Direccin IP: 192.168.30.2, Mscara de subred: 255.255.255.0, Gateway:
192.168.30.1
PC1: Direccin IP: 192.168.30.3, Mscara de subred: 255.255.255.0, Gateway:
192.168.30.1
PC2: Direccin IP: 192.168.40.2, Mscara de subred: 255.255.255.0, Gateway:
192.168.40.1
PC3: Direccin IP: 192.168.40.12, Mscara de subred: 255.255.255.0, Gateway:
192.168.40.1
PC4: Direccin IP: 192.168.50.2, Mscara de subred: 255.255.255.0, Gateway:
192.168.50.1
PC5: Direccin IP: 192.168.50.14, Mscara de subred: 255.255.255.0, Gateway:
192.168.30.1
PC6: Direccin IP: 192.168.60.2, Mscara de subred: 255.255.255.0, Gateway:
192.168.60.1

13
PC7: Direccin IP: 192.168.60.7, Mscara de subred: 255.255.255.0, Gateway:
192.168.60.1
PC8: Direccin IP: 192.168.70.2, Mscara de subred: 255.255.255.0, Gateway:
192.168.70.1
PC9: Direccin IP: 192.168.70.3, Mscara de subred: 255.255.255.0, Gateway:
192.168.70.1
PC11: Direccin IP: 192.168.80.2, Mscara de subred: 255.255.255.0, Gateway:
192.168.80.1
PC10: Direccin IP: 192.168.80.5, Mscara de subred: 255.255.255.0, Gateway:
192.168.80.1
PC12: Direccin IP: 192.168.90.2, Mscara de subred: 255.255.255.0, Gateway:
192.168.20.1
PC13: Direccin IP: 192.168.90.4, Mscara de subred: 255.255.255.0, Gateway:
192.168.90.1

12vo paso: Realice pruebas de conectividad.


Habilitar el enlace troncal en el Switch1 (interface hacia router)

Switch2#configure terminal
Switch2(config)#interface fastethernet 0/5
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#CTRL+Z

Habilitar el enlace troncal en el Switch3 (interface hacia router)

Switch2#configure terminal
Switch2(config)#interface fastethernet 0/8
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#CTRL+Z

13vo paso: Configuracin del router.

router> enable

14
router# configure terminal
router(config)# hostname RouterA
RouterA(config)#
RouterA(config)# enable secret contrasea UNH
RouterA(config)# enable password contrasea sistemas
RouterA(config-line)# exit

CONFIGURAR CONTRASEA DE CONSOLA


RouterA> enable
RouterA# config terminal
RouterA(config)# line con 0
RouterA(config-line)# password contrasea sistemas
RouterA(config-line)# login sistemas
RouterA(config-line)# exit

14avo paso: Configurar el enrutador


Router> enable
Router# configure terminal
Router(config)# interface fa 0/0
Router(config-if)# no shutdown
Router(config-if)# exit

Router(config)# interface fa 0/0.10


Router(config-subif)# encapsulation dot1Q 10
Router(config-subif)# ip address 192.168.10.1 255.255.255.0
Router(config-subif)# exit
Router(config)# interface fa 0/0.20
Router(config-subif)# encapsulation dot1Q 20
Router(config-subif)# ip address 192.168.20.1 255.255.255.0
Router(config-subif)# exit

Router(config)# interface fa 0/0.30


Router(config-subif)# encapsulation dot1Q 30
Router(config-subif)# ip address 192.168.30.1 255.255.255.0

15
Router(config-subif)# exit

Router(config)# interface fa 0/0.40


Router(config-subif)# encapsulation dot1Q 40
Router(config-subif)# ip address 192.168.40.1 255.255.255.0
Router(config-subif)# exit

Router(config)# interface fa 0/0.50


Router(config-subif)# encapsulation dot1Q 50
Router(config-subif)# ip address 192.168.50.1 255.255.255.0
Router(config-subif)# exit

Router(config)# interface fa 0/0.60


Router(config-subif)# encapsulation dot1Q 60
Router(config-subif)# ip address 192.168.60.1 255.255.255.0
Router(config-subif)# exit

Router(config)# interface fa 0/0.70


Router(config-subif)# encapsulation dot1Q 70
Router(config-subif)# ip address 192.168.70.1 255.255.255.0
Router(config-subif)# exit

Router(config)# interface fa 0/0.80


Router(config-subif)# encapsulation dot1Q 80
Router(config-subif)# ip address 192.168.80.1 255.255.255.0
Router(config-subif)# exit

Router(config)# interface fa 0/0.90


Router(config-subif)# encapsulation dot1Q 90
Router(config-subif)# ip address 192.168.90.1 255.255.255.0
Router(config-subif)# exit
Router(config)# interface fa 0/0.100
Router(config-subif)# encapsulation dot1Q 100
Router(config-subif)# ip address 192.168.100.1 255.255.255.0

16
Router(config-subif)# exit
Router(config)# exit

CONFIGURACION DE TELFONOS IPS:

En el modelo presentado se deber de configurar los telfonos ip las cuales estn


distribuidas en las diferentes reas y es necesario la comunicacin entre ellas, para
lo cual se ha realizado las siguientes codificaciones:

ROUTER FA0/0
Paso 1: ingresar al router:

Router>enable #ingresamos al modo de privilegiado


Router#configure terminal # ingresamos al modo de configuracin global
Router(config)#interface fastethernet 0/0 # ingresamos al modo de configuracin
de interfaz
Router(config-if)#ip address 192.168.110.1 255.255.255.0 # Configuramos la
direccin IP de la interfaz
Router(config-if)#no shutdown # habilitamos la interfaz

Paso 2: Habilitaremos el servidor DHCP en el router, para brindarle las


direcciones IP y los parmetros de configuracin TFTP a los telfonos IP, para lo
cual debemos seguir los siguientes pasos:

Router(config)#ip dhcp pool telefonos # en modo de configuracin global,


creamos el pool de direcciones
Router(dhcp-config)#network 192.168.110.0 255.255.255.0 # Indicamos el
segmento de red a emplear
Router(dhcp-config)#default-router 192.168.110.1 # Indicamos quien ser el
default gateway
Router(dhcp-config)#option 150 ip 192.168.110.1 # Indicamos donde estar
ubicado el servidor TFTP

17
Paso 3: Vamos a habilitar el servicio de telefona IP en el router, para lo cual
debemos indicar los siguientes parmetros de configuracin:
Router(dhcp-config)#telephony-service # Habilitar el servicio
Router(config-telephony)#max-dn 4 # Definimos la mxima cantidad de nmeros
en el directorio telefnico
Router(config-telephony)#max-ephone 4 # Definimos la mxima cantidad de
telfonos IP
Router(config-telephony)#ip source-address 192.168.110.1 port 2000 #
Especificamos el servidor VoIP y Puerto donde se registraran los telfonos.
Router(config-telephony)#auto assign 4 to 6 # definimos los rangos para auto
asignar los nmeros de extensiones telefnicas a las teclas de los telfonos.
Router(config-telephony)#auto assign 1 to 5

Paso 4: ingresar al SWITCH 0

Switch>enable # Ingresamos al modo privilegiado

Switch#configure terminal # Ingresamos al modo de configuracin global

Switch(config)#interface range fa0/2-5 # Ingresamos a modo de configuracin de


interfaces, especificando un rango para configurar de una sola vez varias
interfaces con los mismos parmetros.

Switch(config-if-range)#switchport mode access # configuramos los puertos en


modo acceso

Switch(config-if-range)#switchport voice vlan 1 # definimos que utilizaremos la


vlan 1, para el trfico exclusivo de voz

Esperemos unos segundos y comprobemos que los telfonos IP, reciben la


direccin lgica.

18
ROUTER FA1/0
Paso 1: ingresar al router:

Router>enable #ingresamos al modo de privilegiado


Router#configure terminal # ingresamos al modo de configuracin global
Router(config)#interface fastethernet 1/0 # ingresamos al modo de configuracin
de interfaz
Router(config-if)#ip address 192.168.120.1 255.255.255.0 # Configuramos la
direccin IP de la interfaz
Router(config-if)#no shutdown # habilitamos la interfaz

Paso 2: Habilitaremos el servidor DHCP en el router, para brindarle las


direcciones IP y los parmetros de configuracin TFTP a los telfonos IP, para lo
cual debemos seguir los siguientes pasos:

Router(config)#ip dhcp pool telefonos # en modo de configuracin global,


creamos el pool de direcciones
Router(dhcp-config)#network 192.168.120.0 255.255.255.0 # Indicamos el
segmento de red a emplear
Router(dhcp-config)#default-router 192.168.120.1 # Indicamos quien ser el
default gateway
Router(dhcp-config)#option 150 ip 192.168.120.1 # Indicamos donde estar
ubicado el servidor TFTP

Paso 3: Vamos a habilitar el servicio de telefona IP en el router, para lo cual


debemos indicar los siguientes parmetros de configuracin:
Router(dhcp-config)#telephony-service # Habilitar el servicio
Router(config-telephony)#max-dn 9 # Definimos la mxima cantidad de nmeros
en el directorio telefnico
Router(config-telephony)#max-ephone 9 # Definimos la mxima cantidad de
telfonos IP
Router(config-telephony)#ip source-address 192.168.120.1 port 2000 #
Especificamos el servidor VoIP y Puerto donde se registraran los telfonos.

19
Router(config-telephony)#auto assign 4 to 6 # definimos los rangos para auto
asignar los nmeros de extensiones telefnicas a las teclas de los telfonos.
Router(config-telephony)#auto assign 1 to 5

Paso 4: ingresar al SWITCH 1

Switch>enable # Ingresamos al modo privilegiado

Switch#configure terminal # Ingresamos al modo de configuracin global

Switch(config)#interface range fa0/2-6 # Ingresamos a modo de configuracin de


interfaces, especificando un rango para configurar de una sola vez varias
interfaces con los mismos parmetros.

Switch(config-if-range)#switchport mode access # configuramos los puertos en


modo acceso

Switch(config-if-range)#switchport voice vlan 1 # definimos que utilizaremos la


vlan 1, para el trfico exclusivo de voz

Esperemos unos segundos y comprobemos que los telfonos IP, reciben la


direccin lgica.

ASIGNACIN DE NMEROS TELEFNICOS:

Paso 1: ingresar al router


Router(config)#ephone-dn 1 # en modo de configuracin global, definimos la
primera entrada del directorio
Router(config-ephone-dn)#number 501 # Especificamos el nmero de extensin que
se le asignar al telfono
Paso 2: Realizar la asignacin de nmeros a todos los telfonos IPS existentes en la
red.

20
Paso 3: Verificar la asignacin de nmeros:

REALIZACIN DE LLAMADAS TELEFONICAS:

Marcando nmero asignado (503) Recibiendo llamada del 507

21
CONCLUSIONES

Finalmente concluimos con el funcionamiento adecuado de nuestro sistema integrado,


lo cual puede ser aplicado en la vida real para que de esa forma se obtengan beneficios.

22