Vous êtes sur la page 1sur 5

M1 AII

2016/2017
Module Rseau et Protocoles de Communications Industriels

TP N3
Simulation par CISCO PACKET TRACER
Configurations des diffrents quipements rseaux- Insertion
Routeurs-
Routage dynamique

I. Notion de Routage
Les routeurs sont les dispositifs permettant de "choisir" le chemin que les
datagrammes vont emprunter pour arriver destination. Il s'agit de machines ayant
plusieurs cartes rseau dont chacune est relie un rseau diffrent. Ainsi, dans la
configuration la plus simple, le routeur n'a qu' "regarder" sur quel rseau se trouve
un ordinateur pour lui faire parvenir les datagrammes en provenance de l'expditeur.

II. Les deux modes de routages

Il existe deux modes de routages bien distincts lorsque nous souhaitons aborder la
mise en place dun protocole de routage, il sagit du routage statique et du routage
dynamique

II.1 Routage statique

Dans le routage statique, les administrateurs vont configurer les routeurs un


un au sein du rseau afin dy saisir les routes (par lintermdiaire de port de sortie ou
dIP de destination) emprunter pour aller sur tel ou tel rseau. Concrtement, un
routeur sera un pont entre deux rseaux et le routeur daprs sera un autre pont entre
deux autres rseaux :

Le routage statique permet ladministrateur de saisir manuellement les routes


sur les routeurs et ainsi de choisir lui mme le chemin qui lui semble le meilleur pour
aller dun rseau A un rseau B. Si un nouveau rseau vient se crer sur le routeur
1 par exemple, il faudra indiquer au routeur 2 quil faut nouveau passer par le
routeur 1 pour aller sur le rseau D. La configuration de rseaux de taille importante
peut devenir assez longue et complexe, cela peut devenir une source derreur et de
complexit supplmentaire quand la taille du rseau grandit.

II.2 Routage dynamique


1
Le routage dynamique permet quant lui de se mettre jour de faon
automatique. La dfinition dun protocole de routage va permettre au routeur de se
comprendre et dchanger des informations de faon priodique afin que chaque
routeur soit au courant des volutions du rseau sans intervention manuelle de
ladministrateur du rseau.

On voit ici que dans un premier temps, on ajoute le rseau C au routeur 2. Une
annonce va ensuite suivre pour que les autres routeurs sachent que le rseau C est
joignable via le Routeur 2. Par la suite, les routeurs continueront communiquer
priodiquement pour voir si chacun des routeurs est toujours joignable. Si un routeur
vient a tomber et quune autre route existe pour accder un rseau, les tables de
routages des routeurs vont se modifier dynamiquement via des communications faites
entres les routeurs et le calcul de la meilleur route possible emprunter. Cela facilite
la transmission des informations entre les routeurs et la mise jour des topologies
rseaux. Le routage dynamique prsente lavantage de la maintenance rduite par
lautomatisation des changes et des dcisions de routage et sa performance et sa
mise en place ne dpendent pas de la taille du rseau.

III. Simulation par CISCO PACKET TRACER

III.1 Prsentation de la Maquette

La premire tape consiste mettre en place larchitecture rseau ci-dessous. La


maquette se compose de 2 ensembles composs dun Switch et de 2 postes relis par
lintermdiaire de 2 routeurs.

2
III.2 Configuration du protocole RIP

Le protocole de RIP (Routing Information Protocol) est certainement le protocole de


Routage dynamique le plus rpandu de nos jours. La configuration du protocole est
trs facile car il n'y a que deux commandes taper.

Activation du protocole RIP dans le routeur avec la commande suivante en mode


configuration:

(config)#router rip

Dfinition de tous les rseaux directement connects ce Routeur avec la


commande:

(config-router)#network [@rseau]

N'oubliez pas qu'une des principales caractristiques du protocole RIP est qu'il est de
type classfull. Configurons prsent les trois routeurs :

Routeur 1

Routeur1(config)#router rip
Routeur1(config-router)#network 10.0.0.0
Routeur1(config-router)#network 11.0.0.0
Routeur1(config-router)#CTRL z
Routeur1(config-router)#exit

Routeur 2
Routeur2(config)#router rip
Routeur2(config-router)#network 11.0.0.0
Routeur2(config-router)#network 12.0.0.0
Routeur2(config-router)#CTRL z
Routeur2(config-router)#exit

Routeur 3

Routeur3(config)#router rip
Routeur3(config-router)#network 12.0.0.0

3
Routeur3(config-router)#network 13.0.0.0
Routeur3(config-router)#CTRL z
Routeur3(config-router)#exit

IV. Travail demand:

a. Mettre en place cette topologie, en respectant le plan dadressage mentionn


au niveau de la figure et les types de liens mentionns.
b. Ajouter les entrs de routage au niveau des trois routeurs afin de permettre
de connecter tous les postes possibles.
c. Afficher les routes configures au niveau de chaque routeur en utilisant la
commande show ip route.

d. Faire des pings partir du poste PC1 vers les postes PC2, PC3 ou PC2 vers
les deux autres ?

e. Donner lavantage du routage dynamique par rapport au routage statique ?

Rsum des commandes Cisco les plus importantes.

Passer en mode privilgi

Router>enable
Router#

Visualiser la configuration courante

Router#show running-config

Entrer dans le mode de configuration d'une interface

Router(config)#interface FastEthernet 0/0


Router(config-if)#

Dfinir l'adresse IP

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Activer l'interface

Router(config-if)#no shutdown

Ajouter une route statique

4
Router(config)#ip route 10.10.0.0 255.255.0.0 192.168.2.1
ou
Router(config)#ip route 192.168.1.0 255.255.255.0 FastEthernet 0/0

Visualiser les interfaces

Router#show ip interface brief (toutes les interfaces, rsum)


Router#show interfaces (toutes les interfaces, dtaill)
Router#show interfaces ethernet 0 (une interface particulire)

Visualiser les routes

Router>show ip route