Vous êtes sur la page 1sur 8

CCNA Discovery

Travailler dans une PME ou chez un fournisseur de services Internet

Travaux pratiques 5.3.8 Configuration des fonctions NAT et du


protocole DHCP avec linterface de ligne de commande IOS

Adresse Fast Ethernet 0 Adresse Serial 0


Dsignation Nom du et masque de sous et masque de Type Adresse de
du routeur routeur rseau sous-rseau dinterface bouclage
192.168.1.1 209.165.200.225
Routeur 1 Client 255.255.255.0 255.255.255.224 ETCD S/O
209.165.200.226 209.165.200.1
Routeur 2 FAI S/O 255.255.255.224 LETTD 255.255.255.224

Objectifs
Configurer un routeur Client et un hte pour le protocole DHCP
Configurer un routeur dabonn pour une NAT surcharge ou Traduction dadresses de port (PAT)
Vrifier le protocole DHCP et les traductions dadresses de rseau au sein du rseau du client au FAI

Contexte / Prparation
Installez un rseau similaire celui reprsent dans le schma de topologie. Tout routeur rpondant aux
exigences indiques dans ce schma en matire dinterface peut tre utilis, par exemple les routeurs 800,
1600, 1700, 1800, 2500, 2600 ou une combinaison de ces routeurs. Reportez-vous au tableau Relev
des interfaces de routeur qui se trouve la fin de ce document pour dterminer les identifiants dinterface
utiliser en fonction de lquipement disponible. Selon le modle de routeur, le rsultat peut diffrer quelque
peu de ce qui est montr dans ces travaux pratiques. Leurs tapes doivent tre excutes sur chaque
routeur, sauf indication contraire.

Copyright sur lintgralit du contenu 19922007 Cisco Systems, Inc. Tous droits rservs.
Ce document contient des informations publiques Cisco. Page 1 sur 8
CCNA Discovery
Travailler dans une PME ou chez un fournisseur de services Internet

Ressources requises :
Deux routeurs, un avec des interfaces Ethernet et srie, et lautre avec une interface srie
Un ordinateur Windows XP
Cble droit Ethernet de catgorie 5 (PC1 commutateur)
Cble srie Null
Cbles console (de PC 1 aux routeurs R1 et R2)
Accs l'invite de commandes PC
Accs la configuration rseau TCP/IP du PC

partir du PC, dmarrez une session HyperTerminal au routeur.


REMARQUE : Suivez les instructions de la section Effacement et rechargement du routeur qui se
trouvent la fin de ce document. Excutez ces tapes sur tous les routeurs utiliss dans ces travaux
pratiques avant de continuer.
REMARQUE : Routeurs SDM : Si la configuration initiale a t supprime dun routeur SDM, SDM ne
saffiche plus par dfaut lors du redmarrage du routeur. Il est alors ncessaire de crer une configuration
de routeur de base laide des commandes IOS. Reportez-vous la procdure dcrite la fin de ces travaux
pratiques ou contactez votre formateur.

tape 1 : Cblage et configuration des routeurs


a. En fonction du schma de topologie, connectez le PC, le commutateur et les routeurs laide du
cblage appropri.
b. Configurez chaque routeur avec les paramtres suivants : nom dhte, accs et mot de passe de
console, accs et mot de passe vty et mot de passe secret actif. Si ncessaire, reportez-vous aux
Travaux pratiques 5.3.5, Configuration des paramtres de base de routeur avec lILC IOS pour
obtenir des instructions sur le paramtrage des noms dhte, mots de passe et adresses dinterface.
c. Configurez les interfaces de routeur avec ladresse IP et le masque appropris. Vrifiez que les
interfaces sont utilisables et peuvent envoyer une requte ping une interface ou un hte
directement connect.
d. Configurez le routeur FAI avec une adresse de bouclage servant tester le routeur du client.
Ladresse de bouclage reprsente un rseau distant.
ISP(config)#interface loopback 0
ISP(config-if)#ip address 209.165.200.1 255.255.255.224

tape 2 : Configuration dune route par dfaut sur le routeur du client


a. Sur le routeur du client, configurez une route par dfaut qui pointe vers le FAI. Tous les paquets
destins aux rseaux qui ne se trouvent pas dans la table de routage du client sont transmis au
routeur du FAI, qui comporte une table de routage bien plus grande et des connexions vers dautres
fournisseurs Internet. Notez comment cette route par dfaut utilise ladresse IP du routeur voisin
comme dernier numro.
Customer(config)#ip route 0.0.0.0 0.0.0.0 209.165.200.226
b. Pourquoi une route par dfaut nest-elle pas utilise sur le FAI ? Une route par dfaut sur le routeur
FAI serait une mauvaise configuration si elle pointait vers un site de client. Toute route ne figurant pas
dans la table de routage du FAI serait envoye automatiquement au routeur du client. Bien entendu,
ce dernier ne saurait pas quoi faire du paquet et lenverrait sur la route par dfaut du routeur du client,
qui est le FAI. Il se produirait alors une boucle de routage.

Copyright sur lintgralit du contenu 19922007 Cisco Systems, Inc. Tous droits rservs.
Ce document contient des informations publiques Cisco. Page 2 sur 8
CCNA Discovery
Travailler dans une PME ou chez un fournisseur de services Internet

tape 3 : Configuration et test du pool DHCP


a. Sur le routeur du client, configurez un pool DHCP pour les clients internes.
Customer(config)#ip dhcp excluded-address 192.168.1.1
Customer(config)#ip dhcp pool INTERNAL
Customer(dhcp-config)#network 192.168.1.0 255.255.255.0
Customer(dhcp-config)#domain-name abc-xyz-widgets.inc
Customer(dhcp-config)#default-router 192.168.1.1
b. Sur le PC hte du client, cliquez sur Dmarrer > Panneau de configuration > Connexions rseau
pour vrifier que la carte rseau est bien configure pour DHCP. Si ncessaire, ouvrez une invite de
commandes et entrez les commandes ipconfig /release et ipconfig /renew.
c. Sur le PC hte du client, ouvrez une invite de commandes. Cliquez sur Dmarrer > Excuter, puis
tapez cmd et appuyez sur la touche Entre. Vous pouvez galement cliquer sur Dmarrer > Tous
les programmes > Accessoires > Invite de commandes. Envoyez la commande ipconfig /all.
d. Quelle adresse IP est envoye au PC ? __________________________
e. Quelle est ladresse MAC du PC hte ? __________________________
f. partir du PC hte, envoyez une requte ping la passerelle par dfaut (linterface Ethernet du
routeur). La requte ping a-t-elle abouti ? _______ Effectuez un dpannage si ncessaire et
ne continuez pas tant que la requte ping naboutit pas.

tape 4 : Affichage de la liaison DHCP sur le routeur du client


a. Pour voir la combinaison dadresse IP et dadresse matrielle de lhte (MAC) attribue par le serveur
DHCP dans le routeur, entrez la commande show ip dhcp binding sur le routeur du client.
Customer#show ip dhcp binding
IP address Client-ID/ Lease expiration Type
Hardware address
192.168.1.2 0100.0bdb.04a5.cd May 26 2007 11:19 AM Automatic
b. Ladresse IP et ladresse matrielle affiches correspondent-elles celles enregistres pour le PC
hte ltape 3 ? ______

tape 5 : Configuration des fonctions NAT/PAT


a. Sur le routeur du client, utilisez la commande access-list pour identifier les adresses qui doivent tre
traduites. Le numro de rseau est dclar, mais au lieu dtre suivi dun masque normal comme
cest gnralement le cas, il est suivi dun masque gnrique (0.0.0.255).
Customer(config)#access-list 1 permit 192.168.1.0 0.0.0.255
b. Sur le routeur du client, dfinissez quel endroit la fonction NAT doit rechercher les adresses IP traduire
(la liste source 1 se rapporte la liste daccs 1 que vous venez de crer). Dfinissez galement quelle
adresse IP de linterface utiliser comme adresse relle pour chaque paquet destination de linterface
srie passant par linterface FastEthernet. Le paramtre overload la fin de la commande illustre ci-
dessous signifie que ladresse IP du port srie est utilise et que les numros de port sont utiliss pour
effectuer le suivi des paquets. De faon raliste, environ 4 000 adresses peuvent tre traduites avec cette
mthode, bien quil soit techniquement possible den traduire encore plus.
Customer(config)#ip nat inside source list 1 interface serial 0/0 overload
c. Appliquez la fonction NAT aux interfaces internes et externes.
Customer(config)#interface serial 0/0
Customer(config-if)#ip nat outside
Customer(config-if)#exit
Customer(config)#interface fastethernet 0/0

Copyright sur lintgralit du contenu 19922007 Cisco Systems, Inc. Tous droits rservs.
Ce document contient des informations publiques Cisco. Page 3 sur 8
CCNA Discovery
Travailler dans une PME ou chez un fournisseur de services Internet

Customer(config)#ip nat inside


Customer(config)#end

tape 6 : Test des fonctions NAT/PAT


a. partir de linvite de commandes du PC hte, envoyez une requte ping ladresse de bouclage du
routeur du FAI.
ping 209.165.200.1
b. La requte ping a-t-elle abouti ? ________ Sinon, effectuez le dpannage ncessaire.
c. Sur le routeur du client, entrez la commande pour vrifier la traduction NAT.
Customer#show ip nat translation
Pro Inside global Inside local Outside local Outside global
icmp 209.165.200.225:512 192.168.1.2:512 209.165.200.1:512 209.165.200.1:512

d. Indiquez les adresses IP suivantes :


Quelle est ladresse IP globale interne affiche ? _________________________________________
Quelle est ladresse IP locale interne affiche ? __________________________________________
Quelle est ladresse IP locale externe affiche ? __________________________________________
Quelle est ladresse IP globale externe affiche ? _________________________________________
e. Sur le routeur du FAI, configurez le routeur pour quil affiche tous les paquets ICMP qui y entrent.
ISP#debug ip icmp
ICMP packet debugging is on
f. linvite de commande du PC hte, envoyez une requte ping continue.
ping 209.165.200.1 t
g. Sur le routeur du FAI, notez laffichage des informations de dbogage.
ISP#
00:49:10: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:11: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:12: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:13: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:14: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:15: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
00:49:16: ICMP: echo reply sent, src 209.165.200.1, dst 209.165.200.225
h. Quelle est l'adresse IP source de la rponse ICMP ? ______________________________________
i. Quelle est l'adresse IP de destination de la rponse ICMP ? ________________________________
j. Est-ce que ce dbogage confirme ou infirme le fait que des adresses IP internes sont caches et
comment pouvez-vous le savoir ?
______________________________________________________________________________
______________________________________________________________________________
k. Sur le PC hte, arrtez le ping en appuyant sur CTRL-X.
l. Sur le routeur du FAI, arrtez le processus de dbogage. Notez que le routeur prend quelques
instants pour cesser dafficher les rsultats.
ISP#undebug all

Copyright sur lintgralit du contenu 19922007 Cisco Systems, Inc. Tous droits rservs.
Ce document contient des informations publiques Cisco. Page 4 sur 8
CCNA Discovery
Travailler dans une PME ou chez un fournisseur de services Internet

tape 7 : Effacement des traductions NAT


a. linvite de commandes du PC hte du client, ouvrez une session Telnet au routeur FAI.
telnet 209.165.200.226
Cette session Telnet cre une autre traduction sur le routeur du client.
b. Sur le routeur du client, entrez la commande pour vrifier la traduction NAT.
Customer#show ip nat translation
Pro Inside global Inside local Outside local Outside global
tcp 209.165.200.225:1297 192.168.1.2:1297 209.165.200.226:23 209.165.200.226:23
Les numros de port des adresses Internet peuvent tre diffrents parce quil sagit de numros de
port sources gnrs de manire alatoire.

c. Fermez la fentre de commande sur le PC hte du client pour mettre fin la session Telnet.
d. Sur le routeur du client, entrez la commande pour vrifier la traduction NAT.
Customer#show ip nat translation

e. La traduction pour le PC hte du client est-elle toujours active sur le routeur du client ? __________
Les traductions NAT restent actives durant diffrentes priodes, en fonction du type de traduction.
Les traductions NAT TCP peuvent rester actives jusqu 24 heures par dfaut. Les traductions
de port possdent des limites de temps plus brves, mais peuvent tout de mme rester actives
pendant plusieurs minutes voire heures aprs lexpiration de la session entre les deux htes. Les
temporisations par dfaut pour UDP vont de 1 minute 5 minutes. Pour plus dinformations sur les
temporisations NAT, consultez le livre blanc Cisco IOS Network Address Translation Overview
sur le site Web Cisco.com.
http://cisco.com/en/US/tech/tk648/tk361/technologies_white_paper09186a0080091cb9.shtml
f. Sur le routeur du client, entrez la commande pour effacer toutes les traductions NAT actives du
routeur.
Customer#clear ip nat translation *

Vrifiez que la traduction pour le PC hte du client nest plus active sur le routeur du client.

tape 8 : Remarques gnrales


a. Quel serait lun des avantages de lutilisation de la mthode NAT prsente dans ces travaux
pratiques par rapport une configuration statique illustre dans ce cursus ?
______________________________________________________________________________
______________________________________________________________________________
b. Citez un cas o une socit ne doit pas utiliser de NAT/PAT.
______________________________________________________________________________
______________________________________________________________________________

Copyright sur lintgralit du contenu 19922007 Cisco Systems, Inc. Tous droits rservs.
Ce document contient des informations publiques Cisco. Page 5 sur 8
CCNA Discovery
Travailler dans une PME ou chez un fournisseur de services Internet

Effacement et rechargement du routeur


a. Passez en mode dexcution privilgi laide de la commande enable.
Router>enable
b. linvite du mode dexcution privilgi, entrez la commande erase startup-config.
Router#erase startup-config
Vous obtenez le message suivant :
Erasing the nvram filesystem will remove all files! Continue?
[confirm]
c. Appuyez sur Entre pour confirmer.
La rponse est :
Erase of nvram: complete
d. En mode dexcution privilgi, entrez la commande reload.
Router(config)#reload
Vous obtenez le message suivant :
System configuration has been modified. Save? [yes/no]:
e. Tapez n, puis appuyez sur Entre.
Vous obtenez le message suivant :
Proceed with reload? [confirm]
f. Appuyez sur Entre pour confirmer.
La premire ligne de la rponse est la suivante :
Reload requested by console.
Aprs le rechargement du routeur, la ligne suivante saffiche :
Would you like to enter the initial configuration dialog? [yes/no]:
g. Tapez n, puis appuyez sur Entre.
Vous obtenez le message suivant :
Press RETURN to get started!
h. Appuyez sur Entre.
Le routeur est prt et les travaux pratiques peuvent commencer.

Copyright sur lintgralit du contenu 19922007 Cisco Systems, Inc. Tous droits rservs.
Ce document contient des informations publiques Cisco. Page 6 sur 8
CCNA Discovery
Travailler dans une PME ou chez un fournisseur de services Internet

Relev des interfaces de routeur


Modle de Interface Ethernet 1 Interface Ethernet 2 Interface srie 1 Interface srie 2
routeur
800 (806) Ethernet 0 (E0) Ethernet 1 (E1)
1600 Ethernet 0 (E0) Ethernet 1 (E1) Serial 0 (S0) Serial 1 (S1)
1700 Fast Ethernet 0 Fast Ethernet 1 Serial 0 (S0) Serial 1 (S1)
(FA0) (FA0)
1800 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0 (S0/0) Serial 0/0/1
(FA0/0) (FA0/1) (S0/0/1)
2500 Ethernet 0 (E0) Ethernet 1 (E1) Serial 0 (S0) Serial 1 (S1)
2600 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0 (S0/0) Serial 0/1 (S0/1)
(FA0/0) (FA0/1)
REMARQUE : Pour connatre la configuration exacte du routeur, reportez-vous aux interfaces.
Vous pourrez ainsi identifier le type du routeur ainsi que le nombre dinterfaces quil comporte.
Il n'est pas possible de rpertorier de faon exhaustive toutes les combinaisons de configurations
pour chaque type de routeur. En revanche, le tableau fournit les identifiants des combinaisons
d'interfaces possibles pour chaque priphrique. Ce tableau ne comporte aucun autre type
dinterface, mme si un routeur particulier peut en contenir un. Lexemple de linterface RNIS BRI
pourrait illustrer ceci. La chane de caractres entre parenthses est l'abrviation normalise qui
permet de reprsenter l'interface dans une commande IOS.

Configuration IOS de base du routeur SDM pour activer SDM


Si la configuration initiale est supprime dun routeur SDM, SDM ne saffiche plus par dfaut lors du
redmarrage du routeur. Il est alors ncessaire de crer une configuration de base comme suit. Pour
plus dinformations au sujet de la configuration et de lutilisation de SDM, consultez le SDM Quick
Start Guide :
http://www.cisco.com/en/US/products/sw/secursw/ps5318/products_quick_start09186a0080511c89.h
tml#wp44788
1) Dfinissez ladresse IP Fa0/0 du routeur
(il sagit de linterface laquelle un PC se connecte au moyen dun
navigateur pour activer SDM. Ladresse IP du PC doit tre rgle sur
10.10.10.2 255.255.255.248).

REMARQUE : Il est possible qu'un routeur SDM autre que le 1841 require une connexion un port
diffrent pour accder SDM.

Router(config)# interface Fa0/0


Router(config-if)# ip address 10.10.10.1 255.255.255.248
Router(config-if)# no shutdown

2) Activez le serveur HTTP/HTTPS du routeur, en utilisant les commandes


Cisco IOS suivantes :
Router(config)#ip http server
Router(config)#ip http secure-server
Router(config)#ip http authentication local

Copyright sur lintgralit du contenu 19922007 Cisco Systems, Inc. Tous droits rservs.
Ce document contient des informations publiques Cisco. Page 7 sur 8
CCNA Discovery
Travailler dans une PME ou chez un fournisseur de services Internet

3) Crez un compte utilisateur avec le niveau de privilge 15 (activer les


privilges).
Router(config)# username <username> privilege 15 password 0 <password>

Remplacez <username> et <password> par le nom dutilisateur et le mot


de passe que vous souhaitez configurer.

4) Configurez SSH et Telnet pour la connexion locale et le niveau de


privilge 15 :
Router(config)# line vty 0 4
Router(config-line)# privilege level 15
Router(config-line)# login local
Router(config-line)# transport input telnet
Router(config-line)# transport input telnet ssh
Router(config-line)# exit

Copyright sur lintgralit du contenu 19922007 Cisco Systems, Inc. Tous droits rservs.
Ce document contient des informations publiques Cisco. Page 8 sur 8