Vous êtes sur la page 1sur 12

1-On veut raliser un rseau local soit :

La configuration de base :

Device Interface IP Address Subnet Mask


R1 G0/0 209.165.200.225 255.255.255.248
S0/0/0 (DCE) 10.1.1.1 255.255.255.252
R2 S0/0/0 10.1.1.2 255.255.255.252
S0/0/1(DCE) 10.2.2.2 255.255.255.252
R3 G0/1 172.16.3.1 255.255.255.0
S0/0/1 10.2.2.1 255.255.255.252
VLAN 1 (E0/1) 192.168.1.1 255.255.255.0
ASA VLAN 2 (E0/0) 209.165.200.226 255.255.255.248
VLAN 3 (E0/2) 192.168.2.1 255.255.255.0

Device IP Address Subnet Mask Default Gateway


DMZ Server 192.168.2.3 255.255.255.0 192.168.2.1
PC-B 192.168.1.3 255.255.255.0 192.168.1.1
PC-C 172.16.3.3 255.255.255.0 172.16.3.1
2-La confugiration :

hostnames Configurer et les adresses IP d'interface pour les routeurs, les


commutateurs et les PCs : Dans ces deux points que nous devions faire la
configuration de base du routeur, tels que: la configuration des adresses IP
pour les routeurs, les commutateurs et les PC. Ensuite, il faut configurer le
routage statique entre R1, R2 et R3 qui est relie ASA firewall.

Router 1
Router>enable
Router#configure terminal
Router(config) #hostname R1
R1(config) #interface GigabitEthernet 0/0
R1(config-if)#ip address 209.165.200.225 255.255.255.248
Router(config-if)#no shutdown
R1(config-if)#exit
R1(config) #interface serial0/0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit

Router 2
Router>enable
Router#configure terminal
Router(config) #hostname R2
R2(config) #interface serial 0/0/0
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config) #interface serial0/0/1
R2(config-if)#ip address 10.2.2.2 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit

Router 3
Router>enable
Router#configure terminal
Router(config) #hostname R3
R3(config) #interface GigabitEthernet 0/1
R3(config-if)#ip address 172.16.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config) #interface serial0/0/1
R3(config-if)#ip address 10.2.2.1 255.255.255.252
R3(config-if)#clock rate 64000
R3(config-if)#no shutdown
R3(config-if)#exit
PC B

PC C

DMZ Server
Vrifiez la connectivit entre les htes :

PC-C devrait tre en mesure de faire un ping de l'interface R1. De PC-C, ping
sur l'adresse R1 Fa0 / 0 IP.

Il faut faire un adressage RIP des routers

Router 1
R1>enable
R1#configure terminal
R1(config)#router rip
R1(config-router)#network 209.165.200.0
R1(config-router)#network 10.1.1.0

Router 2
R2>enable
R2#configure terminal
R2(config)#router rip
R2(config-router)#network 10.1.1.0
R2(config-router)#network 10.2.2.0

Router3
R3>enable
R3#configure terminal
R3(config)#router rip
R3(config-router)#network 172.16.3.0
R3(config-router)#network 10.2.2.0

le ping entre le PC-C, et le R1 a G 0 / 0 .


3- Configuration des paramtres ASA de base et des niveaux
de scurit Interface :

Tout d'abord configurer un VLAN 1 interface logique pour le rseau


intrieur (inside)et dfinir le niveau de rglage le plus lev de 100t de
scurit. Ensuite, crez une interface logique VLAN 2 pour le rseau
extrieur (outside) et dfinir le niveau de scurit au plus bas de 0 et faire
apparatre l'interface VLAN 2. Aprs que Assign ASA port de couche 2 E0/1
VLAN 1 et le port E0/0 VLAN 2. Cependant, nous avons besoin de
vrifier et de tester tout et chaque commande pour veiller ce que PC-B a
une adresse IP statique avec un masque de sous-rseau et une passerelle
par dfaut et nous avons galement besoin d'utiliser la commande ping
pour assurer la que les lignes sont tout et il y a une connectivit ..

Configuration ASA

Configurer inside et des interfaces outside :

ciscoasa>enable
Password:
ciscoasa#configure terminal
ciscoasa (config) # Interface vlan 1
ciscoasa (config-if) # nameif inside
ciscoasa (config-if) # ip address 192.168.1.1 255.255.255.0
ciscoasa (config-if) security-level 100
ciscoasa (config-if) # Interface vlan 2
ciscoasa (config-if) # nameif outside
ciscoasa (config-if) adresse ip # 209.165.200.226 255.255.255.248
ciscoasa (config-if) # no shutdown
ASA, le port physique peuvent se voir attribuer une adresse IP de couche 3
directement, comme un routeur Cisco. Avec l'ASA 5505, les ports de
commutation intgrs huit sont de couche 2 ports. Pour affecter la couche 3
paramtres, vous devez crer une interface de commutateur virtuel (SVI) ou de
l'interface VLAN logique et ensuite affecter un ou plusieurs de la couche
physique 2 ports elle. Cependant, nous configurons VLAN 1 (inside) et VLAN 2
(outside) interfaces ce moment. Le 3 (dmz) Interface VLAN sera configur a la
prochain.

Ensuite, nous attribuons chaque VLANs que nous avons cr une interface
:

ciscoasa (config) # Interface e0 / 1


ciscoasa (config-if) # switchport access vlan 1
ciscoasa (config-if) # no shutdown
ciscoasa (config-if) # Interface e0 / 0
ciscoasa (config-if) # switchport access vlan 2
ciscoasa (config-if) # no shutdown

Configurer une route statique par dfaut pour l'ASA.

ciscoasa (config) # route outside 0.0.0.0 0.0.0.0 209.165.200.225


Nous avons configur l'interface extrieure ASA avec une adresse IP statique.
Toutefois, l'ASA n'a pas de passerelle de dernier recours dfini. Pour permettre
l'ASA d'atteindre des rseaux externes, vous allez configurer une route
statique par dfaut sur l'interface extrieure ASA.

4-Configuration de AAA, et SSH :

Authentification utilisateur Configurer AAA local.

Dfinir un utilisateur local nomm admin en entrant la commande de nom


d'utilisateur. Configurer AAA pour utiliser la base de donnes ASA local pour
l'authentification de l'utilisateur SSH.

ciscoasa (config)# username admin password cisco123


ciscoasa (config)# aaa authentication ssh console LOCAL

Nous dfinissons un utilisateur local nomm administrateur en entrant la


commande de nom d'utilisateur. Indiquez un mot de passe cisco123. Ensuite,
nous configurons AAA utiliser la base de donnes ASA local pour
l'authentification de l'utilisateur SSH.

Configurer la gestion distance avec SSH.

Vous pouvez configurer l'ASA pour accepter les connexions SSH partir d'un
seul hte ou une plage d'htes sur le rseau inside ou outside. Gnrer une
paire de cls RSA, qui est ncessaire pour soutenir les connexions SSH
Configurer l'ASA pour autoriser les connexions SSH partir de tout hte sur le
rseau inside et de l'hte de gestion distance au bureau de la branche sur le
rseau outside.

ciscoasa (config)# crypto key generate rsa modulus 1024


WARNING: You have a RSA keypair already defined named <Default-RSA-Key>.

Do you really want to replace them? [yes/no]: no


ERROR: Failed to create new RSA keys named <Default-RSA-Key>

ciscoasa (config)# ssh 172.16.3.3 255.255.255.255 outside


ciscoasa (config)# ssh timeout 10

Nous configurons l'ASA pour accepter les connexions SSH partir d'un seul
hte ou une plage d'htes sur le rseau inside ou outside . Le RSA est une paire
de cls, ce qui est ncessaire pour soutenir les connexions SSH. Ensuite, nous
configurons l'ASA pour autoriser les connexions SSH partir de tout l'hte de
gestion distance la succursale (172.16.3.3) sur le rseau outside
seulement . Dfinissez le dlai d'attente SSH 10 minutes (la valeur par dfaut
est de 5 minutes).

5- Configuration d'un DMZ :

ciscoasa (config)# interface vlan 3


ciscoasa (config-if)# ip address 192.168.2.1 255.255.255.0
ciscoasa (config-if)# nameif dmz
ERROR: This license does not allow configuring more than 2 interfaces with nameif and without a
"no forward" command on this interface or on 1 interface(s) with nameif already configured.

ciscoasa (config-if)# no forward interface vlan 1


ciscoasa (config-if)# nameif dmz
ciscoasa (config-if)# security-level 70
ciscoasa (config-if)# no shutdown
ciscoasa (config-if)# interface Ethernet0/2
ciscoasa (config-if)# switchport access vlan 3
ciscoasa (config-if) # no shutdown

Nous configurons DMZ VLAN 3, qui est l'endroit o le serveur Web d'accs
public va rsider. Attribuez-lui adresse IP 192.168.2.1/24, nommez dmz et lui
attribuer un niveau de 70 scurit Ensuite, nous attribuons interface physique
ASA E0 / 2 DMZ VLAN 3 et activer l'interface

Les vlans crier dans ASA :


Les interfaces de ASA :