Vous êtes sur la page 1sur 32

Master of Engineering in

Internetworking

Lab #3
IP MULTICASTING
INWK 6115

Section 1
Group 4

Name
Kaushalkumar Shah (B00610490)
Shahrukh Khan (B00615585)
E.Ram Mohan Rao (B00639567)
QUESTIONS

Q1 What is RPF Check? Why is it used in multicast?

Ans:

Definition:

Reverse path forwarding (RPF) is a technique used in modern routers for the purposes of
ensuring loop-free forwarding of multicast packets in multicast routing and to help prevent
IP address spoofing in unicast routing.

The underlying assumptions of RPF check are that:

The unicast routing table must be correct and converged.


The path used from a sender to a router and the reverse path from the router back to the
sender are symmetric.

If the first assumption is not true, the RPF check will fail because it depends upon the
router's unicast routing table as a fallback. If the second assumption is not true, the RPF
check would reject multicast traffic on all but the shortest path from the sender to the
router and would eventually lead to non-optimal multicast tree.

In cases where the links are unidirectional, the reverse path approach can fail altogether.

Multicast RPF, typically denoted simply as RPF, is used in conjunction with a multicast
routing protocol such as MSDP, PIM-SM and PIM-DM to ensure loop-free forwarding of
multicast packets. In multicast routing, the decision to forward traffic is based upon source
address and not on destination address as in unicast routing. It does this by utilizing either
a dedicated multicast routing table or alternatively the router's unicast routing table.

When a multicast packet enters a router's interface, it will look up the list of networks that
are reachable via that interface i.e., it checks the reverse path of the packet. If the router
finds a matching routing entry for the source IP address of the multicast packet, the RPF
check passes and the packet is forwarded to all other interfaces that are participating in
multicast for that multicast group. If the RPF check fails, the packet will be dropped. As a
result, the forwarding of the packet is decided based upon the reverse path of the packet
rather than the forward path. RPF routers only forward packets that come into the
interface that also holds the routing entry for the source of the packet, thus breaking any
loop
Q2 Attach running configuration and all show commands in your report?

Ans

Router R4:

4R4#show run

Building configuration...

Current configuration : 1992 bytes

! Last configuration change at 16:12:03 UTC Thu Nov 13 2014

! NVRAM config last updated at 16:34:16 UTC Thu Nov 13 2014

! NVRAM config last updated at 16:34:16 UTC Thu Nov 13 2014

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname 4R4

interface Loopback0

ip address 4.4.4.4 255.255.255.255


ip pim sparse-dense-mode

interface Embedded-Service-Engine0/0

no ip address

shutdown

interface GigabitEthernet0/0

no ip address
duplex auto

speed auto

interface GigabitEthernet0/1

ip address 169.1.42.4 255.255.255.0

ip pim sparse-dense-mode

duplex auto

speed auto

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

interface Serial0/0/0

ip address 169.1.24.4 255.255.255.0

ip pim sparse-dense-mode

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

router ospf 1

router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 1
network 169.1.24.4 0.0.0.0 area 1

network 169.1.42.4 0.0.0.0 area 1

ip forward-protocol nd

ip pim rp-address 1.1.1.1

no ip http server

no ip http secure-server

end

4R4# show ip pim rp mapping

PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static

RP: 1.1.1.1 (?)

4R4#show ip rpf 7.7.7.7

RPF information for ? (7.7.7.7)

RPF interface: GigabitEthernet0/1


RPF neighbor: ? (169.1.42.2)

RPF route/mask: 7.7.7.7/32

RPF type: unicast (ospf 1)

Doing distance-preferred lookups across tables

RPF topology: ipv4 multicast base, originated from ipv4 unicast base

4R4#

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) T


Initialised table
Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) T
7.7.7.7/32 EVENT Track start

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) N


7.7.7.7/32 Adding track

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) N


7.7.7.7/32 QP Schedule query

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) T


7.7.7.7/32 EVENT Query found route

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) N


7.7.7.7/32 Adding route

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) R


7.7.7.7/32 d=0 p=0 -> Updating

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4:base) T Initialised table

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) R


7.7.7.7/32 d=110 p=1 -> Gi0/1 169.1.42.2 68 Notifying

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: Adding to client notification queue

Nov 13 22:23:39.877: IPMCAST-RPF : Received notification from Route Watch, Sending


message to process: PIM Process

Nov 13 22:23:39.877: IPMCAST-RPF : Processing Route Watch notification

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) W


7.7.7.7/32 c=0x141A7D08 Client notified reachable

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) W


7.7.7.7/32 c=0x141A7D08 EVENT Track stop

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) W


7.7.7.7/32 c=0x141A7D08 Removing

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) R


7.7.7.7/32 d=110 p=1 -> Gi0/1 169.1.42.2 68 Scheduled to check for deletion

Nov 13 22:23:39.877: IPMCAST-RPF RIB_RWATCH: (default:ipv4 multicast:base) R


7.7.7.7/32 d=110 p=1 -> Gi0/1 169.1.42.2 68 Deleting
4R4#show ip pim interface

Address Interface Ver/ Nbr Query DR DR

Mode Count Intvl Prior

169.1.42.4 GigabitEthernet0/1 v2/SD 1 30 1 169.1.42.4

169.1.24.4 Serial0/0/0 v2/SD 1 30 1 0.0.0.0

4.4.4.4 Loopback0 v2/SD 0 30 1 4.4.4.4

4R4#ping 224.1.1.1

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 169.1.37.7, 12 ms

SWITCH 2: (CLIENT)

4S2#show run

Building configuration...

Current configuration : 2793 bytes

version 12.2

no service pad
service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname 4S2

no aaa new-model
ip subnet-zero

ip routing

no ip domain-lookup

ip multicast-routing

vtp domain inwk

vtp mode transparent

interface Loopback0

ip address 7.7.7.7 255.255.255.255

ip pim sparse-dense-mode

interface FastEthernet0/9

no switchport

ip address 169.1.37.7 255.255.255.0

ip pim sparse-dense-mode

ip igmp join-group 224.1.1.1

router ospf 1

router-id 7.7.7.7

log-adjacency-changes

network 7.7.7.7 0.0.0.0 area 4

network 169.1.37.7 0.0.0.0 area 4

!
ip pim rp-address 1.1.1.1
!

control-plane

line con 0

line vty 5 15

End

4S2#show ip pim ne

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

P - Proxy Capable, S - State Refresh Capable

Neighbor Interface Uptime/Expires Ver DR

Address Prio/Mode

169.1.37.3 FastEthernet0/9 08:53:36/00:01:42 v2 1 / S P

4S2#show ip pim in
Address Interface Ver/ Nbr Query DR DR

Mode Count Intvl Prior

169.1.37.7 FastEthernet0/9 v2/SD 1 30 1 169.1.37.7

7.7.7.7 Loopback0 v2/SD 0 30 1 7.7.7.7

4S2#show ip pim rp mapping

PIM Group-to-RP Mappings


Group(s): 224.0.0.0/4, Static

RP: 1.1.1.1 (?)

ROUTER R3 (Server Emulation)

4R3#show run

Building configuration..

Current configuration : 2097 bytes

! Last configuration change at 15:08:40 UTC Thu Nov 13 2014

! NVRAM config last updated at 16:48:33 UTC Thu Nov 13 2014

! NVRAM config last updated at 16:48:33 UTC Thu Nov 13 2014

version 15.1

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname 4R3
ip multicast-routing

no ip domain lookup

interface Loopback0

ip address 3.3.3.3 255.255.255.255

ip pim sparse-dense-mode
!

interface Embedded-Service-Engine0/0

no ip address

shutdown

interface GigabitEthernet0/0

ip address 169.1.13.3 255.255.255.0

ip pim sparse-dense-mode

duplex auto

speed auto

interface GigabitEthernet0/1

ip address 169.1.33.3 255.255.255.0

ip pim sparse-dense-mode

duplex auto

speed auto

interface GigabitEthernet0/2

ip address 169.1.37.3 255.255.255.0

ip pim sparse-dense-mode

duplex auto

speed auto

interface Serial0/0/0

ip address 192.168.40.1 255.255.255.252

!
interface Serial0/0/1
no ip address

shutdown

router ospf 1

router-id 3.3.3.3

area 2 virtual-link 1.1.1.1

network 3.3.3.3 0.0.0.0 area 2

network 169.1.13.3 0.0.0.0 area 2

network 169.1.33.3 0.0.0.0 area 3

network 169.1.37.3 0.0.0.0 area 4

ip forward-protocol nd

ip pim rp-address 1.1.1.1

scheduler allocate 20000 1000

end

4R3#show ip pim rp

Group: 224.1.1.1, RP: 1.1.1.1, v2, uptime 08:02:08, expires never

Group: 224.0.1.40, RP: 1.1.1.1, v2, uptime 08:37:22, expires never

4R3#show ip pim ne

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

P - Proxy Capable, S - State Refresh Capable, G - GenID Capable


Neighbor Interface Uptime/Expires Ver DR

Address Prio/Mode

169.1.13.1 GigabitEthernet0/0 09:13:14/00:01:33 v2 1 / S P G

169.1.37.7 GigabitEthernet0/2 09:04:15/00:01:40 v2 1 / DR S P G

4R3#show ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

U - URD, I - Received Source Specific Host Report,

Z - Multicast Tunnel, z - MDT-data group sender,

Y - Joined MDT-data group, y - Sending to MDT-data group,

V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 08:03:16/00:03:28, RP 1.1.1.1, flags: SJC

Incoming interface: GigabitEthernet0/0, RPF nbr 169.1.13.1

Outgoing interface list:

GigabitEthernet0/2, Forward/Sparse-Dense, 07:01:04/00:03:28

(*, 224.0.1.40), 09:14:01/00:02:39, RP 1.1.1.1, flags: SJCL

Incoming interface: GigabitEthernet0/0, RPF nbr 169.1.13.1


Outgoing interface list:
GigabitEthernet0/2, Forward/Sparse-Dense, 07:01:04/00:02:45

4R3#show ip igmp interface

GigabitEthernet0/0 is up, line protocol is up

Internet address is 169.1.13.3/24

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 1 joins, 0 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0


Multicast designated router (DR) is 169.1.13.3 (this system)

IGMP querying router is 169.1.13.1

Multicast groups joined by this system (number of users):

224.0.1.40(1)

GigabitEthernet0/1 is up, line protocol is up

Internet address is 169.1.33.3/24

IGMP is enabled on interface

Current IGMP host version is 2


Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 0 joins, 0 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0

Multicast designated router (DR) is 169.1.33.3 (this system)

IGMP querying router is 169.1.33.3 (this system)

No multicast groups joined by this system

GigabitEthernet0/2 is up, line protocol is up

Internet address is 169.1.37.3/24

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

R3#show ip igmp groups

IGMP Connected Group Membership

Group Address Interface Uptime Expires Last Reporter Group Accounted


224.1.1.1 GigabitEthernet0/2 08:04:13 00:02:39 169.1.37.7

224.0.1.40 GigabitEthernet0/2 09:05:59 00:02:42 169.1.37.7

224.0.1.40 GigabitEthernet0/0 09:14:58 00:02:20 169.1.13.1

4R3#ping 224.1.1.1

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 169.1.37.7, 1 ms

Reply to request 0 from 169.1.37.7, 16 ms

Reply to request 0 from 169.1.37.7, 16 ms

Reply to request 0 from 169.1.37.7, 16 ms

ROUTER R1 (RP)

4R1#show run

Building configuration...

Current configuration : 2695 bytes


!

! Last configuration change at 16:40:04 UTC Thu Nov 13 2014

version 15.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname 4R1
!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

ip pim sparse-dense-mode

interface Embedded-Service-Engine0/0

no ip address

shutdown

interface GigabitEthernet0/0

ip address 169.1.13.1 255.255.255.0

ip pim sparse-dense-mode

duplex auto

speed auto

interface Serial0/0/0

ip address 169.1.21.1 255.255.255.0

ip pim sparse-dense-mode

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

!
router ospf 1
router-id 1.1.1.1

area 2 virtual-link 3.3.3.3

network 1.1.1.1 0.0.0.0 area 0

network 169.1.13.1 0.0.0.0 area 2

network 169.1.21.1 0.0.0.0 area 0

ip pim rp-address 1.1.1.1

scheduler allocate 20000 1000

End

4R1#show ip pim rp

Group: 224.1.1.1, RP: 1.1.1.1, next RP-reachable in 00:01:29

Group: 224.0.1.40, RP: 1.1.1.1, next RP-reachable in 00:00:06

4R1#show ip pim ne
PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

P - Proxy Capable, S - State Refresh Capable, G - GenID Capable

Neighbor Interface Uptime/Expires Ver DR

Address Prio/Mode

169.1.13.3 GigabitEthernet0/0 09:19:37/00:01:42 v2 1 / DR S P G

169.1.21.2 Serial0/0/0 09:16:35/00:01:36 v2 1 / S P G


4R1#show ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

U - URD, I - Received Source Specific Host Report,

Z - Multicast Tunnel, z - MDT-data group sender,

Y - Joined MDT-data group, y - Sending to MDT-data group,

G - Received BGP C-Mroute, g - Sent BGP C-Mroute,

Q - Received BGP S-A Route, q - Sent BGP S-A Route,

V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 07:12:44/00:03:17, RP 1.1.1.1, flags: S

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

GigabitEthernet0/0, Forward/Sparse-Dense, 07:07:08/00:03:17

(*, 224.0.1.40), 09:20:50/00:03:01, RP 1.1.1.1, flags: SJCL

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Serial0/0/0, Forward/Sparse-Dense, 06:42:33/00:03:01

GigabitEthernet0/0, Forward/Sparse-Dense, 09:20:50/00:02:39


4R1#show ip igmp in

GigabitEthernet0/0 is up, line protocol is up

Internet address is 169.1.13.1/24

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 1 joins, 0 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0

Multicast designated router (DR) is 169.1.13.3


IGMP querying router is 169.1.13.1 (this system)

Multicast groups joined by this system (number of users):

224.0.1.40(1)

Serial0/0/0 is up, line protocol is up

Internet address is 169.1.21.1/24

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2


IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 0 joins, 0 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0

IGMP querying router is 0.0.0.0 (this system)

No multicast groups joined by this system

Loopback0 is up, line protocol is up

Internet address is 1.1.1.1/32

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set


IGMP activity: 0 joins, 0 leaves
Multicast routing is enabled on interface

Multicast TTL threshold is 0

Multicast designated router (DR) is 1.1.1.1 (this system)

IGMP querying router is 1.1.1.1 (this system)

No multicast groups joined by this system

4R1#show ip pim in

Address Interface Ver/ Nbr Query DR DR

Mode Count Intvl Prior

169.1.13.1 GigabitEthernet0/0 v2/SD 1 30 1 169.1.13.3

169.1.21.1 Serial0/0/0 v2/SD 1 30 1 0.0.0.0

1.1.1.1 Loopback0 v2/SD 0 30 1 1.1.1.1

4R1#ping 224.1.1.1

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 169.1.37.7, 20 ms

Reply to request 0 from 169.1.37.7, 28 ms

Reply to request 0 from 169.1.37.7, 28 ms

Reply to request 0 from 169.1.37.7, 28 ms

Reply to request 0 from 169.1.37.7, 28 ms

Reply to request 0 from 169.1.37.7, 28 ms

Reply to request 0 from 169.1.37.7, 28 ms

Reply to request 0 from 169.1.37.7, 28 ms


Reply to request 0 from 169.1.37.7, 24 ms

Reply to request 0 from 169.1.37.7, 24 ms

Reply to request 0 from 169.1.37.7, 24 ms

Reply to request 0 from 169.1.37.7, 24 ms

Reply to request 0 from 169.1.37.7, 24 ms

Reply to request 0 from 169.1.37.7, 24 ms

Reply to request 0 from 169.1.37.7, 24 ms

Reply to request 0 from 169.1.37.7, 20 ms

ROUTER R2:

4R2#show run

Building configuration...

Current configuration : 2383 bytes

! Last configuration change at 13:35:01 UTC Thu Nov 13 2014

! NVRAM config last updated at 13:45:51 UTC Thu Nov 13 2014

! NVRAM config last updated at 13:45:51 UTC Thu Nov 13 2014

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname 4R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip pim sparse-dense-mode

interface Loopback200

no ip address

shutdown

interface Embedded-Service-Engine0/0

no ip address

shutdown

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface GigabitEthernet0/2

ip address 169.1.22.2 255.255.255.0

ip pim sparse-dense-mode

duplex auto
speed auto
!

interface Serial0/0/0

ip address 169.1.21.2 255.255.255.0

ip pim sparse-dense-mode

clock rate 2000000

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

interface Serial0/1/0

ip address 169.1.24.2 255.255.255.0

ip pim sparse-dense-mode

clock rate 2000000

interface Serial0/1/1

no ip address

shutdown

clock rate 2000000

interface GigabitEthernet0/2/0

ip address 169.1.42.2 255.255.255.0

ip pim sparse-dense-mode

duplex auto

speed auto
!
!

router ospf 1

router-id 2.2.2.2

network 2.2.2.2 0.0.0.0 area 0

network 169.1.21.2 0.0.0.0 area 0

network 169.1.22.2 0.0.0.0 area 5

network 169.1.24.2 0.0.0.0 area 1

network 169.1.42.2 0.0.0.0 area 1

ip forward-protocol nd

ip pim rp-address 1.1.1.1

scheduler allocate 20000 1000

end

4R2#show ip pim ne

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

P - Proxy Capable, S - State Refresh Capable, G - GenID Capable

Neighbor Interface Uptime/Expires Ver DR

Address Prio/Mode

169.1.21.1 Serial0/0/0 09:21:49/00:01:22 v2 1 / S P G

169.1.42.4 GigabitEthernet0/2/0 06:50:43/00:01:17 v2 1 / DR S P G

169.1.24.4 Serial0/1/0 06:43:33/00:01:30 v2 1 / S P G


4R2#show ip pim in

Address Interface Ver/ Nbr Query DR DR

Mode Count Intvl Prior

169.1.22.2 GigabitEthernet0/2 v2/SD 0 30 1 169.1.22.2

169.1.21.2 Serial0/0/0 v2/SD 1 30 1 0.0.0.0

169.1.42.2 GigabitEthernet0/2/0 v2/SD 1 30 1 169.1.42.4

2.2.2.2 Loopback0 v2/SD 0 30 1 2.2.2.2

169.1.24.2 Serial0/1/0 v2/SD 1 30 1 0.0.0.0

4R2#show ip pim rp

Group: 224.1.1.1, RP: 1.1.1.1, v2, uptime 00:02:50, expires never

Group: 224.0.1.40, RP: 1.1.1.1, v2, uptime 07:42:49, expires never

4R2#show ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,


U - URD, I - Received Source Specific Host Report,

Z - Multicast Tunnel, z - MDT-data group sender,

Y - Joined MDT-data group, y - Sending to MDT-data group,

V - RD & Vector, v - Vector

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode


(*, 224.1.1.1), 00:03:03/00:02:56, RP 1.1.1.1, flags: SP

Incoming interface: Serial0/0/0, RPF nbr 169.1.21.1

Outgoing interface list: Null

(*, 224.0.1.40), 08:25:26/00:02:59, RP 1.1.1.1, flags: SJCL

Incoming interface: Serial0/0/0, RPF nbr 169.1.21.1

Outgoing interface list:

GigabitEthernet0/2, Forward/Sparse-Dense, 08:25:26/00:02:59

4R2#show ip igmp in

GigabitEthernet0/2 is up, line protocol is up

Internet address is 169.1.22.2/24

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 1 joins, 0 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0


Multicast designated router (DR) is 169.1.22.2 (this system)
IGMP querying router is 169.1.22.2 (this system)

Multicast groups joined by this system (number of users):

224.0.1.40(1)

Serial0/0/0 is up, line protocol is up

Internet address is 169.1.21.2/24

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 0 joins, 0 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0

IGMP querying router is 0.0.0.0 (this system)

No multicast groups joined by this system

GigabitEthernet0/2/0 is up, line protocol is up

Internet address is 169.1.42.2/24

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2


IGMP query interval is 60 seconds
IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 1 joins, 1 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0

Multicast designated router (DR) is 169.1.42.4

IGMP querying router is 169.1.42.2 (this system)

No multicast groups joined by this system

Loopback0 is up, line protocol is up

Internet address is 2.2.2.2/32

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set


IGMP activity: 0 joins, 0 leaves
Multicast routing is enabled on interface

Multicast TTL threshold is 0

Multicast designated router (DR) is 2.2.2.2 (this system)

IGMP querying router is 2.2.2.2 (this system)

No multicast groups joined by this system

Serial0/1/0 is up, line protocol is up

Internet address is 169.1.24.2/24

IGMP is enabled on interface

Current IGMP host version is 2

Current IGMP router version is 2

IGMP query interval is 60 seconds

IGMP configured query interval is 60 seconds

IGMP querier timeout is 120 seconds

IGMP configured querier timeout is 120 seconds

IGMP max query response time is 10 seconds

Last member query count is 2

Last member query response interval is 1000 ms

Inbound IGMP access group is not set

IGMP activity: 0 joins, 0 leaves

Multicast routing is enabled on interface

Multicast TTL threshold is 0

IGMP querying router is 0.0.0.0 (this system)

No multicast groups joined by this system


4R2#ping 224.1.1.1

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 169.1.37.7, 4 ms

Reply to request 0 from 169.1.37.7, 24 ms

Reply to request 0 from 169.1.37.7, 24 ms

END