Vous êtes sur la page 1sur 162

Travaux pratiques FT_CCM2 (Ver3.

3)
"Tlphonie avance"

SOMMAIRE
I DECOUVERTE DU RESEAU............................................................................................................ 3
I.1 Vrification de la plateforme.......................................................................................................... 3
Objectif : Vrifier que linfrastructure est fonctionnelle...................................................................3
II CONFIGURATION INITIALE DE CCM ET ACTIVATION DES SERVICES......................................9
II.1 Accs la page web dadministration de Call Manager...............................................................9
Objectif : Apprendre accder au systme via un compte/mot de passe......................................9
II.2 Changement du nom des serveurs par ladresse IP...................................................................11
Objectif : Eviter la rsolution DNS par les tlphones..................................................................11
II.3 Activation des services............................................................................................................... 12
Objectif : Activer les services ncessaires au fonctionnement du systme..................................12
II.4 Configuration des privilges daccs linterface dadministration par MLA..............................15
Objectif : Crer deux utilisateurs ayant des privilges diffrents daccs Call Manager............15
II.5 Procdure de sauvegarde et de restauration par Disaster Recovery.........................................20
Objectif : Sauvegarder le systme et le restaurer........................................................................20
III MISE EN PLACE DES TELEPHONES IP POUR CALL MANAGER............................................27
III.1 Dclaration manuelle dun tlphone IP....................................................................................27
Objectif : Enregistrer 1 tlphone IP sous le PBX IP Call Manager et lui attribuer le numro de
tlphone x001............................................................................................................................ 27
III.2 Dclaration des tlphones par linjection dun fichier CSV en utilisant BAT.............................30
Objectif : Enregistrer 2 tlphones IP sous le PBX IP Call Manager et leur attribuer les numros
de tlphone x002 et x003........................................................................................................... 30
IV MISE EN PLACE DES PASSERELLES VoIP..............................................................................41
IV.1 Configuration de la passerelle BR-x en H323 pour les tlphones IP Call Manager.................41
Objectif : Mettre en relation les tlphones IP avec le RTC numrique (RNIS) via BR-x............41
IV.2 Configuration de la passerelle HQ-x en MGCP pour les tlphones IP Call Manager..............43
Objectif : Mettre en relation les tlphones IP avec le RTC numrique (RNIS) via HQ-x...........43
V MISE EN UVRE DUN PLAN DE NUMEROTATION..................................................................50
V.1 Route Patterns pour atteindre le RTC RNIS via H323 sur BR-x ou par MGCP sur HQ-x...........50
Objectif : Les tlphones IP contactent le RTC en composant par exemple 00155940001#.......50
V.2 Discrimination du routage dappel via les Calling Search Space/Partition..................................59
Objectif : Les tlphones HQ doivent passer dabord par HQ-x et le tlphone BR doit passer
prfrentiellement par BR-x pour aller sur le RTC.......................................................................59
VI. MISE EN UVRE DES FONCTIONNALITES DES PASSERELLES............................................66
VI.1 Configuration des Region pour passer en codec bas dbit entre les tlphones HQ et le
tlphone BR................................................................................................................................... 66
Objectif : Vrifier que la confrence par dfaut fonctionne entre les 3 IP phones puis utiliser le
codec G729 entre HQ et BR et conserver le codec G711 entre les tlphones HQ. Vrifier que la
confrence ne marche plus dans ce cas......................................................................................66
VI.2 Cration des Media Resources sur BR-x pour le service de confrence Hardware..................74
Objectif : Utiliser les DSP du routeur BR comme pont de confrence multi-codec......................74
VI.3 Utilisation des media resource de BR-x par Call Manager........................................................76
Objectif : Configurer les ressources cres sur BR-x sur Call Manager pour tre utilisable par les
tlphones IP............................................................................................................................... 76
VI.4 Association dun MRGL pour associer la ressource CFB cre aux tlphones BR.................79
Objectif : Permettre aux tlphones dutiliser dabord la confrence hardware CFB_BR ; la
confrence Software par Call Manager tant utilise par dfaut en premier, avant la confrence
Hardware..................................................................................................................................... 79
VII - IMPLEMENTATION DU DEPLOIEMENT MULTI-SITE ...........................................................83
VII.1 Limitation dappel par le paramtre Location...........................................................................83
Objectif : Limiter le nombre dappel 1 entre HQ et BR..............................................................83
VII.2 Mise en place de SRST sur BR............................................................................................... 86
Objectif : Conserver laccs RTC sur BR mme quand le WAN est down...................................86
VIII CONFIGURATION DES FONCTIONNALITES AVANCEES DU CUCM.....................................87

1
VIII.1 Mise en place de Extension Mobility.......................................................................................87
Objectif : Permettre de se logguer sur un tlphone IP...............................................................87
VIII.2 Mise en place de lAttendant console....................................................................................101
Objectif : Configurer la console de la standardiste.....................................................................101
IX OUTILS DE DIAGNOSTIC : SURVEILLANCE ET GESTION DU SYSTEME DE TELEPHONIE
SUR IP............................................................................................................................................... 123
IX.1 Installation et utilisation de RTMT.......................................................................................... 123
Objectif : Installer le plugin RTMT sur le PC et accder linterface de gestion pour grer
alarmes, altertes et traces.......................................................................................................... 123
IX.2 Utilisation de Dial Number Analyzer.......................................................................................128
Objectif : Vrifier laccessibilit dun numro de tlphone par DNA.........................................128
IX.3 Accs la ligne de commandes via SSH................................................................................130
Objectif : Accder linterface CLI via un compte/mot de passe...............................................130
X - CONFIGURATION DE UNITY...................................................................................................... 139
X.1 Configurer Call Manager pour Cisco Unity..............................................................................139
Objectif : Configuration des Voice Mail Ports en utilisant Cisco Voice Mail Port Wizard et
Configuration du Voice Mail Pilot x800 en tant que numro de la messagerie...........................139
X.2 Configurer des renvoi dappels vers la messagerie................................................................149
Objectif : Mettre en uvre des renvois dappel sur non-rponse ou sur occupation.................149
X.3 Administrer Cisco Unity............................................................................................................ 151
Objectif : Accder Cisco Unity, configurer un compte Subscriber et le standard automatique 151
X.4 Configuration dun compte Subscriber.....................................................................................152
Objectif : configurer deux comptes de messagerie vocale Unity................................................152
X.5 Configuration de lAuto-attendant (Standard Auto)...................................................................157
Objectif : Configurer le Serveur Vocal Interactif (SVI) intgr Cisco Unity.............................157

2
Remarques importantes pralables :
-"x" dsigne votre numro de Pod
-Le formateur doit vous remettre les configurations initiales des routeurs depuis une cl USB ou en
passant par une page web dont il vous remettra lURL
-Les exemples ou les captures d'cran seront toujours donns pour le Pod1. Remplacez 1 par 2 si
vous travaillez sur le Pod2 (ex:10.1.1.1 pour le Pod 1 correspondra 10.2.1.1 pour le Pod2)

I DECOUVERTE DU RESEAU
I.1 Vrification de la plateforme
Objectif : Vrifier que linfrastructure est fonctionnelle

-Lancer Internet Explorer et entrer ladresse : http://rlabs.globalknowledge.net. Demander au


formateur le Rack ID et l Event ID . Ensuite slectionner le Pod1 ou le Pod2 selon ce
que vous aura communiqu le formateur.

Attention ! Le routeur HQ1-x sur la page Web correspond HQ-x sur le schma que vous a
remis le formateur. le routeur HQ2-x (en gris sur la page Web) est en fait le routeur BR-x sur
le schma

-Sur HQ-x et BR-x, tapez enable puis show run pour vrifier la configuration par
dfaut de vos routeurs. Il existe dj une configuration que nous allons remettre zro.
Taper :
> en
# erase startup-configuration
# reload

-Rpondre par no si vous demande de sauvegarder. Aprs le redmarrage (2-3 mins),


taper :

Would you like to enter in configuration dialog ? No


Router> en
Router# conf t
Router(config)#

-Injecter ensuite la configuration propose par le formateur en faisant un copier-coller. Vous


pourrez trouver vos configurations sur le site Web http://rabdoul.free.fr FT_CCM2
configurations initiales

-Ci-dessous, voici les configurations de HQ-1 et BR-1 prises comme exemple :

hostname HQ-1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$8meI$MfFdRY065Wi3TeXfNC6.T1
!
no aaa new-model
memory-size iomem 10
no network-clock-participate wic 1
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.1.3.1 10.1.3.20
ip dhcp excluded-address 10.1.3.30 10.1.3.255
!
ip dhcp pool HQ-Data
network 10.1.3.0 255.255.255.0

3
default-router 10.1.3.199
dns-server 158.43.128.1
!
ip dhcp pool HQ-Voice
network 10.1.2.0 255.255.255.0
default-router 10.1.2.101
option 150 ip 10.1.1.1
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
isdn switch-type primary-net5
!
voice-card 0
no dspfarm
!
archive
log config
hidekeys
!
controller E1 0/1/0
!
interface Loopback0
description HQ-1:Loopback
ip address 10.1.250.101 255.255.255.255
!
interface FastEthernet0/0
description TRUNK to switch
no ip address
duplex full
speed 100
!
interface FastEthernet0/0.101
description Pod1 HQ CCM VLAN (CCM1-1, CCM2-1 and Unity-1)
encapsulation dot1Q 111
ip address 10.1.1.101 255.255.255.0
!
interface FastEthernet0/0.102
description Pod1 HQ Voice VLAN (HQ Phones)
encapsulation dot1Q 112
ip address 10.1.2.101 255.255.255.0
ip helper-address 10.1.1.1
!
interface FastEthernet0/0.103
description Pod1 HQ Data VLAN (PC-1)
encapsulation dot1Q 113
ip address 10.1.3.101 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description to Wan-Switch (pstn)

4
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type cisco
!
interface Serial0/0/0.100 point-to-point
description to gk/itsp (pstn)
ip address 10.1.10.101 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 100
!
interface Serial0/0/0.102 point-to-point
description to BR-1
ip address 10.1.4.101 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 112
!
interface Serial0/0/0.103 point-to-point
description to HQ-2
ip address 10.12.1.101 255.255.0.0
snmp trap link-status
frame-relay interface-dlci 121
!
interface Serial0/0/1
no ip address
clock rate 125000
!
router eigrp 100
network 10.0.0.0
no auto-summary
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
gatekeeper
shutdown
!
banner exec ^CDo not forget to enter TERMINAL MONITOR when using telnet!^C
!
line con 0
password cisco
login
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
!
end

5
hostname BR-1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$QbyQ$7NUSTFdp8AtRO4x5Pv3zE/
!
no aaa new-model
network-clock-participate wic 3
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.1.5.1 10.1.5.10
ip dhcp excluded-address 10.1.5.20 10.1.5.255
!
ip dhcp pool BR-Phones
network 10.1.5.0 255.255.255.0
default-router 10.1.5.101
option 150 ip 10.1.1.1
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
voice-card 0
no dspfarm
!
archive
log config
hidekeys
!
controller E1 0/3/0
description to PSTN
!
interface Loopback0
description BR-1:Loopback
ip address 10.1.250.102 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex full
speed 100
!
interface FastEthernet0/0.105
description Pod 1 BR Voice VLAN (BR Phone)
encapsulation dot1Q 115
ip address 10.1.5.101 255.255.255.0
!
interface FastEthernet0/1
description NOT USED
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description to wan-switch (pstn)
no ip address

6
encapsulation frame-relay
no fair-queue
frame-relay lmi-type cisco
!
interface Serial0/0/0.102 point-to-point
description to HQ-1
ip address 10.1.4.102 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 111
!
interface Serial0/0/1
no ip address
shutdown
clock rate 125000
!
router eigrp 100
network 10.0.0.0
no auto-summary
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
voice-port 0/1/0
!
voice-port 0/1/1
!
gatekeeper
shutdown
!
banner exec ^CCDo not forget to enter TERMINAL MONITOR when using telnet!
^C
!
line con 0
exec-timeout 0 0
password cisco
login
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!
scheduler allocate 20000 1000
!
end

7
-Vrifier la table de routage et la connectivit rseau. Vous pouvez taper "show ip route" sur
HQ-x et BR-x.

Question : quel est le protocole de routage utilis?


...
...

-Vrifier la connectivit dans le rseau. Depuis BR-1 (10.1.5.101), faites un ping sur BR-2
(10.2.5.101) et rciproquement en fonction de votre Pod.

BR-1#ping 10.2.5.101
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.5.102, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms

-De mme vrifier que vous pouvez atteindre depuis vos deux routeurs, les Call Manager
10.x.1.1 :

BR-1#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms

BR-1#ping 10.2.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/34/52 ms

-Si tous les points prcdents ont t vrifis, nous allons pouvoir passer la mise en place
de la ToIP sur le PBX IP Call Manager.

8
II CONFIGURATION INITIALE DE CCM ET ACTIVATION DES
SERVICES
II.1 Accs la page web dadministration de Call Manager
Objectif : Apprendre accder au systme via un compte/mot de passe

-Vous allez configurer trois IP phones pour le PBX IP Call Manager. Pour accder la page
web, tapez sous internet explorer :

https://10.x.1.1/ccmadmin

-Rpondez par oui et entrez Username : ccmadministrator / Password : appuserpass

-Confirmer par Login Vous devriez tomber sur la page daccueil suivante :

9
-Vous tes donc sur un systme Call Manager 6.0.1 (on dit aussi CUCM 6.0.1 )

10
II.2 Changement du nom des serveurs par ladresse IP
Objectif : Eviter la rsolution DNS par les tlphones

-Aller dans System Server :

-Cliquer sur Find. Cliquer sur le premier serveur et changer le nom pour ladresse IP
10.x.1.1 comme indiqu :

-Cliquer Save. Ensuite, aller en haut droite et cliquer sur Go


-Renouveler lopration en cliquant sur le deuxime serveur. Mettre ladresse : 10.x.1.2
-A la fin, vous devriez avoir lcran ci-dessous :

11
II.3 Activation des services
Objectif : Activer les services ncessaires au fonctionnement du systme

-Aller en haut droite dans le panneau de navigation et choisir Cisco Unified Call
Manager Serviceability (ou par https://10.x.1.1/ccmservice/) :

-Puis cliquer sur Go :

12
-Aller dans Tools Service Activation

-Slectionner le serveur 10.x.1.1

-Vous devriez avoir lcran suivant o vous activerez les services comme indiqus :

13
-Terminer par Save et renouveler lopration pour le serveur 10.x.1.2. Notez que le service
Bulk nest pas disponible sur ce serveur.

Attention ! Il est possible quil soit impossible dactiver les services pour le Subscriber
cause dun problme de certificat expir. Voir avec le formateur qui devra mettre le
Publisher lheure et la bonne date puis redmarrer le subscriber par CLI ou /cmplatform

-Les tlphones IP devraient tous afficher Registration Rejected . Cela signifie


simplement que leurs adresses MAC nont pas t configures dans le systme.

14
II.4 Configuration des privilges daccs linterface dadministration
par MLA

Objectif : Crer deux utilisateurs ayant des privilges diffrents daccs Call
Manager

1) Crer deux utilisateurs

-Aller dans User Management End User

-Cliquer sur Add new puis entrez les champs :


User ID : jdupont
Password : cisco
PIN : 12345
Last Name : Dupont
First Name : Jacques

-Sauvegarder en haut gauche avec la disquette

-Cliquer sur le + pour ajouter un deuxime utilisateur : et entrer :


User ID : pdurand
Password : cisco
PIN : 12345
Last Name : Durand
First Name : Paul

-Aller en haut droite vers Back to Find List User et cliquer sur Go

-Vous devriez voir apparatre les deux utilisateurs jdupont et pdurand

15
2) Associer les utilisateurs des groupes de privilges
-Aller dans User Management User Group puis faire Find

-Vrifier en cliquant sur droite les rles de Standard CCM Super Users
-Vous pouvez observer les niveaux de privilges, appels Roles , de ce groupe.

-Revenir dans la prcdente liste de User Group puis cliquer directement sur Standard
CCM Super Users :

-Cliquer sur Add End User to Group

16
-Slectionner lutilisateur jdupont puis cliquer sur Add Selected

-Cliquer sur dans la colonne Permission Droite de lutilisateur Dupont, Jacques


pour observer que les accs sont en Read, Update

17
-Faire de mme avec lautre utilisateur Paul Durand mais en lassociant au groupe
Standard CCM Read Only group.

-Puis aprs avoir ajout cet utilisateur dans ce groupe, cliquer sur dans la colonne
Permission Droite de lutilisateur Durand, Paul. On peut surtout voir que les accs sont
en Read

4) Vrification
-Ouvrir une autre page Web sous Internet Explorer : https://10.1.1.1/ccmadmin
-Se logguer avec pdurand /cisco
-Aller dans User Management End User puis faire Find

Il ny a aucune possibilit dajouter un utilisateur

-Ouvrir encore une autre page Web sous Internet Explorer : https://10.1.1.1/ccmadmin
-Se logguer avec jdupont /cisco
-Aller dans User Management End User puis faire Find

18
Il y a la possibilit dajouter un utilisateur ou de le supprimer

19
II.5 Procdure de sauvegarde et de restauration par Disaster Recovery
Objectif : Sauvegarder le systme et le restaurer

1) Dmarrer le serveur SFTP sur le serveur Windows 10.x.1.4


-Ouvrir une session Terminal Server sur 10 x.1.4. Pour cela, il faut aller dans Start Run
(ou alors dans Dmarrer Excuter sur un Windows franais comme dans la capture
dcran ci-dessous) :

-Entrer : 10.x.1.4

-Entrer : administrator / cisco

20
-Dmarrer lexplorateur sur C :

-Vous devriez apercevoir msftpsrvr ci-dessus (Si ce nest pas le cas, demandez au
formateur de vous uploader le logiciel sur votre serveur 10.x.1.4)
-Crer un rpertoire c:\backup sur le serveur Unity.
-Double-cliquer puis entrer les valeurs qui suivent (User : user / Password : cisco) dans
linterface du serveur SFTP

-Ne pas oublier de faire Start pour dmarrer votre serveur !


-Notre serveur SFTP est maintenant prt recevoir la sauvegarde de CUCM

21
Remarque : Root Path doit tre un rpertoire qui existe sur votre serveur. Si vous
souhaitez mettre c:\backup par exemple, vous devez crer ce rpertoire dans votre partition
C :. Dans le cas contraire, il y a un message derreur lorsque vous configurerez le Network
Directory ltape suivante. Attention, il semble que choisir c:\ ne marche pas avec ce soft.

2) Sauvegarder CUCM en utilisant linterface graphique Disaster Recovery System


-Pour accder la page web, tapez sous internet explorer :

https://10.x.1.1/drf
-Entrer les mmes Username / Password que pour la page web cmplatform :
admin/adminpass

-Aller dans Backup Backup Device. Cliquer sur Add New


-Entrer les valeurs :

Backup device name : UNITYFTP


Serveur Name : 10.x.1.4
Path Name : /
Username : user
Password : cisco

22
-Aprs avoir cliqu sur Save

-Aller dans Backup Manual Backup :

-Cocher les CCM et CDR_CAR (CAR sert faire des rapports de tickets de taxation)
-Faire Start backup

-Pendant la sauvegarde, vous pouvez continuer utiliser le systme mais vous serez en
ReadOnly :

-La sauvegarde va prendre environ 20 minutes et vous serez tenus informs de ltat
davancement en permanence.

Remarque : il est tout fait possible dutiliser CCM pendant le backup mais il est impossible
dcrire, par exemple de crer un simple utilisateur :

23
24
-Lorsque tout sest bien pass, voici le rsultat :

Remarque : Le backup concerne tout le cluster (CUCMx-1 et CUCMx-2)

-Sur le serveur SFTP, lensemble des fichiers totalisent environ 200Mo

25
3) Restauration dune sauvegarde partir du serveur SFTP ( la fin du cours)

Remarque : Pour ce T.P, vous pouvez crer un utilisateur en allant dans User Management
End User puis restaurer pour vous apercevoir quil ne sera plus prsent lors de
redmarrage du serveur.
Demander au formateur ; il vous demandera sans doute de faire la restauration la fin du
cours car cette tape est trs longue et pas trs intressante.

-Aller dans Restore Restore Wizard :

-Il faut donc configurer le backup Device comme indiqu.


-Aller dans Backup Backup Device. Cliquer sur Add New

-Entrer les valeurs :


Backup device name : UNITYFTP
Serveur Name : 10.x.1.4
Path Name : /
Username : user
Password : cisco

Remarque : Assurer vous que le serveur SFTP est bien lanc sur 10.x.1.4

-Faire Save

-Choisissez le Backup File correspondant puis faire Next

-Cocher les deux CCM et CDR_CAR

- Terminer par Restore

26
III MISE EN PLACE DES TELEPHONES IP POUR CALL MANAGER
III.1 Dclaration manuelle dun tlphone IP

Objectif : Enregistrer 1 tlphone IP sous le PBX IP Call Manager et lui attribuer le


numro de tlphone x001

-Revenir dans la page web dadministration en tapant https://10.x.1.1/ccmadmin en se


loggant par ccmadministrator / appuserpass

-Nous allons montrer comment configurer un tlphone. Choisissez le tlphone de gauche


et reprer son type : 7960 ou 7961 puis allez dans le menu Device Phone.

-Cliquer sur Add New

-Puis choisir un tlphone dans la liste, par exemple le 7960:

-Cliquer sur Next

-Cliquer encore sur Next pour accepter SCCP (protocole de signalisation propritaire pour
les IP phones Cisco). Vous aurez 4 champs remplir :
MAC address : <celle de votre tlphone >
Description : Phone x-1 Device pool : Default
Phone Button Template : Standard 7960 SCCP
(1 page plus bas)
Device security profile : Cisco 7960 - Standard SCCP Non-Secure Profile

Remarque : pour voir ladresse MAC de votre tlphone, allez dans le bouton Settings
de votre tlphone ( cot du ? ). Puis choisissez Network Configuration sinon
retournez le tlphone o vous verrez un code barre avec ladresse MAC

-Voir la page suivante pour un exemple.

27
-Voici un exemple de ce que vous auriez pu entrer pour la configuration du tlphone :

-Plus bas dans la page:

-Noubliez pas de cliquer sur la petite disquette en haut gauche pour sauvegarder la
configuration que vous venez deffectuer.
-Confirmer par Ok sur la fentre de dialogue proposant Reset

-Votre tlphone devrait senregistrer dans les prochaines secondes mais il naura aucun
numro de tlphone.
-Nous allons maintenant configurer un numro de tlphone (appel dans Call Manager :
DN pour Directory Number )

28
-Cliquer sur Line [1] : Add a new DN en haut gauche

-Puis entrer dans le champ Directory Number : x001

-Sauvegarder en haut gauche avec la petite disquette.

-La configuration du tlphone est termine. Vous devez observer le numro de tlphone
ainsi que lheure et la date (qui peuvent ne pas tre correcte : cest celle du Call
Manager situ dans un pays tranger, lAngleterre en loccurrence!)

29
III.2 Dclaration des tlphones par linjection dun fichier CSV en
utilisant BAT

Objectif : Enregistrer 2 tlphones IP sous le PBX IP Call Manager et leur attribuer les
numros de tlphone x002 et x003

1) Cration dun Phone Template

-Depuis la page Web ccmadmin, aller dans Bulk Administration Phone Phone
Template :

-Aprs Add New, choisissez le type de tlphone que vous souhaitez injecter Cisco 7960
ou 7961:

-Cliquer sur Next puis entrer les champs comme ci-dessous :

-Noubliez pas plus bas dans cette page Web de spcifier le profile de scurit comme
indiqu dans la page suivante :

30
-Cliquer sur la disquette pour sauvegarder

-Cliquer sur Line [1] : Add a new DN

-Mettez une valeur fictive 9999 pour le DN qui sera de toute faon remplac dans le fichier
Excel puis cliquer sur la disquette pour sauvegarder

-En revenant sur notre Phone Template BAT-7960 :

31
-Il sagit donc dun ensemble de paramtres spcifiques un tlphone donn. Il faudra
donc crer autant de Phone Template quil y a de type de type de tlphones diffrents.

2) Cration du fichier Excel contenant les tlphones laide de la macro bat.xlt

-Aller dans Bulk Administration Upload/Download Files puis cliquer sur Find

-Cliquer sur Download Selected. Enregistrer le fichier sur votre bureau puis ouvrez-le en
activant la macro :

32
-Cliquer sur Create File Format :

-Dplacer les champs comme indiqu ci-dessous :

33
-Cliquer sur Create. Cela va modifier la page Excel avec les champs que vous avez
prciss dans la slection prcdente.

-Remplissez les champs de la feuille Excel avec les valeurs ci-dessous sachant que le
tlphone du milieu aura le numro x003 :

MAC address Description User ID DN 1 Display 1 Line text Label 1


@MAC tel. Milieu Phone x-3 pdurand x003 P.Durand Paul Durand

@MAC tel. Droite Phone x-2 jdupont x002 J.dupont Jacques Dupont

Remarque : attention respecter la casse pour le User ID : pdurand pas Pdurand!

-Voici un exemple de remplissage de la feuille Excel :

-Pour terminer la cration du fichier CSV, il ne vous reste plus qu aller droite de la feuille
Excel et cliquer sur Export to BAT Format

-Cliquer sur Browse et placer votre fichier appel ft sur votre bureau

-Renommer le fichier ft.txt en ft.csv de faon pouvoir louvrir directement par Excel :

34
3) Upload du fichier CSV ft

-Aller dans Bulk Administration Upload/Download Files puis cliquer sur Find

-Cliquer sur Add New

-Cliquer sur Browse (ou Parcourir) et trouver le fichier ft.csv. Ensuite prcisez comme ci-
dessous que vous souhaitez injecter des dtails spcifiques pour des tlphones :

-Terminer par Save


-En revenant dans Administration Upload/Download Files et en cliquant sur Find,
vous remarquerez la prsence du fichier ft.csv :

35
36
4) Validation du fichier CSV ft
-Aller dans Bulk Administration Phone Validate Phones.

-Slectionner les champs indiqus ci-dessous et terminer en cliquant sur Submit

-On peut remarquer que le Job va tre effectu Job request is submitted

-Aller dans Bulk Administration Job Scheduler puis cliquer sur le numro du Job Id :

-Vous pouvez observer que le fichier injecter ne contient aucune erreur avant linsertion
dans la base de Call Manager. Il y a aussi un fichier de log quil peut tre intressant de
consulter sil y a des erreurs :

37
5) Insertion du fichier CSV ft dans la base de Call Manager
-Aller dans Bulk Administration Phones Insert Phones
-Lobjectif est dassocier les dtails spcifiques que lon souhaite injecter (comme la Mac
Address) au Template BAT correspondant au type de tlphone. Ensuite on demandera
injecter tout de suite (Run Immediately).

Remarque : A ne surtout pas faire pendant les heures de production car le CPU monte
prs de 100% et compter environ 5s par enregistrement injecter !

-Entrer les champs comme suit. Terminer par Submit

38
-On peut nouveau voir lvolution de ce Job dans Bulk Administration Job
Scheduler mais on peut voir que lopration est plus longue

-Quand lopration est en Status Completed , cliquer sur le numro du Job ID :

-On peut remarquer ci-dessus quil ny a aucune erreur et que les deux enregistrements ont
t pris en compte

39
Vrification : Aller dans Device Phone puis cliquer sur Find pour voir si les tlphones
injects par BAT sont prsents :

-Dans le prochain TP, vous allez voir comment configurer les passerelles afin de mettre en
relation vos IP phones avec dautres tlphones connects dautres systmes.

40
IV MISE EN PLACE DES PASSERELLES VoIP
IV.1 Configuration de la passerelle BR-x en H323 pour les tlphones IP
Call Manager

Objectif : Mettre en relation les tlphones IP avec le RTC numrique (RNIS) via BR-x

-Nous allons mettre en place des dial-peer H323 pour atteindre les 2 Call Manager et un
dial-peer pots pour sortir sur le RTC. Tapez dabord conf t puis :

-Remplacer x par votre n pod ! ; vous pouvez aller sur http://rabdoul.free.fr FT_CCM2
Config TP pour rcuprer le fichier configH323-BRx.txt et linjecter dans votre routeur
BR-x :

network-clock-participate wic 3
isdn switch-type primary-net5

controller E1 0/3/0
pri-group timeslots 1-3,16
!
dial-peer voice x000 voip
incoming called-number .
destination-pattern x...
session target ipv4:10.x.1.1

dial-peer voice x001 voip


incoming called-number .
destination-pattern x...
session target ipv4:10.x.1.2
preference 1

dial-peer voice 9999 pots


destination-pattern .T
port 0/3/0:15
direct-inward-dial

voice translation-rule 1
rule 1 /.*3\(...\)/ /x\1/
voice translation-profile pstn-in
translate called 1

voice-port 0/3/0:15
translation-profile incoming pstn-in

-Nous allons maintenant voir comment configurer Call Manager pour atteindre le RTC via la
passerelle BR

-Tapez sous internet explorer : https://10.x.1.1/ccmadmin et entrez Username :


ccmadministrator / Password : appuserpass

-Aller dans le menu Device Gateway puis cliquer sur Add New. Choisir tout en bas
Gateway Type : H.323 Gateway. Puis cliquer sur Next

41
-Entrer les valeurs suivantes :
Device Name : 10.1.4.102 (ou 10.2.4.102 si Pod2)
Description : RTC RNIS BR-1 H323
Device Pool : Default

-Cliquer sur Ok et noubliez pas de faire Reset


Vrification : Sur BR-x, tapez csim start x001. Le tlphone x001 devrait sonner.

BR-1#csim start 1001

ou

BR-2#csim start 2001

A partir du tlphone PSTN Pod1, composer le numro 0130381003 et vrifier quil sonne
A partir du tlphone PSTN Pod2, composer le numro 0130392003 et vrifier quil sonne

42
IV.2 Configuration de la passerelle HQ-x en MGCP pour les tlphones
IP Call Manager
Objectif : Mettre en relation les tlphones IP avec le RTC numrique (RNIS) via HQ-x

Pr-requis : connaitre les type dinterface voix que lon va configurer en MGCP : tapez
HQ-x# show inventory

-Tapez sous internet explorer : https://10.x.1.1/ccmadmin et entrer le username et le


mot de passe si besoin. Puis aller dans le menu Device Gateway. Cliquer sur Add New

-Choisir Gateway Type : Cisco 2811 puis Next


-Slectionner Protocol : MGCP puis Next

-Entrer les valeurs suivantes :


Domain name : HQ-x
Description : RTC RNIS E1
Cisco Unified CallManager Group : Default
Module in slot 0 : NM-4VWIC-MBRD
Global ISDN Switch Type : EURO

Remarque : Le Domain Name doit correspondre exactement au Hostname du routeur

43
-Cliquer sur Save

44
-Choisissez pour Subunit 1 : VWIC-1MFT-E1. (si cela est bien le type identifi par la
commande show inventory prcdente). Puis faire Save

-Dans lcran qui suit, cliquer sur 0/1/0

-Entrer les champs suivants :

45
Device pool : Default

-Faire Save pour finir.

-Nous pouvons constater que le port est en Registration Unknown car rien na t fait
sous la passerelle HQ-x.

Configuration de HQ-x pour supporter MGCP :

network-clock-participate wic 1
ccm-manager config server 10.x.1.1
ccm-manager config

-Il apparat ensuite de nombreux messages qui montrent quun fichier xml provenant de Call
Manager a t tlcharg et va configurer la passerelle HQ :

46
HQ-1(config)#
Loading HQ-1.cnf.xml from 10.1.1.1 (via FastEthernet0/0.101): !
[OK - 14594 bytes]

This package type is not the default package type.

*May 29 19:44:32.509: %CONTROLLER-5-UPDOWN: Controller E1 0/1/0, changed state t


to administratively down
echo-cancel coverage 8
^
% Invalid input detected at '^' marker.

*May 29 19:44:37.665: voice_port is not initialized


*May 29 19:44:38.593: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/
0:0, changed state to down

(grosse partie des messages supprime).

*May 29 19:44:38.597: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/


0:8, changed state to down
*May 29 19:44:38.601: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/
0:9, changed state to down
The MGCP process is currently active.
It must be disabled with 'no mgcp' before restarting.

Configuration done!!!

Building configuration...
[OK]
Building configuration...

*May 29 19:44:41.673: %LINK-3-UPDOWN: Interface 0/1/0:15(1), changed state to up


*May 29 19:44:41.673: %LINK-3-UPDOWN: Interface 0/1/0:15(2), changed state to up
*May 29 19:44:41.673: %LINK-3-UPDOWN: Interface 0/1/0:15(3),

(grosse partie des messages supprims).

*May 29 19:44:41.677: %LINK-3-UPDOWN: Interface 0/1/0:15(31), changed state to up


*May 29 19:44:45.077: %CONTROLLER-5-UPDOWN: Controller E1 0/1/0, changed state
to up
*May 29 19:44:47.077: %LINK-3-UPDOWN: Interface Serial0/1/0:15, changed state to
up
Loading HQ-1.cnf.xml from 10.1.1.1 (via FastEthernet0/0.101): !
[OK - 14594 bytes]

-Voici les commandes qui ont t ajoutes par le fichier xml. Un show run peut permettre
de les voir :

controller E1 0/1/0
pri-group timeslots 1-31 service mgcp

interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable ccm-manager redundant-host 10.1.1.1

47
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.1.1.1
ccm-manager config
!
mgcp
mgcp call-agent 10.1.1.2 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
!
mgcp profile default

-Vrifier maintenant que le port E1 PRI est enregistr en appuyant sur F5 pour rafrachir
lcran :

48
Vrification :
-Vrifier que la commande show isdn status prcise multiple_frame_established :

HQ-1#show isdn status


Global ISDN Switchtype = primary-net5

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not
apply

ISDN Serial0/1/0:15 interface


dsl 0, interface ISDN Switchtype = primary-net5
L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 0 CCBs = 0
The Free Channel Mask: 0xFFFF7FFF
Number of L2 Discards = 0, L2 Session ID = 9
Total Allocated ISDN CCBs = 0

-Vrifier que la commande show ccm-manager prcise Registered :


HQ-1#show ccm-manager
MGCP Domain Name: HQ-1
Priority Status Host
============================================================
Primary Registered 10.1.1.1
First Backup Backup Ready 10.1.1.2
Second Backup None

Current active Call Manager: 10.1.1.1


Backhaul/Redundant link port: 2428
Failover Interval: 30 seconds
Keepalive Interval: 15 seconds
Last keepalive sent: 10:52:42 UTC Jun 3 2008 (elapsed time: 00:00:14)
Last MGCP traffic time: 10:52:42 UTC Jun 3 2008 (elapsed time: 00:00:14)
Last failover time: 06:37:57 UTC Jun 3 2008 from (10.1.1.1)
Last switchback time: 06:38:42 UTC Jun 3 2008 from (10.1.1.2)
Switchback mode: Graceful
MGCP Fallback mode: Not Selected
Last MGCP Fallback start time: None
Last MGCP Fallback end time: None
MGCP Download Tones: Disabled

Backhaul Link info:


Link Protocol: TCP
Remote Port Number: 2428
Remote IP Address: 10.1.1.1
Current Link State: OPEN
Statistics:
Packets recvd: 3
Recv failures: 0
Packets xmitted: 3
Xmit failures: 0
PRI Ports being backhauled:
Slot 0, VIC 1, port 0
Configuration Auto-Download Information
=======================================

49
Current version-id: 1212414288-0e79ebdb-5ca0-48f8-bd51-977aa961d8f1
Last config-downloaded:00:00:00
Current state: Waiting for commands
Configuration Download statistics:
Download Attempted :7
Download Successful :7
Download Failed :0
Configuration Attempted :1
Configuration Successful : 1
Configuration Failed(Parsing): 0
Configuration Failed(config) : 0
Last config download command: New Registration
FAX mode: cisco
Configuration Error History:
voice-port 0/1/0:15
echo-cancel coverage 8
end

50
V MISE EN UVRE DUN PLAN DE NUMEROTATION
V.1 Route Patterns pour atteindre le RTC RNIS via H323 sur BR-x ou par
MGCP sur HQ-x
Objectif : Les tlphones IP contactent le RTC en composant par exemple
00155940001#

-Nous allons tout dabord crer deux Route Group dans lequel nous allons placer la
passerelle H323 dune part et la passerelle MGCP dautre part :
-Aller dans Call Routing Route/Hunt Route Group

-Aprs avoir cliqu sur Add New, remplissez les champs suivants :
Route Group Name : RG_RTC_HQ
Distribution Algorithm : Top Down

-Puis slectionner la passerelle HQ S0/SU1/DS1-0@HQ-x et cliquer sur Add to Route


Group pour la placer dans la fentre Selected Devices :

51
-Terminer par Save

-Aller sur le + pour faire un Add New

-De la mme faon que prcdemment, entrer les champs comme ci-dessous. Cette fois-ci
le Route Group sappelle : RG_RTC_BR et va contenir la passerelle H323 : 10.x.4.102 :
Route Group Name : RG_RTC_BR
Distribution Algorithm : Top Down

52
-Vrification de la cration des 2 Route Groups. Aller en haut droite et cliquer sur Go

-Voici ce que vous devez obtenir :

53
-Cration des Route List contenant les deux Route Groups. Allez dans Call Routing
Route/Hunt Route List

-Aprs avoir cliqu sur Add New , remplissez les champs comme suit :

-Aprs avoir cliqu sur Save, vous devez avoir lcran ci-dessous :

-Cliquer sur Add Route Group

54
-Entrer les champs comme indiqu ci-dessous :

(Attention pour le Pod2, Calling Party Transform Mask : 0178162XXX)

-Faire un Save pour terminer lenregistrement de ce Route Group dans le Route List

-Faire nouveau Add Route Group

55
-Entrer les champs comme ci-dessous :

(Noubliez pas pour le Pod2, Calling Party Transform Mask : 0178162XXX)

-Terminer par Save

56
-Faire Reset en haut gauche :

-Confirmer nouveau par Reset

-Aller en haut droite pour faire Back to Find/list puis cliquer sur Go. Vous devriez voir
votre Route List dans ltat Registered

-Procder de la mme faon pour crer un autre Route List : RL_RTC_BR_HQ qui va
contenir dabord le Route Group RG_RTC_BR puis ensuite le Route Group RG_RTC_HQ.

-Lobjectif de ce deuxime Route List sera de faire de la discrimination de routage dappel.


Cela fera lobjet du prochain T.P.

57
-Sauvegarder en rpondant Ok dans les botes de dialogue qui suivent. Pour terminer faire
en haut gauche Back to find/list . Voici ce que vous devriez avoir :

-Pour les deux routes groupes, il faudra modifier les Calling Party Transformation Mask de
la manire suivante :

(Noubliez pas pour le Pod2, Calling Party Transform Mask : 0130393XXX)

58
(Noubliez pas pour le Pod2, Calling Party Transform Mask : 0130393XXX)

-Vrifier bien que le status apparat comme registered . Sinon refaire un Reset du
Route List.

59
V.2 Discrimination du routage dappel via les Calling Search
Space/Partition

Objectif : Les tlphones HQ doivent passer dabord par HQ-x et le tlphone BR doit
passer prfrentiellement par BR-x pour aller sur le RTC

-Commenons par crer deux partitions. Aller dans Call routing Class Of Control
Partition :

-Cliquer sur Add New puis entrer les partitions et leur description comme indiqus plus bas.

-Faire Save pour terminer.

Remarque : il a t choisi PT_CERGY_INTERNE et PT_RUEIL_INTERNE pour lexemple.


Le stagiaire pourra choisir toute autre ville de son choix. Dans notre exemple nous
considrerons que HQ=Rueil et BR=Cergy.

60
-Nous allons crer deux Calling Search Space (CSS). Aller dans Call routing Class Of
Control Calling Search Space :

-Aprs avoir cliqu sur Add New , entrer le CSS comme ci-dessous, en mettant les
partitions dans lordre indiqu :

-Aprs Save , faire Copy en bas gauche pour crer un 2me CSS comme suit :

61
-En faisant Back to find/list , on doit avoir :

-Nous allons maintenant affecter les partitions prcdemment cres au Route Pattern.
-Aller dans Call Routing Route Pattern.

-Cliquer sur le Route Pattern : 0.!# et y associer le Route Partition PT_RUEIL_INTERNE


comme suit :

62
-Faire Save et accepter tout ce qui suit. Ensuite aller dans licne Copy et cliquer dessus.
-Modifier le Route Partition en PT_RUEIL_INTERNE et Gateway/route list en
RL_RTC_HQ_BR puis sauvegarder :

-Aprs Back to find/list , vous devriez finalement avoir :

63
-Pour associer le SDA du site au numro interne des tlphones, nous allons mettre en
place le Translation Pattern suivant (pour le Pod1)

(Noubliez pas pour le Pod2, Le Translation Pattern sera 178162XXX et le Called Party
Transform Mask : 2XXX)

64
-La discrimination au niveau des routes est faite, passons maintenant celle des
tlphones. Nous allons associer un CSS au niveau de chaque Directory Number x001,
x002 et x003.

-Prenons lexemple pour x001. Allez dans Call Routing Directory Number.

-Cliquer sur Find

-Cliquer sur x001 et modifier le CSS en CSS_TEL_HQ puis Save

65
-Renouveler lopration pour x002 en mettant CSS_TEL_HQ et x003 en mettant
CSS_TEL_BR

Vrification :

-Appeler depuis un tlphone HQ (ex : x001) ou BR (x003) vers le RTC


(ex :0.0155940001#). En faisant un debug isdn q931 sur HQ-x, vous devriez voir des
messages RNIS apparatre.

-A partir du tlphone PSTN Pod1, composer le numro 0178151001. Il devrait sonner

-A partir du tlphone PSTN Pod2, composer le numro 0178162001. Il devrait sonner

66
VI. MISE EN UVRE DES FONCTIONNALITES DES PASSERELLES
VI.1 Configuration des Region pour passer en codec bas dbit entre
les tlphones HQ et le tlphone BR

Objectif : Vrifier que la confrence par dfaut fonctionne entre les 3 IP phones puis
utiliser le codec G729 entre HQ et BR et conserver le codec G711 entre les tlphones
HQ. Vrifier que la confrence ne marche plus dans ce cas

0) Configuration pralable
-Crer le Device Pool DP_RUEIL. Aller dans System Device Pool. Cliquer sur Default et
faire une copie. Renommer Default en DP_RUEIL puis terminer par Save
-Aller dans Media Resources Conference Bridge puis cliquer sur Find

-Modifier le Device Pool pour CFB_2 :

-Mettre DP_RUEIL la place de Default puis cliquer sur Save


-Faire de mme pour CFB_3

67
-Faire de mme pour les serveurs de MOH
-Aller dans Media Resources Music On Hold Server puis cliquer sur Find

-Modifier le Device Pool pour MOH_2 :

-Mettre DP_RUEIL la place de Default puis cliquer sur Save


-Faire de mme pour MOH_3

68
-Aller dans System Service Parameters puis slectionner 10.x.1.1 et le service Cisco IP
Voice Media Streaming App

-Cliquer dans le champ 729 Annex A en appuyant sur la touche Ctrl de votre clavier pour
slectionner 729 tout en conservant le 711 puis sauvegarder.
-Lobjectif est de pouvoir envoyer de la MOH vers un tlphone en G711 ou en G729

Faire une confrence Ad Hoc

-Dcrocher x001
-Appeler x002
-Depuis x001, utiliser le Softkey More
-Appuyer sur Confrn
-Composer le numro x003
-Dcrocher x003
-Depuis x001, appuyer nouveau sur Confrn
-Vous devez voir apparatre To Conference car les 3 tlphones sont en
G711 et donc le Call Manager peut grer cette confrence.

Mettre en attente

-Dcrocher x001
-Appeler x002
-Appuyer sur le Softkey Hold de votre tlphone et vrifier quon entend la
musique dattente
-Renouveler lopration entre x001 et x003

69
1) Crer une Region, lassocier un Device Pool et associer le Device Pool au tlphone

-Aller dans System Region puis cliquer Add New. Entrer RUEIL :

-Cliquer sur Add New en bas gauche et ajouter CERGY. Faire Save

-Dans le champ Regions bas gauche, cliquer dabord sur RUEIL puis cliquer dans :
Audio Codec, choisissez : G.729

70
-Terminer en cliquant sur Save

-Aller dans System Device Pool. Cliquer sur Find puis sur DP_RUEIL et entrer les
champs ci-dessous

71
-Faire Save puis choisissez de faire Copy avec licne de copie en haut gauche et
modifier les champs comme suit :

-Aprs avoir sauvegard et fait Back to find/list , vous devriez avoir :

-Nous allons maintenant associer les DP crs prcdemment aux diffrents tlphones.
Nous associerons le DP_RUEIL x001 et x002 et bien sr le DP_CERGY x003. Voici un
exemple avec x001 :

72
-Aller dans Device Phone puis Find et cliquer sur le tlphone de votre choix :

-Modifier le DP comme indiqu :

-Faire le Save et le Reset demand, puis renouveler lopration pour les deux autres
tlphones de la mme faon.
Vrification : Quand vous avez termin, faites Device Phone puis Find pour vrifier
laffectation correcte de vos Device Pool

73
-Vrifier le codec G729 en appelant entre x001 et x003 et en appuyant deux fois de suite
durant lappel sur ? . Par contre, lappel doit rester en G711 entre x001 et x002.

-Refaire une confrence entre les 3 tlphones. Vous devriez avoir entendre une srie de
bip indiquant que a ne marche pas (Fast Busy Tone).

74
VI.2 Cration des Media Resources sur BR-x pour le service de
confrence Hardware
Objectif : Utiliser les DSP du routeur BR comme pont de confrence multi-codec

Pralable : on peut voir les ressources DSP disponibles sur BR-x par la commande qui suit
BR-1#show inventory
NAME: "2811 chassis", DESCR: "2811 chassis"
PID: CISCO2811 , VID: V01 , SN: FCZ0926734P

NAME: "WAN Interface Card - Serial 2A/S on Slot 0 SubSlot 0", DESCR: "WAN
Interface Card - Serial 2A/S"
PID: WIC-2A/S= , VID: 1.0, SN: 32093245

NAME: "2nd generation two port FXO voice interface daughtercard on Slot 0
SubSlot 1", DESCR: "2nd generation two port FXO voice interface daughtercard"
PID: VIC2-2FXO , VID: V01 , SN: FOC11063P84

NAME: "One port E1 voice interface daughtercard on Slot 0 SubSlot 3", DESCR:
"One port E1 voice interface daughtercard"
PID: VWIC-1MFT-E1 , VID: V02, SN: 36225646

NAME: "PVDMII DSP SIMM with Two DSPs on Slot 0 SubSlot 4", DESCR:
"PVDMII DSP SIMM with Two DSPs"
PID: PVDM2-32 , VID: V01 , SN: FOC11111BN6

NAME: "PVDMII DSP SIMM with one DSP with half channel capcity on Slot 0
SubSlot5", DESCR: "PVDMII DSP SIMM with one DSP with half channel capcity"
PID: PVDM2-8 , VID: V01 , SN: FOC12243Q6Z

-Vrifions ltat des DSP avant la configuration:


BR-1#sh dspfarm dsp all

Total number of DSPFARM DSP channel(s) 0

-Mettez en place la configuration suivante (ou allez rcuprer la configuration pour votre
routeur BR sur http://rabdoul.free.fr FT_CCM2 Config TP configCFB-XCODE-
BRx.txt)

Remarque : ci-dessous, remplacer x par votre n de Pod

voice-card 0
dspfarm
dsp services dspfarm

sccp local FastEthernet0/0.x05


sccp ccm 10.x.1.2 identifier 2 version 5.0.1
sccp ccm 10.x.1.1 identifier 1 version 5.0.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate ccm 2 priority 2
bind interface FastEthernet0/0.x01
associate profile 3 register CFB_BR

!
dspfarm profile 3 conference
codec g711ulaw
codec g711alaw
codec g729ar8

75
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 1
associate application SCCP
No shutdown

-Vrifions nouveau ltat des DSP :


BR-1#sh dspfarm all
Dspfarm Profile Configuration

Profile ID = 3, Service = CONFERENCING, Resource ID = 1


Profile Description :
Profile Admin State : UP
Profile Operation State : ACTIVE IN PROGRESS
Application : SCCP Status : ASSOCIATION IN PROGRESS
Resource Provider : FLEX_DSPRM Status : UP
Number of Resource Configured : 1
Number of Resource Available : 1
Codec Configuration
Codec : g711ulaw, Maximum Packetization Period : 30 , Transcoder: Not
Required
Codec : g711alaw, Maximum Packetization Period : 30 , Transcoder: Not
Required
Codec : g729ar8, Maximum Packetization Period : 60 , Transcoder: Not Required
Codec : g729abr8, Maximum Packetization Period : 60 , Transcoder: Not
Required
Codec : g729r8, Maximum Packetization Period : 60 , Transcoder: Not Required
Codec : g729br8, Maximum Packetization Period : 60 , Transcoder: Not Required

SLOT DSP VERSION STATUS CHNL USE TYPE RSC_ID BRIDGE_ID


PKTS_TXED PKTS_RXED

0 6 1.1.1 UP N/A FREE conf 1 - - -

Total number of DSPFARM DSP channel(s) 1

76
VI.3 Utilisation des media resource de BR-x par Call Manager
Objectif : Configurer les ressources cres sur BR-x sur Call Manager pour tre
utilisable par les tlphones IP

Attention! Avant la mise en place de ressources DSP, il faut vrifier que vous ayez les
PVDMs suffisantes. Pour cela, il faut aller dans la DSP Calculator situs lURL :
http://www.cisco.com/pcgi-bin/Support/DSP/cisco_prodsel.pl

-Dans Call Manager, aller dans Media Resources Conference Bridge

-Cliquer sur Add New , Slectionner Cisco IOS Enhanced Conference Bridge et entrer les
champs comme suit :

-Cliquer sur Save, puis Reset. Vrifier que ltat est Registered . Faire ventuellement
un rafrachissement de la page web par F5 car il peut apparatre Rejected

77
-Aprs Back to find/list:

78
-Vrifions que le CFB communique bien en SCCP :

BR-1#sh sccp
SCCP Admin State: UP
Gateway IP Address: 10.1.1.101, Port Number: 2000
IP Precedence: 5
User Masked Codec list: None
Call Manager: 10.1.1.2, Port Number: 2000
Priority: N/A, Version: 5.0.1, Identifier: 2
Call Manager: 10.1.1.1, Port Number: 2000
Priority: N/A, Version: 5.0.1, Identifier: 1

Conferencing Oper State: ACTIVE - Cause Code: NONE


Active Call Manager: 10.1.1.1, Port Number: 2000
TCP Link Status: CONNECTED, Profile Identifier: 3
Reported Max Streams: 8, Reported Max OOS Streams: 0
Supported Codec: g711ulaw, Maximum Packetization Period: 30
Supported Codec: g711alaw, Maximum Packetization Period: 30
Supported Codec: g729ar8, Maximum Packetization Period: 60
Supported Codec: g729abr8, Maximum Packetization Period: 60
Supported Codec: g729r8, Maximum Packetization Period: 60
Supported Codec: g729br8, Maximum Packetization Period: 60
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

BR-1#sh dspfarm all


Dspfarm Profile Configuration

Profile ID = 3, Service = CONFERENCING, Resource ID = 1


Profile Description :
Profile Admin State : UP
Profile Operation State : ACTIVE
Application : SCCP Status : ASSOCIATED
Resource Provider : FLEX_DSPRM Status : UP
Number of Resource Configured : 1
Number of Resource Available : 1
Codec Configuration
Codec : g711ulaw, Maximum Packetization Period : 30 , Transcoder: Not Required
Codec : g711alaw, Maximum Packetization Period : 30 , Transcoder: Not Required
Codec : g729ar8, Maximum Packetization Period : 60 , Transcoder: Not Required
Codec : g729abr8, Maximum Packetization Period : 60 , Transcoder: Not Required
Codec : g729r8, Maximum Packetization Period : 60 , Transcoder: Not Required
Codec : g729br8, Maximum Packetization Period : 60 , Transcoder: Not Required

SLOT DSP VERSION STATUS CHNL USE TYPE RSC_ID BRIDGE_ID


PKTS_TXED PKTS_RXED

0 6 1.1.1 UP N/A FREE conf 1 - - -

Total number of DSPFARM DSP channel(s) 1

79
VI.4 Association dun MRGL pour associer la ressource CFB cre aux
tlphones BR
Objectif : Permettre aux tlphones dutiliser dabord la confrence hardware
CFB_BR ; la confrence Software par Call Manager tant utilise par dfaut en
premier, avant la confrence Hardware

-Par dfaut, on utilise la confrence Software avant la confrence Hardware. Nous allons
donc mettre en uvre la ressource CFB, lassocier un Media Resource Group (MRG),
associ lui-mme un Media Resource Group List (MRGL), associ au DP des tlphones
BR, soit :

Resource : CFB_BR

Media Resource Group : MRG_BR

Media Resource Group List : MRGL_BR

Device Pool : DP_CERGY

-La ressource tant cre, passons la cration du MRG_BR. Aller dans Media Resource
Media Resource Group :

-Aprs Add New, veuillez entrer les champs comme suit puis terminer par Save

80
-Vous noterez que lon na pas plac volontairement les ressources CFB_2 et CFB_3. En
effet, si on les avait places avec CFB_BR, elles seraient devenues prioritaires car elles
apparatraient les premires. Il nest pas possible de mettre CFB_BR en premier devant les
CFB_2 et CFB_3 car lordre conserv est lordre alphabtique.

-Aller dans Media Resource Media Resource Group List puis cliquer sur Add New.
Placer MRG_HQ dans Selected Media Resource Groups . Faire Save

-Aller dans System Device Pool puis Find

-Cliquer sur DP_CERGY :

81
-Terminer par Save et faire Reset toutes les fois demandes :

-Le tlphone BR devrait avoir redmarr. Refaites nouveau une confrence comme
prcdemment en initiant la confrence depuis x003 (Tel. BR), vrifier que la confrence est
maintenant fonctionnelle entre les 3 tlphones et constater lutilisation des DSP pour la
confrence :

BR-1#sh dspfarm all


Dspfarm Profile Configuration

Profile ID = 3, Service = CONFERENCING, Resource ID = 1


Profile Description :
Profile Admin State : UP
Profile Operation State : ACTIVE
Application : SCCP Status : ASSOCIATED
Resource Provider : FLEX_DSPRM Status : UP
Number of Resource Configured : 1
Number of Resource Available : 1
Codec Configuration
Codec : g711ulaw, Maximum Packetization Period : 30 , Transcoder: Not
Required
Codec : g711alaw, Maximum Packetization Period : 30 , Transcoder: Not
Required
Codec : g729ar8, Maximum Packetization Period : 60 , Transcoder: Not Required
Codec : g729abr8, Maximum Packetization Period : 60 , Transcoder: Not
Required
Codec : g729r8, Maximum Packetization Period : 60 , Transcoder: Not Required
Codec : g729br8, Maximum Packetization Period : 60 , Transcoder: Not Required

82
SLOT DSP VERSION STATUS CHNL USE TYPE RSC_ID BRIDGE_ID
PKTS_TXED PKTS_RXED

0 6 1.1.1 UP 1 USED conf 1 1 4707 8418


0 6 1.1.1 UP 1 USED conf 1 2 8513 8421
0 6 1.1.1 UP 1 USED conf 1 3 8511 8389

Total number of DSPFARM DSP channel(s) 1

Vrification : Vous pouvez aussi vrifier le codec en pressant deux fois sur la touche ?
pour vrifier que les codecs sont G711 pour le tlphone BR et G729 pour les tlphones
HQ.

83
VII - IMPLEMENTATION DU DEPLOIEMENT MULTI-SITE

VII.1 Limitation dappel par le paramtre Location


Objectif : Limiter le nombre dappel 1 entre HQ et BR

-Aller dans System Location

-Puis aprs Add New , entrer les valeurs comme indiques ci-dessous :
*Name : LOC_CERGY
*Audio Bandwidth : 24Kbps

84
-Aprs avoir sauvegard, aller dans Device Phone :

-Aprs avoir fait Find, cliquer sur le tlphone BR Phone x-3 et modifier le paramtre
Location : LOC_CERGY comme indiqu ci-dessous :

85
-Faire Save et Reset. Aprs le Reboot du tlphone, nous allons pouvoir tester la limitation
dappel.

Vrification : Appeler x003 depuis x001 et sans raccrocher le premier appel, essayer
dappeler depuis x002 vers x003Vous devriez avoir le message sur lcran : Not
enough bandwith

Question : Comment feriez-vous pour limiter le nombre dappel 3 ?

86
VII.2 Mise en place de SRST sur BR

Objectif : Conserver laccs RTC sur BR mme quand le WAN est down

-Vrifier que la rfrence SRST est en place. Dans un prcdent T.P, nous avions prcis
SRST Reference : Use Default Gateway . Vrifions-le de deux faons diffrentes :

1) Appuyer sur le bouton Settings de votre tlphone, choisir loption 3 : Network


Configuration, puis loption 22. Vous devez constater le champ : Call Manager 2 SRST
=10.x.5.101. Sur le 7961, la procdure est lgrement diffrente, demander au
formateur si besoin.
2) Aller dans System Device Pool Find . Cliquer sur DP_CERGY. Vrifier la
SRST Reference :

-Il faut maintenant mettre SRST en place sur le routeur BR. Tapez conf t :

Config BR :
call-manager-fallback
ip source-address 10.x.5.101
max-ephones 1
max-dn 1

Vrification : Faire un Shutdown de linterface s0/0/0 du routeur BR

BR-1(config)#int s0/0/0
BR-1(config-if)#shutdown
BR-1(config-if)#
*Jun 26 15:28:36.027: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor
10.1.4.101 (Serial0/0/1) is down: interface down
BR-1(config-if)#
*Jun 26 15:28:38.019: %LINK-5-CHANGED: Interface Serial0/0/1, changed state to
administratively down
*Jun 26 15:28:39.019: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0/1, changed state to down

*Jun 26 15:28:44.175: %IPPHONE-6-REG_ALARM: 15: Name=SEP00156387A815


Load=8.0(3.0) Last=CM-ICMP-Unreach
*Jun 26 15:28:44.175: %IPPHONE-6-REGISTER_NEW: ephone
1:SEP00156387A815 IP:10.1.5.1 Socket:1 DeviceType:Phone has registered.

-Comme on peut le voir le tlphone sest r-enregistr sur le routeur BR. On peut aussi
remarquer sur lcran du tlphone CM Fallback Service

87
VIII CONFIGURATION DES FONCTIONNALITES AVANCEES DU
CUCM
VIII.1 Mise en place de Extension Mobility
Objectif : Permettre de se logguer sur un tlphone IP

1) Crer un utilisateur
-Aller dans User Management End User :

-Aprs Add New, entrer les champs comme ci-dessous :


*User ID :mperry
*Password :cisco
*PIN :12345
*Last Name : Perry
*First Name : Mark

-Terminer par Save

2) Crer un service Web XML Extension Mobility

88
-Aller dans System Enterprise Parameters :

-Modifier en bas de la page web, toutes les chanes de caractres Nodex par
10.x.1.1 comme indiqu ci-dessous :

-Faire Save. Reset de tous les tlphones par **#**. Vrifier que vous accder bien une
page de service en pressant sur le bouton service (mappemonde sur le tlphone) :

SERVICE
To set up speed dials and other service for your phone, please go to
https://10.1.1.1:8443/ccmuser/showHome.do

-Aller dans Device Device Settings Phone Services

89
-Faire Add New et entrer les champs comme ci dessous en prcisant pour Service URL*
la valeur suivante :
http://10.x.1.1:8080/emapp/EMAppServlet?device=#DEVICENAME#

-Faire Save

90
-Tester lURL avec Internet Explorer pour voir si elle est correcte :

Si URL incorrecte

Si URL correcte

91
3) Paramtrage du service Extension Mobility
-Aller dans System Service Parameters :

-Choisir le serveur 10.x.1.1 et le service Cisco Extension Mobility

-Entrer les mmes paramtres que ci-dessus puis faire Save

4) Crer un Device Profile Default pour identifier le type de tlphone


-Aller dans Device Device Settings Default Device Profile :

92
-Choisissez le type de tlphone correspondant au phone x-1 (x001)

-Faire Next
-Entrer les champs comme indiqus ci-dessous :

-Faire Save

93
5) Crer le Device Profile (Profile itinrant) pour lutilisateur

-Aller dans Device Device Settings Device Profile :

-Faire Add New puis choisissez le type de tlphone correspondant au phone x-1 (x001) :

-Aprs Next, entrer les champs suivants (ne pas oublier le login id : mperry au bas de la
page !)

94
-Faire Save.

95
-Vous devez abonner le Device Profile prcdent au service Extension Mobility
-Aller en haut droite et slectionner Subscribe/Unsubscribe Services

-Slectionner le service Extension Mobility. Puis Next

96
-Continuer par Subscribe et Save :

-Fermer cette fentre et revenir sur le Device Profile EM_mperry :

97
-Cliquer sur Line [1] Add a new DN en haut gauche. Entrer le Directory Number : x555

-Terminer par Save

6) Associer lutilisateur au Device Profile


-Aller dans User Management End User puis faire Find

98
-Cliquer sur mperry puis au milieu de la page ci-dessous, dplacer le profile EM_mperry de
Available Profile dans Controlled Profile comme cela a t fait :

-Terminer par Save

7) Abonner le tlphone x001 au service Extension Mobility

-Aller dans Device Phone puis Find et cliquer sur le tlphone x001
-Aller vers le milieu de la page web du tlphone et permettre au tlphone de faire de
lExtension Mobility en cochant Enable Extension Mobility et Use Current Device
settings

-Faire Save

99
-Aller dans Subscribe/Unsubscribe puis Go

-Slectionner le service Extension Mobility puis Next, Subscribe et Save pour finir.
-La configuration de lextension Mobility est termine.

Vrification : Aller sur le tlphone x001, sur le bouton service ( mappemonde ). Vous
devez voir apparatre :

SERVICES
1 Extension Mobility

-Appuyer sur le softkey select :

Please Sign On
UserID : mperry
PIN : 12345

-Terminer par Submit . En quelques secondes le tlphone devrait avoir bascul sur un
DN gal x555.

100
Pour se d-logger, r-appuyer sur le bouton service et lancer le service Extension Mobility.

SERVICES
Logout mperry ?

-Rpondre par Yes. Vous tes nouveau avec le profil par dfaut DN :x001

Troubleshooting
-Il y aura sans doute un problme sur notre plateforme en se logguant avec mperry la
premire fois. Il se peut que le tlphone charge le profil, fasse un reset et reste dans ltat
registering (sur un 7960) ou alors il peut rester dans ltat prcdent (sur un 7961) .
Dans ce cas, redmarrer le service Call Manager.
-Nanmoins, le tlphone restera dans ltat registering et on ne pourra pas le
dbloquer. Voir avec le formateur comment faire un reset default factory sur votre
tlphone. Aprs la rinitialisation, vous devriez pouvoir vous logguer sans problme.

101
VIII.2 Mise en place de lAttendant console
Objectif : Configurer la console de la standardiste

1) Ajouter un utilisateur Attendant console

-Aller dans Application Cisco Unified CM Attendant Console Cisco Unified CM


Attendant Console User

-Faire Add New et ajouter user : jjones / password : cisco puis faire Save

2) Configurer le Pilot Point


-Aller dans Application Cisco Unified CM Attendant Console User Pilot Point

-Faire Add New et remplir les champs comme suit :

102
-Cliquer sur Line [1] Add a new DN en haut gauche

-Mettre le Directory Number x111 :

103
3) Configurer le Hunt Group

-Revenir dans Application Cisco Unified CM Attendant Console User Pilot Point :

-Cliquer sur Pilot1

104
-Cliquer sur Add Member. Puis changer le radio button Member Option pour User
Member . Prciser User Name : jjones et Line Number : 1.

105
Faire Save puis Close :

-Faire nouveau Add Member puis choisir Directory number : x001 et cocher la case
Always Route Member .

106
Faire Save et Close :

-Terminer par Save

4) Cration du compte ac
-Aller dans User Management Application User :

107
-Entrer imprativement User ID : ac et Password : 12345

-Faire Save

-Aller dans User Management User Group :

-Faire Find :

108
-Cliquer sur Standard CTI Allow Call Park Monitoring :

109
-Cliquer sur Add Application Users to Group. Faire Find et slectionner lutilisateur ac
comme ci-dessous :

-Terminer par Add Selected

110
-Aller en haut droite dans Back to find/list pour faire rapparatre la liste des User
Group :

-Cliquer sur Standard CTI Allow Control of All Device et Standard CTI enabled et
appliquer la mme procdure que pour le groupe standard CTI allow call park
monitoring . Lobjectif est que ac appartienne ces 3 groupes.
-Quand vous avez fini, vrifier en allant dans User Management Application User puis
cliquer sur le compte ac :

111
-Plus bas dans cette page Web , vous devez avoir les 3 groupes apparaissant dans
permissions information ci-dessous :

-Si ce nest pas le cas, contacter votre formateur !

112
5) Associer le tlphone de la standardiste et le pilot point avec ac
-Le tlphone de la standardiste sera le phone 1-1. Aller dans Device Phone puis Find

-Ladresse MAC retenir est donc SEP00156389B5F7 dans notre exemple.

-Aller dans User Management Application User :

-Cliquer sur ac

113
-Faire descendre Pilot1 et SEP00156389B5F7 dans la fentre du bas, puis faire Save

6) Vrifier que les services Cisco Attendant Console Server et CTI sont dmarrs

-Nous avons au dbut du T.P activ ce service. Allez dans http://10.x.1.1/ccmservice en


entrant ccmadministrator/appuserpass si on vous demande de vous logger :

114
-Aller dans Tools Control Center - Feature Services. Slectionner le serveur 10 x.1.1.

-Vrifier que les deux services : CTI Manager et Attendant Console Server sont dmarrs :

115
-Etant donn que la mise en uvre de ce service nest pas trs fiable, profitez-en pour re-
dmarrer le service Call Manager !

7) Installer et configurer lUCM attendant console


Remarque : voir ventuellement avec le formateur sil peut vous passer le plug-in par cl
USB pour aller plus vite ! Sinon suivre la procdure ci-dessous
-Aller dans Application Plugins

-Faire Find :

-Cliquer sur Download en bas droite de la page et sauvegarder sur son PC local :

116
-Faire Save

-Double-cliquer sur licne et accepter tout ce qui suit

-Aprs Finish, vous avez un icne sur le bureau :

117
-Double-cliquer. Puis entrer pour le serveur : 10.x.1.1 et pour le Directory Number : x001

-Terminer par save

-Entrer User ID : jjones et Password : cisco. Cocher Remember user ID and password.
Laissez la langue anglaise car le Call Manager na pas rcupr User Locale en franais.

-Vous devriez tomber aprs quelques secondes sur lcran suivant :

118
-Il est trs important quen bas droite de lapplication, il apparaisse Call Control Up .
Cela prouve que lapplication peut contrler le tlphone (x001).

Vrification
-Aller en haut gauche dans Go online :

-Aller sur le pav numrique pour faire Dial

119
-Entrer x002

-Faites Dial droite. Le tlphone x002 doit sonner. Vrifier ensuite que le logiciel voit bien
lappel en cours :

Autre vrification
-Appeler x001 depuis un autre phone et voir que le logiciel supervise bien lappel
-Essayer dappeler x111 (Pilot Point) depuis x002. Si lAttendant Console est en Online,
x001 va sonner, sinon l appel sera mise en attente. En passant nouveau en On line
lappel ira directement vers x001.

120
Troubleshooting
-Il est possible que lappel sur x111 soit occup. Aller dans ce cas dans la configuration du
pilot point pour voir sil est Registered :

-Si malgr tout, lappel sur x111 reste occup alors que X111 est bien registered, utiliser
Putty (demander au formateur) pour redmarrer le PC 10.x.1.1 qui supporte Call Manager :

121
-Se logger an tant que admin/adminpass et faire : utils system restart. Attention car le
redmarrage peut prendre 10 minutes vrifier si vos tlphones se sont r-enregistrs.

Remarque : Un autre moyen, cest de passer par la page https://10.x.1.1/cmplatform en se


loggant en tant que admin/adminpass :

122
Autre troubleshooting : Si, lorsquon lance lattendant console, on a call control down ,
ce sera peut tre parce que le compte ac aura t configur avec un autre mot de passe que
12345 Dans ce cas, mme le redmarrage des services voire le redmarrage du
serveur ny fera rien.

Solution :
-Dsinstaller le logiciel AC sous windows par le panneau de configuration
-Dsactiver le service CTI Manager et Attendant console
-Supprimer lAC user jjones, le pilot point 1111 et le compte application user ac
-R-activer le service CTI Manager et Attendant console
-Refaire scrupuleusement tout le TP.

123
IX OUTILS DE DIAGNOSTIC : SURVEILLANCE ET GESTION DU
SYSTEME DE TELEPHONIE SUR IP
IX.1 Installation et utilisation de RTMT
Objectif : Installer le plugin RTMT sur le PC et accder linterface de gestion pour
grer alarmes, altertes et traces

-Aller dans Application Plugins .

-Puis aprs, faire Find

-Cliquer sur Download correspondant RTMT

124
-Faire Save sur votre bureau puis cliquer sur licne pour lancer linstallation :

-Faire Next

-Accepter et faire Next

125
-Faire Next

-Cliquer sur Install

-Vous devriez trouver une icne sur le bureau : Double-cliquer et vous logguer
sur 10.x.1.1 en tant que CCMAdministrator / appuserpass.

126
-Puis valider par Ok la bote qui suit. Vous devez avoir lcran suivant. Cliquer sur OK

-Cliquer sur OK pour avoir accs la surveillance de votre Call Manager

127
-Vous pouvez observer lvolution du CPU et de la mmoire.

-Dautres paramtres intressants vous seront montrs par le formateur votre demande, par
exemple la faon de faire des Traces.

128
IX.2 Utilisation de Dial Number Analyzer
Objectif : Vrifier laccessibilit dun numro de tlphone par DNA

-Ouvrir une page web avec lURL :

https://10.x.1.1:8443/dna

-Aller dans Analysis Analyzer :

-Entrer Calling Party : x001 et Dialed Digits : x002. Cliquer sur Do Analysis

129
-Cliquer sur Expand All pour plus de dtails.

-Refaire le mme exercice en entrant Calling Party : x001, Dialed Digits : 95005550001# et en
mettant le Calling Search Space : CSS_TEL_HQ

130
IX.3 Accs la ligne de commandes via SSH

Objectif : Accder linterface CLI via un compte/mot de passe.

-Lancer Internet Explorer et rcuprer le client SSH putty en tapant putty sous
http://www.google.fr et en choisissant le premier lien qui apparat. Cliquer ci-dessous sur le
lien suivant :

131
-Entrer 10.x.1.1 dans le champ Host Name (Or IP address)

-Vous pouvez, si vous le souhaitez, sauvegarder cette session en entrant Node1 dans
Saved Session et en cliquant sur Save

-Cliquer sur Open et dans la session terminal, entrer login as : admin et password:
adminpass

132
Quelques commandes utiles
Show status
-Permet davoir le pourcentage CPU et la version

Show version active | show version inactive


-Permet davoir la version active de Call Manager et lancienne version, avant la mise jour.
Ici linstallation de la version 5.04 sest faite directement depuis un systme vierge.

133
Show hardware
-Permet davoir le type de serveur physique. Ce sera trs souvent un Cisco MCS. Ici cest
du VMware

Show network eth0


-Voir la configuration IP

134
Show network eth0 detail
-Voir la configuration IP et les statistiques Ethernet, ainsi que l@MAC

File list tftp *


-Permet davoir la liste des fichiers TFTP contenant en particulier les firmwares des
tlphones (fichiers *.bin) ainsi que les sonneries (fichier *.raw)

135
File list install *
-Contient les fichiers de log install.err et install.log qui contiennent le droulement de
linstallation. Contient aussi les logs des rplications Publisher Subscriber

File view install install.log


-Permet de voir le contenu du fichier install.log

136
Utils network capture eth0 count 5
-Permet de montrer en temps rel tous les paquets IP qui sont reus et envoys par Call
Manager

Utils network capture eth0 src 10.1.1.101


-Permet de capturer uniquement les paquets qui ont pour origine ladresse IP 10.1.1.101
(Faire un ping depuis HQ-x pour voir les ICMP ci-dessous)

137
Show firewall list
-Montre les ports ouverts et interdits sur le Call Manager

Show process load


-Permet de voir le processus qui pourrait monopoliser la puissance CPU du Call Manager

138
Show stats io
-Permet de voir ltat du disque dur et des partitions

Show tech ccm service


-Voir ltat des services de Call Manager, leur dmarrage et leur dpendance vis--vis
dautres services

-Dautres commandes sont aussi intressantes comme les commandes commenant par
show tech network pour voir la liste des ports udp/tcp ouverts ou le fichier hosts du CCM

Question : Comment faire un ping vers 10.x.1.2 partir du CLI ? Donner la commande :

139
X - CONFIGURATION DE UNITY
X.1 Configurer Call Manager pour Cisco Unity
Objectif : Configuration des Voice Mail Ports en utilisant Cisco Voice Mail Port Wizard
et Configuration du Voice Mail Pilot x800 en tant que numro de la messagerie

1) Configuration des Voice Mail Ports


-Lensemble des paramtres de messagerie se trouve dans le menu Voice Mail. Aller dans
Voice Mail Cisco Voice Mail Port Wizard :

-Ensuite entrer toutes les paramtres comme spcifi dans chaque capture dcran

-Entrer : CiscoUM1 puis cliquer sur Next

-Configurer 2 ports Voice Mail puis cliquer sur Next

-Entrer le Device Pool : DP_RUEIL puis cliquer sur Next

140
-Entrer le champ Beginning Directory Number : x801

-Cliquer sur Next

-Choisir Yes puis cliquer sur Next

-Entrer LG-VoiceMail puis cliquer sur Next

141
-Cliquer sur Finish

-Cliquer sur Go to Cisco Voice Mail Ports

-Puis cliquer sur Find

142
-Vous pouvez remarquer que les deux VM ports ont bien t crs et quils sont bien
Registered

-En cliquant sur le premier port :

Vrification
-Vrifier quen numrotant x801 vous tes sur la messagerie. Si vous tentez de numroter
simultanment avec un autre tlphone, il y aura donc une occupation.
- En fonction du tlphones x001, x002 ou x003, le message daccueil nest pas le mme.
En effet, lun des tlphones est dj Subscriber (x001) et les autres non.

Remarque : Vous remarquerez que le bouton Messages ne marche pas. Dans le prochain
T.P, nous allons donc configurer un Voice Mail Pilot pour avoir un numro unique de
messagerie

143
2) Configuration du Hunt Pilot x800 pour le groupement de lignes
-Aller dans Call Routing Route/Hunt Hunt List

-Cliquer sur Add New et entrer les champs suivants

-Cliquer sur Save

-Cliquer sur Add Line Group

144
-Slectionner LG_VoiceMail et cliquer sur Save puis Ok

-Cliquer sur la disquette et sur le Ok qui suit

145
-Aller dans Call Routing Route/Hunt Hunt Pilot puis cliquer sur Add New.

-Entrer les champs ci-dessous :


Hunt Pilot : x800
Hunt List : HL_VoiceMail

-Cliquer sur la disquette

146
3) Configuration du Voice Mail Pilot

-Aller dans Voice Mail Voice Mail Pilot puis cliquer sur Add New
-Entrer les champs ci-dessous
Voice Mail Pilot Number : x800
Cocher la case: Make this the default Voice Mail Pilot for the system

-Cliquer sur Save

-Aller dans Voice Mail Voice Mail Profile puis cliquer sur Find

-Cliquer sur Default

147
-Slectionner Voice Mail Pilot : <Use Default>

-Cliquer sur Save. Vous remarquerez que le Voice Mail Pilot va tre rectifi car cest x800
qui est le Default

Vrification
-Vrifier quen appuyant sur le bouton Messages ou en numrotant directement x800 depuis
un tlphone IP, vous tes sur la messagerie. De plus, si vous tentez de numroter
simultanment avec un autre tlphone, il ny aura plus de problme doccupation.

148
4) Configuration de MWI
-Aller dans Voice Mail Message Waiting puis cliquer sur Add New

-Nous allons dabord configurer MWI Off. Entrer pour Message Waiting Number : x998

-Cliquer sur Save

-Faites une copie et configurez MWI On. Entrer pour Message Waiting Number : x999

-Cliquer sur Save

En affichant une liste des Message Waiting, voici ce que vous devez avoir :

149
X.2 Configurer des renvoi dappels vers la messagerie
Objectif : Mettre en uvre des renvois dappel sur non-rponse ou sur occupation

-Aller dans Call Routing Directory Number puis cliquer sur Find

-Slectionner x001

150
-Au bas de la page Web, cocher les 4 cases comme indiqu sur les Forward Busy et
Forward No Answer.
-Sauvegardez et faites Reset.

-Refaire la mme manipulation de renvoi vers la messagerie pour le Directory Number x002

Vrification
-Depuis x003, vrifier quen appelant x001, vous tomber sur la messagerie de Kermit the
Frog .. Par contre si vous appelez x002, vous tomberez sur lAuto Attendant (standard
automatique) avec le message de bienvenue.

151
X.3 Administrer Cisco Unity

Objectif : Accder Cisco Unity, configurer un compte Subscriber et le standard


automatique

-Accs Cisco Unity :


http://10.x.1.4/saweb

-Pour se logger, entrer username : unityadmin et password : cisco


-Si cela ne marche pas, essayer unityinstaller et password : cisco
-On tombe sur la page daccueil suivante :

152
X.4 Configuration dun compte Subscriber
Objectif : configurer deux comptes de messagerie vocale Unity

-Cliquer gauche sur Subscribers

-Si vous avez la fentre ci-dessus, cliquez sur installer Cisco Media Control qui permettra
dutiliser son tlphone comme lecteur ou enregistreur de fichier Wav pour le systme (par
exemple pour la cration par ladministrateur Unity du message de bienvenue).
-Si on vous demande de vous logguer, relogguez-vous avec username : unityadmin et
password : cisco

-Aller ensuite faire Find en cliquant le bouton bleu droite. Cela permet de voir tous les
Subscribers.

-Refaites Find pour revoir lcran ci-dessous :

153
-On peut noter que x001 est dj dfini. Cela explique pourquoi on demande enter your
password avec x001 puisquon voit Kermit the frog associ x001 : x001 est donc dj
un Subscriber.

-Crons un compte pour x002. Faites cancel dans lcran ci-dessus puis faites un ajouter
en allant cliquer sur le bouton bleu droite avec un + dedans :

154
-Vous devriez tomber sur la page ci-dessous remplir avec votre propre nom, prnom et
numro de tlphone :

-Terminer en cliquant sur Add

155
-Dcocher la case Set subscriber for self enrollment at next login :

-Puis sauvegarder avec la petite disquette bleue en haut droite.

-Nous allons modifier le mot de passe. Aller dans Subscriber Phone Password :

156
-Modifier le Password, mettre : 206256 et confirmer avec le mme mot de passe (Le
password 12345 serait trop trivial pour tre accept)
-Dcocher la case User must change password at next login

Vrification : Aller sur x002 et appuyer sur le bouton message . On doit couter enter
your password .Entrer 206256 suivi de #. Vous avez accs votre bote aux lettres.
Essayer de la personnaliser en changeant par exemple le message daccueil lorsque
quelquun va vous laisser un message

-Vous pouvez renouveler lopration en crant un deuxime Subscriber qui portera lidentit
de votre partenaire.

157
X.5 Configuration de lAuto-attendant (Standard Auto)
Objectif : Configurer le Serveur Vocal Interactif (SVI) intgr Cisco Unity

-Cliquer comme ci-dessous sur la flche gauche de Subscriber :

-Vous tes nouveau sur la page daccueil de Cisco Unity. Aller dans Call Management
Call Handler

-Puis faites Find deux reprises. Choisissez Opening Greeting .

158
-Vous devez avoir cet cran aprs avoir slectionn Opening Greeting en faisant
View :

-Modifier Active schedule : All Hours All Days comme ci-dessous

159
-Aller gauche dans Greetings

-Slectionner le bouton rouge :

160
-Cliquer sur le bouton rouge pour enregistrer un message vocal pour lauto attendant. On
vous propose dentrer dans une fentre le priphrique. Entrer lextension x002 et ladresse
IP : 10.x.1.4 :

-On vous propose de crer un nouveau message vocal. Accepter avec OK

-Aprs le bip sonore, enregistrer votre message du type Bienvenue globalknowledge,


veuillez appuyer sur 4 pour accder lannuaire ou 9 pour aller laccueil .-

161
Vrification : Tester depuis un poste non Subscriber, par exemple depuis le tlphone
analogique x003, que le message enregistr prcdemment sera bien celui que vous venez
de crer en appelant le numro de la messagerie x800

162