Vous êtes sur la page 1sur 8

Comunicaciones II

Laboratorio 04
Frame Relay
Objetivos:

Realizar una conexin WAN a travs de dos switches Frame Relay.


Simular una red WAN usando protocolo Frame Relay.
Configurar los parmetros de trafico de una red Frame Relay

Requisitos:

Una computadora con Sistema Operativo Windows 98.


Emulador de terminal : Hyperterminal.
Routers Cisco 2811 (3), 4000 (2) con cables de consola.
Cables WAN DB60-V35Male (DTE)
Cables WAN DB60-V35female (DCE)

Esquema:
1.- Arm la siguiente topologa, en la cual los Routers G2 y G3 se comunicaran solamente con
el router central G1, utilic para la configuracin Frame Relay el uso de Sub-interfaces y los
DLCIs necesarios.

IP LAN2
F.R. 64 Kbps
Router G1 Router G2
F.R. 64 Kbps
IP LAN 1

SWITCH A F.R. 64 Kbps

Router G3
IP LAN3

Pgina 1 de 8
Comunicaciones II

2.- Los PVCs brindarn conexin entre los routers, los cuales estarn dispuesto de la siguiente
forma:
Router G2
DLCI ___

S2

S1
DLCI ___

Router DLCI ___ SWITCH


G1

S3

Procedimiento: Router G3
DLCI ___
3.- Cada grupo deber desarrollar los requerimientos para lograr el acceso desde el Router G# a
la red Frame Relay, de acuerdo a los siguientes parmetros. Utilice el comando show running-
config para conocer la nomenclatura real del puerto fisico (seria0, serial1/0,etc):

Router G1
a) Nivel Fisico:

Puerto Serial: ________________________

Tipo de interfase: ________________________

Velocidad: ________________________

Puerto LAN: ________________________

b) Nivel de Enlace:

Protocolo de mantenimiento: ___________

DLCI # 1: ___________

DLCI # 2: ___________

Tipo de acceso: ________________________

DTE= User
DCE=Network

c) Nivel de Red:

Pgina 2 de 8
Comunicaciones II

Numero de sub-interfase #1: __________________

DLCI asignado: __________________

Direccin IP WAN 1: __________________

Numero de sub-interfase #2: __________________

DLCI asignado: __________________

Direccin IP WAN 2: __________________

Protocolo de ruteo: __________________

Direcciones de red remotas: __________________

__________________

Direccin IP de puerto Ethernet: __________________

Switch
a) Nivel Fisico:

Puerto serial 1 a usar : ________________________

Puerto serial 2 a usar : ________________________

Puerto serial 3 a usar : ________________________

Tipo de interfase: ________________________

Velocidad: ________________________

b) Nivel de Enlace:

Protocolo de mantenimiento serial 1 : ___________

Protocolo de mantenimiento serial 2 : ___________

Protocolo de mantenimiento serial 3 : ___________

Tipo de acceso: ________________________

DTE= User
DCE=Network

Puerto:____ DLCI:_____ CONECTADO A Puerto:____ DLCI:_____

Puerto:____ DLCI:_____ CONECTADO A Puerto:____ DLCI:_____

Router G2

Pgina 3 de 8
Comunicaciones II

a) Nivel Fsico:

Puerto Serial: ________________________

Tipo de interfase: ________________________

Velocidad: ________________________

Puerto LAN: ________________________

b) Nivel de Enlace:

Protocolo de mantenimiento: ___________

DLCI # 1: ___________

Tipo de acceso: ________________________

DTE= User
DCE=Network

c) Nivel de Red:

Numero de sub-interfase #1: __________________

DLCI asignado: __________________

Direccin IP WAN 1: __________________

Direcciones de red remotas: __________________

Direccin IP de puerto Ethernet: __________________

Router G3
a) Nivel Fsico:

Puerto Serial: ________________________

Tipo de interfase: ________________________

Velocidad: ________________________

Puerto LAN: ________________________

b) Nivel de Enlace:

Protocolo de mantenimiento: ___________

Pgina 4 de 8
Comunicaciones II

DLCI # 1: ___________

Tipo de acceso: ________________________

DTE= User
DCE=Network

c) Nivel de Red:

Numero de sub-interfase #1: __________________

DLCI asignado: __________________

Direccin IP WAN 1: __________________

Protocolo de ruteo: __________________

Direcciones de red remotas: __________________

__________________

Direccin IP de puerto Ethernet: __________________

4. - La configuracin Frame relay que usted debe lograr debe ser similar a la siguiente:

Configuracin de Routers G1, G2 , G3

Verifique que la direccin IP WAN as como el nmero de circuito virtual (PVC) , estn definidos
dentro de cada sub-interface. Slo parmetros generales como el encapsulado a Frame Relay, el
protocolo de mantenimiento, el clock rate, etc. son definidos dentro de los parmetros del puerto
serial.

No olvide configurar en el Router G1 los DlCIs necesarios para la comunicacin con los routers G2 y
G3.

interface <puerto_serial>

no ip address
no shutdown
encapsulation frame-relay
frame-relay lmi-type <protoc_mantenimiento>

interface Serial0.1 point-to-point

ip address <ip_wan1> <mascara>


frame-relay interface-dlci <dlci_1>

interface FastEthernet0

ip address <ip_lan> <mascara>

Pgina 5 de 8
Comunicaciones II

no shutdown

NOTA: No olvide configurar las rutas necesarias para la interconexin de la redes LAN
a interconectar use protocolo de ruteo esttico o dinmico
Configuracin Switch ( Enlace G2 G1)
Habilita la conmutacin Frame Relay
Configuracin en modo Global
frame-relay switching
interface S2

no ip address
encapsulation frame-relay
keepalive 15
clockrate <velocidad> Para ruteo de trafico G2 G1
frame-relay lmi-type <protoc_mantenim>
frame-relay intf-type <dte_dce_frame_relay>

frame-relay route <dlci_local_1> interface S1 <dlci_remoto_1>

interface S1
Para ruteo de trafico G1 G2
encapsulation frame-relay
clockrate <velocidad>
frame-relay lmi-type <protoc_mantenim>
frame-relay intf-type <dte_dce_frame_relay>

frame-relay route <dlci_remoto_1> interface S2 <dlci_local_1>

Nota : No es necesario configurar direcciones IP en Switch ya que este solamente actuara en forma
transparente a la comunicacin.

5.- Aplicando Parmetros para la modelacin de Trafico en Frame Relay ( Traffic-shaping), el cual
permitir asignar los valores al CIR y BC de acuerdo a los suministrados por el operador Frame
Relay, para nuestro ejemplo asignremos un CIR de 32 Kbps para cada uno de los enlaces desde
el router central .

Realice los siguientes pasos para la configuracin el Router Central G1:

a). - Habilitar el parmetro de modelacin de trafico sobre la interface serial usada para la
conexin a la red Frame Relay agregando :

RouterG1(config)# interface serial 0

frame-relay traffic-shaping

b).- Especifique el tipo de trafico o clase de trafico en cada sub-interface para la comunicacin
con
cada uno de los puntos remotos agregando :

Enlace Router G1 Router G2

Pgina 6 de 8
Comunicaciones II

RouterG1(config-if)# interface serial0.1 point-to-point

frame-relay class datosG1G2

Nota : Realice lo mismo para el enlace Router G1 a Router G3


Ejemplo : frame-relay class datosG1G3
c).- Definiendo los parmetros de clase o tipo de trafico, para lo cual se asociara un mapeo a la
clase de trafico agregando en el modo global :

RouterG1(config)# map-class datosG1G2

frame-relay cir 48000 (trafico promedio a enviar menor a la vel. puerto)


frame-relay mincir 32000 (trafico garantizado)
frame-relay adaptive-shaping becn (adapte la tx en respuesta a los BECN recividos)
frame-relay bc 6000 (si consideramos Tc=125 ms)
frame-relay be 12000

Nota : Cree el Mapeo de trafico para el enlace RouterG1 a G3

6. Monitoreando el trafico :

Ejemplo :

RouterG1#show frame relay pvc 16

PVC Statistics for interface Serial0/0 (Frame Relay DTE)


DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1
input pkts 8743 output pkts 5 in bytes 2548330
out bytes 520 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
Shaping adapts to BECN
pvc create time 6d01h, last time pvc status changed 6d01h
cir 64000 bc 8000 be 16000 byte limit 3000 interval 125
mincir 56000 byte increment 1000 Adaptive Shaping BECN
pkts 5 bytes 170 pkts delayed 0 bytes delayed 0
shaping inactive
traffic shaping drops 0
Queueing strategy: fifo
Output queue 0/40, 0 drop, 0 dequeued

Ejecute el comando :

RouterG1# show traffic

Pgina 7 de 8
Comunicaciones II

Pgina 8 de 8