Vous êtes sur la page 1sur 7

Club Tutoriel Informatique

IT Nisro
IT
CLUB TUTORIEL INFORMATIQUE
NISRO

Sommaire

I. Partie thorique ....................................................................................... 3


1. Les technologies NAT ............................................................................ 3
2. Nat Statique ......................................................................................... 3

3. Nat Dynamique..................................................................................... 4

II. Partie pratique ........................................................................................ 4


1. Nat Statique ......................................................................................... 4
2. Nat dynamique ..................................................................................... 6

~2~
IT
CLUB TUTORIEL INFORMATIQUE
NISRO

I. Partie Thorique :
1. NAT
Prsentation des fonctions NAT et PAT
NAT est conu pour conserver des adresses IP et permettre aux rseaux dutiliser des
adresses IP prives sur les rseaux internes. Ces adresses internes prives sont traduites en
adresses publiques routables.
Un matriel compatible NAT fonctionne gnralement la priphrie dun rseau dextrmit.
Quand un hte situ lintrieur du rseau dextrmit souhaite mettre vers un hte de lextrieur,
il transfre le paquet au routeur priphrique frontire. Ce routeur priphrique frontire effectue
le processus NAT et traduit ladresse prive interne dun hte en une adresse publique externe
routable.

Les termes lis NAT:


Adresse locale interne Ladresse IP attribue un hte du rseau interne.
Adresse globale interne Une adresse IP lgitime attribue par InterNIC ou par le fournisseur
daccs, et qui reprsente une ou plusieurs adresses IP locales internes pour le monde extrieur.
Adresse locale externe Ladresse IP dun hte externe telle que la connaissent les htes du rseau
interne.
Adresse globale externe Ladresse IP attribue un hte du rseau externe.

Principales fonctionnalits NAT et PAT


Les traductions NAT peuvent avoir de nombreuses utilisations et peuvent indiffremment tre
attribues de faon statique ou dynamique.

2. NAT Statique :
Principe : A chaque adresse prive correspond une adresse publique.
N adresse priv ncessit davoir N adresses publiques.

Avantage de NAT Statique :


*La fonction NAT assure la scurit du rseau. Les rseaux privs ne divulguant pas leurs
adresses ou leur topologie interne, ils restent raisonnablement scuriss quand ils sont
utiliss conjointement la fonction NAT pour obtenir un accs externe.

Inconvnient de NAT Statique :


*Gaspillages des adresses publiques.
*Solution couteuse.

3. NAT Dynamique
Principe : plusieurs @ locales internes correspondent plusieurs @ globales internes on parle
de pool dadresses IP publiques disponible pour le Nat.

N adresse priv n adresses publique (tel que n<N)

Donc on N-n adresses public conomise.


~3~
IT
CLUB TUTORIEL INFORMATIQUE
NISRO

Avantage de NAT Dynamique :

*Moins couteuse.

* masquer les machines du rseau interne.

*Economise des adresses IP publique.

Inconvnient de NAT Dynamique :

*Performance diminu attendre la libration de ladresse utilis pendant la dure du bail.

*Retarder la mise en uvre de la technologie IPv6.

II. Partie pratique :

1. Nat statique :
Les tapes :

Etape 1 Etablissez la traduction statique entre une adresse locale interne et


une adresse globale interne
Etape 2 Spcifie linterface interne
Etape 3 Signalez linterface comme connect lintrieur
Etape 4 Spcifie linterface externe
Etape 5 Signalez linterface comme connect lextrieur

Exemple :
On prend le schma suivant et on applique sur elle la configuration de Nat statique

~4~
IT
CLUB TUTORIEL INFORMATIQUE
NISRO

-Pour associer une adresse locale interne une adresse globale interne on utilise la
command :

Router(config)#ip nat inside source static @local interne @global interne

ista(config)#ip nat inside source staic 10.1.1.2 196.10.1.3

-Pour spcifie linterface connecte a lintrieur :

ista>enable

ista #configure terminal

ista(config)#interface fastEthernet 0/0

ista(config-if)#ip address 10.1.1.1 255.0.0.0

ista(config-if)#ip nat inside

ista(config-if)#no shutdown

ista(config-if)#exit

Pour spcifie linterface connect lextrieur :

ista>enable

ista#configure terminal

ista(config)#interface serial 0/0/0

ista(config-if)#ip address 196.10.1.1 255.255.255.0

ista(config-if)#clock rate 64000

ista(config-if)#ip nat outside

ista(config-if)#no shutdown

ista(config-if)#exit

-Pour visualiser la table de traduction dadresses (table Nat) on utilise la commande :

ista#show ip nat translations

~5~
IT
CLUB TUTORIEL INFORMATIQUE
NISRO

2. Nat Dynamique :
Les tapes :

Etape 1 Dfinissez un pool dadresses globales attribuer selon les


besoins.
Etape 2 Dfinissez une liste daccs standard autorisant les
adresses qui doivent tre traduites.
Etape 3 tablissez une source dynamique de traduction, en
spcifiant la liste daccs dfinie ltape prcdente.
Etape 4 Spcifiez linterface interne.
Etape 5 Signalez linterface comme connecte lintrieur.
Etape 6 Spcifiez linterface externe.
Etape 7 Signalez linterface comme connecte lextrieur.

Terminologie :
Pool : les adresses globale interne (@publique).
ACL : les adresse locale interne (@priv).
Bail : la dure dutilisation dune AGI pour une ALI.

Exemple :
On prend le schma suivant et on applique sur elle la configuration de Nat Dynamique

~6~
IT
CLUB TUTORIEL INFORMATIQUE
NISRO

-Pour dfinir le pool des adresses publiques disponibles, on utilise la commande :

Router(config)#ip nat pool nom-pool @-debut @-fin net mask mask sous reseau

ista(config)#ip nat pool TRI 193.10.1.3 193.10.1.88 netmask 255.255.255.0

-Pour dfinir une Access List:

ista(config)#access-list 1 permit 10.1.1.2 0.0.0.255 (masque gnrique)

-Pour dfinir le bail :

Router(config)# ip nat translation timeout bail

~7~