Vous êtes sur la page 1sur 70

Interconnexion de Rseaux

Grande chelle

Intro au protocole BGP

L. Stefenel 2008 1
Quelques termes utiliss dans ce cours

IGP (Interior Gateway Protocol)


RIP, IGRP, EIGRP, OSPF
Protocoles de routage utiliss l'intrieur d'un systme
autonome (AS)
EGP (Exterior Gateway Protocol)
BGP
Protocole de routage utilis pour changer des informations de
routage entre difrents systmes autonomes (AS)
Autonomous System
(RFC 1771) Un ensemble de routeurs sous une seule
administration, qui utilise un IGP et des mtriques communes
pour faire le routage des paquets l'intrieur d'un AS and et un
EGP pour le routage vers d'autres ASs.
BGP un protocole de routage vecteur de chemin (path vector)

L. Stefenel 2008 2
Est-il obligatoire d'utiliser BGP ?

L'utilisation de BGP dpend du niveau de connaissance


technique et de la prsence d'une de ces situations :
Le AS permet le transit de paquets d'autres AS
Le AS a plusieurs connexions d'autres ASs (multihomed)
Les fux entrants ou sortants de l'AS doivent tre manipuls

L. Stefenel 2008 3
BGP n'est pas ncessaire si

Ne pas utiliser BGP si :


il n'y a qu'une seule connexion ver un autre AS ou FAI
votre AS ne requiert des fltrages ou manipulations des fux
les routeurs sont limits en mmoire ou capacit de calcul
l'administrateur a une connaissance limite du processus de fltrage
et slection des chemins BGP
la liaison entre les AS a une faible bande passante
L. Stefenel 2008 4
Qui rellement a besoin de BGP ?

Pas beaucoup de monde


Vous devez utiliser BGP uniquement si des fortes raisons vous
obligent, comme par exemple lorsque les IGPs ne permettent le
contrle souhait ou si la taille des tables de routage ne peut
pas tre contrle avec de l'agrgation
Dans la plupart des cas, ce ne concerne que les FAIs et leurs
liaisons
Jef Dolye, Routing TCP/IP Vol. II

L. Stefenel 2008 5
Dfnition des Systmes Autonomes (AS)

AS - Un ensemble de routeurs qui partagent des politiques de


routage similaires et qui sont grs dans un mme domaine
administratif. De l'extrieur, un AS est vu comme une entit unique
Un AS peut tre compos :
d'un ensemble de routeurs qui tourne le mme protocole IGP
d'un ensemble de routeurs qui tournent difrents protocoles de
routage (une grande entreprise ou un FAI, par exemple)

L. Stefenel 2008 6
Identifcation des AS

Les numros des AS


Attribus par une entit
Entre 1 et 65535.
Les adresse de 64512 65535 sont rservs pour un usage
prive

L. Stefenel 2008 7
Attribution des AS

cause du nombre limit d'AS, il faut justifer le besoin d'un


numro AS
+- 40000 dj attribus
Aujourd'hui, la IANA (Internet Assigned Numbers Authority)
conseille fortement l'usage des AS 64512-65535 pour les AS
qui sont connects un seul AS
L. Stefenel 2008 8
BGP concepts de base

BGP est un protocole de routage par vecteur de chemin


path vector
RFC 1772
Une route indique la liste d'ASs qu'il faut traverser pour arriver
la destination
L. Stefenel 2 00 8 9
BGP concepts de base

BGP a por objectif :


l'change d'informations de routage entre les ASs
garantir le choix d'une route sans boucle (loop-free)
BGP4 est la premire version de BGP qui supporte CIDR et
agrgation de routes
IGPs comme RIP, OSPF et EIGRP utilisent des mtriques
BGP
n'utilise pas des mtriques
fait les dcisions selon des politiques de routage
n'indique pas les dtails internes des ASs
ne reprsente qu'un arbre d'ASs
show ip bgp commande IOS pour afcher la table de routage BGP
L. Stefenel 2008 10
BGP concepts de base

Les mises jour BGP utilisent TCP sur le port 179


RIP utilise UDP sur le port 520
EIGRP utilise RTP
OSPF n'utilise pas un protocole de couche 4
Du fait d'utiliser TCP, BGP a besoin de :
une connectivit IP entre les voisins BGP
ouvrir des connexions TCP avant d'changer des donnes
BGP bnfcie de la fabilit de TCP

L. Stefenel 2008 11
Chemin sans boucle (Loop-free)

Pour viter les boucles, BGP construit un graphe avec les donnes
envoyes par les voisins
La connexion entre deux AS reprsente un chemin
AS Path Le chemin pour atteindre un AS est reprsent comme
une squence de numros d'AS
Grce aux numros d'AS, un systme autonome peut dtecter un
chemin qui passe deux fois par le mme AS

L. Stefenel 2008 12
BGP Updates AS Path AS Path
1 500 2 100, 500

AS Path
AS Path
3 200, 100, 500
4 300, 200, 100, 500

AS Path AS Path
5 400, 300, 200, 100, 500
6 400, 300, 200, 100, 500

Son propre AS

L. Stefenel 2008 13
Chemin sans boucles

AS_PATH
172.16.0.0/16
Liste des AS associs une (4, 2, 1)
route 172.16.0.0/16
L'un des attributs associs (6, 5, 3, 1) AS7
aux routes ( voir plus tard)
La stratgie la plus simple AS4
consiste choisir le chemin le
plus court
AS6
Pour deux annonces de rseaux
identiques (mmes prefxes), AS2
BGP prfre les routes avec le
AS_PATH le plus petit
Dans cet example, AS7 choisit
le chemin le plus court (4, 2, 1) AS1
AS5 AS3
172.16.0.0/16

L. Stefenel 2008 14
Les types de message BGP

Avant toute communication entre deux peers il est ncessaire de


dmarrer une connexion TCP sur le port 179.
Une fois ouverte la connexion, BGP change plusieurs messages
avec les paramtres de la connexion et les informations de
routage.
Tous les messages BGP sont unicast vers un seul partenaire.
Il y a 4 types de message BGP :
Type 1: OPEN identifcation initiale entre les peers
Type 2: KEEPALIVE
Type 3: UPDATE mises jour
Type 4: NOTIFICATION - erreurs

L. Stefenel 2008 15
Fonctionnement de BGP

Voisins ou pairs Deux routeurs qui tablissent une


connexion TCP
Chaque routeur doit excuter le protocole BGP

L. Stefenel 2008 16
change Initial

Lorsqu'une connexion est tablie, les routeurs changent


leurs routes candidates
Aprs l'change initial, des mises jour incrmentales sont
envoyes entre les routeurs
L. Stefenel 2008 17
Suppression de Routes

Les informations sur les routes peuvent tre aussi


une route qui devient inaccessible
un meilleur chemin disponible
Les routeurs BGP gardent un tableau de numros de version
Liste des numros de version des mises jour reues de chaque
routeur
Increment chaque modifcation des tables de routage BGP
Une incrementation rapide indique normalement un rseau
instable ou mal confgur

L. Stefenel 2008 18
BGP Keepalives

Les pairs changent des messages keepalive pour garder active


la connexion
Le dfaut Cisco est de 60 secondes (le RFC 1771 n'espcifque pas
une valeur standard)
Si l'intervalle est dpass trois fois (180 seconds) un pair est
considr down
Les intervalles peuvent tre confgures
L. Stefenel 2008 19
Attributs d'un Chemin

Chaque route a son propre ensemble d'attributs, qui peut inclure


des informations sur le chemin
prfrences sur les routes
next-hop
informations d'agrgation
Les admins utilisent ces informations pour composer des politiques de
routage
partir des valeurs des attributs, BGP peut tre confgur pour
fltrer des informations sur certaines routes
choisir des chemins prfrentiels
L. Stefenel 2008 20
Attributs de Chemin

Certains attributs ne sont pas reconnus par tous les fabricants


Les attributs de chemin ont quatre types
Well-known mandatory
Well-known discretionary
Optional transitive
Optional non-transitive
L. Stefenel 2008 21
Attributs de Chemin

Well-known mandatory
Un attribut qui doit tre prsent dans une mise jour BGP
Reconnu par toute implmentation BGP
Si un attribut well-known est manquant, une notifcation d'erreur
sera cre
tablit un standard minimum des attributs
Exemple : l'attribut AS_PATH

L. Stefenel 2008 22
Attributs de Chemin

Well-known discretionary
Attribut qui doit aussi tre reconnu par toute implmentation BGP
Peut ne pas tre envoy dans un message BGP UPDATE
Exemple : LOCAL_PREF

L. Stefenel 2008 23
Attributs de Chemin

Optional transitive
Un attribut qui peut ne pas tre reconnu par une implmentation
BGP (donc optionnel)
Cet attribut est transitif
BGP doit accepter et annoncer l'attribut mme s'il ne le
reconnat pas
Exemple : COMMUNITY

L. Stefenel 2008 24
Attributs de Chemin

Optional non-transitive
Un attribut qui peut ne pas tre reconnu par une implmentation
BGP
Mme si un router reconnat l'attribut, il est non-transitif
Ne doit PAS tre repass aux autres pairs BGP
Exemple : ORIGINATOR_ID

L. Stefenel 2008 25
Rsum de la procdure du choix des routes
BGP choisit un seul chemin (pas d'quilibrage de charge)
Quand un chemin est choisi, il est plac dans la table de routage et annonc
aux autres routeurs
L'ordre de choix :
1. Si le prochain saut est inaccessible, ignore le chemin
2. Prfrence aux chemins avec le plus grand poids
3. Prfrence aux chemins avec la plus grande prfrence locale
4. Prfrence aux chemins indiqus par le processus BGP
5. Prfrence aux chemins avec le plus court AS_PATH
6. Prfrence aux chemins avec le plus petit type d'origine
IGP < EGP < Incomplete
7. Prfrence aux chemins avec le plus petit attribut MED
8. Prfrence aux chemins extrieurs
9. Prfrence aux chemins avec le plus proche voisin IGP
10. Prfrence aux chemins avec la plus petite adresse IP, comme indiqu par
BGP router ID.

L. Stefenel 2008 26
Quoi faire dans le cas des AS single-homed ?

Static Route

Premire alternative : routes statiques


Un AS Single-homed system n'a qu'un seul point de sortie
aussi connus comme des rseaux stub
gnralement utilisent une route dfaut pour le trafc destin
l'extrieur de l'AS
Dans ce cas, BGP n'est pas ncessaire

L. Stefenel 2008 27
Quoi faire dans le cas des AS single-homed ?

Utilisation d'un protocole IGP


Le FAI et le client peuvent utiliser une protocole IGP pour partager
les routes du client
A l'avantage de faire le ISP bnfcier du routage dynamique
Dans ce cas, BGP n'est pas ncessaire
L. Stefenel 2008 28
Quoi faire dans le cas des AS single-homed ?

Utiliser BGP
le rseau single-homed peut utiliser BGP pour incrmenter les
politiques de routage
difcilement on obtient un AS, il faut utiliser un numro priv
Le FAI remplace le numro priv pour l'annoncer au coeur de
l'Internet

L. Stefenel 2008 29
Des AS Multi-homed

ISP

routes agrges

0.0.0.0/0 0.0.0.0/0
OSPF
Cost = 10 Cost = 10
Type = E1 Type = E1

AS Multi-homed
On cherche de la redondance
Options
Liens primaire et backup
Possibilit d'utiliser les deux chemins
BGP n'st pas encore obligatoire
Risque de devenir un AS de passage lors d'une dfaillance

L. Stefenel 2008 30
AS Multi-homed : avec ou sans transit de messages

Transit AS permet le passage du trafc entre deux autres AS


Non-transit AS empche ce passage
Annonce uniquement SES routes aux deux autres AS
Dans l'exemple, ISP1 n'utilise pas AS 24 pour atteindre ISP2 ou
vice-versa
Pas obligatoire d'utiliser BGP, mais fortement recommand
BGP ofre plusieurs avantages dont :
Contrle accru de la propagation des routes
Filtrage des routes
L. Stefenel 2008 31
Multi-homed Transit Autonomous Systems

Edge Router

Internal BGP (IBGP) - lorsque BGP est utilis l'intrieur d'un AS


External BGP (EBGP) - lorsque BGP est utilis entre deux AS
Routeur de passage un routeur BGP utilis pour le passage du
trafc IBGP
Routeur frontalier routeurs la limite des AS utiliss pour
changer des routes EBGP
L. Stefenel 2008 32
Les risques d'utilisation de BGP

Voisinage BGP
Crer un voisinage BGP requiert l'accord entre les administrateurs
vous faites confance ce que l'autre admin fait dans son rseau
au mme temps, vous faites tout le possible pour prvenir les
erreurs commis par les autres admins
Paranoia is your friend.
L. Stefenel 2008 33
Les risques de BGP appropriation de routes
Le cas du FAI pakistanais et de YouTube
Le dimanche 24 fvrier 2008, Pakistan Telecom (AS17557) a
annonc sans autorisation le prfxe 208.65.153.0/24.
Selon l'ambassade du Pakistan, c'tait une mesure
gouvernementale destine bloquer l'accs de YouTube en
Pakistan
L'un des FAI de Pakistan Telecom (PCCW Global - AS3491) a
transmis cet annonce sur l'Internet, ce qui a rsult dans le
dtournement global du trafc destin YouTube
Le dbut
AS36561 (YouTube) annonce 208.65.152.0/22.
Dimanche 24 fvrier 2008, 18:47 (UTC) :
AS17557 (Pakistan Telecom) commence annoncer
208.65.153.0/24
AS3491 (PCCW Global Hong Kong) retransmet l'annonce
Les routeurs du monde entier reoivent l'annonce et le trafc de
YouTube est redirig vers le Pakistan
L. Stefenel 2 00 8 34
Suite et fn
Dimanche 24 fvrier 2008, 20:07 (UTC):
AS36561 (YouTube) annonce 208.65.153.0/24.
Avec deux prfxes identiques, des politiques de routage BGP telles
que le chemin le plus court font leur choix
AS17557 (Pakistan Telecom) continue recevoir une partie du trafc
destin YouTube.
Dimanche 24 fvrier 2008, 20:18 (UTC):
AS36561 (YouTube) annonce 208.65.153.128/25 et
208.65.153.0/25 (et aussi /26)
cause du prfxe plus long, chaque routeur qui reoit cet annonce
choisit de s'adresser YouTube
Dimanche 24 fvrier 2008, 20:51 (UTC):
Pakistan Telecom via AS3491 (PCCW Global) annonce les prfxes /
25 et /26
La plupart des routeurs continu s'adresser YouTube cause de la
longueur du chemin
Dimanche 24 fvrier 2008, 21:01 (UTC):
AS3491 (PCCW Global) retire tous les prfxes annoncs par
AS17557 (Pakistan Telecom), fnissant le dtournement des routes.

L. Stefenel 2008 35
Risques avec BGP Devenir un AS de passage

Si AS24 annonce par mgarde des routes apprises sur ISP1 vers ISP2
Les clients ISP2 considrent AS24 comme une route vers ISP1
AS24 devient un domaine de transit pour ISP1 et ISP2
L. Stefenel 2008 36
IBGP versus EBGP
AS 100
Lorsque BGP s'excute Aspen
l'intrieur d'un AS, il est appel
Internal BGP (IBGP).
192.168.1.222/30
Un routeur de transit execute
IBGP 192.168.1.220/30 IBGP
Utilis presque exclusivement
192.168.1.221/30
dans le cas des AS multi- Vail
homed
BGP entre deux AS est appel 192.168.1.226/30
External BGP (EBGP) EBGP 192.168.1.224/30
Un routeur de frontire 192.168.1.225/30

Taos

192.168.100.0/24
192.168.200.0/24
192.168.1.216/30

AS 200
L. Stefenel 2008 37
IBGP versus EBGP

Les routeurs A et B tournent EBGP (BGP) alors que les routeurs B et C


tournent IBGP.
On observe que :
les pairs EBGP (BGP) doivent tre directement connects
les pairs IBGP n'ont pas besoin d'tre directement connects
il suft d'avoir un protocole IGP pour router les messages
l'intrieur d'un AS
L. Stefenel 2008 38
IBGP versus EBGP

Tout noeud BGP l'intrieur d'un AS doit tablir une connexion


entre-eux
Exemple : l'AS 200 est un AS de passage pour AS 100 et AS 300

L. Stefenel 2008 39
Confgurer BGP

Pour commencer, entrer dans le mode confguration BGP


Router(config)#router bgp AS-number

Attention, les commandes BGP sont presque similaires ceux


des IGP
Leur fonction peut tre assez difrente
Note : L'IOS cisco ne permet qu'un seule processus BGP par
routeur
alors un routeur n'appartient qu' un seul AS

L. Stefenel 2008 40
Confgurer BGP

Router(config-router)#network network-number [mask network-


mask]
Les rseaux doivent tre prsents dans la table de routage (show ip
route) pour tre distribus
Les routes apprises avec BGP sont difuses par dfaut, mais souvent
elles sont fltres par des politiques de routage
L. Stefenel 2008 41
Confgurer BGP

Router(config-router)#network network-number [mask network-mask]


Avec les IGPs, la commande network indique les interfaces qui participent ainsi
que les routes annonces
Dans le cas du protocole BGP, la commande network n'afecte pas les
interfaces
En BGP, network indique les routes apprises localement qui seront annonces
Les rseaux peuvent tre des routes connectes, statiques ou apprises
dynamiquement
Seulement confgurer network ne suft pas pour tablir des connexions BGP

L. Stefenel 2008 42
Confgurer BGP

Router(config-router)#neighbor ip-address remote-as AS-number

La commande Neighbor Utilise pour tablire une rlation


de voisinage avec un autre routeur BGP
Le paramtre AS-number indique si le routeur est un voisin EBGP
ou IBGP
L. Stefenel 2008 43
EBGP

RTA(config)#router bgp 100


RTA(config-router)#neighbor 10.1.1.1 remote-as 200

RTB(config)#router bgp 200


RTB(config-router)#neighbor 10.1.1.2 remote-as 100

Observez que la valeur remote-as 100 de la commande neighbor est


difrente de la valeur AS-number spcife par la commande router bgp
(200)
Avec deux numros AS difrents, RTB inicie une connexion EBGP avec RTA

L. Stefenel 2008 44
IBGP

RTB(config)#router bgp 200


RTB(config-router)#neighbor 172.16.1.2 remote-as 200
RTB(config-router)#neighbor 172.16.1.2 update-source loopback 0

RTC(config)#router bgp 200


RTC(config-router)#neighbor 172.16.1.1 remote-as 200
RTC(config-router)#neighbor 172.16.1.1 update-source loopback 0

L. Stefenel 2008 45
RTB(config-router)#neighbor 172.16.1.2 update-source loopback 0
RTC(config-router)#neighbor 172.16.1.1 update-source loopback 0

update-source loopback 0 - indique au routeur d'utiliser toute


interface oprationnelle pour tablir les connexions TCP (tant que Lo0
est active et confgure avec une adresse IP)
Sans cette commande update-source loopback 0, les routeurs BGP
ne peuvent utiliser que l'interface la plus proche
Utiliser n'importe quelle interface augmente la robustesse de BGP si
un lien est dfaillant
L. Stefenel 2008 46
Considrez que la route suivante est entre dans la table de RTB

0 192.168.1.0/24 [110/74] via 10.2.2.1, 00:31:34, Serial2

RTB a appris cette route grce un IGP (OSPF)


Cet AS utilise OSPF pour changer les routes internes
Comment RTB pourra annoncer cette route via BGP ?
Avec la redistribution des routes OSPF sur BGP
ou
Avec la commande BGP network

L. Stefenel 2008 47
EBGP

RTB(config)#router bgp 200


RTB(config-router)#network 172.16.1.0 mask 255.255.255.254
RTB(config-router)#network 10.1.1.0 mask 255.255.255.254
RTB(config-router)#network 192.168.1.0

Les deux premires commandes network indiquent le masque d'un sous-


rseau spcifque
La troisime commande network annonce le rseau 192.168.1.0 sans avoir
besoin d'une redistribution OSPF
route statique
Attention : network ici indique les routes qui seront annoncs sur toute
connexion BGP

L. Stefenel 2008 48
EBGP Multihop EBGP Multihop

EBGP Multihop

I do not speak BGP. But RTW and


RTU can use EBGP multihop to
speak BGP.

EBGP doit connecter directement les pairs pour tablir une session
Exception : l'IOS Cisco a une option multihop pour permettre la
connexion logique entre RTW et RTU mme si RTV n'implmente
pas BGP
quivalent augmenter le TTL d'un annonce BGP
Cette option doit tre confgure pour chaque pair
Router(config-router)#neighbor IP-address ebgp-multihop
[hops]

L. Stefenel 2008 49
EBGP

EBGP Multihop

EBGP Multihop

I do not speak BGP. But RTW and RTU


can use EBGP multihop to speak BGP.

L. Stefenel 2008 50
RTW(config)#router bgp 200
RTW(config-router)#neighbor 1.1.1.2 remote-as 300
RTW(config-router)#neighbor 1.1.1.2 ebgp-multihop 2

AS200 1.1.1.1

AS300

1.1.1.2

RTU(config)#router bgp 300


RTU(config-router)#neighbor 1.1.1.1 remote-as 200
RTU(config-router)#neighbor 1.1.1.1 ebgp-multihop 2

L. Stefenel 2008 51
Confgurer BGP

Lors de la confguration de BGP, les modifcations ne sont pas


immdiatement visibles
Pour forcer BGP de reinitialiser ses tables, utiliser la commande
clear ip bgp
Router#clear ip bgp *
Router#clear ip bgp 10.0.0.0
Utilisez cette commande avec beaucoup d'attention, voir pas du tout
sur un rseau de production
clear ip bgp * OOPS!Not me but a colleague who was an employee of a
large ISP with a 3 letter title. Got back from a Cisco routing course and
thought they would try out some commands on the core network. It took 45
minutes for the core to reconverge. P45 followed

L. Stefenel 2008 52
Exemple

L. Stefenel 2008 53
Exemple

L. Stefenel 2008 54
Exemple

L. Stefenel 2008 55
Exemple

L. Stefenel 2008 56
L. Stefenel 2008 57
Comment vrifer la confg BGP

Si le routeur n'a pas install les routes prvues, on peut utiliser la


commande show ip bgp pour vrifer les routes que BGP a appris

RTA#show ip bgp
BGP table version is 3, local router ID is 10.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


* i1.0.0.0 192.168.1.6 0 100 0 200 400 e
*>i10.1.1.1/32 10.1.1.1 0 100 0 i
*>i172.16.1.0/24 10.1.1.1 0 100 0 i
* i192.168.1.32/27 192.168.1.6 0 100 0 200 i

L. Stefenel 2008 58
show ip bgp

RouterC#show ip bgp
BGP table version is 8, local router ID is 200.200.200.66
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


*> 11.0.0.0 0.0.0.0 0 32768 i
*> 12.0.0.0 200.200.200.65 0 300 200 i
*> 192.10.2.0 200.200.200.65 0 0 300 i

BGP table version numro de version interne, augmente chaque


update
local router ID adresse IP du routeur
Status codes Statut des entres dans la table
s l'entre a t supprime
* l'entre est valide
> l'entre est le meilleur chemin pour le rseau (path vector)
i l'entre a t apprise par une session IBGP

L. Stefenel 2008 59
show ip bgp

RouterC#show ip bgp
BGP table version is 8, local router ID is 200.200.200.66
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


*> 11.0.0.0 0.0.0.0 0 32768 i
*> 12.0.0.0 200.200.200.65 0 300 200 i
*> 193.10.2.0 200.200.200.65 0 0 300 i

Origin codes L'origine des entres :


i entre origine d'un IGP
e entre origine d'un EGP
? entre avec une origine non tablie. Normalement est un
routeur BGP appris partir d'un IGP
Network adresse IP du rseau
Next Hop adresse IP du prochain saut. Une entre 0.0.0.0 indique que le
routeur a une route non-BGP vers la destination
L. Stefenel 2008 60
show ip bgp

RouterC#show ip bgp
BGP table version is 8, local router ID is 200.200.200.66
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


*> 11.0.0.0 0.0.0.0 0 32768 i
*> 12.0.0.0 200.200.200.65 0 300 200 i
*> 193.10.2.0 200.200.200.65 0 0 300 i

Metric Si affiche, indique une mtrique du systme interautonome


LocPrf Prfrence locale, dfinie avec la commande set local-
preference. La valeur dfaut est de 100
Weight Poids d'une route, dfinie par les filtres de l'AS
Path Le chemin vers la destination

L. Stefenel 2008 61
Comment vrifer la confg BGP

Si un routeur BGP n'apparat dans les tables BGP, on peut utiliser


show ip bgp neighbors pour vrifer les connexions tablies
RTA#show ip bgp neighbors
BGP neighbor is 172.24.1.18, remote AS 200, external link
BGP version 4, remote router ID 172.16.1.1
BGP state = Established, up for 00:03:25
Last read 00:00:25, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received
Address family IPv4 Unicast: advertised and received
Received 7 messages, 0 notifications, 0 in queue
Sent 8 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
<output omitted>

L. Stefenel 2008 62
Voisinage BGP

Split Horizon Des routes apprises via IBGP ne sont pas


propages vers d'autres noeuds IBGP
Cela vite la formation de boucles de routage
Pour qu'un routeur IBGP apprend sur les autres routeurs IBGP
l'intrieur d'un AS, ils doivent tre connects en full mesh
Il suft qu'une connexion TCP soit possible, pas besoin d'tre
directement connect
L. Stefenel 2008 63
Synchronisation des AS

Quand un routeur IBGP reoit un update partir d'un pair IBGP, il


vrife cette destination avec un IGP, comme EIGRP ou OSPF.
Si le routeur IBGP ne peut pas trouver le rseau dans la table de
routage IGP, il n'annonce pas cette destinations aux autres
routeurs BGP.
L. Stefenel 2008 64
Synchronisation des AS

Si la route n'est pas atteignable via IGP, des routeurs non-BGP ne


seront pas capables de directionner le trafc qui traverse le AS vers
sa destination
Il est inutile d'annoncer des routes aux pairs externes si les
donnes envoyes travers cet AS seront rejets par un routeur
non-BGP tt ou tard
L. Stefenel 2008 65
Synchronisation des AS

La rgle de synchronisation BGP empche un routeur BGP (RTC)


d'annoncer aux pairs extrieurs (ISP2) les destinations
(192.213.1.0/24) apprises par un voisin intrieur (RTA) moins
que cette destination soit vrifable via IGP (RTD and RTB).
Si un routeur vrife la route via IGP, il assume que cette route a
dj t annonc dans l'AS et que le rseau est atteignable
L. Stefenel 2008 66
Synchronisation des AS

Si un routeur IBGP (RTC) a une route IGP vers cette destination, la


route est considre synchronise et la route sera annonc aux
autres pairs BGP (ISP2)

L. Stefenel 2008 67
Synchronisation des AS

L'injection d'une route BGP dans un AS est assez coteuse


La redistribution des routes BGP ver un IGP reprsente une
surcharge que certains routeurs ne sont pas capables de tolrer
une table BGP reprsente autour de 200MB
De plus, connatre toutes les routes BGP l'intrieur d'un AS n'est
pas ncessaire
L. Stefenel 2008 68
Synchronisation des AS

L'IOS Cisco a une option no synchronization


Cette commande donne la possibilit de propager des routes sans
les avoir vrif

L. Stefenel 2008 69
Synchronisation des AS

Dans la pratique, deux situations permettent d'arrter la synchonisation


sans danger :
Quand tous les routeurs dans l'AS sont des routeurs IBGP (et par
consquent totalement connects)
La liaison interne est garantie par l'interconnexion en mesh IBGP
Lorsque l'AS n'est pas un AS de passage
L. Stefenel 2008 70