Vous êtes sur la page 1sur 3

Configuration basique dun switch

Changer le nom du switch


On se met en mode privilgi, puis en mode configuration et on
rentre la commande host suivi du nouveau nom :
Switch>en
Switch#conf t
Switch(config)#host Switch1
Switch1(config)#

Configuration des mots de passe


Il est ncessaire de configurer des mots de passes pour le mode
privilge et console virtuelle. De plus lencryption doit tre
active.
Tout dabord pour activer lencryption la commande suivant doit
tre saisie :
Switch1(config)#service password-encryption

Ensuite pour activer le mot de passe afin daccder au mode


privilge :
Switch1(config)#enable secret Password
O Password est votre mot de passe

Puis on met un mot de passe afin daccder au routeur avant


mme dentrer en mode privilge :
Switch1(config)#line con 0
Switch1(config-line)#password P@ssw0rd
Switch1(config-line)#login
Switch1(config-line)#exit

Enfin, on cre un mot de passe pour laccs via Telnet :


Switch1(config)#line vty 0 15
Switch1(config-line)#password T3ln3t
Switch1(config-line)#login
Switch1(config-line)#end
Afficher une bannire lors de la
connexion
Pour afficher une bannire lors de la connexion, la commande
suivante doit tre saisie :
Switch1(config)#banner motd #
Enter TEXT message. End with the character '#'.
Acces interdit aux personnes non autorisees#
Switch1(config)#

VLAN & Routage inter-VLAN


Dans ce contexte nous utiliserons les VLANs suivants :
- VLAN EMPLOYE (20) : 192.168.20.0/24
- VLAN VISITEURS (30) : 192.168.30.0/24
Les manipulations sont faites sur du matriel CISCO, via
PacketTracer

Configuration des VLAN


Tout dabord, nous crons et nommons les VLANs
Switch>enable
Switch#conf t
Switch(config)#vlan 20
Switch(config-vlan)# name EMPLOYE
Switch(config-vlan)# exit
Switch(config)# vlan 30
Switch(config-vlan)# name VISITEURS
Switch(config-vlan)# exit

Puis nous affectons les interfaces aux VLANs


Switch(config)#int range fa0/1-10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#exit
Switch(config)#int range fa0/11-20
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#exit
Enfin nous passons linterface fa0/24 en mode trunk afin de
crer une liaison avec le routeur, et afin davoir des ports
tagus :
Switch(config)#int fa0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed 20,30

Maintenant nous passons sur le routeur, afin de crer des sous-


interfaces virtuelles en leur donnant une adresse afin quelles
puissent communiquer :
Router>en
Router# conf t
Router(config)#int fa0/1.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.254 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit
Router(config)#int fa0/1.30
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 192.168.30.254 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit

Pour finir nous enregistrons la configuration


Router#copy running-config startup-config