Vous êtes sur la page 1sur 8

CCIEv5 PPP Mega Lab By CCSI: Yasser Auda

PPP Lab

Task 1
Configure PPP connection between R3 & R2

R3
int s0/1
ip add 10.23.23.3 255.255.255.0
no sh
encap ppp

R2
int s0/1
ip add 10.23.23.2 255.255.255.0
encap ppp
no sh

R2#sh ip int br | i Serial0/1


Serial0/1 10.23.23.2 YES manual up up
R2#
CCIEv5 PPP Mega Lab By CCSI: Yasser Auda

Task 2 IPCP
-Configure R1 s0/0 to connect to R2 s0/0 using PPP
-R1 should provide ip address to R2 s0/0 and default route

R1
ip dhcp pool R2
network 10.12.12.0 255.255.255.0
default-router 10.12.12.21

interface Serial0/0
ip address 10.12.12.21 255.255.255.0
encapsulation ppp
peer default ip address dhcp-pool R2

R2
interface Serial0/0
ip address negotiated
encapsulation ppp
ppp ipcp route default

int s0/0
sh
no sh

R2#sh ip route | i 0.0.0.0/0


S* 0.0.0.0/0 [1/0] via 10.12.12.21

R2#sh ip int br | i Serial0/0


Serial0/0 10.12.12.1 YES IPCP up up

Internet Protocol Control Protocol (IPCP) is a Network Control Protocol (NCP) for establishing and
configuring Internet Protocol over a Point-to-Point Protocol link. IPCP is responsible for configuring the IP
addresses

unlike DHCP , IPCP will not send by default the default-gatway unless client ask for that by typing " ppp
ipcp route default"
CCIEv5 PPP Mega Lab By CCSI: Yasser Auda

Task 3 Multilink
Configure PPP multilink connection between R1 & R3 using s0/2 s0/3 , make sure connection will
never come up unless there is two links up in the bindle

R1
interface Multilink1
ip address 10.13.13.1 255.255.255.0
ppp multilink
ppp multilink links minimum 2 mandatory
ppp multilink group 1
ppp multilink fragment disable

interface Serial0/2
no ip address ppp multilink links minimum (#) (mandatory)
encapsulation ppp Specifies the required minimum number of links in a Multilink
ppp multilink PPP (MLP) bundle.
ppp multilink group 1 If the minimum number of links in the MLP bundle falls
below the number specified by the links argument, the MLP
int s0/3 bundle is disabled.
no ip address linksMinimum number of links, in the range from 0 to 255.
encapsulation ppp
ppp multilink
ppp multilink group 1

R3
interface Multilink1
ip address 10.13.13.3 255.255.255.0
ppp multilink
ppp multilink links minimum 2 mandatory
ppp multilink group 1
ppp multilink fragment disable

interface Serial0/2
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1

int s0/3
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1

R1#sh ip int br | i Multilink


Multilink1 10.13.13.1 YES manual up up
R1#
CCIEv5 PPP Mega Lab By CCSI: Yasser Auda

Task 4 PPPOE

-R1 & R4 connected to each other using fastethernet 0/0 , we want them use PPP by implementing
PPPOE
-R1 will act as server and should only allow tow sessions per mac
-R1 should provide ip address & default route 192.168.12.1to R4 using local pool named CLEINT
-R4 will act as client

R1 server
bba-group pppoe global
virtual-template 1
sessions per-mac limit 2
exit

interface virtual-template 1
ip address 192.168.12.2 255.255.255.0
mtu 1492
peer default ip address pool CLIENT
ip local pool CLIENT 192.168.12.1

interface FastEthernet 0/0


pppoe enable group global

R4 client
interface dialer 1
mtu 1492
encapsulation ppp
ip address negotiated
dialer persistent
dialer pool 1

interface FastEthernet 0/0


pppoe-client dial-pool-number 1

R1#sh ip int br | i Virtual


Virtual-Access1 unassigned YES unset up up
Virtual-Access1.1 192.168.12.2 YES TFTP up up
Virtual-Template1 192.168.12.2 YES manual down down
Virtual-Access2 unassigned YES unset down down
R1#

R4#sh ip int br | i Dialer1


Dialer1 192.168.12.1 YES IPCP up up
CCIEv5 PPP Mega Lab By CCSI: Yasser Auda

To get default route from R1 :

R4
int dialer 1
ppp ipcp route default

R4#sh ip route | i 0.0.0.0/0


S* 0.0.0.0/0 [1/0] via 192.168.12.2
R4#

Note if task ask R1 to provide ip address to R4 using dhcp instead of Local pool , we should do the
following:

R1
int virtual-temp 1
peer def ip address dhcp-pool POOL
exit

ip dhcp pool POOL


host 192.168.12.1 255.255.255.0
client-id

(you can know client-id by using debug ip dhcp server packer on the server)

R4
int dialer 1
ip add dhcp
exit
dialer-list 1 protocol ip permit
CCIEv5 PPP Mega Lab By CCSI: Yasser Auda

Explaining PPPOE commands

Server
PPPoE requires a BBA (BroadBand Access) group which is where you can configure session limitations
per client and such:

bba-group pppoe global


virtual-template 1
sessions per-mac limit 2

Refer to a virtual-template. This is where we configure the IP address and some other settings:

interface virtual-template 1
ip address 192.168.12.2 255.255.255.0
mtu 1492
peer default ip address pool CLIENT

Since PPPoE adds another header (8 bytes) we have to reduce the MTU size to 1492.

Define what IP address the client will receive. Im using a simple pool called CLIENT for this
You can also use DHCP if you want some more options

ip local pool CLIENT 192.168.12.1

Activate the BBA group on the interface:

interface FastEthernet 0/0


pppoe enable group global

Client
Requires a dialer interface:

interface dialer 1
mtu 1492
encapsulation ppp
ip address negotiated
dialer pool 1

Just like the server we set the MTU to 1492 and the IP address is negotiated since we receive it from
the server. The dialer persistent command ensures that our dialer always stays up. The dialer
interface refers to a pool number. well need it for the next part:

interface FastEthernet 0/0


pppoe-client dial-pool-number 1

debug ppp negotiation


sh pppoe session
CCIEv5 PPP Mega Lab By CCSI: Yasser Auda

PPP Authentication CHAP/PAP

One Way Authentication CHAP R1 will challenge R2

R1
Int s0/0
ppp authen chap < this command will challenge R2

username MYR2 pass cisco <R2 should answer with same value here

R2
Int s0/0
ppp chap hostname MYR2
ppp chap password cisco

Two Way Authentication CHAP (Both R1 & R2 will challenge each others)

R3
username MYR1 pass cisco

int s0/0
ppp authentication chap
ppp chap hostname MYR3
ppp chap password 0 cisco

R1
username MYR3 pass cisco

int s0/0
ppp authentication chap
ppp chap hostname MY1
ppp chap password 0 cisco

One Way Authentication PAP R3 will challenge R2

R3
ppp authentication pap
username IAMR2 password cisco

R2
ppp pap sent-username IAMR2 password cisco

Note : we can also do CHAP or PAP , one way or two way for Multilink interface in R1 & R3
CCIEv5 PPP Mega Lab By CCSI: Yasser Auda

Resources:
http://networklessons.com/cisco/introduction-to-ppp-on-cisco-ios-router/

http://networklessons.com/cisco/cisco-pppoe-server-configuration-example/

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/wan_mlp/configuration/xe-3s/wan-mlp-xe-3s-
book/wan_cfg_mlppp_conn_xe.html

Good Luck
CCSI: Yasser Auda
https://www.facebook.com/YasserRamzyAuda
https://learningnetwork.cisco.com/people/yasser.r.a?view=documents
https://www.youtube.com/user/yasserramzyauda

Vous aimerez peut-être aussi