Vous êtes sur la page 1sur 5

R1

*************************

interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
ip address 10.0.1.1 255.255.255.0
!
interface Loopback2
ip address 10.0.2.1 255.255.255.0
!
interface Loopback3
ip address 10.0.3.1 255.255.255.0

interface Serial2/0
ip address 192.168.0.1 255.255.255.252
serial restart-delay 0

interface Serial2/1
ip address 192.168.1.1 255.255.255.252
serial restart-delay 0

interface Serial2/2
ip address 192.168.5.1 255.255.255.252
serial restart-delay 0

router bgp 100


bgp log-neighbor-changes
network 10.0.0.0 mask 255.255.255.0
network 10.0.1.0 mask 255.255.255.0
network 10.0.2.0 mask 255.255.255.0
network 10.0.3.0 mask 255.255.255.0
neighbor WEIGHT peer-group
neighbor 172.16.0.1 remote-as 200
neighbor 172.16.0.1 ebgp-multihop 2
neighbor 172.16.0.1 update-source Loopback0
neighbor 172.16.0.1 weight 10
neighbor 172.16.1.0 remote-as 200
neighbor 172.16.1.0 peer-group WEIGHT
neighbor 192.168.0.2 remote-as 200
neighbor 192.168.0.2 next-hop-self
neighbor 192.168.1.2 remote-as 200
neighbor 192.168.5.2 remote-as 200

ip route 10.0.4.0 255.255.255.252 192.168.6.2


ip route 10.0.4.0 255.255.255.252 192.168.4.2
ip route 192.168.4.0 255.255.255.252 192.168.0.2
ip route 192.168.6.0 255.255.255.252 192.168.0.2

line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login

---------------------------------------------
hostname R2

no aaa new-model
no ip icmp rate-limit unreachable

ip tcp synwait-time 5

interface Loopback0
ip address 172.16.0.1 255.255.255.0

interface Loopback1
ip address 172.16.1.1 255.255.255.0

interface Loopback2
ip address 172.16.2.1 255.255.255.0

interface Serial1/0
ip address 192.168.1.2 255.255.255.252
serial restart-delay 0

interface Serial1/1
ip address 192.168.5.2 255.255.255.252
serial restart-delay 0

interface Serial1/2
ip address 192.168.2.1 255.255.255.252
serial restart-delay 0

interface Serial1/3
ip address 192.168.3.1 255.255.255.252
serial restart-delay 0

router ospf 1
network 192.168.2.0 0.0.0.3 area 0
!
router bgp 200
bgp log-neighbor-changes
network 172.16.0.0 mask 255.255.255.0
network 172.16.1.0 mask 255.255.255.0
network 172.16.2.0 mask 255.255.255.0
neighbor 10.0.0.1 remote-as 100
neighbor 10.0.0.1 ebgp-multihop 2
neighbor 10.0.0.1 update-source Loopback0
neighbor 192.168.1.1 remote-as 100
neighbor 192.168.2.2 remote-as 200
neighbor 192.168.2.2 next-hop-self
neighbor 192.168.3.2 remote-as 300
neighbor 192.168.3.2 next-hop-self
neighbor 192.168.5.1 remote-as 100

line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login

------------------------------------
hostname R3

no ip icmp rate-limit unreachable

no ip domain lookup

ip tcp synwait-time 5

interface Loopback0
ip address 172.16.3.1 255.255.255.0

interface Serial1/0
ip address 192.168.0.2 255.255.255.252
serial restart-delay 0

interface Serial1/1
ip address 192.168.4.2 255.255.255.252
serial restart-delay 0

interface Serial1/2
ip address 192.168.6.2 255.255.255.252
serial restart-delay 0

interface Serial1/3
ip address 192.168.2.2 255.255.255.252
serial restart-delay 0

router ospf 1
network 192.168.2.0 0.0.0.3 area 0
!
router bgp 200
bgp log-neighbor-changes
network 172.16.3.0 mask 255.255.255.0
neighbor 10.0.4.1 remote-as 300
neighbor 10.0.4.1 ebgp-multihop 2
neighbor 10.0.4.1 update-source Loopback0
neighbor 192.168.0.1 remote-as 100
neighbor 192.168.0.1 next-hop-self
neighbor 192.168.2.1 remote-as 200
neighbor 192.168.2.1 next-hop-self
neighbor 192.168.4.1 remote-as 300
neighbor 192.168.6.1 remote-as 300

line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login

------------------------------------------------
hostname R4

no ip icmp rate-limit unreachable

no ip domain lookup

ip tcp synwait-time 5

interface Loopback4
ip address 10.0.4.1 255.255.255.0

interface Loopback5
ip address 10.0.5.1 255.255.255.0

interface Loopback6
ip address 10.0.6.1 255.255.255.0

interface Loopback7
ip address 10.0.7.1 255.255.255.0

interface Serial1/0
ip address 192.168.4.1 255.255.255.252
serial restart-delay 0

interface Serial1/1
ip address 192.168.6.1 255.255.255.252
serial restart-delay 0

interface Serial1/2
ip address 192.168.3.2 255.255.255.252
serial restart-delay 0

router bgp 300


bgp log-neighbor-changes
network 10.0.4.0 mask 255.255.255.0
network 10.0.5.0 mask 255.255.255.0
network 10.0.6.0 mask 255.255.255.0
network 10.0.7.0 mask 255.255.255.0
neighbor 172.16.3.1 remote-as 200
neighbor 172.16.3.1 ebgp-multihop 2
neighbor 172.16.3.1 update-source Loopback4
neighbor 192.168.3.1 remote-as 200
neighbor 192.168.3.1 next-hop-self
neighbor 192.168.4.2 remote-as 200
neighbor 192.168.6.2 remote-as 200

no ip http server
no ip http secure-server
ip route 192.168.0.0 255.255.255.252 192.168.6.2
ip route 192.168.0.0 255.255.255.252 192.168.4.2

line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login

Vous aimerez peut-être aussi