Vous êtes sur la page 1sur 2

ESTRUCTURAS SELECTIVAS

Se evala una accin y en funcin del resultado, se realiza una opcin u otra.
IF CASE
Ejecuta una determinada accin cuando se cumple una Alternativa Mltiple ms de dos posibilidades.
condicin.
Simples (SI/ENTONCES Dobles (si-entonces-si_no / if- Segn_sea, caso de Segn_sea, caso Segn_sea,
IF/THEN) then -else) /Case Modelo 1 de /Case caso de /Case
Modelo 2 Modelo 3
Algoritmo 1. Inicio 1. Inicio Proceso prueba
2. Verificar condicin 2. Verificar condicin Segn A Hacer
1:
3. Si condicin es 3. Si condicin es Verdadera Escribir "Lunes";
Verdadera 4. Realizar Accion1 2:
4. Realizar Accion1 5. sino Accin 2 Escribir "Martes";
5. de lo contrario ir a paso 6. Fin 3:
Escribir "Mircoles";
6 De Otro Modo:
6. Fin Escribir "Fuera de Rango";
FinSegun
FinProceso
Pseudocdigo Si <condicin> entonces Si <condicin> entonces
<accion1> <accion1>
Fin_si Si_no
<accion2>
IF <condicion> then fin_si
<Accion1>
endif
DFD

Cdigo C++ If (condicin) if (condicin) switch (Var) {


{ { case 1:
sentencias Sentencia1; Accion1
} } break;
else case 2:
{ Accion2
Sentencia2; break;
} case 3:
Accion3
break;
default:
Accion_default
break;
}