Vous êtes sur la page 1sur 3

********************Router Main*********************

hostname Main

interface GigabitEthernet0/0
ip address 192.168.18.41 255.255.255.248
ip nat inside

interface Serial0/0/0
bandwidth 128
ip address 192.168.10.106 255.255.255.252
ip ospf cost 7500

interface Serial0/0/1
bandwidth 128
ip address 192.168.10.113 255.255.255.252
clock rate 128000

interface Serial0/1/0
ip address 198.51.100.1 255.255.255.240
ip access-group 101 in
ip nat outside

router ospf 10
router-id 2.2.2.2
passive-interface GigabitEthernet0/0
network 192.168.10.104 0.0.0.3 area 0
network 192.168.10.112 0.0.0.3 area 0
network 192.168.18.40 0.0.0.7 area 0

ip nat pool INTERNET 198.51.100.3 198.51.100.13 netmask 255.255.255.240


ip nat inside source list 1 pool INTERNET
ip nat inside source static 192.168.18.46 198.51.100.14

ip route 0.0.0.0 0.0.0.0 Serial0/1/0


ip route 192.168.200.0 255.255.252.0 Serial0/0/1

access-list 1 permit 192.168.45.0 0.0.0.255


access-list 1 permit 192.168.47.0 0.0.0.255
access-list 1 permit 192.168.200.0 0.0.3.255
ip access-list standard MANAGE
permit host 203.0.113.18
access-list 101 permit ip host 203.0.113.18 any
access-list 101 permit tcp any host 198.51.100.14 eq www
access-list 101 permit tcp any any established
access-list 101 deny ip any any

line vty 0 4
access-class MANAGE in
password class
login

***************Router Building-1*******************************

service password-encryption

hostname Building-1

enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0


ip dhcp excluded-address 192.168.45.1 192.168.45.20
ip dhcp excluded-address 192.168.47.1 192.168.47.20

ip dhcp pool VLAN45


network 192.168.45.0 255.255.255.0
default-router 192.168.45.1
dns-server 192.168.18.100
ip dhcp pool VLAN47
network 192.168.47.0 255.255.255.0
default-router 192.168.47.1
dns-server 192.168.18.100

no ip domain-lookup

interface GigabitEthernet0/0

interface GigabitEthernet0/0.45
encapsulation dot1Q 45
ip address 192.168.45.1 255.255.255.0

interface GigabitEthernet0/0.47
encapsulation dot1Q 47
ip address 192.168.47.1 255.255.255.0

interface GigabitEthernet0/0.101
encapsulation dot1Q 101
ip address 192.168.101.1 255.255.255.0

interface Serial0/0/0
description conexion al router Main
bandwidth 128
ip address 192.168.10.105 255.255.255.252
ip ospf cost 7500
clock rate 128000

router ospf 10
router-id 1.1.1.1
log-adjacency-changes
passive-interface GigabitEthernet0/0.45
passive-interface GigabitEthernet0/0.47
passive-interface GigabitEthernet0/0.101
network 192.168.10.104 0.0.0.3 area 0
network 192.168.45.0 0.0.0.255 area 0
network 192.168.47.0 0.0.0.255 area 0
network 192.168.101.0 0.0.0.255 area 0

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

banner motd ^Cwelcome^C

line con 0
password 7 0822404F1A0A
logging synchronous
login

line vty 0 4
password 7 0822404F1A0A
login
***********************Router Building2******************
hostname Building-2

interface Serial0/0/0
ip address 192.168.10.126 255.255.255.252

interface Serial0/0/1
bandwidth 128
ip address 192.168.10.114 255.255.255.252

router ospf 10
router-id 3.3.3.3
network 192.168.10.112 0.0.0.3 area 0
network 192.168.10.124 0.0.0.3 area 0

ip route 0.0.0.0 0.0.0.0 Serial0/0/1


ip route 192.168.200.0 255.255.252.0 Serial0/0/0
***********************SW1**********************************
hostname Blding1-Sw1

interface FastEthernet0/10
switchport access vlan 45
switchport mode access

interface FastEthernet0/15
switchport access vlan 47
switchport mode access

interface GigabitEthernet0/1
switchport mode trunk

interface GigabitEthernet0/2
switchport mode trunk

interface Vlan101
mac-address 00d0.bcb5.c401
ip address 192.168.101.2 255.255.255.0

ip default-gateway 192.168.101.1
*********************SW2****************************************
hostname Bldg1-SW2

interface FastEthernet0/3
switchport access vlan 45
switchport mode access

interface FastEthernet0/21
switchport access vlan 47
switchport mode access

interface GigabitEthernet0/1
switchport mode trunk

interface Vlan101
mac-address 00e0.8f3c.1001
ip address 192.168.101.3 255.255.255.0

ip default-gateway 192.168.101.1

Vous aimerez peut-être aussi