Vous êtes sur la page 1sur 28

Esto es extraido de MUM2009 QoS Megis.

voy a tratar de mostrarles paso por paso


como implementar este novedoso sistema de priorizar y dar una mejor calidad de
servicio, bueno teclados y mouse a la obra.

aqui el link original, para lo q quieran revisarlo.

http://mum.mikrotik.com/presentations/US09/megis_qos.pdf

Nota. Traduccion hechas por mi xD

P: Es posible priorizar trafico por tipo de cliente, mientras se hace restricion,


limitando por usuario en el mismo Router?
R: Si.

P:Que necesito para lograr esto?


R: Necesitaras.
1)Diagrama del flujo de paquetes. 2)HTB(queue tree). 3)Mangle. 4)PCQ. 5)Address
List.

MANGLE

Mable facilita la marcacion de paquetes especiales por IP


Estas marcas son usadas por las instalaciones de otro router como
enrutamiento y gestion de ancho de banda para identificar los paquetes
HTB - Hierarchical Token Bucket

Toda implementacion de gestion de ancho de banda en RouterOS esta basado


en Hierarchical Token Bucket (HTB)
HTB permite crear colas jerrquicas, estructurando y determinando las
relaciones entre colas
Los RouterOS soprtan 3 HTB vituales (Global-in, Global-out y Global-Total)
aqui el diagrama de flujo
Doble Calidad de Servicio

Es posible marcar y ajustar el trafico dos veces en el mismo router.

1. Mangle chain Prerouting - Primera Marcacion.


2. Global-in HTB - Primera Marcacion.
3. Mangle chain Forward o Postrouting - Segunda Marcacion
4. Global-out o Out-interface HTB - Segunda Marcacion

doble calidad de servicio solo es posible en queue tree


Por que no Simple Queue?

Simple Queue son ordenados - Similar a las normas del Firewall


1. Con el fin de llegar a la cola de paquetes 999 tendra q revisar primero los 998
anteriores

Cada Simple Queue puede estar separada por 3 colas.

1. One in Global-in (parte directa)


2. One in Global-out (parte de reserva)
3. One in Global-total (parte Total)
Queue tree

Queue Tree tiene direccin unica y se puede colocar en cualquiera de los HTBs
disponibles
Queue Tree no tiene ningn fin , todo el trafico se procesa simultaneamente
Todas las colas Hijas deben tener marcacion de paquetes en "/ip firewall
mangle"
Global-Out o Interface HTB?

En caso de SRC-NAT, Global-Out se dara cuenta de las direcciones de los


clientes provados, pero la interfaz HTB no, interfaz HTB es despues de SRC-NAT
Cada HTB solo recibe trafico que se deja a traves de una interfaz en particular -
no hay necesidad de separar la carga y descarga de mangle.
Conclusiones

Vamos a usar Mangle y Queue Tree:

Marcar el trafico por tipo en la cadena mangle "prerouting"


Priorizar y limitar el trafico por tipo de Global-in HTB
Vuelver a marcar el trafico de clientes en la cadena mangle Forward o
Postrouting
Limitar el trafico por cliente en la interfaz HTB
Es necesario mantener las reglas mangle en un minimo de colas para asi aumentar el
rendimiento de la misma

Limitar A los Clientes(aqui se viene lo bueno)

En esta ocacion vamos a crear 2 Tipos de clientes

1. Clientes VIP(2M)
2. Clientes Limitados (350K)
PCQ

Per Connection Queue, es un tipod e cola capaz de dividir el trafico en sub-


streams, sobre la base de clasificadores seleccionados.
Cada flujo Sub-Stream, entonces pasa por la cola FIFO, con el tamao de la
cola especifica por "PCQ-Limit" y la opcion de tasa maxima especificada por
"PCQ-rate".
Con el fin de asegurar que cada PCQ Sub-Stream representa un cliente en
particular necesitamos crear dos tipos de PCQ:

1. PCQ_upload - scr-address como origen clasificador


2. PCQ_downlaod - dst-address como desitino clasificador

PCQ distribuira el trafico disponible por igual entre los sub-queues hasta que la
tasa sea alcanzada(si se especifica)
CASO 1

1. Como podemos ver en la imagen estamos colocando al PCQ un rate de 128000


= 128K
2. En nuestra queue hemos especificado que el tipo de queue sea pcq-down y q
tenga un max limit de 512k.
3. como se puede ver en la imagen habiendo limitado por pcq a los clientes aun
rate de 128k y teniendo un max limit de 512k, cuando tengamos dos clientes
conectados cada uno recibir un maximo de 128k hasta completar los 512k del
max limit.
4. Entonces si se sobre pasara este max limite como podemos ver en al imagen
cuanod tenemos 7 usuario se dividira equitativamente este rate colocado.
5. Este es el primer caso si decidimos colocar un RATE a nuestro PCQ.
CASO 2
1. Aqui vemos q no hemos especificado el PCQ-Rate esta en 0
2. Al hacer esto como podemos ver en la imagen el 1er cliente conectado esta
recibiendo todo el max-limit ya especificado en el queue.
3. como podemos ver al ir incrementando los clientes se va repartiendo el ancho
de banda.
4. esto no es algo muy recomendado si es q no se esta usando un limite ya sea
por simple queue u otro, ya veran poco a poco el por q.
entonces ahora veremos los PCQ q necesitaremos.
Primero damos clic en el +.

1. Especificaremos el nombre q le daremos a nuestro PCQ en el caso de esta guia


seria asi.
o PCQ_Down_350K (Descarga)
o PCQ_Upload_256K(Subida)
2. En este cuadro especificamos el rate para cada opcion ya sea down o upload
o 350K Down
o 256K Up
3. Para down nosotros especificamos como queremos q califique nuestras
conexiones la mejor opcion es por address en este caso para Down debemos
colocar dst.address
4. para UP debemos oscojer scr.address
guardamos nuestra config dando aplicar y ok y listo ya tenemos configurada nuestras
PCQ(ojos agreguen las q ustedes vean convenientes y necesarias para esta guia
estamos usando 2.

Address Lists
Las Address List se introdujeron para asignar multiples direcciones IP/Rangos,
para la regla del firewall, de esta manera reducir el numero total de normas
firewall y aumentar el rendimiento del router.
Las Address List se pueden crear:

Manualmente
Automaticamente apartir del perfil PPP - solo se tiene q especificar al Address-
list de opciones y tan pronto como el cliente se conecte, se la aadir a la lista
de direcciones correcta.
Automaticamente a parir de RADIUS - Atributo "mikrotik:19".
Aqui la imagen de la config q necesitaremos

Como podran ver en la imagen estamos especificando un nombre en este caso


Cliente_350k y en el address debemos especificar al IP del cliente q tendra la
limitacion a 350K. para nuestra guia debes tmb crear un cliente de con la opcion
VIPcomo puede ven en al imagen yo tengo VIP y 350K
El Marcado de Paquetes

Use "connection-mark" para la accion de clasificar todos las conexiones basadas


en el address-list.
Use "packet-mark" para la accion de clasificar todo el trafico basado en marcas
de conexion.
Aqui comensaremos a hacer la conexion

Connection-mark

aqui es donde hacemos el llamado a nuestro address list para q pueda reconocer las
IPS de loc clientes y la categoria q usaran.
Packet-Mark
y todo quedaria de esta manera en mangle

una ves hecho esto ya es el turno de crear nuestras Queue Tree y q nuestro usuarios
comiencen a ser limitados.
como puden ver en las imagenes ya tenemos configurado prcticamente todo, aqui les
dejo tmb el export de esto.

Queue Tree

[ros]
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name="Total Download" parent=LOCAL priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name="Total Upload" parent=WAN priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Cliente_350k_down packet-mark=clientes_350K parent="Total
Download" priority=1 queue=PCQ_Down_350K
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Cliente_Vip_Down packet-mark=cliente_vip parent="Total Download"
priority=1 queue=PCQ_down_VIP
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Cliente_350k_up packet-mark=clientes_350K parent="Total Upload"
priority=1 queue=PCQ_up_256K
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Cliente_VIP_Up packet-mark=cliente_vip parent="Total Upload"
priority=1 queue=PCQ_up_VIP
[/ros]
Mangle

[ros]/ip firewall mangle


add action=mark-connection chain=postrouting comment="Clientes VIP" disabled
new-connection-mark=clientes_vip_conex passthrough=yes src-address-
list=Cliente_VIP
add action=mark-packet chain=postrouting connection-mark=clientes_vip_conex
disabled=no new-packet-mark=cliente_vip passthrough=no
add action=mark-connection chain=postrouting comment=Clientes disabled=no new-
connection-mark=clientes_conex passthrough=yes src-address-list=Cliente_350K
add action=mark-packet chain=postrouting connection-mark=clientes_conex
disabled=no new-packet-mark=clientes passthrough=no
[/ros]
para los que an leido la guia de megis como como se habran dado cuenta yo no estoy usando la opcion forward si no postrouting,
exactamente no se como describirlo pero bueno yo estoy usando PPPoE Client y al usarlo ya me negera reglas Forward y por ende
me quedan deshabitadas la de megis por eso uso postrouting, si ustedes no usan PPPoE client no ahi problema pueden usar
forward.

Bueno aqui la parte mas interesante de la guia y la parte un poco complicada al


principio.
debo dar gracias a lepumin por sacarme algunas dudas que tenia respecto al tema.

tan bien cabe resaltar q esta parte del tema no esta muy profundizada en la guia de
megis, es por eso q esto yo lo hago a mi manera, y recalco digo complicada por q
muchos de nosotros tendemos a pensar q al usar global-in siempre va ser solo para
subida, como me pasaba a mi xD y como veremos en lo siguiente are q sea lo mas
intuitivo posible y asi ustedes mismos puedan ir implementandolo.

Tarea:

Priorizar el Trafico?
Y por q hacerlo.

Buena pregunta, q muchos de nosotros nos hacemos...

Muchos de nosotros pensamos q priorizar es limitar (yo tmb pense lo mismo ), peor
no, no es lo mismo primero vamos a ver q pasa si es q no priorizamos.

Trafico no priorizado:

No se si les ha pasado q muchos de sus clientes los llaman y les dicen no puedo entrar
a ninguna web, pero ustedes notan q tienen algun programa P2P instalado y activo los
cuales muchos de neustros clientes solo lo instalan y no los limitan, bueno q pasa q
consume todo el ancho de banda asignado y por ende no puedo hacer mas nada.

otro caso les llama un cliente diciendoles no puedo navegar por q tengo el ping alto, si
el tipoco ping 192.168.1.1 si es el caso de su red, pero muchas veces no es por eso y
tmb suele suceder por los programas p2p y por algun virus.
Trafico Priorizado

Aqui con un trafico priorizado damos al cliente la calidad de servicio q necesita, ya q


podemos priorizar los http, streans, voip, y dar una baja prioridad a otros elementos,

Supongamos q ustedes son una empresa y en su empresa nadie tien por q jugar asi q
para q le va dar una priorridad a los juegos si loq usted necesita es q tenga prioridad
las web, voip o hasta aun VPN, y para sus clientes en hogares pues tiene hijos
pequeos y quisa son de jugar usted q cree.. bueno para esto es q sirve priorizar.

no siempre es conveniente hacer este tipo de priorizacion ya q tmb tienen q fijarse si


lo q pasa es q ahi un exceso de ancho de banda y loq te falta es eso y no es por un
tema de priorizacion, ya q si vees q no tienes mucho consumo pero vees q ahi algoq
falla ahi es donde uno puedo ir priorizando y es dodne se dara cuenta si realmente lo
necesita.

Bueno comencemos.

de acuerdo a la guia de megis nos da pequeas pautas de priozacion, como vemos en


al imagen siguiente
como vemos aqui dese el p2p q esta al final hasta las dns telnet http q esta al
principio.

aqui podemos ver una imagen de referencia de como podemos hacer una priorizacion
para lograr esto vamos a crear marcaciones en mangle con chain=prerouting para asi
poder priorizar el trafico con Global-in en la Queue Tree.

siguiente la imagen de arriba podramos hacer una prioridad de esta manera

Ensign_services (Priority=1)
User_requests (Priority=3)
Communication_services (Priority=5)
Download_services (Priority=7)
P2P_services (Priority=8)
entonces comencemos.

haciendo uso de la priorizacion por HTB q es la q vamos a usar.


Primero crearemos reglas en magle del tipo Packet como vemos en las imagenes
80=Http
luego de a ver creado estas reglas en mangle tan solo nos quedaria crear nuestras
reglas en Queue tree

para ellos crearemos una Cola q sera nuestro padre.

en este caso yo lo tengo con el nombre servicios con un max-limit de 512

y he creado una cola como hijo con el nombre http, parent=servicios, un max-limit de
512 y un limit-at de 160k
como podemos ver en la imagen

lo demas es lo mismo y no sera dificil de definir... y asi ustedes tmb pueden ir


aprendiendo.

Nota: Si es q alguien tubiera otra forma de como priorizar o quisa yo me este equivocando seria
muy bien recibida toda la informacin para asi mejorar esta sistema, muchas gracias y espero
alla sido de su entera utilidad.

Aqui el export Completo para q puedan ver como queda lo conveniente seria q puedan
hacerlo ustedes mismos asi aprenden pero de todos modos se los dejo aqui

Al final de las reglas q harn full cache a TC 7.1.

Queue Tree

[ros]/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name="Total Download" packet-mark="" parent=LAN priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name="Total Upload" packet-mark="" parent=WAN priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Clientes_down packet-mark=clientes parent="Total Download"
priority=1 queue=PCQ_Down_Clientes
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Cliente_Vip_Down packet-mark=cliente_vip parent="Total Download"
priority=1 queue=PCQ_Down_VIP
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Clientes_up packet-mark=clientes parent="Total Upload" priority=1
queue=PCQ_Up_Clientes
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Cliente_VIP_Up packet-mark=cliente_vip parent="Total Upload"
priority=1 queue=PCQ_Up_VIP
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=461k name=Servicios packet-mark="" parent=global-in priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=50k max-
limit=461k name=Msn_in packet-mark=msn_pkt parent=Servicios priority=2
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=461k name=Winbox_in packet-mark=winbox_pkt parent=Servicios priority=1
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=120k max-
limit=461k name=Youtube_in packet-mark=youtube_pkt parent=Servicios priority=8
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=160k max-
limit=461k name="Http Up" packet-mark=http_up_pkt parent=Servicios priority=1
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=64k max-
limit=461k name=TeamViewer packet-mark=teamviewer parent=Servicios priority=1
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=128k max-
limit=461k name=Https_Up packet-mark=https_pkt parent=Servicios priority=1
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1k max-
limit=461k name=Otros packet-mark=otros_pkt parent=Servicios priority=8
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=461k name=SSH packet-mark=ssh_pkt parent=Servicios priority=1
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=20k max-
limit=461k name=FTP packet-mark=ftp_pkt parent=Servicios priority=7
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=461k name=Telnet packet-mark=telnet_pkt parent=Servicios priority=7
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1k max-
limit=461k name=Talk packet-mark=google_pkt parent=Servicios priority=3
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1k max-
limit=2k name=P2P packet-mark=p2p_in parent=Servicios priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Sin_Limite_in packet-mark="" parent=global-in priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Sin_limite_out packet-mark="" parent=global-out priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=90k max-
limit=461k name=Http_Up2 packet-mark=http_up_pkt2 parent=Servicios priority=3
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=Dns_in packet-mark=dns_in parent=Sin_Limite_in priority=1
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name="ICMP in" packet-mark=icmp_in parent=Sin_Limite_in priority=1
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name="ICMP out" packet-mark=icmp_out parent=Sin_limite_out priority=1
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=ICMP_in2 packet-mark=icmp_in2 parent=Sin_Limite_in priority=1
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-
limit=0 name=ICMP_out2 packet-mark=icmp_out2 parent=Sin_limite_out priority=1
queue=default
add name=fullcache packet-mark=fullcache parent=global-out priority=8 max-
limit=5M queue=default
[/ros]

Ruta TC 7.1

[ros]/ip route
add check-gateway=ping gateway=10.0.0.222 routing-mark=thunder_route[/ros]
Mangle

Aqui estoy agrenado Las reglas de redireccion y Full cache para TC7.1 ojo deben
cambiar el valor DSCP por defecto esta en 18, reglas aadidas son la numero 3 y 10, si
no usas TC obvia esas.

[ros]/ip firewall mangle

add action=mark-routing chain=prerouting comment="Redireccion a Thunder"


disabled=no dst-port=80 in-interface=LAN protocol=tcp new-routing-
mark=thunder_route passthrough=yes

add action=mark-packet chain=prerouting comment="ICMP LAN" disabled=no in-


interface=LAN new-packet-mark=icmp_in passthrough=no protocol=icmpadd
action=mark-packet chain=postrouting disabled=no new-packet-mark=icmp_out out-
interface=LAN passthrough=no protocol=icmpadd action=mark-packet
chain=prerouting comment="ICMP WAN" disabled=no in-interface=WAN new-packet-
mark=icmp_in2 passthrough=no protocol=icmp
add action=mark-packet chain=postrouting disabled=no new-packet-mark=icmp_out2
out-interface=WAN passthrough=no protocol=icmp
add action=mark-packet chain=prerouting comment=DNS disabled=no dst-port=53
in-interface=LAN new-packet-mark=dns_in passthrough=no protocol=udp
add action=mark-packet chain=prerouting disabled=no dst-port=53 in-interface=LAN
new-packet-mark=dns_in passthrough=no protocol=tcp

add action=mark-packet chain=forward dscp=18 new-packet-mark=fullcache


passthrough=no

add action=mark-packet chain=prerouting comment="YouTube connection"


content=youtube disabled=no dst-address=74.125.0.0/16 in-interface=LAN new-
packet-mark=youtube_pkt passthrough=no
add action=mark-packet chain=prerouting disabled=no dst-
address=208.117.224.0/19 in-interface=LAN new-packet-mark=youtube_pkt
passthrough=no
add action=mark-packet chain=prerouting comment=Http connection-bytes=0-500000
disabled=no dst-port=80 in-interface=LAN new-packet-mark=http_up_pkt
passthrough=no protocol=tcp
add action=mark-packet chain=prerouting connection-bytes=500000-0 disabled=no
dst-port=80 in-interface=LAN new-packet-mark=http_up_pkt2 passthrough=no
protocol=tcp
add action=mark-packet chain=prerouting comment=Https disabled=no dst-port=443
in-interface=LAN new-packet-mark=https_pkt passthrough=no protocol=tcp
add action=mark-packet chain=prerouting comment="Google Talk" disabled=no dst-
port=5222 in-interface=LAN new-packet-mark=google_pkt passthrough=no
protocol=tcp
add action=mark-packet chain=prerouting comment=MSN disabled=no dst-port=1863
in-interface=LAN new-packet-mark=msn_pkt passthrough=no protocol=tcp
add action=mark-packet chain=prerouting comment=Telnet disabled=no dst-port=23
in-interface=LAN new-packet-mark=telnet_pkt passthrough=no protocol=tcp
add action=mark-packet chain=prerouting comment=SSH disabled=no dst-port=22
in-interface=LAN new-packet-mark=ssh_pkt passthrough=no protocol=tcp
add action=mark-packet chain=prerouting comment=FTP disabled=no dst-port=21 in-
interface=LAN new-packet-mark=ftp_pkt passthrough=no protocol=tcp
add action=mark-packet chain=prerouting comment=WinBox disabled=no dst-
port=8291,8292,8293 in-interface=LAN new-packet-mark=winbox_pkt
passthrough=no protocol=tcp
add action=mark-packet chain=prerouting disabled=no dst-port=20561 in-
interface=LAN new-packet-mark=winbox_pkt passthrough=no protocol=udp
add action=mark-packet chain=prerouting comment=P2P disabled=no in-
interface=LAN new-packet-mark=p2p_in p2p=all-p2p passthrough=no
add action=mark-packet chain=prerouting comment=Otros connection-limit=1,32
disabled=no in-interface=LAN new-packet-mark=otros_pkt packet-mark=no-mark
passthrough=no
add action=mark-connection chain=postrouting comment="Clientes VIP" disabled
new-connection-mark=clientes_vip_conex passthrough=yes src-address-
list=Cliente_VIP
add action=mark-packet chain=postrouting connection-mark=clientes_vip_conex
disabled=no new-packet-mark=cliente_vip passthrough=no
add action=mark-connection chain=postrouting comment=Clientes disabled=no new-
connection-mark=clientes_conex passthrough=yes src-address-list=Cliente_350K
add action=mark-packet chain=postrouting connection-mark=clientes_conex
disabled=no new-packet-mark=clientes passthrough=no
[/ros]

Queue Type

[ros]/queue type
add kind=pcq name=PCQ_Down_VIP pcq-burst-rate=0 pcq-burst-threshold=0 pcq-
burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-
address6-mask=128 pcq-limit=50 pcq-rate=2M pcq-src-address-mask=32 pcq-src-
address6-mask=128 pcq-total-limit=2000
add kind=pcq name=PCQ_Up_VIP pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-
time=10s pcq-classifier=src-address pcq-dst-address-mask=32 pcq-dst-address6-
mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-
mask=128 pcq-total-limit=2000
add kind=pcq name=PCQ_Down_Clientes pcq-burst-rate=0 pcq-burst-threshold=0
pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-
address6-mask=128 pcq-limit=50 pcq-rate=400k pcq-src-address-mask=32 pcq-src-
address6-mask=128 pcq-total-limit=2000
add kind=pcq name=PCQ_Up_Clientes pcq-burst-rate=0 pcq-burst-threshold=0 pcq-
burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 pcq-dst-
address6-mask=64 pcq-limit=50 pcq-rate=128k pcq-src-address-mask=32 pcq-src-
address6-mask=64 pcq-total-limit=2000
[/ros]