Vous êtes sur la page 1sur 5

Excel Exercice

Le meilleur site sur Excel


Accueil Contact FAQ Inscription/Connexion

Recherche Recherche

DiagrammedeGantt GAUCHEDROITESTXT

FonctionSOMME.SI.ENS
Condition,Intermdiaire ParFrdricLEGUEN Mai20,20177:37

SOMME SI ENS (Fonction Excel) FrdricLEGUEN

Dans notre exemple sur la gestion de stock de produits de beaut,


nous voudrions savoir la quantit restante en fin de mois pour le
rouge lvres ou encore le nombre de ventes ralis au cours du
mois pour un autre produit. La fonction SOMME.SI.ENS va nous
permettre de retourner cette information trs simplement.

Autant la fonction NB.SI.ENS ne pose gnralement pas de


problmes de comprhension, autant il mest arriv de constater que Start Download - View PDF
lapprentissage de la fonction SOMME.SI.ENS posait plus de Convert From Doc to PDF, PDF to Doc
Simply With The Free Online App!
difficult. Pourtant, les 2 fonctions sont extrmement proches dans
leur construction. Si vous comprenez NB.SI.ENS, il ny a aucune
raison que SOMME.SI.ENS vous pose des problmes.

Quand vous matriserez la cration de la fonction SOMME.SI.ENS, nous verrons les fonctions
MOYENNE.SI.ENS, MIN.SI.ENS et MAX.SI.ENS. Ces 2 dernires fonctions taient trs attendues
depuis de nombreuses annes et sont apparues seulement depuis la dernire version dExcel
2016. Si vous navez pas la dernire version dExcel sur votre ordinateur, vous pouvez nanmoins
utiliser la fonction en utilisant Excel Online

Sommaire Suivez Excel Exercice sur


Facebook
LafonctionSOMME.SI.ENS
Construction PageFacebook
Quantitfindemois
Combiendeventesralisesdanslemois
Nouveauxcritres
MOYENNE.SI.ENS
MAX.SI.ENSetMIN.SI.ENS

LafonctionSOMME.SI.ENS

Convert From Doc to


Start Download PDF, PDF to Doc Simply
- View PDF With The Free Online App!
Construction

La fonction SOMME.SI.ENS se construit exactement comme la fonction NB.SI.ENS.La seule chose


qui change, cest que vous allez indiquer dans les paramtres une colonne supplmentaire ; celle
qui contient les lments additionner. Cette colonne supplmentaire se positionne en
premire position des paramtres de la fonction.

=SOMME.SI.ENS(PlageadditionnerPlagedecritres1Critre1)


Utilisez le document suivant pour y copier toutes les formules qui vont suivre afin dy
afficherles diffrents rsultats retourns par les diffrentes fonctions.

Produit Produit Couleur Fournisseur StockM1 Achat Vente StockM Rsultat


REF_001 Rougelvres Rouge A 33 2 15 20
REF_002 Rougelvres Rose A 16 15 7 24
REF_003 Rougelvres Vert A 13 0 8 5
REF_004 Rougelvres Bleu A 35 4 8 31
REF_005 Vernisongle Rouge A 30 19 7 42
REF_006 Vernisongle Rose A 22 19 11 30
REF_007 Vernisongle Vert A 19 0 0 19
REF_008 Vernisongle Bleu A 34 2 1 35
REF_009 Vernisongle Jaune A 27 5 25 7
REF_010 Vernisongle Noir A 33 20 19 34
REF_011 FardPaupire Noir A 24 11 4 31
REF_012 FardPaupire Rose A 11 2 4 9
REF_013 FardPaupire Rouge A 25 19 5 39
REF_014 FardPaupire Jaune A 25 2 0 27
REF_015 FardPaupire Vert A 24 14 8 30

Quantit fin de mois

Nous souhaitons dterminer la quantit de rouge lvres en stock


la fin du mois. Depuis notre tableau des ventes nous allons
Start Download
construire une fonction NB.SI.ENS qui va comptabiliser le nombre - PDF Now
delignes qui contiennent le mot rouge lvres.
Convert From Doc to PDF,
PDF to Doc Simply With The
=NB.SI.ENS(B2:B41Rougelvres) => Rsultat 8
Free On-line App!
Plus quun rsultat, la fonction NB.SI.ENS nous indique que nous fromdoctopdf.com
avons correctement crit nos critres 8 Forts de ce constat, nous
allons transformer la fonction NB.SI.ENS en fonction SOMME.SI.ENS.
Dj, nous remplaons le terme NB par SOMME et nous rajoutons en premire position, la
colonne stock fin de mois. La fonction devient :

=SOMME.SI.ENS(H2:H41B2:B41Rougelvres) => Rsultat189


Les plages de critres et les critres tant les mmes entre une fonction NB.SI.ENS et la
fonction SOMME.SI.ENS, il est beaucoup plus simple de commencer par construire votre
fonction NB.SI.ENS pour sassurer que vos critres sont corrects et ensuite de rajouter le seul
lment qui manque la fonction SOMME.SI.ENS ; la colonne additionner.

Combien de ventes ralises dans le mois

Exactement de la mme manire si nous voulons connatre le nombre de vernis ongle que nous
avons vendus au cours du mois, nous allons dabord faire une fonction NB.SI.ENS sur le critre
vernis ongle et ensuite, rajouter la colonne des ventes.

La premire formule scrit

=NB.SI.ENS(B2:B41Vernisongle) => Rsultat12

La transformation avec SOMME.SI.ENS scrit


=SOMME.SI.ENS(G2:G41B2:B41Vernisongle) => Rsultat137

Nouveaux critres

Maintenant, si vous voulez rajouter dautres critres, il vous suffit de les rajouter aprs le dernier
critre dj prsent dans votre formule. Pour connatre la quantit de vernis ongle du
fournisseur A vendu au cours du mois, il faut crire la formule suivante

=SOMME.SI.ENS(G2:G41B2:B41VernisongleD2:D41A) => Rsultat63

Tout le reste de la fonction reste exactement identique.

MOYENNE.SI.ENS
La fonction MOYENNE.SI.ENS est en tout point identique la fonction SOMME.SI.ENS la
diffrence quici ce nest pas une somme qui va tre retourne mais la moyenne des donnes de
votre colonne en reprenant vos critres.

Reprenons la premire formule qui nous a donn le nombre de rouge lvres en stock. Si
maintenant nous voulons connatre la moyenne des rouges lvres en stock, il nous suffit de
replacer le mot SOMME par MOYENNE et sans changer le moindre paramtre, la fonction nous
retourne cette fois la valeur suivante

=MOYENNE.SI.ENS(H2:H41B2:B41Rougelvres)

Rsultat 23,6 tube de rouge lvres, par rfrence, en stock fin de mois.

MAX.SI.ENSetMIN.SI.ENS

Mise jour. Par rapport la vido, les fonctions ont t renommes

Ces 2 nouvelles fonctions sont apparues en fvrier 2016 et taient


attendues depuis trs longtemps. Tout comme nous lavons fait avec
SOMME.SI.ENS et MOYENNE.SI.ENS, ces deux fonction pour nous
permettre de retourner la valeur minimale ou maximale dune
colonne selon les critres que nous allons crire en paramtre.

Par exemple si vous voulons connatre la quantit minimale de vernis


ongle vendue au cours du mois nous allons crire

=MIN.SI.ENS(G2:G41B2:B41Vernisongle) => Rsultat 0

Et si nous voulons connatre la quantit maximale de vernis ongle vendue au cours du mois
nouscrirons

=MAX.SI.ENS(G2:G41B2:B41Vernisongle) => Rsultat28

Dans ces 2 exemples, nous navons utilis quun seul critre mais nous pouvons bien videmment
en rajouter si votre tableau de bord le ncessite.

tiquettes:SOMME.SI.ENS

1 ping
(12 commentaires) 1 ping Passerauformulairedecommentaire

MichaelIpert
18/03/201617:06(UTC1) Rpondre

Bonjour,
Pourlesdatesvousdemandezexceldechercherlesdatessuprieuresladatesdedbutetinfrieuresladatedefinmaiscelane
risquepasdadditionntouteslesdatessuprieuresaudbutcestdiremmecellessuprieuresladatedefinettouteslesdates
infrieuresladatedefincestdiremmecellesantrieuresladatededbut.oulafonctionfaitensortequetouteslesconditionssoit
runiessinonelleneffectuepasladdition?

Anonyme
28/11/201509:47(UTC1) Rpondre

vraimenttop.merci!

Anonyme
25/11/201510:57(UTC1) Rpondre

Bonjour.jutilisepourmapartdepuislongtempslafonctionsommeprod()etjaidumalvoirladiffrencedecomportemententreces
deuxfonctions.Pourriezvousmclairer?

Mercidevotreaide.

Cacaille76
23/09/201512:26(UTC1) Rpondre

Bonjour,Letutoestbontoutefoisunepetitequestion:estilpossibledenommerlesplages?
=somme.si.ens(chemin_repertoire\Nom_fichier!nom_feuille(mon_calcul)(chemin_repertoire\Nom_fichier!nom_feuille(ma_plage1)critre1
(chemin_repertoire\Nom_fichier!nom_feuille(ma_plage2)critre2
Mercidevotrereponce

FrdricLEGUEN
23/09/201513:23(UTC1) Rpondre

Bonjour,
Cestpossiblemaisilfautqueleclasseurquicontiennentlesdonnessoitouvertcestimpratif.

danbo52danbo
28/07/201508:44(UTC1) Rpondre

cestmieuxsilesentetessontdanslesexemplescolonnesetlignes

AlainRoussel
09/07/201500:23(UTC1) Rpondre

danslaformuleSomme.si.ensestcepossibledinsreruncritreavecunecomparaisondunevaleurquiseretrouvesuruneautrefeuille.
Voiciunexemple:
LaformuleSomme.si.ensestdansunecelluledelaFeuille1,maisunevaleurdecomparaisonpouruncritreseretrouvedanslaFeuille2.

=SOMME.SI.ENS(B1:B5C1:C5=LABELLED1:D5=Feuil2!A1)

Jessy
02/06/201506:45(UTC1) Rpondre

Bonjour

Mercipourcetutoriel.Demonctjaimeraisavoirsiilestpossibledutiliserdeuxrepriseslammeplagedecritre.Jevousmontremon
cas:voicimabase

ABCDE
GroupeSpcialCotunitaireQuantitCottotal
FruitsEnspcial$0,50502$251,00
PoissonEnspcial$0,70426$298,20
FruitsPrixrguliers$2,50583$1457,50
PoissonsEnspcial$2,00254$508,00
LgumesPrixrguliers$1,40532$744,80
FruitsPrixrguliers$1,90628$1193,20
LgumesEnspcial$1,20502$602,40
LgumesPrixrguliers$2,30498$1145,40
FruitsEnspcial$1,00504$504,00
LgumesEnspcial$1,40555$777,00
LgumesPrixrguliers$1,70467$793,90
PoissonEnspcial$2,80611$1710,80
FruitsPrixrguliers$3,20289$924,80
LgumesEnspcial$2,00420$840,00

Jaimeraidoncsavoirlecottotalpourlesfruitetdelgumesdanslammecellulesachantquemesdeuxcritressetrouvedansla
colonneA.
Quelquunauraitilunesolutionadquate,lajaidonnunexemple,maisdansmoncasrelenentreprise(contrledegestion)ilsagit
dunfichieravecplusde3000

Laurie
22/10/201509:52(UTC1) Rpondre

BonjourJessy,avezvoustrouvunesolutionpourutiliserlammeplagedecellulesavecplusieurscritres?carmoiaussije
souhaitefairesomme.si.ensavecuncritredansuneplageAetplusieurscritresdansuneplageB.

Mercidevotrerponse

Chico
14/05/201718:49(UTC1) Rpondre

Vouspourriezutiliseruncontrolequisemetvraioufauxselonvoscritresetutilisercedernierdansvotresomme.si.ens.

Anonyme
22/07/201322:43(UTC1) Rpondre

cool

Anonyme
10/03/201516:47(UTC1) Rpondre

mercidetoninterventionmimmimimimimi

Laisser un commentaire
Votreadressedemessagerieneserapaspublie.Leschampsobligatoiressontindiqusavec*

Message:*

VouspouvezutilisercesbalisesetattributsHTML:
<ahref=""title=""><abbrtitle=""><acronymtitle=""><b><blockquotecite=""><cite><code><del
datetime=""><em><i><qcite=""><s><strike><strong>

Nom:* Email* SiteWeb:

Soumettrelecommentaire

Copyright RetourenHaut
AllrightsreservedtoFLGConsultingServicesLtd(2017)

Conceptionsiteweb:Isidore,lemajordomeduNet