Vous êtes sur la page 1sur 8

Configurar Etherchannel

Publicado 04/14/2012 CCNA , CISCO 1 Comentario


Etiquetas: CCNA, CISCO, ETHERCHANNEL

Etherchannel es una tecnologa de CISCO que nos permite


realizar una agrupacin lgica de varios enlaces fsicos
ethernet para que estos enlaces sean tratados como un
nico enlace, permitiendo sumar la velocidad de cada
puerto y de esta forma lograr un enlace troncal de alta
velocidad.

Modos de configuracin
Negociacin
o PAgP Port Aggregation Protocol
o LACP Link Aggregation Control Protocol
Manual
o Mode ON

En los modos PAgP y LACP el switch negocia con el otro


extremo cuales son los puertos que deben ponerse activos.

En el modo Mode on, todos los puertos se ponen activos.

Configuracin de Etherchannel
En el ejemplo, vamos a ver cmo configurar Etherchannel
en modo manual con mode on. Tenemos dos switches
(CHIP y CHOP) conectados entre s en cuatro de sus
puertos (fa0/1, fa0/2, fa0/3 y fa0/4). Lo primero que
vamos hacer es ingresar en el modo de configuracin de
interfaz, e indicar el grupo y el modo de configuracin del
etherchannel.

CHIP# configure terminal


CHIP(config)# interface range fastethernet 0/1 4
CHIP(config-if-range)# channel-group 1 mode on
CHIP(config-if-range)# exit
CHIP(config)# exit

Configuramos el mismo modo y grupo en el otro extremo.

CHOP# configure terminal


CHOP(config)# interface range fastethernet 0/1 4
CHOP(config-if-range)# channel-group 1 mode on
CHOP(config-if-range)# exit
CHOP(config)# exit

Para configurar etherchanel como enlace troncal, hacemos


lo siguiente.

CHIP(config)# interface port-channel 1


CHIP(config-if)# switchport mode trunk
CHIP(config-if)# exit
CHIP(config)# exit

Y hacemos lo mismo en el otro extremo.


CHOP(config)# interface port-channel 1
CHOP(config-if)# switchport mode trunk
CHOP(config-if)# exit
CHOP(config)# exit

Y por ltimo hacemos una breve comprobacin mediante el


siguiente comando.

CHOP(config)# show etherchannel port-channel

Que nos arrojar una salida similar a la de la captura.


Como hacer un etherchannel con 2 switches en
Packet tracer 5
Posted on June 26, 2011 | Leave a comment

Me parecio extrao encontrar poca informacin escrita en espaol acerca de como hacer un
etherchannel utilizando Packet Tracer, asi que aca voy a escribir los comandos para que queden
para la posteridad y screenshots para ir viendo como deberia de quedarnos nuestro
etherchannel.

Primero, que es etherchannel?


Bueno, etherchannel es una tecnologia que toma 2 switches y hace un link entre ellos, para
conmutar la seal que pasa a traves de ellos y agrandar la velocidad de comunicacion 2, 4 y
hasta 8 veces, creando asi un canal de alta velocida y balanceando la carga de comunicacion.
Primero usamos 2 switches que se van a mandar la informacin entre ellos, y hacemos 2 links
de cable cruzado entre ellos.

Haciendo el link entre los 2 switches


Ingresamos a la configuracin de nuestro primer switch y damos los comandos abajo descritos.
Para esto hacemos click sobre nuestro switch, nos pasamos a la lengueta de CLI y presionamos
enter y luego ingresamos los comandos:

Switch>enable
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#spanning-tree mode rapid-pvst
Switch(config)#spanning-tree portfast default
Switch(config)#exit

%SYS-5-CONFIG_I: Configured from console by console


Switch#

Luego juntamos esto con 2 routers, uno de cada lado o uno a cada switch por asi decirlo; ya que
esta nueva configuracion de los switches se conoce como multi-layer-switch.

los router conectados a cada extremo del multi-layered switch


Con sh spanning-tree o show spanning-tree procedemos a ver la vlan que se configuro dentro
de nuestro multi-layered-switch.

Switch#show spanning-tree
VLAN0001
Spanning tree enabled protocol rstp
Root ID Priority 32769
Address 0001.4391.C03E
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)


Address 0001.4391.C03E
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type


---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p

Switch#

Configuramos ambos switches de la misma manera, creando el canal en el rango de los puertos
donde hicimos el etherchannel fsicamente.

Switch>enable
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int port
Switch(config)#int port-channel 1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#int ran f0/1-2
Switch(config-if-range)#channel-group 1 mode auto

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to


down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to
up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to
down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to
up
Switch(config-if-range)#exit
Switch(config)#
Con esto realizado, tenemos que tener en cuenta que el rango de interfaces debe ser donde
pusimos nuestros cables cruzados, en este caso, la f0/1 y 2.

Con show etherchannel miramos la configuracion que realizamos del canal.

Switch#show etherchannel
Channel-group listing:
----------------------

Group: 1
----------
Group state = L2
Ports: 2 Maxports = 8
Port-channels: 1 Max Portchannels = 1
Protocol: PAGP
Switch#

Ahora que tenemos nuestro etherchannel arriba, vamos a configurar los routers con sus
respectivas direcciones IP.

Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to
up
Router(config-if)#ip add 10.10.0.1 255.255.255.0
Router(config-if)#exit
Teniendo cuidado de cambiar la IP en el segundo router.
Terminamos haciendo un ping entre routers para verificar la velocidad de conexion entre ellos.

Router#ping 10.10.0.2

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.10.0.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 5/10/14 ms

Router#
Y asi se miraria nuestra configuracion del etherchannel en Packet tracer:
Resultado final

Y esto para que me sirve?


El etherchannel es funcional para generar velocidades mas altas de conexion entre 2 switches y
todo lo que este unido a ellos. Lo que nos puede servir como ejemplo, seria tener esta
configuracion para realizar una conexion ultra-rapida entre nuestro servidor de base de datos y
el servidor de replicacion de la BD o generar conexiones muy rapidas entre 2 puntos para, no
se, jugar Counter-Strike con cero de latencia XD.

Eso si, para que esto sea funcional debemos de tener tarjetas de red que soporten esta capacidad
de envio/recepcion.