Vous êtes sur la page 1sur 17

En el presente trabajo se encuentran 5 ejercicios de algoritmos, cada uno con lo

que el problema pide. Asimismo, servir como gua de estudio y repaso para el
prximo examen de Algoritmos de Programacin Bsica.
SERIE DE ALGORITMOS
1. A travs de un pseudocdigo y un diagrama de flujo queremos hacer la
siguiente encuesta a 100 personas:
Tienen televisin o no la tienen. Contar los que tienen y los que no tienen.
Es de alta definicin o no los es. Contarlos.
Si no tienen T.V. pregunte si piensan comprar o no. Contarlos.
Hallar los tantos por ciento de TODO.
2. Introducir el nmero de alumnos de un grupo y contabilizar por separado en
qu sector de Guadalajara viven o si en su defecto viven en otro municipio;
para tal efecto se mostrarn las siguientes opciones:
R) Reforma
H) Hidalgo
L) Libertad
J) Jurez
O) Otro municipio
Dnde vives?
3. Una compaa dedicada al alquiler de automviles cobra un monto fijo de
$30 para los primeros 300 km de recorrido. Para ms de 300 km y hasta 1000
km, cobra un monto adicional de $ 0.15 por cada kilmetro en exceso sobre
300. Para ms de 1000 km cobra un monto adicional de $ 0.10 por cada
kilmetro en exceso sobre 1000. Los precios ya incluyen el 14% del IVA.
Disee un pseudocdigo y un diagrama de flujo que determinen el monto a
pagar por el alquiler de un vehculo y el monto incluido del impuesto.
4. En una clase hay 30 alumnos y cada uno de ellos tiene 4 calificaciones,
correspondientes a 4 diferentes materias. Un pseudocdigo y un diagrama
de flujo que calcule e imprima:
A) El promedio de cada alumno.
B) El promedio general de la clase (promedio de los promedios).
C) El nmero de alumnos condicionados, es decir, cuntos alumnos tienen ms de
2 materias reprobadas (con nota inferior a 6)
5. Una tienda desea obtener un reporte de las ventas realizadas en un da.
Elabore el pseudocdigo y diagrama de flujo que:
a) Solicite el monto de cada venta sin IVA,
b) Para cada venta, calcule e imprima el IVA y el total con IVA,
c) Al terminar el da, imprima los totales de:
* Ventas sin IVA,
* IVA, * Ventas con IVA,
* Promedio de las ventas con IVA.
Considere que el nmero de ventas que se realizaron fueron 124. Suponga que el
IVA es del 16%. Elabore un pseudocdigo y un diagrama de flujo que emitan el
reporte.
1. A travs de un pseudocdigo y un diagrama de flujo queremos hacer la
siguiente encuesta a 100 personas:
Tienen televisin o no la tienen. Contar los que tienen y los que no tienen.
Es de alta definicin o no los es. Contarlos.
Si no tienen T.V. pregunte si piensan comprar o no. Contarlos.
Pseudocdigo

Algoritmo encuesta
Definir cont_1,cont_2, cont_3,cont_4, cont_5,cont_6,i Como Entero
Definir tv, definicin, compra como caracter
cont_1<-0
cont_2<-0
cont_3<-0
cont_4<-0
cont_5<-0
cont_6<-0
Para i<-1 Hasta 100 Con Paso 1 Hacer
Escribir "Buen da, por favor, responda esta encuesta " i
Escribir "Cuenta con una televisin en casa? (Responda Si o
No)"
leer tv
Segun tv Hacer
'Si','SI', 'si':
cont_1<-cont_1+ 1
Escribir "Su Tv es de alta definicin?(Responda
Si o No)"
Leer definicin
Segun definicin Hacer
'Si','SI', 'si':
cont_2<-cont_2 +1
'No', 'NO','no':
cont_3<-cont_3 +1
De Otro Modo:
Escribir "Error"
Fin Segun
'No', 'NO','no':
cont_4<-cont_4 + 1
Escribir "Piensa comprar una TV? (Responda Si
o No)"
Leer compra
Segun compra Hacer
'Si','SI','si':
cont_5<-cont_5 +1
'No','NO','no':
cont_6<-cont_6 +1
De Otro Modo: Escribir "Error"
Fin Segun
De Otro Modo:
Escribir "Error"
Fin Segun
Escribir "Gracias por su participacion"
Fin Para
Escribir "De los encuestados, el " , (cont_1*100)/100, "% tienen TV y
el " ,(cont_4*100)/100, "% no tienen TV."
Escribir "De los que si tienen TV, " ,(cont_2)*100/cont_1, "% cuentan
con TV de alta definicin y el " ,(cont_3)*100/cont_1, "% no tiene."
Escribir "De los que no tienen TV, " ,(cont_5)*100/cont_4, "% piensan
comprar una TV y el " ,(cont_6)*100/cont_4, "% no."
FinAlgoritmo
Ejecucin

2. Introducir el nmero de alumnos de un grupo y contabilizar por separado en


qu sector de Guadalajara viven o si en su defecto viven en otro municipio;
para tal efecto se mostrarn las siguientes opciones:
R) Reforma
H) Hidalgo
L) Libertad
J) Jurez
O) Otro municipio
Dnde vives?
Pseudocdigo
Algoritmo Guadalajara
Definir cont_r, cont_h, cont_l, cont_j, cont_otro,i,alumnos Como Entero
definir sector Como Caracter
cont_r=0
cont_h=0
cont_l=0
cont_j=0
cont_otro=0
escribir "ingrese el numero de alumnos del grupo a contabilizar"
leer alumnos
Para i<-1 Hasta alumnos Con Paso 1 Hacer
escribir "En qu sector de Guadalajara vive? R) Reforma,H)
Hidalgo,L) Libertad,J) Jurez,O) Otro municipio"
leer sector
Segun sector Hacer
'R','r':
cont_r=cont_r+1
'H','h':
cont_h=cont_h+1
'L','l':
cont_l=cont_l+1
'J','j':
cont_j=cont_j+1
'O','o':
cont_otro=cont_otro+1
Fin Segun
Fin Para
escribir "de los " ,alumnos, " alumnos encuestados " , cont_r , " viven en el
sector Reforma"
escribir cont_h, " viven en el sector Hidalgo"
escribir cont_l, " viven en el sector Libertad"
escribir cont_j, " viven en el sector Jurez"
Escribir cont_otro, " viven en otro sector"
FinAlgoritmo
Ejecucin

3. Una compaa dedicada al alquiler de automviles cobra un monto fijo de


$30 para los primeros 300 km de recorrido. Para ms de 300 km y hasta 1000
km, cobra un monto adicional de $ 0.15 por cada kilmetro en exceso sobre
300. Para ms de 1000 km cobra un monto adicional de $ 0.10 por cada
kilmetro en exceso sobre 1000. Los precios ya incluyen el 14% del IVA.
Disee un pseudocdigo y un diagrama de flujo que determinen el monto a
pagar por el alquiler de un vehculo y el monto incluido del impuesto.

Pseudocdigo
Algoritmo renta_autos
definir distancia, monto,precio,impuesto Como Real
precio=30
escribir "ingrese la distancia a recorrer"
leer distancia
Si distancia<=300 Entonces
monto=30
Sino
si distancia>300 y distancia<=1000 Entonces
monto=30+((distancia-300)*0.15)
Sino
si distancia>1000 entonces
monto=30+((distancia-1000)*0.10)
FinSi
FinSi
Fin Si
escribir "el monto a pagar es de " monto
impuesto=monto-(monto*0.86)
escribir "el monto incluido del impuesto es de " impuesto
FinAlgoritmo
Ejecucin

Realic la ejecucin del algoritmo con 3 pruebas diferentes con base en las
condiciones del mismo. Si se hacen manualmente las operaciones del algoritmo, se
comprueba que los resultados que imprime el algoritmo son correctos.
Diagrama de flujo
Ejecucin en DFD

Igual que en la ejecucin de PseInt, realic la comprobacin con 3 valores diferentes


y cumplen con las condiciones planteadas en el problema.

4. En una clase hay 30 alumnos y cada uno de ellos tiene 4 calificaciones,


correspondientes a 4 diferentes materias. Un pseudocdigo y un diagrama
de flujo que calcule e imprima:
A) El promedio de cada alumno.
B) El promedio general de la clase (promedio de los promedios).
C) El nmero de alumnos condicionados, es decir, cuntos alumnos tienen ms de
2 materias reprobadas (con nota inferior a 6)
Pseudocdigo
Algoritmo alumnos
definir prom_alu,prom_clase,calif1,calif2,calif3,calif4 como real
definir cont_cond,cont_alu,i como entero
cont_cond=0
suma_prom=0
Para i<-1 Hasta 30 Con Paso 1 Hacer
escribir "ingrese la calificacion 1 del alumno " i
leer calif1
escribir "ingrese la calificacion 2 del alumno " i
leer calif2
escribir "ingrese la calificacion 3 del alumno " i
leer calif3
escribir "ingrese la calificacion 4 del alumno " i
leer calif4
prom_alu=(calif1+calif2+calif3+calif4)/4
escribir "el promedio del alumno " i " es " prom_alu
suma_prom=suma_prom+prom_alu
si prom_alu<=6.25 Entonces
cont_cond=cont_cond+1
FinSi
Fin Para
prom_clase=suma_prom/30
escribir "el promedio de la clase es " prom_clase
escribir "la cantidad de alumnos condicionados es: " ,cont_cond
FinAlgoritmo

Ejecucin
Realic la ejecucin para 3 alumnos, ya que es una ejecucin prueba y no cre
necesario meter los 30 datos que pide, aun as, los resultados son correctos.
Diagrama de flujo
Ejecucin en DFD
Para DFD, tambin hice la prueba con 3 alumnos:

5. Una tienda desea obtener un reporte de las ventas realizadas en un da.


Elabore el pseudocdigo y diagrama de flujo que:
a) Solicite el monto de cada venta sin IVA,
b) Para cada venta, calcule e imprima el IVA y el total con IVA,
c) Al terminar el da, imprima los totales de:
* Ventas sin IVA,
* IVA, * Ventas con IVA,
* Promedio de las ventas con IVA.
Considere que el nmero de ventas que se realizaron fueron 124. Suponga que el
IVA es del 16%. Elabore un pseudocdigo y un diagrama de flujo que emitan el
reporte.
Pseudocdigo
Algoritmo tienda
definir monto_sin_iva, iva_venta ,total_con_iva, suma_sin_iva, suma_iva,
suma_con_iva, prom_con_iva como real
suma_con_iva=0
suma_iva=0
suma_sin_iva=0
Para i<-1 Hasta 124 Con Paso 1 Hacer
escribir "ingrese el monto de la venta " ,i, " sin IVA"
leer monto_sin_iva
iva_venta=(monto_sin_iva)-monto_sin_iva*0.84
total_con_iva=iva_venta+monto_sin_iva
escribir "el iva de la venta " i " es: " iva_venta " y el total de la
venta con iva es de: " total_con_iva
suma_sin_iva=suma_sin_iva+monto_sin_iva
suma_iva=suma_iva+iva_venta
suma_con_iva=suma_con_iva+total_con_iva
finpara
escribir "las ventas sin iva son de: " suma_sin_iva
escribir "el iva total es de: " suma_iva
escribir "las ventas con iva son de: " suma_con_iva
prom_con_iva=suma_con_iva/124
escribir "el promedio de las ventas con iva es de: " prom_con_iva
FinAlgoritmo

Ejecucin
Como se tenan que hacer 124 repeticiones, cambi el ciclo para hasta 3, ya que
la ejecucin fue una prueba de que el pseudocdigo corriera adecuadamente.
Diagrama de flujo
Ejecucin en DFD
Igualmente, hice la prueba para 3 compras.
Durante la elaboracin de esta serie, tuve algunas complicaciones respecto a
declaracin de variables y contadores, as como problemas mnimos como comas,
comillas, etc.
El presente trabajo me sirvi como gua de apoyo y repaso de elaboracin de
pseudocdigos y diagramas de flujo.