Vous êtes sur la page 1sur 3

UNIVERSIDAD POLITECNICA SALESIANA

Carrera de Ingeniera Mecnica Automotriz


Programacin I
Ing. Jorge Barros

Ejercicios: Realizar los algoritmos (Diagrama de flujo y


pseudocdigo) para resolver los siguientes problemas:

1. Mostrar todos los nmeros divisibles para 3 entre 10 y 25


2. Dado el trmino n calcular el total de la sumatoria:
5/1 + 5/2 + 5/3 + 5/4 + 5/n
3. Dada n notas calcular el promedio de las notas aprobadas
y el promedio de las notas reprobadas. Aprobadas >= 70.

Anlisis del problema:


Entrada de datos
Notas(n)
Proceso
Ingresar nota y compara si es mayor o igual a 70 si se cumple esta condicin
acumulamos aprobamos caso contrario acumulamos la nota de los alumnos
reprobados. Calcular el promedio de notas aprobadas y reprobadas
Salida
Promedio de notas aprobadas y reprobadas.
Diagrama de flujo:

Seudocdigo
Algoritmo promedio
Var
Entero n, cantA,canR,I
Real nota, sumaA, sumaR, proA, proR
Inicio
Escribir ingrese nota
Leer n
CantR=0
cantA=0
sumaA=0
sumaR=0
mientras I<n
leer nota
si nota>=70 entonces
suma A= sumaA+nota
cantA=cantA+1
si_no
sumaR= sumaR+nota
contR= contR +1
fin_si
I=I+1
Fin_mientras
PromA=sumaA/ cantA
PromR= sumaR/cantR
Escribir promedio aprobadospromA
Escribir promedio reprobadospromR

fin

1. Hacer el algoritmo para un programa que imprima el mayor


y el menor de 8 nmeros ingresados por teclado.

Anlisis del problema:


Entrada de datos
Ingreso de numero por teclado
Proceso
Compara si son num >8 o num<8
Salida
Mostrar en pantalla numero mayores ymenores a 8
Diagrama de flujo:

Seudocdigo
Algoritmo promedio
Var
Entero n, cantA,canR,I
Real nota, sumaA, sumaR, proA, proR

2. Hacer el algoritmo para un programa, que calcule y muestre


las reas de un terreno rectangular de lados 100-2x y x
respectivamente, para valores de x entre 10 y 30

<>
3. Elaborar un algoritmo que permita ingresar n nmeros y
muestre todos los nmeros menores e iguales a 25.
4. Escriba el algoritmo para un programa que imprima la suma
de 15 elementos de la serie: 1/2 +3/4 +7/8 +15/16.
5. Las potencias de 2 son: 1, 2, 4, 8,16,..... Para obtener
la siguiente potencia se multiplica la anterior por 2.
Escribir el algoritmo para un programa que imprima la
primera potencia de 2 que pasa de 1000.