Vous êtes sur la page 1sur 7

a) Solicitar al usuario el ingreso de un nmero, validar si es positive

Anlisis del problema

Dado un nmero ingresado por teclado el programa debe determinar si es positivo, como nos
pide usar la estructura de repetir el programa va a seguir pidiendo nmeros hasta un nmero
dado por el usuario sea 0 dado que este no es ni positivo ni negativo.

Diagrama de Flujo

Seudocdigo

Algoritmo numero_positivo

Var
real: num
Inicio
escribir ingrese un numero:
leer num
repetir
si num>0 entonces
escribir el nmero es positivo
si_no
escribir ingrese otro nmero:
leer num
fin_si
hasta_que num=0
Fin

Prueba de escritorio
num num>0 SI num = 0
2 si elnumero es positivo no
-3 no no
4 si elnumero es positivo no
0 no si

b) Calcule el promedio de N nmeros ingresados por teclado e imprima su resultado

Anlisis del problema

Pide que elaboremos un programa que de l promedio de los nmeros ingresados por
teclado, para esto se ocupa un contador que guarde el nmero total de cantidades
ingresadas y otra variable que sume estas cantidades para al final realizar la operacin.

Diagrama de Flujo
Seudocdigo

Algoritmo promedio

Var
real: num, suma, promedio
entero: i, N
Inicio
escribir ingrese la cantidad de nmeros:
leer N
i <- 0
suma <- 0
repetir
escribir ingrese un numero:
leer num
suma = suma + num
i=i+1
hasta_que i = N
prom = suma/N
escribir El Promedio es: , prom
Fin

c) Solicite el ingreso de 2 nmeros, asegrese que el segundo sea distinto de cero elabore
un men cuyas opciones sean sumar, restar, multiplicar, dividir y potenciar ambos
nmeros. Muestre en pantalla el resultado.

Prueba de escritorio

Anlisis del problema

Pide que elaboremos un programa que se tiene que verificar si el segundo nmero es 0 en
caso contrario tocara pedir de nuevo el nmero, ya con los dos nmeros realizar las
operaciones de acuerdo al requerimiento del usuario.

Diagrama de Flujo

Seudocdigo

Algoritmo menu_operaciones

Var
real: a, b, sum, dif, prod, div, pot
entero: menu
Inicio
escribir ingrese el primer nmero:
leer a
escribir ingrese el segundo nmero (distinto de 0):
leer b
si b=0 entonces
escribir ingrese el segundo nmero (distinto de 0):
leer b
fin_si
repetir
escribir ingrese el nmero correspondiente a la operacin a realizar:
1 sumar
2 restar
3 multiplicar
4 dividir
5 potencia
6 salir del programa
leer menu
si menu = 1 entonces
sum = a+b
escribir a+b= , sum
si_no
si menu = 2 entonces
dif = a-b
escribir a-b= , dif
si_no
si menu = 3 entonces
prod = a*b
escribir a*b= , prod
si_no
si menu = 4 entonces
div = a/b
escribir a/b= , div
si_no
si menu = 5 entonces
pot = a^b
escribir a^b= , pot
fin_si
fin_si
fin_si
fin_si
fin_si
hasta_que menu = 8
Fin

d) Solicitar el ingreso de un numero N, determine cuntos de ellos son pares y cuantos


impares, muestre por pantalla su resultado.

Anlisis del problema

Despus de ingresar un numero n cualquiera de nmeros enteros el programa debe


diferenciar cuales son pares o impares, contabilizando cuntos de estos hay en total
respectivamente.

Diagrama de Flujo
Seudocdigo

Algoritmo pares_impares

Var
entero: n_par, n_impar, N, num
Inicio
escribir ingrese la cantidad de nmeros:
leer N
n_par <- 0
n_impar <- 0
repetir
escribir ingrese un numero:
leer num
si num mod 2 = 0 entonces
n_par = n_par +1
si_no
n_impar= n_impar +1
fin_si
i=i+1
hasta_que i = N
escribir cantidad de pares: , n_par
escribir cantidad de impares: , n_impar
Fin

Prueba de escritorio

si no
n_par n_impar num num mod 2=0 n_par=n_par +1 n_impar=n_impar +1 i=i+1 i=N
0 0 3 no 0 1 1 no
0 1 2 si 1 1 2 no
1 1 4 si 2 1 3 no
2 1 6 si 3 1 4 si

n_par 3
n_impar 1