Vous êtes sur la page 1sur 59

VLAN Trunking

CCNA 3 version 3.1


Philippe Dastroy
IEPSA janvier 2007
VLAN Tagging

• La liaison physique unique (trunk) entre les deux commutateurs est


capable de transporter le trafic pour n’importe quel VLAN. Pour cela,
chaque trame envoyée sur la liaison est étiquetée afin d’identifier le VLAN
auquel elle appartient.
• L’identificateur est interprété et examiné par chaque commutateur avant
tout broadcast ou transmission à d’autres commutateurs, routeurs ou
équipements de station d'extrémité.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 2


VLAN Tagging

• Lorsque la trame quitte le backbone du réseau, le commutateur retire


l’identificateur avant de transmettre la trame à la station d’extrémité cible.
L’étiquetage des trames est effectué au niveau de la couche 2, il nécessite
des temps de traitement ou d'administration peu importants.
• Il est important de comprendre qu'un lien multi-VLAN n'appartient à aucun
VLAN spécifique. Un lien multi-VLAN doit servir de canal pour les VLAN
entre les commutateurs et les routeurs.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 3


VLAN Tagging

No VLAN Tagging

VLAN Tagging

• Le VLAN Tagging est utilisé quand un seul lien


doit transporter le trafic de plusieurs VLANs.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 4


VLAN Tagging

• Les systèmes d’étiquetage les plus courants pour les segments


Ethernet sont répertoriés ci-dessous:
– ISL (Inter-Switch Link) – Protocole propriétaire Cisco
– 802.1Q – Norme IEEE plus particulièrement traitée dans cette section
• ISL fût la méthode la plus répandue, mais maintenant il est remplacé
par 802.1Q.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 5
VLAN Tagging : détails

• 802.1Q est recommandé par Cisco et est utilisé avec


des switches d’autres fabricants.
• Attention : certain switches plus anciens peuvent ne
supporter que ISL alors que certains nouveaux switches
peuvent ne supporter que 802.1Q.
• 802.1Q ne tag pas le VLAN natif. Par défaut, c’est le VLAN
1 qui est natif. Mais cela est configurable.
• Supporte une instance spanning tree par VLAN avec
PVST+ ( c’est le cas aussi pour ISL).
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 6
ISL (Frame
Encapsulation)

• Une trame Ethernet est encapsulée avec une en-tête qui transporte le Vlan Id.
• ISL encapsule tous les VLANs, même le VLAN 1, il n’y a pas de notion de VLAN
natif pour ISL.
• L’encapsulation ISL est ajoutée par le switch avant d’envoyer la trame sur le lien
trunk.
• Le switch enlève l’encapsulation ISL avant d’envoyer la trame sur un lien non
trunk.
• Cela ajoute une surcharge de 26 bytes à la trame. L’en-tête de 26 bytes contient
un Vlan-Id de 12 bits.
• En plus, un CRC (cyclic redundancy check ) de 4-bytes est ajouté à la fin de
chaque trame.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 7


IEEE 802.1Q

• Beaucoup moins lourd que ISL.


• A l’inverse des 30 bytes ajoutés par ISL, 802.1Q n’ajoute que 4
bytes dans la trame Ethernet.
• Le Tag 802.1Q est inséré par le switch avant d’envoyer la trame sur
le trunk.
• Le switch enlève le Tag 802.1Q avant d’envoyer la trame sur un lien
non trunk
• L’ID de vlan a la même taille que pour ISL : 12 bits.
• La FCS est recalculée pour la trame taggée.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 8
Trunking (agrégation)

or 802.1Q

• Les protocoles d’agrégation (Trunking) ont été développés pour gérer le transfert
de trames de différents VLANs sur un seul lien physique.
• Les protocoles d’agrégation établissent les règles de distribution des trames aux ports
associés des deux côtés du Trunk.
• Des liens Trunk peuvent transporter du trafic pour tous les Vlans ou pour certains
VLANs.
• Les informations de VLAN tagging sont ajoutées par le switch avant qu’il n’envoie la
trame sur le Trunk et sont retirées par le switch avant de l’envoyer sur un lien non-trunk.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 9


VLANs et trunking

Non-Trunk Links

Trunk Link

Non-Trunk Links

• Il est important de comprendre qu'un lien multi-VLAN


n'appartient à aucun VLAN spécifique.
• Le rôle d’un lien Trunk est d’agir comme une conduite pour
VLANs entre switches et routeurs (ou switches et
switches).
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 10
Configuration du Trunking

Note: sur des


switches qui
supportent 802.1Q et
ISL, la commande
switchport trunk
encapsulation doit
être entrée AVANT la
commande
switchport mode
trunk.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 11


Configuration du Trunking

Switch(config-if)switchport trunk encapsulation [dot1q|isl]

• Cette commande configure le Vlan Tagging sur une interface si le


switch supporte plusieurs protocoles de trunking.
• Les deux options sont:
– dot1q – IEEE 802.1Q
– isl – ISL
• Le Tagging doit être le même des deux côtés.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 12
Configuration du Trunking

802.1Q only ISL only


No Trunk

SwitchA(config-if)switchport mode trunk

SwitchB(config-if)switchport mode trunk

• Si le SwitchA peut faire seulement du 802.1.Q trunk et si le


SwitchB peut faire uniquement du ISL trunk, ces deux
switches ne seront pas capables de former un trunk.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 13


Configuring Trunking

802.1Q only Both ISL and 802.1Q


Trunk

SwitchA(config-if)switchport mode trunk

SwitchB(config-if)switchport mode trunk encapsulation dot1q


SwitchB(config-if)switchport mode trunk

• Si le SwitchA peut faire seulement du 802.1.Q trunk et si le SwitchB


peut faire ISL et 8021.Q trunk, configurez le SwitchB pour 802.1Q.
• Sur les switches qui supportent 802.1Q et ISL, la commande
switchport trunk encapsulation doit être entrée avant la
commande switchport mode trunk .

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 14


.
Configuring Trunking

Switch(config-if)switchport mode [access|trunk]

• Par défaut, les Catalyst 2900XL ont leurs ports configurés comme
“access ports”.
– Ce n’est pas le cas pour beaucoup d’autres switches (par défaut, ils
sont en mode trunk dynamic desirable).
• Un port access ne peut appartenir qu’à un seul VLAN.
• Les ports Access sont utilisés quand:
– Un seul appareil est connecté au port
– Plusieurs appareils (hub) sont connectés au port, appartenant tous au
même VLAN
– Un autre switch est connecté à cette interface, mais ce lien ne transporte
des trames que pour un seul (non-trunk link).
• Les ports Trunk sont utilsés quand:
– Un autre switch est connecté à cette interface, et ce lien transporte des
trames pour plusieurs VLANs (trunk link).

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 15


Configuring Trunking

No VLAN Tagging

Switch(config-if)switchport mode access


Switch(config-if)switchport mode trunk

VLAN Tagging

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 16


DTP
Dynamic Trunking Protocol

To Trunk or not to Trunk (access


mode), that is the question.
DTP – Dynamic Trunking Protocol

• Voir le document sur DTP dans les documentations supplémentaires.


• Les slides qui suivent donnent les bases de DTP et concernent principalement
les séries Catalyst 2950 et 3550.
• Il peut y avoir de petites différences sur un switch 2900XL.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 18


DTP – Dynamic Trunking Protocol
• Les interfaces trunk Ethernet supportent beaucoup de modes
différents :
– Access
– Dynamic desirable (mode par défaut pour Catalyst 2950 et 3550)
– Dynamic auto
– Trunk
– Non-negotiate
– dotq-tunnel (pas possible pour le Catalyst 2950.)
• En utilisant ces différents modes, une interface peut être configurée
pour faire du trunking ou pas, ou elle peut être capable de négocier un
trunk avec l’interface voisine.
• Pour automatiquement négocier un trunk, les interfaces doivent être
dans le même domaine VTP.
• La négotiation de trunk est contrôlée par le protocole Dynamic
Trunking Protocol (DTP), qui est un protocole Point-to-Point
propriétaire Cisco.
• Ces différents modes sont configurés en utilisant la commande
d’interface switchport mode .

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 19


DTP – Dynamic Trunking Protocol

• Nous avons déjà vu les deux options “non-dynamiques” :


Switch(config-if)switchport mode access
Switch(config-if)switchport mode trunk
• Ces options mettent l’interface en mode non-trunking
(access) ou en mode trunking (trunk)

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 20


DTP – Dynamic Trunking Protocol

• Tous ces modes DTP et leurs différentes combinaisons


peuvent prêter à confusion.
• Examinons quelques combinaisons de base pour y voir
plus clair.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 21
DTP

• Par défaut, les interfaces Ethernet de la plupart des switches Cisco


sont en mode dynamic desirable. (Catalyst 2950 et 3550)
• Le mode Desirable créera un lien trunk si l’interface voisine est en
mode desirable, trunk, ou auto.
• Comme par défaut les deux interfaces sont en mode desirable, cela
signifie qu’un lien entre deux switches Cisco deviendra
automatiquement un lien trunk, sauf autre configuration.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 22
Creating VLANs

Ce lien deviendra un lien trunk sauf si un des ports


Défaut: dynamic desirable est configuré comme lien access avec la commande
switchport mode access

• Par défaut, tous les ports sont configurés en


switchport mode dynamic desirable, ce
qui signifie que si le port est connecté à un autre
switch avec un port configuré avec le même mode
par défaut, (desirable ou auto), ce lien deviendra
un lien trunk.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 23
DTP

Default
2950/3550

• La figure 1 montre les différents modes DTP et le résultat


des différentes combinaisons.
• Il est important de sélectionner la bonne combinaison pour
les deux extrémités du lien, puisque certaines
combinaisons ne peuvent pas être employées puisqu’elles
donnent des résultats inattendus.
• Une combinaison qui conduit au blocage du trafic est une
interface en mode access et la voisine en mode trunk .

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 24


DTP

Note: cette table se base sur le fait que DTP est


activé des 2 côtés.

• show dtp interface – pour déterminer la configuration

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 25


DTP

• Dorénavant, pour vous simplifier la vie, utilisez


une de ces deux commandes:
Switch(config-if)#switchport mode access
ou
Switch(config-if)#switchport mode trunk

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 26


Assigner un port acces à un VLAN
Switch(config)#interface range fa 0/11 - 15
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10

Switch(config)#interface range fa 0/16 - 17


Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20

• Ces deux commandes doivent être utilisées pour les ports


access :

– switchport mode access


– switchport access vlan n

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 27


Pourquoi utiliser la commande switchport mode access ?

Switch(config)#interface range fa 0/11 - 15


Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#end

Switch#show interface fa 0/11 switchport


Name: Fa0/11
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 10 (Accounting)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none

• Sans la commande la commande switchport mode access,


cette interface va essayer de négocier un trunk.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 28
Pourquoi utiliser la commande switchport mode access ?

Switch(config)#interface range fa 0/11 - 15


Switch(config-if-range)#switchport mode access

Switch#show interface fa 0/11 switchport


Name: Fa0/11
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 10 (Accounting)

• Maintenant, configurez la série d’interfaces en mode access .


• Vous constaterez que la négociation de trunk a été arrêtée et que ces
ports seront donc des ports access (non trunk).
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 29
VTP
VLAN Trunking Protocol

Créez les une fois et envoyez les aux


autres switches.
Bénéfices de VTP (VLAN Trunking Protocol)
• Avant de discuter de VTP, il est important de comprendre que
VTP n’est pas obligatoire pour configurer des VLANs ou du
Trunking sur les switches Cisco.

Bénéfices de VTP :
• VTP est un protocole Cisco qui permet l’ échange d’information de
configuration de VLANs entre des switches.
• VTP est un protocole de messagerie de couche 2 qui permet aux
switches d’échanger des informations de configuration de VLANs de
manière à ce que la configuration reste uniforme à travers un réseau.
• VTP permet de minimiser le risque d’inconsistances quand des
changements sont fais dans la configuration (par exemple nom en
double).
• En plus, VTP réduit la complexité de création et de gestion des
VLANs, permettant aux changements effectués sur un switch d’être
propagés aux autres switches par VTP.
• Sur la plupart des switches Cisco, VTP tourne par défaut et a certains
paramètres configurés par défaut.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 31
VTP
• VTP (VLAN Trunking Protocol) est utilisé pour distribuer et synchroniser des
informations sur les VLANs qui sont configurés à travers un réseau switché
appartenant à un domaine VTP.
• Les switches transmettent des annonces VTP seulement sur des liens trunk.
• Note: VTP n’est pas nécessaire pour configurer du trunking entre switches,
mais est utilisé pour simplifier le management des VLANs.

• Les 3 modes VTP :

• VTP Server
– C’est le mode VTP par défaut d’un switch 2950.
– Les VLANs peuvent être créés, modifiés, et supprimés.
– Les VLANs sont sauvegardés en NVRAM.
• VTP Client
– Les Vlans ne peuvent pas être créés, modifiés ou supprimés sur un switch en mode
VTP client.
– Les VLANS sont seulement stockés en RAM, pas sauvegardés en NVRAM.
• VTP Transparent
– Les switches en mode VTP Transparent n’écoutent pas les annonces VTP, mais ils
les transmettent aux switches voisins par ses liens trunk.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 32


Opérations VTP – Numéro de révision
• Les annonces VTP sont transmises par toutes les connexions trunk,
comprenant ISL, IEEE 802.1Q, IEEE 802.10, et ATM LANE trunks.
• Les annonces VTP contiennent un n°de révision de c onfiguration, les n°et
noms des VLANs et des informations sur quel switch a des ports assignés à
chaque VLAN.
• Un des composants le plus important des annonces VTP est le Numéro de
révision de configuration VTP.
• Ce nombre de 32-bits indique le n°de la révision d e la configuration VTP.
• Le n°de révision commence à 0 à l’allumage du switch et s’incrémente
par pas de 1 lors de chaque changement de la configuration jusqu’à ce
qu’il atteigne 4294927295, point au quel il recommence à 0.
• Chaque appareil VTP surveille son propre n°de révis ion.
• Les paquets VTP contiennent le n°de révision de la configuration de
l’envoyeur.
• Cette information détermine si le l’information reçue est plus récente que la
version courante.
• Si un switch reçoit une annonce VTP sur un lien trunk, il prend les informations
si le nom de domaine VTP correspond et si le n°de r évision est supérieur au
sien.
• Le switch ignore les annonces qui ont un autre nom de domaine VTP et
un n°de révision plus bas que le sien.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 33


Opérations VTP
• Les annonces VTP sont envoyées comme un broadcast à travers le domaine
VTP.
• Les serveurs et les clients VTP sont synchronisés sur le dernier n°de
révision.
• Les annonces VTP sont envoyées toutes les 5 minutes ou quand il y a un
changement.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 34


Opérations VTP : mode client

• Les clients VTP ne peuvent pas créer, modifier ou supprimer des


informations de VLANs.
• Le seul rôle d’un client VTP est de procéder aux changements de Vlan reçus
du serveur VTP et d’envoyer l’annonce par tous ses ports en mode trunkts.
• Le client VTP maintient une liste complète de tous les VLANs du domaine
VTP, mais il ne stocke pas l’information dans sa NVRAM.
• Les clients VTP se comportent de la même façon que les serveurs VTP, mail il
est impossible de créer, modifier ou supprimer des VLANs sur un client VTP.
• Chaque changement fait devra venir par une annonce d’un Serveur VTP.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 35


Opérations VTP : mode transparent

• Les switches en mode VTP transparent transmettent les annonces VTP mais ignorent
les informations contenues dans le message.
• Un switch en mode transparent ne modifiera pas sa base de données quand des mises
à jour seront reçues, il n’enverra pas non plus une mise à jour lors d’un changement
pour un de ses VLAN.
• A part transmettre les annonces VTP, VTP est inactif sur les switches en mode
transparent.
• Il y a aussi un mode “off” pour VTP pour lequel les switches se comportent de la même
façon que les switches en mode transparent, mais sans transmettre les annonces.
• On peut créer des VLAns sur un switch en mode transparent, cependant, ils n’auront
qu’une signification locale, ils ne seront pas annoncés aux autres switches.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 36


VTP Pruning

• La propagation de la configuration des VLANs est une des


raison d’employer VTP. VTP Pruning en est une autre.
• Par défaut, une connexion trunk transporte le trafic pour
tous les VLANs. Les Broadcasts ( et les unicasts pour une
destination inconnue ) dans chaque VLAN sont envoyés
vers tous les switches du réseau, sur base de la topologie
STP.
• Cependant, dans la plupart des réseaux, un switch n’a pas
forcément des interfaces dans tous les VLANs, ce qui fait
que les broadcats pour des VLANs dans lesquels il n’a
aucune interface lui font gaspiller de la bande passante si
précieuse.
• VTP Pruning permet aux switches d’éviter d’envoyer des
broadcasts ou des unicasts inconnus vers un switch qui
n’aurait aucun port dans ce VLAN.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 37
VTP Pruning - Exemple

• Dans la figure, les Switches 1 et 4 ont des dans le VLAN 10. Avec VTP
Pruning activé, quand la Station A envoie un broadcast, le broadcast est
« flooded » seulement vers chaque switch ayant des ports assignés au VLAN
10.
• Comme résultat, le trafic de broadcast pour le VLAN 10 venant de la Station A
n’est pas transmis aux switches 3, 5 et 6, parce que le trafic pour le VLAN 10
a été « pruned » (stoppé, coupé) par VTP sur les liens indiqués sur les
switches 2 et 4 (voir schéma).
• VTP pruning augmente la bande passante disponible en limitant le trafic
« flooded » provenant de broadcast ou d’unicasts inconnus
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 38
Configuration de VTP

• VTP peut être configuré en employant les modes de


configuration suivants :

– Configuration de VTP en mode de configuration globale


– Configuration de VTP en mode de configuration VLAN

• Le mode configuration VLAN est atteint en entrant la


commande vlan database en mode privilégié.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 39
Configuration de VTP – la version

• Deux différentes versions de VTP peuvent tourner dans le domaine de


management, VTP Version 1 et VTP Version 2.
• Les deux versions ne sont pas compatibles dans le même domaine.
• La différence principale entre les deux versions est le fait que la version 2
introduit le support des Vlans Token Ring.
• Si tous les switches dans le domaine VTP Version 2, la version 2 doit juste
être activé sur un switch VTP server, lequel la propagera aux autres switches
du domaine VTP.
• La Version 2 ne peut être activée que si tous les switches du domaine VTP la
supportent.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 40


Configuration de VTP – Domaine et mot de passe

• Le nom de domaine peut contenir entre 1 et 32 caractères.


• Un password optimal doit faire de 8 à 64 caractères de long.
• Si le switch est le premier switch installé dans le réseau, le domaine
de management doit être créé.
• Cependant, si le réseau a d’autres switches faisant tourner VTP, alors
le nouveau switch joindra le domaine de management existant.
• Attention : le nom de domaine et le password sont case sensitive.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 41


Configuration de VTP – Domaine et mot de passe

• Par défaut, les domaines de management sont en mode non secure,


ce qui signifie que les switches communiquent sans employer un
password.
• En ajoutant un password, on met automatiquement le domaine de
management en mode secure.
• Le même password doit être configuré sur chaque switch dans le
domaine de management pour utiliser le mode secure.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 42
Configuration de VTP – modes VTP

Switch#config terminal
Switch(config)#vtp mode [client|server|transparent]

Switch#vlan database
Switch(vlan)#vtp [client|server|transparent]
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 43
Configuration de VTP - résumé
• Configuration de VTP en mode de configuration globale:
Switch#config terminal
Switch(config)#vtp version 2
Switch(config)#vtp mode server
Switch(config)#vtp domain cisco
Switch(config)#vtp password mypassword

• Configuration de VTP en mode de configuration VLAN :


Switch#vlan database
Switch(vlan)#vtp v2-mode
Switch(vlan)#vtp server
Switch(vlan)#vtp domain cisco
Switch(vlan)#vtp password mypassword

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 44


Verification de VTP

status

• Cette commande est utilisée pour vérifier la configuration


VTP sur un switch Cisco basé sur un IOS.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 45


Vérification de VTP

• Cette commande est utilisée pour afficher les


statistiques sur les annonces envoyées et reçues
par le switch.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 46
Ajout d’un switch à un domaine VTP existant

• Il faut être prudent quand on introduit un nouveau switch dans un domaine existant.
• Dans le but de préparer un switch à entrer dans un domaine VTP existant, voici les
étapes à suivre :

– Effacer la VLAN database


– Effacer la startup configuration
– Redémarrer le switch

• Cela permettra d’éviter des problèmes provenant de configurations VLAN résiduelles ou


d’ajouter un switch avec une valeur de révison de configuration supérieure, ce qui peut
conduire à la propagation d’informations VLAN incorrectes.
• Le switch n’étant pas connecté, dans le mode privilégié, tapez les commandes delete
vlan.dat et erase startup-config, puis redémarrez le switch. Le fait de
redémarrer le switch, va remettre son numéro de révision à 0.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 47


Inter-VLAN Routing
Inter-VLAN Routing

Fa 0/0 Fa 0/1
10.1.0.1/16 10.2.0.1/16

10.1.0.10/16 10.2.0.20/16 10.1.0.30/16 10.2.0.40/16


DG: 10.1.0.1 DG: 10.2.0.1 DG: 10.1.0.1 DG: 10.2.0.1

• Quand un hôte dans un sous-réseau ou VLAN veut communiquer avec


un hôte dans un autre sous-réseau ou VLAN, un routeur est
nécessaire pour router le trafic entre les VLANs.
• Sans appareil de routage, le trafic inter-vlan n’est pas possible.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 49
Inter-VLAN Routing – Liens Non-trunk

10.10.0.11/16 10.20.0.22/16

10.20.0.1/16
10.10.0.1/16

• Une possibilité est d’utiliser un lien séparé vers le routeur pour chaque VLAN à
la place de liens trunk.
• Cependant, ce n’est pas l’idéal, car en cas de trafic faible, il y a une mauvaise
utilisation des liens.
• Il faut s’assurer que les hôtes et les routeurs ont la bonne adresse IP associée
avec le bon Vlan.
• C’est une pratique commune de donner un n°au Vlan qui correspond à
l’adresse IP quand cela est possible.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 50


Interfaces physiques et logiques

• On peut utiliser les sous-interfaces sur un routeur pour diviser un


simple lien physique en de multiples interfaces logiques.
• Des routeurs de début de gamme comme le 2500 et le 1600 ne
supportent pas les sous-interfaces.
• Chaque interface physique peut avoir jusqu’à 65,535 interfaces
logiques (cela dépend du type de routeur).
Rtr(config)#interface fastethernet
port/interface.subinterface
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 51
Inter-VLAN Routing – Liens Trunk

10.10.0.11/16 10.20.0.22/16

10.1.0.1/16
10.10.0.1/16 “Router-on-a-Stick”
10.20.0.1/16

Rtr(config)#interface fastethernet 0/1.1


Rtr(config-subif)#description VLAN 1
Rtr(config-subif)#encapsulation dot1q 1
Rtr(config-subif)#ip address 10.1.0.1 255.255.0.0

• Il est recommandé que le n°de la sous-interface cor responde au VLAN.


• Il est recommandé que le VLAN 1 ne soit pas utilisé, ni pour le trafic de
management, ni pour un autre trafic.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 52
Inter-VLAN Routing – Liens Trunk

10.10.0.11/16 10.20.0.22/16

10.1.0.1/16
10.10.0.1/16
10.20.0.1/16

Rtr(config)#interface fastethernet 0/1.10


Rtr(config-subif)#description Management VLAN 10
Rtr(config-subif)#encapsulation dot1q 10
Rtr(config-subif)#ip address 10.10.0.1 255.255.0.0

Rtr(config)#interface fastethernet 0/1.20


Rtr(config-subif)#description Management VLAN 20
Rtr(config-subif)#encapsulation dot1q 20
Rtr(config-subif)#ip address 10.20.0.1 255.255.0.0
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 53
Inter-VLAN Routing – Liens Trunk

10.10.0.11/16 10.20.0.22/16

10.1.0.1/16
10.10.0.1/16
10.20.0.1/16

switch(config)#interface FastEthernet 0/0


switch(config-if)#switchport trunk encapsulation
dot1q
switch(config-if)#switchport mode trunk

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 54


Router On A Stick: 802.1Q Trunk Link
switch(config)#interface FastEthernet 0/0
switch(config-if)#switchport trunk encapsulation
dot1q
switch(config-if)#switchport mode trunk

Router(config)#interface FastEthernet0/0
Router(config-if)no shutdown

Router(config)#interface FastEthernet 0/0.1


Router(config-subif) description VLAN 1
Router(config-subif)#encapsulation dot1Q 1 native
Router(config-subif)#ip address 10.10.1.1 255.255.255.0

Router(config)#interface FastEthernet 0/0.10


Router(config-subif) description VLAN 10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 10.10.10.1 255.255.255.0

Router(config)#interface FastEthernet 0/0.20


Router(config-subif)# description VLAN 20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 10.10.20.1 255.255.255.0

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 55


Informations supplémentaires
sur les VLANs
VLAN de management

• Pour plus d’informations sur le VLAN 1, le VLAN de management, le VLAN


par défaut et le VLAN Native, voyez l’article NativeVLAN.pdf, dans les
documentations supplémentaires.
• Cet article explique les différents types de VLANs et tente de lever certaines
confusions courantes.
• Par défaut, toutes les interfaces Ethernet des switches Cisco sont dans le
VLAN 1.
• Sur les switches Catalyst, tous les VLANs listés ci-dessus sont rassembler
dans le VLAN 1, ce qui augmente la difficulté de comprendre les différences.

Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 57


VLAN de management

• Sans rentrer dans les détails voici quelques informations.


• Vous noterez que dans ce cas ci, le VLAN de
management est le VLAN 99.
• Le VLAN de management est un VLAN séparé pour les
switches et les routeurs. Cela permet l’accès à ces
appareils quand d’autres VLANs rencontrent des
problèmes.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 58
Résumé

• Par défaut, le VLAN 1 est le VLAn natif et doit être employé seulement pour
transporter du trafic de contrôle, CDP, VTP, PAgP, and DTP. Ces informations
sont transmises sur un lien trunk non taggées (Native Vlan).
• Les VLANs utilisateur ne doivent pas inclure le VLAN natif, VLAN 1. Les
informations d’utilisateurs seront envoyées sur les liens trunk taggées.
• Le VLAN de management devrait être un VLAN séparé des autres VLANs et
ne devrait pas être le VLAN natif. Cela permettra l’accès à l’appareil en cas de
problème réseau.
• La sous-interface du routeur qui est utilisée pour envoyer et recevoir le trafic
du VLAN natif doit être configurée avec l’option native de la commande de
mode d’interface encapsulation. Cela permettra au routeur de savoir que
toute trame entrante non taggée appartient à la sous-interface et fait partie du
VLAN 1, le VLAN natif. Cela en supposant que le VLAN natif est le VLAN 1, le
VLAN natif par défaut.
Philippe Dastroy – IEPSA janvier 2007 - Module 9 – VLAN Trunking 59