Vous êtes sur la page 1sur 53

Rapport de stage de

fin de formation

Thème :

Réalisé par :
Encadré par :
Lamyae Mimett
Ms Bali

RAPPORT DE STAGE 1 - 2017 – Lamyae Mimett


TRI 201
2016-2017

RAPPORT DE STAGE 2 - 2017 – Lamyae Mimett


Préambule
En tant que futur Technicien Spécialisé en Réseaux et Systèmes
Informatiques, j’ai choisi comme sujet de Stage : « Etude et mise en
œuvre de OSPF multi-area » qui me semble passionnant et très
intéressant en même temps.

Tout en me permettant de combler ma formation, en parallèle,


en CCNA «Cisco Certified Network Associate», l’étude de ce projet
me permettra d’avoir un meilleur aperçu réseautique et m’éclaircira
de l’importance de la mise en œuvre de OSPF dans les équipements
CISCO, étant donné que ces derniers sont très en vogue dans le
marché informatique et télécom de nos jours.

Pour ceci je vais tenter de vous donner une explication


détaillée pour une parfaite réalisation d’un tel projet.

Le sujet de mon stage constitue à étudier et à mettre en œuvre


l’un des protocoles de routage dynamique, considéré comme le plus
puissant, c’est OSPF, et puisque la comparaison aide toujours à mieux
comprendre l’importance, j’ai commencé par une phases de
découverte des autres protocoles qui ont existés avant ospf avec
leurs avantages et leurs faiblesses, une partie de cette recherche
préliminaire est inclus au début de ce rapport, une deuxième parties
a été consacré à OSPF, le résultat de la mise en œuvre figure à la
fin.

RAPPORT DE STAGE 3 - 2017 – Lamyae Mimett


Remerciement
Ce n’est pas par ce que la tradition l’exige ou par habitude que

cette page est présente dans mon rapport, mais parce que les

personnes auxquelles s’adressent mes remerciements les méritent

vraiment. Je tiens à exprimer ma profonde gratitude et mes

chaleureux remerciements à tous mes amies de premières années

de formation en systèmes et réseaux informatiques pour leurs

précieux conseils ainsi que leurs soutiens permanant.

Je remercie aussi Mr Abd Elmotaleb Lakbidi ingénieur

informatique de m’avoir accordé ce stage au sein de cour

d’appel administrative ainsi que :

Mme Chaaka Zineb pour ces précieux conseils et sa disponibilité.

Je tiens également à exprimer toute ma reconnaissance et ma

gratitude à toutes les personnes qui m’ont soutenu de près ou

de loin pour la réalisation de ce stage.

RAPPORT DE STAGE 4 - 2017 – Lamyae Mimett


Sommaire
Chapitre I ;Présentation de Cour
d’Appel Administrative
Chapitre II :Rapport De Stage OSPF
I) Routage et protocoles
I-1-Introduction
I-2-types de routage
a) Routage Statique :
b) Routage dynamique :
I-3-Famille de protocoles
a)Les IGP :
b) Les EGP :
I–4-Classes De Protocoles
A) Vecteur de distance :
B) Etat de Lien :
I–5-Caractéristiques des différents protocoles de routage :
a) RIP:
b) IGRP:
c) EIGRP:
d) OSPF:
I–6-Comparaison entre RIP et OSPF
II) Etude du protocole OSPF
II-1-Introduction

RAPPORT DE STAGE 5 - 2017 – Lamyae Mimett


II–2-Le Protocole De Routage OSPF
II–3-Les différents types de paquets OSPF :
II– 4-Election du DR et BDR
II-5-La base de données topologiques
II–6-La notion de coût
II-7-L' élection des meilleures routes
II– 8-La détermination d’une table de routage
II- 9-Le concept de zone (area)
II–10-Le fonctionnement d’ OSPF en détail :

III) Mise en œuvre de OSPF :

III–1-Bref préambule :
III–2-Réalisation de la maquette :
III–3-La configuration des différents routeurs de la
maquette :
III–4-Identification des routeurs voisins de chaque
routeur :
III–5-Vérification des tables de routage :
III–6-La base de donnée topologique de chaque routeur :

IV) Conclusion

RAPPORT DE STAGE 6 - 2017 – Lamyae Mimett


Presentation de la cour d’appel administrative
La cour administrative d'appel de Rabat est la plus grande
juridiction administrative d'appel du Maroc par le nombre
d'affaires traitées par les tribunaux relevant de sa
circonscription.
Ses locaux se trouvent à Rabat.
Sa principale juridiction est le tribunal administratif de Rabat qui
est la plus importante du Maroc par le nombre d'affaires
traitées.

Plus que jamais, les technologies de l’information jouent un rôle


moteur dans l’accroissement de la productivité des administrations
et des entreprises. Dorénavant, les performances d’une
entreprise résideront en grande partie dans la capacité de celle-
ci à assimiler les technologies de l’information et à les intégrer
efficacement dans son organisation interne et dans ses rapports
avec ses partenaires clés.

RAPPORT DE STAGE 7 - 2017 – Lamyae Mimett


I ) Routage et protocoles
I - 1- Introduction

Le terme routage désigne le mécanisme par lequel les données d'un équipement
expéditeur sont acheminées jusqu'à leur destinataire, même si aucun des deux
ne connaît le chemin complet que les données devront suivre, c’est ainsi un
processus permettant à un paquet d’être acheminé vers le destinataire lorsque
celui-ci n’est pas sur le même réseau physique que l’émetteur.

Un routeur est un matériel de communication de réseau


informatique destiné au routage. Son travail est de limiter les domaines de
diffusion et de déterminer le prochain nœud du réseau auquel un paquet de
données doit être envoyé, afin que ce dernier atteigne sa destination finale le
plus rapidement possible. Ce processus nommé routage intervient à la couche 3
du modèle OSI.

Le routeur réalise le choix du chemin en appliquant un algorithme de routage à


partir des tables de routage et permet un filtrage du trafic et un rééquilibrage.

Pour router un paquet le routeur doit:

 Connaître l’adresse de destination du paquet


 Identifier les routeurs qui peuvent fournir les informations sur la
destination
 Déterminer les chemins possibles
 Choisir le meilleur chemin
Maintenir et vérifier la table routage

RAPPORT DE STAGE 8 - 2017 – Lamyae Mimett


I - 2- types de routage

On distingue deux types de routage :

a) Routage Statique :

Utilise les chemins que l’administrateur réseau configure manuellement au niveau


des routeurs, Et consiste à indiquer manuellement l'adresse IP des réseaux que
l'on cherche à atteindre. On associe à chaque adresse, le nom de l'interface du
routeur ou l'adresse IP du routeur voisin se situant sur la route vers ces réseaux
de destination.

Si le réseau global est complexe, la configuration peut être fastidieuse et


source d'erreurs. De plus, lorsque un nouveau réseau est ajouté, il faut
reconfigurer l'ensemble. Enfin, pour prévenir tout dysfonctionnement (panne
d'un routeur, ligne coupée, etc.), il faut effectuer une surveillance
permanente et reconfigurer chaque routeur le cas échéant. Si la route est
rétablie, il faut recommencer la manipulation.

RAPPORT DE STAGE 9 - 2017 – Lamyae Mimett


b) Routage dynamique :

Utilise les chemins que le protocole de routage crée automatiquement en


fonction de la topologie du réseau et le changement de trafic. Compte tenu de
l'évolution du nombre de réseaux à interconnecter, dans le cas d'Internet par
exemple, il est devenu impossible de se cantonner au routage statique. C'est
pourquoi, le routage dynamique a été imaginé afin d'alléger la charge
d'administration mais aussi pour réaliser des réseaux tolérants aux pannes d'un
routeur ou d'une liaison

L'idée générale du routage dynamique est la suivante : plutôt que de


centraliser la configuration du routage dans les mains d'un individu dont le
temps de réaction est fatalement long et les risques d'erreurs importants,
cette tache est délocalisé au niveau des routeurs

Etant directement au contact des supports de communication, un routeur peut


établir un diagnostic sur l'état des liaisons. Fort de ces informations, il n'a
plus qu'à les partager avec ses voisins. De proche en proche, les nouvelles se
répandront à chaque routeur du réseau. L'intervention humaine se situera en
amont dans la définition de directives et de règles à appliquer par les
routeurs pour la diffusion des routes d’où la nécessité de définition de
protocole pour garantir une inter compréhension.

A travers un tel processus, Routage dynamique, la table de routage dynamique


est créée à partir des informations échangées par les protocoles de routage,
ces derniers sont conçus pour distribuer les informations qui permettent
d'adapter dynamiquement les routes afin de refléter les modifications
apportées aux conditions de fonctionnement du réseau. Ce qui se traduit par
la prise en charge des situations complexes d'acheminement plus rapidement
et avec plus de précision que l'administrateur système.

Cependant, les protocoles de routage ne sont pas conçus uniquement pour


commuter vers une route de secours lorsque la voie principale est inutilisable ;
ils sont aussi conçus pour déterminer quelle est la "meilleure" route vers une
destination donnée.

RAPPORT DE STAGE 10 - 2017 – Lamyae Mimett


Dans des environnements de routage IP dynamique, les informations de routage
IP sont transmises à l'aide de protocoles de routage IP. Les protocoles de
routage IP utilisés pour les intranets sont les protocoles suivants : RIP (Routing
Information Protocol) ,IGRP (Interior Gateway Routing Protocol ), EIGRP
(Enhanced IGRP) ,IS-IS (Inetermediate System to Intermediate System ) et
OSPF (Open Shortest Path First) ,ces derniers font partie des IGP(Interior
Gateway Protocol).

I - 3- Famille de protocoles

Avant toute approche sur ce type de protocole il faut bien distinguer protocole
de routage et protocole routé :

• Un protocole routé : est un protocole de la couche 3 du modèle OSI et


définissant un adressage logique permettant le routage, IP et IPX sont des
protocoles routés

• Un protocole de routage : sert a l’échange d’information de routage, ces


informations sont stockées dans les tables du routeur, il existe 2 familles de
protocole de routage.

Ces deux types de protocoles de routage, destinés et donc conçu, pour des
usages différents sont les suivants:

a)Les IGP :

Interior Gateway Protocol sont les protocoles de routages destinés à être


utilisés au sein d'un même système autonome et donc d'une même organisation.
Lorsqu'il s'agit de définir quel protocole de routage doit être utilisé au sein d'un
réseau d'entreprise, il s'agira systématiquement d'un IGP. Ceux-ci sont
beaucoup plus nombreux, nous verrons ici les principaux : RIP, IGRP, EIGRP,
OSPF.

b)Les EGP :

RAPPORT DE STAGE 11 - 2017 – Lamyae Mimett


Exterior Gateway Protocol sont destinés à la communication des informations de
routage entre systèmes autonomes distincts, c'est-à-dire entre réseau faisant
partie d'organisation différentes. Ces protocoles sont utilisés sur les très grand
réseau d'interconnections, en particulier Internet. Ils ne sont rencontrées dans
les entreprises que rarement et le plus souvent localement pour leur accès
Internet. Ces protocoles sont peu nombreux, les plus implémentés étant EGP et
BGP, BGP étant le protocole de routage utilisé sur Internet.
Pour mieux comprendre les IGP et les EGP voici un petit schéma explicatif :

I – 4- Classes De Protocoles

A ) Vecteur de distance :

RAPPORT DE STAGE 12 - 2017 – Lamyae Mimett


Avec ce type de protocole le routeur connaît uniquement le prochain saut à
effectuer pour envoyer le paquet vers la bonne destination, ici les informations
de routage (table de routage) entre routeurs sont générées et envoyé
périodiquement, d’une manière générale c’est la distance qui est utilisée comme
métrique dans ce type de protocole.

RAPPORT DE STAGE 13 - 2017 – Lamyae Mimett


 La notion de distance:On touche ici au concept de métrique,
fondamental dans le domaine du routage. En effet, il arrive fréquemment
(c'est même une situation recherchée pour des raisons de tolérance aux
pannes) que le réseau ait une topologie maillée. Dans ce cas, plusieurs
routes mènent à la même destination, la distance correspondant au
nombre de routeurs à traverser (hop count ou nombre de sauts) avant
d'atteindre un réseau, Le routeur doit alors choisir la route qu'il
considère la meilleure et donc la plus courte, vers une destination donnée.
Chaque routeur calcule cette distance à partir informations reçues de ses
voisins.

Pour des soucies de convergence cohérente des mécanismes tel que Split horizon
Poison reverse, et Triggered update ont été introduit afin d’éviter les boucles de
routage, c’est mécanismes sont expliqués ci-dessous:

Split horizon : Une information de routage reçue sur une interface n'est
jamais retransmise sur celle-ci.

poison reverse : Les mises à jour de routage poison reverse appliquent une
métrique «infinie» aux routes transmises par l'interface d'émission. Ce type de
mise à jour aide à prévenir les boucles de routage.

triggered update : Une panne est immédiatement diffusée sans attendre le


prochain cycle de diffusion des tables afin de réduire le délai de convergence.

B ) Etat de Lien :

RAPPORT DE STAGE 14 - 2017 – Lamyae Mimett


Ce type de protocole de routage utilise une base de donnée topologique crée sur
chaque routeur renfermant différentes informations parmis lesquelles les liens
connectés au routeur et les routeurs adjacents. L’algorithme de Dijkstra (SPF)
aide au calcul de la meilleure route. Par définition les protocoles de routage à
état de lien converge plus rapidement que les routages par vecteur de distance
mais demande un calcul plus lourd pour permettre cette convergence.

C ) Hybride :
Le routage hybride combine des aspects du routage à état de liens et du routage
à vecteur de distance. Le protocole EIGRP est un exemple de protocole de
routage hybride.

I – 5- Caractéristiques des différents protocoles de routage :

a) RIP:

 RIP est très simple à mettre en œuvre.


Conseillée pour les petits réseaux.
 Dans le mode RIP chaque Routeur broadcast sa table de routage toutes
les 30secondes, Pour un grand réseau, il faut un certain temps pour mettre
à jour toutes les tables de routage.
 Le Masque de sous réseau doit être identique.
 Métrique = nombre de saut.
 Maximum métrique = 16.

Remarque :

RIP V1 ne supporte pas les masques de sous réseau de longueur variable.


Une deuxième version de RIP (RIP v2) a été développée pour permettre à ce
protocole de routage simple (en terme de mise en place et de compréhension) et
adapté pour un grand nombre de réseaux, de répondre aux contraintes des
réseaux actuels (découpages des réseaux IP en sous réseaux, authentification
par mot de passe,...).

RAPPORT DE STAGE 15 - 2017 – Lamyae Mimett


Toute fois ce protocole présente quelques avantages mais aussi de sérieux
inconvénients d’où la conclusion.

b) IGRP:

 Protocole IGRP est développé par Cisco.


 Similaire au protocole RIP.
 Métrique :
 Bande passante (bandwidth).
 Délai (Delay).
 Charge (load).
 Fiabilité (reliability).
 Unité maximale de transmission (MTU : maximal transmission Unit).
 Échange de la table de routage chaque 90s.

RAPPORT DE STAGE 16 - 2017 – Lamyae Mimett


Avant de continuer, il convient de définir ce qu’un système autonome car
ça va se répéter tout au long de ce rapport :

Un système autonome est un ensemble de réseaux qui utilisent un


protocole de routage commun et qui dépend d’une autorité
d’administration unique.

c) EIGRP:

 Protocole propriétaire de Cisco


 EIGRP découvre les routeurs voisins avant de leur envoyer les informations de
routage.
 Utilise la même métrique que IGRP multiplié par 256.
 Au lieu d’envoyer des mises à jour entière lors d’un changement topologique,
EIGRP envoie des mises à jour immédiatement après un changement de topologie
 EIGRP construit une table de la topologie réseau qui contient le meilleur
chemin et deux autres chemins alternatifs
 Supporte le partage de charge entre les chemins de la même métrique

d) OSPF:

 C’est un protocole standard.


 OSPF est un protocole à état de lien.
 Échange la totalité de la table de routage avec les routeurs voisin chaque 30s.
 Au lieu d’envoyer des mises à jour entières lors d’un changement topologique,
OSPF envoie des mises à jour incrémentielles.
 OSPF supporte VLSM.
 Recommandé pour les réseaux importants.
 Le réseau OSPF est subdivisé en plusieurs zones (area).

RAPPORT DE STAGE 17 - 2017 – Lamyae Mimett


 Chaque routeur possède une connaissance complète des réseaux au sein d’une
zone (area).
 La communication inter area ne laisse passer l’échange d’informations
minimales seulement pour que les zones restent connectées.
 OSPF utilise l’algorithme du chemin le plus court pour déterminer le meilleur
chemin vers un réseau de destination.

I – 7- Comparaison entre RIP et OSPF

RAPPORT DE STAGE 18 - 2017 – Lamyae Mimett


RIP OSPF
Calcule le coût en fonction du nombre Calcule la route en fonction du nombre
de sauts de sauts, du débit, du coût du lien
On peut augmenter artificiellement un
nombre de sauts pour privilégier une
autre route
Diffuse des messages toutes les 30s Diffusion limitée
Surcharge importante de trafic sur Moins de surcharge
grands
Réseaux
En cas de panne de route, il faut Plus rapide à trouver de nouvelles
échanger routes
toute la table de routage (long sur
réseaux
grande distance)

II ) Etude du protocole OSPF

II - 1-Introduction

RAPPORT DE STAGE 19 - 2017 – Lamyae Mimett


Les deux classes principales de protocoles IGP (Interior Gateway Routing
Protocol) sont le vecteur de distance et l’état de liens. Ces deux types de
protocoles de routage ont pour but de trouver des routes parmi les systèmes
autonomes. Les protocoles de vecteur de distance et d’état de liens utilisent des
méthodes différentes pour accomplir les mêmes tâches.

Les algorithmes de routage à état de liens, également appelés algorithmes du


plus court chemin d’abord (SPF), gèrent une base de données topologiques
complexe. Un algorithme de routage à état de liens gère une base de
connaissances complète sur les routeurs distants et leurs interconnexions. Par
contre, les algorithmes à vecteur de distance comprennent des informations non
spécifiques sur les réseaux distants et ne fournissent aucune information sur les
routeurs distants.

Il est essentiel de comprendre le fonctionnement des protocoles de routage à


état de liens pour savoir comment activer, vérifier et dépanner leur
fonctionnement. Je vais essayer de vous expliquer comment les protocoles d’état
de liens fonctionnent, il décrit leurs fonctions, l’algorithme qu’ils utilisent, ainsi
que les avantages et les inconvénients de ce type de routage.

Ce protocole a deux caractéristiques essentielles :


 Il est ouvert : c'est le sens du terme Open de OSPF. Son fonctionnement
est connu de tous.
 Il utilise l'algorithme SPF pour Shortest Path First, plus connu sous le nom
d'algorithme de Dijkstra, afin d'élire la meilleure route vers une destination
donnée.

II – 2-Le Protocole De Routage OSPF

OSPF est un protocole de routage à état de lien (Link-state) ce qui diffère donc
des protocoles à vecteur de distance (Distance Vector) comme RIP.
Le Link-state va permettre au routeur d'avoir une vision globale du réseau et de
sa topologie, et le Shortest Path First Algorithm (conçu par le scientifique
Dijkstra) va

RAPPORT DE STAGE 20 - 2017 – Lamyae Mimett


déterminer le meilleur chemin (le moins couteux).Plusieurs standard de la IETF
décrivent OSPF, mais le plus récent est la RFC 2328 (OSPF Version2).
OSPF est non propriétaire et est entrain de devenir l'Interior Gateway Protocol
(IGP) préféré, à la place de RIP qui souffre de quelques lacunes.
RIP ne peut pas aller plus loin que 15 routeurs (hops), il converge lentement, il
peut choisir des routes lentes parce qu'il ne se base que sur un seul métric (le
hop).
OSPF gère les limitations de RIP et il peut s'appliquer sur de très larges
réseaux, en utilisant un design hiérarchique.
Un réseau OSPF est divisé en plusieurs zones (Aera) qui se connectent à une
Aera centrale de distribution, Area 0, appelé aussi le backbone.
Chaque routeur s'informe sur l'état de ses propres interfaces, ces informations
sont ensuite floodées à tous les routeurs voisins (ç’est a dire sur toutes les
interfaces, sauf celles d'où elles arrivent. Attention ce n'est pas un broadcast!),
ils annoncent donc leur état et reçoivent les infos des autres.
De ce fait, tous les routeurs auront la même base de données sur l'état des
connections de tous les autres routeurs appartenant à la même Area, ensuite ils
lancent tous le shortest path first (SPF) algorithme, ce qui déterminera les
meilleures routes, qui seront alors ajoutées à la table de routage.
Pour réduire le nombre d'informations de routage échangées parmis tous les
routeurs du même réseau, les routeurs vont élire un DR (designated router) et
un BDR (backup designated router) qui serviront de point central d'échange. Non
verront cette notion plus tard.
Les routeurs OSPF établissent donc des liaisons avec leurs voisins pour partager
efficacement les informations d'état de lien, contrairement à RIP, où les
routeurs broadcast (RIPv1) ou multicast (RIPv2) l'entierté de leur table de
routage toutes les 30 secondes.
Par défaut, RIP n'envoit qu'une sorte de message (leur table). OSPF lui peut
envoyer 5 sortes de paquets! Ce qui permet une communication plus complexe et
plus sophistiquée.

RAPPORT DE STAGE 21 - 2017 – Lamyae Mimett


II – 3-Les différents types de paquets OSPF :

OSPF Paquet Type Description


Etablit et maintient les informations d'adjacence
Type 1 - HELLO
avec les voisins
Type 2 - Database description Décrit le contenu de la base de donnée d'état de
packet (DBD) lien d'un routeur OSPF
Fais (demande) des requêtes sur les bases de
Type 3 - Link State Request
données
Type 4 - Link State Update Transportes les annonces de link-state (LSA - Link
(LSU) State Avertissement) pour les routeur voisins.
Type 5 - Link Sate
Accusé de réception pour les LSA
Acknowledgement (LSACK)

II – 4- Election du DR et BDR

Si chaque routeur doit établir une adjacence avec chaque routeur présent dans
la même Area et échanger leurs informations, cela va devenir très vite lourd. Par
exemple, 5 routeurs nécessitent 10 relations et 10 routeurs nécessitent 45
relations (la formule est (n.n-1)/2).
Pour éviter ceci, une élection va s'effectuer dans le réseau pour élire un routeur
désigné (DR - Designated Router). Ce routeur devient adjacent pour tous les
routeurs, et tous les routeurs envoient leurs informations au DR. Du coup, pour
un réseau de 5 routeurs, il ne faudra que 5 relations, et 10 relations pour 10
routeurs. Le DR envoi l'information d'état de lien à tous les routeurs en utilisant
l'adresse multicast 224.0.0.5 (Pour tous les routeurs OSPF du même segment)
En dépit de ce gain d'efficacité d'élection du DR, il reste une grosse faiblesse :
le DR devient un point central de défaillance. Il y a donc une élection d'un second
routeur, le BDR (backup designated router) qui pourra remplacer la fonction du
DR en cas de problème. Tous les routeur envoient leurs informations au DR et au
BDR en utilisant l'adresse multicast 224.0.0.6

RAPPORT DE STAGE 22 - 2017 – Lamyae Mimett


II - 5- La base de données topologique

Avec le protocole OSPF, tous les routeurs d'un même réseau (on parle de «zone»
dans le vocabulaire OSPF, voir plus loin dans ce rapport) travaillent sur une base
de données topologique identique qui décrit le réseau. Cette base a été
constituée pendant une première phase. Examinons la base de données suivante
qui décrit la
topologie (sur le
schéma en bas)

Arc Coût

R1 - R2 1
R1 - R5 10
R2 - R3 1
R3 - R4 10
R3 - R5 1
R4 - R5 10
R4 - 192.168.1.0 10

II – 6- La notion de coût

Supposons que du routeur R1 on cherche à atteindre le réseau 192.168.1.0. Dans


une telle situation, Le protocole RIP aurait élu la route passant par R5 puisque
c'est la plus court en termes de saut. Cependant, imaginons que les liens
représentés sous forme d'éclairs soient «rapides» (de type FastEthernet à 100
Mbps par exemple) et que les liens représentés sous formes de segments droits
soient «lents» (de type Ethernet à 10 Mbps par exemple). Le choix du protocole
RIP n'est plus du tout pertinent ! Le protocole OSPF fonctionne différemment.
Il attribue un coût à chaque liaison (appelée lien dans le jargon OSPF) afin de
privilégier l'élection de certaines routes. Plus le coût

RAPPORT DE STAGE 23 - 2017 – Lamyae Mimett


est faible, plus le lien est intéressant. Par défaut, les coûts suivants sont utilisés
en fonction de la bande passante du lien :

Type de réseau Coût par défaut

FDDI, FastEthernet 1
Ethernet 10 Mbps 10
E1 (2,048 Mbps) 48
T1 (1,544 Mbps) 65
64 Kbps 1562
56 Kbps 1758
19.2 Kbps 5208

La formule de calcul est la suivante :

10 8
Coût 
bande passante du lien en bps

La référence 108 correspond à un débit maximum de 100Mbps. Dans le cas où l'on


utilise des interfaces avec un débit supérieur, il est possible de redéfinir la
référence

RAPPORT DE STAGE 24 - 2017 – Lamyae Mimett


avec une commande du type auto-cost reference-bandwidth 1000 pour la
valeur 109.
Le protocole OSPF privilégie les routes qui ont un coût faible, donc celles qui
sont supposées rapides en terme de débit théorique.

II - 7-L' élection des meilleures routes

L'algorithme SPF de Dijsktra va traiter cette base de données afin de


déterminer les routes les moins coûteuses. Une fois le traitement réalisé,
chaque routeur se voit comme la racine d'un arbre contenant les meilleures
routes. Par exemple :

RAPPORT DE STAGE 25 - 2017 – Lamyae Mimett


Dans l'exemple, entre R1 et 192.168.1.0, la meilleure route passe par R2, R3 et
R4 pour un coût total de 1 + 1 + 10 + 10 soit 22.

II – 8- La détermination d’une table de routage

La base de données topologique décrit le réseau mais ne sert pas directement au


routage. La table de routage est déterminée par l'application de l'algorithme du
SPF sur la base topologique. Sur R1, voici un extrait de la table de routage
calculée par SPF au sujet du réseau 192.168.1.0 :

Réseau de destination Moyen de l'atteindre


Coût

192.168.1.0 R2 22

Sur R5, on aura l'extrait suivant :

Réseau de destination Moyen de l'atteindre


Coût

192.168.1.0 R4 20

RAPPORT DE STAGE 26 - 2017 – Lamyae Mimett


II - 9- Le concept de zone (area)

Contrairement à RIP, OSPF a été pensé pour supporter de très grands


réseaux. Mais, qui dit grand réseau, dit nombreuses routes. Donc, afin d'éviter
que la bande passante ne soit engloutie dans la diffusion des routes, OSPF
introduit le concept de zone (area). Le réseau est divisé en plusieurs zones de
routage qui contiennent des routeurs et des hôtes.
Chaque zone, identifiée par un numéro, possède sa propre topologie et ne connaît
pas la topologie des autres zones.
Chaque routeur d'une zone donnée ne connaît que les routeurs de sa propre zone
ainsi que la façon d'atteindre une zone particulière, la zone numéro 0. Toutes les
zones doivent être connectées physiquement à la zone 0 (appelée backbone ou
réseau fédérateur). Elle est constituée de plusieurs routeurs interconnectés. Le
backbone est chargé de diffuser les informations de routage qu'il reçoit d'une
zone aux autres zones. Tout routage basé sur OSPF doit posséder une zone 0.

RAPPORT DE STAGE 27 - 2017 – Lamyae Mimett


1. Elire les routes à utiliser.
2. Maintenir la base de donnée topologique.

État Initial

Le processus de routage OSPF est inactif sur tous les routeurs.

Établir la liste des routeurs voisins : Hello, my name is R1 and I'm


an OSPF router.

Les routeurs OSPF sont bien élevés. Dès qu'ils sont activés, ils n'ont qu'une hâte
: se présenter et faire connaissance avec leurs voisins et donc établir
l'adjacence, Les routeurs du même segment sont dites voisins ou adjacent
(neighbor).

Pour atteindre l'adjacence, Rb envoie des HELLO paquets qui annonce son
ID,
sur S0 et E0. Ra et Rc reçoivent donc les paquets, inclut l'ID de Rb dans leurs
HELLO paquets et entre en Init State avec Rb.

RAPPORT DE STAGE 28 - 2017 – Lamyae Mimett


Rb reçoit ensuite ces paquets HELLO de ses 2 voisins, et y voit sa propre
ID (10.6.0.1). Rb sait donc que le voisinage qu’il a avec Ra et RC est bidirectionnel
(Rb voit que Ra et Rc le voit).

A ce moment, Rb va déterminer quel est le mode d'établissement


d'adjacence basé sur le type de réseau. Si le réseau est de type point to point,
le routeur devient adjacent avec son seul voisin. Si le réseau est de type multi

accès, Rb lance le processus d'élection pour devenir DR ou BDR, sauf si


déjà établit. Si il n'y a pas besoin d'élection on passe directement à l'étape 3.

Cette phase de découverte des voisins est fondamentale puisque OSPF est
un protocole à état de liens. Il lui faut connaître ses voisins pour déterminer s'ils
sont toujours joignables et donc déterminer l'état du lien qui les relie.

Élire le routeur désigné DR et le routeur désigné de secours BDR

Si chaque routeur doit établir une adjacence avec chaque routeur présent
dans la même Area et échanger leurs informations, cela va devenir très vite
lourd. Par exemple, 5 routeurs nécessitent 10 relations et 10 routeurs
nécessitent 45 relations (la formule est (n.n-1)/2).

Pour éviter ceci, une élection va s'effectuer dans le réseau pour élir un
routeur désigné (DR - Designated Router). Ce routeur devient adjacent pour tous
les routeurs, et tous les routeurs envoient leurs informations au DR. Du coup,
pour un réseau de 5 routeurs, il ne faudra que 5 relations, et 10 relations pour 10
routeurs. Le DR envoie l'information d'état de lien à tous les routeurs en
utilisant l'adresse multicast 224.0.0.5 (Pour tous les routeurs OSPF du même
segment)

RAPPORT DE STAGE 29 - 2017 – Lamyae Mimett


En dépit de ce gain d'efficacité d'élection du DR, il reste une grosse faiblesse :
le DR devient un point central de défaillance. Il y a donc une élection d'un second
routeur, le BDR (backup designated router) qui pourra remplacer la fonction du
DR en cas de problème. Tous les routeur envoyent leurs informations au DR et au
BDR en utilisant l'adresse multicast 224.0.0.6

Le DR et le BDR d'un LAN sont généralement les routeurs qui ont le plus
grand travail à effectuer, il convient donc de sélectionner les routeurs ayant le
plus de puissance CPU.

Election d'un
Type de réseau Caractéristiques
DR?
Ethernet, Token Ring, ou
Broadcast multiaccess Oui
FDDI
Nonbroadcast
Frame Relay, X.25, SMDS Oui
multiaccess
Point-to-point PPP, HDLC Non
Configuré par
Point-to-multipoint Non
l'administrateur
Ceci répondra donc aux objectifs suivants :

 Réduire le trafic lié à l'échange d'informations sur l'état des liens


(car il n'y a pas d'échange entre tous les routeurs mais entre chaque
routeur et le DR),
 Améliorer l'intégrité de la base de données topologique (car cette
base de données doit être unique),
 Accélérer la convergence (défaut de RIP).

L'élection se fait grâce aux HELLO paquets qui contiennent l'ID du routeur et
un champ de priorité. Le routeur qui a la plus grande valeur de priorité remporte
les élections et devient le DR, le second le BDR. Une fois élu le DR et le BDR, ils
tiendront

RAPPORT DE STAGE 30 - 2017 – Lamyae Mimett


leur rôle jusqu'à une défaillance, même si un routeur d'une plus grande priorité
se rajoute au réseau. Tous les nouveaux routeurs seront informé de l'identité du
DR et du BDR.

Par défaut, tous les routeurs ont une priorité de 1. On peut assigné une priorité
de 0 à 255. Une priorité de 0 empêchera le routeur de devenir le DR, tandis que
le 255 assurera au minimum une égalité. Le champs ID du routeur sera là pour
départager les égalités, la plus grande ID sélectionnera le DR.

On voit que Rb et Rc sont connecté par Point to point Protocol (PPP). Un DR n'est
donc pas nécessaire pour le réseau 10.6.0.0/16.

Les réseaux 10.4.0.0/16 et 10.5.0.0/16 en revanche sont des réseaux Ethernet


multi-acces donc même si il n'y a qu'un seul routeur, un DR sera élu, parce qu'il y
a le potentiel pour d’autres routeurs. Comme Ra est le seul routeur du réseau
10.4.0.0/16 il s'est élu lui-même DR. Dans le réseaux 10.5.0.0/16, Ra et Rb ont la
même priorité, donc en vertu du tie-breaker c'est Rb qui sera élu DR : un plus
grand ID (10.5.0.2 contre 10.5.0.1). Maintenant ils sont prêt à échanger leurs
info et construire leurs bases de données

Découvrir les routes

Il faut maintenant constituer la base de données topologique. Les routeurs


communiquent automatiquement les routes pour les réseaux qui participent au
routage
dynamique (ceux déclarés avec la commande network). Ils peuvent aussi
diffuser des routes provenant d'autres sources que OSPF, grâce à la commande
redistribute.

RAPPORT DE STAGE 31 - 2017 – Lamyae Mimett


Chaque routeur (non DR ou BDR) établit une relation maître/esclave avec
le DR. Le DR initie l'échange en transmettant au routeur un résumé de sa base
de données topologique via des paquets de données appelés LSA (Link State
Avertissement).

Ces paquets comprennent essentiellement l'adresse du routeur, le coût du


lien et un numéro de séquence. Ce numéro est un moyen pour déterminer
l'ancienneté des informations reçues. Si les LSA reçus sont plus récents que
ceux dans sa base topologique, le routeur demande une information plus complète
par un paquet LSR (Link State Request). Le DR répond par des paquets LSU (Link
State Update) contenant l'intégralité de l'information demandée. Ensuite, le
routeur (non DR ou BDR) transmet les routes meilleures ou inconnues du DR.

L'administrateur peut consulter la base de données topologique grâce à la


commande show ip ospf database.

Élire les routes à utiliser

Lorsque le routeur est en possession de la base de données topologique, il


est en mesure de créer la table de routage. L'algorithme du SPF est appliqué sur
la base topologique. Il en ressort une table de routage contenant les routes les
moins coûteuses. Il faut noter que sur une base de données topologique
importante, le calcul consomme pas mal de ressources CPU car l'algorithme est
relativement complexe.

Maintenir la base topologique

Lorsqu'un routeur détecte un changement de l'état d'un lien (cette


détection se fait grâce aux paquets HELLO adressés périodiquement par le
routeur à ses voisins), celui-ci émet un paquet LSU sur l'adresse multicast
224.0.0.6 : le DR et le BDR de la zone se considèrent comme destinataires.

RAPPORT DE STAGE 32 - 2017 – Lamyae Mimett


Le DR et le BDR intègrent cette information à leur base topologique. Le
DR et diffuse l'information sur l'adresse 224.0.0.5 (tous les routeurs OSPF sans
distinction). C'est le protocole d'inondation. Toute modification de la topologie
déclenche une nouvelle exécution de l'algorithme du SPF et une nouvelle table de
routage est constituée.

III) Mise en œuvre de OSPF :

III – 1- Bref préambule :

Pour configurer OSPF, Il faut :

1. Créer une identité OSPF (OSPF ID) par la configuration d’une


interface en rebouchage ( loopback ) et lui assigner une adresse IP.

Cette étape est facultative, bien que recommandée. Si l’identité OSPF n’est
pas précisée, le routeur prend comme telle, l’adresse IP la plus élevée parmi
celles configurées sur ses interfaces actives. Si cette interface tombe en
panne, elle sera remplacée par l’adresse IP la lus élevée parmi les interfaces
restantes. Mais si une interfaces en rebouchage est configurée, c’est celle
ci qui sera prise pour l’identité OSPF.

L’avantage de l’interface de rebouchage, c’est qu’elle est interne au routeur,


et vu son caractère logique, ne peut jamais tomber en panne.

Si la commande de création de l’interface en rebouchage est omise lors de


la configuration de OSPF, et qu’elle est introduite par la suite, le routeur ne
basculera pas l’identité OSPF sur l’adresse IP de cette interface. Un
basculement de l’identité OSPF sur une interface de rebouclage créée après
coup ne peut intervenir que lors du redémarrage du routeur lui-même ou de
l’interface physique qui servait jusque là comme identité OSPF.

2. Créer un processus OSPF sur les routeurs Par la commande

RAPPORT DE STAGE 33 - 2017 – Lamyae Mimett


Router ospf <identité de processus>

Le paramètre peut être un chiffre quelconque entre 1 et 65535.

3. Activer le traitement des mises à jour sur les interfaces adéquates


Par la commande (en mode de configuration router ospf)

Network <adresse IP/masque générique> area 0

Le masque générique (en notation décimale pointée), permet de


déterminer les interfaces desservies par OSPF, est constitué de bits dont
chaque position à 1 signifie que le bit correspondant dans l’adresse IP doit
être ignoré lors de son application. La disposition des bits du masque
générique, contrairement au masque de sous réseau, n’a pas à être continue.

III – 2- Réalisation de la maquette :

Pour la réalisation de ma maquette j’ai eu besoin de :

 Cinq routeurs 2620 « IOS C2600 Software (C2600-IO3-M), Version 12.2


(26) »
 Quatre câbles séries pour liaison point à point
 2 câble croisé rj45

Avec ces derniers, j’ai pu construire un petit réseau tel qu’illustrer sur le schéma
suivant qui comporte trois zone différentes :

RAPPORT DE STAGE 34 - 2017 – Lamyae Mimett


III – 3- La configuration des différents routeurs de la
maquette :

 La configuration du routeur R1 est la suivante :

R1#sh running-config
Building configuration...

RAPPORT DE STAGE 35 - 2017 – Lamyae Mimett


hostname R1
!
enable secret 5 $1$pf63$wsMAE4eYmyBIc4tH7A2TJ1
!
ip subnet-zero
!
interface Loopback1
ip address 1.1.1.1 255.255.255.25
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface Serial0/0
ip address 10.10.0.1 255.0.0.0
encapsulation ppp
clockrate 64000
!
interface Serial0/1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 10.10.0.0 0.0.255.255 area 1
network 192.168.1.0 0.0.0.255 area 1
!
ip classless
ip http server
!
banner motd ^Attention!! vous etes sur le routeur R1^
!
line con 0
password cisco

RAPPORT DE STAGE 36 - 2017 – Lamyae Mimett


login
line aux 0
line vty 0 4
password cisco
login
!
end

 la configuration du routeur ABR 1 est la suivante :

ABR1#show running-config
Building configuration...
hostname ABR1
!
enable secret 5 $1$F.E1$4gkcyx8wU7KZ1XJCUj88e0
!
ip subnet-zero
! interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface Serial0/0
ip address 10.10.0.2 255.255.0.0
encapsulation ppp
!
interface Serial0/1
ip address 10.20.0.1 255.255.0.0
encapsulation ppp
clockrate 64000

RAPPORT DE STAGE 37 - 2017 – Lamyae Mimett


!
interface Serial0/2
no ip address
shutdown
interface Serial0/3
no ip address
shutdown
!
router ospf 2
log-adjacency-changes
network 10.10.0.0 0.0.255.255 area 1
network 10.20.0.0 0.0.255.255 area 0
!
ip classless
ip http server
dial-peer cor custom
!
!
banner motd ^attention!! vous etes sur le routeur ABR1^
!
line con 0
password cisco
login
line aux 0
line vty 0 4
password cisco
login
!
end

 la configuration du backbone router est la suivante :

Backbonerouter #show running-config


Building configuration...

RAPPORT DE STAGE 38 - 2017 – Lamyae Mimett


!
hostname Backbonerouter
!
enable secret 5 $1$FiFU$DBxKPwFYeo1ZZFSQXlNMs1
!
ip subnet-zero
!
!
interface Loopback3
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface Serial0/0
ip address 10.20.0.2 255.255.0.0
encapsulation ppp
no fair-queue
!
interface Serial0/1
ip address 10.30.0.1 255.255.0.0
encapsulation ppp
clockrate 64000
!
interface Serial0/2
no ip address
shutdown
!
interface Serial0/3
no ip address
shutdown
!

RAPPORT DE STAGE 39 - 2017 – Lamyae Mimett


router ospf 3
log-adjacency-changes
network 10.20.0.0 0.0.255.255 area 0
network 10.30.0.0 0.0.255.255 area 0
!
ip classless
ip http server
banner motd ^attention!! vous etes sur le backbone router^
line con 0
password cisco
login
line aux 0
line vty 0 4
password cisco
login
!
end

 la configuration du routeur ABR2 est la suivante :

ABR2#show running-config
Building configuration...

Hostname ABR2
!
enable secret 5 $1$QQ1v$WnBMzfKmc6hmx7LOfqGKE0
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface Ethernet0/0
ip address dhcp

RAPPORT DE STAGE 40 - 2017 – Lamyae Mimett


half-duplex
!
interface Serial0/0
ip address 10.30.0.2 255.255.0.0
encapsulation ppp
!
interface Serial0/1
ip address 10.40.0.1 255.255.0.0
Encapsulation ppp
clock rate 64000
!
interface Serial0/2
no ip address
shutdown

interface Serial0/3
no ip address
shutdown
!
router ospf 4
log-adjacency-changes
network 10.30.0.0 0.0.255.255 area 0
network 10.40.0.0 0.0.255.255 area 2
!
ip classless
ip http Server
!
Banner motd ^attention!! vous étés sur le routeur ABR 2^
!
line con 0
Password cisco
login
Line aux 0
Line vty 0 4

RAPPORT DE STAGE 41 - 2017 – Lamyae Mimett


Password Cisco
login
!
end

 la configuration du routeur R2 est la suivante :

R2#show running-config
Building configuration...

Hostname R2
!
Enable secret 5 $1$Quq2$DEZvLyd.8x3nQK/1iNpAD0
!
!
Interface Loopback5
ip address 5.5.5.5 255.255.255.255
Interface Ethernet0/0
no ip address
Shutdown
Half-duplex
!
Interface Serial0/0
ip address 10.40.0.2 255.255.0.0
Encapsulation ppp
!
Interface Serial0/1
no ip address
Shutdown
!
Router ospf 5
Log-adjacency-changes
Network 10.40.0.0 0.0.255.255 area 2

RAPPORT DE STAGE 42 - 2017 – Lamyae Mimett


!
ip classless
ip http server
!
Banner motd ^attention!! Vous étés sur le routeur R2^
!
line con 0
Password cisco
Login
line aux 0
line vty 0 4
password cisco
login
!
end

III – 4- Identification des routeurs voisins de chaque routeur :

On va utiliser la commande’ show ip ospf neighbour ‘ pour voir les routeurs


voisins de chaque routeur :

 show ip ospf neighbour sur le Routeur R1 :

R1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface


2.2.2.2 1 FULL 00:00:32 10.10.0.2 Serial0/0

show ip ospf neighbour sur le Routeur ABR1 :

RAPPORT DE STAGE 43 - 2017 – Lamyae Mimett


ABR1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface


3.3.3.3 1 FULL/ - 00:00:38 10.20.0.2 Serial0/1
1.1.1.1 1 FULL/ - 00:00:37 10.10.0.1 Serial0/0

 show ip ospf neighbour sur le backbone router :

backbonerouter#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface


4.4.4.4 1 FULL/ - 00:00:32 10.30.0.2 Serial0/1
2.2.2.2 1 FULL/ - 00:00:31 10.20.0.1 Serial0/0

 show ip ospf neighbour sur le routeur ABR2 :

ABR2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface


3.3.3.3 1 FULL/ - 00:00:35 10.30.0.1 Serial0/0
10.40.0.2 1 FULL/ - 00:00:34 10.40.0.2 Serial0/1

 show ip ospf neighbour sur le routeur R2 :

R2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface


4.4.4.4 1 FULL/ - 00:00:34 10.40.0.1 Serial0/0

RAPPORT DE STAGE 44 - 2017 – Lamyae Mimett


III – 5- Vérification des tables de routage :

Maintenant on va vérifier les tables de routages sur tous les routeurs :

 Sur R1 :

R1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets


C 1.1.1.1 is directly connected, Loopback1
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
O 10.10.0.0/16 [110/1562] via 10.10.0.2, 20:38:30, Serial0/0
C 10.10.0.2/32 is directly connected, Serial0/0
C 10.0.0.0/8 is directly connected, Serial0/0
O IA 10.30.0.0/16 [110/2343] via 10.10.0.2, 00:26:46, Serial0/0
O IA 10.20.0.0/16 [110/1562] via 10.10.0.2, 20:38:26, Serial0/0
O IA 10.40.0.0/16 [110/3124] via 10.10.0.2, 00:26:37, Serial0/0

 Sur ABR1 :

ABR1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

RAPPORT DE STAGE 45 - 2017 – Lamyae Mimett


D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets


C 2.2.2.2 is directly connected, Loopback2
10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
C 10.10.0.0/16 is directly connected, Serial0/0
C 10.10.0.1/32 is directly connected, Serial0/0
O 10.0.0.0/8 [110/1562] via 10.10.0.1, 20:43:05, Serial0/0
O 10.30.0.0/16 [110/1562] via 10.20.0.2, 00:31:13, Serial0/1
C 10.20.0.2/32 is directly connected, Serial0/1
C 10.20.0.0/16 is directly connected, Serial0/1
O IA 10.40.0.0/16 [110/2343] via 10.20.0.2, 00:31:14, Serial0/1

 Sur backbonerouter :

backbonerouter#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

RAPPORT DE STAGE 46 - 2017 – Lamyae Mimett


3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback3
10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
O IA 10.10.0.0/16 [110/1562] via 10.20.0.1, 00:33:14, Serial0/0
O IA 10.0.0.0/8 [110/2343] via 10.20.0.1, 00:33:14, Serial0/0
C 10.30.0.0/16 is directly connected, Serial0/1
C 10.30.0.2/32 is directly connected, Serial0/1
C 10.20.0.0/16 is directly connected, Serial0/0
C 10.20.0.1/32 is directly connected, Serial0/0
O IA 10.40.0.0/16 [110/1562] via 10.30.0.2, 00:33:15, Serial0/1

 Sur ABR2 :

ABR2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.6.1 to network 0.0.0.0

4.0.0.0/32 is subnetted, 1 subnets


C 4.4.4.4 is directly connected, Loopback4
10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
O IA 10.10.0.0/16 [110/2343] via 10.30.0.1, 00:34:46, Serial0/0
O IA 10.0.0.0/8 [110/3124] via 10.30.0.1, 00:34:46, Serial0/0
C 10.30.0.0/16 is directly connected, Serial0/0
C 10.30.0.1/32 is directly connected, Serial0/0
O 10.20.0.0/16 [110/1562] via 10.30.0.1, 00:34:46, Serial0/0
C 10.40.0.2/32 is directly connected, Serial0/1

RAPPORT DE STAGE 47 - 2017 – Lamyae Mimett


C 10.40.0.0/16 is directly connected, Serial0/1
S* 0.0.0.0/0 [254/0] via 192.168.6.1
C 192.168.0.0/16 is directly connected, Ethernet0/0

 Sur R2

R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

5.0.0.0/32 is subnetted, 1 subnets


C 5.5.5.5 is directly connected, Loopback5
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
O IA 10.10.0.0/16 [110/3124] via 10.40.0.1, 00:35:43, Serial0/0
O IA 10.0.0.0/8 [110/3905] via 10.40.0.1, 00:35:43, Serial0/0
O IA 10.30.0.0/16 [110/1562] via 10.40.0.1, 20:33:45, Serial0/0
O IA 10.20.0.0/16 [110/2343] via 10.40.0.1, 00:35:43, Serial0/0
C 10.40.0.0/16 is directly connected, Serial0/0
C 10.40.0.1/32 is directly connected, Serial0/0

III – 6- La base de donnée topologique de chaque routeur :

RAPPORT DE STAGE 48 - 2017 – Lamyae Mimett


 Contenu de la base de données topologique du Routeur1:

R1#show ip ospf database

OSPF Router with ID (1.1.1.1) (Process ID 1)

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count


1.1.1.1 1.1.1.1 1479 0x8000002A 0x00901C 2
2.2.2.2 2.2.2.2 690 0x80000028 0x00FF9E 2

Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum


10.20.0.0 2.2.2.2 690 0x80000026 0x002DB4
10.30.0.0 2.2.2.2 444 0x80000002 0x009A51
10.40.0.0 2.2.2.2 444 0x80000002 0x00BF12

 Contenu de la base de données topologique du Routeur ABR1:

ABR1#show ip ospf database

OSPF Router with ID (2.2.2.2) (Process ID 2)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count


2.2.2.2 2.2.2.2 1150 0x80000029 0x00750D 2
3.3.3.3 3.3.3.3 978 0x80000004 0x00778C
4
4.4.4.4 4.4.4.4 925 0x8000002B 0x002833 2

Summary Net Link States (Area 0)

RAPPORT DE STAGE 49 - 2017 – Lamyae Mimett


Link ID ADV Router Age Seq# Checksum
10.0.0.0 2.2.2.2 1150 0x80000026 0x00BB2A
10.10.0.0 2.2.2.2 1150 0x80000026 0x00A546
10.40.0.0 4.4.4.4 164 0x80000026 0x00FFC5

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count


1.1.1.1 1.1.1.1 1942 0x8000002A 0x00901C 2
2.2.2.2 2.2.2.2 1150 0x80000028 0x00FF9E 2

Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum


10.20.0.0 2.2.2.2 1150 0x80000026 0x002DB4
10.30.0.0 2.2.2.2 1158 0x80000002 0x009A51
10.40.0.0 2.2.2.2 1158 0x80000002 0x00BF12

 Contenu de la base de données topologique du backbone router :

backbonerouter#show ip ospf database

OSPF Router with ID (3.3.3.3) (Process ID 3)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count


2.2.2.2 2.2.2.2 1883 0x80000029 0x00750D 2
3.3.3.3 3.3.3.3 1709 0x80000004 0x00778C 4
4.4.4.4 4.4.4.4 1656 0x8000002B 0x002833 2

RAPPORT DE STAGE 50 - 2017 – Lamyae Mimett


Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum


10.0.0.0 2.2.2.2 1883 0x80000026 0x00BB2A
10.10.0.0 2.2.2.2 1883 0x80000026 0x00A546
10.40.0.0 4.4.4.4 895 0x80000026 0x00FFC5

 Contenu de la base de données topologique du ABR2:

ABR2#show ip ospf database

OSPF Router with ID (4.4.4.4) (Process ID 4)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count


2.2.2.2 2.2.2.2 687 0x8000002A 0x00730E 2
3.3.3.3 3.3.3.3 503 0x80000005 0x00758D 4
4.4.4.4 4.4.4.4 443 0x8000002C 0x002634 2

Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum


10.0.0.0 2.2.2.2 687 0x80000027 0x00B92B
10.10.0.0 2.2.2.2 687 0x80000027 0x00A347
10.40.0.0 4.4.4.4 1722 0x80000026 0x00FFC5

Router Link States (Area 2)

Link ID ADV Router Age Seq# Checksum Link count


4.4.4.4 4.4.4.4 1722 0x8000002A 0x00928E 2

RAPPORT DE STAGE 51 - 2017 – Lamyae Mimett


10.40.0.2 10.40.0.2 1909 0x80000027 0x00A15E 2

Summary Net Link States (Area 2)

Link ID ADV Router Age Seq# Checksum


10.0.0.0 4.4.4.4 443 0x80000003 0x0001DF
10.10.0.0 4.4.4.4 468 0x80000003 0x00EAFB
10.20.0.0 4.4.4.4 468 0x80000003 0x00D418
10.30.0.0 4.4.4.4 1747 0x80000026 0x007857

 Contenu de la base de données topologique du R2:

R2#show ip ospf database

OSPF Router with ID (10.40.0.2) (Process ID 5)

Router Link States (Area 2)

Link ID ADV Router Age Seq# Checksum Link count


4.4.4.4 4.4.4.4 503 0x8000002B 0x00908F 2
10.40.0.2 10.40.0.2 700 0x80000028 0x009F5F 2

Summary Net Link States (Area 2)

Link ID ADV Router Age Seq# Checksum


10.0.0.0 4.4.4.4 1256 0x80000003 0x0001DF
10.10.0.0 4.4.4.4 1256 0x80000003 0x00EAFB
10.20.0.0 4.4.4.4 1256 0x80000003 0x00D418
10.30.0.0 4.4.4.4 503 0x80000027 0x007658

RAPPORT DE STAGE 52 - 2017 – Lamyae Mimett


Conclusions :
OSPF est un protocole de routage dynamique moderne, robuste et conçu pour les
grands réseaux. On constate qu'il est nettement plus complexe que RIP. Pas
forcément dans sa configuration mais dans son fonctionnement interne. Un
inconvénient de ce protocole est qu'il peut être gourmand en puissance de calcul
et en mémoire lorsque le réseau comporte beaucoup de routes où qu'il y a de
fréquentes modifications de topologie.
OSPF est un protocole IGP (Interior Gateway Protocol), c'est-à-dire qu'il agit au
sein d'un système autonome. Un AS (Autonomous System) est un ensemble de
réseaux gérés par un administrateur commun. Chaque système autonome possède
un numéro identifiant sur 16 bits délivré par l'IANA (Internet Assigned
Numbers Authority) ou ses délégations. Classiquement, les multinationales, les
opérateurs de télécoms ou les fournisseurs d'accès à Internet détiennent un
numéro de système autonome.
Pour assurer le routage entre les systèmes autonomes, un protocole de type EGP
(Exterior Gateway Protocol) doit être mis en oeuvre. Dans le cas de l'Internet,
c'est généralement BGP (Border Gateway Protocol) qui assume cette mission.
BGP, protocole supporté par Zebra, constitue un vaste terrain d'investigation.
Pour terminer, je voudrais saluer tous personne qui m’a aidé dans la réalisation de
ce rapport.

RAPPORT DE STAGE 53 - 2017 – Lamyae Mimett