Vous êtes sur la page 1sur 3

EJERCICIOS DE RECUPERACIÓN/LÓGICA DE

PROGRAMACIÓN

1.-Realizar un algoritmo para suma, multiplicación y división de 2


números positivos ingresados dese el teclado.

SEUDOCODIGOS

Algoritmo_para suma, multiplicación y división de 2 números


Variables
Entero: n1; n2
Inicio
Leer n1; n2
Suma=n1+n2
Multiplicación=n1*n2
División=n1/n2
Imprimir suma
Imprimir Multiplicación
Imprimir División
Fin

2.-Realizar un algoritmo para leer número mayor y menor de 3 números


ingresados desde el teclado.

SEUDOCODIGOS

Algoritmo_para leer el número mayor y menor de 3 números


Variables
Entero: n1; n2; n3
Inicio
Leer n1; n2; n3
Si n1>n2 y n1>n3 entonces
Imprimir “el numero mayor es n1”
Sino n2>n1 y n2>n3 entonces
Imprimir “el numero mayor es n2”
Sino n3>n1 y n3>n2 entonces
Imprimir “el numero mayor es n3”
Fin si
Si n1<n2 y n1<n3 entonces
Imprimir “el numero menor es n1”
Sino n2<n1 y n2<n3 entonces
Imprimir “el numero menor es n2”
Sino n3<n1 y n3<n2 entonces
Imprimir “el numero menor es n3”
Fin si
Imprimir el numero mayor
Imprimir el numero menor
Fin

3.-Realizar un algoritmo para sacar el promedio de una asignatura a


base de 3 números teniendo en cuenta >=13 “Aprobado”, <=12
“Desaprobado”.

SEUDOCODIGOS

Algoritmo_ para calcular promedio de una asignatura de 3 notas


Variables
Entero: nota1, nota2, nota3, promedio
Inicio
Leer nota1, nota2, nota3, promedio
Promedio = (a + b + c) / 3
Si promedio>=13 entonces
Imprimir “Aprobado”
Sino promedio<=12 entonces
Imprimir “Desaprobado”
Fin si
fin

4.-Realizar un algoritmo la ecuación cuadrática.

SEUDOCODIGOS

Algoritmo_ para hallar la ecuación cuadrática


Variables
Doble: a, b, c, x1, x2, raíz
Inicio
Leer a, b, c, x1, x2, raíz
Si ((b ^ 2) - (4 * (a * c))) < 0 entonces
Mostrar el mensaje “no existe una solución real”
Sino
raíz = ((b ^ 2) - (4 * (a * c))) ^ (1 / 2)
x1 = CStr(((-b) + raíz) / (2 * a))
imprimir "el valor de X1 es:”
x2 = CStr(((-b) - raíz) / (2 * a))
imprimir "el valor de X2 es:”
Fin si
imprimir valor de X1
imprimir valor de X2
fin

5.-Realizar un algoritmo para calcular el número mayor de 2 números


ingresados desde el teclado.

Algoritmo_ para leer el número mayor de 2 números


Variables
Entero: n1; n2
Inicio
Leer n1; n2
Si n1>n2 entonces
Imprimir “el numero mayor es n1”
Sino n2>n1 entonces
Imprimir “el numero mayor es n2”
Fin si
Imprimir el numero mayor
Fin

NOTA: Algoritmo significa realizar el seudocódigo.