Vous êtes sur la page 1sur 22

1

¿Qué es ser un WISP?

Bueno a esta altura de juego me imagino que ya sabes que ​WISP ​significa “Wireless
Internet Service Provider” y como todo negocio de servicio es complejo.

Sin embargo digamos que tenías un negocio de dar servicios de impresión o de


fotografía. Las variables que hacen que tu servicio sea bueno o malo son controlables
todas dentro de tu negocio.

Un WISP tiene la tarea de controlar y manejar decenas de variables muchas de las


cuales no están sobre tu control. Por poner uno de los muchos ejemplos, tenemos
variables externas e internas las cuales describo a continuación.

Variables Externas

Estado del servicio del proveedor​: Esta variable es de extremo importancia y es la que
define la calidad del servicio que brindamos. De nada te sirve tener los mejores equipos
instalados y con la mayor calidad posible si no tienes un buen proveedor que te de un
servicio estable, confiable y eficiente.

Dentro de estas variable está el ping que es el​ RTT o Round Time Trip​ o tiempo de ida
y vuelta de un paquete. Luego de ser enviado el un paquete de prueba con el comando
ping este debe regresar con una respuesta. Este tiempo no puede ser mayor a los 30
ms. A estos 30 debemos de sumarle nuestra latencia interna de nuestra red que sí
tenemos control. Una red promedio anda por los 12 ms lo que sería 30 más 12 igual a
42.

No es la mejor medida 42 pero está dentro de los parámetros normales de una buena
conexión.

Ser wisp es ser negociante.

Conociendo una red WISP

¿Qué es un router?

Es un dispositivo electrónico que se encarga de encaminar paquetes de datos de una


red a otra red. Sin importar su marca, modelo o año de fabricación hace el mismo
trabajo: interconectar redes.
Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com
2

¿Qué es un switch?

Dispositivo electrónico usado para conectar hosts. Estos pueden ser dos
computadoras, dos celualres, una computadora y un router, un celular y un router.. Y
cualquier combinaación de dispositivos.

REDES WISP ENRUTADAS

Para crear una red ​WISP ​escalable, tolerante a fallos sencilla y fácil de administrar lo mejor que
podemos hacer es dividir la red completa en subredes. Para esta división podemos tomar en
cuenta las ubicaciones, radios, zonas o cualquier otro parámetro de nuestra conveniencia.

Ventajas de crear una red WISP L3

Yo actualmente utilizo una red por cada radio, así me es más fácil la administración del tráfico.
Por ejemplo si quiero cambiar un radio completo de línea de internet hacia otra solo tengo que
crear una regla de marcado de paquetes en el mangle hacia una ruta en específica con el
src-address=”red del radio”​.

Otra ventaja de tener una red ​WISP en Leyer 3 es que no tendrás que preocuparte más por el
enemigo de toda red de área local: ​el broadcast (BC). Las personas que tienen redes grandes
ya se han topado con el problema de lentitud y la necesidad de comprar equipos cada vez más
costosos para descongestionar la red.

Con una red L3 este problema desaparece. Como sabemos los routers son delimitadores de
las redes LAN y por tanto estos no pasan los BC de una red a otra. De paso elimina la
necesidad de crear y transportar ​VLANs ​de una localidad a otra debiendo configurar
manualmente cada router por donde pasa la VLAN.

El uso indiscriminado de VLANs para administrar una red complica la detección de errores y la
modificación de la estructura de una red. Desde el punto de vista administrativo las VLANs son
ideales para dividir un switche en diferentes partes y usar cada para digamos tipos de
dispositivos, departamentos, dividir servidores de máquinas… necesitando un router para la
comunicación inter-vlan.

El uso de VLANs también crea la necesidad de comprar switches administrables los cuales son
muy costosos. Como todo negocio la idea es generar ingresos con la menor cantidad de
recursos posibles sin comprometer la calidad del servicio.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


3

Te cuento mediante un ejemplo cómo ​utilizar redes dentro de una red ​WISP ​para dividir grupos
de clientes. Digamos que tienes un rocket con 20 clientes y estos se encuentren conectados al
router que los administra. Todo el tráfico de esos clientes se puede agrupar digamos en la red
10.3.0.0/24.

/ip fire mangle add src-address=10.1.0.0/0


new-routing-mark=TRAFFIC_RP2

/ip route add dst-address=0.0.0.0/0 gateway=10.1.0.1 distance=1


routing-mark=TRAFFIC_RP2

Podemos  usar  ​VLSM  ​pero  para  simplificar  la  documentación 


usaremos máscaras de 24. 

Es importante señalar el comportamiento del lookup process de los routers mikrotik a la hora de
decidir la interfaz de salida de un paquete determinado. Como puede verse en el mensaje de
abajo este es desplegado por el router cuando ingresas una ruta marcada.

Route that have routing-mark are placed, not in the default routing
table, but in separate routing tables. Routes with different routing
mark are in different routing tables. Routes with same routing mark
are in the same routing table. Packets that have routing-flow equal
to that of any route are first routed by that routing table, and only
if lookup in that routing table fails they are routed normally

La traducción al español es: ​“rutas que tienen marcas de rutero no son colocadas en la tabla de
enrutamiento por defecto (main) si no en una tabla de enrutamiento separada. Rutas que tienen
diferentes marcas de ruteo están en distintas tablas de enrutamiento. Rutas que tienen la
misma marca de ruteo se colocan en la misma tabla. Paquetes que su flujo de enrutamiento es
igual a alguna de esas rutas son primeros enrutados en base a esos routing table secundarios
y solamente si no se encuentra ninguna coincidencia entonces son enrutados usando la tabla
de enrutamiento por defecto osea la main.”

.
Paquete MARCA1

LAN1

Esto significa que cada routing mark crea una tabla separada de enrutamiento ​FIB​. Al ingresar
un paquete marcado primero se busca una coincidencia dentro de la tabla FIB de esa marca si
se encuentra una salida entonces este es encaminado por esa salida. Si no se encuentra nada

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


4

entonces el router en vez de descartar el paquete busca en la tabla main algún registro que le
indique por qué interfaz sacar el paquete.

Si no encuentra ningún destino entonces lo lanza por su ruta 0.0.0.0/0. Si no tiene esta ruta
entonces descarta el paquete y devuelve ​no route to host​. Si el router no ​buscará en la
tabla main luego de hacer la búsqueda en la tabla marcada entonces nos encontraríamos con
muchos inconvenientes como por ejemplo de crear rutas 0.0.0.0/0 en cada ​FIB ​osea por cada
ruta marcada.

Bien, la red lista para ser montada ¿Qué hago para crear una red L3? Cual router me
recomiendan​? Actualmente el router que mejor desempeño ofrece vs. su costo es el
RB750Gr3​. ​Este router tiene 2 procesadores con 2 hilos de ejecución cada uno. Yo pienso que
podría manejar 200 clientes y balancear 2 o 3 lineas al mismo tiempo sin sentir ningún tipo de
congestión.

CÓMO SE ARMA UNA RED ENRUTADA

El primero paso es crear la topología de la red. Dónde irán los routers, los switches y definir las
redes que emplearemos. Dónde se conectarán las sectoriales, los radios de transporte, Para
este proceso existen muchas herramientas disponibles de diseño. Yo personalmente los hago
en un papel o mascota pero para los fines es lo mismo.

Por su propia naturaleza, las redes enrutadas no tienen que tener un router central o principal.
La topología ideal para una red WISP es aquella que carece de centralización. No hay router
central ni balanceador centra aunque pudiera exister no es necesario centralizar las diferentes
tareas que desempeñan los routers.

Una red descentralizada es más tolerante a fallos como cortes energéticos, cambios de
frecuencia de enlaces PTP, routers frizados… etc. También es más sencillo redirigir tráfico,
cambiar clientes y radios de líneas, balancear segmentos grupos de clientes y otros no.

Dicho esto, veremos a continuación una pequeña red que contiene 3 routers. Cabe señalar que
desde esta perspectiva los routers no reciben el internet directamente de las líneas. Este
diseño invierte el sentido que comúnmente vemos en las redes WISP donde los routers van
primero que los switches. En este caso los switches reciben las líneas y estos reparten a los
routers el ancho de banda total disponible.

En el siguiente dibujo mostraré cómo era la red ​Oxigeno Networks en el momento de escribir
este documento. Esto te puede servir de guía para que tengas una idea de cómo diseñar la
tuya propia.

REDES WISP CON MULTIPLES ACCESO A INTERNET

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


5

ESCENARIO 1

En el siguiente caso de estudio se muestra una red en donde se quiere tener acceso a internet
desde diferentes puntos. En una red donde se tiene múltiples accesos a internet la redundancia
es un derivado del propio diseño.

Cuando digo “​múltiples accesos a internet​” se refiere a que los servicios contratados para suplir
a los clientes no se encuentran en un solo punto físico ​sino que se encuentra en varios puntos
distribuidos dentro de una zona.

RP1 y RP2 son los router bordes de la red. Son los encargados de encaminar los paquetes al exterior.
Usualmente ONT y/o ​MÓDEMS​. Si RP1 y RP2 no hablan ningún protocolo de enrutamiento deberán utilizarse
NATs en L1 de R1 y R2 para que los paquetes que ingresan desde internet a los RPs destinados al interior de la
red no sean descartados debido a que no existe registro en sus respectivos FIBs

Entiéndase por paquetes desconocidos los que no tienen ninguna coincidencia durante el
proceso de búsqueda en el ​FIB ​(​Forwarding ​Information Base​). Estos dispositivos utilizan un
tipo de memoria llamado ​CAM ​(Content Addressable Memory) la cual está específicamente
diseñada para al ingresar un valor de búsqueda y esta busca en un array asociativo
devolviendo el lugar donde el valor fue encontrado en caso de que exista.

Consulta la tabla de enrutamiento:​ /ip route pr

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


6

Consulta la tabla ARP:​ /ip arp pr

Como se puede ver en la gráfica, tenemos dos puntos de acceso a internet los cuales serán
utilizados por todos los host dentro de la red ​WISP​.

L1,L2…. L5 son las interfaces lan de los​ routers​. LAN1, LAN2… LAN5 etc.

En el dibujo están marcados con ​RP ​significando ​Router Proveedor​. Dependiendo del país y
de la disponibilidad de acceso a internet puede que sea ONT o alguna clase de MODEM. Para
los fines de nuestro caso de estudio es lo mismo. Estos están directamente conectados a los
dos router ​R1-RP1 ​y ​R2-RP2. ​Estas conexiones (10.0.0.0/24 y la 10.1.0.0/24) bien podrían ser
enlaces inalámbricos o conexiones por medio a cables ethernet o fibras ópticas.

En cada torre está instalado un router. Este router puede ser de cualquier marca o modelo…
sin embargo usaremos la sintaxis de ​MIKROTIK ​en los comandos.

La idea de esta topología es que teniendo dos torres las cuales cada una tiene su servicio del
proveedor estas puedan compartirse el internet a través de la red 10.2.0.0/24 dependiendo del
estado de los servicios de los routers ​RP​. Si alguno pierde servicio del proveedor que el tráfico
fluya desde la torre vecina hacia la otra torre por medio al enlace ​inalámbrico​.

Lo que se debe hacer en este caso es establecer en ambos routers ​R1 ​y ​R2 ​rutas por defecto
estáticas a sus ​RP ​directamente conectados con una métrica digamos de 1. Esta ruta principal
por defecto siempre estará activa y se ​desactiva (se torna azul) si por alguna razón su ​RP
pierde servicio de internet.

En este caso eventual todos los clientes conectados al router ​R1 ​perderán conectividad al
exterior. Sin embargo como ​R2 ​tiene servicio activo lo que debemos hacer es indicarle al ​R1
que en caso de que pierda esa ruta por defecto por ​L1 ​utilice una segunda ruta alternativa por
su interfaz ​L2 ​con una métrica de 2. En este caso ​R1 ​enviará todos los paquetes desconocidos
a ​R2 ​utilizando​ L2 ​y este a su vez a su ​RP ​directamente conectado.

10.0.0.0/24 RP1 asociada a L1 del router R1. Natear L1


si RP1 no tiene en el FIB las rutas de la red
WISP

10.1.0.0/24 RP2 asociada a L1 del router R2. Natear L1


si RP2 no tiene en el FIB las rutas de la red
WISP

10.2.0.0/24 Red usada para interconectar ​routers​ R1 y


R2

10.3.0.0/24 Red para clientes router R1 en zona A.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


7

asociada a L3

10.4.0.0/24 Red para clientes router R2 en zona B


asociada a L3
Dicho de otro modo más simple: crear dos rutas por defecto con métricas distintas indicandole
al router R1 dónde debe enviar los paquetes desconocidos.

Para ​R1​>

/ip route add dst-address=0.0.0.0/0 gateway=10.0.0.1 distance=1


check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=10.2.0.2 distance=2
check-gateway=ping

La primera ruta es la ruta por defecto que utilizará ​R1 ​en todos los paquetes desconocidos. La
segunda es en caso de que pierda la primera (se torna azul) entonces usará la segunda para
encaminar los paquetes desconocidos.

Para ​R2​>

/ip route add dst-address=0.0.0.0/0 gateway=10.1.0.1 distance=1


check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=10.2.0.1 distance=2
check-gateway=ping

La primera ruta es la ruta por defecto que utilizará ​R2 ​en todos los paquetes desconocidos. La
segunda es en caso de que pierda la primera (se torna azul) entonces usará la segunda a
través de L2 para encaminar los paquetes desconocidos.

ESCENARIO 2

En el siguiente escenario las dos torres no se encuentran comunicadas y los dos ​RP ​están en
el mismo local físico. Estos dos RPs se comunican vía enlaces inalámbricos con los routers que
manejan​ la red WISP.

Para lograr el mismo objetivo se necesitará definir dos IP por interfaz en los routers R1 y R2.
Esto es para que pueda haber comunicación en capa 3 entre los dos RP. A la topología anterior
le agregaremos dos IP a las interfaces L1 de ambos routers para que puedan comunicarse con
sus RP adyacentes y también con el otro router ​RP ​conectado vía un cable de red
representado por la línea en trazo.

Para ​R1​>

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


8

/ip add add address=10.1.0.3/24 interface=LAN1


/ip route add dst-address=0.0.0.0/0 gateway=10.1.0.3
check-gateway=ping distance=2

Para ​R2​>

/ip add add address=10.0.0.3/24 interface=LAN1


/ip route add dst-address=0.0.0.0/0 gateway=10.0.0.1
check-gateway=ping distance=2

Considerando los ​RP ​como switches (ONT de fibra óptica funcionan así y la mayoría de
MÓDEMS de los proveedores) entre ellos dos nunca habrá comunicación directa. Sin embargo
los dos routers sí se podrán comunicar con los dos ya que el RP1 repetirá las tramas al RP2 y
vice versa.

En este escenario los dos router de el proveedor se encuentran en el mismo local y las dos torres no están
conectadas entre sí estando físicamente alejados R1 y R2.La linea entrazo representa una conexión vía ethernet
entre los dos router RP1 y RP2

GATEWAY PARA RADIO ENLACES PTP


Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com
9

Una red WISP tiene muchos enlaces ptp para el transporte de datos hacia diferentes zonas de
distribución. Normalmente estos radios se configuran en modo puente. Se le colocan los dns de
nuestra red y el gateway uno de los dos routers adyacentes.

Sin embargo esto plantea un dilema a la hora de ser 100% tolerante a fallas. Si accedo a un
radio desde otra red que no es la suya entonces para comunicarme con ellos necesito una
puerta de enlace.

Si esta puerta de enlace se cae entonces los radios quedarían inaccesibles desde fuera de su
red local. Esto no plantea problema si tu red completa está en una sola red, digamos la
192.168.10.0/24 sin embargo si está dividida por diferentes redes entonces estos radios no
serán alcanzales.

Una forma de resolver esto temporalmente es colocar un nat en la interfaz que maneja el radio
osea con el out-interface la interfaz que maneja esos radios. Así le haces creer a estos que tú
estás accediendo desde el interior de su propia red ya que la ip que le llega a él es la del
gateway debido al nating en el out-interface conectada a los radios.

Para resolver este problema tenemos un protocolo muy utilizado y versátil llamado ​VRRP
Virtual Router Redundancy Protocol. Con este protocolo dos o más routers comparten una
misma ip. Sin embargo cabe señalar que esta ip compartida solamente uno de ellos responderá
ante una llamada ARP. Esto significa que los demás routers simplemente ignorarán las tramas
dirigidas a esa ip compartida.

Como pueden ver en la imagen, tenemos 3 interfaces virtuales de las cuales 2 están en estado
backup y 1 en estado master. Esto significa que las interfaces backup están a la espera de que su
router anfitrión se detenga de enviar los paquetes alive para entonces entrar en modo master.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


10

En este protocolo tendremos dos estados de una interfaz. Las master y las backup. En el
winbox aparecerá como una interfaz virtual con una ​B ​(backup) los que están en estado backup
y una ​RM ​(Running Master)​ ​si esta interfaz es master osea dueña de la ip compartida.

¿Cómo funciona el protocolo? Pues es muy simple y efectivo. El router con mayor prioridad la
cual puede ser modificada por el administrador, envía periódicamente un paquete indicando a
todos los demás routers que participan en el protocolo que está “vivo”.

Este intervalo de tiempo en el cual los paquetes son enviados pueden ser modificados por el
administrador. De hecho este timer debe ser el mismo en todos los routers que participan de lo
contrario habrán más de un router RM y ya saben que no pueden haber dos host con la misma
ip dentro de una red local.

SIMPLE QUEUE

La regla que verán a continuación la utilizo para dar diferentes velocidades dependiendo de la
hora del día. En este caso desactivar la velocidad asignada a ese cliente desde las 23:50:00
hasta las 8:00:00 de la mañana.

Dicho de otro modo, la regla funcionará de 8 de la mañana hasta las 11 y 50 minutos.

Esta regla que funcionará únicamente de 8 de la mañana hasta las 11:50 de la noche. Quedando inactiva
ósea en rojo luego de esas horas diariamente. Como puede verse puedes seleccionar los días de la semana

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


11

que cada regla está activa.

BALANCEO L3 NO ES SUMA

BALANCEO DE CARGA DE LÍNEAS DEL PROVEEDOR

SUMA DE ANCHO DE BANDA EN L2


SUMATORIA DE ANCHO DE BANDA CON BONDING

SCRIPTS GENERALES

Lista de scripts de uso general. Utilizó el nombre de las interfaces ethernet como LAN1,LAN2…
etc y las inalámbricas agregando una W. WLAN1, WLAN2….

1. Cambia el cpe a 20mhz de ancho de canal, le cambia el nombre al radio a 118 RAUL
DONE y el nombre al equipo al mismo nombre.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


12

/interface wireless set channel-width=20mhz numbers=WLAN1


/system identity set name="118 RAUL DONE"
/interface wireless set radio-name="118 RAUL DONE"

Como instalar tu raspberry con mikrowisp

1. Utilizar un puerto físico de un router independiente para la raspberry. Este router puede
estar físicamente en cualquier punto. Lo importante es que se pueda acceder a él desde
cualquier parte de la red. Si no tienes puertos disponibles asigna una ip adicional a una
interfaz que esté conectada a un sw y conecta la raspberry en ese switch.

2. Asignarle una dirección IP a ese puerto y habilitar el DHCP server en ese puerto.

3. Conectar la raspberry a ese puerto y encenderla.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


13

4. Esperar que la raspberry bootee y solicite una dirección IP al DHCP server de la


interfaz.

5. Utilizar el comando ​/ip dhcp-s lea pr para ver cual dirección IP le entregó el
router a la raspberry

6. Buscar el registro con el host-name raspberry y cuando lo encuentres fíjate en el


número que le asignó el dhcp server. En mi caso como puede ver es el 0 entonces
sustituye el 0 por el valor que te dio a ti e introduce el siguiente comando ​/ip dhcp-s
lea make-static numbers=0. ​Si luego por alguna razón quieres cambiar la ip del
server contáctame 809.980.1532

7. Luego de ahi ya la raspberry tendrá una ip fija. Esa ip será la que usarás para entrar al
sistema. Para facilitar la entrada es bueno que hagas una entrada estática en los DNS
para que los usuarios entren con un domain name en vez de usar una IP.

Entrada DNS estática en el DNS server

Digamos que tu negocio se llama NOMBREWIFI y quieres que tus usuarios entren a la
raspberry usando el domain nombrewifi.net entonces lo que debes hacer es introducir ese
nombre de dominio estáticamente en tu/tus mk que administran los clientes. Para ello introduce
los siguientes comandos.

/ip dns static add address=nombrewifi.net


/ip dns static add address=​www.nombrewifi.net
/ip dns static add address=http://www.nombrewifi.net

Es importante mencionar que esto sólo funcionará si tienes los DNS de tus clientes apuntando
al router que los administra.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


14

NETWORK ADDRESS TRANSLATION (NAT)

“Activale el nat para que de internet”.. Es una de las frases más usadas x los WISP cuando
están instalando un cliente. Un cpe que esté en modo router debe tener el NAT activo para que
pueda tener comunicación fuera de su red local que serían dos, la wifi y la lan.

Sin embargo qué es lo que hace el nat realmente, por qué lo necesitamos y cuando y quién se
lo inventó. Estas son unas de las preguntas que tu como WISP debe hacerte. Entender esto es
parte del procedimiento que dia a dia usamos para instalar y administrar nuestros servicios.

Bien dicho esto empezamos por definir lo que es la traducción de direcciones de red. Copiando
y pegando de wikipedia podemos leer su definición:

La ​traducción de direcciones de red o ​NAT (del inglés Network Address Translation)


es un mecanismo utilizado por ​routers IP para intercambiar ​paquetes entre dos ​redes
que asignan mutuamente ​direcciones incompatibles. Consiste en convertir, en tiempo
real, las direcciones utilizadas en los paquetes transportados. También es necesario
editar los paquetes para permitir la operación de ​protocolos que incluyen información
de direcciones dentro de la conversación del protocolo.

Dicho esto vamos a definir para un wisp qué es un nat. Definición 1: Mecanismo por el cual las ONT
y los MODEMs de nuestros proveedores pueden encaminar los paquetes que vienen de internet
hacia los multiples host que están dentro de nuestra red.

¿Por qué los routeres de nuestros proveedores no pueden encaminar los paquetes que vienen
desde fuera hacia nuestros clientes y dispositivos? Esta es una respuesta fácil. No conocen la red
de destino. Para las ONT y MODEMs son direcciones de red inalcanzables debido a que no existe
ruta que le indique a estos dipositivos cómo llegar a los host que pertenecen a otra red distinta a la
que tienen conectadas. Recordando que estos dispositivos no están diseñados para enrutar
paquetes entre diferentes redes hay que reconocer sus limitaciones por diseño. Veamos en un
pequeño diagrama lo que sucede.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


15

En la imagen tenemos una pequeña red interna para representar lo que generalmente tenemos
dentro de una red. Como se podrá ver tenemos 3 redes locales que tenemos bajo nuestro control.
La 192.168.22.0, 192.168.34.0 y la 10.0.0.0. Estas 3 redes están directamente conectadas al R1 el
cual tiene conocimiento de su existencia ya que son interfaces que pertenecen al mismo router.

La ONT por otra parte conoce la 10.0.0.0 sin embargo no conoce ni la 192.168.22.0 ni tampoco la
192.168.24.0. No tiene información de cómo encaminar un paquete hacia esas redes y si recibe un
paquete con destino a una de esas redes responderá con un “​no rute to host​” osea no hay ruta que
le indiquen como llegar a esas redes.

Para resolver este problema tenemos 2 opciones. Opción uno es agregar una ruta estática en la ont
enseñándole que los paquetes hacia la red 192.168.24.0 y 192.168.22.0 debe encaminarlos a
travez de su router vecino 10.0.0.2.

Con este “parche” se resuelve rápidamente el intercambio de paquetes entre la ONT y los host
internos que están conectados a otras interfaces del router. Esta solución es especialmente util si

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


16

solo usamos un solo rango dentro de nuestra red WISP. No importa si la tenemos subdividida
usando vlans. Si es el mismo rango funciona igual.

En esta imagen se puede apreciar dónde en las ONT de claro es que se configuran las rutas estáticas.

Esta solución tiene solo un pequeño inconveniente. A medida que crece la red entonces tendremos
que ir agregando rutas estáticas a cada dirección de red nueva esto es debido a que los fabricantes
de las ONT y MODEMs no incorporan protocolos de enrutamiento dinámico en esto dispositivos.

Otra forma de resolver esto es aplicando una traducción de direcciones de red o NAT en la interfaz
de salida del router R1 (en la imagen NAT2) y hacerle creer al router ONT que solo tiene un host
conectado, osea el R1 y este se encargará de modificar todos los paquetes que salgan hacia la
ONT quitando la dirección de red fuente por su interfaz de salida L1.

Desventajas del NAT

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


17

Conceptos básicos de QOS - Calidad De Servicio

Como todos podrán imaginar vivimos en un mundo globalizado donde cada día el Internet se vuelve
más importante. Esto es producto de lo que los expertos denominan "​convergencia​": los sistemas
se vuelven cada vez más integrales y entrelazados, compartiendo el mismo medio para su
distribución y consumo.

Antes existía una red swicheada por circuito para el teléfono; una red del tipo broadcasted para la
TV; una para la radio, una para el sistema de seguridad, otra para el Internet mismo... etc. Hoy en
día todos estos servicios se están entregando y distribuyendo a través de una sola red del tipo
"packet-switched-network"​.

​SMLXL

Esto es algo genial desde el punto de vista económico, pues una misma red puede usarse para
cualquier cosa, abaratando los costos de distribución de los servicios. Recuerden que antes para
llamar a cualquier parte del mundo teníamos diferentes tarifas. Hoy en día eso no existe, pues
usando whatsapp podemos llamar libre de costo a cualquier lugar.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


18

Esta integración o convergencia ha traído que todos estos servicios se ​"jalen los moños" por los
recursos de la red. Todos quieren pasar al mismo tiempo y exigen cada día más capacidad de la
red, la cual, obviamente, no es ilimitada.

Esto ha planteado un problema, un dolor de cabeza para todos los administradores de red. Tienen
que lidiar con los usuarios, como si fueran policías de tránsito, para darles paso, detenerlos y hasta
"aniquilarlos". Es algo elemental: una ambulancia (routing o protocol data) no puede tener la misma
prioridad que otro usuario que "va al parque o al cine a ver una película" (descargar un archivo de 8
tb).

Dicho esto, está claro que debemos implementar algún sistema que nos permita darle prioridad en
el tráfico a las "ambulancias" o "bomberos" , frente a otros que pueden esperar.

A este conjunto de herramientas, sistemas y técnicas se le ha llamado ​QOS, ​que en inglés no es


más que ​Quality Of Service o ​Calidad De Servicio​. Inicialmente fue una herramienta no tan
compleja, pero debido a lo explicado anteriormente, se ha convertido en una verdadera ciencia del
mundo del networking.

QOS ​no aumenta la capacidad de manejo de tráfico de una carretera. El rol principal de este
conjunto de técnicas es darle paso a los paquetes más importantes. ¿Quién decide qué es
importante?: el administrador.

Congestión y QOS, ¿Qué significan estos términos?

Congestión: situación en la que la cantidad de datos que quiere pasar por un dispositivo o medio
sobrepasa su capacidad. Una congestión similar es la que ocurre en las carreteras de alto tráfico en
horas pico. Todos los vehículos quieren pasar en un mismo lapso de tiempo provocando
taponamientos.

Sin embargo, a diferencia del tráfico vehicular donde no puedes simplemente eliminar a un vehículo
para hacerle espacio a una ambulancia, por ejemplo, en una red tenemos la facilidad de eliminar a
los que están provocando el embotellamiento. El sacrificio de algunos ayuda al bienestar común.
Eso es QOS.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


19

Repito: QOS no ​aumenta la capacidad de datos que puedas transferir. Simplemente le da


prioridad a algunos a costa de sacrificar a otros. Al igual que en una carretera los conductores se
echan a un lado para dejar pasar los servicios de emergencia: eso es Calidad De Servicio

Tipos de retardo

Desde que un paquete ingresa en la interfaz de un router existen innumerables motivos por los
cuales este toma un tiempo en salir y en llegar a su destino. ?Dónde es que se pierde el tiempo a la
hora de transferir un paquete de datos de un lugar A a un lugar B? Veamos:

Retardo por procesamiento: Tiempo que le toma a un router tomar un paquete de una interfaz,
examinarlo, procesarlo y colocarlo en la cola de salida de otra (o la misma) interfaz.

Retardo de cola: Tiempo que toma en salir un paquete que está en la cola de salida de la interfaz.

Retardo de serialización: Tiempo que le toma al hardware del router colocar bit a bit el paquete en el
medio. Tiempo que le toma al router colocar la trama en el medio de transmisión (cobre, fibra, etc)

Retardo de transmisión: Tiempo que le toma al paquete llegar a su próximo salto.

¿Cómo funciona un QOS?

La calidad de servicio puede ser dividida en dos partes principales. Una de ellas es la operación
local de los datos y otra es la señalización que en leyer 3 le podemos llamar ​marcado de paquetes
(mangle)​. Estos son sus dos componentes principales. No importa la marca o el modelo del
dispositivo usado para aplicar estos dos componentes.

Uno de los mecanismos más básicos y antiguos de controlar la congestión es usar el llamado "​tail
drop​" que consiste en descargar los paquetes cuando la cola de la interfaz está llena. Es como un
restaurante adonde van llegando y saliendo personas.

Si entran más de las que salen llegará un momento en que se llene y entonces el "portero" dirá a los
nuevos que van llegando: "N​o pueden entrar. Está full​".

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


20

Este modo de operación plantea un problema y es que lo más importante puede que no llegue a su
destino en el momento deseado y si llega tarde pues ya no es necesario. Imagina que mandas a
buscar una pizza y el deliveri se tarda tanto en llegar por la congestión que termina llegando al otro
día. ¿Necesitas la pizza? Obviamente ya no.

Lo mismo pasa con los paquetes de voz que llegan demasiado tarde. Deben llegar con un límite de
tiempo determinado para que estos pueden ser útiles, de lo contrario solo servirán para cargar más
la aplicación que lo necesitaba, pues igual debe procesarlo, solo que al darse cuenta que llegó muy
tarde simplemente lo descarta (leyer 7 drop).

Otro problema del taildrop es la ​sincronización global TCP de las conexiones. De este tema
podemos pasar un mes discutiendo sin llegar a comprenderlo del todo. Creo que es mejor que
hagas un googleado que te dará un sinfín de informaciones al respecto.

Operación y Marcado

Estos son los dos pilares del QOS. Su modo de operación, que en concepto es bastante fácil de
comprender, y el marcado o señalización, que consiste en pasar la información de un router a otro
sobre la importancia de un paquete.

Valor TOS (DSCP)

Todos los routeres que pertenecen a una misma administración deben de entrar en un acuerdo
donde el tratamiento a cada tipo de paquete marcado debe ser (no necesariamente) el mismo. Al
menos la identificación debe ser la misma para que se le haga un tratamiento específico
dependiendo de su marca.

Algo importante es que esta marca no es del tipo de marca "mangle" , que no sale del router. Este
es un tipo de marca que se hace modificando el contenido del paquete y del cual voy a hablar en un
artículo más detallado sobre ese tema en específico. Este garantiza un tratamiento similar en cada
router durante sus saltos entre hops.

Weigthed Random Early Detection WRED

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


21

El modo de operación también merece un artículo separado debido a su complejidad. El algoritmo


usado actualmente se le llama ​WRED el cual es el encargado de mantener "a ralla" a todo el que de
alguna manera quiera ahogar el medio con datos.

Este algoritmo es independiente de la marca o modelo del router. Todos funcionan de forma similar
y se le aplican los mismos conceptos teóricos. WRED es como un policía de tráfico que se pone
bastante nervioso cuando nota que la intersección donde él está trabajando se congestiona.

Cuando se congestiona se vuelve implacable y empieza a aniquilar a todo el que se quiera pasar de
listo a una velocidad mayor de la acordada. Al controlar la cantidad de paquetes caídos, los
protocolos de las capas superiores y sus sistemas de control de congestión, él reacciona bajando la
tasa en la cual estos son enviados.

A este proceso de control se le llama "windows size" y es una de las principales características del
protocolo ​TCP/IP ​y parte integral de su diseño.

Jitter: Short term timing variation from its ideal position


Latency:
Packet Loss:

Comportamiento Inter Host o Per Hop Behavior (PHB)

Si encuentras una traducción mejor a este término agradecería me la dejes en los comentarios. El
comportamiento inter-host define el modo de clasificación y tratamiento de los paquetes entre los
routeres responsables de conectar dos puntos determinados.


Es responsabilidad del administrador definir la clasificación y que esta sea coherente entre los
routeres. Dicho de otro modo, un paquete marcado como voz en el router R1 debe significar voz
también en el router R2.

Conclusiones

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com


22

Un QOS bien implementado no se trata de googlear y encontrar cualquier lista de códigos y


copiarlos y pegarlos en un router. Hay que analizar los requerimientos de la red, lo más importante y
lo que más demanda tiene dentro de nuestra red para darle el correcto tratamiento en todo el
trayecto (saltos) de la información.

Luego de esta identificación corresponde crear nuestro PHB, el cual usaremos para identificar el
tipo de información que pasa por cada router inequívocamente; y por último, definir el tamaño y el
tratamiento de las colas que cada uno de estos flujos de datos tendrá junto a su probabilidad de
descarte.

Preparado por: Oliver Ramirez 809.980.1532 | oliver.rs@gmail.com