Vous êtes sur la page 1sur 90

Cisco TechAdvantage Webinars

Next Gen MVPN


Rabiul Hasan
Ujjwal Vinod

© 2013 Cisco and/or its affiliates. All rights reserved.


Follow us @GetYourBuildOn
1
•  MULTICAST VPN BUSINESS DRIVERS

•  OVERVIEW
•  PROVIDER-TREE
•  mLDP and P2MP-TE
•  DESIGN DETAILS
o  UPSTREAM MULTICAST HOP
o  DUPLICATE TRAFFIC AVOIDANCE
o  SWITCHING FROM SHARED TREE TO SOURCE C-TREE
o  PIM-SM WITHOUT INTER-SITE SHARED C-TREES

•  SUPPORTED PROFILES
•  SAMPLE CONFIGURATIONS
o  IOS/XE
For Your
o  IOS-XR Reference

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 2
© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 3
Consumer Internet Video traffic will reach 20Mobile
EB/month
Video in 2016

20.1 38% Mobile Video

14.8 6% Internet PVR

11% Ambient Video


10.5
7.05 18% Live Internet TV

4.8 Internet Video


27%
2.5 4x Growth, 34% CAGR

2011 2012 2013 2014 2015 2016

Consumer Internet Video Traffic


Source: Cisco Visual Networking Index—Forecast, 2011-2016

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 4
IPv4 IPv6 IPv4 IPv6

Service Native Native mVPN mVPN

PORT
C-Multicast Signaling PIM BGP

PIM mLDP P2MP TE


Core Tree Signaling (pt-mpt) (pt-mpt | mpt-mpt) (pt-mpt)

Encapsulation IP/GRE LSM


/Forwarding

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 5
IP multicast packets are transported using
1
MPLS encapsulation.

2
MPLS encoding for LSM documented in
RFC-5332.

3
Unicast and Multicast share the same label
space.

MPLS protocols RSVP-TE and LDP are


4
modified to support P2MP and MP2MP LSPs.

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 6
•  mLDP in-band-signaling
IPTV / Internet multicast transport •  1:1 mapping between IP multicast flow and LSP
•  non-VPN

•  Multicast over VPLS VPN


VPLS LSM •  P2MP mLDP or RSVP TE for P-tree
•  Dynamic tunnels

Carriers Carrier service •  A provider offering services to another provider

MVPN (RFC-6037 i.e. Rosen •  MP2MP mLDP for MI-PMSI ( i.e. default MDT)
Model) •  P2MP mLDP or RSVP TE for MS-PMSI ( i.e. data MDT)

•  Dynamic model of above.


MVPN (Dynamic partitioned MDT) •  Using mLDP MP2MP for the dynamic MDT.

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 7
7
•  Growing Demand
•  Growing number of MPLS-VPN customers have IP Multicast Traffic
•  Volume and Type of multicast Traffic
•  Expected to grow to a significant share of the total traffic
•  Increasing demand for video, rich-media

•  Evolution of Label Switched Multicast


•  Extend MPLS-VPN service offering to include support for multicast traffic
•  Same architecture/Model as 4364 VPN unicast
•  Re-use the 4364 unicast mechanisms with extensions
•  BGP as the Signaling Protocol for all services
•  No PIM in the Core
•  Same flexibility and scalability of 4364 VPN unicast

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 8
© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 9
PE2 CE2 Sx
Site-2

PAYLOAD C-header P-header


Rx
Sx
CE1 PE1 Rx
Site-1
Rx PE3 CE3 Site-3
SP-CLOUD
Sx

PE2CE mcast PE2PE routing(uni/mcast/label-swap) PE2CE mcast

CE2CE mcast

CLASSICAL-support NG-support

ENCAPSULATION OPTIONS IN CORE IP/GRE MPLS

OPTIONS TO DISCOVER PEs PIM BGP

CORE/PROVIDER-TREE PIM-ASM/SSM/BIDIR mLDP, P2MP-TE, INGRESS-REPLICATION

C-MCAST ROUTING OPTIONS (PE-PE) PIM BGP

PE-CE MCAST ROUTING PIM-ASM/SSM/BIDIR mLDP, BGP

BINDING BTW FLOW & P-TREE PIM BGP

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 10
CE2
Site-2 Sx

Rx

PE2 PE3
Sx
CE3
Site-3

Rx
Sx
CE1 PE1 Rx
Site-1
Rx PE4 CE4 Site-4

Sx

v4/6PIM LDP, RSVP-TE, v4PIM, mLDP, P2MP-RSVP-TE v4/6PIM


MULTICAST CORE PROTOCOL OPTIONS CORE/PROVIDER TREE
1)  PIM (SM, SSM, BIDIR) 1)  P2MP
2)  MPLS mLSP using mLDP 2)  MP2MP
3)  MPLS mLSP using RSVP P2MP-TE 3)  P2P

MODEL AUTO-DISCOVERY
1)  ROSEN: Default MDT (MI-PMSI) [MUST], On- 1)  [RFC-6037] PIM (ASM, SSM, BIDIR) + BGP
Demand Data MDT (S-PMSI) [OPTIONAL] 2)  [RFC-6514] BGP
2)  PARTITIONED: On-Demand Partition MDT
(MS-PMSI) [MUST], On-Demand Data MDT (S-
PMSI) [OPTIONAL] C-MULTICAST ROUTING OPTIONS
3)  IN-BAND: On-Demand core-tree per-VRF, per- 1)  PIM (ASM, SSM, BIDIR)
S,G 2)  BGP

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 11
Without Enhancements With Enhancements

Unified signalling protocol for unicast and


NO YES
multicast VPN

Unified forwarding plane using MPLS labels NO YES

Auto-Discovery with Unidirectional P-Tree NO YES

PIM-SM in VRF without SHARED tree creation NO YES

Inherent Stability & Reliability of BGP in use NO YES

Simplification of ASSERT in core NO YES

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 12
1 2 3 t
BGP EXTENDED COMMUNITY: Here PE loopback BGP MDT SAFI: The source PE address and the MDT BGP MCAST-VPN SAFI: The MCAST-VPN NLRI
(source address) information is sent as a VPNv4 prefix group address are passed to PIM using BGP MDT SAFI is carried in BGP using BGP Multiprotocol
using Route Distinguisher (RD) Type 2 (to distinguish updates. The RD type has changed to RD type 0 and Extensions with an AFI of 1 or 2 and SAFI of
it from unicast VPNv4 prefixes). The MDT group address BGP determines the best path for the MDT updates M C A S T- V P N . The NLRI field in the
is carried in a BGP extended community. before passing the information to PIM. MP_REACH_NLRI/MP_UNREACH_NLRI attribute
contains the MCAST-VPN NLRI.
Prior to the introduction of MDT SAFI support, the BGP
extended community attribute was used as an interim
solution to advertise the IP address of the source PE and
default MDT group before IETF standardization.
The IPv4 address identifies the PE that originated this
A BGP extended community attribute in an MVPN route, and the RD identifies a VRF in that PE. The group
environment, however, has certain limitations: it cannot address MUST be an IPv4 multicast group address and
be used in inter-AS scenarios (because the attribute is is used to build the P-tunnels. All PEs attached to a
non-transitive), and it uses RD Type 2 (which is not a given MVPN MUST specify the same group address,
supported standard). even if the group is an SSM group. MDT-SAFI routes do
not carry RTs, and the group address is used to
associate a received MDT-SAFI route with a VRF.

SAFI:
001: NLRI used for unicast forwarding Next-Gen MVPN
002: NLRI used for multicast forwarding
128: MPLS-labeled VPN address
129: Multicast for BGP/MPLS IP VPNs MULTICAST MPLS
066: BGP MDT SAFI
005: MCAST-VPN BGP
For Your
Reference
http://www.iana.org/assignments/safi-namespace/safi-namespace.xml

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 13
NLRI
1)  INTRA-AS I-PMSI A-D ROUTE [Originated by ALL MVPN PEs]
1)  MCAST-VPN NLRI
2)  INTER-AS I-PMSI A-D ROUTE [Originated by MVPN ASBRs]
3)  S-PMSI A-D ROUTE [Originated by SENDER PEs]
ROUTE TYPE
4)  LEAF A-D ROUTE [Originated by TAIL PEs]
[1 BYTE] 5)  SOURCE ACTIVE A-D ROUTE [Originated by ACTIVE-SOURCE/RP PEs]
LENGTH 6)  SHARED TREE JOIN ROUTE [Originated by RECEIVER PEs]
7)  SOURCE TREE JOIN ROUTE [Originated by RECEIVER PEs]
[1 BYTE]

ROUTE TYPE SPECIFIC


[VAR LENGTH]

ATTRIBUTES
1)  PMSI TUNNEL ATTRIBUTE [The PTA is used in conjunction with: Intra-AS I-PMSI A-D, Inter-AS I-PMSI A-D, S-PMSI A-D, Leaf A-D]
2)  PE DISTINGUISHER LABEL ATTRIBUTE [PDL is distributed with Intra-AS I-PMSI A-D and/or S-PMSI A-D routes]
3)  SOURCE AS EXTENDED COMMUNITY ATTRIBUTE [AS SPECIFIC extended community. Specifies the originator AS of a route]
4)  VRF ROUTE IMPORT EXTENDED COMMUNITY ATTRIBUTE [IP ADDRESS SPECIFIC extended community. Specifies the originator
PE of a route]

For Your
Reference

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 14
[Local Label] [Outgoing Label] [Prefix or Tunnel Id] [Bytes Label switched] [Outgoing interface] [Next Hop]
2113  1862 22.22.22.22 0 [39] 187469 Te3/0/1 13.1.1.3

[Local Label] [Outgoing Label] [Prefix or Tunnel Id] [Bytes Label switched] [Outgoing interface] [Next Hop]
5851 1912 22.22.22.22 0 [39] 187469 Te3/0/0 13.1.1.3
3631 22.22.22.22 0 [39] 187491 Te3/0/1 14.1.1.3
7192 22.22.22.22 0 [39] 187480 Te3/0/2 15.1.1.3
7089 22.22.22.22 0 [39] 187445 Te3/0/3 16.1.1.3

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 15
BUILD MULTIPOINT LSPs ASSIGN FLOWS TO LSPs PEs DISCOVERY

Multipoint LDP (mLDP) STATIC PIM


 Extensions to LDP
 Support both P2MP and MP2MP LSP
 RFC 6388
PIM BGP
 RFC 6037
P2MP RSVP-TE
 Extensions to RSVP-TE
 Support P2MP LSP
 RFC 487 BGP
 RFC 6513
 Also adds Auto-Discovery capability

mLDP IN-BAND SIGNALING


 draft-ietf-mpls-mldp-in-band-signaling-08
  In VRF & Global context

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 16
16
© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 17
Default MDT

PE1

PE2 PE7

IP/MPLS CLOUD

PE3 PE6

PE5
PE4

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 18
VRF1 configured with
Default MDT Default group address

PE1

PE2 PE7

DEFAULT
MDT

PE3 PE6

PE5
PE4

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 19
(Sx1, G1)
VRF1 configured with
Default MDT Default group address

PE1

PE2 PE7

DEFAULT
MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

Receiver2
(Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 20
(Sx1, G1), 8 Mbps
VRF1 configured with
Default MDT 1
Default group address

PE1

PE2 PE7

DEFAULT
MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

Receiver2
(Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 21
(Sx1, G1), 8 Mbps
VRF1 configured with
Data MDT 1
Default group address

PE1

PE7 THRESHOLD of 5 Mbps


PE2
is configured at PE1.

DEFAULT NOTE: Each stream in


MDT

DATA
particular VRF with
MDT bandwidth in use >=
THRESHOLD, should be
switched to DATA MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

Receiver2
(Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 22
(Sx1, G1), 8 Mbps
VRF1 configured with
Data MDT 1
Default group address

PE1

PE7 THRESHOLD of 5 Mbps


PE2
is configured at PE1.

DEFAULT NOTE: Each stream in


MDT

DATA
particular VRF with
MDT bandwidth in use >=
THRESHOLD, should be
switched to DATA MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

Receiver2
(Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 23
(Sx1, G1), 8 Mbps
VRF1 configured with
Aggregated Data MDT 1
Default group address
(Sx2, G2)
PE1

PE7 THRESHOLD of 5 Mbps


PE2
is configured at PE1.

DEFAULT NOTE: Each stream in


MDT

DATA
particular VRF with
MDT bandwidth in use >=
THRESHOLD, should be
switched to DATA MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

Receiver3 Receiver2
(Sx2, G2) (Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 24
(Sx1, G1), 8 Mbps
VRF1 configured with
Aggregated Data MDT 2 1
Default group address
(Sx2, G2), 8 Mbps
PE1

PE7 THRESHOLD of 5 Mbps


PE2
is configured at PE1.

DEFAULT NOTE: Each stream in


MDT

DATA
particular VRF with
MDT bandwidth in use >=
THRESHOLD, should be
switched to DATA MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

Receiver3 Receiver2
(Sx2, G2) (Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 25
(Sx1, G1)
VRF1 configured
Partitioned MDT

PE1

PE2 PE7

PARTITIONED
MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 26
(Sx1, G1), 8 Mbps
VRF1 configured
Partitioned MDT 1

PE1

PE2 PE7

PARTITIONED
MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 27
(Sx1, G1), 8 Mbps
VRF1 configured
Partitioned MDT 1

PE1

PE2 PE7

PARTITIONED
MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

Receiver2
(Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 28
(Sx1, G1), 8 Mbps
VRF1 configured
Partitioned MDT 2 1

(Sx2, G2), 8 Mbps


PE1

PE2 PE7

PARTITIONED
MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4

Receiver3 Receiver2
(Sx2, G2) (Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 29
(Sx1, G1), 8 Mbps
VRF1 configured
Partitioned MDT 2 1

(Sx2, G2), 8 Mbps


PE1

(Sx3, G3)
PE2 PE7
PARTITIONED Receiver4
MDT
(Sx3, G3)
PARTITIONED
MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4 Receiver5
(Sx3, G3)

Receiver3 Receiver2
(Sx2, G2) (Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 30
(Sx1, G1), 8 Mbps
VRF1 configured
Partitioned MDT 2 1

(Sx2, G2), 8 Mbps


3 PE1

(Sx3, G3), 8 Mbps


PE2 PE7
PARTITIONED Receiver4
MDT
(Sx3, G3)
PARTITIONED
MDT

PE3 PE6

Receiver1
(Sx1, G1) PE5
PE4 Receiver5
(Sx3, G3)

Receiver3 Receiver2
(Sx2, G2) (Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 31
(Sx1, G1), 8 Mbps
VRF1 configured
Partition MDT 2 1

(Sx2, G2), 8 Mbps


3 PE1

(Sx3, G3), 8 Mbps


PE2 PE7
PARTITIONED Receiver4
MDT
(Sx3, G3)
PARTITIONED
MDT

PARTITIONED to DATA
MDT switchover is
applicable here also,
which is very similar to
PE3 PE6 DEFAULT to DATA MDT
switchover.
Receiver1
(Sx1, G1) PE5
PE4 Receiver5
(Sx3, G3)

Receiver3 Receiver2
(Sx2, G2) (Sx1, G1)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 32
# TREE TYPE

-  Multi-Directional Inclusive Provider Multicast Service Instance (MI-PMSI),


1 INCLUSIVE P-TREE like Default MDT.
-  Using INTRA-AS I-PMSI AD ROUTE.
-  One per-VRF.
-  Created on provisioning VRF and related attributes.

-  Selective Provider Multicast Service Instance (S-PMSI), like Data MDT.


2 SELECTIVE P-TREE
-  Using S-PMSI AD ROUTE.
-  One per-VRF, per-(S,G).
-  Dynamically created for (S,G) once configured threshold for per stream
in particular VRF is reached.
-  Selective Provider Multicast Service Instance (S-PMSI), like Aggregated
3 AGGREGATED SELECTIVE P-TREE Data MDT.
-  Using S-PMSI AD ROUTE.
-  One per-VRF, multiple-(S,G).
-  Multiple (S,G) streams are connected to same Selective-P-Tree when
max allowed # of Selective-P-Tree for particular VRF is reached and still
unattached (S,G) streams exist.
-  S-PMSI (like Partitioned MDT).
4 PARTITIONED P-TREE
-  Using S-PMSI AD ROUTE for (*,*).
-  One per-VRF, per-INGRESS-PE-NODE.
-  Dynamically created when receiver for particular (S,G) comes up.

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 33
© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 34
R1

LFIB
IN OUT
PATH PATH
RESV RESV Label Label I/F

L=48 L=48 48 19 gig1


gig0 23 gig2

R4
gig1 gig2

PATH
PATH

RESV RESV
L=19 L=23

R2 R3

  A P2MP LSP can be signaled using one or more PATH messages.


  A branch LSR can send one or more RESV message upstream.

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 35
R1 G S Data

S Data
LFIB
IN OUT

Label Label I/F

G
48 19 gig1

48
gig0 23 gig2

R4
gig1 gig2

S Data
S Data

G
G

23
19

R2 R3

G S Data G S Data

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 36
show mpls traffic-eng tunnels source-id 11.11.11.11 IOS
<..truncated..>
P2MP SUB-LSPS: For Your
LSP: Source: 11.11.11.11, TunID: 1, LSPID: 139 Reference
P2MP ID: 1, Subgroup Originator: 11.11.11.11
Name: PE2_t1
Bandwidth: 0, Global Pool
Sub-LSP to 21.21.21.21, P2MP Subgroup ID: 5, Role: midpoint
Path-Set ID: 0x86000001
InLabel : GigabitEthernet0/0, 48
Prev Hop : 7.0.0.2
OutLabel : GigabitEthernet0/1, 19
Next Hop : 9.0.0.2
FRR OutLabel : Tunnel105, 38
Explicit Route: 9.0.0.2 21.21.21.21
Record Route (Path): NONE
Record Route (Resv): 21.21.21.21(38)
Sub-LSP to 31.31.31.31, P2MP Subgroup ID: 22, Role: midpoint
Path-Set ID: 0xA4000007
InLabel : GigabitEthernet0/0, 48
Prev Hop : 7.0.0.2
OutLabel : GigabitEthernet0/2, 23
Next Hop : 81.0.0.1
FRR OutLabel : Tunnel102, 34
Explicit Route: 81.0.0.1 31.31.31.31
Record Route (Path): NONE
Record Route (Resv): 31.31.31.31(34)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 37
R1"

TLV Label Map Msg


Type = P2MP

48
FEC: Root = R1
Opaque = 200

LABEL: 48
gig0
TLV Label Map Msg R4 TLV Label Map Msg
Type = P2MP
gig1 gig2 Type = P2MP
FEC: Root = R1
FEC: Root = R1
Opaque = 200
Opaque = 200
LABEL: 19
LABEL: 23

R2" R2"
Join (S, G)
Join (S, G)

•  FECs created are identical for same multicast stream


•  Labels allocated from platform label space (same pool as unicast MPLS)
© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 38
R1 G S Data

S Data
LFIB
IN OUT

G
Label Label I/F

48
48 19 s1
gig0 23 s2
R4
gig1 gig2

S Data
S Data

G
G

23
19

R2 R3

G S Data G S Data

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 39
R5" R1"
42 62
TLV Label Map Msg

TLV Label Map Msg Type =MP2MP Down

64
Type=MP2MP UP FEC: Root = R1
FEC: Root = R1 Opaque = 200
Opaque = 200
Upstream Traffic

Downstream Traffic
LABEL: 64
LABEL: 42

44
TLV Label Map Msg
Type =MP2MP Down gig0
FEC: Root = R1 R4"
Opaque = 200
gig1 gig2
LABEL: 65

TLV Label Map Msg


Type =MP2MP UP
FEC: Root = R1
Opaque = 200
R2" R3"
LABEL: 45

•  Root manually configured on all Edge LSR or learned via BGP-AD


•  If a MP2MP downstream FEC type is received
o  An MP2MP Upstream reply is sent with a corresponding label
o  One Upstream state entry exists per downstream interface

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 40
R5 R1
42 62

mLDP DB (UP States)

64
IN OUT

Downstream Traffic
mLDP DB (DOWN State) Label I/F Label I/F

44
IN OUT
Upstream Traffic

48 g2 44 g0
Label I/F Label I/F

64 g0 65 g1 45 g1 44 g0
gig0
68 g2
R4
gig1 gig2

R2 R3
•  Upstream can merge relevant downstream states
o  If (UPSTATE IN I/F) = (DOWNSTATE Out I/F) then do not merge entries. This
prevents traffic being sent back where it came from.

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 41
R5
DOWN"
62 G S1 Data
R1
LFIB
IN OUT
Label Label I/F

64 65 g1

Downstream Traffic
68 g2

44 G S1 Data
48 44 g0

UP"
65 g1
Upstream Traffic

45 44 g0
68 g2
gig0
R4
gig1 gig2

R2 R3

•  Traffic can be forwarded up and down the tree G S Data

•  Up towards the root, Down towards a leaf

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 42
IOS-XR
RP/0/0/CPU0:P1#sho mpls ldp mldp data 0x3
<..truncated..>
LSM-ID: 0x00000003 (RNR LSM ID: 00000004) Type: MP2MP .. For Your
Reference
FEC Root : 192.192.5.1
Upstream neighbor(s) :
80.80.80.80:0 [Active] Uptime: 00:14:55
Next Hop : 2.58.1.2
Interface : GigabitEthernet0/6/0/3
Local Label (D) : 16029 Remote Label (U): 16037
Downstream client(s):
PIM MDT Uptime: 01:01:12
Egress intf : Lmdtp1/2
Local Label : 16001 (internal)
LDP 1.1.1.1:0 Uptime: 00:14:34
Next Hop : 2.59.1.2
Interface : GigabitEthernet0/6/0/4
Remote label (D) : 16036 Local label (U) : 16036

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 43
P2MP RSVP-TE mLDP

The egress (leaf) receives a PIM Join. The egress (leaf) receives a PIM Join.

The Leafs sends a BGP A-D leaf to notify the ingress PE The leaf sends a mLDP label mapping to the ingress PE.

The ingress sends RSVP-TE PATH messages to the leaves

The leaves respond with RSVP-TE RESV messages

The core router received 6 updates. The core router received 3 update messages

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 44
P2MP RSVP-TE mLDP

Control Plane: 3 P2P sub-LSPs from the ingress to the leaves Control Plane: 1 P2MP LSP

Data Plane: The 3 sub-LSP are merged into one P2MP for replication Forwarding Plane: 1 P2MP LSP

P: one state for each individual leaf, total 3 in example; 12 path/resv msg P: 1 P2MP FEC (independent of the number of leaves), 4 control msgs

PE: 1 P2MP FEC (independent of the number of leaves), 1 control


Ingress PE: 3 LSPs, 6 path/resv msg msg
When a leaf wants to leave, control-msg is sent all the way to the ingress When a leaf wants to leave, the message is only sent to the next
PE to remove the LSP branch point, not all the way to ingress PE

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 45
© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 46
UPSTREAM MULTICAST HOP

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 47
  If the route to the C-ROOT is across the VPN backbone, then the PE
S2 needs to find the UMH for the (S/*,G) flow.

PE3   UMH selection is applicable to EGRESS-PEs.

  UMH is either the PE or ASBR.


AS 200
  Routes eligible for UMH selection should have <VRF Route Import
Extended Community & Source AS Extended Community> attributes.
ASBR2
  UMH ROUTE CANDIDATE SET: <ROUTE, UPSTREAM PE, UPSTREAM RD>
S1

ASBR1
PE2
AS 100
CASE-2:
CASE-1: UPSTREAM-PE !=
UPSTREAM-PE = UPSTREAM-MULTICAST-HOP
UPSTREAM-MULTICAST-HOP
PE1

VRF-RED: VRF-BLUE:
(S1,G1) JOIN (S2,G2) JOIN

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 48
  INSTALLED ROUTES: Routes installed in unicast RIB.
S1   INSTALLED PATHS: Multiple Paths associated with each installed route.
PE1 These are the ones selected by BGP, by running its best-path selection
algorithm and the maximum-paths configuration under BGP.
  BGP PATHS: It is possible for BGP to have additional paths, which are not
installed in RIB. This full set of paths in the BGP database, is called as "BGP-
Paths".
  SELECTED PATH: When PIM receives the Installed-Paths for a Source/RP, it
PE3 selects one of the paths for sending (*,G) and (S,G) Joins Upstream. This is
called as "Selected-Path".
PE2 PE4
  UMH Selection options available for the Customer.
•  Hash of Installed-Paths: No additional resources are required in
BGP or RIB, to support this option.
P •  Highest PE Address: Highest PE Address among the BGP-paths is
tracked.
•  Hash of BGP-Paths: Additional resources are required in BGP or
RIB, to support this option.

PE1

VRF-RED: VRF-RED:
(S1,G1) JOIN (S1,G2) JOIN

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 49
DUPLICATE TRAFFIC AVOIDANCE

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 50
How to avoid duplication of packets?
a)  RESOLUTION ON EGRESS PE: Discarding data packets received from the "wrong" PE
b)  SINGLE FORWARDER SELECTION: All EGRESS PEs select the same UMH
c)  RESOLUTION ON INGRESS PE: Native PIM methods

RP SRC

PE1 PE2

2X
PE5
PE3: Joins the MI-PMSI
source tree MI-PMSI (C*,CG)

2X
2X PE4
PE3
(C*,CG)
(C*,CG)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 51
SWITCHING FROM SHARED TREE TO SOURCE C-TREE

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 52
RP SRC

PE1 PE2

2X
Source Tree Join C- PE5
multicast route MI-PMSI
generated by PE3 MI-PMSI (C*,CG)

2X
2X PE4
PE3
(C*,CG)
(C*,CG)

If it is desirable to suppress receiving duplicate traffic, then it is necessary


to choose a single forwarder PE for (CS,CG).

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 53
When, as a result of receiving a Source Tree Join C-multicast route for (CS,CG) from some other PE the local PE adds
either the S-PMSI or the I-PMSI to the outgoing interface list of the (CS,CG) state, the local PE MUST originate a Source
Active A-D route. The Source Active A-D route is propagated to all the PEs of the MVPN.

RP
SRC

PE1 PE2

Source Tree Join C- PE5


multicast route MI-PMSI
generated by PE3 SOURCE ACTIVE
A-D ROUTE
(C*,CG)

PE3 PE4

(C*,CG)
(C*,CG)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 54
If matching (C*,CG) is found at PE which received
“Source-Active A-D Route”, PE sets up its forwarding
path to receive (CS,CG) traffic from the tunnel the
originator of the selected Source Active A-D route uses
RP SRC for sending (CS,CG).

PE1 PE2

Source Tree Join C- PE5


multicast route MI-PMSI
generated by PE3 SOURCE ACTIVE
A-D ROUTE
(C*,CG)

PE3 PE4

(C*,CG)
(C*,CG)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 55
But this 2X traffic is only for transient
duration, see how, next………

RP SRC

PE1 PE2

2XPE5
Source Tree Join C-
multicast route MI-PMSI
generated by PE3 SOURCE ACTIVE
A-D ROUTE
(C*,CG)
2X 2X
PE3 PE4

(C*,CG)
(C*,CG)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 56
If { ((OIF for the (C*,CG) entry in the MVPN-TIB on the PE contains I-PMSI) OR
(OIF for the (C*,CG) entry in the MVPN-TIB on the PE contains S-PMSI)) AND
(The PE does not originate the Source Tree Join C-multicast route for CS,CG)}
{
The PE MUST transition the (CS,CG,rpt) downstream state machine on
I-PMSI/S-PMSI to the Prune state (Conceptually, the C-PIM state machine
on the PE will act "as if" it had received Prune (CS,CG,rpt) on I-PMSI/S-PMSI,
without actually having received one).
}

RP SRC

PE1 PE2

Source Tree Join C- 2XPE5


multicast route MI-PMSI
generated by PE3 SOURCE ACTIVE
A-D ROUTE
(C*,CG)
2X 2X
PE3 PE4

(C*,CG)
(C*,CG)
© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 57
RP SRC

PE1 PE2

PE5

(C*,CG)

PE3 PE4

(C*,CG)
(C*,CG)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 58
PIM-SM WITHOUT INTER-SITE SHARED C-TREES

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 59
A PE can obtain information about active multicast sources within a given MVPN in a variety of ways:
1)  One way is for the PE to act as a fully functional customer RP (C-RP) for that MVPN.
2)  Another way is to use PIM Anycast RP procedures to convey information about active multicast sources from one or more of the MVPN C-RPs to the PE.
3)  Yet another way is to use MSDP [MSDP] to convey information about active multicast sources from the MVPN C-RPs to the PE.

FHR
REGISTERING
When a PE using any of the above methods first learns of a new
(multicast) source within that MVPN, the PE constructs a Source
Active A-D route and sends this route to all other PEs that have
one or more sites of that MVPN connected to them. The Source
PIM JOIN Active A-D route is propagated to all the PEs of the MVPN.
(CS,CG) RP
PE1 PE2

Source Tree Join C-


multicast route
PE5
(C*,CG)
SOURCE ACTIVE A-D
ROUTE (CS,CG)

PE3 PE4

(C*,CG)
(CS,CG)

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 60
© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 61
I: IOS/XE SUPPORTED (15.3(1)S, 3.8S)
For Your X : IOS-XR SUPPORTED (4.3.0)
Reference 1)  DEFAULT MDT using PIM without BGP-AD [ I, X ]
PIM 2)  DEFAULT MDT using PIM with BGP-AD [ I, X ]
3)  DEFAULT MDT using PIM with BGP-AD & c-mcast routing [ I, X ]

1)  Global In-Band signaling with mLDP [ I, X ]


2)  VRF in-band-signaling with mLDP [ I, X ]
3)  DEFAULT MDT using P2MP mLDP with BGP-AD [ X ]
P2MP mLDP 4)  DEFAULT MDT using P2MP mLDP with BGP-AD & c-mcast routing [ X ]
5)  PARTITIONED MDT using P2MP mLDP with BGP-AD [ X ]
6)  PARTITIONED MDT using P2MP mLDP with BGP-AD & c-mcast routing [X]

PROFILES
1)  DEFAULT MDT using MP2MP mLDP without BGP-AD [ I, X ]
2)  DEFAULT MDT using MP2MP mLDP with BGP-AD [ I, X ]
3)  DEFAULT MDT using MP2MP mLDP with BGP-AD & c-mcast routing [ I, X ]
MP2MP mLDP 4)  PARTITIONED MDT using MP2MP mLDP without BGP-AD [ X ]
5)  PARTITIONED MDT using MP2MP mLDP with BGP-AD [ X ]
6)  PARTITIONED MDT using MP2MP mLDP with BGP-AD & c-mcast routing [X]

1)  Global P2MP-TE [ I, X ]


2)  P2MP-TE with BGP-AD in VRF context [ X ]
P2MP RSVP-TE 3)  DEFAULT MDT using P2MP-TE with BGP-AD [ X ]
4)  DEFAULT MDT using P2MP-TE with BGP-AD & c-mcast routing [ X ]

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 62
© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 63
IOS/XE

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 64
BGP CLI:

1] [MANDATORY] To enable BGP MVPN AD & C-route signaling, configure the below mentioned
CLI under BGP router mode.
[no] address-family [ipv4 | ipv6] mvpn

MULTICAST CLI:

1] [MANDATORY] This CLI needs to be configured for an address-family in a VRF to enable


BGP Auto-Discovery advertisements from multicast and to process multicast BGP Customer
routes received at a router. If the command is not configured, then the router will not
originate any BGP MVPN SAFI Auto-discovery routes for the VRF address-family and will not
process received BGP Customer routes as well. The keyword “pim/mldp” determines the core
P-Tree that is advertised by multicast for BGP INTRA-AS I-PMSI (Type 1) and S-PMSI (Type
3) A-D routes. The keyword “pim-tlv-announce” is OPTIONAL and it enables origination of
periodic UDP TLV messages for data MDTs in addition to S-PMSI A-D routes advertised via
BGP. Without “pim-tlv-announce” only Type-3, S-PMSI A-D routes are advertised
[no] mdt auto-discovery {pim/mld} [pim-tlv-announce]

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 65
MULTICAST CLI:

2] [MANDATORY] CLI is configured at the address-family sublevel. This CLI is used to


decide which overlay protocol should be used to carry customer join/prunes. Default mode
is PIM signaling. The spt-only option is a hidden option and only applies to the use-bgp
keyword. This hidden knob needs to be enabled for testing the SPT-only mode for ASM
groups.
[no] mdt overlay use-bgp [spt-only]

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 66
BGP SHOW KNOB:
show bgp [ipv4 | ipv6] mvpn [vrf <vrf>] [route-type <route-type#>] [all | <prefix>]

</EX>
show bgp ipv4 mvpn vrf <vrf_name> route-type <1> <originator ID>
show bgp ipv4 mvpn vrf vpn_0 route-type 1 1.1.1.1

show bgp ipv4 mvpn vrf <vrf_name> route-type <3> <mcast-src-add> <mcast-grp-add>
<originator-id>
show bgp ipv4 mvpn vrf vpn_0 route-type 3 12.1.1.2 225.1.1.1 1.1.1.1

show bgp ipv4 mvpn vrf <vrf_name> route-type <7> <Remote VPN Route Distinguisher> <AS-
number> <mcast-src-add> <mcast-grp-add> <originator-id>
show bgp ipv4 mvpn vrf vpn_0 route-type 7 1000:1 1000 12.1.1.1 225.1.2.3
<EX/>

MULTICAST SHOW KNOB:


show <ip | ipv6> pim [vrf <vrf_name>] mdt bgp [c-mroutes | source-active] [group] [source]
Show mpls mldp database

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 67
SAMPLE CONFIG: [P-TREE: PIM SSM/ASM/BIDIR]

vrf definition vpn_0


rd 81:1111 router bgp 55
route-target export 80:1111 ...
route-target import 80:1111 neighbor 205.2.0.2 remote-as 55
! neighbor 205.2.0.2 update-source Loopback0
address-family ipv4 ...
mdt auto-discovery pim pim-tlv-announce !
mdt default 232.10.0.0 address-family ipv4 mvpn
mdt data 232.100.0.0 0.0.3.255 neighbor 205.2.0.2 activate
mdt overlay use-bgp spt-only neighbor 205.2.0.2 send-community extended
route-target export 80:1111 exit-address-family
route-target import 80:1111 ...
exit-address-family address-family ipv6 mvpn
! neighbor 205.2.0.2 activate
address-family ipv6 neighbor 205.2.0.2 send-community extended
mdt auto-discovery pim pim-tlv-announce exit-address-family
mdt default 232.10.0.0 !
mdt data 232.200.0.0 0.0.3.255 ...
mdt overlay use-bgp spt-only ...
route-target export 80:1111
route-target import 80:1111
exit-address-family

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 68
SAMPLE CONFIG: [P-TREE: mLDP]

vrf definition vpn_0


rd 81:1111 router bgp 55
vpn id 80:1111 ...
route-target export 80:1111 neighbor 205.2.0.2 remote-as 55
route-target import 80:1111 neighbor 205.2.0.2 update-source Loopback0
! ...
address-family ipv4 !
mdt auto-discovery mldp address-family ipv4 mvpn
mdt default mpls mldp 205.3.0.3 neighbor 205.2.0.2 activate
mdt data mpls mldp 5000 neighbor 205.2.0.2 send-community extended
mdt overlay use-bgp exit-address-family
route-target export 80:1111 ...
route-target import 80:1111 address-family ipv6 mvpn
exit-address-family neighbor 205.2.0.2 activate
! neighbor 205.2.0.2 send-community extended
address-family ipv6 exit-address-family
mdt auto-discovery mldp !
mdt default mpls mldp 205.3.0.3 ...
mdt data mpls mldp 5000 ...
mdt overlay use-bgp
route-target export 80:1111
route-target import 80:1111
exit-address-family

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 69
IOS-XR

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 70
SAMPLE CONFIG: [ROSEN-mLDP with BGP-AD, HEAEND] router bgp 100
mvpn
vrf p9_v46 bgp router-id 100.0.0.1
vpn id 109:1 address-family ipv4 unicast
address-family ipv4 unicast address-family vpnv4 unicast
import route-target address-family ipv6 unicast
109:1 address-family vpnv6 unicast
export route-target address-family ipv4 mvpn
109:1 address-family ipv6 mvpn
address-family ipv6 unicast neighbor 100.0.0.3
import route-target remote-as 100
update-source Loopback0
109:1
address-family ipv4 unicast
export route-target
address-family vpnv4 unicast
109:1
address-family vpnv6 unicast
address-family ipv4 mvpn
interface Loopback0 address-family ipv6 mvpn
ipv4 address 100.0.0.1 255.255.255.255 vrf p9_v46
ipv6 address 2008:100::1/128 rd 109:1
address-family ipv4 unicast
route-policy rosen address-family ipv6 unicast
set core-tree mldp-rosen address-family ipv4 mvpn
end-policy address-family ipv6 mvp
neighbor 15.0.0.2
router ospf 100 remote-as 200
router-id 100.0.0.1 address-family ipv4 unicast
area 0 neighbor 2008:15::2
interface Loopback0 remote-as 200
interface TenGigE0/0/0/0 address-family ipv6 unicast

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 71
mpls ldp
router-id 100.0.0.1
mldp
make-before-break delay 30 0
interface TenGigE0/0/0/0

router pim
vrf p9_v46
address-family ipv4
rpf topology route-policy rosen
address-family ipv6
rpf topology route-policy rosen

multicast-routing
address-family ipv4
mdt source Loopback0
rate-per-route
interface all enable
accounting per-prefix
address-family ipv6
rate-per-route
interface all enable
accounting per-prefix
vrf p9_v46
address-family ipv4
bgp auto-discovery mldp
mdt default mldp ipv4 100.0.0.2
address-family ipv6
bgp auto-discovery mldp
mdt default mldp ipv4 100.0.0.2

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 72
SAMPLE CONFIG: [VRF in-band-signaling with mLDP, HEAEND]
router bgp 100
vrf p6_v46 mvpn
address-family ipv4 unicast bgp router-id 100.0.0.1
import route-target address-family ipv4 unicast
106:1 address-family vpnv4 unicast
export route-target address-family ipv6 unicast
106:1 address-family vpnv6 unicast
address-family ipv6 unicast neighbor 100.0.0.3
import route-target remote-as 100
106:1 update-source Loopback0
export route-target address-family ipv4 unicast
106:1 next-hop-self
address-family vpnv4 unicast
interface Loopback0 address-family vpnv6 unicast
ipv4 address 100.0.0.1 255.255.255.255 vrf p6_v46
ipv6 address 2008:100::1/128 rd 106:1
address-family ipv4 unicast
route-policy inband address-family ipv6 unicast
set core-tree mldp-inband neighbor 15.0.0.2
end-policy remote-as 200
address-family ipv4 unicast
router ospf 100 as-override
router-id 100.0.0.1 neighbor 2008:15::2
area 0 remote-as 200
interface Loopback0 address-family ipv6 unicast
interface TenGigE0/0/0/0

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 73
mpls ldp
router-id 100.0.0.1
mldp
make-before-break delay 30 0
interface TenGigE0/0/0/0

multicast-routing
address-family ipv4
mdt source Loopback0
interface all enable
address-family ipv6
interface all enable
vrf p6_v46
address-family ipv4
mdt mldp in-band-signaling ipv4
address-family ipv6
mdt mldp in-band-signaling ipv4

router pim
vrf p6_v46
address-family ipv4
rpf topology route-policy inband
address-family ipv6
rpf topology route-policy inband

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 74
SAMPLE CONFIG: [Partition-P2MP-mLDP/MS-PMSI-mLDP-P2MP router bgp 100
with BGP-AD, HEAEND] bgp router-id 100.0.0.1
address-family ipv4 unicast
vrf p5_v46 address-family vpnv4 unicast
address-family ipv4 unicast address-family ipv6 unicast
import route-target address-family vpnv6 unicast
105:1 address-family ipv4 mvpn
export route-target address-family ipv6 mvpn
105:1 neighbor 100.0.0.3
address-family ipv6 unicast remote-as 100
import route-target update-source Loopback0
105:1 address-family ipv4 unicast
export route-target address-family vpnv4 unicast
105:1 address-family vpnv6 unicast
address-family ipv4 mvpn
interface Loopback0 address-family ipv6 mvpn
ipv4 address 100.0.0.1 255.255.255.255 vrf p5_v46
ipv6 address 2008:100::1/128 rd 105:1
address-family ipv4 unicast
route-policy partition-p2mp address-family ipv6 unicast
set core-tree mldp-partitioned-p2mp address-family ipv4 mvpn
end-policy address-family ipv6 mvpn
neighbor 15.0.0.2
router ospf 100 remote-as 200
router-id 100.0.0.1 address-family ipv4 unicast
area 0 neighbor 2008:15::2
interface Loopback0 remote-as 200
interface TenGigE0/0/0/0 address-family ipv6 unicast

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 75
mpls ldp
router-id 100.0.0.1
mldp
make-before-break delay 30 0
interface TenGigE0/0/0/0

multicast-routing
address-family ipv4
mdt source Loopback0
interface all enable
address-family ipv6
interface all enable
vrf p5_v46
address-family ipv4
bgp auto-discovery mldp
mdt partitioned mldp ipv4 p2mp
interface all enable
address-family ipv6
bgp auto-discovery mldp
mdt partitioned mldp ipv4 p2mp
interface all enable

router pim
vrf p4_v46
address-family ipv4
rpf topology route-policy partition-p2mp
address-family ipv6
rpf topology route-policy partition-p2mp

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 76
1)  Enable mLDP on all Core Routers
2)  Configure MBB or MoFRR on appropriate Core Routers
3)  Configure BGP to enable BGP-AD Address-Family
4)  Configure route-policy
5)  Configure vrf instance for customers
6)  Put CFI (Customer Facing Interface) into appropriate vrf
7)  Enable Multicast on PE and CE routers
8)  Configure MDT Source
9)  Configure Default MDT and Data MDT
10) Configure MDT for Inband Signalling Profiles
11) Configure PIM topology on PE routers
12) Other optional configurations

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 77
Enable mLDP on all Core Routers:

1)  Enable mLDP on all Core Routers Syntax:


2)  Configure MBB or MoFRR on appropriate Core Routers + mldp [disable]
3)  Configure BGP to enable BGP-AD Address-Family
4)  Configure route-policy mpls ldp
5)  Configure vrf instance for customers router-id 1.1.1.1
6)  Put CFI (Customer Facing Interface) into appropriate vrf mldp
7)  Enable Multicast on PE and CE routers logging notifications
8)  Configure MDT Source !
9)  Configure Default MDT and Data MDT interface GigabitEthernet0/2/0/0
10) Configure MDT for Inband Signalling Profiles !
11)  Configure PIM topology on PE routers interface GigabitEthernet0/2/0/1
12) Other optional configurations mldp disable
!
!

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 78
Configure MBB or MoFRR on appropriate Core Routers:

Syntax:
+ make-before-break delay <Forwarding delay in
seconds> <Delete delay in seconds>
1)  Enable mLDP on all Core Routers
+ mofrr
2)  Configure MBB or MoFRR on appropriate Core Routers
3)  Configure BGP to enable BGP-AD Address-Family
4)  Configure route-policy mpls ldp
5)  Configure vrf instance for customers router-id 1.1.1.1
6)  Put CFI (Customer Facing Interface) into appropriate vrf mldp
7)  Enable Multicast on PE and CE routers make-before-break delay 10 20
8)  Configure MDT Source mofrr
9)  Configure Default MDT and Data MDT logging notifications
10) Configure MDT for Inband Signalling Profiles !
11)  Configure PIM topology on PE routers interface GigabitEthernet0/2/0/0
12) Other optional configurations !
interface GigabitEthernet0/2/0/1
mldp disable
!
!

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 79
Configure BGP to enable BGP-AD Address-Family:
Syntax:
+ address-family ipv4|ipv6 mvpn
router bgp 100
address-family ipv4 mvpn
!
1)  Enable mLDP on all Core Routers address-family ipv6 mvpn
2)  Configure MBB or MoFRR on appropriate Core Routers !
3)  Configure BGP to enable BGP-AD Address-Family neighbor 100.3.3.3
4)  Configure route-policy remote-as 100
5)  Configure vrf instance for customers address-family ipv4 mvpn
6)  Put CFI (Customer Facing Interface) into appropriate vrf !
7)  Enable Multicast on PE and CE routers
address-family ipv6 mvpn
8)  Configure MDT Source
9)  Configure Default MDT and Data MDT
!
10) Configure MDT for Inband Signalling Profiles !
11)  Configure PIM topology on PE routers vrf p1_v46
12) Other optional configurations rd 1:1
address-family ipv4 mvpn
!
address-family ipv6 mvpn
!
!
!

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 80
Configure route-policy:

Syntax:
+ set core-tree mldp-default | mldp-inband |
mldp-partitioned-mp2mp | mldp-partitioned-p2mp |
mldp-default | p2mp-te-default | pim-default
1)  Enable mLDP on all Core Routers
+ set c-multicast-routing bgp | pim
2)  Configure MBB or MoFRR on appropriate Core Routers
3)  Configure BGP to enable BGP-AD Address-Family
4)  Configure route-policy route-policy provider-tree
5)  Configure vrf instance for customers set core-tree mldp-inband
6)  Put CFI (Customer Facing Interface) into appropriate vrf end-policy
7)  Enable Multicast on PE and CE routers
8)  Configure MDT Source route-policy provider-tree
9)  Configure Default MDT and Data MDT if next-hop in (12.1.1.1) then
10) Configure MDT for Inband Signalling Profiles set core-tree mldp-default
11)  Configure PIM topology on PE routers set c-multicast-routing bgp
12) Other optional configurations elseif next-hop in (14.1.1.1) then
set core-tree mldp-partitioned-p2mp
set c-multicast-routing pim
endif
end-policy

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 81
Configure vrf instance for customers:
Syntax:
+ vrf <vrf name>
+ vpn id <OUI VPN-index>
vrf p1_v46
vpn id 100:1
address-family ipv4 unicast
import route-target
1)  Enable mLDP on all Core Routers 100:1
2)  Configure MBB or MoFRR on appropriate Core Routers !
3)  Configure BGP to enable BGP-AD Address-Family
export route-target
4)  Configure route-policy
100:1
5)  Configure vrf instance for customers
!
6)  Put CFI (Customer Facing Interface) into appropriate vrf
7)  Enable Multicast on PE and CE routers !
8)  Configure MDT Source address-family ipv6 unicast
9)  Configure Default MDT and Data MDT import route-target
10) Configure MDT for Inband Signalling Profiles 100:1
11)  Configure PIM topology on PE routers !
12) Other optional configurations export route-target
100:1
!
!
!
Note: VPN-ID is mandatory configuration for Rosen mLDP
Profiles, but not for others.

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 82
1)  Enable mLDP on all Core Routers
2)  Configure MBB or MoFRR on appropriate Core Routers Put CFI (Customer Facing Interface) into appropriate vrf:
3)  Configure BGP to enable BGP-AD Address-Family
4)  Configure route-policy Syntax:
5)  Configure vrf instance for customers + vrf <vrf name>
6)  Put CFI (Customer Facing Interface) into appropriate vrf
7)  Enable Multicast on PE and CE routers interface TenGigE0/2/0/0
8)  Configure MDT Source vrf p1_v46
9)  Configure Default MDT and Data MDT ipv4 address 15.0.0.1 255.255.255.0
10) Configure MDT for Inband Signalling Profiles ipv6 address 2008:15:100::1:1/112
11)  Configure PIM topology on PE routers !
12) Other optional configurations

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 83
Enable Multicast on PE and CE routers:
Syntax:
+ multicast-routing
address-family ipv4|ipv6
interface <interface name> enable
vrf <vrf_instance>
address-family ipv4|ipv6
interface <interface name> enable

NOTE: We can enable multicast and pim on interfaces one by


1)  Enable mLDP on all Core Routers one. We can also easily enable all interfaces to run
2)  Configure MBB or MoFRR on appropriate Core Routers multicast and pim, there is a keyword “all” followed
3)  Configure BGP to enable BGP-AD Address-Family interface.
4)  Configure route-policy
5)  Configure vrf instance for customers multicast-routing
6)  Put CFI (Customer Facing Interface) into appropriate vrf address-family ipv4
7)  Enable Multicast on PE and CE routers interface Loopback0
8)  Configure MDT Source enable
9)  Configure Default MDT and Data MDT interface TenGigE0/0/0/0
10) Configure MDT for Inband Signalling Profiles enable
11)  Configure PIM topology on PE routers address-family ipv6
12) Other optional configurations interface Loopback0
enable
interface TenGigE0/0/0/0
enable
vrf p1_v46
address-family ipv4
interface all enable
address-family ipv6
© 2011 Cisco and/or its affiliates. All rights reserved. interface all enable Cisco Confidential 84
Configure MDT Source:
Syntax:
+ multicast-routing
1)  Enable mLDP on all Core Routers address-family ipv4|ipv6
2)  Configure MBB or MoFRR on appropriate Core Routers mdt source <interface>
3)  Configure BGP to enable BGP-AD Address-Family vrf <vrf instance>
4)  Configure route-policy address-family ipv4|ipv6
5)  Configure vrf instance for customers mdt source <interface>
6)  Put CFI (Customer Facing Interface) into appropriate vrf
7)  Enable Multicast on PE and CE routers multicast-routing
8)  Configure MDT Source address-family ipv4
9)  Configure Default MDT and Data MDT mdt source Loopback0
10) Configure MDT for Inband Signalling Profiles
11)  Configure PIM topology on PE routers multicast-routing
12) Other optional configurations vrf p1_v46
address-family ipv4
mdt source Loopback1001

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 85
Configure Default MDT and Data MDT:
Syntax:
+ mdt default mldp ipv4 <Root Address>
[This is for Rosen mLDP Profile]
+ mdt partitioned mldp ipv4 mp2mp|p2mp
[This is for Partitional mLDP Profile]
1)  Enable mLDP on all Core Routers + mdt data <maxi data MDT number> threshold
2)  Configure MBB or MoFRR on appropriate Core Routers <rate>
3)  Configure BGP to enable BGP-AD Address-Family NOTE: Different mLDP mVPN Profiles have different MDT
4)  Configure route-policy definition. Default MDT and Data MDT only exist on
Rosen and Partitional MDT profiles and can be
5)  Configure vrf instance for customers configured under multicast via below CLI. Default MDT
6)  Put CFI (Customer Facing Interface) into appropriate vrf is mandatory configuration for Rosen and Partition
7)  Enable Multicast on PE and CE routers Profiles.
8)  Configure MDT Source NOTE: To configure Root Node Redundancy (RNR) in Rosen
9)  Configure Default MDT and Data MDT Profiles, just configure Multiple Rood Address in
10) Configure MDT for Inband Signalling Profiles multiple CLI lines.
11)  Configure PIM topology on PE routers multicast-routing
12) Other optional configurations vrf p1_v46
address-family ipv4
mdt default mldp ipv4 10.2.2.2
mdt data 255 threshold 2
address-family ipv6
mdt default mldp ipv4 10.2.2.2
mdt data 255 threshold 2

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 86
Configure MDT for Inband Signalling Profiles:

Syntax:
+ mdt mldp in-band-signaling ipv4

1)  Enable mLDP on all Core Routers NOTE: There are no concepts of Default MDT and Data MDT
2)  Configure MBB or MoFRR on appropriate Core Routers on Inband Signalling Profiles, we can configure In-Band
Signaling Core-Tree via below CLI under multicast.
3)  Configure BGP to enable BGP-AD Address-Family
4)  Configure route-policy ***Option 1: Global Inband***
5)  Configure vrf instance for customers
multicast-routing
6)  Put CFI (Customer Facing Interface) into appropriate vrf
address-family ipv4
7)  Enable Multicast on PE and CE routers
8)  Configure MDT Source mdt mldp in-band-signaling ipv4
9)  Configure Default MDT and Data MDT address-family ipv6
10) Configure MDT for Inband Signalling Profiles mdt mldp in-band-signaling ipv4
11)  Configure PIM topology on PE routers ***Option 2: VRF Inband***
12) Other optional configurations multicast-routing
vrf p1_v46
address-family ipv4
mdt mldp in-band-signaling ipv4
address-family ipv6
mdt mldp in-band-signaling ipv4

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 87
Configure BGP-AD route discovery mode under multicast:
1)  Enable mLDP on all Core Routers
2)  Configure MBB or MoFRR on appropriate Core Routers Syntax:
3)  Configure BGP to enable BGP-AD Address-Family + multicast-routing
4)  Configure route-policy vrf <vrf instance>
5)  Configure vrf instance for customers address-family ipv4 | ipv6
6)  Put CFI (Customer Facing Interface) into appropriate vrf bgp auto-discovery [mldp | pim | p2mp-te]
7)  Enable Multicast on PE and CE routers
8)  Configure MDT Source multicast-routing
9)  Configure Default MDT and Data MDT vrf p_1
10) Configure MDT for Inband Signalling Profiles address-family ipv4
11)  Configure BGP-AD route discovery mode under multicast bgp auto-discovery mldp
12) Other optional configurations address-family ipv6
bgp auto-discovery mldp

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 88
Configure pim topology:

Syntax:
+ router pim
address-family ipv4 | ipv6
1)  Enable mLDP on all Core Routers rpf topology route-policy <route-policy
2)  Configure MBB or MoFRR on appropriate Core Routers name>
3)  Configure BGP to enable BGP-AD Address-Family
4)  Configure route-policy NOTE:
5)  Configure vrf instance for customers   Configure pim rpf topology to define which core-tree
will be chosen to accept and join.
6)  Put CFI (Customer Facing Interface) into appropriate vrf
7)  Enable Multicast on PE and CE routers
router pim
8)  Configure MDT Source
9)  Configure Default MDT and Data MDT address-family ipv4
10) Configure MDT for Inband Signalling Profiles rpf topology route-policy inband
11)  Configure PIM topology on PE routers address-family ipv6
12) Configure pim topology rpf topology route-policy inband
vrf p1_v46
address-family ipv4
rpf topology route-policy provider-tree
address-family ipv6
rpf topology route-policy provider-tree

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 89
•  Thank you!
•  Please complete the post-event survey
•  Join us for upcoming webinars:
Register: www.cisco.com/go/techadvantage

Follow us @GetYourBuildOn

© 2011 Cisco and/or its affiliates. All rights reserved. Cisco Confidential 90