Vous êtes sur la page 1sur 37

TC 1.2.

1 EBGP Post routing interoperability test

The test 1.2.1


number
The test The release of the EBGP routing interoperability test
project
The purpose The basic route of EBGP release and interworking function is normal
of testing
The test environment:

AS200 AS100
10.168.20.70
20.72 1.1.1.2 1.1.1.1

DUT1 DUT2
PC1

Preparation work:
1、 Set up the test environment according to the diagram;
2、 The default gateway is set PC1 is directly connected to the router port address;
3、 Configure the DUT1 belongs to AS200, DUT2 belongs to AS200;
4、 Check whether the DUT neighbor relationships to form;

The associated configuration:


The DUT1 configuration:
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/0
ip address 10.168.20.72 255.255.0.0
no ip directed-broadcast
!
interface FastEthernet0/1
ip address 1.1.1.2 255.255.255.0
no ip directed-broadcast
!
router bgp 200
bgp log-neighbor-changes
network 10.1.1.0/24
redistribute connected
neighbor 1.1.1.1 remote-as 100
!

The DUT2 configuration:


!
interface Loopback0
ip address 20.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/1
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
!
router bgp 100
bgp log-neighbor-changes
network 20.1.1.0/24
neighbor 1.1.1.2 remote-as 200
!

Test point 1: The EBGP connection, through the network routing information release
Test step:
1、 Viewing on a DUT1 with or without DUT2 issued by network over20.1.1.0/24 this route;
2、 Viewing on a DUT2 with or without DUT1 issued by network over10.1.1.0/24 this route;
3、DUT1 using 10.1.1.1 as the source 20.1.1.1 address of Ping DUT2interoperability testing

Test point 2: The EBGP connection, through the forward command routing information release
Test step:

1、 See no DUT1 forward direct routing released over the route in DUT210.168.0.0/16
2、DUT2 10.168.20.70 interoperability testing with 20.1.1.1 as ping source address PC1 address

The expected results:

Test point 1:

Each DUT has 1 steps, the two route 2 expected (in show list item ofmarked in blue related in
the following), and DUT1 with 10.1.1.1 as the source address is able to Ping DUT2 20.1.1.1

Test point 2:

In DUT2 show 1 steps expected 10.168.0.0/16 this route (in show list item
of marked with green related in the following), and DUT2 with 20.1.1.1 asthe source address is
able to Ping PC1

DUT1#sho ip bgp
BGP table version is 0, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 0.0.0.0 32768 ?
* 10.1.1.0/24 0.0.0.0 32768 ?
*> 0.0.0.0 32768 i
*> 10.168.0.0/16 0.0.0.0 32768 ?
*> 20.1.1.0/24 1.1.1.1 0 100 i

Total number of prefixes 4


DUT1#sho ip route
Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected
D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type

VRF ID: 0

C 1.1.1.0/24 is directly connected, FastEthernet0/1


C 10.1.1.0/24 is directly connected, Loopback0
C 10.168.0.0/16 is directly connected, FastEthernet0/0
B 20.1.1.0/24 [20,0] via 1.1.1.1

DUT2#sho ip bgp
BGP table version is 0, local router ID is 20.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


*> 1.1.1.0/24 1.1.1.2 0 200 ?
*> 10.1.1.0/24 1.1.1.2 0 200 i
*> 10.168.0.0/16 1.1.1.2 0 200 ?
*> 20.1.1.0/24 0.0.0.0 32768 i

Total number of prefixes 4

DUT2#sho ip route
Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected
D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type

VRF ID: 0

C 1.1.1.0/24 is directly connected, FastEthernet0/1


C 2.1.1.0/24 is directly connected, FastEthernet0/0
B 10.1.1.0/24 [20,0] via 1.1.1.2
B 10.168.0.0/16 [20,0] via 1.1.1.2
C 20.1.1.0/24 is directly connected, Loopback0

The test results:pass

Remarks:
TC5.3.7.1 Ripv1

Test case TC5.3.7.1 The test RIPv1 interworking


number project
The test target: RIPv1 routing, test connectivity
The test environment configuration: The topological graph
R1 BD7208_1 BD7208_2

S2/0 S4/0 S4/1 S4/0


20.1.1.2 20.1.1.1 10.1.1.1 10.1.1.2

Test cases and procedures:


1 . R1, BD7208_1 and BD7208_2 serial port directly connected with back to back line
2 . Configure the physical layer rate respectively
3 . The configuration of RIPv1 in R1, BD7208_1 and BD7208_2
4 . R1 and BD7208_2 on Ping 64 and 20000 byte big
5 . With the relevant command to view routing information
The router configuration:
R1:
interface Serial2/0
ip address 20.1.1.2 255.255.255.0
no ip directed-broadcast
physical-layer speed 64000
!
router rip
version 1
network 20.0.0.0

BD7208_1 :
interface Serial4/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
physical-layer speed 64000
!
interface Serial4/1
ip address 20.1.1.1 255.255.255.0
no ip directed-broadcast
physical-layer speed 64000
!
router rip
version 1
network 20.0.0.0
network 10.0.0.0

BD7208_2 :
interface Serial4/0
ip address 10.1.1.2 255.255.255.0
no ip directed-broadcast
physical-layer speed 64000
!
router rip
version 1
network 10.0.0.0

The expected results: BD7208_1 and BD7208_2 can be connected to the Ping, 64 or 20000byte
packet no crash, restart the phenomenon. Use the followingcommand to display information:

R1#sho ip route

Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected


D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2

VRF ID: 0

R 10.0.0.0/8 [120,1] via 20.1.1.1(on Serial2/0)


C 20.1.1.0/24 is directly connected, Serial2/0

R1#sho ip rip prot

RIP is Active
Sending updates every 30 seconds, next due in 30 seconds
Invalid after 180 seconds, holddown 120
update filter list for all interfaces is:
update offset list for all interfaces is:
Redistributing:
Default version control: send version 1, receive version 1 2
Interface Send Recv
Serial2/0 1 1
Automatic network summarization is in effect
Routing for Networks:
20.0.0.0/8
10.0.0.0/8
Distance: 120 (default is 120)
Maximum route count: 1024, Route count:3

R1#sho ip rip sum

/*-----------------------------------------------------------*/
RIP route table:
Maximum route number:1024
Total route number :3
Connect route number :1
Summary route number :1
Learn route number :1
Redistributed route number :0
/*-----------------------------------------------------------*/

R1#sho ip rip dat

10.0.0.0/8 [120,1] via 20.1.1.1 (on Serial2/0) 00:00:16


20.0.0.0/8 auto-summary
20.1.1.0/24 directly connected Serial2/0

R1_config#debug ip rip pro


R1#2005-1-20 10:39:48 RIP: recv RIP from 20.1.1.1 on Serial2/0
2005-1-20 10:39:48 vers 1, CMD_RESPONSE, length 24
2005-1-20 10:39:48 10.0.0.0/0 via 0.0.0.0 metric 1
A description of the test:
The measured results: PASS

TC5.3.7.1 OSPF

Test case TC5.3.8.1 The test OSPF interworking


number project
The test target: Simple routing function test of OSPF is normal
The test environment configuration: The topological graph
1.1.1.1 2.2.2.1
PC1 PC2
DUT1 DUT2 DUT3
G0/1 F0/0

20.191 10.1.1.1 10.1.1.2 11.1.1.1 11.1.1.2 100.1

10.168.20.161 192.168.100.3
10.168.20.191

Test cases and procedures:



1 Between DUT1, DUT2, DUT3 are connected by a 2M V.35 serial line.

2 Configuration to enable OSPF in each DUT, and belong to one and the same area 0.

3 The default gateway is set PC is directly connected to the router port address

4 From PC1 Ping PC2. Observe the DUT routing table is complete.


The router configuration:
DUT1
interface Loopback0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface Serial3/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast+
!
interface GigaEthernet0/1
ip address 10.168.20.191 255.255.255.0
no ip directed-broadcast
!
router ospf 1
network 1.1.1.0 255.255.255.0 area 0
network 10.168.20.0 255.255.255.0 area 0
network 10.1.1.0 255.255.255.0 area 0


!
DUT2
interface Loopback0
ip address 2.2.2.1 255.255.255.0
no ip directed-broadcast
!
interface Serial3/0
ip address 10.1.1.2 255.255.255.0
no ip directed-broadcast
physical-layer speed 2048000
!
interface Serial3/2
ip address 11.1.1.1 255.255.255.0
no ip directed-broadcast
physical-layer speed 2048000
!
router ospf 1
network 2.2.2.0 255.255.255.0 area 0
network 10.1.1.0 255.255.255.0 area 0
network 11.1.1.0 255.255.255.0 area 0

!
DUT3
interface Loopback0
ip address 3.3.3.1 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/0
ip address 192.168.100.1 255.255.255.0
no ip directed-broadcast
!
interface Serial1/0
ip address 11.1.1.2 255.255.255.0
no ip directed-broadcast
!
router ospf 1
network 3.3.3.0 255.255.255.0 area 0
network 192.168.100.0 255.255.255.0 area 0
network 11.1.1.0 255.255.255.0 area 0
!
The expected results: PC1 can ping through PC2, the DUT routing table is complete.
A description of the test;
The measured results: PASS

TC 1.1.2 level-2 In the region of interoperability testing

The test 1.1.2


number
The test Level-2 in the region of different test
project
The purpose DUT work in leve-2 basic function is normal
of testing
The test environment:

L2 L2 L2
1.1.1.1 1.1.1.2 2.1.1.2 2.1.1.1

DUT1 DUT2 DUT3


Test step:
1、 According to the chart to build a good test environment
2、 Configure the associated IP addresses on the DUT and associated
Isisprocess, and then configure Isis routing, each of the DUT work
in level-2;
3、 System stability after view between each DUT is able to establish a neighbor
relationship, each of the DUT routing table is correct, whether the interworking between
DUT.

The associated configuration:


The DUT1 configuration:
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
osi enable
ip router isis 1
!
interface Loopback2
ip address 10.1.2.1 255.255.255.255
no ip directed-broadcast
osi enable
ip router isis 1
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
osi enable
ip router isis 1
!
router isis 1
is-type level-2
net 51.0001.0000.0000.000a.00
!
The DUT2 configuration:
!
interface Loopback1
ip address 20.1.1.1 255.255.255.0
no ip directed-broadcast
osi enable
ip router isis 1
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.0
no ip directed-broadcast
osi enable
ip router isis 1
!
interface FastEthernet0/3
ip address 2.1.1.2 255.255.255.0
no ip directed-broadcast
osi enable
ip router isis 1
!
router isis 1
is-type level-2
net 51.0001.0000.0000.000b.00
!

The DUT3 configuration:


!
interface Loopback1
ip address 30.1.1.1 255.255.255.255
no ip directed-broadcast
osi enable
ip router isis 1
!
interface Loopback2
ip address 30.1.2.1 255.255.255.0
no ip directed-broadcast
osi enable
ip router isis 1
!
interface FastEthernet0/0
ip address 2.1.1.1 255.255.255.0
no ip directed-broadcast
osi enable
ip router isis 1
!
!
router isis 1
is-type level-2
net 51.0001.0000.0000.000c.00
!
The expected results:
1、Each DUT can correctly establish a neighbor relationship:
DUT2_config#sho isis nei

Area 1:
System Id Interface State Type Priority Circuit Id
0000.0000.000A FastEthernet0/0 Up L2 64 0000.0000.000A.03
0000.0000.000C FastEthernet0/3 Up L2 64 0000.0000.000B.02

2、The DUT routing table is complete:


DUT1_config# sho isis route

Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2


ia - IS-IS inter area, D - discard, e - external metric

Area 1:
Destination Metric Next-Hop Interface
C 1.1.1.0 10 -- FastEthernet0/0
L2 2.1.1.0 20 1.1.1.2 FastEthernet0/0
C 10.1.1.0 10 -- Loopback1
C 10.1.2.1 10 -- Loopback2
L2 20.1.1.0 20 1.1.1.2 FastEthernet0/0
L2 30.1.1.1 30 1.1.1.2 FastEthernet0/0
L2 30.1.2.0 30 1.1.1.2 FastEthernet0/0

DUT1_config#sho ip route
Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected
D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

VRF ID: 0

C 1.1.1.0/24 is directly connected, FastEthernet0/0


L2 2.1.1.0/24 [18,20] via 1.1.1.2(on FastEthernet0/0)
C 10.1.1.0/24 is directly connected, Loopback1
C 10.1.2.1/32 is directly connected, Loopback2
L2 20.1.1.0/24 [18,20] via 1.1.1.2(on FastEthernet0/0)
L2 30.1.1.1/32 [18,30] via 1.1.1.2(on FastEthernet0/0)
L2 30.1.2.0/24 [18,30] via 1.1.1.2(on FastEthernet0/0)

DUT2_config#sho isis route


Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric

Area 1:
Destination Metric Next-Hop Interface
C 1.1.1.0 10 -- FastEthernet0/0
C 2.1.1.0 10 -- FastEthernet0/3
L2 10.1.1.0 20 1.1.1.1 FastEthernet0/0
L2 10.1.2.1 20 1.1.1.1 FastEthernet0/0
C 20.1.1.0 10 -- Loopback1
L2 30.1.1.1 20 2.1.1.1 FastEthernet0/3
L2 30.1.2.0 20 2.1.1.1 FastEthernet0/3

DUT2_config#sho ip route
Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected
D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

VRF ID: 0

C 1.1.1.0/24 is directly connected, FastEthernet0/0


C 2.1.1.0/24 is directly connected, FastEthernet0/3
L2 10.1.1.0/24 [18,20] via 1.1.1.1(on FastEthernet0/0)
L2 10.1.2.1/32 [18,20] via 1.1.1.1(on FastEthernet0/0)
C 20.1.1.0/24 is directly connected, Loopback1
L2 30.1.1.1/32 [18,20] via 2.1.1.1(on FastEthernet0/3)
L2 30.1.2.0/24 [18,20] via 2.1.1.1(on FastEthernet0/3)

DUT3_config#sho isis route

Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2


ia - IS-IS inter area, D - discard, e - external metric

Area 1:
Destination Metric Next-Hop Interface
L2 1.1.1.0 20 2.1.1.2 FastEthernet0/0
C 2.1.1.0 10 -- FastEthernet0/0
L2 10.1.1.0 30 2.1.1.2 FastEthernet0/0
L2 10.1.2.1 30 2.1.1.2 FastEthernet0/0
L2 20.1.1.0 20 2.1.1.2 FastEthernet0/0
C 30.1.1.1 10 -- Loopback1
C 30.1.2.0 10 -- Loopback2
DUT3_config#sho ip route
Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected
D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

VRF ID: 0

L2 1.1.1.0/24 [18,20] via 2.1.1.2(on FastEthernet0/0)


C 2.1.1.0/24 is directly connected, FastEthernet0/0
L2 10.1.1.0/24 [18,30] via 2.1.1.2(on FastEthernet0/0)
L2 10.1.2.1/32 [18,30] via 2.1.1.2(on FastEthernet0/0)
L2 20.1.1.0/24 [18,20] via 2.1.1.2(on FastEthernet0/0)
C 30.1.1.1/32 is directly connected, Loopback1
C 30.1.2.0/24 is directly connected, Loopback2

3、Good interoperability:The other two DUT associated Ping address for each DUT, can pass.

The test results: pass

TC 1.1.2 BGP4+ Interoperability test

Test case TC1.1.2 The test EBGP4+ Post routing interoperability


number project test
The test target: The basic route of EBGP release and interworking function is normal
The test environment:

DUT1 DUT2 DUT3


Test step:
1. DUT1, DUT2 and DUT3 Ethernet line directly connected with back to back
2. Configure the DUT1 belongs to AS100, DUT2 belongs to AS200, DUT3 to the
default routing DUT2
3. Check the DUT neighbor is established, the routing is complete, whether
DUT1 and DUT3 can ping
The router configuration:
DUT1:
!
ipv6 unicast-routing
!
interface Null0

!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface GigaEthernet0/0
no ip address
no ip directed-broadcast
ipv6 address 100::1/64
!
interface GigaEthernet0/1
no ip address
no ip directed-broadcast
ipv6 address 200::1/64
!
!
!
!
router bgp 100
bgp log-neighbor-changes
neighbor 100::2 remote-as 200

address-family ipv6
network 100::/64
network 200::/64
neighbor 100::2 activate
exit-address-family
!
!
!
DUT2:
!
ipv6 unicast-routing
!
interface Null0

!
interface Loopback0
ip address 20.1.1.1 255.255.255.0
no ip directed-broadcast
!
!
!
!
!
!
interface GigaEthernet0/0
no ip address
no ip directed-broadcast
ipv6 address 100::2/64
!
interface GigaEthernet0/1
no ip address
no ip directed-broadcast
ipv6 address 300::2/64
!
!
!
!
!
!
router bgp 200
bgp log-neighbor-changes
neighbor 100::1 remote-as 100

address-family ipv6
network 100::/64
network 300::/64
neighbor 100::1 activate
exit-address-family
!
!
!
!

DUT3:
!
ipv6 unicast-routing
!
interface Null0
!
interface Loopback0
ip address 30.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface GigaEthernet0/0
no ip address
no ip directed-broadcast
ipv6 address 300::1/64

!
ipv6 route default 300::2
!

The expected results: The DUT neighbor can be established, can learn a complete routing,DUT1 is
able to Ping DUT3
DUT1_config#show ip bgp nei
BGP neighbor is 100::2, remote AS 200, local AS 100, external link
BGP version 4, remote router ID 20.1.1.1
BGP state = Established, up for 00:00:19
Last read 00:00:35, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 5 messages, 0 notifications, 0 in queue
Sent 7 messages, 1 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds

For address family: IPv4 Unicast


Community attribute sent to this neighbor (both)
0 accepted prefixes

For address family: IPv6 Unicast


Community attribute sent to this neighbor (both)
2 accepted prefixes

Connections established 2; dropped 1


Last reset 00:00:25, due to Address family activated
Local host: 100::1, Local port: 20479
Foreign host: 100::2, Foreign port: 179
Nexthop: 10.1.1.1
Nexthop global: 100::1
Nexthop local: fe80::2e0:fff:fe8c:1067
BGP connection: shared network
Read thread: on Write thread: off

DUT1_config#show ip bgp ipv6 uni


BGP table version is 0, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best,
i - internal, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
* 100::/64 100::2 0 0 200 i
*> :: 0 32768 i
*> 200::/64 :: 0 32768 i
*> 300::/64 100::2 0 0 200 i

Total number of prefixes 3


DUT1_config#ping6 300::1
PING 300::1 (300::1): 56 data bytes
!!!!!
--- 300::1 ping6 statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 0/0/0 ms

DUT2_config#show ip bgp ipv6 uni


BGP table version is 0, local router ID is 20.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best,
i - internal, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


* 100::/64 100::1 0 0 100 i
*> :: 0 32768 i
*> 200::/64 100::1 0 0 100 i
*> 300::/64 :: 0 32768 i

Total number of prefixes 3

DUT3_config#show ipv6 route


Codes: C - Connected, L - Local, S - Static, R - Ripng, B - BGP
ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2
OE1 - OSPF external type 1, OE2 - OSPF external type 2
DHCP - DHCP type

VRF ID: 0

S ::/0[1]
[1,0] via 300::2(on GigaEthernet0/0)
C 300::/64[1]
is directly connected, C,GigaEthernet0/0
C 300::1/128[1]
is directly connected, L,GigaEthernet0/0
C fe80::/10[1]
is directly connected, L,Null0
C fe80::/64[1]
is directly connected, C,GigaEthernet0/0
C fe80::2e0:fff:fe98:d81/128[1]
is directly connected, L,GigaEthernet0/0
C ff00::/8[1]
is directly connected, L,Null0

A description of the test:


The measured results: PASS

TC 1.1.2 pim-sm Interoperability test

BSR28 Router:

ip multicast-routing
!
interface GigaEthernet0/0
ip address 1.1.1.1 255.255.0.0
no ip directed-broadcast
ip pim-sm
ip igmp version 2
!
interface GigaEthernet0/1
ip address 2.1.1.1 255.255.255.0
no ip directed-broadcast
ip pim-sm
ip igmp version 2
!
router pim-sm // Automatic generation

Router_config#sho ip igmp gr
Total igmp group number: 1
interface: GigaEthernet0/1: igmp group number: 1
Interface Group address Uptime Expires Last Reporter Flags
GigaEthernet0/1 225.0.0.1 00:00:01 00:02:09 2.1.1.2 R
Router_config#
Router_config#
TC 1.1.2 IGMP-V3 Interoperability test

Test point 3: igmpv3(Refused to join a particular group)


ip multicast-routing
!

interface Loopback0
ip address 30.1.1.1 255.255.255.0
no ip directed-broadcast
ip pim-sm
!
interface GigaEthernet0/0
ip address 1.1.1.1 255.255.0.0
no ip directed-broadcast
ip pim-sm
!
interface GigaEthernet0/1
ip address 2.1.1.1 255.255.0.0
no ip directed-broadcast
ip pim-sm
ip igmp access-group test
!
router pim-sm
reg-rate-limit 1
static-rp 30.1.1.1
!
!
ip access-list extended test
deny igmp 225.0.0.0 255.255.255.0 any
!
Router_config#

The test results
Unable to join the multicast

Add access list When adding IP IGMP group multicast 225.0.0.1 show in front of the no
information

Remove the access list able
When changing the multicast entries, or flow, to re edit the variousoptions on it; to ensure that the
premise of flow can open
QOS:

interface GigaEthernet0/0
ip address 10.0.1.1 255.255.255.0
no ip directed-broadcast
!
interface GigaEthernet0/1
ip address 10.0.2.1 255.255.255.0
no ip directed-broadcast
bandwidth 360000
fair-queue
!

PPPOE:

Test case TC 5.3.22.10 The test PPPOE as a Client terminal test


number project

The test target A router can support PPPOE, and as the Client terminal

The test environment configuration The topological graph
See TC 5.3.22.1 topology graph

Test step:
1. R1 PC1 R2 f0/0 connection, f0/0 connection PC2
2. R1 f1/0 is connected to the R2 f1/0 through a crossovercable
3. Configure R1 to Server, R2 is configured as a Client, configuration parameters of
PPPOE
4. PC2 Ping PC1, see whether can pass。
5. Debug PPPOE tracking information, check the related information

The test configuration:


The configuration of R1:
Server terminal:
aaa authentication ppp default local
!
username user password 0 123
!
interface Virtual-template1 // Interface virtual server
ip address 11.1.1.1 255.255.255.0
no ip directed-broadcast
ppp authentication chap
ppp chap hostname user
!
vpdn enable
!
vpdn-group 1 // Create a VPDN group
accept-dialin // VPDN is set to NS (NS is the server end, Nac is the client side)
port Virtual-template1
protocol pppoe // The type of protocol settings of the VPDN group
pppoe bind f2/0 // Group VPDN binding PPOE protocol to which the Ethernet port

The configuration of R2:


Client terminal:
aaa authentication ppp default local
!
username user password 0 123
!
interface Virtual-tunnel1
ip address 11.1.1.2 255.255.255.0
no ip directed-broadcast
ppp authen chap
ppp chap hostname user
!
vpdn enable
!
vpdn-group 1
request-dialin // Set the VPDN NAC
port Virtual-tunnel1
protocol pppoe
pppoe bind f1/0
!

The expected results: Can ping Server end R2 address from the debug PPPoE, can be related
information, can through the show command to view the PPPoE connection related
information

The measured results pass

MPLS VPN Function:


PE1 :
!
mpls ip
mpls ldp router-id 10.0.0.2
!
!
!
ip vrf vpn1
rd 1:0
route-target export 1:0
route-target import 1:0
!
!
!
!
interface Loopback0
ip address 10.0.0.2 255.255.255.255
no ip directed-broadcast
!
interface GigaEthernet0/0
ip address 30.1.1.1 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
!
interface GigaEthernet0/1
ip vrf forwarding vpn1
ip address 10.0.1.1 255.255.255.0
no ip directed-broadcast
!
!
!
!
router ospf 1
network 10.0.0.2 255.255.255.255 area 0
network 30.1.1.0 255.255.255.0 area 0
!
router ospf 2 vrf vpn1
network 10.0.1.0 255.255.255.0 area 0
redistribute bgp 1
!
!
!
!
!
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.1 remote-as 1
neighbor 10.0.0.1 update-source Loopback0

address-family vpnv4
neighbor 10.0.0.1 activate
neighbor 10.0.0.1 send-community extended
bgp redistribute-internal
exit-address-family
address-family ipv4 vrf vpn1
no synchronization
bgp redistribute-internal
redistribute ospf 2 match external 1-2
redistribute connected
exit-address-family
!
!

PE2 :
!
mpls ip
mpls ldp router-id 10.0.0.1
!
!
!
!
!
!
!
ip vrf vpn1
rd 1:0
route-target export 1:0
route-target import 1:0
!
!
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
no ip directed-broadcast
!
interface GigaEthernet0/0
ip address 30.1.1.2 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
!
interface GigaEthernet0/1
ip vrf forwarding vpn1
ip address 10.0.2.1 255.255.255.0
no ip directed-broadcast
!
!
!
!
!
router ospf 1
network 10.0.0.1 255.255.255.255 area 0
network 30.1.1.0 255.255.255.0 area 0
!
router ospf 2 vrf vpn1
network 10.0.2.0 255.255.255.0 area 0
redistribute bgp 1
!
!
!
!
!
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.2 remote-as 1
neighbor 10.0.0.2 update-source Loopback0

address-family vpnv4
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 send-community extended
bgp redistribute-internal
exit-address-family

address-family ipv4 vrf vpn1


no synchronization
bgp redistribute-internal
redistribute ospf 2 match external 1-2
redistribute connected
exit-address-family
!
MPLS Two layer function:

1 . Point to point test


The test environment testcenter----PE1----P----PE2----testcenter

The test configuration
PE1:
mpls ip
mpls ldp discovery targeted-hello accept
mpls ldp neighbor 30.1.1.1 targeted
mpls ldp router-id 10.1.1.1
!
!
mpls l2vpn
mpls vfi red ptop
pwid 100
neighbor 30.1.1.1 encapsulation mpls
!
mpls vfi blue ptop
pwid 200
neighbor 30.1.1.1 encapsulation mpls
!

interface Loopback0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface GigaEthernet0/0
no ip address
no ip directed-broadcast
ip http firewalltype 0
!
interface GigaEthernet0/0.1
no ip directed-broadcast
encapsulation dot1Q 1
bandwidth 1000000
delay 1
mpls l2vpn vfi red
ip http firewalltype 0
!
interface GigaEthernet0/0.2
no ip directed-broadcast
encapsulation dot1Q 2
bandwidth 1000000
delay 1
mpls l2vpn vfi blue
!
interface GigaEthernet0/1
ip address 2.1.1.1 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
ip http firewalltype 0
!
router ospf 1
network 10.1.1.1 255.255.255.255 area 0
network 2.1.1.0 255.255.255.0 area 0
!
!

P:
mpls ip
mpls ldp router-id 20.1.1.1
!
!
interface Loopback0
ip address 20.1.1.1 255.255.255.255
no ip directed-broadcast
!
interface GigaEthernet0/0
ip address 3.1.1.2 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
ip http firewalltype 0
!
interface GigaEthernet0/1
ip address 2.1.1.2 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
ip http firewalltype 0
!
!
!
router ospf 1
network 2.1.1.0 255.255.255.0 area 0
network 3.1.1.0 255.255.255.0 area 0
network 20.1.1.1 255.255.255.255 area 0
!
!

PE2:
mpls ip
mpls ldp discovery targeted-hello accept
mpls ldp neighbor 10.1.1.1 targeted
mpls ldp router-id 30.1.1.1
!
!
mpls l2vpn
mpls vfi red ptop
pwid 100
neighbor 10.1.1.1 encapsulation mpls
!
mpls vfi blue ptop
pwid 200
neighbor 10.1.1.1 encapsulation mpls
!
!
interface Loopback0
ip address 30.1.1.1 255.255.255.255
no ip directed-broadcast
!
interface GigaEthernet0/0
ip address 3.1.1.1 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
ip http firewalltype 0
!
interface GigaEthernet0/1
no ip address
no ip directed-broadcast
ip http firewalltype 0
!
interface GigaEthernet0/1.1
no ip address
no ip directed-broadcast
encapsulation dot1Q 1
bandwidth 1000000
delay 1
mpls l2vpn vfi red
ip http firewalltype 0
!
interface GigaEthernet0/1.2
no ip address
no ip directed-broadcast
encapsulation dot1Q 2
bandwidth 1000000
delay 1
mpls l2vpn vfi blue
!

router ospf 1
network 30.1.1.1 255.255.255.255 area 0
network 3.1.1.0 255.255.255.0 area 0
!

Viewed through the following command:


PE1_config#show mpls l2vpn pw
Local intf VFI name Dest addr PW-ID Status
======================================================================
g0/0.1 red 30.1.1.1 100 UP
g0/0.2 blue 30.1.1.1 200 UP
PE1_config#show mpls l2vpn vfi
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No
VFI name: red
Local attachment circuits:
VFI name PWID PWTYPE VC intf VFI status
=============================================================
red 100 VLAN g0/0.1 UP
Neighbors connected via pseudowires:
Peer Address VC ID Split-horizon
30.1.1.1 100 Y
VFI name: blue
Local attachment circuits:
VFI name PWID PWTYPE VC intf VFI status
=============================================================
blue 200 VLAN g0/0.2 UP
Neighbors connected via pseudowires:
Peer Address VC ID Split-horizon
30.1.1.1 200 Y
PE1_config#show mpls ft vfi
MPLS ftn table for vfi
PWID PWtype Flag MTU Stat OutLbl Creator Next-Hop(OutIntf)
======================================================================
==
100 VLAN -- 1500 ACT 1042 LDP 30.1.1.1:0
1298 LDP 2.1.1.2:0(g0/1)
200 VLAN -- 1500 ACT 1043 LDP 30.1.1.1:0
1298 LDP 2.1.1.2:0(g0/1)
PE1_config#show mpls ldp nei
--------------
Peer LDP Ident: | 30.1.1.1:0 |
--------------
Up time: 4d02h53m; Refresh Time: 00:00:58; State: Operation; SSN: T
TCP connection: 10.1.1.1,646 <-> 30.1.1.1,20213
Label Distribution Method: DU
Transport Address: 30.1.1.1
Discovery Interface:
Targeted intf, Src IP addr: 3.1.1.1, Refresh Time: 00:00:33
Addresses bound to peer LDP Ident:
3.1.1.1 30.1.1.1 4.1.1.1 4.2.1.1
--------------
Peer LDP Ident: | 20.1.1.1:0 |
--------------
Up time: 4d02h54m; Refresh Time: 00:00:52; State: Operation; SSN: L
TCP connection: 2.1.1.1,646 <-> 2.1.1.2,20233
Label Distribution Method: DU
Transport Address: 0.0.0.0
Discovery Interface:
GigaEthernet0/1, Src IP addr: 2.1.1.2, Refresh Time: 00:00:12
Addresses bound to peer LDP Ident:
3.1.1.2 2.1.1.2 20.1.1.1
PE1_config#show mpls ldp p
PE1_config#show mpls ldp parameters
Protocol version: 1
Session hold time: 60 sec; keep alive interval: 20 sec
Discovery hello: holdtime: 15 sec; interval: 5 sec
LDP loop detection: off
LDP label distribution method: DU
LDP label retention mode: Conservative
LDP label allocation method: Independ

If PE1, PE2 configuration is replaced by the following:


PE1:
interface GigaEthernet0/0
no ip address
no ip directed-broadcast
mpls l2vpn vfi blue
ip http firewalltype 0
!
PE2:
interface GigaEthernet0/1
no ip address
no ip directed-broadcast
mpls l2vpn vfi blue
ip http firewalltype 0
!
PE2#show mpls ftn vfi
MPLS ftn table for vfi
PWID PWtype Flag MTU Stat OutLbl Creator Next-Hop(OutIntf)
======================================================================
==
100 VLAN -- 1500 ACT 1027 LDP 10.1.1.1:0
1029 LDP 3.1.1.2:0(g0/0)
200 EHTE -- 1500 ACT 1028 LDP 10.1.1.1:0
1029 LDP 3.1.1.2:0(g0/0)
If set up a sub interface, in the standard port configuration L2vpn,PWtype for
VLAN, L2vpn standard direct configuration in the mouth,PWtype EHTE

2.Multi point test


The test environment testcenter----PE1----P----PE2----testcenter

The test configuration
PE1:
mpls ip
mpls ldp discovery targeted-hello accept
mpls ldp neighbor 30.1.1.1 targeted
mpls ldp router-id 10.1.1.1
!
!
mpls l2vpn
mpls vfi red vpls
pwid 100
neighbor 30.1.1.1 encapsulation mpls
!
mpls vfi blue ptop
pwid 200
neighbor 30.1.1.1 encapsulation mpls
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
no ip directed-broadcast
!
interface GigaEthernet0/0.3
no ip address
no ip directed-broadcast
encapsulation dot1Q 3
bandwidth 1000000
delay 1
mpls l2vpn vfi red
!
interface GigaEthernet0/0.4
no ip address
no ip directed-broadcast
encapsulation dot1Q 4
bandwidth 1000000
delay 1
mpls l2vpn vfi blue
!
interface GigaEthernet0/0.5
no ip address
no ip directed-broadcast
encapsulation dot1Q 5
bandwidth 1000000
delay 1
mpls l2vpn vfi red
!
interface GigaEthernet0/1
ip address 2.1.1.1 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
ip http firewalltype 0
!
!
router ospf 1
network 2.1.1.0 255.255.255.0 area 0
network 10.1.1.1 255.255.255.255 area 0
!
!

P:
mpls ip
mpls ldp router-id 20.1.1.1
!
interface Loopback0
ip address 20.1.1.1 255.255.255.255
no ip directed-broadcast
!
interface GigaEthernet0/0
ip address 3.1.1.2 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
ip http firewalltype 0
!
interface GigaEthernet0/1
ip address 2.1.1.2 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
ip http firewalltype 0
!
!
router ospf 1
network 2.1.1.0 255.255.255.0 area 0
network 3.1.1.0 255.255.255.0 area 0
network 20.1.1.1 255.255.255.255 area 0
!

PE2 :
mpls ip
mpls ldp discovery targeted-hello accept
mpls ldp neighbor 10.1.1.1 targeted
mpls ldp router-id 30.1.1.1
!
!
mpls l2vpn
mpls vfi red vpls
pwid 100
neighbor 10.1.1.1 encapsulation mpls
!
mpls vfi blue ptop
pwid 200
neighbor 10.1.1.1 encapsulation mpls
!

interface Loopback0
ip address 30.1.1.1 255.255.255.255
no ip directed-broadcast
!
interface GigaEthernet0/0
ip address 3.1.1.1 255.255.255.0
no ip directed-broadcast
mpls ip
mpls ldp enable
ip http firewalltype 0
!
interface GigaEthernet0/1
no ip address
no ip directed-broadcast
ip http firewalltype 0
!
interface GigaEthernet0/1.3
no ip address
no ip directed-broadcast
encapsulation dot1Q 3
bandwidth 1000000
delay 1
mpls l2vpn vfi red
!
interface GigaEthernet0/1.4
no ip address
no ip directed-broadcast
encapsulation dot1Q 4
bandwidth 1000000
delay 1
mpls l2vpn vfi blue
!
interface GigaEthernet0/1.5
no ip address
no ip directed-broadcast
encapsulation dot1Q 5
bandwidth 1000000
delay 1
mpls l2vpn vfi red
!
router ospf 1
network 3.1.1.0 255.255.255.0 area 0
network 30.1.1.1 255.255.255.255 area 0
!

PE1_config#show mpls ftn vfi


MPLS ftn table for vfi
PWID PWtype Flag MTU Stat OutLbl Creator Next-Hop(OutIntf)
======================================================================
==
100 VLAN -- 1500 ACT 1038 LDP 30.1.1.1:0
1038 LDP 2.1.1.2:0(g0/1)
200 VLAN -- 1500 ACT 1037 LDP 30.1.1.1:0
1038 LDP 2.1.1.2:0(g0/1)
PE1_config#show mpls for
MPLS Forwarding Table:
In Out Prefix&Len Out Next Hop Label Flag MTU
Label Label pwid Intf Address Creator
======================================================================
=========

1026 Pop Tag 200[PW] NULL 0.0.0.0 LDP -- 1500


1027 Pop Tag 100[PW] NULL 0.0.0.0 LDP -- 1500

show mpls l2vpn vfi


Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No
VFI name: red
Local attachment circuits:
VFI name PWID PWTYPE VC intf VFI status
=============================================================
red 100 VLAN g0/0.5 UP
g0/0.3
Neighbors connected via pseudowires:
Peer Address VC ID Split-horizon
30.1.1.1 100 Y
VFI name: blue
Local attachment circuits:
VFI name PWID PWTYPE VC intf VFI status
=============================================================
blue 200 VLAN g0/0.4 UP
Neighbors connected via pseudowires:
Peer Address VC ID Split-horizon
30.1.1.1 200 Y

PE1_config#show mpls l2vpn pw


Local intf VFI name Dest addr PW-ID Status
======================================================================
- red 30.1.1.1 100 UP
g0/0.4 blue 30.1.1.1 200 UP

P#show mpls for


MPLS Forwarding Table:
In Out Prefix&Len Out Next Hop Label Flag MTU
Label Label pwid Intf Address Creator
======================================================================
=========
1037 Pop Tag 10.1.1.1/32 g0/1 2.1.1.1 LDP
1038 Pop Tag 30.1.1.1/32 g0/0 3.1.1.1 LDP

PE2#show mpls for


MPLS Forwarding Table:
In Out Prefix&Len Out Next Hop Label Flag MTU
Label Label pwid Intf Address Creator
======================================================================
=========
1037 Pop Tag 200[PW] NULL 0.0.0.0 LDP -- 1500
1038 Pop Tag 100[PW] NULL 0.0.0.0 LDP -- 1500
PE2#show mpls ftn vfi
MPLS ftn table for vfi
PWID PWtype Flag MTU Stat OutLbl Creator Next-Hop(OutIntf)
======================================================================
==
100 VLAN -- 1500 ACT 1027 LDP 10.1.1.1:0
1037 LDP 3.1.1.2:0(g0/0)
200 VLAN -- 1500 ACT 1026 LDP 10.1.1.1:0
1037 LDP 3.1.1.2:0(g0/0)

PE2#show mpls l2
l2vpn -- Show l2 mpls pw information
PE2#show mpls l2vpn pw
Local intf VFI name Dest addr PW-ID Status
======================================================================
- red 10.1.1.1 100 UP
g0/1.4 blue 10.1.1.1 200 UP

PE2#show mpls l2vpn vfi


Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No
VFI name: red
Local attachment circuits:
VFI name PWID PWTYPE VC intf VFI status
=============================================================
red 100 VLAN g0/1.5 UP
g0/1.3
Neighbors connected via pseudowires:
Peer Address VC ID Split-horizon
10.1.1.1 100 Y
VFI name: blue
Local attachment circuits:
VFI name PWID PWTYPE VC intf VFI status
=============================================================
blue 200 VLAN g0/1.4 UP
Neighbors connected via pseudowires:
Peer Address VC ID Split-horizon
10.1.1.1 200 Y
Two under the port belongs to vlan3, vlan5 capture floware

TC5.3.7.1 GRE

Test case TC 5.3.22.1 The test GRE interworking performance


number project
The test target: A router can support the GRE package
The test environment configuration: The topological graph

PC1 R1 R2 PC2

A topologica

R76-2_config#show run int tunnel1001


Building configuration...

Current configuration:
!
interface Tunnel1001
ip address 192.171.233.1 255.255.255.0
no ip directed-broadcast
tunnel source 1.4.233.2
tunnel destination 1.4.233.1
tunnel speed-up
R76-2_config#
Test step:
1 . R1 PC1 R2 f0/0 connection, f0/0 connection PC2
2 . R1 S4/0 is connected to the R2 S8/0 via V.35 cable
3 . The establishment of tunnel interface in R1 and R2, configuration parameters of Tunnel
interface
4 . PC2 Ping PC1, see whether can pass
5 . Debug tracking information, check the related information
The test configuration:
The configuration of R1:
interface Tunnel1
mtu 1472
ip address 100.1.1.1 255.255.255.0
no ip directed-broadcast
tunnel source 11.1.1.1
tunnel destination 11.1.1.2
tunnel key 123456
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
interface Serial1/0
ip address 11.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
!
ip route default Tunnel1

The configuration of R2:


interface Tunnel0
mtu 1472
ip address 100.1.1.2 255.255.255.0
no ip directed-broadcast
tunnel source 11.1.1.2
tunnel destination 11.1.1.1
tunnel key 123456
interface FastEthernet0/0
ip address 20.1.1.1 255.255.255.0
no ip directed-broadcast
!
ip route default Tunnel0

The expected resultsPC2 can ping through PC1, to debug related information
A description of the test:
The measured results: pass