Vous êtes sur la page 1sur 4

Cisco Express Forwarding

Cisco Express Forwarding (CEF) est une technologie avancée de commutation de couche 3 utilisée
principalement dans les grands réseaux cœur ou dans l’internet.

Fonction

CEF est principalement utiliée pour augmenter la vitesse


de commutation, réduire le coût globale et les retards
introduits par d’autres techniques de routage, ameliorant
ainsi les performances en general. CEF est base sur deux
elements clés: la Forwarding Information Base (FIB) et
les adjacences.

La FIB est similaire à la table de routage générée par de


multiples protocoles de routage, maintenant que
l’adresse du prochain-saut pour une route IP particulière.

L’adjacence maintient les informations de couche 2 ou


de commutation liées à une entrée particulière de la FIB,
évitant ainsi le besoin de requêtes ARP pour chaque
table lookup ; Il y a cinq types d’adjacences :

 Null adjacency: Rassemble les paquets destinés à une interface NULL. Les paquets avec une
FIB pointant vers des entrées NULL adjacencies normalement est supprimé.
 Punt adjacency: Porte sur les paquets qui nécessitent une manipulation spéciale ou ne
peuvent pas être commuté par la CEF. Ces paquets sont transmis au à la couche de
commutation suivante (généralement de commutation rapide) où ils peuvent être transmis
correctement.
 Glean adjacency: Rassemble les paquets destinés actuellement à des hotes joints, mais sans
information de couche 2
 Discard adjacency: Les entrées de la FIB pointant vers ce type d’adjacences seront rejetées.
 Drop adjacency: Les paquets de pointage sur cette entrée sont abandonnés, mais le préfixe
sera vérifié.

De manière à prendre tous les avantages de la CEF, il est recommandé d’utiliser dCEF (distributed
CEF), où il y a une table FIB sur chacune des cartes. Cela évite la nécessité d'interroger le processeur
principal ou la table de routage de manière à obtenir les informations sur le next-hop, la réalisation de
la commutation rapide sur la carte elle-même. CEF soutient actuellement Ethernet, Frame Relay,
ATM, PPP, FDDI, les Tunnels et HDLC.
Exemple de Configuration: Configuration dans le cadre du
Mode MPLS
La Figure1 montre la topologie du réseau pour la configuration qui suit, qui montre comment
configurer dans le cadre du mode MPLS.

Figure1 :Topologie du réseau pour l’exemple de configuration

R1 Router

Router>enable Moves to privileged mode


Router#configure terminal Moves to global configuration mode
Router(config)#hostname R1 Assigns hostname to router
R1(config)#ip cef Enables CEF on device (enabled by default)
R1(config)#mpls ip Enables MPLS globally on device (enabled by
default)
R1(config)#interface loopback 0 Moves to interface configuration mode
R1(config-if)#ip address 172.16.1.1 Assigns IP address and netmask
255.255.255.0
R1(config-if)#interface fastethernet Moves to interface configuration mode
0/0
R1(config-if)#ip address 172.16.10.1 Assigns IP address and netmask
255.255.255.0
R1(config-if)#mpls ip Enables MPLS on this interface
R1(config-if)#mpls mtu 1508 Changes the maximum size of the packet
allowed on this interface to 1508 bytes
R1(config-if)#no shutdown Activates interface
R1(config-if)#exit Returns to global configuration mode
R1(config)#router eigrp 1 Enables the EIGRP routing process for AS 1
R1(config-router)#network 172.16.0.0 Specifies which network to advertise in EIGRP
R1(config-router)#no auto-summary Turns off the auto-summarization feature
R1(config-router)#exit Returns to global configuration mode
R1(config)#exit Returns to privileged mode
R1#copy running-config startup- Saves configuration in NVRAM
config
R2 Router

Router>enable Moves to privileged mode


Router#configure terminal Moves to global configuration mode
Router(config)#hostname R2 Assigns hostname to router
R2(config)#ip cef Enables CEF on device (enabled by default)
R2(config)#mpls ip Enables MPLS globally on device (enabled by
default)
R2(config)#interface loopback 0 Moves to interface configuration mode
R2(config-if)#ip address 172.16.2.1 Assigns IP address and netmask
255.255.255.0
R2(config-if)#interface fastethernet Moves to interface configuration mode
0/0
R2(config-if)#ip address 172.16.10.2 Assigns IP address and netmask
255.255.255.0
R2(config-if)#mpls ip Enables MPLS on this interface
R2(config-if)#mpls mtu 1508 Changes the maximum size of the packet
allowed on this interface to 1508 bytes
R2(config-if)#no shutdown Activates interface
R2(config-if)#interface serial 0/0/0 Moves to interface configuration mode
R2(config-if)#ip address 172.16.20.5 Assigns IP address and netmask
255.255.255.252
R2(config-if)#mpls ip Enables MPLS on this interface
R2(config-if)#clock rate 64000 Enables clock rate for this interface
R2(config-if)#no shutdown Activates interface
R2(config-if)#exit Returns to global configuration mode
R2(config)#router eigrp 1 Enables the EIGRP routing process for AS 1
R2(config-router)#network 172.16.0.0 Specifies which network to advertise in
EIGRP
R2(config-router)#no auto-summary Turns off the auto-summarization feature
R2(config-router)#exit Returns to global configuration mode
R2(config)#exit Returns to privileged mode
R2#copy running-config startup-config Saves configuration in NVRAM
R3 Router

Router>enable Moves to privileged mode


Router#configure terminal Moves to global configuration mode
Router(config)#hostname R3 Assigns hostname to router
R3(config)#ip cef Enables CEF on device (enabled by
default)
R3(config)#mpls ip Enables MPLS globally on device
(enabled by default)
R3(config)#interface loopback 0 Moves to interface configuration mode
R3(config-if)#ip address 172.16.3.1 Assigns IP address and netmask
255.255.255.0
R3(config-if)#interface serial 0/0/0 Moves to interface configuration mode
R3(config-if)#ip address 172.16.20.6 Assigns IP address and netmask
255.255.255.252
R3(config-if)#mpls ip Enables MPLS on this interface
R3(config-if)#no shutdown Activates interface
R3(config-if)#exit Returns to global configuration mode
R3(config)#router eigrp 1 Enables the EIGRP routing process for
AS 1
R3(config-router)#network 172.16.0.0 Specifies which network to advertise in
EIGRP
R3(config-router)#no auto-summary Turns off the auto-summarization feature
R3(config-router)#exit Returns to global configuration mode
R3(config)#exit Returns to privileged mode
R3#copy running-config startup-config Saves configuration in NVRAM