Vous êtes sur la page 1sur 5

El náufrago satisfecho” ofrece hamburguesas sencillas, dobles y triples, las cuales

tienen un costo de $20.00, $25.00 y $28.00 respectivamente. La empresa acepta tarjetas de crédito con un cargo de 5 % sobre la compra. Suponiendo que los clientes adquieren sólo un tipo de hamburguesa, realice un algoritmo para determinar cuánto debe pagar una persona por N hamburguesas. Represéntelo mediante diagrama de flujo, pseudocódigo.

El náufrago satisfecho” ofrece hamburguesas sencillas, dobles y triples, las cuales tienen un costo de $20.00,

El consultorio del Dr. Lorenzo T. Mata Lozano tiene como política cobrar la consulta

con base en el número de cita, de la siguiente forma: • Las tres primeras citas a $200.00 c/u. • Las siguientes dos citas a $150.00 c/u. • Las tres siguientes citas a $100.00 c/u. •

Las restantes a $50.00 c/u, mientras dure el tratamiento. Se requiere un algoritmo para determinar:

  • a) Cuánto pagará el paciente por la cita.

  • b) El monto de lo que ha pagado el paciente por el tratamiento. Para la solución de este

problema se requiere saber qué número de cita se efectuará, con el cual se podrá determinar el costo que tendrá la consulta y cuánto se ha gastado en el tratamiento. Con este análisis se puede determinar que las variables que se van a utilizar son las que se muestran en la tabla

El náufrago satisfecho” ofrece hamburguesas sencillas, dobles y triples, las cuales tienen un costo de $20.00,

Se requiere un algoritmo para obtener la edad promedio de un grupo de N alumnos. Realice el diagrama de flujo, el pseudocódigo y el diagrama N/S para representarlo, utilizando los tres tipos de estructuras de ciclo. La tabla muestra las variables que se van a utilizar para la solución del problema, sin importar qué estructura de ciclo se utilice; por consiguiente, es la misma para los tres tipos de ciclo para los que se dará la solución.

Se requiere un algoritmo para obtener la edad promedio de un grupo de N alumnos. Realice

Para

Proceso promedio definir c,ed,su,nu como entero definir pr como real escribir "Ingrese el numero de alumnos " leer nu Para c<-1 Hasta nu Con Paso 1 Hacer escribir "ingrese edad" leer ed su <- su + ed

ed<-0

Se requiere un algoritmo para obtener la edad promedio de un grupo de N alumnos. Realice

Fin Para pr<-su/nu Escribir " el promedio de las estaturas es:" escribir pr FinProceso

Mientras

Proceso mientr definir c,ed,su,nu como entero definir pr como real escribir "Ingrese el numero de alumnos " leer nu c<-nu Mientras c>0 Hacer escribir "ingrese edad" leer ed su <- su + ed

ed<-0

c<-c-1

Fin Mientras pr<-su/nu Escribir " el promedio de las estaturas es:" escribir pr FinProceso

Repetir

Proceso sin_titulo definir c,ed,su,nu como entero definir pr como real escribir "Ingrese el numero de alumnos "

Mientras Proceso mientr definir c,ed,su,nu como entero definir pr como real escribir "Ingrese el numero de

leer nu

c<-1

Repetir

escribir "ingrese edad" leer ed su <- su + ed

ed<-0

c<-c+1

Hasta Que c>nu pr<-su/nu Escribir " el promedio de las estaturas es:" escribir pr FinProceso

leer nu c<-1 Repetir escribir "ingrese edad" leer ed su <- su + ed ed<-0 c<-c+1

3. Se requiere un algoritmo para obtener la estatura promedio de un grupo de personas, cuyo número de miembros se desconoce, el ciclo debe efectuarse siempre y cuando se tenga una estatura registrada. Realice el diagrama de flujo, el pseudocódigo para representarlo, utilizando el ciclo apropiado. Variables utilizadas para obtener la estatura promedio de un número Desconocido de personas se muestra en la siguiente tabla

leer nu c<-1 Repetir escribir "ingrese edad" leer ed su <- su + ed ed<-0 c<-c+1

Proceso promedio

definir c,n como entero definir est,su,pr como real escribir "Ingrese el numero de personas las cuales va ingresar su estatura" leer c Para n<-1 Hasta c Con Paso 1 Hacer escribir "ingrese estatura" leer est su <- su + est

est<-0

Fin Para pr<-su/c Escribir " el promedio de las estaturas es:" escribir pr FinProceso

definir c,n como entero definir est,su,pr como real escribir "Ingrese el numero de personas las cuales